Device(config)# ip explicit-path name foo
Device(config-ip-expl-path)# index 10 next-address 10.1.1.1 node address
Device(config-ip-expl-path)# index 20 next-address 10.12.12.2 link address
Note
IP アンナンバード インターフェイスを使用する場合、ネクスト ホップ アドレスを明示的パスのインデックスとして指定することはできません。これは、ノード アドレスまたはラベルである必要があります。
明示的パスは、セグメントルーティング SID として指定することもできます。
Device(config)# ip explicit-path name foo
Device(config-ip-expl-path)# index 10 next-label 20
インターフェイスのアフィニティの設定
インターフェイスでアフィニティを設定するには、次の手順を実行します。
interface GigabitEthernet2
ip address 192.168.2.1 255.255.255.0
ip router isis 1
negotiation auto
mpls traffic-eng tunnels
mpls traffic-eng attribute-flags 0x1
isis network point-to-point
ip rsvp bandwidth
使用例:セグメント ルーティング トラフィック エンジニアリングの基本設定
SR-TE の構成を理解するには、次のトポロジを検討してください。
ヘッドエンド ルータで設定するには、R1 で次を実行します。
!
mpls traffic-eng tunnels
!
segment-routing mpls
connected-prefix-sid-map
address-family ipv4
10.1.1.1/32 index 111 range 1
exit-address-family
!
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family
!
interface Loopback1
ip address 10.1.1.1 255.255.255.255
ip router isis 1
!
int gig0/0
ip address 10.11.11.1 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
isis network point-to-point
!
router isis 1
net 49.0001.0010.0100.1001.00
is-type level-1
metric-style wide
segment-routing mpls
segment-routing prefix-sid-map advertise-local
mpls traffic-eng router-id Loopback1
mpls traffic-eng level-1
!
end