RIP Commands

address-family ipv4 vrf

To enable Routing Information Protocol (RIP) under a Virtual Routing and Forwarding (VRF), use the address-family ipv4 vrf command in router configuration mode. To remove the address family from the RIP configuration, use the no form of this command.

address-family ipv4 [ unicast | | vrf vrf-name ]

no address-family ipv4 [ unicast | | vrf vrf-name ]

Syntax Description

ipv4

Selects the IPv4 protocol address family.

unicast

(Optional) Specifies the unicast address family.

vrf vrf-name

(Optional) Specifies the name of the VRF. This keyword/argument pair is required for RIP configurations.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE address-family ipv4 command.

The following example shows how to configure an IPv4 address family session for a VRF named 100:


  vrf definition 100
    !
    rd 1:1
    address-family ipv4
     exit address-family
    !
  router rip
    address-family ipv4 vrf 100

address-family ipv6

To enter address family configuration mode for configuring routing sessions, such as Routing Information Protocol (RIP), that use standard IPv6 address prefixes, use the address-family ipv6 command in router configuration mode. To disable address family configuration mode, use the no form of this command.

address-family ipv6 vrf vrf-name

no address-family ipv6 vrf vrf-name

Syntax Description

vrf

Specifies VPN routing and forwarding (VRF) instance tables.

vrf-name

A specific VRF table for an IPv6 address.

Command Default

IPv6 address prefixes are not enabled.

Command Modes

Router configuration (config-rtr)

Command History

Release Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE address-family ipv6 command.

The following example shows how to place the router in address family configuration mode:

Device(config)# ipv6 router rip sdwan
Device(config-rtr)# address-family ipv6 vrf 1
Device(config-ipv6-router-af)# no address-family
Device(config-rtr)# 

auto-summary (RIP)

To restore the default behavior of automatic summarization of subnet routes into network-level routes, use the auto-summary command in router configuration mode. To disable this function and send subprefix routing information across classful network boundaries, use the no form of this command.

auto-summary

no auto-summary

Syntax Description

This command has no arguments or keywords.

Command Default

When auto-summary is enabled, the software summarizes subprefixes to the classful network boundary when crossing classful network boundaries.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE auto-summary (RIP) command.

The following example show how to configure auto summary, where network numbers are not summarized automatically:


router rip
!
  version 2    
  no auto-summary
!

default-information originate (RIP)

To generate a default route into Routing Information Protocol (RIP), use the default-information originate command in router configuration mode. To disable this feature, use the no form of this command.

default-information originate [ on-passive | | route-map map-name ]

no default-information originate

Syntax Description

on-passive

(Optional) Sends default routes only on RIP-passive interfaces.

route-map map-name

(Optional) Specifies the routing process that is generating the default route if the route map is satisfied.

Command Default

No default routes are generated into RIP.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE default-information originate (RIP) command.

The following example shows how to configure a default originate route (0.0.0.0/0) over a certain interface when 172.17.0.0/16 is present. In this example a route map condition is applied:


router rip 
 version 2
 network 172.17.0.0
 default-information originate route-map condition
!
route-map condition permit 10
 match ip address 10
 set interface s1/0
!
access-list 10 permit 172.17.0.0 0.0.255.255
!

default-metric (RIP)

To set default metric values for Routing Information Protocol (RIP), use the default-metric command in router configuration mode. To return to the default state, use the no form of this command.

default-metric number-value

no default-metric [number-value]

Syntax Description

number-value

Specifies default metric value.

Command Default

Default-metric is built-in, automatic metric translations, as appropriate, for each routing protocol.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE default-metric (RIP) command.

The following example shows how to configure a router in autonomous system 109 using both the RIP and Open Shortest Path First (OSPF) routing protocols. The example shows OSPF-derived routes advertisements using RIP and how to assign the OSPF-derived routes a RIP metric of 10:


router rip
!
  default-metric 10
  redistribute ospf 109
!

distance (IP)

To define an administrative distance for routes that are inserted into a routing table, use the distance command in router configuration mode. To return the administrative distance to its default distance definition, use the no form of this command.

distance distance ip-address wildcard-mask [ ip-standard-acl | access-list-name ]

no distance distance ip-address wildcard-mask [ ip-standard-acl | access-list-name ]

Syntax Description

distance

Administrative distance. Valid value is an integer from 10 to 255. (The values 0 to 9 are reserved for internal use. Routes with a distance value of 255 are not installed in the routing table.)

ip-address

IP address in four-part, dotted decimal notation. The IP address or the network address from where routes are learned.

wildcard-mask

Wildcard mask in four-part, dotted decimal notation. A bit set to 1 in the wildcard-mask argument instructs the software to ignore the corresponding bit in the address value.

ip -standard-acl

(Optional) Standard IP access list (ACL) number to be applied to incoming routing updates.

access-list-name

(Optional) Named access list to be applied to incoming routing updates.

Command Default

Default administrative RIP distance is 120.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE distance (ip) command.

In the following example, the router rip global configuration command sets up Routing Information Protocol (RIP) routing. The network router configuration command specify RIP routing on 192.168.7.0 and 172.16.0.0 networks. The first distance command sets the administrative distance to 90 for all routers on the Class C network 192.168.7.0. The second distance command sets the administrative distance to 120 for the router with the address 172.16.0.0.


config-transaction
!
  router rip
!
    network 192.168.7.0
    network 172.16.0.0
    distance 90 192.168.7.0 0.0.255.255
    distance 120 172.16.0.0 0.0.255.255
!
Table 1. Related Commands

Commands

Description

distance(IPv6)

Configures an administrative distance for IS-IS, RIP, or OSPF IPv6 routes inserted into the IPv6 routing table.

distance(ISO CLNS)

Configures the administrative distance for CLNS routes learned.

distancebgp

Allows the use of external, internal, and local administrative distances that could be a better route to a node.

distancebgp(IPv6)

Allows the use of external, internal, and local administrative distances that could be a better route than other external, internal, or local routes to a node.

distanceeigrp

Allows the use of two administrative distances--internal and external--that could be a better route to a node.

distanceospf

Defines OSPF route administrative distances based on route type.

showipprotocols

Displays the parameters and current state of the active routing protocol process.

distribute-list (RIP)

To filter the networks received in updates, to suppress networks from being advertised in updates, or to apply a prefix list to Routing Information Protocol (RIP) routing updates that are received or sent on an interface, use the distribute-list command in router configuration mode or address family configuration mode. To remove the prefix list, or to not filter updates, use the no form of this command.

distribute-list [ acl-number | expanded-acl-number | acl-name | gateway prefix-list-name | in | out | prefix listname ]

no distribute-list [ acl-number | expanded-acl-number | acl-name | gateway prefix-list-name | in | out | prefix listname ]

Syntax Description

acl-number

IP access list number. The acl-number argument defines which networks are to be received and which are to be suppressed in routing updates.

Range is 1 to 199.

expanded-acl-number

IP-expanded access list number.

Range is 1300 to 2699.

acl-name

IP access list name. The access-name argument defines which networks are to be received and which are to be suppressed in routing updates.

gateway

Filters incoming address updates based on a gateway.

prefix-list-name

IP prefix list name. This argument defines which routes from specified IP prefixes in the routing table are to be received and which are to be suppressed in routing updates.

in

Applies the prefix list to incoming routing updates on the specified interface.

out

Applies the prefix list to outgoing routing updates on the specified interface.

interface-type

(Optional) Specified interface type. For supported interface types, use the question mark (?) online help function.

interface-number

(Optional) Specified interface number.

prefix

Filters prefixes in routing address updates.

listname

Name of a prefix list. The list defines which IPv6 RIP networks are to be accepted in incoming routing updates and which networks are to be advertised in outgoing routing updates after matching the network prefix with the prefixes in the list.

Command Default

Networks that are received in updates are not filtered.

Command Modes

Router configuration (config-router)

Address family configuration (config-router-af)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE distribute-list prefix-list command.

The following example shows how to configure the distribute list prefix, which applies the prefix name prefix-list-1 to the Routing Information Protocol (RIP) routing updates that are received on GigabitEthernet interface 1/0/1:


router rip
!  
    distribute-list prefix prefix-list-1 in GigabitEthernet 1/0/1

distribute-list prefix-list (IPv6 RIP)

To apply a prefix list to IPv6 Routing Information Protocol (RIP) routing updates that are received or sent on an interface, use the distribute-list prefix-list command in router configuration mode. To remove the prefix list, use the no form of this command.

distribute-list prefix-list listname { in | out }

no distribute-list prefix-list listname

Syntax Description

listname

Name of a prefix list. The list defines which IPv6 RIP networks are to be accepted in incoming routing updates and which networks are to be advertised in outgoing routing updates, based upon matching the network prefix to the prefixes in the list.

in

Applies the prefix list to IPv6 RIP incoming routing updates on the specified interface.

out

Applies the prefix list to IPv6 RIP outgoing routing updates on the specified interface.

Command Default

Prefix lists are not applied to IPv6 RIP routing updates.

Command Modes

Router configuration (config-rtr)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

If no interface is specified, the prefix list is applied to all the interfaces.

For usage guidelines, see the Cisco IOS XE distribute-list prefix-list command.

The following example shows how to apply the prefix list named cisco to IPv6 RIP routing updates that are received on GigabitEthernet interface 0/0/0:


Device(config)# ipv6 router rip sdwan
Device(config-rtr)# distribute-list prefix-list cisco in GigabitEthernet0/0/0

input-queue

To define the number of received, but unprocessed Routing Information Protocol (RIP) update packets contained in the RIP input queue, use the input-queue command in router configuration mode. To remove the configured depth and restore the default depth, use the no form of this command.

input-queue depth

no input-queue

Syntax Description

depth

Numerical value associated with the maximum number of packets in a RIP input queue. The larger the numerical value, the larger the depth of the queue. The range is from 0 to 1024. The default is 150.

Command Default

Default depth value is 150.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE input-queue command.

The following example shows how to set the depth of a RIP input queue to 100:


router rip
!
  input-queue 100  
!

ip rip advertise

To configure the interval at which Routing Information Protocol (RIP) updates are advertised from a specific RIP-enabled interface, use the ip rip advertise command in interface configuration mode. To remove the configured interval in which RIP updates are advertised from a specific RIP-enabled interface, use the no form of this command.

ip rip advertise interval

no ip rip advertise

Syntax Description

interval

Periodic advertisement interval, in seconds, at which RIP updates are sent from a specific RIP-enabled interface. The range is from 0 to 429466. The default is 30.

Command Default

RIP updates are advertised every 30 seconds, which is the default global periodic interval for a Cisco device.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ip rip advertise command.

The following example shows how to configure the periodic advertisement interval on an interface:


config-transaction
  interface GigabitEthernet 1/0/1
!
    ip rip advertise 5

ip rip receive version

To specify the Routing Information Protocol (RIP) version that will be received on an interface, use the ip rip receive version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip receive version [1] [2]

no ip rip receive version

Syntax Description

1

(Optional) Accepts only RIP version 1 packets on the interface.

2

(Optional) Accepts only RIP version 2 packets on the interface.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ip rip receive version command.

The following example shows how to configure an interface to receive both RIP version 1 and version 2 packets:


config-transaction
  interface GigabitEthernet 1/0/1
!
   ip rip receive version 1 2
!

The following example shows how to configure an interface to receive only RIP version 1 packets:


config-transaction
  interface GigabitEthernet 1/0/1
!
   ip rip receive version 1
!

ip rip send version

To specify the Routing Information Protocol (RIP) version that will be sent on an interface, use the ip rip send version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip send version [1] [2]

no ip rip send version

Syntax Description

1

(Optional) Sends only RIP version 1 packets from the interface.

2

(Optional) Sends only RIP version 2 packets from the interface.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ip rip send version command.

The following example shows how to configure an interface to send both RIP version 1 and version 2 packets from the interface:


config-transaction
  interface GigabitEthernet 1/0/1
!
   ip rip send version 1 2
!

The following example shows how to configure an interface to send only RIP version 2 packets from the interface:


config-transaction
  interface GigabitEthernet 1/0/1
!
   ip rip send version 2
!

ipv6 prefix-list

To create an entry in an IPv6 prefix list, use the ipv6 prefix-list command in global configuration mode. To delete the entry, use the no form of this command.

ipv6 prefix-list list-name [seq seq-number] { deny ipv6-prefix (IP/length) | permit ipv6-prefix (IP/length) | description text} [ge ge-value] [le le-value]

no ipv6 prefix-list list-name

Syntax Description

list-name

Name of the prefix list.

  • Cannot be the same name as an existing access list.

  • Cannot be detail or summary because these are keywords in the show ipv6 prefix-list command.

seq seq-number

(Optional) Sequence number of the prefix list entry being configured.

deny

Denies networks that don't match the condition.

permit

Permits networks that match the condition.

ipv6-prefix

The IPv6 network that is assigned to the specified prefix list.

This argument must be in the form documented in RFC 2373, where the address is specified in hexadecimal format, using 16-bit values between colons.

(IP/length)

The length of the IPv6 prefix. A decimal value that indicates how many of the high-order contiguous bits of the address comprise the prefix (the network portion of the address). A slash mark must precede the decimal value.

description text

A description of the prefix list that can be up to 80 characters in length.

ge ge-value

(Optional) Specifies a prefix length greater than or equal to the ipv6-prefix / prefix-length arguments. It is the lowest value of a range of the length (from portion of the length range).

le le-value

(Optional) Specifies a prefix length less than or equal to the ipv6-prefix / prefix-length arguments. It is the highest value of a range of the length (to portion of the length range).

Command Default

No prefix list is created.

Command Modes

Global configuration (config)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ipv6 prefix-list command.

The following example shows how to deny all routes with a prefix of ::/0:

Device(config)# ipv6 prefix-list abc deny ::/0

The following example shows how to permit the prefix 2002::/16:

Device(config)# ipv6 prefix-list abc permit 2002::/16

The following example shows how to specify a group of prefixes to accept any prefix—from prefix 5F00::/48 up to and including prefix 5F00::/64:

Device(config)# ipv6 prefix-list abc permit 5F00::/48 le 64

The following example shows how to deny prefix lengths greater than 64 bits in routes that have the prefix 2001:0DB8::/64:

Device(config)# ipv6 prefix-list abc permit 2001:0DB8::/64 le 128

The following example shows how to permit mask lengths from 32 bits to 64 bits in all address spaces:

Device(config)# ipv6 prefix-list abc permit ::/0 ge 32 le 64

The following example shows how to deny mask lengths greater than 32 bits in all address spaces:

Device(config)# ipv6 prefix-list abc deny ::/0 ge 32

The following example shows how to deny all the routes with a prefix of 2002::/128:

Device(config)# ipv6 prefix-list abc deny 2002::/128

The following example shows how to permit all the routes with a prefix of ::/0:

Device(config)# ipv6 prefix-list abc permit ::/0
 

ipv6 rip default-information

To originate a default IPv6 route into Routing Information Protocol (RIP), use the ipv6 rip default-information command in interface configuration mode. To remove the default IPv6 RIP route, use the no form of this command.

ipv6 rip ripng-instance default-information { only | originate } [ metric metric-value ]

no ipv6 rip ripng-instance default-information

Syntax Description

ripng-instance

Name of the IPv6 RIP routing process.

The only possible value is sdwan .

only

Advertises the IPv6 default route (::/0) only. Suppresses the advertisement of all other routes.

originate

Advertises the IPv6 default route (::/0). The advertisement of other routes is unaffected.

metric metric-value

(Optional) Associates a metric with the default route. The metric-value range is from 1 through 15.

Command Default

Metric value is 1.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ipv6 rip default-information command.

The following example shows how a default IPv6 route distributed into RIPng on GigabitEthernet interface 0/0 and advertises only the default route in router updates that are sent on the interface:

Device(config)# interface GigabitEthernet 0/0
Device(config-if)# ipv6 rip sdwan default-information only

The following example shows how a default IPv6 route is distributed into RIPng on GigabitEthernet interface 0/0 and advertises the default route with all other routes in router updates that are sent on the interface:

Device(config)# interface GigabitEthernet 0/0
Device(config-if)# ipv6 rip sdwan default-information originate

ipv6 rip enable

To enable an IPv6 Routing Information Protocol (RIP) routing process on an interface, use the ipv6 rip enable command in interface configuration mode. To disable an IPv6 RIP routing process on an interface, use the no form of this command.

ipv6 rip ripng-instance enable

no ipv6 rip ripng-instance

Syntax Description

ripng-instance

Name of the IPv6 RIP routing process.

The only possible value is sdwan .

Command Default

An IPv6 RIP routing process is not defined.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ipv6 rip enable command.

The following example shows how to enable the IPv6 RIP routing process named sdwan on GigabitEthernet interface 0/1/0:

Device(config)# interface GigabitEthernet 0/1/0
Device(config-if)# ipv6 rip sdwan enable

ipv6 rip metric-offset

To set the IPv6 Routing Information Protocol (RIP) metric offset for an interface, use the ipv6 rip metric-offset command in interface configuration mode. To return the metric to its default value, use the no form of this command.

ipv6 rip ripng-instance metric-offset offset value

no ipv6 rip ripng-instance metric-offset

Syntax Description

ripng-instance

Name of the IPv6 RIP routing process.

The only possible value is sdwan .

offset value

Specifies the offset value added to the metric of an IPv6 RIP route received in a report message.

Range is from 1 to 16.

Command Default

The default metric offset value is 1.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ipv6 rip metric-offset command.

The following example shows how to configure a metric offset increment of 10 for the RIP routing process named sdwan on GigabitEthernet interface 0/0:


Device(config)# interface GigabitEthernet 0/0
Device(config-if)# ipv6 rip sdwan metric-offset 10

ipv6 rip summary-address

To configure IPv6 Routing Information Protocol (RIP) to advertise summarized IPv6 addresses on an interface and to specify the IPv6 prefix that identifies the routes to be summarized, use the ipv6 rip summary-address command in interface configuration mode. To stop advertising the summarized IPv6 addresses, use the no form of this command.

ipv6 rip ripng-instance summary-address ipv6-prefix/prefix-length

no ipv6 rip ripng-instance summary-address

Syntax Description

ripng-instance

Name of the IPv6 RIP routing process.

The only possible value is sdwan .

ipv6-prefix

Specifies an IPv6 network number as the summary address.

This argument must be in the format that is documented in RFC 2373, where the address is specified in hexadecimal using 16-bit values between colons.

/ prefix-length

The length of the IPv6 prefix. A decimal value that indicates how many of the high-order contiguous bits of the address comprise the prefix (the network portion of the address). A slash mark must precede the decimal value.

Command Default

No default behavior or values.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ipv6 rip summary-address command.

The following example shows how the IPv6 address 2001:0DB8:0:1:260:3EFF:FE11:6770 that is assigned to GigabitEthernet interface 0/0 with an IPv6 prefix length of 64 bits is summarized as IPv6 prefix 2001:0DB8::/35 for the IPv6 RIP routing process named sdwan:


Device(config)# interface GigabitEthernet 0/0
Device(config-if)# ipv6 address 2001:0DB8:0:1:260:3EFF:FE11:6770 /64
Device(config-if)# ipv6 rip sdwan summary-address 2001:90::1/32

ipv6 rip vrf-mode enable

To enable VRF-aware support for IPv6 Routing Information Protocol (RIP), use the ipv6 rip vrf-mode enable command in global configuration mode. To disable VRF-aware support for IPv6 RIP, use the no form of this command.

ipv6 rip vrf-mode enable

no ipv6 rip vrf-mode enable

Syntax Description

This command has no arguments or keywords.

Command Default

VRF-aware support is not enabled in IPv6 RIP.

Command Modes

Global configuration (config)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

When VRF-aware support is enabled in IPv6 RIP, you can configure only one RIP instance at a given time. More than one RIP instance is not allowed.

For usage guidelines, see the Cisco IOS XE ipv6 rip vrf-mode enable command.

The following example shows how to enable VRF-aware support for IPv6 RIP routing:

Device(config)# ipv6 rip vrf-mode enable
Device(config)# ipv6 router rip sdwan
Device(config-rtr)# address-family ipv6 vrf 1

ipv6 router rip

To configure an IPv6 Routing Information Protocol (RIP) routing process, use the ipv6 router rip command in global configuration mode. To remove a routing process, use the no form of this command.

ipv6 router rip ripng-instance

no ipv6 router rip ripng-instance

Syntax Description

ripng-instance

Name of the RIPng instance that describes the routing process.

The only possible value is sdwan .

Command Default

No IPv6 RIP routing process is defined.

Command Modes

Global configuration (config)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ipv6 router rip command.

The following example shows how to configure the IPv6 RIP routing process named sdwan and place the router in router configuration mode for the IPv6 RIP routing process:

Device(config)# ipv6 router rip sdwan
Device(config-rtr)# address-family ipv6 vrf 1

ipv6 unicast-routing

To enable the forwarding of IPv6 unicast datagrams, use the ipv6 unicast-routing command in global configuration mode. To disable the forwarding of IPv6 unicast datagrams, use the no form of this command.

ipv6 unicast-routing

no ipv6 unicast-routing

Syntax Description

This command has no arguments or keywords.

Command Default

IPv6 unicast routing is disabled.

Command Modes

Global configuration (config)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE ipv6 unicast-routing command.

The following example shows how to enable the forwarding of IPv6 unicast datagrams:

Device(config)# ipv6 unicast-routing

maximum-paths

To control the maximum number of parallel routes that an IP routing protocol can support, use the maximum-paths command in router address family topology configuration mode or router configuration mode. To restore the default number of parallel routes, use the no form of this command.

maximum-paths number-of-paths

no maximum-paths number-of-paths

Syntax Description

number-of-paths

Maximum number of parallel routes that an IP routing protocol installs in a routing table. Valid values vary by Cisco IOS release and platform. For more information on valid values, use the question mark (? ) online help function.

The number-of-paths argument is an integer from 1 to 64. The default for RIP is 4 paths.

Command Default

The default number of parallel routes vary by Cisco IOS release and platform.

Command Modes

Router configuration (config-router)

Router address family topology configuration (config-router-af-topology)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE maximum-paths command.

The following example shows how to configure a maximum of 16 paths to be allowed to a destination in a RIP routing process:


config-transaction
!
  router rip
!
    maximum-paths 16
!

neighbor (RIP)

To define a neighboring router for exchanging routing information, use the neighbor command in router configuration mode. To remove a neighboring router entry, use the no form of this command.

neighbor ip-address [bfd]

no neighbor ip-address [bfd]

Syntax Description

ip-address

IP address of a peer router with which the routing information is exchanged.

bfd

(Optional) Sets the baseline Bidirectional Forwarding Detection (BFD) session parameters on an interface.

Command Default

No neighboring routers are defined.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE neighbor (RIP) command.

The following example shows how RIP updates are sent to all the interfaces on network 10.0.0.0 except GigabitEthernet interface 1/0/1. However, in this case, a neighbor router configuration command is included. The neighbor command permits the sending of routing updates to specific neighbors. One copy of the routing update is generated for each neighbor.


config-transaction
!
  router rip
!
    network 10.0.0.0
    passive-interface GigabitEthernet 1/0/1
    neighbor 10.108.20.4
!

The following example shows how to enable BFD for RIP neighbors:


config-transaction
!
  router rip
!
    neighbor 10.0.0.1 bfd
!

network (RIP)

To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. To remove an entry, use the no form of this command.

network ip-address

no network ip-address

Syntax Description

ip-address

IP address of the network of directly connected networks.

Command Default

No networks are specified.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

Only classful IP network addresses are supported for network configuration. For usage guidelines, see the Cisco IOS XE network (RIP) command.

The following example shows how to configure a network that defines RIP as the routing protocol to be used on all the interfaces connected to networks 10.0.0.0 and 192.168.7.0:


config-transaction
!
  router rip
!
    network 10.0.0.0
    network 192.168.7.0
!

offset-list (RIP)

To add an offset to incoming and outgoing metric for routes learned through Routing Information Protocol (RIP), use the offset-list command in router configuration mode. To remove an offset list, use the no form of this command.

offset-list { access-list-number | expanded-access-list-number | access-list-name } { in offset | out offset } { interface-type interface-name }

no offset-list { access-list-number | expanded-access-list-number | access-list-name } { in offset | out offset } { interface-type interface-name }

Syntax Description

access-list-number

IP access list number. The access-list-number argument defines which networks are to be received and which are to be suppressed in routing updates.

Range is 1 to 199.

expanded-acl-number

IP-expanded access list number.

Range is 1300 to 2699.

access-list-name

Standard access list name to be applied.

in

Applies the access list to incoming metrics.

out

Applies the access list to outgoing metrics.

offset

Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken. Range is from 0 to 16.

interface-type

(Optional) Specified interface type. For supported interface types, use the question mark (?) online help function.

interface-number

(Optional) Specified interface number.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE offset-list (RIP) command.

The following example shows how a router applies an offset of 10 to the metric for routes matching access list 21:


config-transaction
!
  router rip
!
    offset-list 21 out 10
!

The following example shows how a router applies an offset of 10 to the routes learned from GigabitEthernet interface 1/0/1:


config-transaction
!
  router rip
!
   offset-list 21 in 10 GigabitEthernet 1/0/1
!

omp-route-tag

To enable automatic setting of the Routing Information Protocol version 2 (RIPv2)/Routing Information Protocol new generation (RIPng) route tag for the redistributed Overlay Management Protocol (OMP) routes, use the omp-route-tag command in router configuration mode or address family configuration mode. To disable this feature, use the no form of this command.

omp-route-tag

no omp-route-tag

Syntax Description

This command has no arguments or keywords.

Command Default

By default, omp-route-tag is enabled, and is not displayed in show running-config .

Command Modes

Router configuration (config-router)

Address family configuration (config-router-af)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

When a router is installed by another Cisco IOS XE Catalyst SD-WAN device, the admin distance is set to 252 so that OMP routes are preferred over redistributed OMP routes.

The omp-route-tag configuration is effective only on Cisco IOS XE Catalyst SD-WAN devices.

The following example shows how to enable automatic RIPv2 route tag for OMP routes in router configuration mode:


config-transaction
!
    router rip
!
      omp-route-tag
!

output-delay

To change the interpacket delay for the Routing Information Protocol (RIP) updates sent, use the output-delay command in router configuration mode. To remove the delay, use the no form of this command.

output-delay delay

no output-delay

Syntax Description

delay

Delay between packets in a multiple-packet RIP update, in milliseconds. The range is from 8 to 50. The default is 0.

Command Default

The default interpacket delay is 0 milliseconds.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE output-delay command.

The following example shows how to set the interpacket delay to 10 milliseconds:


config-transaction
!
  router rip
!
   output-delay 10
!

passive-interface

To disable the sending of routing updates on an interface, use the passive-interface command in router configuration mode. To re-enable the sending of routing updates, use the no form of this command.

passive-interface default [interface-name]

no passive-interface

Syntax Description

default

(Optional) Causes all the interfaces to become passive.

interface-name

(Optional) Interface name.

Command Default

Routing updates are sent on the interface.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE passive-interface command.

The following example shows how to configure an interface. RIP updates are sent to all the interfaces in the network 10.0.0.0 except GigabitEthernet interface 1/0/1:


config-transaction
!
  router rip
!
   network 10.0.0.0
   passive-interface GigabitEthernet 1/0/1
!

redistribute

To redistribute the specified routes into the Routing Information Protocol (RIP) routing process, use the redistribute command in the router configuration mode. To disable the configuration, use the no form of this command.

redistribute protocol [ metric Default-metric ] [ route-map map-tag ]

no redistribute protocol

Syntax Description

protocol

Protocol argument that can be one of these keywords—bgp, connected, eigrp, isis, omp, ospf, ospfv3, or static.

metric

Specifies the metric for redistributed routes.

Default-metric

Default metric value. Range is from 0 to 16.

route-map map-tag

Specifies the name of a route map that controls the redistribution.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

The following example shows how to configure a router to redistribute OMP routes into a RIP process:


router rip
!
  redistribute omp metric 15 route-map x

The following example shows how to redistribute the specified EIGRP process routes into an OSPF domain. The EIGRP-derived metric will be remapped to 100 and RIP routes to 200:


router ospf 109
 !
  redistribute eigrp 109 metric 100 subnets
  redistribute rip metric 200 subnets

The following example shows how to remove the connected metric 1000 subnets options from the redistribute connected metric 1000 subnets command and leave the redistribute connected command in the configuration:


router rip
  !  
  no redistribute connected metric 1000 subnets

The following example shows how to remove the metric 5 option from the redistribute static metric 5 command and leave the redistribute static command in the configuration:


router rip
  !
  no redistribute static metric 5

redistribute (IPv6)

To redistribute IPv6 routes from one routing domain into another routing domain, use the redistribute command in address family configuration or router configuration mode. To disable redistribution, use the no form of this command.

redistribute source-protocol [ metric metric-value ] [ route-map map-tag ]

no redistribute source-protocol [ metric metric-value ] [ route-map map-tag ]

Syntax Description

source-protocol

Source protocol from which routes are being redistributed. It can be one of the following keywords: application , bgp , eigrp , isis , omp , static , lisp , nd , connected , ospf , ospfv3 .

metric metric-value

(Optional) Carries a metric from one process to the other if no metric value is specified when redistributing from one OSPF process to another OSPF process on the same router. When redistributing other processes to an OSPF process, the default metric is 20 when no metric value is specified.

route-map

(Optional) Specifies the route map that should be checked to filter routes from the source protocol as and when they are imported to the current routing protocol. If the route-map keyword is not specified, all the routes are redistributed. If this keyword is specified, but no route map tags are listed, no routes is imported.

map-tag

(Optional) Identifier of a configured route map.

Command Default

Route redistribution is disabled.

Command Modes

Address family configuration (config-ipv6-router-af)

Router configuration (config-rtr)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.8.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE redistribute ipv6 command.

The following example shows how to redistribute IPv6 BGP routes into the IPv6 RIP routing process named cisco:

Device(config)# ipv6 router rip cisco
Device(config-rtr)# redistribute bgp 42

The following example shows how to redistribute RIP for IPv6 routes into the OSPF for the IPv6 routing process:

Device(config)# ipv6 router ospf 1
Device(config-rtr)# redistribute rip 1 metric 32

The following example shows how to redistribute OMP routes for the IPv6 routing process:

Device(config-rtr)# address-family ipv6 vrf 1                                         
Device(config-ipv6-router-af)# redistribute omp metric 10

router rip

To configure the Routing Information Protocol (RIP) routing process, use the router rip command in global configuration mode. To disable the RIP routing process, use the no form of this command.

router rip

no router rip

Syntax Description

This command has no arguments or keywords.

Command Default

No RIP routing process is defined.

Command Modes

Global configuration (config)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE router rip command.

The following example shows how to configure a RIP router, which begins the RIP routing process:


config-transaction
!
  router rip
!

timers basic (RIP)

To adjust the Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To reset the default timers, use the no form of this command.

timers basic update invalid holddown flush

no timers basic

Syntax Description

update

Rate, in seconds, at which updates are sent. This is the fundamental timing parameter of the routing protocol. The default is 30 seconds.

invalid

Interval of time, in seconds, after which a route is declared invalid; it should be at least three times the value of the update argument. A route becomes invalid when there is an absence of updates that refresh the route. The route then enters into a holddown state. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. The default is 180 seconds.

holddown

Interval, in seconds, during which routing information regarding better paths is suppressed. It should be at least three times the value of the update argument. A route enters into a holddown state when an update packet, which indicates that the route is unreachable is received. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. When holddown expires, routes advertised by other sources are accepted and the route is no longer inaccessible. The default is 180 seconds.

flush

Amount of time, in seconds, that must pass before the route is removed from the routing table; the interval specified should be greater than the value of the invalid argument. If it is less than this sum, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. The default is 240 seconds.

Command Default

No RIP network timers are adjusted.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE timers basic (RIP) command.

The following example sets updates to be broadcast every 5 seconds. If a router does not respond within 15 seconds, the router is declared as unusable. Further information is suppressed for an additional 15 seconds, after which the route is flushed from the routing table:


router rip
!  
  timers basic 5  15  15  30
!

Note


By setting a short update period, you run the risk of congesting slow-speed serial lines. A short update period can be a concern on faster-speed Ethernets and T1-rate serial lines. Also, if you have many routes in your updates, you can cause the routers to spend an excessive amount of time processing updates.


The following example shows how to adjust address family timers:


router rip
 version 2
 timers basic 5 10 15 20
 redistribute connected
 network 5.0.0.0
 default-metric 10
  no auto-summary
  !
  address-family ipv4 vrf 1
   timers basic 10 20 20 20
   redistribute connected
   network 10.0.0.0
   default-metric 5
   no auto-summary
   version 2
   exit-address-family
  !
  address-family ipv4 vrf 1
   timers basic 20 40 60 80
   redistribute connected
   network 20.0.0.0
   default-metric 2
   no auto-summary
   version 2
   exit-address-family
 !

traffic-share min

To configure traffic to use minimum-cost routes when there are multiple routes that have different-cost routes to the same destination network, use the traffic-share min command in router address family topology configuration mode or router configuration mode. To disable this function, use the no form of this command.

traffic-share min across-interfaces

no traffic-share min across-interfaces

Syntax Description

across-interfaces

Configures multiinterface load splitting on several interfaces with equal-cost paths.

Command Default

Traffic is configured to use minimum-cost paths.

Command Modes

Router configuration (config-router)

Router address family topology configuration (config-router-af-topology)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE traffic-share min command.

The following example shows multiinterface load splitting configuration on different interfaces with equal-cost paths:


router rip
!  
    traffic-share min across-interfaces
!

validate-update-source

To have the Cisco IOS software validate the source IP address of incoming routing updates for the Routing Information Protocol (RIP) routing protocols, use the validate-update-source command in router configuration mode. To disable this function, use the no form of this command.

validate-update-source

no validate-update-source

Syntax Description

This command has no arguments or keywords.

Command Default

The behavior of this command is enabled by default.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE validate-update-source command.

The following example configures a router to not perform validation checks on the source IP address of incoming RIP updates:


router rip
! 
  network 10.0.0.0
  no validate-update-source
!

version (RIP)

To specify a Routing Information Protocol (RIP) version used globally by the router, use the version command in router configuration mode. To restore the default value, use the no form of this command.

version { 1 | 2 }

no version

Syntax Description

1

Specifies RIP version 1.

2

Specifies RIP version 2.

Command Default

The software receives RIP version 1 and version 2 packets, but sends only version 1 packets.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

Cisco IOS XE Catalyst SD-WAN Release 17.7.1a

This command was introduced.

Usage Guidelines

For usage guidelines, see the Cisco IOS XE version command.

The following example shows how to configure version 2, which enables the software to send and receive RIP version 2 packets:


router rip
!
  version 2
!