このドキュメントでは、Cisco アグリゲーション サービス ルータ(ASR)1000 プラットフォームでオーバーレイ トランスポート仮想化(OTV)マルチキャスト モードを設定する方法について説明します。OTV により、物理的に異なるサイトにわたってレイヤ 2(L2)トポロジが拡張されます。これにより、デバイスはレイヤ 3(L3)プロバイダーにおいて L2 で通信できます。サイト 1 のデバイスは、デバイス自体がサイト 2 のデバイスと同じブロードキャスト ドメインにあると認識します。
次の項目に関する知識があることが推奨されます。
このドキュメント内の情報は、Cisco IOS® バージョン asr1000rp1-adventerprise.03.09.00.S.153-2.S.bin が搭載された ASR 1002 に基づくものです。
ASR 1000 に OTV 機能を実装するためには、システムが次の要件を満たしている必要があります。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、初期(デフォルト)設定の状態から起動しています。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的な影響について確実に理解しておく必要があります。
ここでは、OTV マルチキャスト モードの設定方法について説明します。
基本設定から開始します。ASR の内部インターフェイスは、dot1q トラフィックのサービス インスタンスに対して設定されます。OTV Join インターフェイスは、外部 WAN L3 インターフェイスです。
ASR-1
interface GigabitEthernet0/0/0
description OTV-WAN-Connection
mtu 9216
ip address 172.17.100.134 255.255.255.0
negotiation auto
cdp enable
ASR-2
interface GigabitEthernet0/0/0
description OTV-WAN-Connection
mtu 9216
ip address 172.16.64.84 255.255.255.0
negotiation auto
cdp enable
OTV が 42 バイトのヘッダーを追加するため、インターネット サービス プロバイダー(ISP)がサイト間で最小 MTU サイズを渡していることを確認する必要があります。この検証を行うには、DF ビットをセットした 1542 のパケット サイズを送信します。これにより ISP には、必要なペイロードと、OTV パケットをシミュレートするための do not fragment タグがパケットで渡されます。DF ビットを設定せずに ping を発行できない場合は、ルーティングに問題があります。DF ビットを設定せずに ping を発行できるが、DF ビットを設定すると ping を発行できない場合は、MTU に問題があります。いずれも成功した場合は、ご使用のサイトの ASR に OTV ユニキャスト モードを追加する準備が整いました。
ASR-1#ping 172.17.100.134 size 1542 df-bit
Type escape sequence to abort.
Sending 5, 1514-byte ICMP Echos to 172.17.100.134, timeout is 2 seconds:
Packet sent with the DF bit set
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
内部インターフェイスは、L2 dot1q タグ付きパケットのサービス インスタンスを使用して設定された L2 ポートです。内部サイト ブリッジ ドメインも作成します。この例では、タグなしVLAN1です。内部サイトブリッジドメインは、同じサイトにある複数のOTVデバイスの通信に使用されます。これにより、デバイス間の通信が可能になり、またどのデバイスがどのブリッジ ドメインの Authoritative Edge Device(AED)であるかが判定できます。
サービス インスタンスはオーバーレイを使用するブリッジ ドメインに設定する必要があります。
ASR-1
interface GigabitEthernet0/0/1
no ip address
negotiation auto
cdp enable
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
service instance 50 ethernet
encapsulation dot1q 100
bridge-domain 200
!
service instance 51 ethernet
encapsulation dot1q 101
bridge-domain 201
ASR-2
interface GigabitEthernet0/0/2
no ip address
negotiation auto
cdp enable
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
service instance 50 ethernet
encapsulation dot1q 100
bridge-domain 200
!
service instance 51 ethernet
encapsulation dot1q 101
bridge-domain 201
これは、いくつかのコマンドだけで OTV と Join /内部インターフェイスをセットアップできる基本構成です。
ローカル サイト ブリッジ ドメインを設定します。この例では、LAN 上の VLAN1 です。サイト識別子は、物理的な場所それぞれに固有です。この例では、物理的に独立している 2 つのリモートの場所が存在します。それに応じて、サイト 1 とサイト 2 が設定されます。マルチキャストを OTV の要件に従って設定する必要もあります。
ASR-1
Config t
otv site bridge-domain 1
otv site-identifier 0000.0000.0001
ip multicast-routing distributed
ip pim ssm default
interface GigabitEthernet0/0/0
ip pim passive
ip igmp version 3
ASR-2
Config t
otv site bridge-domain 1
otv site-identifier 0000.0000.0002
ip multicast-routing distributed
ip pim ssm default
interface GigabitEthernet0/0/0
ip pim passive
ip igmp version 3
それぞれにオーバーレイを作成します。オーバーレイを設定して、Join インターフェイスを適用し、コントロールとデータ グループをそれぞれの側に追加します。
拡張する 2 つのブリッジ ドメインを追加します。必要なのは 2 つの VLAN だけで、サイト ブリッジ ドメインは拡張しないことに注意してください。ブリッジドメイン200および201を呼び出すために、オーバーレイインターフェイス用に別のサービスインスタンスを構築します。dot1qタグ100および101をそれぞれ適用します。
ASR-1
Config t
interface Overlay1
no ip address
otv join-interface GigabitEthernet0/0/0
otv control-group 225.0.0.1 otv data-group 232.10.10.0/24
service instance 10 ethernet
encapsulation dot1q 100
bridge-domain 200
service instance 11 ethernet
encapsulation dot1q 101
bridge-domain 201
ASR-2
Config t
interface Overlay1
no ip address
otv join-interface GigabitEthernet0/0/0
otv control-group 225.0.0.1 otv data-group 232.10.10.0/24
service instance 10 ethernet
encapsulation dot1q 100
bridge-domain 200
service instance 11 ethernet
encapsulation dot1q 101
bridge-domain 201
この段階で、ASR / ASR OTV 間のマルチキャスト隣接関係が構築され、機能するようになります。ネイバーが検出されるため、ASR は拡張が必要な VLAN に対して AED 対応にする必要があります。
ASR-1#show otv
Overlay Interface Overlay1
VPN name : None
VPN ID : 2
State : UP
AED Capable : Yes
IPv4 control group : 225.0.0.1
Mcast data group range(s): 232.10.10.0/24
Join interface(s) : GigabitEthernet0/0/0
Join IPv4 address : 172.17.100.134
Tunnel interface(s) : Tunnel0
Encapsulation format : GRE/IPv4
Site Bridge-Domain : 1
Capability : Multicast-reachable
Is Adjacency Server : No
Adj Server Configured : No
Prim/Sec Adj Svr(s) : None
ASR-2#show otv
Overlay Interface Overlay1
VPN name : None
VPN ID : 2
State : UP
AED Capable : Yes
IPv4 control group : 225.0.0.1
Mcast data group range(s): 232.10.10.0/24
Join interface(s) : GigabitEthernet0/0/0
Join IPv4 address : 172.16.64.84
Tunnel interface(s) : Tunnel0
Encapsulation format : GRE/IPv4
Site Bridge-Domain : 1
Capability : Multicast-reachable
Is Adjacency Server : No
Adj Server Configured : No
Prim/Sec Adj Svr(s) : None
ここでは、設定が正常に機能しているかどうかを確認します。
この出力では、VLAN 100 と 101 が拡張されていることが示されています。ASR は AED であり、VLAN をマッピングする内部インターフェイスとサービス インスタンスが出力に表示されています。
ASR-1#show otv vlan
Key: SI - Service Instance
Overlay 1 VLAN Configuration Information
Inst VLAN Bridge-Domain Auth Site Interface(s)
0 100 200 yes Gi0/0/1:SI50
0 101 201 yes Gi0/0/1:SI51
Total VLAN(s): 2
Total Authoritative VLAN(s): 2
ASR-2#show otv vlan
Key: SI - Service Instance
Overlay 1 VLAN Configuration Information
Inst VLAN Bridge-Domain Auth Site Interface(s)
0 100 200 yes Gi0/0/2:SI50
0 101 201 yes Gi0/0/2:SI51
Total VLAN(s): 2
Total Authoritative VLAN(s): 2
検証するために、VLAN を拡張して、サイト間 ping を実行します。ホスト192.168.100.2はサイト1に、ホスト192.168.100.3はサイト2に配置されています。アドレス解決プロトコル(ARP)をローカルに構築し、OTVを介して反対側に構築すると、最初のいくつかのpingが失敗することが予想されます。
LAN-SW1#ping 192.168.100.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.3, timeout is 2 seconds:
...!!
Success rate is 40 percent (2/5), round-trip min/avg/max = 1/5/10 ms
LAN-SW1#ping 192.168.100.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/10 ms
LAN-SW1#ping 192.168.100.3 size 1500 df-bit
Type escape sequence to abort.
Sending 5, 1500-byte ICMP Echos to 192.168.100.3, timeout is 2 seconds:
Packet sent with the DF bit set
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/10 ms
MAC テーブルと OTV ルーティング テーブルがローカル デバイスで正しく構築されていることを確認するには、show otv route コマンドを使用してリモート デバイスの MAC アドレスを参照します。
LAN-SW1#show int vlan 100
Vlan100 is up, line protocol is up
Hardware is Ethernet SVI, address is 0c27.24cf.abd1 (bia 0c27.24cf.abd1)
Internet address is 192.168.100.2/24
LAN-SW2#show int vlan 100
Vlan100 is up, line protocol is up
Hardware is Ethernet SVI, address is b4e9.b0d3.6a51 (bia b4e9.b0d3.6a51)
Internet address is 192.168.100.3/24
ASR-1#show otv route vlan 100
Codes: BD - Bridge-Domain, AD - Admin-Distance,
SI - Service Instance, * - Backup Route
OTV Unicast MAC Routing Table for Overlay1
Inst VLAN BD MAC Address AD Owner Next Hops(s)
----------------------------------------------------------
0 100 200 0c27.24cf.abaf 40 BD Eng Gi0/0/1:SI50
0 100 200 0c27.24cf.abd1 40 BD Eng Gi0/0/1:SI50 <--- Local mac is
pointing to the physical interface
0 100 200 b4e9.b0d3.6a04 50 ISIS ASR-2
0 100 200 b4e9.b0d3.6a51 50 ISIS ASR-2 <--- Remote mac is
pointing across OTV to ASR-2
4 unicast routes displayed in Overlay1
----------------------------------------------------------
4 Total Unicast Routes Displayed
ASR-2#show otv route vlan 100
Codes: BD - Bridge-Domain, AD - Admin-Distance,
SI - Service Instance, * - Backup Route
OTV Unicast MAC Routing Table for Overlay1
Inst VLAN BD MAC Address AD Owner Next Hops(s)
----------------------------------------------------------
0 100 200 0c27.24cf.abaf 50 ISIS ASR-1
0 100 200 0c27.24cf.abd1 50 ISIS ASR-1 <--- Remote mac is
pointing across OTV to ASR-1
0 100 200 b4e9.b0d3.6a04 40 BD Eng Gi0/0/2:SI50
0 100 200 b4e9.b0d3.6a51 40 BD Eng Gi0/0/2:SI50 <--- Local mac is
pointing to the physical interface
4 unicast routes displayed in Overlay1
----------------------------------------------------------
4 Total Unicast Routes Displayed
出力内の OTV Does Not Form エラー メッセージは、ASR が AED 対応ではないことを示しています。これは、ASR が OTV 経由で VLAN を転送しないことを意味します。これには複数の原因が考えられますが、一般的には、サイト間で ASR が接続されていないことが原因です。L3 接続とブロックされている可能性のあるマルチキャスト トラフィックをチェックします。この状況で考えられる別の原因として、内部サイトのブリッジ ドメインが設定されていない場合があります。これは、サイト上で唯一の ASR かどうかが判断できないために、ASR が AED になれない状態です。
ASR-1#show otv
Overlay Interface Overlay1
VPN name : None
VPN ID : 2
State : UP
AED Capable : No, overlay DIS not elected <--- Not Forwarding
IPv4 control group : 225.0.0.1
Mcast data group range(s): 232.0.0.0/8
Join interface(s) : GigabitEthernet0/0/0
Join IPv4 address : 172.17.100.134
Tunnel interface(s) : Tunnel0
Encapsulation format : GRE/IPv4
Site Bridge-Domain : 1
Capability : Multicast-reachable
Is Adjacency Server : No
Adj Server Configured : No
Prim/Sec Adj Svr(s) : None
ASR-2#show otv
Overlay Interface Overlay1
VPN name : None
VPN ID : 2
State : UP
AED Capable : No, overlay DIS not elected <--- Not Forwarding
IPv4 control group : 225.0.0.1
Mcast data group range(s): 232.0.0.0/8
Join interface(s) : GigabitEthernet0/0/0
Join IPv4 address : 172.16.64.84
Tunnel interface(s) : Tunnel0
Encapsulation format : GRE/IPv4
Site Bridge-Domain : 1
Capability : Multicast-reachable
Is Adjacency Server : No
Adj Server Configured : No
Prim/Sec Adj Svr(s) : None
ここでは、設定のトラブルシューティングに使用できる情報を示します。
考えられる問題のトラブルシューティングに役立てるために、ASR の内蔵パケット キャプチャ デバイスが利用できます。
アクセス コントロール リスト(ACL)を作成して、キャプチャの影響と過飽和状態を最小限に抑えます。2 つのサイト間のマルチキャスト Hello だけをキャプチャするようにセットアップされます。ネイバーの Join インターフェイスと一致するように IP アドレスを調整します。
ip access-list extended CAPTURE
permit ip host 172.16.64.84 host 225.0.0.1
permit ip host 172.17.100.134 host 225.0.0.1
両方の ASR で両方向の Join インターフェイスを調べるようにキャプチャをセットアップします。
monitor capture 1 buffer circular access-list CAPTURE interface g0/0/0 both
キャプチャを開始するには、次を入力します。
monitor capture 1 start
*Nov 14 15:21:37.746: %BUFCAP-6-ENABLE: Capture Point 1 enabled.
<wait a few min>
monitor capture 1 stop
*Nov 14 15:22:03.213: %BUFCAP-6-DISABLE: Capture Point 1 disabled.
show mon cap 1 buffer brief
バッファ出力は、キャプチャ内の Hello がキャプチャされたインターフェイスを出るところを示しています。マルチキャストアドレス225.0.0.1宛てのhelloを表示します。これは設定済みの制御グループです。キャプチャ内の最初の 13 パケットを検査して、単方向の出力しか存在しないことを確認してください。172.17.100.134 からの Hello は無視されます。コア内のマルチキャストの問題が解決されると、ネイバー Hello がパケット番号 14 で表示されます。
ASR-1#show mon cap 1 buff bri
-------------------------------------------------------------
# size timestamp source destination protocol
-------------------------------------------------------------
0 1456 0.000000 172.17.100.134 -> 225.0.0.1 GRE
1 1456 8.707016 172.17.100.134 -> 225.0.0.1 GRE
2 1456 16.880011 172.17.100.134 -> 225.0.0.1 GRE
3 1456 25.873008 172.17.100.134 -> 225.0.0.1 GRE
4 1456 34.645023 172.17.100.134 -> 225.0.0.1 GRE
5 1456 44.528024 172.17.100.134 -> 225.0.0.1 GRE
6 1456 52.137002 172.17.100.134 -> 225.0.0.1 GRE
7 1456 59.819010 172.17.100.134 -> 225.0.0.1 GRE
8 1456 68.641025 172.17.100.134 -> 225.0.0.1 GRE
9 1456 78.168998 172.17.100.134 -> 225.0.0.1 GRE
10 1456 85.966005 172.17.100.134 -> 225.0.0.1 GRE
11 1456 94.629032 172.17.100.134 -> 225.0.0.1 GRE
12 1456 102.370043 172.17.100.134 -> 225.0.0.1 GRE
13 1456 110.042005 172.17.100.134 -> 225.0.0.1 GRE
14 1456 111.492031 172.16.64.84 -> 225.0.0.1 GRE <---Mcast core
fixed and now see neighbor hellos
15 1456 111.493038 172.17.100.134 -> 225.0.0.1 GRE
16 1456 112.491039 172.16.64.84 -> 225.0.0.1 GRE
17 1456 112.501033 172.17.100.134 -> 225.0.0.1 GRE
18 116 112.519037 172.17.100.134 -> 225.0.0.1 GRE
19 114 112.615026 172.16.64.84 -> 225.0.0.1 GRE
20 114 112.618031 172.17.100.134 -> 225.0.0.1 GRE
21 1456 113.491039 172.16.64.84 -> 225.0.0.1 GRE
22 1456 115.236047 172.17.100.134 -> 225.0.0.1 GRE
23 142 116.886008 172.17.100.134 -> 225.0.0.1 GRE
24 102 117.290045 172.17.100.134 -> 225.0.0.1 GRE
25 1456 118.124002 172.17.100.134 -> 225.0.0.1 GRE
26 1456 121.192043 172.17.100.134 -> 225.0.0.1 GRE
27 1456 122.443037 172.16.64.84 -> 225.0.0.1 GRE
28 1456 124.497035 172.17.100.134 -> 225.0.0.1 GRE
29 102 126.178052 172.17.100.134 -> 225.0.0.1 GRE
30 142 126.629032 172.17.100.134 -> 225.0.0.1 GRE
31 1456 127.312047 172.17.100.134 -> 225.0.0.1 GRE
32 1456 130.029997 172.17.100.134 -> 225.0.0.1 GRE
33 1456 131.165000 172.16.64.84 -> 225.0.0.1 GRE
34 1456 132.591025 172.17.100.134 -> 225.0.0.1 GRE
35 102 134.832010 172.17.100.134 -> 225.0.0.1 GRE
36 1456 135.856010 172.17.100.134 -> 225.0.0.1 GRE
37 142 136.174054 172.17.100.134 -> 225.0.0.1 GRE
38 1456 138.442030 172.17.100.134 -> 225.0.0.1 GRE
39 1456 140.769025 172.16.64.84 -> 225.0.0.1 GRE
40 1456 141.767010 172.17.100.134 -> 225.0.0.1 GRE
41 102 144.277046 172.17.100.134 -> 225.0.0.1 GRE
42 1456 144.996003 172.17.100.134 -> 225.0.0.1 GRE
ASR-1#
2#show mon cap 1 buff bri
OTV ネイバー間のマルチキャスト ルーティング状態を構築する場合は、適切な PIM 状態にする必要があります。ASR 上の予想される PIM 状態を確認するには、次のコマンドを使用します。
ASR-1#show otv
Overlay Interface Overlay1
VPN name : None
VPN ID : 2
State : UP
AED Capable : No, overlay DIS not elected
IPv4 control group : 225.0.0.1
Mcast data group range(s): 232.0.0.0/8
Join interface(s) : GigabitEthernet0/0/0
Join IPv4 address : 172.17.100.134
Tunnel interface(s) : Tunnel0
Encapsulation format : GRE/IPv4
Site Bridge-Domain : 1
Capability : Multicast-reachable
Is Adjacency Server : No
Adj Server Configured : No
Prim/Sec Adj Svr(s) : None
前回と同じエラー(AED capable: No, overlay DIS not elected)に注意してください。この意味は、ASR が AED フォワーダになれないということです。これは、ASR がそのピアに関する十分な情報を入手していないためです。内部インターフェイスが起動していない、サイト ブリッジ ドメインがダウンしている/作成されていない、または 2 つのサイトが ISP 上でお互いを認識できないことが考えられます。
ASR-1 を調査して問題を特定します。PIM ネイバーが表示されないことを示しています。この現象は、このネイバーが機能していたとしても生じることが想定されます。原因は、PIM が Join インターフェイス上でパッシブに動作していることです。PIM パッシブは、OTV 用の Join インターフェイスでサポートされる唯一の PIM モードです。
ASR-1#show ip pim neigh
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
ASR-1 上で PIM インターフェイスが設定されていることを確認するには、次のコマンドを入力します。
ASR-1#show ip pim int
Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
172.17.100.134 GigabitEthernet0/0/0 v2/P 0 30 1 172.17.100.134
172.17.100.134 Tunnel0 v2/P 0 30 1 172.17.100.134
0.0.0.0 Overlay1 v2/P 0 30 1 0.0.0.0
ASR の mroute 状態は、リンクのマルチキャスト ステータスに関する豊富な情報を提供します。この出力では、ネイバーが ASR mroute テーブル上の S,G エントリとして表示されていません。コントロール グループの mroute カウントを表示したときも、ローカル Join インターフェイスだけが送信元として表示されます。このカウントは転送合計と一緒に受信されたパケットに対応することに注意してください。これは、マルチキャスト ドメインのローカル側で起動して転送していることを意味します。
ASR-1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.0.0.1), 00:20:29/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:20:29/00:02:55
GigabitEthernet0/0/0, Forward/Sparse-Dense, 00:20:29/Proxy
(172.17.100.134, 225.0.0.1), 00:16:25/00:02:19, flags: T
Incoming interface: GigabitEthernet0/0/0, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet0/0/0, Forward/Sparse-Dense, 00:16:25/Proxy
Tunnel0, Forward/Sparse-Dense, 00:16:25/00:02:55
(*, 224.0.1.40), 00:20:09/00:02:53, RP 0.0.0.0, flags: DPC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
ASR-1#show ip mroute count
Use "show ip mfib count" to get better response time for a large number of mroutes.
IP Multicast Statistics
3 routes using 1828 bytes of memory
2 groups, 0.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
Group: 225.0.0.1, Source count: 1, Packets forwarded: 116, Packets received: 117
Source: 172.17.100.134/32, Forwarding: 116/0/1418/1, Other: 117/1/0
Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
コアなマルチキャスト問題が解決されれば、ASR からの想定される出力が表示されます。
ASR-1#show otv
Overlay Interface Overlay1
VPN name : None
VPN ID : 2
State : UP
AED Capable : Yes
IPv4 control group : 225.0.0.1
Mcast data group range(s): 232.0.0.0/8
Join interface(s) : GigabitEthernet0/0/0
Join IPv4 address : 172.17.100.134
Tunnel interface(s) : Tunnel0
Encapsulation format : GRE/IPv4
Site Bridge-Domain : 1
Capability : Multicast-reachable
Is Adjacency Server : No
Adj Server Configured : No
Prim/Sec Adj Svr(s) : None
まだ PIM ネイバーは存在せず、物理インターフェイス、オーバーレイ インターフェイス、およびトンネル インターフェイスがローカル PIM インターフェイスのままです。
ASR-1#show ip pim neigh
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
ASR-1#show ip pim int
Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
172.17.100.134 GigabitEthernet0/0/0 v2/P 0 30 1 172.17.100.134
172.17.100.134 Tunnel0 v2/P 0 30 1 172.17.100.134
0.0.0.0 Overlay1 v2/P 0 30 1 0.0.0.
mroute テーブルとカウンタがマルチキャスト状態に関する情報を提供します。出力は、Join インターフェイスだけでなく、コントロール グループ内の OTV ネイバーも送信元として表示します。リモート サイトの [Reverse Path Forwarding (RPF) Neighbor (NBR)] フィールドにもランデブー ポイント(RP)が表示されていることを確認してください。また、転送カウンタと受信カウンタが一致します。2 つの送信元でグループ受信合計を合算する必要があります。
ASR-1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.0.0.1), 00:25:16/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:25:16/00:02:06
GigabitEthernet0/0/0, Forward/Sparse-Dense, 00:25:16/Proxy
(172.16.64.84, 225.0.0.1), 00:04:09/00:02:50, flags: T
Incoming interface: GigabitEthernet0/0/0, RPF nbr 172.17.100.1
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:04:09/00:02:06
(172.17.100.134, 225.0.0.1), 00:21:12/00:01:32, flags: T
Incoming interface: GigabitEthernet0/0/0, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet0/0/0, Forward/Sparse-Dense, 00:21:12/Proxy
Tunnel0, Forward/Sparse-Dense, 00:21:12/00:02:06
(*, 224.0.1.40), 00:24:56/00:02:03, RP 0.0.0.0, flags: DPC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
ASR-1#show ip mroute count
Use "show ip mfib count" to get better response time for a large number of mroutes.
IP Multicast Statistics
4 routes using 2276 bytes of memory
2 groups, 1.00 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
Group: 225.0.0.1, Source count: 2, Packets forwarded: 295, Packets received:
297 <----- 32 + 263 = 295
Source: 172.16.64.84/32, Forwarding: 32/0/1372/1, Other: 32/0/0
Source: 172.17.100.134/32, Forwarding: 263/0/1137/3, Other: 264/1/0
Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
OTV は、カプセル化トラフィックであるため、送信元が Join インターフェイスで宛先がリモート Join インターフェイスの Generic Routing Encapsulation(GRE)トラフィックと見なされます。トラフィックを具体的に確認するために、できることはあまりありません。トラフィックが OTV を越えるかどうかを確認するために使用可能な 1 つの方法は、現在のトラフィック パターンとは無関係なパケット サイズを指定したパケット キャプチャをセットアップする方法です。この例では、サイズが 700 の Internet Control Message Protocol(ICMP)パケットを指定して、キャプチャから除外可能なものを決定できます。この方法は、パケットが OTV クラウドを越えるかどうかを検証するために使用できます。
2 つの Join インターフェイス間でアクセス リスト フィルタをセットアップするには、次のコマンドを入力します。
ip access-list extended CAPTURE
permit ip host 172.17.100.134 host 172.16.64.84
指定した 756 のサイズを除外するようにモニタ セッションをセットアップするには、次のコマンドを入力します。
monitor capture 1 buffer size 1 access-list CAPTURE limit packet-len 756
interface g0/0/0 out
キャプチャを開始するには、次を入力します。
ASR-1#mon cap 1 start
*Nov 18 12:45:50.162: %BUFCAP-6-ENABLE: Capture Point 1 enabled.
サイズを指定した特定の ping を送信します。OTV が 8 バイトの ICMP と 20 バイトの IP ヘッダーに 42 バイトのヘッダーを追加するため、700 にサイズ設定された ping を送信することによって、パケット サイズが 756 のデータが OTV クラウドに到達するかどうかを確認できます。
LAN-Sw2#ping 192.168.100.2 size 700 repeat 100
Type escape sequence to abort.
Sending 100, 700-byte ICMP Echos to 192.168.100.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 10/19/30 ms
キャプチャを停止するには、次のコマンドを入力します。
ASR-1#mon cap 1 stop
*Nov 18 12:46:02.084: %BUFCAP-6-DISABLE: Capture Point 1 disabled.
キャプチャ バッファで、100 パケットすべてがローカル側のキャプチャに到達したことがわかります。100 パケットすべてがリモート側に到達したこともわかるはずです。そうでない場合は、OTV クラウドでのパケット損失をさらに調査する必要があります。
ASR-1#show mon cap 1 buff bri
-------------------------------------------------------------
# size timestamp source destination protocol
-------------------------------------------------------------
0 756 0.000000 172.17.100.134 -> 172.16.64.84 GRE
1 756 0.020995 172.17.100.134 -> 172.16.64.84 GRE
2 756 0.042005 172.17.100.134 -> 172.16.64.84 GRE
3 756 0.052991 172.17.100.134 -> 172.16.64.84 GRE
<Output Omitted>
97 756 1.886999 172.17.100.134 -> 172.16.64.84 GRE
98 756 1.908009 172.17.100.134 -> 172.16.64.84 GRE
99 756 1.931003 172.17.100.134 -> 172.16.64.84 GRE
改定 | 発行日 | コメント |
---|---|---|
1.0 |
25-Apr-2014 |
初版 |