Automatic Multicast Tunneling

Automatic Multicast Tunneling (AMT) provides a method to tunnel multicast data over a unicast network. The tunneling is performed between AMT relays and AMT gateways, using User Datagram Protocol (UDP) encapsulation. AMT enables service providers and their customers to participate in delivering multicast traffic even in the absence of end-to-end multicast connectivity.

Restrictions for Automatic Multicast Tunneling

  • AMT tunnel only support PIM passive mode on AMT Gateway side.

  • AMT only support SSM modes for PIM signaling.

  • AMT only support ipv4 transport for tunnel.

  • For AMT, auto-rp is invalid between relay and gateway.

Overview

The multicast source sends traffic to the first-hop. Multicast traffic flows through the network until it reaches the last-hop (receivers) or AMT relays. AMT Relay is a multicast router configured to support transit routing between nonmulticast capable internetwork and the native multicast infrastructure.

The following diagram provides a sample AMT network where Relay1 and Relay2 are two AMT relays, which encapsulate the traffic into AMT tunnels, and send one copy to each of the AMT gateways.

Figure 1. Automatic Multicast Tunneling (AMT)


Automatic Multicast Tunneling Message Exchanges

The AMT protocol defines seven message types for control and encapsulation. The message exchanges happen in the following sequence:

  1. Relay Discovery—Gateway sends an AMT discovery message to an anycast address that represents the AMT relay.

  2. Relay Advertisement—Relay responds with an advertisement message, which includes the relay’s unique IP address.

  3. Relay Request—Gateway sends an AMT Request message to the relay using the unique IP address as the destination, along with a nonce to be used for security.

  4. Membership Query—Relay responds with an AMT query that includes the nonce from the AMT request and an opaque security code.

  5. Membership Update—Gateway responds with a membership update that includes an encapsulated IGMPv3/MLDv2 packet.

  6. Teardown—Gateway sends a message to stop the delivery of multicast data messages requested in an earlier membership update message.

  7. After validation the Relay establishes the AMT Tunnel and starts sending multicast traffic [Type 6]. Any further (S,G) uses the same Request/Query/Update - three-way handshake because the tunnel is already established.

AMT Tunnel and Traffic Types

The multicast traffic carried in the AMT tunnel may be IPv4 or IPv6. The AMT tunnel may be setup with IPv4 or IPv6 endpoints, thereby providing the following possibilities.

  • IPv4-in-IPv4—IPv4 multicast traffic carried over an IPv4 tunnel

  • IPv6-in-IPv4—IPv6 multicast traffic carried over an IPv4 tunnel

  • IPv6-in-IPv6—IPv6 multicast traffic carried over an IPv6 tunnel

  • IPv4-in-IPv6—IPv4 multicast traffic carried over an IPv6 tunnel


Note


In Cisco IOS XE Release 3.15S, AMT supports IPv4-in-IPv4 and IPv6-in-IPv4 only.


Advantages of Automatic Multicast Tunneling

  • Simplicity—Instead of incurring the overhead of manually provisioning, establishing and maintaining GRE tunnels between two locations, the receiving network simply sends AMT advertisements to a well-known any-cast prefix. The rest of the tunnel establishment process is done automatically without the need for additional configuration.

  • Resiliency—Because the relay discovery uses an any-cast address, gateways automatically find the closest relay. If that relay becomes unavailable or unreachable, the routing table reconverges on the next closest relay.

  • Efficiency—AMT allows transit routers to perform flow-based load balancing for more efficient link utilization.

Automatic Multicast Tunneling supports IPv4 transport for tunnel and also support for IPv4 multicast traffic & IPv6 multicast traffic. You can also configure AMT relay-only, gateway-only and relay-gateway coexisting modes.

Prerequisites for AMT

  • AMT relay and gateway tunnel requires an interface IP address. However the interface IP addresses do not need to be unique. You can configure the same addresses for the tunnel source address using the ip unnumbered command.

  • You must configure IGMP version 3 on the tunnel interfaces for the SSM to work across tunnels.

  • The tunnel source port and tunnel destination port must be configured to achieve a valid AMT configuration.

Configuration Recommendations for AMT

The tunnel source interface address should be an interface that is set up to be reachable from receivers under all instances. You can use a physical interface address, but it can cause the tunnel to go down if that physical interface is down. A loopback interface is recommended to sustain availability. You do not need a separate loopback address, you can reuse the loopback interface that you usually would have to carry router and router-ID IP address (usually Loopback 0).

IP PIM passive is the recommended and supported mode on AMT interfaces to enable IP multicast routing for AMT tunnel interfaces. This is recommended since no PIM messages (only AMT/IGMP messages) will be sent or received via the AMT tunnel.

On an AMT relay, you need only one tunnel interface to which all gateways can connect. Therefore the interface is a multipoint interface. Every gateway interface can only connect to one relay, but you can configure multiple tunnel interfaces.

Even though AMT tunnels (relay and gateway) only support IPv4 tunnels, the IPv4 tunnels can carry both IPv4 and IPv6 simultaneously. You can configure the AMT for the version(s) of IP that you need.

If you want to set up a redundant AMT relay, your AMT relay address configured on the gateway should be any IP address that you set up as an anycast address on your relays. If you do not plan to use redundant (Anycast) Relay, you can use the relays tunnel source address on the gateways.

If you shut down the anycast Loopback interface, the AMT relay would not accept new AMT gateway tunnel requests. IP routing for the anycast address would only point to any other relays active with the same address and new requests would therefore go to those relays. Any AMT gateways already connected to this relay would stay on this relay, because they already are using the relays interface address.

Enabling and Configuring Automatic Multicast Tunneling on a Relay


Note


Switch-over from active relay to backup relay can take more than 5 minutes.


SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface tunnel number
  4. ip address ip-address mask
  5. no ip redirects
  6. ip pim sparse-mode
  7. ip igmp version version number
  8. ipv6 enable
  9. tunnel source interface-type interface-number
  10. tunnel mode udp multipoint
  11. tunnel dst-port dynamic
  12. tunnel src-port dynamic
  13. amt relay traffic {ip | ipv6}
  14. exit
  15. ip multicast-routing distributed
  16. ipv6 multicast-routing
  17. ip pim ssm {default | range access-list}

DETAILED STEPS

  Command or Action Purpose

Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

interface tunnel number

Example:

Device(config)# interface tunnel 11

Specifies the interface tunnel number and enters interface configuration mode.

Step 4

ip address ip-address mask

Example:

Device(config-if)# 11.1.1.1 255.255.255.0

Configures the IP address on the interface.

Step 5

no ip redirects

Example:

Device(config-if)# no ip redirects

Disables sending ICMP Redirect messages.

Step 6

ip pim sparse-mode

Example:

Device(config-if)# ip pim sparse-mode

Enable PIM sparse-mode operation.

Step 7

ip igmp version version number

Example:

Device(config-if)# ip igmp version 3

Specifies IGMP version.

Step 8

ipv6 enable

Example:

Device(config-if)# ipv6 enable

Enables IPv6 on interface.

Step 9

tunnel source interface-type interface-number

Example:

Device(config-if)# tunnel source loopback 0

Configures tunnel source as a loopback interface.

Step 10

tunnel mode udp multipoint

Example:

Device(config-if)# tunnel mode udp multipoint

Specifies the UDP encapsulation protocol.

Step 11

tunnel dst-port dynamic

Example:

Device(config-if)# tunnel dst-port dynamic

Specifies the tunnel destination port.

Step 12

tunnel src-port dynamic

Example:

Device(config-if)# tunnel src-port dynamic

Specifies the tunnel source port.

Step 13

amt relay traffic {ip | ipv6}

Example:

Device(config-if)# amt relay traffic ipv6

Enables IPv4 or IPv6 traffic on AMT relay interface.

Step 14

exit

Example:

Device(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 15

ip multicast-routing distributed

Example:

Device(config)# ip multicast-routing distributed

Enables Multicast Distributed Switching (MDS).

Step 16

ipv6 multicast-routing

Example:

Device(config)# ipv6 multicast-routing

Enables multicast routing using Protocol Independent Multicast (PIM) and Multicast Listener Discovery (MLD).

Step 17

ip pim ssm {default | range access-list}

Example:

Device(config)# ip pim ssm default

Specifies the Source Specific Multicast (SSM) range of IP multicast addresses.

Enabling and Configuring Automatic Multicast Tunneling on Gateway

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface tunnel number
  4. ip address ip-address mask
  5. ip pim passive
  6. ip igmp version version number
  7. ipv6 enable
  8. ipv6 pim passive
  9. tunnel source interface-type interface-number
  10. tunnel mode udp ip
  11. tunnel destination dynamic
  12. tunnel dst-port dynamic
  13. tunnel src-port dynamic
  14. amt gateway traffic {ip | ipv6}
  15. amt gateway relay-address IP address
  16. exit
  17. ip multicast-routing distributed
  18. ipv6 multicast-routing
  19. ip pim ssm {default | range access-list}
  20. ipv6 multicast pim-passive-enable
  21. ip route ip-address interface-type interface-number [multicast]
  22. ipv6 route ipv6-prefix/prefix-length interface-type interface-number [multicast]

DETAILED STEPS

  Command or Action Purpose

Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

interface tunnel number

Example:

Device(config)# interface tunnel 11

Specifies the interface tunnel number and enters interface configuration mode.

Step 4

ip address ip-address mask

Example:

Device(config-if)# 11.1.1.1 255.255.255.0

Configures the IP address on the interface.

Step 5

ip pim passive

Example:

Device(config-if)# ip pim passive

Enables IP PIM passive mode operation.

Step 6

ip igmp version version number

Example:

Device(config-if)# ip igmp version 3

Specifies IGMP version.

Step 7

ipv6 enable

Example:

Device(config-if)# ipv6 enable

Enables IPv6 on interface.

Step 8

ipv6 pim passive

Example:

Device(config-if)# ipv6 pim passive

Enables IPv6 PIM passive mode operation.

Step 9

tunnel source interface-type interface-number

Example:

Device(config-if)# tunnel source loopback 0

Configures tunnel source as a loopback interface.

Step 10

tunnel mode udp ip

Example:

Device(config-if)# tunnel mode udp ip

Specifies the UDP encapsulation protocol.

Step 11

tunnel destination dynamic

Example:

Device(config-if)# tunnel destination dynamic

Applies the tunnel destination address dynamically to the tunnel interface.

Step 12

tunnel dst-port dynamic

Example:

Device(config-if)# tunnel dst-port dynamic

Applies the tunnel destination port dynamically.

Step 13

tunnel src-port dynamic

Example:

Device(config-if)# tunnel src-port dynamic

Applies the tunnel source port dynamically.

Step 14

amt gateway traffic {ip | ipv6}

Example:

Device(config-if)# amt gateway traffic ipv6

Enables IPv4 or IPv6 traffic on AMT gateway interface.

Step 15

amt gateway relay-address IP address

Example:

Device(config-if)# amt gateway relay-address 172.16.0.0

Specifies the destination IP address of AMT discovery.

Step 16

exit

Example:

Device(config-if)# exit

Exits interface configuration mode and returns to global configuration mode.

Step 17

ip multicast-routing distributed

Example:

Device(config)# ip multicast-routing distributed

Enables Multicast Distributed Switching (MDS).

Step 18

ipv6 multicast-routing

Example:

Device(config)# ipv6 multicast-routing

Enables multicast routing using Protocol Independent Multicast (PIM) and Multicast Listener Discovery (MLD).

Step 19

ip pim ssm {default | range access-list}

Example:

Device(config)# ip pim ssm default

Specifies the Source Specific Multicast (SSM) range of IP multicast addresses.

Step 20

ipv6 multicast pim-passive-enable

Example:

Device(config)# ipv6 multicast pim-passive-enable

Enables passive PIM operation.

Step 21

ip route ip-address interface-type interface-number [multicast]

Example:

Device(config)# ip route 101.0.0.2 255.255.255.255 tunnel10 multicast

Specifies the IP address along with interface type, interface number, and multicast route.

Step 22

ipv6 route ipv6-prefix/prefix-length interface-type interface-number [multicast]

Example:

Device(config)# ipv6 route 2011::101:0:0:2/128 Tunnel10 multicast

Specifies the IPv6 prefix and length along with interface type, interface number, and multicast route (route only usable by multicast).

Displaying and Verifying AMT Configuration

SUMMARY STEPS

  1. ping 3.3.3.3 source 5.5.5.5
  2. show ip igmp membership
  3. show ip mroute
  4. show ip rpf10.3.3.1

DETAILED STEPS


Step 1

ping 3.3.3.3 source 5.5.5.5

Example:

Device# ping 3.3.3.3 source 5.5.5.5
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
   Packet sent with a source address of 5.5.5.5
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/8 ms

Ping the relay tunnel source address from the gateway, using the gateways tunnel source address and the gateway address (if both are different as the example).

Step 2

show ip igmp membership

Example:

Device# show ip igmp membership
  ...
   Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
  /*,232.2.3.4                    0.0.0.0         00:03:02 stop  2MA    Lo0
   10.3.3.1,232.2.3.4                             00:03:02 stop  A      Lo0

Note

 

The command is executed at destination gateway.

You can use the ip igmp static-group command, you create an IGMP membership request on the interface. You can do this on any physical interface configured for IP multicast, but if there are multiple routers attached to the interface, then the AMT gateway router may not become the PIM-DR and therefore not join to the multicast traffic. It can therefore be easier to put the join on an existing loopback interface and also enable it for IP multicast (IP PIM passive).

Step 3

show ip mroute

Example:

Device# show ip mroute
  ...
  (10.3.3.1, 232.2.3.4), 00:01:53/00:01:08, flags: sTI
    Incoming interface: Tunnel1, RPF nbr 0.0.0.0, Mroute
    Outgoing interface list:
      Loopback0, Forward/Sparse-Dense, 00:01:51/00:01:08

Note

 

The command is executed at destination gateway.

The AMT gateway will join the multicast traffic towards the AMT relay if the mroute shows the incoming interface as the Tunnel interface and when it is joined for example, when there are one or more outgoing interfaces.

When the command is executed on the source gateway, the mroute state on the relay will show the relay interface as an adjacency in the outgoing interface list. Because there is one interface for all joining relays, each outgoing copy across the AMT relay interface is identified by the AMT relay interface, the IP address of the gateway and the UDP port number of the relay as seen by the relay. If there are multiple gateways in a home behind a NAT/PAT (single IP address to the internet), there would be multiple adjacencies shown with the same gateway IP address, but different UDP ports. If state is not built as expected, you can use debug ip igmp to troubleshoot it. There are no additional AMT debugs for the AMT/IGMP joins, instead those are all part of IGMP debugs.

Step 4

show ip rpf10.3.3.1

Example:

Device#
RPF information for ? (10.3.3.1)
  RPF interface: Tunnel1
  RPF neighbor: ? (0.0.0.0)
  RPF route/mask: 10.3.3.0/24
  RPF type: multicast (static)
  Doing distance-preferred lookups across tables
  RPF topology: ipv4 multicast base

Note

 

The command is executed at destination gateway.

Verifies Multicast RPF.

If the output is not showing the desired AMT gateway tunnel interface as the RPF interface, then your routing configuration for IP multicast into the AMT tunnel is not set up correctly. If you have only one AMT gateway interface, you can use a static mroute. If you have multiple AMT tunnel for different relays, you need to configure the source prefixes (and RP-addresses when you use PIM-SM) towards their respective AMT tunnel.

For IP multicast tree to flow correctly via the AMT tunnels, you must first check if the IP multicast state is correctly built from gateway to relay. This primarily means that the (S,G) join for a source in PIM-SSM/PIM-SM or the (*,G) join to the RP address in PIM-SM need to RPF towards the desired AMT gateway tunnel.


Displaying and Verifying AMT Relay Configuration

SUMMARY STEPS

  1. enable
  2. show ip amt tunnel
  3. show ip mroute section [group-address]
  4. show ipv6 mroute section [group-address]
  5. show ip mfib section [group-address]
  6. show ipv6 mfib section [group-address]
  7. show platform software ip rp active mfib section [group-address]
  8. show platform software ipv6 rp active mfib section [group-address]
  9. show platform software mlist rp active index multicast-index-number
  10. show platform software adjacency rp active index platform-allocated-index-value
  11. show ip interface brief

DETAILED STEPS


Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

show ip amt tunnel

Example:

Device# show ip amt tunnel

AMT Relay tunnel:
    Local address       UDP port
      11.11.11.11       2268 (0x8DC )
    Remote address                      Expire time
      33.33.33.33       59464(0xE848)   00:03:07
    Connected to 1 Gateway

  Total active Gateways: 1
Displays AMT relay configuration.

Step 3

show ip mroute section [group-address]

Example:

Device# show ip mroute section 232.1.1.1

(101.0.0.2, 232.1.1.1), 2d00h/00:02:18, flags: sTI
  Incoming interface: GigabitEthernet0/0/4, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel10, 33.33.33.33, UDP port 59464, Forward/Sparse, 2d00h/00:02:18
Displays information about sparse mode routes in the IP multicast routing (mroute) table for the specified multicast group.

Step 4

show ipv6 mroute section [group-address]

Example:

Device# show ipv6 mroute section 232.1.1.1

(2011::101:0:0:2, FF3F::232:1:1:1), 2d00h/never, flags: sTI
  Incoming interface: GigabitEthernet0/0/4
  RPF nbr: 2011::101:0:0:2
  Immediate Outgoing interface list:
    Tunnel10, AMT NH 33.33.33.33, UDP Port 59464, Forward, 2d00h/never
Displays information about sparse mode routes in the IPv6 mroute table for the specified multicast group.

Step 5

show ip mfib section [group-address]

Example:

Device# show ip mfib section 232.1.1.1

(101.0.0.2,232.1.1.1) Flags: HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   NA/NA/NA/NA, Other: NA/NA/NA
   GigabitEthernet0/0/4 Flags: A
   Tunnel10, AMT Encap 33.33.33.33, UDP Port:59464 Flags: F NS
     Pkts: 0/0
Displays the status of entries and interfaces in the IPv4 Multicast Forwarding Information Base (MFIB) for the specified multicast group.

Step 6

show ipv6 mfib section [group-address]

Example:

Device# show ipv6 mfib section 232.1.1.1
 
(2011::101:0:0:2,FF3F::232:1:1:1) Flags: HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   NA/NA/NA/NA, Other: NA/NA/NA
   GigabitEthernet0/0/4 Flags: A
   Tunnel10, AMT Encap 33.33.33.33, UDP Port:59464 Flags: F NS
     Pkts: 0/0
Displays the status of entries and interfaces in the IPv6 Multicast Forwarding Information Base (MFIB) for the specified multicast group.

Step 7

show platform software ip rp active mfib section [group-address]

Example:

Device# show platform software ip rp active mfib section 232.1.1.1

232.1.1.1, 101.0.0.2/64 --> OBJ_INTF_LIST (0x5a)
                Obj id: 0x5a, Flags:
                OM handle: 0x421712c4
Displays platform software IPv4 MFIB route processor information for the specified multicast group.

Step 8

show platform software ipv6 rp active mfib section [group-address]

Example:

Device# show platform software ipv6 rp active mfib section 232.1.1.1

ff3f::232:1:1:1, 2011::101:0:0:2/256 --> OBJ_INTF_LIST (0x5b)
                Obj id: 0x5b, Flags:
                OM handle: 0x42171d24
Displays platform software IPv6 MFIB route processor information for the specified multicast group.

Step 9

show platform software mlist rp active index multicast-index-number

Example:

Device# show platform software mlist rp active index 0x5a

OCE              Type             OCE Flags        Interface
--------------------------------------------------------------------------------------
0x57             OBJ_ADJACENCY    NS, F            Tunnel10
0xf80000c1       OBJ_ADJACENCY    A                GigabitEthernet0/0/4
Displays platform software route processor information for the specified multicast list index.

Step 10

show platform software adjacency rp active index platform-allocated-index-value

Example:

Device# show platform software adjacency rp active index 0x57

Number of adjacency objects: 22

Adjacency id: 0x57 (87)
  Interface: Tunnel10, IF index: 20, Link Type: MCP_LINK_IP
  Encap: 45:0:0:0:0:0:0:0:ff:11:63:95:b:b:b:b:21:21:21:21:8:dc:e8:48:0:0:0:0:6:0
  Encap Length: 30, Encap Type: MCP_ET_TUNNEL, MTU: 1470
  Flags: no-l3-inject
  Incomplete behavior type: None
  Fixup: gre
  Fixup_Flags_2: pmip-udp
  Nexthop addr: 33.33.33.33
  IP FRR MCP_ADJ_IPFRR_NONE 0
  OM handle: 0x4217013c
Displays platform software adjacency route processor information for the specified platform allocated index.

Step 11

show ip interface brief

Example:

Device(source gateway)# show ip interface brief

  Interface              IP-Address      OK? Method Status                Protocol
    Tunnel1                3.3.3.3         YES TFTP   up                    up
    ....

The above output indicates that the relay has no connection from a gateway. The AMT relay interface will be up after it is correctly configured. If the output displays Protocol "down", you must check your configuration. If the interface command shows administratively down, you have not configured the "no shut" in the interface.

Displays errors in AMT gateway configuration.

Displaying and Verifying AMT Gateway Configuration

SUMMARY STEPS

  1. enable
  2. show ip amt tunnel
  3. show ip mroute section [group-address]
  4. show ipv6 mroute section [group-address]
  5. show ip mfib section [group-address]
  6. show ipv6 mfib section [group-address]
  7. show platform software adjacency rp active index platform-allocated-index-value
  8. show ip interface brief

DETAILED STEPS


Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

show ip amt tunnel

Example:

Device(destination gateway)# show ip amt tunnel

AMT Gateway tunnel Tunnel1:
       Local address       UDP port
            5.5.5.5           54358(0xD456)
       Remote address
            3.3.3.3           2268 (0x8DC )

  Total active Relays: 1
Device(source gateway)# show ip amt tunnel 
AMT Relay tunnel:
      Local address       UDP port
        3.3.3.3           2268 (0x8DC )
      Remote address                      Expire time
        5.5.5.5           54358(0xD456)   00:03:53
      Connected to 1 Gateway

The above output is displayed if both relay and gateway is working correctly.

Displays AMT gateway configuration.

Step 3

show ip mroute section [group-address]

Example:

Device# show ip mroute section 232.1.1.1

(101.0.0.2, 232.1.1.1), 2d00h/00:02:54, flags: sTI
  Incoming interface: Tunnel10, RPF nbr 0.0.0.0, Mroute
  Outgoing interface list:
    GigabitEthernet0/0/4, Forward/Sparse, 2d00h/00:02:54
Displays information about the IP multicast routing (mroute) table for the specified multicast group.

Step 4

show ipv6 mroute section [group-address]

Example:

Device# show ipv6 mroute section 232.1.1.1

(2011::101:0:0:2, FF3F::232:1:1:1), 2d00h/never, flags: sTI
  Incoming interface: Tunnel10
  RPF nbr: ::
  Immediate Outgoing interface list:
    GigabitEthernet0/0/4, Forward, 2d00h/never
Displays information about the IPv6 mroute table for the specified multicast group.

Step 5

show ip mfib section [group-address]

Example:

Device# show ip mfib section 232.1.1.1

(101.0.0.2,232.1.1.1) Flags: HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   NA/NA/NA/NA, Other: NA/NA/NA
   Tunnel10 Flags: A
   GigabitEthernet0/0/4 Flags: F NS
     Pkts: 0/0
Displays the entries and interfaces in the IPv4 Multicast Forwarding Information Base (MFIB) for the specified multicast group.

Step 6

show ipv6 mfib section [group-address]

Example:

Device# show ipv6 mfib section 232.1.1.1
 
(2011::101:0:0:2,FF3F::232:1:1:1) Flags: HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   NA/NA/NA/NA, Other: NA/NA/NA
   Tunnel10 Flags: A
   GigabitEthernet0/0/4 Flags: F NS
     Pkts: 0/0
Displays the entries and interfaces in the IPv6 Multicast Forwarding Information Base (MFIB) for the specified multicast group.

Step 7

show platform software adjacency rp active index platform-allocated-index-value

Example:

Device# show platform software adjacency rp active index 0x57

Number of adjacency objects: 19
Adjacency id: 0xf8000126 (4160749862)
  Interface: Tunnel10, IF index: 18, Link Type: MCP_LINK_IP
  Encap: 45:0:0:0:0:0:0:0:ff:11:63:95:21:21:21:21:b:b:b:b:e8:48:8:dc:0:0:0:0:6:0
  Encap Length: 30, Encap Type: MCP_ET_TUNNEL, MTU: 1470
  Incomplete behavior type: None
  Fixup: gre
  Fixup_Flags_2: pmip-udp
  IP FRR MCP_ADJ_IPFRR_NONE 0
  OM handle: 0x4216aaf4
Displays platform software adjacency route processor information for the specified platform allocated index.

Step 8

show ip interface brief

Example:

Device(destination gateway)# show ip interface brief

  Interface              IP-Address      OK? Method Status                Protocol
  Tunnel1                5.5.5.5         YES TFTP   up                    down

The Protocol: down displayed in the above output indicates that the gateway has no connection to the relay. If the interface command shows administratively down, you have not configured the "no shut" in the interface. If the command displays UNKNOWN but Protocol shows "up", then the gateway did have a connection to the relay hat was terminated.

Note

 

It takes a few minutes before a gateway will consider a relay to be unreachable after not receiving packets from it. The gateway will then revert trying to reach the anycast address to find a new relay (in case the existing relay is down).

Displays errors in AMT gateway configuration.

Example: AMT Relay Configuration

The following example shows how to configure AMT relay:
enable 
configure terminal 
interface Tunnel10
 ip address 11.1.1.1 255.255.255.0
 no ip redirects
 ip pim sparse-mode
 ip igmp version 3
 ipv6 enable
 tunnel source Loopback0
 tunnel mode udp multipoint
 tunnel dst-port dynamic
 tunnel src-port dynamic
 amt relay traffic ip
 amt relay traffic ipv6
exit

ip multicast-routing distributed
ipv6 multicast-routing
ip pim ssm default
end

Example: AMT Gateway Configuration

The following example shows how to configure AMT gateway:
enable 
configure terminal 
interface Tunnel10
 ip address 33.1.1.1 255.255.255.0
 ip pim passive
 ip igmp version 3
 ipv6 enable
 ipv6 pim passive
 tunnel source Loopback0
 tunnel mode udp ip
 tunnel destination dynamic
 tunnel dst-port dynamic
 tunnel src-port dynamic
 amt gateway traffic ip
 amt gateway traffic ipv6
 amt gateway relay-address 167.3.0.1
exit

ip multicast-routing distributed
ipv6 multicast-routing
ip pim ssm default
ipv6 multicast pim-passive-enable
ip route 101.0.0.2 255.255.255.255 Tunnel10 multicast
ipv6 route 2011::101:0:0:2/128 Tunnel10 multicast
end

Additional References for Automatic Multicast Tunneling

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

IP Multicast commands

Cisco IOS IP Multicast Command Reference

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for Automatic Multicast Tunneling

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to https://cfnng.cisco.com/. An account on Cisco.com is not required.