EVPN-VPWS Single Homed
The EVPN-VPWS single homed solution requires per EVI Ethernet Auto Discovery route. EVPN defines a new BGP Network Layer Reachability Information (NLRI) used to carry all EVPN routes. BGP Capabilities Advertisement used to ensure that two speakers support EVPN NLRI (AFI 25, SAFI 70) as per RFC 4760.
The architecture for EVPN VPWS is that the PEs run Multi-Protocol BGP in control-plane. The following image describes the EVPN-VPWS configuration:
-
The VPWS service on PE1 requires the following three elements to be specified at configuration time: -
The VPN ID (EVI)
-
The local AC identifier (AC1) that identifies the local end of the emulated service.
-
The remote AC identifier (AC2) that identifies the remote end of the emulated service.
PE1 allocates a MPLS label per local AC for reachability.
-
-
The VPWS service on PE2 is set in the same manner as PE1. The three same elements are required and the service configuration must be symmetric.
PE2 allocates a MPLS label per local AC for reachability.
-
PE1 advertise a single EVPN per EVI Ethernet AD route for each local endpoint (AC) to remote PEs with the associated MPLS label.
PE2 performs the same task.
-
On reception of EVPN per EVI EAD route from PE2, PE1 adds the entry to its local L2 RIB. PE1 knows the path list to reach AC2, for example, next hop is PE2 IP address and MPLS label for AC2.
PE2 performs the same task.
Configure EVPN-VPWS Single Homed
This section describes how you can configure single-homed EVPN-VPWS feature.
/* Configure PE1 */
Router# configure
Router(config)# router bgp 100
Router(config-bgp)# address-family l2vpn evpn
Router(config-bgp-af)# exit
Router(config-bgp)# neighbor 10.10.10.1
Router(config-bgp-nbr))# address-family l2vpn evpn
Router(config-bgp-nbr-af)# commit
Router(config-bgp-nbr-af)# exit
Router(config-bgp-nbr)# exit
Router(config-bgp)# exit
Router(config)# l2vpn
Router(config-l2vpn)# xconnect group evpn-vpws
Router(config-l2vpn-xc)# p2p evpn1
Router(config-l2vpn-xc-p2p)# interface TenGigE0/1/0/2
Router(config-l2vpn-xc-p2p)# neighbor evpn evi 100 target 12 source 10
Router(config-l2vpn-xc-p2p-pw)# commit
Router(config-l2vpn-xc-p2p)# exit
/* Configure PE2 */
Router# configure
Router(config)# router bgp 100
Router(config-bgp)# address-family l2vpn evpn
Router(config-bgp-af)# exit
Router(config-bgp)# neighbor 10.10.10.1
Router(config-bgp-nbr))# address-family l2vpn evpn
Router(config-bgp-nbr-af)# commit
Router(config-bgp-nbr-af)# exit
Router(config-bgp-nbr)# exit
Router(config-bgp)# exit
Router(config)# l2vpn
Router(config-l2vpn)# xconnect group evpn-vpws
Router(config-l2vpn-xc)# p2p evpn1
Router(config-l2vpn-xc-p2p)# interface TenGigE0/1/0/2
Router(config-l2vpn-xc-p2p)# neighbor evpn evi 100 target 10 source 12
Router(config-l2vpn-xc-p2p-pw)# commit
Router(config-l2vpn-xc-p2p)# exit
Running Configuration
/* On PE1 */
configure
router bgp 100
address-family l2vpn evpn
neighbor 10.10.10.1
address-family l2vpn evpn
!
configure
l2vpn
xconnect group evpn-vpws
p2p evpn1
interface TenGigE0/1/0/2
neighbor evpn evi 100 target 12 source 10
!
/* On PE2 */
configure
router bgp 100
address-family l2vpn evpn
neighbor 10.10.10.1
address-family l2vpn evpn
!
configure
l2vpn
xconnect group evpn-vpws
p2p evpn1
interface TenGigE0/1/0/2
neighbor evpn evi 100 target 10 source 12
!
Configure EVPN-VPWS on RoE Interface
This section describes how you can configure EVPN-VPWS on RoE interface feature.
Feature Name |
Release Information |
Feature Description |
EVPN-VPWS support to RoE interface |
Release 7.3.2 |
This feature extends support in carrying the Radio over Ethernet (RoE) packets from Cell Site Router (CSR) to the aggregation router. |
Global Configurations for BGP
router bgp 108
bgp router-id 10.255.255.5
address-family l2vpn evpn
!
neighbor 10.255.255.4
remote-as 108
update-source Loopback0
address-family l2vpn evpn
Global Configurations for EVPN
evpn
evi 108
!
evpn
evi 109
!
Common Public Radio Interface (CPRI)
interface CPRIoE0/0/0/6
mtu 9600
l2transport
l2vpn
xconnect group evpn-vpws108
p2p evpn108
interface CPRIoE0/0/0/6
neighbor evpn evi 108 service 108
!