- show vlan
- show vlan access-log config
- show vlan access-log flow
- show vlan access-log statistics
- show vlan access-map
- show vlan all-ports
- show vlan counters
- show vlan dot1q tag native
- show vlan filter
- show vlan free
- show vlan free summary
- show vlan internal usage
- show vlan mapping
- show vlan port provisioning
- show vlan private-vlan
- show vlan remote-span
- show vlan virtual-port
- show vlan-range
- show vlans
- show vlans dot1q
- show vlans tokenring
- show vlan-switch
- show vtp
- shutdown vlan
- snmp trap mac-notification change
- spanning-tree backbonefast
- spanning-tree bpdufilter
- spanning-tree bpduguard
- spanning-tree bridge assurance
- spanning-tree cost
- spanning-tree etherchannel guard misconfig
- spanning-tree extend system-id
- spanning-tree guard
- spanning-tree link-type
- spanning-tree loopguard default
- spanning-tree mode
- spanning-tree mst
- spanning-tree mst configuration
- spanning-tree mst forward-time
- spanning-tree mst hello-time
- spanning-tree mst max-age
- spanning-tree mst max-hops
- spanning-tree mst pre-standard
- spanning-tree mst priority
- spanning-tree mst root
- spanning-tree mst simulate pvst (interface)
- spanning-tree mst simulate pvst global
- spanning-tree pathcost method
- spanning-tree portfast (interface)
- spanning-tree portfast bpdufilter default
- spanning-tree portfast bpduguard default
- spanning-tree portfast default
- spanning-tree port-priority
- spanning-tree transmit hold-count
- spanning-tree uplinkfast
- spanning-tree vlan
show vlan
To display VLAN information, use the show vlan command in privileged EXEC mode.
show vlan [brief | id vlan-id | name name [ifindex] | ifindex]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Each Ethernet switch port and Ethernet repeater group belong to only one VLAN. Trunk ports can be on multiple VLANs.
If you shut down a VLAN using the state suspend or the state active command, these values appear in the Status field:
•suspended—VLAN is suspended.
•active—VLAN is active.
If you shut down a VLAN using the shutdown command, these values appear in the Status field:
•act/lshut—VLAN status is active but shut down locally.
•sus/lshut—VLAN status is suspended but shut down locally.
This is an example of the ouput for a VLAN (VLAN0002) that is active but shut down locally:
Router#
show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa5/9
2 VLAN0002 act/lshut Fa5/9
<...Output truncated...>
If a VLAN is shut down internally, these values appear in the Status field:
•act/ishut—VLAN status is active but shut down internally.
•sus/ishut—VLAN status is suspended but shut down internally.
This is an example of the ouput for a VLAN (VLAN0002) that is active but shut down internally:
Router#
show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa5/9
2 VLAN0002 act/ishut Fa5/9
<...Output truncated...>
If a VLAN is shut down locally and internally, the value that is displayed in the Status field is act/ishut or sus/ishut. If a VLAN is shut down locally only, the value that is displayed in the Status field is act/lshut or sus/lshut.
Separate VLAN ranges with a hyphen, and separate VLANs with a comma and no spaces in between. For example, you can enter the following:
Router#
show vlan id 1-4,3,7,5-20
Examples
This example shows how to display the VLAN parameters for all VLANs within the administrative domain:
Router#
show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa5/9
2 VLAN0002 active Fa5/9
3 VLAN0003 active Fa5/9
4 VLAN0004 active Fa5/9
5 VLAN0005 active Fa5/9
6 VLAN0006 active Fa5/9
<...Output truncated...>
1004 fddinet-default active Fa5/9
1005 trbrf-default active Fa5/9
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 303 0
4 enet 100004 1500 - - - - - 304 0
5 enet 100005 1500 - - - - - 305 0
6 enet 100006 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
<...Output truncated...>
Remote SPAN VLANs
-----------------
2, 20
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
Router#
This example shows how to display the VLAN name, status, and associated ports only:
Router#
show vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa5/9
2 VLAN0002 active Fa5/9
3 VLAN0003
act/lshutFa5/9
4 VLAN0004
act/lshutFa5/9
5 VLAN0005 active Fa5/9
10 VLAN0010 active Fa5/9
.
.
.
999 VLAN0999 active Fa5/9
1002 fddi-default active Fa5/9
1003 trcrf-default active Fa5/9
1004 fddinet-default active Fa5/9
1005 trbrf-default active Fa5/9
Router#
This example shows how to display the VLAN parameters for multiple VLANs:
Router# show vlan id 1-4,3,7,5-20
VLAN Name Status Ports
---- -------------------------------- --------- ------------------------------
1 default active Fa5/7, Fa5/12
2 VLAN0002 active
3 VLAN0003 act/lshut
4 VLAN0004 act/lshut
5 VLAN0005 active
6 VLAN0006 active
10 VLAN0010 active
20 VLAN0020 active
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 303 0
4 enet 100004 1500 - - - - - 304 0
5 enet 100005 1500 - - - - - 305 0
6 enet 100006 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
Router#
This example shows how to display the ifIndex number for VLAN 10 only:
Router
# show vlan id 10 ifindex
VLAN Ifindex
---- -------
10 37
Router
#
Table 31 describes the fields that are shown in the example.
Related Commands
|
|
---|---|
show vlan private-vlan |
Display PVLAN information. |
vlan (config-VLAN submode) |
Configures a specific VLAN. |
vtp |
Configures the global VTP state. |
show vlan access-log config
To display VLAN access control list (VACL) logging configuration properties, use the show vlan access-log config command in privileged EXEC mode.
show vlan access-log config
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Syslog messages are generated when the device reaches the set threshold, or five minutes after the previous message is displayed, whichever occurs first. The threshold controls the rate of the syslog message only and does not affect the log table entries. Packets exceeding the specified rate limit will not be logged.
Examples
The following example shows how to display the configured VACL logging properties. The fields are self-explanatory.
Router# show vlan access-log config
VACL Logging Configuration:
max log table size :500
log threshold :4000
rate limiter :3000
Related Commands
show vlan access-log flow
To display VLAN access control list (VACL) flow table contents, use the show vlan access-log flow command in privileged EXEC mode.
show vlan access-log flow protocol {src-addr src-mask | any | host {hostname | host-ip}} {dst-addr dst-mask | any | host {hostname | host-ip}} [vlan vlan-id]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Entries for the standard protocols or any protocol can be displayed by specifying the protocol name or protocol number. Entries are removed from the table, if there is no increment in the packet counter after the last syslog message.
Examples
The following example shows how to display the VACL flow table contents.
Router# show vlan access-log flow 17 172.20.10.110 255.255.0.0 172.20.10.105 255.255.0.0
id prot src_ip dst_ip sport dport vlan port count total lastlog
-----------------------------------------------------------------------------------
1 17 172.20.10.110 172.20.10.105 68 67 2 Gi1/0/3 324 325 00:03:14.338
2 17 172.20.10.109 172.20.10.105 68 67 2 Gi1/0/3 324 325 00:03:13.843
3 17 172.20.10.108 172.20.10.105 68 67 2 Gi1/0/3 325 326 00:03:13.340
4 17 172.20.10.107 172.20.10.105 68 67 2 Gi1/0/3 326 327 00:03:12.845
5 17 172.20.10.106 172.20.10.105 68 67 2 Gi1/0/3 327 328 00:03:12.342
6 17 172.20.10.110 172.20.10.105 68 67 2 Gi1/0/2 603 604 00:02:32.202
7 17 172.20.10.109 172.20.10.105 68 67 2 Gi1/0/2 605 606 00:02:31.204
8 17 172.20.10.108 172.20.10.105 68 67 2 Gi1/0/2 607 608 00:02:30.206
9 17 172.20.10.107 172.20.10.105 68 67 2 Gi1/0/2 607 608 00:02:29.216
10 17 172.20.10.106 172.20.10.105 68 67 2 Gi1/0/2 607 608 00:02:28.201
Total number of matched entries: 10
Table 32 describes the significant fields shown in the display.
Related Commands
show vlan access-log statistics
To display VLAN access control list (VACL) packet counts, messages, and other statistics, use the show vlan access-log statistics command in privileged EXEC mode.
show vlan access-log statistics
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
All platforms do not display VACL logging index. Packets that are dropped do not generate any syslog messages.
Examples
The following example shows how to display the VACL statistics. The fields are self-explanatory.
Router# show vlan access-log statistics
VACL Logging Statistics:
total packets :0
logged :0
dropped :0
Dropped Packets Statistics:
unsupported protocol :0
no packet buffer :0
hash queue full :0
flow table full :0
Misc Information:
VACL Logging LTL Index :0x7E02
free packet buffers :8192
log messages sent :0
log table size :0
Related Commands
show vlan access-map
To display the contents of a VLAN-access map, use the show vlan access-map command in privileged EXEC mode.
show vlan access-map [map-name]
Syntax Description
map-name |
(Optional) VLAN access-map name. |
Command Modes
Privileged EXEC (#)
Command History
Examples
This command shows how to display the contents of a VLAN-access map. The fields shown in the display are self-explanatory.
Router# show vlan access-map access_map_example_1
Vlan access-map access_map_example_1
match: ip address 13
action: forward capture
Related Commands
show vlan all-ports
To display VLAN information for trunk and access ports, use the show vlan all-ports command in privileged EXEC mode.
show vlan all-ports
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SXH |
This command was introduced. |
Examples
The following example shows how to display VLAN information for trunk and access ports:
Router# show vlan all-ports
VLAN Name Status Ports ---- -------------------------------- --------- ------------------------------- 1 default active 2 VLAN0002 active 3 VLAN0003 active .
.
.
1003 trcrf-default act/unsup 1004 fddinet-default act/unsup 1005 trbrf-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2 ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------ 1 enet 100001 1500 - - - - - 0 0 2 enet 100002 1500 - - - - - 0 0 3 enet 100003 1500 - - - - - 303 0 .
.
.
1002 fddi 101002 1500 - - - - - 0 0 1003 trcrf 101003 4472 1005 3276 - - srb 0 0 1004 fdnet 101004 1500 - - - ieee - 0 0 1005 trbrf 101005 4472 - - 15 ibm - 0 0
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1005 trbrf 101005 4472 - - 15 ibm - 0 0
VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
802 0 0 off
1003 7 7 off
Primary Secondary Type Ports ------- --------- ----------------- ------------------------------------------
Table 33 describes the significant fields shown in the display.
show vlan counters
To display the software-cached counter values, use the show vlan counters command in privileged EXEC mode.
show vlan [id vlanid] counters
Syntax Description
id vlanid |
(Optional) Displays the software-cached counter values for a specific VLAN; valid values are from 1 to 4094. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
The show vlan id counters command is not supported on switch virtual interfaces (SVIs).
For Layer 2 and Layer 3 VLAN interfaces and router ports, per-interface switching statistics and VLAN-counter information to the Multilayer Switching Feature Card 2 (MSFC2) are exported approximately every 3 minutes.
If you enter the show vlan counters command with no arguments, the software-cached counter values for all VLANs are displayed.
Examples
This example shows how to display the software-cached counter values for a specific VLAN. The fields shown in the display are self-explanatory.
Router# show vlan id 205 counters
VLAN vlanid 205
L2-Unicast-Pkts 10
L3-In-Unicast-Pkts 0
L3-Out-Unicast-Pkts 0
L2-NonUnicast-Pkts + L3-In-NonUnicast-Pkts 5
L3-Out-NonUnicast-Pkts 6
L2-Unicast-Octets 6
L3-In-Unicast-Octets 6
L3-Out-Unicast-Octets 6
L2-NonUnicast-Octets + L3-In-NonUnicast-Octets 6
L3-Out-NonUnicast-Octets 6
Router#
Related Commands
|
|
---|---|
clear vlan counters |
Clears the software-cached counter values to zero for a specified VLAN or all existing VLANs. |
show vlan dot1q tag native
To display native VLAN-tagging information, use the show vlan dot1q tag native command in privileged EXEC mode.
show vlan dot1q tag native
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC (#)
Command History
Examples
This example shows how to display native VLAN-tagging information. The fields shown in the display are self-explanatory.
Router# show vlan dot1q tag native
dot1q native vlan tagging is enabled
Internal dot1q native vlan: 1015
Router#
Related Commands
|
|
---|---|
vlan dot1q tag native |
Enables dot1q tagging for all VLANs in a trunk. |
show vlan filter
To display information about the VLAN filter, use the show vlan filter command in privileged EXEC mode.
show vlan filter [access-map map-name | vlan vlan-id | interface interface interface-number]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
The show vlan filter map-name interface command accepts only ATM, packet over SONET/SDH (POS), or serial interface types. If your system is not configured with any of these interface types, the interface interface interface-number keyword and arguments are not provided.
The interface-number argument designates the module and port number. Valid values for interface-number depend on the specified interface type and the chassis and module that are used. For example, if you specify a Gigabit Ethernet interface and have a 48-port 10/100BASE-T Ethernet module that is installed in a 13-slot chassis, valid values for the module number are from 2 to 13 and valid values for the port number are from 1 to 48.
If you do not specify an optional keyword and argument, all mappings are displayed. If you enter access-map map_name, all the VLANs and interfaces that are associated with the specified map are shown. If you enter vlan vlan-id or interface interface interface-number, its associated access map, if existing, is shown.
In the output for VLAN access control lists (VACLs) on VLANs, the following applies:
•Configured on VLANs—User configured
•Active on VLANs—VLAN list on which the VACL is active
In the WAN-interface outputs, the following applies:
•Configured on interfaces—User configured
•Active on Interfaces—Interfaces on which the VACL is active
Examples
This example shows how to display mappings between the VACLs and the VLANs and the VACLs and the interfaces. The fields shown in the display are self-explanatory.
Router# show vlan filter
VLAN Map mordred:
Configured on VLANs: 2,4-6
Active on VLANs: 2,4-6
Router#
Related Commands
|
|
---|---|
vlan access-map |
Creates a VLAN access map or enters VLAN access-map command mode. |
vlan filter |
Applies a VLAN access map. |
show vlan free
To display the total number of free VLANs on a router, use the show vlan free command in privileged EXEC mode.
show vlan free
Syntax Description
This command has no arguments or keywords.
Command Default
All free VLANs are displayed.
Command Modes
Privileged EXEC (#)
Usage Guidelines
The show vlan free command displays the total number of free VLANs on a router.
Command History
|
|
---|---|
12.2(33)SRE |
This command was introduced on the Cisco 7600 series routers. |
Examples
The following is sample output from the show vlan free command. This example lists the number of free VLANs on a router. The fields shown in the display are self-explanatory.
Router#
show vlan free
Free VLANs
----------
2
3
4
5
6
7
8
9
10
Related Commands
|
|
---|---|
show vlan |
Displays the VLAN information in the system. |
show vlan free summary
To display the usage summary information for VLANs, use the show free vlan summary command in privileged EXEC mode.
show vlan free summary
Syntax Description
This command has no arguments or keywords.
Command Default
Usage summary information for all of the free VLANs is displayed.
Command Modes
Privileged EXEC (#)
Usage Guidelines
The show vlan free summary command displays the following VLAN information:
•Total number of available VLANs
•Total number of free VLANs
•Total number of used VLANs.
Command History
|
|
---|---|
12.2(33)SRE |
This command was introduced on the Cisco 7600 series routers. |
Examples
This example shows how to view the summary information for the existing VLANs in the system. The field descriptions shown in the display are self-explanatory.
Router# show vlan free summary
======= vlan free/usage Summary =======
Total number of available vlans = 4094
Total number of free vlans = 4074
Total number of used vlans = 20
Router#
Related Commands
|
|
---|---|
show vlan free |
Displays the total number of the free VLANs on a router. |
show vlan internal usage
To display information about the internal VLAN allocation, use the show vlan internal usage command in privileged EXEC mode.
show vlan [id vlan-id] internal usage
Syntax Description
id vlan-id |
(Optional) Displays information about the internal VLAN allocation for the specified VLAN; valid values are from 1 to 4094. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
In some cases, the output displays the following:
workaround vlan
A workaround VLAN is used to enable the Policy Feature Card (PFC)-based policing on the PWAN1 main interface. Without the workaround VLAN, the packets hit the PFC policer twice for PWAN1 because the same VLAN is used when packets traverse the local bus before and after Parallel eXpress Forwarding (PXF) processing.
Entering the show vlan internal usage command displays the Optical Services Module (OSM) interfaces and subinterfaces in addition to the regular Ethernet interfaces.
To display the associated subinterfaces, enter the show cwan vlan command. The show cwan vlan command displays the mapping between the WAN subinterface and the internal VLANs in use.
Examples
This example shows how to display the current internal VLAN allocation. The fields shown in the displays are self-explanatory.
Router# show vlan internal usage
VLAN Usage
---- --------------------
1025 -
1026 -
1027 -
1028 -
1029 Port-channel6
1030 GigabitEthernet1/2
1032 FastEthernet3/20
1033 FastEthernet3/21
1129 -
This example shows how to display the internal VLAN allocation for a specific VLAN:
Router# show vlan id 1030 internal usage
VLAN Usage
---- --------------------
1030 GigabitEthernet1/2
show vlan mapping
To register a mapping of an 802.1Q VLAN to an Inter-Switch Link (ISL) VLAN, use the show vlan mapping command in privileged EXEC mode.
show vlan mapping
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC (#)
Command History
Examples
This example shows how to list the map for an 802.1Q VLAN to an ISL VLAN. The fields shown in the display are self-explanatory.
Router# show vlan mapping
802.1Q Trunk Remapped VLANs:
802.1Q VLAN ISL VLAN
----------- -----------
101 202
200 330
Router#
Related Commands
|
|
---|---|
show interfaces vlan mapping |
Displays the status of a VLAN mapping on a port. |
switchport vlan mapping enable |
Enables VLAN mapping per switch port. |
show vlan port provisioning
To display the VLAN port provisioning status, use the show vlan port provisioning command in privileged EXEC mode.
show vlan port provisioning
Syntax Description
This command has no arguments or keywords.
Command Modes
Command History
|
|
---|---|
12.2(33)SXH |
This command was introduced. |
Examples
Router# show vlan port provisioning
port provision: disabled
Related Commands
|
|
---|---|
vlan port provisioning |
Enables or disables VLAN port provisioning. |
show vlan private-vlan
To display private VLAN (PVLAN) information, use the show vlan private-vlan command in privileged EXEC mode.
show vlan private-vlan [type]
Syntax Description
type |
(Optional) Displays the PVLAN type (isolated, community, or primary). |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
In the show vlan private-vlan type command output display, "normal" displayed as a type indicates a regular VLAN that is configured in a PVLAN. A display of "normal" means that two VLANs have been associated before the type was set and that the PVLAN is not operational. This information is useful for debugging purposes.
Examples
This example shows how to display information about all currently configured PVLANs:
Router#
show vlan private-vlan
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
2 301 community Fa5/3, Fa5/25
2 302 community
10 community
100 101 isolated
150 151 non-operational
202 community
303 community
401 402 non-operational
Router#
This example shows how to display information about all currently configured PVLAN types:
Router#
show vlan private-vlan type
Vlan Type
---- -----------------
202 primary
303 community
304 community
305 community
306 community
307 community
308 normal
309 community
440 isolated
Router#
Table 34 describes the fields that are shown in the example.
Related Commands
show vlan remote-span
To display a list of remote Switched Port Analyzer (RSPAN) VLANs, use the show vlan remote-span command in privileged EXEC mode.
show vlan remote-span
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC (#)
Command History
Examples
This example shows how to display a list of remote SPAN VLANs. The fields shown in the display are self-explanatory.
Router#
show vlan remote-span
Remote SPAN VLANs
------------------------------------------------------------------------------
2,20
Related Commands
|
|
---|---|
remote-span |
Configures a VLAN as an RSPAN VLAN. |
vlan (config-VLAN submode) |
Configures a specific VLAN. |
show vlan virtual-port
To display the number of logical virtual ports required, use the show vlan virtual-port command in privileged EXEC mode.
show vlan virtual-port [slot number]
Syntax Description
slot number |
(Optional) Specifies the slot number of which status is to be displayed. |
Command Modes
Privileged EXEC (#)
Command History
Examples
This example shows how to display the number of logical virtual ports that are required for a specific slot. The fields shown in the display are self-explanatory.
Router#
show vlan virtual-port slot 3
Slot 3
Port Virtual-ports
-------------------------
Fa3/1 1
Fa3/2 1
Fa3/3 1
Fa3/4 1
Fa3/5 1
Fa3/6 1
Fa3/7 1
Fa3/8 1
Fa3/11 1
Fa3/12 1
Fa3/13 1
.
.
.
Fa3/33 4
Fa3/34 4
Fa3/35 4
Fa3/36 4
Fa3/37 4
Fa3/38 4
Fa3/39 4
Fa3/40 4
Total virtual ports:82
Router#
This example shows how to display the number of logical virtual ports that are required for all slots. The fields shown in the display are self-explanatory.
Router#
show vlan virtual-port
Slot 1
-------
Total slot virtual ports 1
Slot 3
-------
Total slot virtual ports 82
Slot 4
-------
Total slot virtual ports 4
Total chassis virtual ports 87
Router#
show vlan-range
To display the VLAN range, use the show vlan-range command in privileged EXEC mode.
show vlan-range
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC (#)
Command History
Examples
The following is sample output from the show vlan-range command. The field descriptions in the display are self-explanatory.
Router# show vlan-range
IDB-less VLAN Ranges on FastEthernet0/1 (1 ranges)
7-67 (range)
Related Commands
|
|
---|---|
vlan-range dot1q |
Enables IEEE 802.1Q VLAN encapsulation for a range of VLANs on Ethernet interface. |
show vlans
To display VLAN subinterfaces, use the show vlans command in privileged EXEC mode.
show vlans
Catalyst 6500 Series Switches and Cisco 7600 Series Routers
show vlans [vlan]
Syntax Description
vlan |
(Optional) VLAN ID number; valid values are from 1 to 4094. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
On the Catalyst 6500 series switches and Cisco 7600 series routers, the EXEC show vlan command displays information about the Layer 2 VLAN. The privileged EXEC show vlans command displays information about the VLAN subinterface in Layer 3.
When entering the show vlans command, you cannot shorten the vlans keyword.
If you want to view the Layer 3 statistics, do not use the show vlans command, instead use the show interface vlan vlan-num stats command or the show interface vlan vlan-num accounting command.
Examples
The following is sample output from the show vlans command:
Router# show vlans
Virtual LAN ID: 2 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: FastEthernet5/0.1
Protocols Configured: Address: Received: Transmitted:
IP 10.0.0.3 16 92129
Virtual LAN ID: 3 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: Ethernet6/0/1.1
Protocols Configured: Address: Received: Transmitted:
IP 10.0.0.5 1558 1521
Virtual LAN ID: 4 (Inter Switch Link Encapsulation)
vLAN Trunk Interface: FastEthernet5/0.2
Protocols Configured: Address: Received: Transmitted:
IP 10.0.0.7 0 7
The following is sample output from the show vlans command indicating a native VLAN and a bridged group:
Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: FastEthernet1/0/2
This example shows how to display information about the Cisco IOS VLAN subinterfaces:
Router#
show vlans
Virtual LAN ID: 122 (Inter Switch Link Encapsulation)
VLAN Trunk Interface: GE-WAN9/1.1
Protocols Configured: Address: Received: Transmitted:
IP 10.122.0.2 18 16
Virtual LAN ID: 123 (Inter Switch Link Encapsulation)
VLAN Trunk Interface: GE-WAN9/1.2
Protocols Configured: Address: Received: Transmitted:
IP 10.123.0.2 13 16
Virtual LAN ID: 124 (Inter Switch Link Encapsulation)
VLAN Trunk Interface: GE-WAN9/1.3
Protocols Configured: Address: Received: Transmitted:
IP 10.124.0.2 0 17
Virtual LAN ID: 133 (Inter Switch Link Encapsulation)
VLAN Trunk Interface: GE-WAN9/3.1
Protocols Configured: Address: Received: Transmitted:
IP 10.133.0.1 0 1
Virtual LAN ID: 134 (Inter Switch Link Encapsulation)
VLAN Trunk Interface: GE-WAN9/3.2
Protocols Configured: Address: Received: Transmitted:
IP 10.134.0.1 0 1
This VLAN is configured as a native VLAN for the following interfaces:
FastEthernet1/0/2
Protocols Configured: Address: Received: Transmitted:
Virtual LAN ID: 100 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: FastEthernet1/0/2.1
Protocols Configured: Address: Received: Transmitted:
Bridging Bridge Group 1 0 0
The following is sample output from the show vlans command that shows the traffic count on Fast Ethernet subinterfaces:
Router# show vlans
Virtual LAN ID: 2 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: FastEthernet5/0.1
Protocols Configured: Address: Received: Transmitted:
IP 172.16.0.3 16 92129
Virtual LAN ID: 3 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: Ethernet6/0/1.1
Protocols Configured: Address: Received: Transmitted:
IP 172.20.0.3 1558 1521
Virtual LAN ID: 4 (Inter Switch Link Encapsulation)
vLAN Trunk Interface: FastEthernet5/0.2
Protocols Configured: Address: Received: Transmitted:
IP 172.30.0.3 0 7
Table 35 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
vlan database |
Enters VLAN configuration mode. |
vlan (VLAN) |
Configures a specific VLAN. |
show vlans dot1q
To display statistics about 802.1Q VLAN subinterfaces, use the show vlans dot1q command in privileged EXEC mode.
show vlans dot1q [internal | interface-type interface-number.subinterface-number [detail] | outer-id [interface-type interface-number | second-dot1q [inner-id | any]] [detail]]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
If no arguments or keywords are entered, statistics for all of the 802.1Q VLAN IDs are displayed.
The any keyword is not supported for IPoQinQ because IP routing is not supported on ambiguous subinterfaces. However, the second-dot1q inner-id keyword and argument can be used on IPoQinQ for a specific inner VLAN ID that is not an ambiguous subinterface.
Note On the Cisco 10000 series router, the following is an implementation limitation—when a service policy is applied to a PPPoEoQinQ or IPoQinQ subinterface and the service policy drops some packets, the packets dropped are still displayed in the outgoing packet counters as output.
Note For the Cisco ASR 1000 Series Aggregation Services Router only, the command output includes the total number of packets dropped from the shared port adapter (SPA) because of ingress oversubscription on the VLAN. An example of the output is included in the "Cisco ASR 1000 Series Router: Example" section below.
Examples
802.1Q VLAN Statistics: Example
The output from the show vlans dot1q command displays the statistics for all the 802.1Q VLAN IDs. Only the outer VLAN IDs are displayed here.
Router# show vlans dot1q
Total statistics for 802.1Q VLAN 1:
441 packets, 85825 bytes input
1028 packets, 69082 bytes output
Total statistics for 802.1Q VLAN 101:
5173 packets, 510384 bytes input
3042 packets, 369567 bytes output
Total statistics for 802.1Q VLAN 201:
1012 packets, 119254 bytes input
1018 packets, 120393 bytes output
Total statistics for 802.1Q VLAN 301:
3163 packets, 265272 bytes input
1011 packets, 120750 bytes output
Total statistics for 802.1Q VLAN 401:
1012 packets, 119254 bytes input
1010 packets, 119108 bytes output
Table 36 describes the significant fields shown in the display.
The following sample output from the show vlans dot1q command displays the statistics for the 802.1Q VLAN subinterface configured on Gigabit Ethernet interface 5/0:
Router# show vlans dot1q GigabitEthernet 5/0.1011001
GigabitEthernet5/0.1011001 (101/1001)
1005 packets, 122556 bytes input
1023 packets, 125136 bytes output
Table 37 describes the significant fields shown in the display.
The following sample output from the show vlans dot1q command displays the summary statistics for all of the VLAN subinterfaces under the physical interface Gigabit Ethernet 5/0 that have an outer VLAN ID of 101:
Router# show vlans dot1q 101 GigabitEthernet 5/0
Total statistics for 802.1Q VLAN 101 on GigabitEthernet5/0:
5218 packets, 513444 bytes input
3042 packets, 369567 bytes output
The following sample output from the show vlans dot1q command displays the individual subinterface statistics and summary statistics for all the VLAN subinterfaces under the physical interface Gigabit Ethernet 5/0 that have an outer VLAN ID of 101:
Router# show vlans dot1q 101 GigabitEthernet 5/0 detail
GigabitEthernet5/0.101 (0)
3220 packets, 269148 bytes input
1008 packets, 119622 bytes output
GigabitEthernet5/0.1019999 (101/1-1000,1003-2000)
0 packets, 0 bytes input
3 packets, 1143 bytes output
GigabitEthernet5/0.1011001 (101/1001)
1005 packets, 122556 bytes input
1023 packets, 125136 bytes output
GigabitEthernet5/0.1011002 (101/1002)
1005 packets, 122556 bytes input
1008 packets, 123666 bytes output
Total statistics for 802.1Q VLAN 101 on GigabitEthernet5/0:
5230 packets, 514260 bytes input
3042 packets, 369567 bytes output
The following sample output from the show vlans dot1q command displays the statistics for an outer VLAN and inner VLAN ID combination. This is a summary that displays the total for all the subinterfaces on the router that are configured with the specified IDs.
Note When multiple inner VLANs are used, the statistics displayed are at subinterface-level granularity, not VLAN-ID granularity. For example, when a range of inner VLAN IDs is assigned to a subinterface, the statistics are reported only at the subinterface level. Statistics are not available for each inner VLAN ID.
Router# show vlans dot1q 101 second-dot1q 1001 detail
GigabitEthernet5/0.1011001 (101/1001)
1005 packets, 122556 bytes input
1023 packets, 125136 bytes output
Total statistics for Outer/Inner VLAN 101/1001:
1005 packets, 122556 bytes input
1023 packets, 125136 bytes output
The following sample output from the show vlans dot1q command displays the statistics for a specific outer VLAN ID of 301 and an inner VLAN ID of any. This is a summary that displays the total for all of the subinterfaces on the router that are configured with the specified IDs.
Router# show vlans dot1q 301 second-dot1q any
GigabitEthernet5/0.301999 (301/any)
0 packets, 0 bytes input
3 packets, 1128 bytes output
Total statistics for Outer/Inner VLAN 301/"any":
0 packets, 0 bytes input
3 packets, 1128 bytes output
QinQ Subsystem Information: Example
The following sample output from the show vlans dot1q command displays some internal information about the QinQ subsystem and is used for troubleshooting purposes (typically by Cisco engineers):
Router# show vlans dot1q internal
Internal VLAN representation on FastEthernet0/0:
VLAN Id: 1 (.1Q, Fa0/0)
VLAN Id: 201 (.1Q-in-.1Q tree, 3 elements)
Inner VLAN Id: (0 -0 ) Fa0/0.201
dot1q software subblock bitlist missing
Inner VLAN Id: (2001-2001) Fa0/0.2012001
2001
Inner VLAN Id: (2002-2002) Fa0/0.2012002
2002
"any" Fa0/0.201999
VLAN Id: 401 (.1Q-in-.1Q tree, 3 elements)
Inner VLAN Id: (0 -0 ) Fa0/0.401
dot1q software subblock bitlist missing
Inner VLAN Id: (100 -900 ) Fa0/0.4019999
100-900,1001-2000
Inner VLAN Id: (1001-2000) Fa0/0.4019999
100-900,1001-2000
Internal VLAN representation on GigabitEthernet5/0:
VLAN Id: 1 (.1Q, Gi5/0)
VLAN Id: 101 (.1Q-in-.1Q tree, 5 elements)
Inner VLAN Id: (0 -0 ) Gi5/0.101
dot1q software subblock bitlist missing
Inner VLAN Id: (1 -1000) Gi5/0.1019999
1-1000,1003-2000
Inner VLAN Id: (1001-1001) Gi5/0.1011001
1001
Inner VLAN Id: (1002-1002) Gi5/0.1011002
1002
Inner VLAN Id: (1003-2000) Gi5/0.1019999
1-1000,1003-2000
VLAN Id: 301 (.1Q-in-.1Q tree, 1 elements)
Inner VLAN Id: (0 -0 ) Gi5/0.301
dot1q software subblock bitlist missing
"any" Gi5/0.301999
Cisco ASR 1000 Series Router: Example
The following is an example of the output displayed on the Cisco ASR 1000 series router only. For the Cisco ASR 1000 series router only, the command output includes the total number of packets dropped from the SPA due to ingress over subscription on the VLAN.
Router# show vlans dot1q gigabitEthernet 0/0/3.1
GigabitEthernet0/0/3.1 (0)
133279760 packets, 8529904640 bytes input
0 packets, 0 bytes output
121997683 oversub packet drops
Table 38 describes the significant fields shown in the display.
Related Commands
show vlans tokenring
To display Token Ring VLANs, use the show vlans tokenring command in user EXEC or privileged EXEC mode.
show vlans tokenring
Syntax Description
This command has no arguments or keywords.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Examples
The following example shows how to use the show vlans tokenring command. The fields shown in the display are self-explanatory.
Router# show vlans tokenring
When the show vlans tokenring command is executed on a device with the Token Ring configurations, the output consists of a list of Token Ring interfaces with VLAN configuration.
Related Commands
show vlan-switch
To display VLAN information, use the show vlan-switch command in user EXEC or privileged EXEC mode.
show vlan-switch [brief | id vlan | internal usage | name name | summary]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(2)XT |
This command was introduced. |
12.2(8)T |
This command was integrated into Cisco IOS Release 12.2(8)T. |
Usage Guidelines
Each Ethernet switch port and Ethernet repeater group belongs to only one VLAN. Trunk ports can be on multiple VLANs.
Examples
The following is sample output from the example show vlan-switch command, which displays the VLAN parameters for all VLANs within the administrative domain:
Router# show vlan-switch
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa4/0, Fa4/1, Fa4/2, Fa4/3
Fa4/4, Fa4/5, Fa4/6, Fa4/7
Fa4/8, Fa4/9, Fa4/10, Fa4/11
Fa4/12, Fa4/13, Fa4/14, Fa4/15
Fa4/16, Fa4/17, Fa4/18, Fa4/19
Fa4/20, Fa4/21, Fa4/22, Fa4/23
Fa4/24, Fa4/25, Fa4/26, Fa4/27
Fa4/28, Fa4/29, Fa4/30, Fa4/31
Fa4/32, Fa4/33, Fa4/34, Fa4/35
Gi4/0, Gi4/1, Po1
2 VLAN0002 active
3 VLAN0003 active
5 VLAN0005 active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
5 enet 100005 1500 - - - - - 0 0
1002 fddi 101002 1500 - 0 - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 ibm - 0 0
1005 trnet 101005 1500 - - 1 ibm - 0 0
Table 39 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
vlan (VLAN) |
Configures specific VLANs. |
show vtp
To display general information about the VLAN Trunking Protocol (VTP) management domain, status, and counters, use the show vtp command in privileged EXEC mode.
show vtp {counters | interface [type/number] | status | password | devices [conflicts]}
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
In the output of the show vtp status command, the last modified time is of the modifier itself. For example, the time displayed in the line "Configuration last modified by 7.0.22.11 at 5-5-06 05:51:49", is the time that the modifier (7.0.22.11) last modified the VLAN configuration.
Examples
The following is sample output from the show vtp counters command:
Router# show vtp counters
VTP statistics:
Summary advertisements received : 0
Subset advertisements received : 0
Request advertisements received : 0
Summary advertisements transmitted : 6970
Subset advertisements transmitted : 0
Request advertisements transmitted : 0
Number of config revision errors : 0
Number of config digest errors : 0
Number of V1 summary errors : 0
VTP pruning statistics:
Trunk Join Transmitted Join Received Summary advts received from non-pruning-capable device
---------------- ---------------- ---------------- ---------------------------
Gi1/11 0 0 0
Gi8/10 0 0 0
Gi8/15 0 0 0
Gi8/16 0 0 0
Fa3/1 0 0 0
Fa3/2 0 0 0
Router#
This example shows how to display only those lines in the show vtp output that contain the word Summary:
Router# show vtp counters | include Summary
Summary advertisements received : 1
Summary advertisements transmitted : 32
Trunk Join Transmitted Join Received Summary advts received from
Router#
This example shows how to display general information about the VTP management domain:
Router# show vtp status
VTP Version capable : 1 to 3
VTP version running : 2
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 0012.44dc.b800
MD5 digest : 0x61 0x98 0xD0 0xAD 0xA4 0x8C 0x53 0x35
Configuration last modified by 10.10.0.0 at 8-7-06 06:56:27
Local updater ID is 10.10.0.0 on interface Lo0 (first layer3 interface found)
Feature VLAN:
--------------
VTP Mode : Server
Maximum VLANs supported locally : 1005
Number if existing VLANs : 53
Revision : 1
Router#
Table 40 describes the significant fields shown in the display.
The following is sample output from the show vtp status command for VTP version 1 and VTP version 2:
Router# show vtp status
VTP Version : 3 (capable)
Configuration Revision : 1
Maximum VLANs supported locally : 1005
Number of existing VLANs : 37
VTP Operating Mode : Server
VTP Domain Name : [smartports]
VTP Pruning Mode : Disabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0x26 0xEE 0x0D 0x84 0x73 0x0E 0x1B 0x69
Configuration last modified by 172.20.52.19 at 7-25-08 14:33:43
Local updater ID is 172.20.52.19 on interface Gi5/2 (first layer3 interface fou)
VTP version running : 2
Table 41 describes the significant fields shown in the display.
The following is sample output from the show vtp status command for all three VTP versions on the Cisco 7600 series routers running Release 12.2(33)SRC and later.
This example shows how to verify the configuration when the device is running VTP version 1:
Router# show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : Lab_Network
VTP Pruning Mode : Enabled
VTP Traps Generation : Disabled
Device ID : 0016.9c6d.5300
Configuration last modified by 127.0.0.12 at 10-18-07 10:12:42
Local updater ID is 127.00.12 at 10-18-07 10:2:42
Feature VLAN:
--------------
VTP Operating Mode : Server
Maximum number of existing VLANs : 5
Configuration Revision : 1
MD5 digest : 0x92 0xF1 0xE8 0x52 0x2E ox5C 0x36 0x10 0x70 0x61 0xB8 0x24 0xB6 0x93 0x21 0x09
Router#
This example shows how to verify the configuration when the device is running VTP version 2:
Router# show vtp status
VTP Version capable : 1 to 3
VTP version running : 2
VTP Domain Name : Lab_Network
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 0012.44dc.b800
Configuration lst modified by 127.0.0.12 at 10-18-07 10:38:45
Local updater ID is 127.0.0.12 on interface EO 0/0 (first interface found)
Feature VLAN:
--------------
VTP Operating Mode : Server
Maximum VLANs supported locally: 1005
Number of existing VLANs : 1005
Configuration Revision : 1
MD5 digest : 0x2E 0x6B 0x99 0x58 0xA2 0x4F 0xD5 0x150x70 0x61 0xB8 0x24 0xB6 0x93 0x21 0x09
Router#
This example shows how to verify the configuration when the device is running VTP version 3:
Router# show vtp status
VTP Version capable : 1 to 3
VTP version running : 3
VTP Domain Name : Lab_Network
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 0012.44dc.b800
Feature VLAN:
--------------
VTP Operating Mode : Server
Number of existing VLANs : 1005
Number of existing extended VLANs: 3074
Configuration Revision : 18
Primary ID : 0012.4371.9ec0
Primary Description :
Router#
Table 42 describes the significant fields shown in the displays.
This example shows how to display information for a specific interface:
Router# show vtp interface GigabitEthernet2/4
Interface VTP Status
------------------------------------
GigabitEthernet2/4 enabled
This example shows how a password is displayed when it is configured using the hidden keyword (VTP version 3 only):
Router# show vtp password
VTP Password: 89914640C8D90868B6A0D8103847A733
Router#
This example shows how to display information about all VTP devices in the domain:
Router# show vtp devices
Gathering information from the domain, please wait.
VTP Database Conf switch ID Primary Server Revision System Name
lict
------------ ---- -------------- ------------------------ ------------------
VLAN Yes 00b0.8e50.d000 000c.0412.6300 12354 main.cisco.com
MST No 00b0.8e50.d000 0004.AB45.6000 24 main.cisco.com
VLAN Yes 000c.0412.6300=000c.0412.6300 67 querty.cisco.com
Table 43 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
clear vtp counters |
Clears the VTP and pruning counters. |
vtp |
Configures the VTP mode. |
shutdown vlan
To shut down local traffic on a specified VLAN, use the shutdown vlan command in global configuration mode. To restart local traffic on the VLAN, use the no form of this command.
shutdown vlan vlan-id
no shutdown vlan vlan-id
Syntax Description
vlan-id |
VLAN number of the VLAN to be locally shut down; valid values are from 2 to 1001. |
Command Default
Local traffic on a specified VLAN is not shut down.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
This command does not support extended-range VLANs.
Examples
This example shows how to shut down traffic on VLAN 2:
Router(config)#
shutdown vlan 2
snmp trap mac-notification change
To enable the Simple Network Management Protocol (SNMP) trap notification on a LAN port when MAC addresses are added to or removed from the address table, use the snmp trap mac-notification change command in interface configuration mode. To disable the SNMP trap notification on a LAN port when MAC addresses are added to or removed from the address table, use the no form of this command.
snmp trap mac-notification change [added | removed]
no snmp trap mac-notification change
Syntax Description
added |
(Optional) Sends notification only when a MAC address is added to the table. |
removed |
(Optional) Sends notification only when a MAC address is removed to the table. |
Command Default
The SNMP trap notification is disabled.
Command Modes
Interface configuration (config-if)
Command History
|
|
---|---|
12.2(33)SXH |
This command was introduced. |
Examples
The following example shows how to enable the SNMP trap notification on a LAN port when MAC addresses are added to the address table:
Router(config-if)# snmp trap mac-notification change added
The following example shows how to enable the SNMP trap notification on a LAN port when MAC addresses are removed from the address table:
Router(config-if)# snmp trap mac-notification change removed
The following example shows how to disable the SNMP trap notification on a LAN port:
Router(config-if)# no snmp trap mac-notification change
Related Commands
|
|
---|---|
mac-address-table notification change |
Sends a notification of the dynamic changes to the MAC address table. |
spanning-tree backbonefast
To enable BackboneFast to allow a blocked port on a switch to change immediately to a listening mode, use the spanning-tree backbonefast command in global configuration mode. To return to the default setting, use the no form of this command.
spanning-tree backbonefast
no spanning-tree backbonefast
Syntax Description
This command has no arguments or keywords.
Command Default
BackboneFast is disabled.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
BackboneFast should be enabled on all of the Cisco routers containing an Ethernet switch network module. BackboneFast provides for fast convergence in the network backbone after a spanning-tree topology change. It enables the switch to detect an indirect link failure and to start the spanning-tree reconfiguration sooner than it would under normal spanning-tree rules.
Use the show spanning-tree privileged EXEC command to verify your settings.
Examples
The following example shows how to enable BackboneFast on the switch:
Router(config)# spanning-tree backbonefast
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree bpdufilter
To enable bridge protocol data unit (BPDU) filtering on the interface, use the spanning-tree bpdufilter command in interface configuration mode. To return to the default settings, use the no form of this command.
spanning-tree bpdufilter {enable | disable}
no spanning-tree bpdufilter
Syntax Description
enable |
Enables BPDU filtering on this interface. |
disable |
Disables BPDU filtering on this interface. |
Command Default
The setting that is already configured when you enter the spanning-tree portfast bpdufilter default command.
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
Entering the spanning-tree bpdufilter enable command to enable BPDU filtering overrides the PortFast configuration.
When configuring Layer 2-protocol tunneling on all the service-provider edge switches, you must enable spanning-tree BPDU filtering on the 802.1Q tunnel ports by entering the spanning-tree bpdufilter enable command.
BPDU filtering prevents a port from sending and receiving BPDUs. The configuration is applicable to the whole interface, whether it is trunking or not. This command has three states:
•spanning-tree bpdufilter enable—Unconditionally enables BPDU filtering on the interface.
•spanning-tree bpdufilter disable—Unconditionally disables BPDU filtering on the interface.
•no spanning-tree bpdufilter—Enables BPDU filtering on the interface if the interface is in operational PortFast state and if you configure the spanning-tree portfast bpdufilter default command.
Use the spanning-tree portfast bpdufilter default command to enable BPDU filtering on all ports that are already configured for PortFast.
Examples
This example shows how to enable BPDU filtering on this interface:
Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree portfast bpdufilter default |
Enables BPDU filtering by default on all PortFast ports. |
spanning-tree bpduguard
To enable bridge protocol data unit (BPDU) guard on the interface, use the spanning-tree bpduguard command in interface configuration mode. To return to the default settings, use the no form of this command.
spanning-tree bpduguard {enable | disable}
no spanning-tree bpduguard
Syntax Description
enable |
Enables BPDU guard on this interface. |
disable |
Disables BPDU guard on this interface. |
Command Default
The setting that is already configured when you enter the spanning-tree portfast bpduguard default command.
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
BPDU guard prevents a port from receiving BPDUs. Typically, this feature is used in a service-provider environment where the network administrator wants to prevent an access port from participating in the spanning tree. If the port still receives a BPDU, it is put in the error-disabled state as a protective measure. This command has three states:
•spanning-tree bpduguard enable—Unconditionally enables BPDU guard on the interface.
•spanning-tree bpduguard disable—Unconditionally disables BPDU guard on the interface.
•no spanning-tree bpduguard—Enables BPDU guard on the interface if it is in the operational PortFast state and if the spanning-tree portfast bpduguard default command is configured.
Examples
This example shows how to enable BPDU guard on this interface:
Router(config-if)# spanning-tree bpduguard enable
Router(config-if)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree portfast bpduguard default |
Enables BPDU guard by default on all PortFast ports. |
spanning-tree bridge assurance
To enable Bridge Assurance on all network ports on the switch, use the spanning-tree bridge assurance command in global configuration mode. To disable Bridge Assurance, use the no form of this command.
spanning-tree bridge assurance
no spanning-tree bridge assurance
Syntax Description
This command has no arguments or keywords.
Command Default
Bridge Assurance is enabled.
Command Modes
Global configuration (config)
Command History
|
|
12.2(33)SXI |
Support for this command was introduced. |
Usage Guidelines
Bridge Assurance protects against a unidirectional link failure or other software failure and a device that continues to forward data traffic when it is no longer running the spanning tree algorithm.
Bridge Assurance is enabled only on spanning tree network ports that are point-to-point links. Both ends of the link must have Bridge Assurance enabled. If the device on one side of the link has Bridge Assurance enabled and the device on the other side either does not support Bridge Assurance or does not have this feature enabled, the connecting port is blocked.
Disabling Bridge Assurance causes all configured network ports to behave as normal spanning tree ports.
Examples
This example shows how to enable Bridge Assurance on all network ports on the switch:
Router(config)#
spanning-tree bridge assurance
Router(config)#
This example shows how to disable Bridge Assurance on all network ports on the switch:
Router(config)#
no spanning-tree bridge assurance
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree cost
To set the path cost of the interface for Spanning Tree Protocol (STP) calculations, use the spanning-tree cost command in interface configuration mode. To revert to the default value, use the no form of this command.
spanning-tree cost cost
no spanning-tree cost
Syntax Description
cost |
Path cost; valid values are from 1 to 200000000 for Cisco IOS Releases 12.1(3a)E and later releases and from 1 to 65535 for Cisco IOS releases prior to Cisco IOS Release 12.1(3a)E. |
Command Default
The default path cost is computed from the bandwidth setting of the interface; default path costs are:
Ethernet: 100
16-Mb Token Ring: 62
FDDI: 10
FastEthernet: 10
ATM 155: 6
GigibitEthernet: 1
HSSI: 647
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
When you specify a value for the cost argument, higher values indicate higher costs. This range applies regardless of the protocol type specified.
Examples
The following example shows how to access an interface and set a path cost value of 250 for the spanning tree VLAN associated with that interface:
Router(config)# interface ethernet 2/0
Router(config-if)# spanning-tree cost 250
Related Commands
spanning-tree etherchannel guard misconfig
To display an error message when a loop due to a channel misconfiguration is detected, use the spanning-tree etherchannel guard misconfig command in global configuration mode. To disable the error message, use the no form of this command.
spanning-tree etherchannel guard misconfig
no spanning-tree etherchannel guard misconfig
Syntax Description
This command has no arguments or keywords.
Command Default
Error messages are displayed.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
EtherChannel uses either Port Aggregation Protocol (PAgP) or Link Aggregation Control Protocol (LACP) and does not work if the EtherChannel mode of the interface is enabled using the channel-group group-number mode on command.
The spanning-tree etherchannel guard misconfig command detects two types of errors: misconfiguration and misconnection errors. A misconfiguration error is an error between the port-channel and an individual port. A misconnection error is an error between a switch that is channeling more ports and a switch that is not using enough Spanning Tree Protocol (STP) Bridge Protocol Data Units (BPDUs) to detect the error. In this case, the switch will only error disable an EtherChannel if the switch is a nonroot switch.
When an EtherChannel-guard misconfiguration is detected, this error message displays:
msgdef(CHNL_MISCFG, SPANTREE, LOG_CRIT, 0, "Detected loop due to etherchannel
misconfiguration of %s %s")
To determine which local ports are involved in the misconfiguration, enter the show interfaces status err-disabled command. To check the EtherChannel configuration on the remote device, enter the show etherchannel summary command on the remote device.
After you correct the configuration, enter the shutdown and the no shutdown commands on the associated port-channel interface.
Examples
This example shows how to enable the EtherChannel-guard misconfiguration:
Router(config)#
spanning-tree etherchannel guard misconfig
Router(config)#
Related Commands
spanning-tree extend system-id
To enable the extended-system ID feature on chassis that support 1024 MAC addresses, use the spanning-tree extend system-id command in global configuration mode. To disable the extended system identification, use the no form of this command.
spanning-tree extend system-id
no spanning-tree extend system-id
Syntax Description
This command has no arguments or keywords.
Command Default
Enabled on systems that do not provide 1024 MAC addresses.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
The Catalyst 6500 series switch can support 64 or up to 1024 MAC addresses. For a Catalyst 6500 series switch with 64 MAC addresses, STP uses the extended-system ID and a MAC address to make the bridge ID unique for each VLAN.
You cannot disable the extended-system ID on a Catalyst 6500 series switch that supports 64 MAC addresses.
Enabling or disabling the extended-system ID updates the bridge IDs of all active Spanning Tree Protocol (STP) instances, which might change the spanning-tree topology.
Examples
This example shows how to enable the extended-system ID:
Router(config)# spanning-tree extend system-id
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree guard
To enable or disable the guard mode, use the spanning-tree guard command in interface configuration mode. To return to the default settings, use the no form of this command.
spanning-tree guard {loop | root | none}
no spanning-tree guard
Syntax Description
loop |
Enables the loop-guard mode on the interface. |
root |
Enables root-guard mode on the interface. |
none |
Sets the guard mode to none. |
Command Default
Guard mode is disabled.
Command Modes
Interface configuration (config-if)
Command History
Examples
This example shows how to enable root guard:
Router(config-if)# spanning-tree guard root
Router(config-if)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree loopguard default |
Enables loop guard as a default on all ports of a given bridge. |
spanning-tree link-type
To configure a link type for a port, use the spanning-tree link-type command in the interface configuration mode. To return to the default settings, use the no form of this command.
spanning-tree link-type {point-to-point | shared}
no spanning-tree link-type
Syntax Description
point-to-point |
Specifies that the interface is a point-to-point link. |
shared |
Specifies that the interface is a shared medium. |
Command Default
Link type is automatically derived from the duplex setting unless you explicitly configure the link type.
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
Rapid Spanning Tree Protocol Plus (RSTP+) fast transition works only on point-to-point links between two bridges.
By default, the switch derives the link type of a port from the duplex mode. A full-duplex port is considered as a point-to-point link while a half-duplex configuration is assumed to be on a shared link.
If you designate a port as a shared link, RSTP+ fast transition is forbidden, regardless of the duplex setting.
Examples
This example shows how to configure the port as a shared link:
Router(config-if)# spanning-tree link-type shared
Router(config-if)#
Related Commands
|
|
---|---|
show spanning-tree interface |
Displays information about the spanning-tree state. |
spanning-tree loopguard default
To enable loop guard as a default on all ports of a given bridge, use the spanning-tree loopguard default command in global configuration mode. To disable loop guard, use the no form of this command.
spanning-tree loopguard default
no spanning-tree loopguard default
Syntax Description
This command has no arguments or keywords.
Command Default
Loop guard is disabled.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
Loop guard provides additional security in the bridge network. Loop guard prevents alternate or root ports from becoming the designated port due to a failure that could lead to a unidirectional link.
Loop guard operates only on ports that are considered point to point by the spanning tree.
The individual loop-guard port configuration overrides this command.
Examples
This example shows how to enable loop guard:
Router(config)#
spanning-tree loopguard default
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree guard |
Enables or disables the guard mode. |
spanning-tree mode
To switch between Per-VLAN Spanning Tree+ (PVST+), Rapid-PVST+, and Multiple Spanning Tree (MST) modes, use the spanning-tree mode command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mode [pvst | mst | rapid-pvst]
no spanning-tree mode
Syntax Description
pvst |
(Optional) PVST+ mode. |
mst |
(Optional) MST mode. |
rapid-pvst |
(Optional) Rapid-PVST+ mode. |
Command Default
pvst
Command Modes
Global configuration (config)
Command History
Usage Guidelines
Examples
This example shows how to switch to MST mode:
Router(config)#
spanning-tree mode mst
Router(config)#
This example shows how to return to the default mode (PVST+):
Router(config)#
no spanning-tree mode
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst
To set the path cost and port-priority parameters for any Multiple Spanning Tree (MST) instance (including the Common and Internal Spanning Tree [CIST] with instance ID 0), use the spanning-tree mst command in interface configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst instance-id {{cost cost | port-priority priority} | pre-standard}
no spanning-tree mst instance-id {{cost | port-priority} | pre-standard}
Syntax Description
Command Default
The defaults are as follows:
•cost depends on the port speed; the faster interface speeds indicate smaller costs. MST always uses long path costs.
•priority is 128.
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
Higher cost cost values indicate higher costs. When entering the cost, do not include a comma in the entry; for example, enter 1000, not 1,000.
Higher port-priority priority values indicate smaller priorities.
Examples
This example shows how to set the interface path cost:
Router(config-if)#
spanning-tree mst 0 cost 17031970
Router(config-if)#
This example shows how to set the interface priority:
Router(config-if)#
spanning-tree mst 0 port-priority 64
Router(config-if)#
Related Commands
spanning-tree mst configuration
To enter MST-configuration submode, use the spanning-tree mst configuration command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst configuration
no spanning-tree mst configuration
Syntax Description
This command has no arguments or keywords.
Command Default
The default value for the Multiple Spanning Tree (MST) configuration is the default value for all its parameters:
•No VLANs are mapped to any MST instance (all VLANs are mapped to the Common and Internal Spanning Tree [CIST] instance).
•The region name is an empty string.
•The revision number is 0.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
The MST configuration consists of three main parameters:
•Instance VLAN mapping—See the instance command
•Region name—See the name (MST configuration submode) command
•Configuration revision number—See the revision command
The abort and exit commands allow you to exit MST configuration submode. The difference between the two commands depends on whether you want to save your changes or not.
The exit command commits all the changes before leaving MST configuration submode. If you do not map secondary VLANs to the same instance as the associated primary VLAN, when you exit MST-configuration submode, a warning message displays and lists the secondary VLANs that are not mapped to the same instance as the associated primary VLAN. The warning message is as follows:
These secondary vlans are not mapped to the same instance as their primary:
-> 3
The abort command leaves MST-configuration submode without committing any changes.
Changing an MST-configuration submode parameter can cause connectivity loss. To reduce service disruptions, when you enter MST-configuration submode, make changes to a copy of the current MST configuration. When you are done editing the configuration, you can apply all the changes at once by using the exit keyword, or you can exit the submode without committing any change to the configuration by using the abort keyword.
In the unlikely event that two users commit a new configuration at exactly at the same time, this warning message displays:
% MST CFG:Configuration change lost because of concurrent access
Examples
This example shows how to enter MST-configuration submode:
Router(config)#
spanning-tree mst configuration
Router(
config-mst)#
This example shows how to reset the MST configuration to the default settings:
Router(config)#
no spanning-tree mst configuration
Router(config)#
Related Commands
spanning-tree mst forward-time
To set the forward-delay timer for all the instances on the Catalyst 6500 series switch, use the spanning-tree mst forward-time command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst forward-time seconds
no spanning-tree mst forward-time
Syntax Description
seconds |
Number of seconds to set the forward-delay timer for all the instances on the Catalyst 6500 series switch; valid values are from 4 to 30 seconds. |
Command Default
seconds is 15.
Command Modes
Global configuration (config)
Command History
Examples
This example shows how to set the forward-delay timer:
Router(config)# spanning-tree mst forward-time 20
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst hello-time
To set the hello-time delay timer for all the instances on the Catalyst 6500 series switch, use the spanning-tree mst hello-time command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst hello-time seconds
no spanning-tree mst hello-time
Syntax Description
seconds |
Number of seconds to set the hello-time delay timer for all the instances on the Catalyst 6500 series switch; valid values are from 1 to 10 seconds. |
Command Default
2 seconds
Command Modes
Global configuration (config)
Command History
Usage Guidelines
If you do not specify the hello-time value, the value is calculated from the network diameter.
Examples
This example shows how to set the hello-time delay timer:
Router(config)# spanning-tree mst hello-time 3
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst max-age
To set the max-age timer for all the instances on the Catalyst 6500 series switch, use the spanning-tree mst max-age command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst max-age seconds
no spanning-tree mst max-age
Syntax Description
seconds |
Number of seconds to set the max-age timer for all the instances on the Catalyst 6500 series switch; valid values are from 6 to 40 seconds. |
Command Default
20 seconds
Command Modes
Global configuration (config)
Command History
Examples
This example shows how to set the max-age timer:
Router(config)# spanning-tree mst max-age 40
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst max-hops
To specify the number of possible hops in the region before a bridge protocol data unit (BPDU) is discarded, use the spanning-tree mst max-hops command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst max-hops hopnumber
no spanning-tree mst max-hops
Syntax Description
hopnumber |
Number of possible hops in the region before a BPDU is discarded; valid values are from 1 to 255 hops. |
Command Default
20 hops
Command Modes
Global configuration (config)
Command History
Examples
This example shows how to set the number of possible hops:
Router(config)# spanning-tree mst max-hops 25
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst pre-standard
To configure a port to transmit only prestandard bridge protocol data units (BPDUs), use the spanning-tree mst pre-standard command in interface configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst pre-standard
no spanning-tree mst pre-standard
Syntax Description
This command has no arguments or keywords.
Command Default
The default is to automatically detect prestandard neighbors.
Command Modes
Interface configuration (config-if)
Command History
|
|
12.2(18)SXF |
Support for this command was introduced on the Supervisor Engine 720. |
12.2(33)SRA |
This command was integrated into Cisco IOS Release 12.2(33)SRA. |
Usage Guidelines
Even with the default configuration, the port can receive both prestandard and standard BPDUs.
Prestandard BPDUs are based on the Cisco IOS Multiple Spanning Tree (MST) implementation that was created before the IEEE standard was finalized. Standard BPDUs are based on the finalized IEEE standard.
If you configure a port to transmit prestandard BPDUs only, the prestandard flag displays in the show spanning-tree commands. The variations of the prestandard flag are as follows:
•Pre-STD (or pre-standard in long format)—This flag displays if the port is configured to transmit prestandard BPDUs and if a prestandard neighbor bridge has been detected on this interface.
•Pre-STD-Cf (or pre-standard (config) in long format)—This flag displays if the port is configured to transmit prestandard BPDUs but a prestandard BPDU has not been received on the port, the autodetection mechanism has failed, or a misconfiguration, if there is no prestandard neighbor, has occurred.
•Pre-STD-Rx (or pre-standard (rcvd) in long format)—This flag displays when a prestandard BPDU has been received on the port but it has not been configured to send prestandard BPDUs. The port will send prestandard BPDUs, but we recommend that you change the port configuration so that the interaction with the prestandard neighbor does not rely only on the autodetection mechanism.
If the MST configuration is not compatible with the prestandard (if it includes an instance ID greater than 15), only standard MST BPDUs are transmitted, regardless of the STP configuration on the port.
Examples
This example shows how to configure a port to transmit only prestandard BPDUs:
Router(config-if)# spanning-tree mst pre-standard
Router(config-if)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst priority
To set the bridge priority for an instance, use the spanning-tree mst priority command in global configuration mode. To return to the default setting, use the no form of this command.
spanning-tree mst instance priority priority
no spanning-tree mst priority
Syntax Description
Command Default
priority is 32768.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
You can set the bridge priority in increments of 4096 only. When you set the priority, valid values are 0, 4096, 8192, 12288, 16384, 20480, 24576, 28672, 32768, 36864, 40960, 45056, 49152, 53248, 57344, and 61440.
You can set the priority to 0 to make the switch root.
You can enter instance as a single instance or a range of instances, for example, 0-3,5,7-9.
Examples
This example shows how to set the bridge priority:
Router(config)# spanning-tree mst 0 priority 4096
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst root
To designate the primary and secondary root switch and set the timer value for an instance, use the spanning-tree mst root command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree mst instance root {primary | secondary} [diameter diameter [hello-time seconds]]
no spanning-tree mst instance root
Syntax Description
Command Default
The spanning-tree mst root command has no default settings.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
You can enter instance as a single instance or a range of instances, for example, 0-3,5,7-9.
The spanning-tree mst root secondary value is 16384.
The diameter diameter and hello-time seconds keywords and arguments are available for instance 0 only.
If you do not specify the seconds argument, the value for it is calculated from the network diameter.
Examples
This example shows how to designate the primary root switch and timer values for an instance:
Router(config)# spanning-tree mst 0 root primary diameter 7 hello-time 2
Router(config)# spanning-tree mst 5 root primary
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst simulate pvst (interface)
To override the global Per-VLAN Spanning Tree (PVST) simulation setting for a port, use the spanning-tree mst simulate pvst interface command in interface configuration mode. To return to the default PVST simulation setting, use the no form of this command.
spanning-tree mst simulate pvst [disable]
no spanning-tree mst simulate pvst
Syntax Description
disable |
Disables PVST simulation on the interface. |
Command Default
PVST simulation is enabled.
Command Modes
Interface configuration (config-if)
Command History
|
|
12.2(33)SXI |
Support for this command was introduced. |
Usage Guidelines
PVST simulation is enabled by default so that an interface can interoperate between Multiple Spanning Tree (MST) and Rapid Per-VLAN Spanning Tree Plus (PVST+). To prevent an accidental connection to a device that does not run MST as the default Spanning Tree Protocol (STP) mode, you can disable PVST simulation. If you disable PVST simulation, the MST-enabled port moves to the blocking state once it detects it is connected to a Rapid PVST+-enabled port. This port remains in the inconsistent state until the port stops receiving Bridge Protocol Data Units (BPDUs), and then the port resumes the normal STP transition process.
Examples
This example shows how to prevent a port from automatically interoperating with a connecting device that is running Rapid PVST+:
Router(config)#
interface gi3/13
Router(config-if)#
spanning-tree mst simulate pvst disable
Router(config-if)#
Related Commands
spanning-tree mst simulate pvst global
To enable Per-VLAN Spanning Tree (PVST) simulation globally, enter the spanning-tree mst simulate pvst global command in global configuration mode. To disable PVST simulation globally, enter the no form of this command.
spanning-tree mst simulate pvst global
no spanning-tree mst simulate pvst global
Syntax Description
This command has no arguments or keywords.
Command Default
PVST simulation is enabled.
Command Modes
Global configuration (config)
Command History
|
|
12.2(33)SXI |
Support for this command was introduced. |
Usage Guidelines
PVST simulation is enabled by default so that all interfaces on the device interoperate between Multiple Spanning Tree (MST) and Rapid Per-VLAN Spanning Tree Plus (PVST+). To prevent an accidental connection to a device that does not run MST as the default Spanning Tree Protocol (STP) mode, you can disable PVST simulation. If you disable PVST simulation, the MST-enabled port moves to the blocking state once it detects it is connected to a Rapid PVST+-enabled port. This port remains in the inconsistent state until the port stops receiving Bridge Protocol Data Units (BPDUs), and then the port resumes the normal STP transition process.
To override the global PVST simulation setting for a port, enter the spanning-tree mst simulate pvst interface command in the interface command mode.
Examples
This example shows how to prevent the switch from automatically interoperating with a connecting device that is running Rapid PVST+:
Router(config)#
no spanning-tree mst simulate pvst global
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree mst simulate pvst (interface) |
Overrides the global PVST simulation setting for a port. |
spanning-tree pathcost method
To set the default path-cost calculation method, use the spanning-tree pathcost method command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree pathcost method {long | short}
no spanning-tree pathcost method
Syntax Description
long |
Specifies the 32-bit based values for default port-path costs. |
short |
Specifies the 16-bit based values for default port-path costs. |
Command Default
short
Command Modes
Global configuration (config)
Command History
Usage Guidelines
This command applies to all the spanning-tree instances on the Catalyst 6500 series switch.
The long path-cost calculation method utilizes all 32 bits for path-cost calculation and yields values in the range of 1 through 200,000,000.
The short path-cost calculation method (16 bits) yields values in the range of 1 through 65535.
Examples
This example shows how to set the default path-cost calculation method to long:
Router(config
#) spanning-tree pathcost method long
Router(config
#)
This example shows how to set the default path-cost calculation method to short:
Router(config
#) spanning-tree pathcost method short
Router(config
#)
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree portfast (interface)
To enable PortFast mode where the interface is immediately put into the forwarding state upon linkup without waiting for the timer to expire, use the spanning-tree portfast command in interface configuration mode. To return to the default settings, use the no form of this command.
spanning-tree portfast
spanning-tree portfast {disable | edge [trunk] | network | trunk}
no spanning-tree portfast
Syntax Description
Command Default
The settings that are configured by the spanning-tree portfast default command.
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
You should use this command only with interfaces that connect to end stations; otherwise, an accidental topology loop could cause a data-packet loop and disrupt the Catalyst 6500 series switch and network operation.
An interface with PortFast mode enabled is moved directly to the spanning-tree forwarding state when linkup occurs without waiting for the standard forward-time delay.
Be careful when using the no spanning-tree portfast command. This command does not disable PortFast if the spanning-tree portfast default command is enabled.
This command has these states:
•spanning-tree portfast—This command enables PortFast unconditionally on the given port.
•spanning-tree portfast disable—This command explicitly disables PortFast for the given port. The configuration line shows up in the running configuration because it is not the default.
•spanning-tree portfast edge—This command allows you to configure PortFast edge mode on the given port.
•spanning-tree portfast network—This command allows you to configure PortFast network mode on the given port.
•spanning-tree portfast [edge] trunk—This command allows you to configure PortFast on trunk ports. The edge keyword is required with trunk in Cisco IOS Release 12.2(33)SXI and later releases.
Note If you enter the spanning-tree portfast trunk command, the port is configured for PortFast even in the access mode.
•no spanning-tree portfast—This command implicitly enables PortFast if you define the spanning-tree portfast default command in global configuration mode and if the port is not a trunk port. If you do not configure PortFast globally, the no spanning-tree portfast command is equivalent to the spanning-tree portfast disable command.
Examples
This example shows how to enable PortFast mode in releases earlier than Cisco IOS Release 12.2(33)SXI:
Router(config-if)#
spanning-tree portfast
Router(config-if)#
This example shows how to enable PortFast edge mode in Cisco IOS Release 12.2(33)SXI and later releases:
Router(config-if)#
spanning-tree portfast edge
Router(config-if)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree portfast default |
Enables PortFast by default on all access ports. |
spanning-tree portfast bpdufilter default
To enable bridge protocol data unit (BPDU) filtering by default on all PortFast ports, use the spanning-tree portfast bpdufilter default command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree portfast bpdufilter default
no spanning-tree portfast bpdufilter default
Syntax Description
This command has no arguments or keywords.
Command Default
Disabled
Command Modes
Global configuration (config)
Command History
Usage Guidelines
The spanning-tree portfast bpdufilter command enables BPDU filtering globally on PortFast ports. BPDU filtering prevents a port from sending or receiving any BPDUs.
You can override the effects of the portfast bpdufilter default command by configuring BPDU filtering at the interface level.
Note Be careful when enabling BPDU filtering. The feature's functionality is different when you enable it on a per-port basis or globally. When enabled globally, BPDU filtering is applied only on ports that are in an operational PortFast state. Ports send a few BPDUs at linkup before they effectively filter outbound BPDUs. If a BPDU is received on an edge port, it immediately loses its operational PortFast status and BPDU filtering is disabled.
When enabled locally on a port, BPDU filtering prevents the Catalyst 6500 series switch from receiving or sending BPDUs on this port.
Examples
This example shows how to enable BPDU filtering by default:
Router(config)#
spanning-tree portfast bpdufilter default
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree bpdufilter |
Enables BPDU filtering on the interface. |
spanning-tree portfast bpduguard default
To enable bridge protocol data unit (BPDU) guard by default on all PortFast ports, use the spanning-tree portfast bpduguard default command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree portfast bpduguard default
no spanning-tree portfast bpduguard default
Syntax Description
This command has no arguments or keywords.
Command Default
Disabled
Command Modes
Global configuration (config)
Command History
Usage Guidelines
BPDU guard disables a port if it receives a BPDU. BPDU guard is applied only on ports that are PortFast enabled and are in an operational PortFast state.
Examples
This example shows how to enable BPDU guard by default:
Router(config)#
spanning-tree portfast bpduguard default
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree mst |
Displays the information about the MST protocol. |
spanning-tree bpdufilter |
Enables BPDU filtering on the interface. |
spanning-tree portfast default
To enable PortFast by default on all access ports, use the spanning-tree portfast default command in global configuration mode. To disable PortFast by default on all access ports, use the no form of this command.
spanning-tree portfast {edge [bpdufilter | bpduguard] | network | normal} default
no spanning-tree portfast {edge [bpdufilter | bpduguard] | network | normal} default
Syntax Description
Note These keywords are available only in Cisco IOS Release 12.2(33)SXI and later releases.
Command Default
PortFast is disabled by default on all access ports.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
An interface with PortFast mode enabled is moved directly to the spanning-tree forwarding state when linkup occurs without waiting for the standard forward-time delay.
You can enable PortFast mode on individual interfaces using the spanning-tree portfast (interface) command.
Examples
This example shows how to enable PortFast by default on all access ports in releases earlier than Cisco IOS Release 12.2(33)SXI:
Router(config)#
spanning-tree portfast default
Router(config)#
This example shows how to enable PortFast edge mode with BPDU Guard by default on all access ports in Cisco IOS Release 12.2(33)SXI and later releases:
Router(config)#
spanning-tree portfast edge bpduguard default
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree portfast (interface) |
Enables PortFast on a specific interface. |
spanning-tree port-priority
To set an interface priority when two bridges tie for position as the root bridge, use the spanning-tree port-priority command in interface configuration mode. To revert to the default value, use the no form of this command.
spanning-tree port-priority port-priority
no spanning-tree port-priority
Syntax Description
port-priority |
Port priority; valid values are from 2 to 255. The default is 128. |
Command Default
The port priority is 128.
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
The priority you set breaks the tie.
Examples
The following example shows how to increase the likelihood that spanning-tree instance 20 is chosen as the root-bridge on interface Ethernet 2/0:
Router(config)# interface ethernet 2/0
Router(config-if)# spanning-tree port-priority 20
Router(config-if)#
Related Commands
spanning-tree transmit hold-count
To specify the transmit hold count, use the spanning-tree transmit hold-count command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree transmit hold-count value
no spanning-tree transmit hold-count
Syntax Description
value |
Number of bridge protocol data units (BPDUs) that can be sent before pausing for 1 second; valid values are from 1 to 20. |
Command Default
value is 6.
Command Modes
Global configuration (config)
Command History
|
|
12.2(18)SXF |
Support for this command was introduced on the Supervisor Engine 720. |
12.2(33)SRA |
This command was integrated into Cisco IOS Release 12.2(33)SRA. |
Usage Guidelines
This command is supported on all spanning-tree modes.
The transmit hold count determines the number of BPDUs that can be sent before pausing for 1 second.
Note Changing this parameter to a higher value may have a significant impact on CPU utilization, especially in rapid-Per-VLAN Spanning Tree (PVST) mode. Lowering this parameter could slow convergence in some scenarios. We recommend that you do not change the value from the default setting.
If you change the value setting, enter the show running-config command to verify the change.
If you delete the command, use the show spanning-tree mst command to verify the deletion.
Examples
This example shows how to specify the transmit hold count:
Router(config)# spanning-tree transmit hold-count 8
Router(config)#
Related Commands
|
|
---|---|
show running-config |
Displays the status and configuration of the module or Layer 2 VLAN. |
show spanning-tree mst |
Display the information about the MST protocol. |
spanning-tree uplinkfast
To enable UplinkFast, use the spanning-tree uplinkfast command in global configuration mode. To disable UplinkFast, use the no form of this command.
spanning-tree uplinkfast [max-update-rate packets-per-second]
no spanning-tree uplinkfast [max-update-rate]
Syntax Description
max-update-rate packets-per-second |
(Optional) Specifies the maximum rate (in packets per second) at which update packets are sent; valid values are from 0 to 65535. |
Command Default
The defaults are as follows:
•UplinkFast is disabled.
•packets-per-second is 150 packets per second.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
Use this command only on access switches.
When you configure UplinkFast, the bridge priority is changed to 49152 so that this switch is not selected as root. All interface path costs of all spanning-tree interfaces that belong to the specified spanning-tree instances also increase by 3000.
When spanning tree detects that the root interface has failed, UplinkFast causes an immediate switchover to an alternate root interface, transitioning the new root interface directly to the forwarding state. During this time, a topology change notification is sent. To minimize the disruption that is caused by the topology change, a multicast packet is sent to 01-00-0C-CD-CD-CD for each station address in the forwarding bridge except for those associated with the old root interface.
Use the spanning-tree uplinkfast max-update-rate command to enable UplinkFast (if it is not already enabled) and change the rate at which update packets are sent. Use the no form of this command to return to the default rate.
Examples
This example shows how to enable UplinkFast and set the maximum rate to 200 packets per second:
Router(config)#
spanning-tree uplinkfast max-update-rate 200
Router(config)#
Related Commands
|
|
---|---|
show spanning-tree |
Displays information about the spanning-tree state. |
spanning-tree vlan
To configure Spanning Tree Protocol (STP) on a per-virtual LAN (VLAN) basis, use the spanning-tree vlan command in global configuration mode. To return to the default settings, use the no form of this command.
spanning-tree vlan vlan-id [forward-time seconds | hello-time seconds | max-age seconds | priority priority | protocol protocol | [root {primary | secondary} [diameter net-diameter [hello-time seconds]]]]
no spanning-tree vlan vlan-id [forward-time | hello-time | max-age | priority | protocol | root]
Syntax Description
Command Default
The defaults are:
•forward-time—15 seconds
•hello-time—2 seconds
•max-age—20 seconds
•priority—The default with IEEE STP enabled is 32768; the default with STP enabled is 128.
•protocol—IEEE
•root—No STP root
When you issue the no spanning-tree vlan xx root command the following parameters are reset to their defaults:
•priority—The default with IEEE STP enabled is 32768; the default with STP enabled is 128.
•hello-time—2 seconds
•forward-time—15 seconds
•max-age—20 seconds
Command Modes
Global configuration (config)
Command History
Usage Guidelines
When you set the max-age seconds parameter, if a bridge does not hear bridge protocol data units (BPDUs) from the root bridge within the specified interval, it assumes that the network has changed and recomputes the spanning-tree topology.
Valid values for protocol are dec (Digital STP), ibm (IBM STP), ieee (IEEE Ethernet STP), and vlan-bridge (VLAN Bridge STP).
The spanning-tree root primary command alters this switch's bridge priority to 8192. If you enter the spanning-tree root primary command and the switch does not become the root switch, then the bridge priority is changed to 100 less than the bridge priority of the current bridge. If the switch still does not become the root, an error results.
The spanning-tree root secondary command alters this switch's bridge priority to 16384. If the root switch should fail, this switch becomes the next root switch.
Use the spanning-tree root commands on backbone switches only.
The spanning-tree etherchannel guard misconfig command detects two types of errors: misconfiguration and misconnection errors. A misconfiguration error is an error between the port-channel and an individual port. A misconnection error is an error between a switch that is channeling more ports and a switch that is not using enough Spanning Tree Protocol (STP) Bridge Protocol Data Units (BPDUs) to detect the error. In this case, the switch will only error disable an EtherChannel if the switch is a nonroot switch.
Examples
The following example shows how to enable spanning tree on VLAN 200:
Router(config)# spanning-tree vlan 200
The following example shows how to configure the switch as the root switch for VLAN 10 with a network diameter of 4:
Router(config)# spanning-tree vlan 10 root primary diameter 4
The following example shows how to configure the switch as the secondary root switch for VLAN 10 with a network diameter of 4:
Router(config)# spanning-tree vlan 10 root secondary diameter 4