Step 1 |
enable
|
Enables privileged EXEC mode.
|
Step 2 |
configure
terminal
Router# configure terminal
|
Enters global configuration mode.
|
Step 3 |
interface
type
number
Router(config)# interface loopback0
|
Configures an interface type and enters interface configuration mode.
|
Step 4 |
ip
address
ip-address
mask
[secondary ]
Router(config-if)# ip address 172.16.1.1 255.255.255.255
|
Configures an IP address.
|
Step 5 |
exit
|
Exits interface configuration mode and returns to global configuration mode.
|
Step 6 |
interface
type
number
Router(config)# interface loopback1
|
Configures an interface type and enters interface configuration mode.
|
Step 7 |
ip
vrf
forwarding
vrf-name
[downstream
vrf-name2 ]
Router(config-if)# ip vrf forwarding vrf_trans
|
Associates a VRF with an interface or subinterface.
Note
|
Executing this command on an interface removes the IP address. The IP address should be reconfigured.
|
|
Step 8 |
ip
address
ip-address
mask
[secondary ]
Router(config-if)# ip address 10.99.1.1 255.255.255.255
|
Configures an IP address.
|
Step 9 |
Repeat Step 5 through Step 8 for each VRF to be associated with an interface.
|
|
Step 10 |
exit
|
Exits interface configuration mode and returns to global configuration mode.
|
Step 11 |
router
bgp
autonomous-system-number
Router(config)# router bgp 45000
|
Enters router configuration mode for the specified routing process.
|
Step 12 |
bgp
router-id
{ip-address |
vrf
auto-assign }
Router(config-router)# bgp router-id vrf auto-assign
|
Configures a fixed router ID for the local BGP routing process.
|
Step 13 |
no
bgp
default
ipv4-unicast
Router(config-router)# no bgp default ipv4-unicast
|
Disables the IPv4 unicast address family for the BGP routing process.
Note
|
Routing information for the IPv4 unicast address family is advertised by default for each BGP routing session configured
with the
neighbor
remote-as router configuration command unless you configure the
no
bgp
default
ipv4-unicast router configuration command before configuring the
neighbor
remote-as command. Existing neighbor configurations are not affected.
|
|
Step 14 |
bgp
log-neighbor-changes
Router(config-router)# bgp log-neighbor-changes
|
Enables logging of BGP neighbor resets.
|
Step 15 |
neighbor
{ip-address |
peer-group-name }
remote-as
autonomous-system-number
Router(config-router)# neighbor 192.168.1.1 remote-as 45000
|
Adds the IP address or peer group name of the neighbor in the specified autonomous system to the IPv4 multiprotocol BGP neighbor
table of the local router.
-
If the
autonomous-system-number argument matches the autonomous system number specified in the
router
bgp command, the neighbor is an internal neighbor.
-
If the
autonomous-system-number argument does not match the autonomous system number specified in the
router
bgp command, the neighbor is an external neighbor.
-
In this example, the neighbor is an internal neighbor.
|
Step 16 |
neighbor
{ip-address |
peer-group-name }
update-source
interface-type
interface-number
Router(config-router)# neighbor 192.168.1.1 update-source loopback0
|
Allows BGP sessions to use any operational interface for TCP connections.
|
Step 17 |
address-family
{ipv4 [mdt |
multicast |
unicast [vrf
vrf-name ] |
vrf
vrf-name ] |
vpnv4 [unicast ]}
Router(config-router)# address-family vpnv4
|
Enters address family configuration mode to configure BGP peers to accept address-family-specific configurations.
|
Step 18 |
neighbor
{ip-address |
peer-group-name }
activate
Router(config-router-af)# neighbor 172.16.1.1 activate
|
Activates the neighbor under the VPNv4 address family.
|
Step 19 |
neighbor
{ip-address |
peer-group-name }
send-community {both |
standard |
extended }
Router(config-router-af)# neighbor 172.16.1.1 send-community extended
|
Specifies that a communities attribute should be sent to a BGP neighbor.
|
Step 20 |
exit-address-family
Router(config-router-af)# exit-address-family
|
Exits address family configuration mode and returns to router configuration mode.
|
Step 21 |
address-family
{ipv4 [mdt |
multicast |
unicast [vrf
vrf-name ] |
vrf
vrf-name ] |
vpnv4 [unicast ]}
Router(config-router)# address-family ipv4 vrf vrf_trans
|
Enters address family configuration mode to configure BGP peers to accept address-family-specific configurations.
|
Step 22 |
redistribute
connected
Router(config-router-af)# redistribute connected
|
Redistributes from one routing domain into another routing domain.
-
In this example, the
connected keyword is used to represent routes that are established automatically when IP is enabled on an interface.
-
Only the syntax applicable to this step is displayed. For more details, see the
Cisco IOS IP Routing: BGP Command Reference.
|
Step 23 |
neighbor
{ip-address |
peer-group-name }
remote-as
autonomous-system-number
Router(config-router-af)# neighbor 192.168.1.1 remote-as 40000
|
Adds the IP address or peer group name of the neighbor in the specified autonomous system to the IPv4 multiprotocol BGP neighbor
table of the local router.
-
If the
autonomous-system-number argument matches the autonomous system number specified in the
router
bgp command, the neighbor is an internal neighbor.
-
If the
autonomous-system-number argument does not match the autonomous system number specified in the
router
bgp command, the neighbor is an external neighbor.
-
In this example, the neighbor at 192.168.1.1 is an external neighbor.
|
Step 24 |
neighbor
ip-address
local-as
autonomous-system-number
[no-prepend [replace-as [dual-as ]]]
Router(config-router-af)# neighbor 192.168.1.1 local-as 50000 no-prepend
|
Customizes the AS_PATH attribute for routes received from an eBGP neighbor.
-
The autonomous system number from the local BGP routing process is prepended to all external routes by default.
-
Use the
no-prepend keyword to not prepend the local autonomous system number to any routes received from the eBGP neighbor.
-
In this example, routes from the neighbor at 192.168.1.1 will not contain the local autonomous system number.
|
Step 25 |
neighbor
{ip-address |
peer-group-name }
ebgp-multihop [ttl ]
Router(config-router-af)# neighbor 192.168.1.1 ebgp-multihop 2
|
Accepts and attempts BGP connections to external peers residing on networks that are not directly connected.
|
Step 26 |
neighbor
{ip-address |
peer-group-name }
activate
Router(config-router-af)# neighbor 192.168.1.1 activate
|
Activates the neighbor under the IPV4 address family.
|
Step 27 |
neighbor
ip-address
allowas-in
[number ]
Router(config-router-af)# neighbor 192.168.1.1 allowas-in 1
|
Configures provider edge (PE) routers to allow the readvertisement of all prefixes that contain duplicate autonomous system
numbers.
|
Step 28 |
no
auto-summary
Router(config-router-af)# no auto-summary
|
Disables automatic summarization and sends subprefix routing information across classful network boundaries.
|
Step 29 |
no
synchronization
Router(config-router-af)# no synchronization
|
Enables the Cisco IOS software to advertise a network route without waiting for synchronization with an Internal Gateway
Protocol (IGP).
|
Step 30 |
Repeat Step 20 to Step 29 to configure another VRF instance.
|
|
Step 31 |
end
Router(config-router-af)# end
|
Exits address family configuration mode and returns to privileged EXEC mode.
|
Step 32 |
show
ip
bgp
vpnv4
{all |
rd
route-distinguisher |
vrf
vrf-name }
Router# show ip bgp vpnv4 all
|
(Optional) Displays VPN address information from the BGP table.
Note
|
Only the syntax applicable to this task is used in this example. For more details, see the
Cisco IOS Multiprotocol Label Switching Command Reference.
|
|