absolute
To specify an absolute time for a time-range, use the absolute command in time-range configuration mode. To remove the time limitation, use the no form of this command.
absolute [start time date | end time date]
no absolute
Syntax Description
start time date |
(Optional) Absolute time and date that the permit or deny statement of the associated access list starts going into effect. The time is expressed in 24-hour notation, in the form of hours:minutes. For example, 8:00 is 8:00 a.m. and 20:00 is 8:00 p.m. The date is expressed in the format day month year. The minimum start is 00:00 1 January 1993. If no start time and date are specified, the permit or deny statement is in effect immediately. |
end time date |
(Optional) Absolute time and date that the permit or deny statement of the associated access list is no longer in effect. Same time and date format as described for the start keyword. The end time and date must be after the start time and date. The maximum end time is 23:59 31 December 2035. If no end time and date are specified, the associated permit or deny statement is in effect indefinitely. |
Command Default
There is no absolute time when the time range is in effect.
Command Modes
Time-range configuration
Command History
Release |
Modification |
---|---|
12.0(1)T |
This command was introduced. |
12.2(33)SRA |
This command was integrated into Cisco IOS Release 12.2(33)SRA. |
12.2SX |
This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware. |
Usage Guidelines
Time ranges are used by IP and Internetwork Packet Exchange (IPX) extended access lists. Time ranges are applied to the permit or deny statements found in these access lists.
The absolute command is one way to specify when a time range is in effect. Another way is to specify a periodic length of time with the periodic command. Use either of these commands after the time-range command, which enables time-range configuration mode and specifies a name for the time range. Only one absolute entry is allowed per time-range command.
If a time-range command has both absolute and periodic values specified, then the periodic items are evaluated only after the absolute start time is reached, and are not further evaluated after the absolute end time is reached.
Note |
All time specifications are interpreted as local time. To ensure that the time range entries take effect at the desired times, the software clock should be synchronized using the Network Time Protocol (NTP), or some other authoritative time source. For more information, refer to the “Performing Basic System Management” document on Cisco.com. |
Examples
In the following example, an access list named ‘northeast’ references a time range named ‘xyz’. The access list and time range configuration permits traffic on Ethernet interface 0, starting at noon on January 1, 2005 and going forever.
time-range xyz
absolute start 12:00 1 January 2005
!
ip access-list extended northeast
permit ip any any time-range xyz
!
interface ethernet 0
ip access-group northeast in
The configuration sample permits UDP traffic until noon on December 31, 2005. After that time, UDP traffic is no longer allowed out Ethernet interface 0.
time-range abc
absolute end 12:00 31 December 2005
!
ip access-list extended northeast
permit udp any any time-range abc
!
interface ethernet 0
ip access-group northeast out
The configuration sample permits outgoing UDP traffic on Ethernet interface 0 on weekends only, from 8:00 a.m. on January 1, 2005, to 6:00 p.m. on December 31, 2006:
time-range weekend1
absolute start 8:00 1 January 2005 end 18:00 31 December 2006
periodic weekends 00:00 to 23:59
!
ip access-list extended northeast1
permit udp any any time-range weekend1
!
interface ethernet 0
ip access-group northeast1 out