Step 1
|
configure terminal
switch# configure terminal
|
Enters global configuration mode.
|
Step 2
|
feature-set mpls
switch(config)# feature-set mpls
|
|
Step 3
|
nv overlay evpn
switch(config)# nv overlay evpn
|
|
Step 4
|
feature bgp
switch(config)# feature bgp
|
|
Step 5
|
feature mpls l3vpn
switch(config)# feature mpls l3vpn
|
|
Step 6
|
feature mpls segment-routing
switch(config)# feature mpls segment-routing
|
|
Step 7
|
feature interface-vlan
switch(config)# feature interface-vlan
|
|
Step 8
|
feature vn-segment-vlan-based
switch(config)# feature vn-segment-vlan-based
|
Enable VLAN based VN segment.
|
Step 9
|
feature nv overlay
switch(config)# feature nv overlay
|
|
Step 10
|
router bgp
autonomous-system-number
switch(config)# router bgp 1
|
Configure BGP. The value of autonomous-system-number is from 1 to 4294967295.
|
Step 11
|
address-family ipv4 unicast
switch(config-router)# address-family ipv4 unicast
|
Configure address family for IPv4.
|
Step 12
|
redistribute direct route-map
route-map-name
switch(config-router-af)# redistribute direct route-map passall
|
Configure redistribution.
|
Step 13
|
network
address
switch(config-router-af)# network 0.0.0.0/0
|
Injects prefixes into handoff BGP along with redistribution.
|
Step 14
|
exit
switch(config-router-af)# exit
|
|
Step 15
|
address-family l2vpn evpn
switch(config-router)# address-family l2vpn evpn
|
Configure L2VPN address family.
|
Step 16
|
neighbor
address
remote-as
number
switch(config-router)# neighbor 108.108.108.108 remote-as 65535
|
Define eBGP neighbor IPv4 address and remote Autonomous-System (AS) number.
|
Step 17
|
update-source
type/id
switch(config-router-af)# update-source loopback100
|
Define interface for eBGP peering.
|
Step 18
|
ebgp-multihop
number
switch(config-router)# ebgp-multihop 10
|
Specifies multihop TTL for remote peer. The range of number is from 2 to 255.
|
Step 19
|
address-family ipv4 unicast
switch(config-router)# address-family ipv4 unicast
|
Configure the address family for IPv4.
|
Step 20
|
send-community extended
switch(config-router-af)# send-community extended
|
Configures community for BGP neighbors.
|
Step 21
|
exit
switch(config-router-af)# exit
|
|
Step 22
|
address-family vpnv4 unicast
switch(config-router)# address-family vpnv4 unicast
|
Configure the address family for IPv4.
|
Step 23
|
send-community extended
switch(config-router-af)# send-community extended
|
Configures community for BGP neighbors.
|
Step 24
|
import l2vpn evpn reoriginate
switch(config-router)# import l2vpn evpn reoriginate
|
Reoriginates the route with new RT. Can be extended to use an optional route-map.
|
Step 25
|
neighbor
address
remote-as
number
switch(config-router)# neighbor 175.175.175.2 remote-as 65535
|
Define eBGP neighbor IPv4 address and remote Autonomous-System (AS) number.
|
Step 26
|
address-family ipv4 unicast
switch(config-router)# address-family ipv4 unicast
|
Configure the address family for IPv4.
|
Step 27
|
send-community extended
switch(config-router-af)# send-community extended
|
Configures community for BGP neighbors.
|
Step 28
|
exit
switch(config-router-af)# exit
|
|
Step 29
|
address-family ipv6 unicast
switch(config-router)# address-family ipv6 unicast
|
Configure the IPv6 unicast address family. This is required for IPv6 over VXLAN with an IPv4 underlay.
|
Step 30
|
send-community extended
switch(config-router-af)# send-community extended
|
Configures community for BGP neighbors.
|
Step 31
|
exit
switch(config-router-af)# exit
|
|
Step 32
|
address-family l2vpn evpn
switch(config-router)# address-family l2vpn evpn
|
Configure L2VPN address family.
|
Step 33
|
send-community extended
switch(config-router-af)# send-community extended
|
Configures community for BGP neighbors.
|
Step 34
|
exit
switch(config-router-af)# exit
|
|
Step 35
|
import vpn unicast reoriginate
switch(config-router)# import vpn unicast reoriginate
|
Reoriginate the route with new RT. Can be extended to use an optional route-map.
|