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Cisco Identity Services Engine (ISE) is an identity-based network access control and policy enforcement
system. It functions as a common policy engine that enables endpoint access control and network device
administration for enterprises.

You can leverage Cisco ISE to ensure compliance, enhance infrastructure security, and streamline service
operations.

A Cisco ISE administrator can gather real-time contextual data for a network, including users and user groups
(who?), device type (what?), access time (when?), access location (where?), access type (wired, wireless, or
VPN) (how?), and network threats and vulnerabilities.
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As a Cisco ISE administrator, you can use this information to make network governance decisions. You can
also tie identity data to various network elements to create policies that govern network access and usage.

Cisco ISE Features

Cisco ISE software must be installed as is. You cannot install any other third-party applications at the underlying
operating system level.

Cisco ISE empowers you with the following capabilities:

Device Administration: Cisco ISE uses the TACACS+ security protocol to control and audit the
configuration of network devices. It facilitates granular control of who can access which network device
and change the associated network settings. Network devices can be configured to query Cisco ISE for
authentication and authorization of device administrator actions. These devices also send accounting
messages to Cisco ISE to log such actions.

Guest and Secure Wireless: Cisco ISE enables you to provide secure network access to visitors,
contractors, consultants, and customers. You can use web-based and mobile portals to on-board guests
to your company’s network and internal resources. You can define access privileges for different types
of guests, and assign sponsors to create and manage guest accounts.

Bring Your Own Device (BYOD): Cisco ISE allows your employees and guests to securely use their
personal devices on your enterprise network. BYOD feature end users can use configured pathways to
add their devices, and provision predefined authentications and levels of network access.

Asset Visibility: Cisco ISE gives you visibility and control over who and what is on your network
consistently, across wireless, wired, and VPN connections. Cisco ISE uses probes and device sensors to
listen to the way devices connect to the network. The Cisco ISE profile database, which is extensive,
then classifies the device. This gives the visibility and context you need to grant the right level of network
access.

Secure Access: Cisco ISE uses a wide range of authentication protocols to provide network devices and
endpoints with a secure network access. These include, but are not limited to, 802.1X, RADIUS, MAB,
web-based, EasyConnect, and external agent-enabled authentication methods.

Segmentation: Cisco ISE uses contextual data about network devices and endpoints to facilitate network
segmentation. Security group tags, access control lists, network access protocols, and policy sets that
define authorization, access, and authentication, are some ways in which Cisco ISE enables secure
network segmentation.

Posture or Compliance: Cisco ISE allows you to check for compliance, also known as posture, of
endpoints, before allowing them to connect to your network. You can ensure that endpoints receive the
appropriate posture agents for posturing services.

Threat Containment: If Cisco ISE detects threat or vulnerability attributes from an endpoint, adaptive
network control policies are sent to dynamically change the access levels of the endpoint. After the threat
or vulnerability is evaluated and addressed, the endpoint is given back its original access policy.

Security Ecosystem I ntegrations: The pxGrid feature allows Cisco ISE to securely share context-sensitive
information, policy and configuration data, and so on, with connected network devices, third-party
vendors, or Cisco partner systems.
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Cisco ISE Administrators

Administrators can use the admin portal to:

* Manage deployments, help desk operations, and network devices, and node monitoring and
troubleshooting.

» Manage Cisco ISE services, policies, administrator accounts, and system configuration and operations.

* Change administrator and user passwords.

A CLI administrator can start and stop the Cisco ISE application, apply software patches and upgrades, reload
or shut down the Cisco ISE appliance, and view all the system and application logs. Because of the special
privileges that are granted to a CLI administrator, we recommend that you protect the CLI administrator
credentials and create web-based administrators for configuring and managing Cisco ISE deployments.

The username and password that you configure during setup is intended only for administrative access to the
CLI. This role is considered to be the CLI admin user, also known as CLI administrator. By default, the
username for a CLI admin user is admin, and the password is defined during setup. There is no default
password. This CLI admin user is the default admin user, and this user account cannot be deleted. However,
other administrators can edit it, including options to enable, disable, or change password for the corresponding
account.

You can either create an administrator, or promote an existing user to an administrator role. Administrators
can also be demoted to simple network user status by disabling the corresponding administrative privileges.

Administrators are users who have local privileges to configure and operate the Cisco ISE system.

Administrators are assigned to one or more admin groups.

)

Note From Cisco ISE Release 2.7, use alphanumeric values while creating user accounts in Cisco ISE.

Related Topics
Cisco ISE Administrator Groups, on page 5

Force CLI Administrator to Use External Identity Store

Authentication with an external identity source is more secure than using the internal database.

Define a User’s Attributes in the Active Directory User Directory

Using the Windows server running Active Directory, modify the attributes for each user that you plan to
configure as a CLI Administrator.

1. From the Server Manager window, choose Server Manager > Roles> Active Directory Domain
Services> Active Directory Usersand Computers > [ ad.adserver | <ad_server>.local.

2. Enable Advanced Featuresunder the View menu so that you can edit a user’s attributes.
3. Navigate to the Active Directory group that contains a list of all the admin users and select a user.

4. Double-click the corresponding user ID.

Overview of Cisco ISE .
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The Properties window is displayed.
5. Click the Attribute Editor.

6. Click any attribute and start entering gid to locate the gidNumber. If you don't find the gidNumber attribute,
click the Filter button and uncheck the Show only attributes that have values check box.

7. Double-click an attribute name to edit each attribute. For each user:

* Assign a uidNumber greater than 60000, and make sure that the number is unique. Do not change
the uidNumber after assignment.

* Assign gidNumber as 110 or 111. While 110 denotes an admin user, whereas 111 denotes a read-only
user. If you modify the gidNumber, wait for at least five minutes before making an SSH connection.

Join the Admin CLI User to the Active Directory Domain

Connect to the Cisco ISE CLI, run the identity-store command, and assign the Admin user to the ID store.
For example, to map the CLI admin user to the Active Directory defined in ISE as adpooll, run the
identity-store active-directory domain-name adpool1 user admincliuser command.

After the join is complete, connect to the Cisco ISE CLI and log in as the Admin CLI user to verify your
configuration.

If the domain you use in this command was previously joined to the ISE node, you must rejoin the domain
in the Administrators console.

1. In the Cisco ISE GUI, click the Menu icon (=) and choose Administration > Identity Management
> External Identity Sources.

2. In the left-hand pane, click Active Directory and select your Active Directory name.

\}

Note If you test the connection, with the test user using either MS-RPC or Kerberos, the status for your Active
Directory connection might show Operational, but error messages are displayed.

3. Verify that you can still log in to the Cisco ISE CLI as the Admin CLI user.

Create a New Administrator

Cisco ISE administrators need accounts with specific roles assigned to them in order to perform specific
administrative tasks. You can create multiple administrator accounts and assign one or more roles to these
admins based on the administrative tasks that these admins have to perform.

Use the Admin Users window to view, create, modify, delete, change the status, duplicate, or search for
attributes of Cisco ISE administrators.

)

Note We recommend that you configure Active Directory access in the CLI before you join it in the GUI if the
admin user's domain is the same in both the CLI and the GUI. Else, you must rejoin the domain from the GUI
to avoid authentication failures to that domain.
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Step 1 In the Cisco ISE GUI, click the Menu icon (=) and choose Administration > System > Admin Access>
Administrators> Admin Users> Add.

Step 2 From the Add drop-down list, choose one of the following options:
+ Create an Admin User

If you choose Create an Admin User, a New Administrator window appears, from where you can configure
account information for the new admin user.

» Select from Network Access Users

If you choose Select from Network Access Users, a list of current users appears, from which you can choose a
user. Subsequently, the Admin User window corresponding to this user appears.

Step 3 Enter values in the fields. The characters supported for the Namefieldare #$° () *+-./ @ _.

The admin user name must be unique. If you have entered an existing user name, an error pop-up window displays the
following message:

User can't be created. A User with that name already exists.

Step 4 Click Submit to create a new administrator in the Cisco ISE internal database.

Related Topics
Read-Only Admin Policy, on page 143
Customize Menu Access for the Read-Only Administrator, on page 144

Cisco ISE Administrator Groups

Administrator groups are role-based access control (RBAC) groups in Cisco ISE. All the administrators who
belong to the same group share a common identity and have the same privileges. An administrator’s identity
as a member of a specific administrative group can be used as a condition in authorization policies. An
administrator can belong to more than one administrator group.

Cisco ISE supports multiple external identity stores for enhanced user access management by admins.

An administrator account with any level of access can be used to modify or delete the objects for which it has
permission, on any window it has access to.

The Cisco ISE security model limits administrators to create administrative groups that contain the same set
of privileges that the administrator has. The privileges given are based on the administrative role of the user,
as defined in the Cisco ISE database. Thus, administrative groups form the basis for defining privileges to
access the Cisco ISE systems.

The following table lists the admin groups that are predefined in Cisco ISE, and the tasks that members from
these groups can perform.
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Table 1: Cisco ISE Admin Groups, Access Levels, Permissions, and Restrictions
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Admin Group Role

Access Level

Permissions

Restrictions

Customization Admin

Manage sponsor, guest,
and personal device
portals.

+ Configure guest and sponsor access.
* Manage guest access settings.

* Customize end-user web portals.

* Cannot perform any policy
management, identity
management, or system-level
configuration tasks in Cisco
ISE.

+ Cannot view any reports.

monitoring and
troubleshooting
operations.

Helpdesk Admin Query monitoring and * Run all reports. Cannot create, update, or delete
troubleshooting il leshooting fl reports, troubleshooting flows, live
operations * Run all troubleshooting flows. authentications, or alarms.

* View the Cisco ISE dashboard and
live logs.
* View alarms.

Identity Admin * Manage user * Add, edit, and delete user accounts | Cannot perform any policy
accounts and and endpoints. management or system-level
endpoints. ) ) ) configuration tasks in Cisco ISE.

* Add, edit, and delete identity sources.

* Manage identity ) ) .
SOUICES. * Add, edit, and delete identity source
sequences.

* Configure general settings for user
accounts (attributes and password
policy).

« View the Cisco ISE dashboard, live
logs, alarms, and reports.

* Run all troubleshooting flows.

MnT Admin Perform all the * Manage all the reports (run, create, |Cannot perform any policy

and delete).
* Run all the troubleshooting flows.

 View the Cisco ISE dashboard and
live logs.

* Manage alarms (create, update, view,
and delete).

management, identity management,
or system-level configuration tasks
in Cisco ISE.

. Overview of Cisco ISE



| Overview of Cisco ISE

Cisco ISE Administrator Groups .

Admin Group Role

Access Level

Permissions

Restrictions

Network Device Admin

Manage Cisco ISE
network devices and
network device
repository.

* Read and write permissions on
network devices

* Read and write permissions on
Network Device Groups and all
network resource object types.

* View the Cisco ISE dashboard, live
logs, alarms, and reports.

* Run all the troubleshooting flows.

Cannot perform any policy
management, identity management,
or system-level configuration tasks
in Cisco ISE.

Policy Admin

Create and manage
policies for all the Cisco
ISE services across the
network, which are
related to authentication,
authorization, posture,
profiler, client
provisioning, and work
centers.

* Read and write permissions on all the
elements that are used in policies,
such as authorization profiles,
Network Device Groups (NDGs), and
conditions.

* Read and write permissions on
identities, endpoints, and identity
groups (user identity groups and
endpoint identity groups).

* Read and write permissions on
services policies and settings.

 View the Cisco ISE dashboard, live
logs, alarms, and reports.

* Run all the troubleshooting flows.

* Device Administration: Access to
device administration work centers.
Permission for TACACS policy
conditions and results. Network
device permissions for TACACS
proxy and proxy sequences.

Cannot perform any identity
management or system-level
configuration tasks in Cisco ISE.

Device Administration: Access to
the work center does not guarantee
access to the subordinate links.

Overview of Cisco ISE .
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Admin Group Role

Access Level

Permissions

Restrictions

RBAC Admin

All the tasks under the
Oper ationsmenu, except
for Adaptive Network
Control, and partial
access to some menu
items under
Administration.

 View the authentication details.

* Enable or disable Adaptive Network
Control

* Create, edit, and delete alarms;
generate and view reports; and use
Cisco ISE to troubleshoot problems
in your network.

* Read permissions on administrator
account settings and admin group
settings

* View permissions on admin access
and data access permissions in the
RBAC Poalicy window.

* View the Cisco ISE dashboard, live
logs, alarms, and reports.

* Run all the troubleshooting flows.

Cannot perform any identity
management or system-level
configuration tasks in Cisco ISE.

. Overview of Cisco ISE
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Admin Group Role

Access Level

Permissions

Restrictions

Read-Only Admin

Read-only access to the
ISE GUI.

* View and use the functions of the
dashboard, reports, and live logs or
sessions, such as filtering data,
querying, saving options, printing,
and exporting data.

* Change passwords of their own
accounts.

* Query ISE using global search,
reports, and live logs or sessions.

« Filter and save data based on the
attributes.

» Export data pertaining to
authentication policies, profile
policies, users, endpoints, network
devices, network device groups,
identities (including groups), and
other configurations.

+ Customize report queries, save, print,
and export them.

* Generate custom report queries, save,
print, or export the results.

* Save GUI settings for future
reference.

* Download logs, such as ise-psc-log
from the Operations >
Troubleshoot > Download L ogs
window.

* Perform any configuration
changes such as create,
update, delete, import,
quarantine, and Mobile
Device Management (MDM)
actions of objects, such as
authorization policies,
authentication policies,
posture policies, profiler
policies, endpoints, and users.

Perform system operations,
such as backup and restore,
registration or deregistration
of nodes, synchronization of
nodes, creating, editing, and
deleting node groups, or
upgrade and installation of
patches.

Import data pertaining to
policies, network devices,
network device groups,
identities (including groups),
and other configurations.

Perform operations, such as
CoA, endpoint debugging,
modifying collection filters,
bypassing suppression on live
sessions data, modifying the
PAN-HA failover settings,
and editing the personas or
services of Cisco ISE nodes.

Run commands that might
have a heavy impact on
performance. For example,
access to the TCP Dump in
the Operations >
Troubleshoot > Diagnostic
Tools> General Tools
window is restricted.

* Generate support bundles.
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Admin Group Role Access Level Permissions Restrictions

Super Admin All Cisco ISE Create, read, update, delete, and eXecute * Device Administration:
administrative functions. | (CRUDX) permissions on all Cisco ISE Access to the work center
The default administrator | resources. does not guarantee access to
account belongs to this the subordinate links.

A super admin can modify the credentials

group- of any Cisco ISE local user at any time.

Only an admin user from the
Note The super admin user cannot default S.up er Admin Group

modify the default can modify or delete other
admin users. Even an
externally mapped user who
is part of an Admin Group
cloned with the Menu and
Data Access privileges of the
Super Admin Group cannot
modify or delete an admin
user.

system-generated RBAC policies
and permissions. To do this, you
must create new RBAC policies
with the necessary permissions
based on your needs, and map
these policies to an admin group.

Device Administration: Access to device
administration work centers. Permission
for TACACS policy conditions and results.
Network device permissions for TACACS
proxy and proxy sequences. In addition,
permission to enable TACACS global
protocol settings.
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Admin Group Role

Access Level

Permissions

Restrictions

System Admin

All Cisco ISE
configuration and
maintenance tasks.

Full access (read and write permissions) to
perform all the activities under the

Operationstab and partial access to some
menu items under the Administration tab:

* Read permissions on administrator
account settings and administrator
group settings.

* Read permissions on admin access
and data access permissions along
with the RBAC policy window.

* Read and write permissions for all
options under Administration >
System.

 View authentication details.

* Enable or disable Adaptive Network
Control

* Create, edit, and delete alarms;
generate and view reports; and use
Cisco ISE to troubleshoot problems
in your network.

* Device Administration: Permission to
enable TACACS global protocol
settings.

Cannot perform any policy
management or system-level
configuration tasks in Cisco ISE.

Elevated System Admin
(available in Cisco ISE,

Release 2.6, Patch 2 and
above )

All Cisco ISE
configuration and
maintenance tasks.

In addition to all the privileges of the
System Admin, an Elevated System Admin
can create Admin users.

+ Cannot create or delete Super
Admin users.

+ Cannot manage the Super

Services (ERS) Operator

API, only GET

Admin groups.
External RESTful Full access to all the ERS * Create, read, update, and delete ERS | The role is meant only for ERS
Services (ERS) Admin | API requests such as API requests. authorization supporting internal
GET, POST, DELETE, users, identity groups, endpoints,
PUT endpoint groups, and SGT .
External RESTful Read-only access to ERS * Can only read ERS API requests The role is meant only for ERS

authorization supporting internal
users, identity groups, endpoints,
endpoint groups, and SGT.
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Admin Group Role Access Level Permissions Restrictions

TACACS+ Admin Full access Access to: —

* Device Administration Work Center.

* Deployment: To enable TACACS+
services.

» External ID stores.

* Operations> TACACS Live Logs
window.

Related Topics
Cisco ISE Administrators, on page 3

Create an Admin Group

Step 1

Step 2

Step 3

Step 4

Step 5

The Admin Groupswindow allows you to view, create, modify, delete, duplicate, or filter Cisco ISE network
admin groups.

Before you begin

To configure an external administrator group type, you must have already specified one or more external
identity stores.

In the Cisco ISE GUI, click the M enu icon (=) and choose Administration > System > Admin Access> Administrators
> Admin Groups

Click Add, and enter a name and description.

The supported special characters for the Name field are: space, #$ & () *+-./ @ .

Check the corresponding check box to specify the Type of administrator group you are configuring:

* Internal: Administrators assigned to this group type authenticate against the credentials that are stored in the Cisco
ISE internal database.

« External: Administrators assigned to this group authenticate against the credentials stored in the external identity
store that you select in the Administration > System > Admin Access> Authentication > Authentication M ethod
window. You can specify the external groups, if required.

Note If an internal user is configured with an external identity store for authentication, while logging in to the ISE
Admin portal, the internal user must select the external identity store as the |dentity Source. Authentication will
fail if Internal 1dentity Sourceis selected.

Click Add in the Member Usersarea to add users to this admin group. To delete users from the admin group, check the
check box corresponding to the user that you want to delete, and click Remove.

Click Submit.

. Overview of Cisco ISE
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Administrative Access to Cisco ISE

Cisco ISE administrators can perform various administrative tasks based on the administrative group to which
they belong. These administrative tasks are critical. Grant administrative access only to users who are authorized
to administer Cisco ISE in your network.

\)

Note When a Cisco ISE server is added to a network, it is marked to be in Running state after its web interface
comes up. However, it might take some more time for all the services to be fully operational because some
advanced services, such as posture services, might take longer to be available.

Administrative Access Methods

You can connect to the Cisco ISE servers in several ways. The policy administration node (PAN) runs the
Administrators portal. An admin password is required to log in. Other ISE persona servers are accessible
through SSH or the console, from where you run the CLI. This section describes the process and password
options available for each connection type:

» Admin password: The Cisco ISE Admin user that you created during installation, times out in 45 days
by default. You can prevent that by turning off Password Lifetime from Administration > System >
Admin Settings. Click the Password Policy tab, and uncheck theAdministrative passwor ds expire
check box under Password Lifetime.

If you do not do this, and the password expires, you can reset the admin password in the CLI by running
the application reset-passwd command. You can reset the admin password by connecting to the console
to access the CLI, or by rebooting the ISE image file to access the boot options menu.

 CLI password: You must enter a CLI password during installation. If you have a problem logging in to
the CLI because of an invalid password, you can reset the CLI password. Connect to the console and run
the passwor d CLI command to rest the password. See the Cisco Identity Services Engine CLI Reference
Guide for more information.

» SSH accesstothe CLI: You can enable SSH access either during installation or after, using the service
sshd command. You can also force SSH connections to use a key. Note that when you do this, SSH
connections to all the network devices also use that key. For more information, see SSH Key Validation.
You can force the SSH key to use the Diffie-Hellman algorithm. Note that ECDSA keys are not supported
for SSH keys.

Role-Based Admin Access Control in Cisco ISE

Cisco ISE provides role-based access control (RBAC) policies that ensure security by restricting administrative
privileges. RBAC policies are associated with default admin groups to define roles and permissions. A standard
set of permissions (for menu as well as data access) is paired with each of the predefined admin groups, and
is thereby aligned with the associated role and job function.

Some features in the user interface require certain permissions for their use. If a feature is unavailable, or you
are not allowed to perform a specific task, your admin group may not have the necessary permissions to
perform the task that utilizes the feature.

Overview of Cisco ISE .
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. Role-Based Permissions

Regardless of the level of access, any administrator account can modify or delete objects for which it has
permission, on any window that it can access.

\)

Note  Only system-defined admin users with Super Admin or Read Only Admin permissions can see the identity-based

users who are not a part of a user group. Admins you create without these permissions cannot see these users.

Role-Based Permissions

RBAC Policies

Cisco ISE allows you to configure permissions at the menu and data levels. These are called menu access and
data access permissions.

The menu access permissions allow you to show or hide the menu and submenu items of the Cisco ISE
administrative interface. This feature lets you create permissions so that you can restrict or enable access at
the menu level.

The data access permissions allow you to grant read and write, read only, or no access to the Admin Groups,
User Identity Groups, Endpoint Identity Groups, Locations, and Device Types data in the Cisco ISE interface.

RBAC policies determine if an administrator can be granted a specific type of access to a menu item or other
identity group data elements. You can grant or deny access to a menu item or identity group data element to
an administrator based on the admin group, by using RBAC policies. When administrators log in to the Admin
portal, they can access menus and data that are based on the policies and permissions defined for the admin

groups with which they are associated.

RBAC policies map admin groups to menu access and data access permissions. For example, you can prevent
a network administrator from viewing the Admin Access operations menu and the policy data elements. This
can be achieved by creating a custom RBAC policy for the admin group with which that network administrator
is associated.

)

Note If you are using customized RBAC policies for admin access, ensure that you provide all the relevant menu

access for a given data access. For example, to add or delete endpoints with data access of Identity or Policy
Admin, you must provide menu access to Work Center > Network Access and Administration > | dentity
M anagement.

Default Menu Access Permissions

Cisco ISE provides an out-of-the-box set of permissions that are associated with a set of predefined admin
groups. Having predefined admin group permissions allow you to set permissions so that a member of any
admin group can have full or limited access to the menu items within the administrative interface (known as
menu access) and to delegate an admin group to use the data access elements of other admin groups (known
as data access). These permissions are reusable entities that can be further used to formulate RBAC policies
for various admin groups. Cisco ISE provides a set of system-defined menu access permissions that are already
used in the default RBAC policies. Apart from the predefined menu access permissions, Cisco ISE also allows
you to create custom menu access permissions that you can use in RBAC policies. The key icon represents
menu access privileges for the menus and submenus, and the key with a close icon represents no access for
different RBAC groups.

. Overview of Cisco ISE
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Note For a Super Admin user, all the menu items are available. For other admin users, all the menu items in the
Menu Access Privileges column are available for standalone deployment, and primary node in a distributed
deployment. For secondary nodes in a distributed deployment, the menu items under the Administration tab
are not available.

Table 2: Default Menu Access Permissions for Different Admin Groups

Menus | Super Policy | Helpdesk | Identity | Network | System | RBAC MnT | Qsovisin | TACACS+

and Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin

Submenus | Menu Menu | Menu | Menu | Menu | Menu | Menu | Menu | Menu | Menu
Access | Access | Access | Access | Access | Access | Access | Access | Access | Access

Home | N

Home >

it I A e A A A A A R e

A I B A e A N N N N

Context

Visibility \ \ \ \ \ \ \ \ X X

Context

VSBIY) oy N N Y Y Y x| x

Endpaints

Context

Visbility | \ \ \ \ \ \ \ X X

> Users

Context

Visibility

> S e e A N A O N N A O

Networ k

Devices

Context

\>/|S|b|I|ty N N N N N N N ~ X X

Application

opgaios] | N | N | N | V[ N | V] x [

Opeadions

>

Adaptive \ \ X X X X X X X X

Networ k

Control
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Menus |Super | Policy |Helpdesk | Identity | Network | System | RBAC | MnT | Qsovisin | TACACS+
and Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin
Submenus | Menu Menu | Menu | Menu | Menu | Menu | Menu | Menu | Menu | Menu
Access | Access | Access | Access | Access | Access | Access | Access | Access | Access

Opeadions
>

Adaptive
Networ k N N X X X X X X X X
Control
> Policy
List

Opadions
>

Adaptive
Networ k

Control v v
>
Endpoint
Asgmat

Opadions
>

Reports
Opeadions
>

RADIUS
Opadions
>

RADIUS| V J J J J J J X X
>Live
Logs
Opadions
>

RADIUS| v v v v v v v X X

> Live
Sessions

Opeadions
>

ThretCatic
v N N N N O O T O I

Live
Logs
Opeadions
>

TACACS
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Menus |Super | Policy |Helpdesk | Identity | Network | System | RBAC | MnT | Qsovisin | TACACS+
and Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin | Admin
Submenus | Menu Menu | Menu | Menu | Menu | Menu | Menu | Menu | Menu | Menu
Access | Access | Access | Access | Access | Access | Access | Access | Access | Access

Opeadions
>
TACACS| N N N N N N N X \

> Live
Logs

Opeadions
>
Traehod
Opeadions
>

Trabedhot N
>

Doanload
Logs

Opeadions
>

e N N e N N O A O O

>
Diagnogtic
Tools
Opadions
>
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Configure Menu Access Permissions

Cisco ISE allows you to create custom menu access permissions that you can map to an RBAC policy.
Depending on the role of the administrators, you can allow them to access only specific menu options.

Step 1 In the Cisco ISE GUI, click the Menu icon (=) and choose Administration > System > Admin Access >
Authorization > Permissions > Menu Access

Step 2 Click Add, and enter values for the Name and Description fields.
a) Expand the | SE Navigation Structuremenu to the required level, and click the options for which you want to create
permissions.
b) Inthe Permissionsfor Menu Access pane, click Show.

Step 3 Click Submit.

Prerequisites for Granting Data Access Permissions

When an RBAC admin has Full Access permission to an object (for example, Employeein the User |dentity
Groups data type), the admin can view, add, update, and delete users who belong to that group. Ensure that
the admin has menu access permission granted for the User swindow (Administration > | dentity M anagement
> | dentities> Users). This is applicable for network devices and endpoint objects (based on the permissions
granted to the Network Device Groups and Endpoint | dentity Groups data types).

You cannot enable or restrict data access for network devices that belong to the default network device group
objects—All Device Types and All Locations. All the network devices are displayed if Full Access data
permission is granted to an object created under these default network device group objects. Therefore, we
recommend that you create a separate hierarchy for the Network Device Groups data type, which is
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independent of the default network device group objects. You should assign the network device objects to
the newly created network devices groups to create restricted access.

\)

Note  You can enable or restrict data access permissions only for the User Identity Groups, Network Device Groups,

and Endpoint Identity Groups, but not to Admin Groups.

Default Data Access Permissions

Cisco ISE comes with a set of predefined data access permissions. These permissions enable multiple
administrators to have the data access permissions within the same user population. You can enable or restrict
the use of data access permissions to one or more admin groups. This process allows autonomous delegated
control to administrators of one admin group to reuse data access permissions of the chosen admin groups
through selective association. Data access permissions range from full access to no access for viewing selected
admin groups or network device groups. RBAC policies are defined based on the administrator (RBAC) group,
menu access, and data access permissions. You should first create menu access and data access permissions
and then create an RBAC policy that associates an admin group with the corresponding menu access and data
access permissions. The RBAC policy takes the form: If admin_group=Super Admin then assign SuperAdmin
Menu Access permission + SuperAdmin Data Access permission. Apart from the predefined data access
permissions, Cisco ISE also allows you to create custom data access permissions that you can associate with
an RBAC policy.

There are three data access permissions, namely, Full Access, No Access, and Read Only access that can be
granted to admin groups.

The Read Only permission can be granted to the following admin groups:
» Administration > Admin Access > Administrators> Admin Groups
« Administration > Groups > User |dentity Group
« Administration > Groups > Endpoint I dentity Groups
» Network Visibility > Endpoints
» Administration > Network Resources > Network Device Groups
» Administration > Network Resources > Network Devices
» Administration > Identity Management > | dentities
» Administration > I dentity Management > Groups > User Identity Groups

« Administration > Identity Management > Groups > Endpoint | dentity Groups
If you have read-only permission for a data type (for example, Endpoint Identity Groups), you will not be

able to perform CRUD operations on that data type. If you have read-only permission for an object (for
example, GuestEndpoints), you cannot perform edit or delete operations on that object.

The following image shows how data access privileges are applied at the second-level or third-level menu
that contains additional submenus or options for different RBAC groups.
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Figure 1: Data Access Privileges

S < x Admin Groups

» User Identity Groups - @

* o Endpoint Identity Groups —

b

Blacklist

o

v o Continents » (&
o ASIA > @)

o

AUSTRALIA

&)

5 USA

o GuestEndpoints

» oy Profiled

ofy RegisteredDevices

Cﬁ Unknown

» o Network Device Groups

¥

®

Label

Description

Denotes full access for the User Identity Groups data type.

Denotes that Endpoint | dentity Groupsderive the maximum permission (full access)
that is granted to its child (Asia, in the example shown in the figure).

Denotes that there is no access for the object (blocked list).

Denotes that the parent (Continents) derives the maximum access permission granted
to its child (Asia).

Denotes read-only access for the object (Australia).

Denotes that when full access is granted to the parent (Network Device Groups), it
results in the children automatically inheriting permissions.

Denotes that when full access is granted to the parent (Asia), it results in the objects
inheriting the Full Access permission, unless permissions are explicitly granted to the
objects.

The following table shows the default data access permissions for different admin groups.

V: Denotes that a user has full access
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x: Denotes that a user has no access

I: Denotes that a user has read-only access

Table 3: Data Access Permissions

Menus | Super Policy |ldentity |Network |System |RBAC | Customization | TACACS+ | Read
and Admin |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

Admin |V X X X v v X X !
Groups

Admin |V X X X v v X X !
Groups
> Super
Admin

Admin |V X X X \ \ X X !
Groups
> Policy
Admin

Admin |V X X X v v X X !
Groups
>
Hdpdek
Admin

Admin |V X X X v v X X !
Groups
>

I dentity
Admin

Admin |V X X X v v X X !
Groups
>
Networ k
Device
Admin

Admin |V X X X v v X X !
Groups
> System
Admin

Admin |V X X X v v X X !
Groups
> RBAC
Admin
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Menus | Super Policy Identity | Network | System |RBAC | Customization | TACACS+ | Read
and Admin  |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

Admin |V X X X \ \ X X !
Groups
>MnT
Admin

Admin |V X X X v v X X !
Groups
>ERS
Admin

Admin |V X X X v v X X !
Groups
>ERS

Operator

Admin |V X X X v v X X !
Groups

Admin

Admin |V X X X v v X X !
Groups

TACACS+
Admin

Admin |V X X X v v X X !
Groups
> Read
Only

Admin

Admin |V X X X \ \ X X !
Groups

Elevated
System
Admin

Admin |V X X X v v X X !
Groups
> SPOG
Admin
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Menus | Super Policy Identity | Network | System |RBAC | Customization | TACACS+ | Read
and Admin |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

Admin |V X X X \ \ X X !
Groups
> ERS

Trustsec

User v v v X X X v v !
I dentity
Groups

User \ \ \ X X X \ \ !
I dentity
Groups
>

G/
(default)

User \ \ \ X X X v v !
I dentity
Groups
>
QWETDINS
(default)

User v v v X X X v v !
I dentity
Groups
>
(default)

User \ \ \ X X X v v !
I dentity
Groups
>

Géfyesiha)
(default)

User v v v X X X v v !
I dentity
Groups
>

Employee
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Menus | Super Policy Identity | Network | System |RBAC | Customization | TACACS+ | Read
and Admin  |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

User v \ \ X X X \ \ !
I dentity
Groups
>

QuesTyeDd/
(default)

User \ \ \ X X X V V !
I dentity
Groups
>

GyEkD
(default)

User \ \ \ X X X \ \ !
I dentity
Groups
>
ALATONS
(default)

Endpoint |V \ \ X X X \ X !
I dentity
Groups

Endpoint |V \ \ X X X \ X !
I dentity
Groups
>
Blocked
List

Endpoaint | V \ \ X X X \ X !
I dentity
Groups
>

Qefidns
Endpoint | V V V X X X V X !
I dentity

Groups
>

B
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Menus | Super Policy Identity | Network | System |RBAC | Customization | TACACS+ | Read
and Admin |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

Endpoaint | V V V X X X \ X !
I dentity
Groups
>
Unknoan

Endpoint | V V V X X X V X !
I dentity
Groups
>

Profiled

Endpoint |V \ \ X X X \ X !
I dentity
Groups
>
Profiled
>

SmnyDeie
Endpoint | V \ \ X X X \ X !
I dentity

Groups
>

Profiled
>

(€ V0

Endpoaint | V \/ \/ X X X \/ X !
I dentity
Groups
>
Profiled
>

Wiabéik/\digin)

Endpoint | V \ \ X X X \ X !
I dentity
Groups
>

Profiled

>
AxeDeie
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Menus | Super Policy Identity | Network | System |RBAC | Customization | TACACS+ | Read
and Admin  |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

Endpoaint | V V V X X X \ X !
I dentity
Groups
>
Profiled
>
BladBary

Endpoint |V \ v X X X \ X !
I dentity
Groups
>
Profiled
>

Android

Endpoint |V \ \ X X X \ X !
I dentity
Groups
>
Profiled
>
AxisDaiice

Endpoint | V V V X X X V X !
I dentity
Groups
>
Profiled
>

.

Endpaint | V V \/ X X X V X !
I dentity
Groups
>
Profiled
>

EenDeaie)
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Menus | Super Policy Identity | Network | System |RBAC | Customization | TACACS+ | Read
and Admin |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

Endpoaint | V V V X X X \ X !
I dentity
Groups
>

Profiled
>
Srimy/Daie
Endpoint | \ \ X X X \ X !
I dentity
Groups
>
Profiled
>
VizoDeie

Endpoint |V \ \ X X X \ X !
I dentity
Groups
>

Profiled
>

TecheDai

Endpoint | V V V X X X V X !
I dentity
Groups
>
Profiled
>

02 [2211)5!

Endpaint | V V V X X X V X !
I dentity
Groups
>
Profiled
>

o b
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Menus | Super Policy Identity | Network | System |RBAC | Customization | TACACS+ | Read
and Admin  |Admin |Admin |Admin |Admin |Admin |AdminData |Admin |Only
Submenus | Data Data Data Data Data Data Access Data Admin
Access |Access |Access |Access |Access |Access Access |Data
Access

Endpoaint | V V V X X X \ X !
I dentity
Groups
>
Profiled
>
Warkgation

Network | X X N, X X X N !
Device
Groups

Network |V X X v X X X v !
Device
Groups
> All

L ocations

Network | X X N X X X N !
Device
Groups
> All

L ocations
> Asia

Network | X X N X X X N !
Device
Groups
> All

L ocations
> Asia>
India

Network |V X X v X X X v !
Device
Groups
>|s

IPSEC
Device
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Menus
and
Submenus

Super
Admin
Data
Access

Policy
Admin
Data
Access

Identity
Admin
Data
Access

Network
Admin
Data
Access

System
Admin
Data
Access

RBAC
Admin
Data
Access

Customization
Admin Data
Access

TACACS+
Admin
Data
Access

Read
Only
Admin
Data
Access

Networ k
Device
Groups
>|s
IPSEC
Device>
Yes

!

Networ k
Device
Groups
>|s
IPSEC
Device >
No

Networ k
Device
Groups
> All
Device
Types

—

NA

NA

NA

NA

NA

NA

NA

NA

Configure Data Access Permissions

Step 1

Step 2
Step 3

Step 4

Cisco ISE allows you to create custom data access permissions that you can map to an RBAC policy. Based
on the role of the administrator, you can choose to provide access to only select data.

In the Cisco ISE GUI, click the M enu icon (=) and choose Administration > System > Admin Access> Authorization >

Permissions

Choose Permissions > Data Access.

Click Add, and enter values for the Name and Description fields.

a) Click to expand the admin group and select the corresponding admin group.
b) Click Full Access, Read Only Access, or No Access.

Click Save.

Read-Only Admin Policy

The default Read-Only Admin policy is available in the Administration > System > Admin Access >
Authorization > RBAC Policy window. This policy is available for both new installations and upgraded

Overview of Cisco ISE .
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. Customize Menu Access for the Read-Only Administrator

deployments. The Read-Only Admin policy is applicable to the Read-Only Admin group. By default, Super
Admin Menu Access and Read-Only Data Access permissions are granted to Read-Only administrators. This
policy cannot be duplicated and the associated Data Access permission cannot be edited.

\)

Note * The default read-only policy is mapped to the Read Only Admin group. You cannot create custom RBAC
policy using the Read Only Admin group.

* Cisco ISE supports the read-only functionality based on the static check of Read-Only Admin Group
only.

Customize Menu Access for the Read-Only Administrator

Step 1
Step 2

Step 3
Step 4

Step 5

Step 6
Step 7

Step 8

By default, Read-Only Administrators are given Super Admin Menu Access and Read Only Admin Data
Access. However, if the Super Admin requires that the Read-Only Administrator view only the Home and
Administration tabs, the Super Admin can create a custom menu access or customize the default Permissions
to, for example, MnT Admin Menu Access or Policy Admin Menu Access. The Super Admin cannot modify
the Read Only Data Access mapped to the Read Only Admin Policy.

Log in to the Admin portal as a Super Admin.

In the Cisco ISE GUI, click the M enu icon (=) and choose Administration > System > Admin Access> Authorization >
Per missions> Menu Access
Click Add and enter a Name (for example, MyMenu) and Description.

In the Menu Access Privileges section, you can enable the Show or Hide option to choose the required options (for
example, Home and Administration tabs) that should be displayed for the Read-Only Administrator.

Click Submit.
The custom menu access permission is displayed in the Permissions drop-down list corresponding to the Read-Only
Admin Policy displayed in the Administration > System > Admin Access > Authorization > Policy window.

Choose Administration > System > Admin Access > Authorization > RBAC Policy window.

Click the Per missions drop-down list corresponding to the Read-Only Admin Policy and choose a default (MnT Admin
Menu Access) or custom menu access permission (MyMenu) that you have created in the Administration > System >
Admin Access > Authorization > Permissions > M enu Access window.

Click Save.
Note * You will encounter an error if you choose Data Access permissions for the Read-Only Admin policy.

* When you log in to the Read-Only Admin portal, a Read-Only icon appears at the top of the window, and
you can view only the specified menu options without data access.
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