User Interface

This chapter explains how to use the WAE Design GUI.
This section contains the following topics:

» Starting WAE Design, on page |

* Main Window, on page 1

* Viewing Plots, on page 4

* Objects, on page 6

* Configuring Preferences, on page 11

* Tables, on page 12

* Context Menus, on page 17

* Log and Report Windows , on page 17

Starting WAE Design

To start WAE Design from the directory in which the WAE Design software is installed, double-click the
wae_design executable.

* From the CLI, enter ./wae_design.

(Optional) You can associate the plan file using the .pln format with the wae design executable.
Double-clicking a .pln file opens the plan in a new instance of the GUI.

Main Window

The WAE Design GUI is divided into the following primary sections. Figure 1: WAE Design User Interface,
on page 2 shows the GUI with a sample us_wan.txt plan in the network plot area.

* Menus—Menu selections for network modeling, simulation, and optimization.
* Visualization toolbar—Drop-down lists and icons that control how the network is displayed.

* Plan file tabs—Identify which plan is currently opened. There can be multiple plans open; the tab with
a white background is the active plan. To bring a plan to the forefront and make it the active plan, click
its associated tab.
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. Visualization Toolbar

* Network plot—Displays a visual representation of the network topology. The color on each interface
represents the percentage of traffic utilization on that interface. Rows that are selected in the tables, such
as demands or interfaces, are highlighted in the plot with additional graphical attributes.

* Tables—Display network properties, including both measured and simulated information, for the network
plan.

« Status bar—Identifies the network simulation mode.

» Context menus—Let you right-click anywhere to view a list of actions that you can take.

Figure 1: WAE Design User Interface
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Visualization Toolbar

The Visualization toolbar (Figure 2: Visualization Toolbar, on page 3) provides a convenient way to change
the visual aspects of the network plot.
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Figure 2: Visualization Toolbar
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» L3/L1 View—A toggle button to change the view between Layer 3 (L3) and Layer 1 (L1). You can also
simultaneously view L3 and L1 networks. This is set in the Layer 1 tab of the Plot Options. For more
information, see Layer 1 Simulation.

» Network Plot—A drop-down menu from which you choose the type of traffic displayed in the plot.

* Refine View icons—These icons let you refine and enhance your view in the network plot and in the site
plots.

* Arrange icon—Opens an Arrange palette that lets you move selected nodes and sites into a selected
schematic alignment.

» Utilization Color—Traffic utilizations are displayed by colors as a percent of available capacity used on
that interface. This enhances the other visual cues, which is the length of the fill. You can change the
colors and the utilizations they represent.

N

Note  All traffic is displayed in Mbps. In the network plot, the traffic utilization colors
represent outbound traffic.

* Simulation On/Off (white arrow in green circle) icon—By default, any change that voids the current
simulation automatically triggers a resimulation. For example, changes in topology trigger a resimulation.
To turn off this resimulation, use the drop-down arrow next to the icon to uncheck Auto resimulate.

* Network Options icon—Lets you set global simulation modes, such as Full Convergence or Fast Reroute
for MPLS, and whether to include multicast hops. You can also set IGP, BGP, and Multicast protocol
options.

* Traffic Levels—Drop-down list of user-defined traffic levels in the plan. For more information, see
Traffic Demand Modeling.

* QoS Level—Drop-down list of service classes, interface queues, and undifferentiated traffic. From the
Manage QoS option, you can add or edit service classes, assign service classes to queues, and add or edit
service policies. For more information, see Quality of Service Simulation.

» Worst-Case Simulation Subset (red X) icon—After a simulation analysis is performed over a specified
set of failure scenarios (for example, circuits, nodes, and ports), you can click this icon to select which
subset of these failure scenarios (for example, circuits only), as well as service classes you want included
in the worst-case analysis. This avoids having to run a second simulation analysis.
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 Layouts—Drop-down list of user-defined plots. For example, you might have schematic layouts,
geographic layouts, separate layouts for different continents, simplified layouts with hidden nodes or
sites, or other representations of the network.

* Plot Options icon—Lets you customize circuit width, text on interfaces, layouts (such as background
images and geographic views), and other plot options.

* Legend (question mark) icon—Displays a legend of icons and line types in the plot and their meanings.
For more information, see Plot Legend for Design Layouts.

Viewing Plots

WAE Design opens to the main network plot. Although WAE Design shows only the sites in the network
plot and tables, you can view those sites in more depth. You can also view more depth of interfaces and
demands in their respective plots. In addition to these plot views, you can create and view layouts that show
only those portions of the network plot that you choose. For more information, see the Cisco WAE Network
Visualization Guide .

Viewing Network Plots

The network plot, also referred to simply as the plot , is the main area showing the network topology. It can
contain both sites and nodes.

There are multiple network plot views available (top left of Figure 2: Visualization Toolbar, on page 3).
The default view is Simulated Traffic. To change the view, select it from the Network Plot View drop-down
list in the Visualization toolbar.

+ Simulated Traffic—View of simulated traffic that can be used for capacity planning, what-if analysis,
and failure planning. Circuits are sized proportional to their capacity. Interfaces are colored according
to the percentage of simulated traffic (in comparison to available capacity as defined by the size of the
interface or the QoS bound).

* Measured Traffic—View of traffic as measured from live views of the network. Circuits are sized
proportional to their capacity. Interfaces are colored according to the percentage of measured traffic (in
comparison to available capacity as defined by the size of the interface or the QoS bound).

» Worst-Case Traffic—Interfaces are colored to show the maximum utilization of the interface over all
failure scenarios as defined by the most recently run simulation analysis. For more information, see
Simulation Analysis.

* Failure Impact—Interfaces and nodes are colored to indicate how a failure of that interface or node would
impact other interfaces and nodes. For more information, see Simulation Analysis.

» LSP Reservations—Circuits are sized proportional to their LSP reservable bandwidth. Interfaces are
colored according to the percentage of bandwidth (in comparison to what is reserved for the LSP). For
information, see RSVP-TE Simulation.

* By editing the plan file directly, you can add a user-defined static view to display interfaces with
customized color fills and fill percentages. The view then appears as an option in the Network Plot
drop-down list. For information, see the Cisco WAE Design I ntegration and Devel opment Guide .
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Viewing Site

Although WAE Design focuses on IP/MPLS Layer 3 (L3) network views and traffic, you can also create and
view Layer 1 topologies. To toggle between views of these two layers, choose View > Layer 1 View or View
> Layer 3 View, or use the shortcuts Ctrl-1 for Layer 1 and Ctrl-3 for Layer 3. For information, see Layer 1

Simulation.

Plots

The site plot can contain other sites or nodes and their connecting interfaces, including external interfaces

that are labeled with their destination node (Figure 3: Site Plots, on page 5).

To open a site plot, do one of the following:

* Double-click a single site from the plot.

* Choose multiple sites from the plot and then double-click one of those sites.

* Right-click one or more sites from the plot or the Sites table and choose Open Site View.

Figure 3: Site Plots
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Viewing Site Plots .
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The interface plot is a window that displays selected interfaces in a stacked format, making it easier to compare
one with another (Figure 4: Interface Plot, on page 6).

Select one or more interfaces from either the Interfaces table or the plot.

Open the interface plot in one of two ways:

User Interface .


cisco-wae-design-76-user-guide_chapter12.pdf#nameddest=unique_13
cisco-wae-design-76-user-guide_chapter12.pdf#nameddest=unique_13

User Interface |

. Objects

 Choose View > Interface Plot.

* Right-click and choose Plot | nterfaces.

Step 3 Work with interface plots in these ways:
» To vertically move the interface list within the plot, click the up and down arrows.
* To view a table of the selected interfaces, click the Adjust button. A new Interfaces table appears.

* To sort the interfaces by ascending or descending order, click the Adjust button. Click a column heading to toggle
its sorting between ascending or descending order, then click OK.

The interface plot displays the interfaces according to the sort.

What to do next
Figure 4: Interface Plot
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Objects

Other than a site, an object is a representation of elements found in networks, such as nodes (which represent
routers), circuits, interfaces, LSPs, and more. A site is also an object, and is a WAE Design construct for
simplifying the visualization of a network by grouping nodes within a site, or even by grouping sites within
a site.

Objects have properties that identify and define them, many of which are discovered, though they can also
be manually added and changed. For example, all circuits have a discovered Capacity property that can be
edited. Other properties are derived. For example, Capacity Sim is derived from the Capacity property. Another
example is that interfaces have a Util Sim property that identifies the percentage of Capacity Sim the simulated
traffic is using. Properties are viewable and editable through an object’s Properties dialog box (right-click the
object and choose Properties). They are also viewable as table columns.
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Object Selections .

Objects are selectable through tables and plots. However, not all objects are selectable from both, though most
are. Some object types are only selectable through their tables, such as LSPs.

All selections made in a plot appear in the associated table and vice versa (Table 1: Select Objects , on page
7). Likewise, changes made in the plot are reflected in the tables, and vice versa. Hidden objects are excluded

from the selection.

Table 1: Select Objects , on page 7 assumes that all objects are in the foreground. For information on selecting
objects that are in the foreground versus background, see Refining Viewable Objects, on page 9.

Table 1: Select Objects

To...

Do This...

Site Selections

« If the object you select is a site, none of the child objects
(child sites, nodes, and circuits) are selected.

* To select a site and all objects contained within it, press
and hold the Alt key during the selections identified in
this table.

Examples

* To select only a site, click it.

To select a site and all of its nested child objects, press
and hold Alt while clicking the site.

* To select only two sites, click one object and then
Ctrl-click each site that you want to select.

To select two sites and all the objects they contain, press
and hold both Alt and Ctrl while selecting both sites.

* To select all sites in the plan file, press Ctrl-A in either
the network plot or the Sites table.

To select all sites and all objects they contain, press and
hold Alt and Ctrl-A together in either the network plot or
the Sites table.

Select an object. If other objects were selected prior to this new
selection, those objects become deselected.

Click one or more objects in any plot or table.
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To...

Do This...

Select multiple objects from the plot.

* Do one of these steps from the plot:

* Click and hold while you drag the cursor across any
objects you want included in the selection.

* Click one object and then Ctrl-click each object that you
want to select.
* Select all objects showing in a plot:

* Press Ctrl-A (Cmd-A on a Mac).

* Click and hold while you drag the cursor over an entire
plot.

Select multiple objects from tables.

* Do one of these steps in a table:

* Click and hold while you drag the cursor across any
objects you want included in the selection.

* Click one object and then Ctrl-click each object that you

want to select.

* Select all objects in a table:

* Press Ctrl-A (Cmd-A on a Mac).

* Click and hold while you drag the cursor over an entire
table.

* If you are selecting objects from multiple tables, make your
selection in one table, and then press and hold the Alt key
(Option key on a Mac) while making selections in another table.

Clear the entire selection.

Do one of these steps:

*» Choose Select All > Clear Selection. This deselects all objects
within that table. If objects in other tables are selected, they
remain selected.

* Click anywhere in any plot. This deselects all objects in that
plot and in the associated table.

Invert the current selection (everything selected becomes
deselected and vice versa).

1. Show the table whose selections you want to invert.

2. Choose Select All > Invert Selection.
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Filtering to Selected Objects

To filter only to the selected objects, choose one or more objects in any plot or table, then choose Filter >
Filter to Selection. Alternatively, you can press and hold Ctrl-Shift (Cmd-Shift on a Mac), and then
double-click.

As with other object selections, to include the nested objects for site selections, add Alt to the selection process.
For example, press and hold Alt while clicking one or more sites, and then choose Filter > Filter to Selection.

Filtering to Nested or Parent Objects

If a site contains multiple levels of child sites, you can filter to those nested objects. Right-click a site, choose
Filter to Contained <object> , and then choose one of the following, where <object> equals sites, nodes,
or L1 nodes:

* Direct—To see only the objects immediately contained within the site.

» All—To see all contained objects, no matter how deeply nested they are within child sites.

If a site contains only one level, the context menu changes to reflect as such.

Conversely, you can find a parent site for any given node. Choose it, and then choose Filter to Sites.

Refining Viewable Objects

View icons are available both in the network plot and in the site plots. Each of these icons makes it easier to
find what you need.

Set to Foreground

Fit to Plot

CEN RN R

Zoom

Adjust Opacity of
Background Objects

Drag Plot

407029
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Except for Set to Foreground, when accessed through the Visualization toolbar, the view changes apply only
to the network plot. When accessed through a site plot, the Zoom, Fit-to-Plot, and Drag actions apply only to
that site plot.

Both the Zoom and Set to Foreground icons let you better focus and work in specific plot areas.
» Zoom—Lets you drag in the area that you want enlarged to fit the entire plot.

Shortcut—Press the letter “z,” which toggles this functionality on and off.

To escape from the Zoomed view, press Esc.
* Fit-to-Plot—Resizes the diagram to fit within and fill the plot area.

Shortcut—Press the letter “f,” which toggles this functionality on and off.

* Drag Plot—Lets you move the cursor over any portion of the plot to drag it to a different location.

Shortcut—Press the letter “d” or press the icon again to toggle this functionality on and off. The feature
remains enabled until you turn it off.

To escape from the Drag option, either press Esc or click the icon to toggle it off.

* Set to Foreground—Brings selected objects to the foreground for improved viewing while sending all
other objects to the background where they appear as if they are transparent. Selected objects must be
L3 nodes, L3 circuits, sites, L1 nodes, or L1 links. This feature does not apply to other objects, such as
demands, LSPs, L1 circuits, and L1 circuit paths.

To escape the Set to Foreground option, click the icon to toggle it off while objects are selected.

To increase or decrease the transparency (opacity) of how well the background objects appear, click the
drop-down arrow next to the Set to Foreground icon. Enter the desired value, and click OK. The higher
the value, the denser (darker) the background objects appear.

\)

Note If you are viewing both L3 and L1 objects, this opacity value for background
objects takes precedence over the layout opacity value that is set for viewing
different layers.

R B

Set Opacity.. |

Background Opacity:

K Cancel
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Configuring Preferences

Table 2: Feature History

Feature Release Information Description

User specified online map support | Cisco WAE Release 7.4.0 WAE Design now allows you to
connect to a map server using
proxy. You can now connect to a
map sever of your choice using the
URL of the map server.

You can configure scaling, foreground and background object preferences, and the background color for
layouts.

Step 1 Choose View > Preferences.
Step 2 Click the General tab and configure the following options:

* Uniform Scaling—Enter a scale factor from 5% to 1000%. Objects and fonts are scaled uniformly based on the
factor you enter.

* Individual Scaling—Enter an individual scale factor for L3/L1 nodes and sites, circuits and L1 links, and fonts.

WAE Design considers the settings on circuit and link width in the layouts and scales them accordingly based on
the given scale factors in the network plot.

* Enable Selection of Background Objects—If checked, you can select objects in the background.

* Fit to Screen Zooms to Foreground Objects—If checked, clicking the Fit to Screen icon takes into account only the
foreground objects. If unchecked, clicking Fit to Screen takes all objects into account.

* Show Tooltips—If checked, tooltips are shown.

One method of seeing related information about an object is to show the tooltips and then hover the mouse over a
site, node, L1 node, interface, or L1 link. For example, hovering over a site you can see the number of contained L3
nodes, L1 nodes, and sites, as well as the total number of interfaces connected to the contained L3 nodes.

* Scroll Table to Selected Object—If checked, when you click a single plot object (site, node, L1 node, interface, or
L1 link), the table automatically scrolls to the row for that object.

For example, if in the plot you click a node, and the Nodes table is open, the table scrolls automatically to the row
for that node.

Step 3 Click the Layoutstab and configure the following options:

* Schematic Layout—Choose a gray or white background for schematic plots. (If sites or nodes have a white border
and the background is also white, a black line appears around them.)

* Geographic Layout—Choose a gray or multi-color palette for geographic plots.

* Online Map Server URL—If not specified, the default background map server is used by WAE Design. Use Online
Map Server URL to specify a different server. Add markers (%1 %2 %3) for substituting map zoom level and
coordinates in the URL.
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For example, https://a.tile.openstreetmap.de/%$1/%2/%3.png

Note The map server must conform to OpenStreetMap standard.

* Online Map Proxy—Use this option to configure map proxy. Click Enable Proxy to enable the proxy settings.
Enter the following details:

* Authentication Type: Choose between Anonymous, User + Password, Client Side Certificate.
* Proxy Server: Enter the server name or IP address.

* Proxy Protocol: Choose between HTTP or HTTPS.

* Proxy Port: Enter the port number

» Username: Only for Authentication Type 'User + Password'.

* Password: Only for Authentication Type 'User + Password'.

* Certificate File: Path to file containing certificate (only for type Client Side Certificate)

* Certificate Type: Choose between DER, PEM, ENG (only for type Client Side Certificate)

Select Save Settings to save the configurations for future WAE Design sessions.
Select Save Password to save the password in config file.

Note To disable proxy, uncheck the Enable Proxy check box and save the settings.

» Use Site, Node, and L1 Node Icons—If checked, icons are displayed for sites, nodes, and L1 node names.

Step 4 (Optional) To save all preferences for future sessions, check Save Preferences.
Step 5 (Optional) To reset the settings back to their default, click Reset. The dialog box refreshes automatically with the default
values.

Step6  Click OK.

Tables

The tables that are viewable from the WAE Design GUI display a series of rows and columns, where the rows
are objects and the columns are properties (Figure 5: Common Table Functions, on page 13). Plan files also
contain other tables that are not viewable from the GUI. These tables contain more complex information, such
as showing complex relationships between objects. If you open a plan file using a .txt editor, each table is
labeled with angle brackets, such as <Nodes> and <Sites>.

)

Note For detailed information about plan files and tables, as well as information on creating user-defined columns
and tables, see the Cisco WAE Design Integration and Development Guide .
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There are numerous tables available for specialized purposes, such as Multicast, P2MP LSPs, and Ports. The

tables listed below are the most commonly used and are the defaults.

To bring a table to the forefront and make it the active table, click its associated tab. For example, to open the

LSPs table, click the L SPstab.

 Interfaces—A list of the interfaces in the network.

* Demands—A list of the demands in the network. Each demand specifies how much traffic is routed from
a source (node, external AS, or external endpoint) to a destination (node, external AS, external endpoint,

or multicast flow destination).

 Shortest Paths—A list of the routes between selected sites.

* Nodes—A list of network routers, which typically have names that suggest their location and function.

For example, node crl.atl is core router 1 in the Atlanta site.

¢ LSPs—A list of MPLS LSPs in the network; each LSP contains both a source and destination. Note that

sub-LSPs within point-to-multipoint (P2MP) LSPs are listed in the LSP table.

* Sites—A list of network sites.

* SRLGs—A list of the shared risk link groups (SRLGs); an SRLG is a group of objects that might all fail

due to a common cause.

» AS—A list of both internal and external autonomous systems (ASes). An AS is a collection of connected

IP routing prefixes that are controlled by one operator.

Figure 5: Common Table Functions
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» Select any table tab to bring that table to the front.

« Right-click on any table tab to hide that table or add new tables.

* Right-click on any column (or click wheel icon) to hide that column or add new columns for

that table, and to view other variables related to the column, such as average values.
« Click on any column to toggle its sort between ascending and descending order.

» Enter text or numbers in the Search field to find a matching string for that table.
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Showing or Hiding Tables or Columns

Table 3: Show or Hide Tables or Columns

To... Do This...

Show or hide one or more tables |1. Do one of these two steps:

Choose View > Tables> Show/Hide Tables.

Right-click any table tab and choose Show/Hide Tables.
2. Toggle the tables you want to show to T (true) and the ones you want to hide to F (false).
3. Click OK.

Hide a single table Right-click any table tab and choose Hide this Table.

Show or hide one or more columns | 1. Do one of these steps:
Choose View > Tables > Show/Hide Columns.
Right-click any column heading and choose Show/Hide Columns.

Click the wheel icon in the table area.

2. Toggle the columns you want to show to T (true) and the ones you want to hide to F

(false).
3. Click OK.
Hide a single column Right-click any column heading and choose Hide this Column.

Searching and Filtering in Tables

Most WAE Design tables, whether below the network plot or with dialog boxes, have an empty Search field
in the top right as shown in Figure 5: Common Table Functions, on page 13. Likewise, they usually have a
Filter control menu that opens a Filter dialog box specific to that table. Figure 6: Interfaces Filter, on page 15
is an example of an Interfaces Filter dialog box.

Table 4: Table Search and Filter Features

To... Do This...

Search for objects that match a specific string. | 1. If you are not in a dialog box, show the table whose objects you want to search.

2. In the Search field, enter a search string and press Enter.
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Searching and Filtering in Tables .

To...

Do This...

Filter the table to a list of specific search values, | 1.
and either replace, add to, or narrow the list of
objects currently showing in a table.

If you are not in a dialog box, show the table whose objects you want to filter.
Click the Filter control menu button (Figure 6: Interfaces Filter, on page 15).
Choose from the drop-down lists and enter search criteria.

If you are filtering by more than one criterion, you can optionally use these
controls:

Match All—(Default) Filters to only those rows that match all the specified
criteria (default).

Match Any—Filters to rows that match any one of the criteria.

Select whether to replace, add to, or narrow the list of objects currently showing
in a table.

Replace—Replaces objects showing in the table with those found in the search
(default).

Union—Adds the objects found to those showing in the table.

Intersection—Filters to (search for) objects only within those objects that are
currently showing in the table.

associated interfaces.

Filter the selection to associated objects. For
example, you might want to filter a circuit to

Choose Filter > Filter to X, where X is a name of a viable object.

Toggle whether to change the filter selection
with or without first asking.

Choose Filter > Interaction with current filter > X, where X is either Always
Ask or Replace.

Figure 6: Interfaces Filter
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Saving Table Settings or Restoring Defaults

Table 5: Table Settings

To... Do This...
Save table and column settings Choose View > Tables > Save All Settings.
Save table settings Do one of these steps:

» Choose View > Tables > Show/Hide Tables.

* Right-click any table tab and choose Save Table Settings.

Save column settings 1. Show the table whose column settings you want to save.
2. Do one of these steps:
Choose View > Tables > Show/Hide Columns.

Right-click any table tab and choose Save Column Settings.

Restore all table and column settings to | Choose View > Tables > Reset All.
system defaults

Resize column widths 1. Show the table whose column settings you want to save.

2. To adjust the column width to that of the longest variable, right-click the column
heading, and choose Adjust Width to Fit.

To adjust the column width to any desired size, click and drag the column heading
edge to any size.

Restore column widths to their original size | 1. Show the table whose column widths you want to restore.

2. Choose View > Tables> Reset Column Widths.

Other Table Actions

Table 6: Miscellaneous Table Tools

To... Do This...

Show all objects for a table within the plan 1. Show the table whose objects you want to see.

2. Click Show All.

Toggle the columns to sort in ascending or Click a column heading.
descending order

View the sum of the values in a column, the average, | Right-click a column heading.
the minimum, and the maximum
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To...

Do This...

View how many entries in a column are unique

Right-click a column heading.

Resize column widths

* To adjust the column width to that of the longest variable, right-click the
column heading and choose Adjust Width to Fit.

* To adjust the column width to any desired size, click and drag the column
heading edge to any size.

Restore column widths to their original size

1. Show the table whose column widths you want to restore.

2. Choose View > Tables> Reset Column Widths.

Detach the table from the plot

Do one of these steps:

* Click and hold the empty gray area above the table while you drag it to a
different location.

* Click the double-page icon in the right of that same gray area.

Reattach the table to the plot

Click and hold the empty gray area above the table while you drag it to the
bottom of the plot. When an empty blue area appears, release the mouse button.

Context Menus

WAE Design has a hidden menu called a context menu . Anywhere that you right-click, whether it is in an
empty area in the plot, on an object in the plot, on a table tab, or on a column or row in a table, a context menu
appears with available options based on where you clicked. The context menu does not apply only in the main
menus and in the Visualization toolbar.

The most common use case for context menus is for filtering to related objects. For example, to find the L1
circuits mapped to an L3 circuit, right-click the L3 circuit and choose Filter to L1 Circuits. You can select
multiple objects and right-click just one to find the related information for all selected objects. If you want to
see only selected objects in a table, right-click one of the selected objects and choose Filter to Selections.

If in a site, an interface, or a demand plot, the right-click actions taken affect the network plot.

Log and Report Windows

The following additional windows are displayed using menu items or after running tools:

* Log window—This window appears automatically when warnings or errors are logged. You can view
these by choosing Window > L og window.

* Reports—Reports are generated through the Tools > Reports menu, as well as automatically when running
certain tools such as Simulation Analysis. The report window appears at that time, and is accessible later
by choosing Window > Reports. For more information, see Reports.
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