Reports

WAE Design letsyou generate reports that compare | PPMPL Stopol ogy and configuration information, demand
routings, L SP routings, or traffic between two plan files. You can use these reports to:

« Plan for upgrades—Compare plan files before and after topology and configuration changes are made
to acurrent network. For example, you could compare the original plan file to a proposed new planin
which circuits or nodes are added or upgraded.

* Mitigate congestion—Compare plans before and after making configuration changesto mitigate congestion
due to afailure or planned maintenance, such as metric changes or L SP additions and reroutings.

* Validate simulations—Compare the simulated traffic under failure in one plan to the measured traffic
after afailure has occurred in another plan to validate the accuracy of the smulation.

« Audit plans—Review any changes between two plan files.

« |dentify demand and L SP reroutes—Compare plans to determine which demands or L SPs experienced
routing changes, for example as the result of an interface metric change or capacity upgrades.

Upon comparing plan files, areport of the results opens automatically. You can access this report later by
choosing Window > Reports.

For More Information... See...
Reports on L SP path routes MPLS Simulation
Reports on L1 circuit routes Layer 1 Simulation

Reports on demand groupings and demand grouping costs | Traffic Forecasting
Cost Modeling

Reports on infrastructure costs Cost Modeling

This section contains the following topics:

« Plan Comparison Reports, on page 2
« Traffic Comparison Reports, on page 9
* Viewing or Exporting Reports, on page 10

Reports .


cisco-wae-design-74-user-guide_chapter9.pdf#nameddest=unique_150
cisco-wae-design-74-user-guide_chapter12.pdf#nameddest=unique_13
cisco-wae-design-74-user-guide_chapter7.pdf#nameddest=unique_71
cisco-wae-design-74-user-guide_chapter28.pdf#nameddest=unique_125
cisco-wae-design-74-user-guide_chapter28.pdf#nameddest=unique_125

Reports |
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Plan Comparison Reports

Comparison reports let you compare objects between two plan files to determine:
» Which objects are present in one plan, but not in the other.

» Which objects are present in both plans and which, if any, have different properties.

Plan 1: us_netwk

Plan 2: [us_wan_Ll =

Report

IF/MPLS topology and configuration
) Demand routings
) LSP routings

1@ Complete plan comparison

For each object

'@ Only show properties with differences

) Show all properties compared
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You can run four types of plan comparison reports:

* IPIMPL S topology and configuration—Objects describing the topology (such as nodes, circuits, and
interfaces), configured objects (such asL SPsand L SP paths), and related properties (such as | GP metrics
and capacity).

» Demand routings—Demand paths and the properties that indicate routing changes, such as Path Length
and Max Latency. For acomplete list of compared properties, see Table 1: Plans Comparison Report:
IP/IMPLS Topology and Configuration , on page 3.

« L SProutings—Properties of L SPsthat indicate routing changes, such as TE Path Metric and Active Path
Sim. For acompletelist of compared properties, see Table 2: Plans Comparison Report: Demand Routings
, 0N page 6.

» Complete plan comparison—Al|l tablesin the table schema are compared, except for internal simulation
caching tables. For acomplete list of these tables, refer to the SCARIDEN_HOME/docs/table_schema
file.

Report Columns

Each WAE Design table has key columns that uniquely identify objects. For example, the key columnsin the
Interfaces table are the Node and Interface columns, which represent the name of the node containing the
interface and the name of the interfaceitself. In a Plan Comparison report, an object in one plan isidentified
with an object in another plan only if the key columns of the two objects match. That is, key columns determine
if an object is present in both plans or in only one of the plans.
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The Plan Comparison report displays three other types of columns. Table 1: Plans Comparison Report:
IP/MPLS Topology and Configuration , on page 3, Table 2: Plans Comparison Report: Demand Routings
, 0n page 6, and Table 3: Plans Comparison Report: LSP Routings, on page 7 list the properties reported
upon and their associated column type.

« Information only (Info)—There are no comparisons made. Information is reported for the plan file from
which you are running the report (Plan 1).

« Differences (Diff)—Specific properties are compared for each object that has matching key columns
across the two plan files. Objects are then identified as belonging in either Plan 1 only (file from which
you are running the report), in Plan 2 only (plan file to which you are comparing), or in both Plan 1 and
Plan 2. If the object existsin both plan files, but has different properties, a Diff column shows T (true)
if there are any differences or F (false) if there are none.

Differences are based on the current state of the open plan files. For example, if acircuit hasfailed, the
demand routings change to route around the failure.

» Summary Differences (Summ Diff)—These are not columns within WAE Design tables. They are T/F
(true or false) values, depending on some differences in the table objects that are not represented in the
table columns. For example, if acommon L SP path is configured differently between plans, thisdifference
is represented in a summary difference column in the L SP section. If demand routings differ, thisis
represented in a summary difference column in the Demands section.

A

Note For easy reference, the following tableslist columnsin the order of type first:
Key, Info, Diff, and Summ Diff. Properties within each column type are
alphabetical.

Table 1: Plans Comparison Report: IP/MPLS Topology and Configuration

Compared Table | Compared Columns Comparison Column Type | Summary Difference Description

Interfaces Name Key
Node Key
Remote Node Info
Affinities Diff
Area Diff
Capacity Diff
Circuit Diff
Description Diff
FRR Protect Diff
IGP Metric Diff
IP Address Diff
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Compared Table

Compared Columns

Comparison Column Type

Summary Difference Description

PC Min BW Diff
PC Min Links Diff
Resv BW Diff
TE Metric Diff
Circuits InterfaceA Key
InterfaceB Key
NodeA Key
NodeB Key
Name Info
Active Diff
Capacity Diff
Delay Diff
Nodes Name Key
Active Diff
AS Diff
BGPID Diff
ECMP Max Diff
IP Address Diff
IP Manage Diff
Model Diff
0s Diff
Vendor Diff
LSPs Node Key
Source Key
Active Diff
Destination Diff
Exclude Diff
FRR Link Protect Diff
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Compared Table

Compared Columns

Comparison Column Type

Summary Difference Description

Hold Pri Diff
Hop Limit Diff
Include Diff
Include Any Diff
Load Share Diff
Metric Diff
Metric Type Diff
Setup BW Diff
Setup Pri Diff

Unresolved Destination

Diff

L SPs Path Diff Summ Diff T (true) if there are any differencesin the L SP Paths table for
this LSP. If two L SPs have differencesin their named path
hops or L SP paths, these differences are propagated to this
column.

L SP Paths Node Key

Path Option Key

Source Key

Exclude Diff

Hold Pri Diff

Hop Limit Diff

Include Diff

Include Any Diff

Path Name Diff

Setup BW Diff

Setup Pri Diff

Standby Diff

Named Path Diff Summ Diff T (true) if there are any differences in the Named Paths table
for this LSP path.

Named Paths Active Key
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Compared Table | Compared Columns Comparison Column Type | Summary Difference Description
Name Key
Source Key
Named Path Hops Diff | Summ Diff T (true) if there are any differences in the Named Path Hops
table for this named L SP path.
Named Path Name Key
Hops
Source Key
Step Key
Interface Diff
IP Address Diff
Node Diff
Type Diff
Unresolved Hop Diff

Table 2: Plans Comparison Report: Demand Routings

Compared Compared Comparison Column Type | Summary Difference Description
Table Columns
Demands Destination Key

Name Key

Service Class Key

Source Key

Destination Site | Info

Source Site Info

Active Diff

ECMP Min % Diff

Max Latency Diff

Path Metric Diff

Path Diff Summ Diff T (true) if there are any differencesin routing of the demand.
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Table 3: Plans Comparison Report: LSP Routings

Report Sections .

Compared Compared Columns | Comparison Column Type | Summary Difference Description
Table
LSPs Name Key
Source Key
Active Path Sim | Diff
Destination Diff
Routed Diff
Shortest TE Path | Diff
TE Path Metric Diff
Actua Path Diff | Summ Diff T (true) if there are any differences in routing of the actual LSP
path.
Simulated Path Diff | Summ Diff T (true) if there are any differences in routing of the LSP.

Report Sections

The Summary section shows the number of objectsin each plan file, the number of objectsin both plan files,
and the number of objects with property differences (Figure 1: Example Plan Comparison Report Summary,

on page 8).

Example: Nodes A, B, and C arein Plan 1, and B, C, and D arein Plan 2. Nodes B and C have matching key
columns. The B nodes have identical properties, but the C nodes have different 1P addresses. Therefore, in
the Summary section, the In Both Plans column shows 2, and the Different Properties column shows 1.

Anindividual sectionisgenerated for each object that appearsin only one plan fileand if there are differences
between the properties, a section is generated showing these differences. Thus, there is the potential of

generating one to three sections per compared table: one for objects appearing only in Plan 1, one for objects
appearing only in Plan 2, and one listing objects existing in both plan files, a ong with their differences noted
withaT (true) or F (false).
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. Creating Plan File Comparison Reports

Figure 1: Example Plan Comparison Report Summary

Reports Plan Comparison Report
4 Campare Plans
Summary
Interfaces Diffs (14) PMan 1 us_wan_L1-2
LSPs Diffs (1056) Pan 2 us_wan_L1

Demands Plan 2 Only (8)
Demand Traffic Plan 2 Only (&)
Demand Traffic Diffs (83)
Interface Traffic Plan 1 Only (1)

Report Type Complete Plan Files
Show All properties

Interface Traftic Diffs (33) Plan 1| Plan 2 | Plan 1| Plan 2 | In Both Plans | In Both Plans,

Plot Layout Elements Plan 1 Only (11) Different Properties
| interfaces | 00| 100 0| o 100 14
IL‘SPS [ 1056 1056 I 0 I 0 1056 1056
:' Demands 8 os| o | 6 89 0
Demand Traffic &9 a5 I ] ! ] a9 a9
IJn1;erfute Traffic . 100 » I 1 | 0 99 .99
Pt Loyout Blements | 57| 46| 11| 0| 46 0

Other than Summary, the report sections and columns (properties) that appear depend on the options selected
when generating the report.

« If you select to show only properties with differences, only those columns with differences in properties
appear inthereport. If only onevalueisdifferent, all objectsarelisted (not just the one with the different

property).

« If you select to show all properties compared, all compared properties appear in the report whether there
are differences between the two plan files or not.

Creating Plan File Comparison Reports

Step 1
Step 2
Step 3
Step 4

Step 5
Step 6

Open the two plan files you want to compare.

In either of these two plan files, choose Tools > Reports > Compare Plans.
Choose the plan file to which you are comparing the open plan.

Choose the type of comparisons you want to generate:

 IPIMPL S topology and configuration
« Demand routings

* LSP routings

» Complete plan files

Choose whether to show only properties with differences or whether to show all properties compared.
Click OK.

. Reports
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Traffic Comparison Reports

Traffic Comparison reports compare traffic values within a single plan or between two plan files. You can
comparetraffic on one object at atime (nodes, interfaces, circuits, demands, L SPs, multicast flows, and flows).
Each object hasadifferent set of comparisons from which to choose. For example, interface traffic and capacity
can be compared, and L SP traffic and setup bandwidth can be compared. Another example would be to
compare the simulated interface traffic in aplan file before afailure to the measured interface traffic of aplan
filein which afailure occurred. Such a comparison lets you determine which interfaces show the greatest
differences.

For each plan file compared, the current traffic level and either the selected service class or queue are used.
They can be different in each plan.

The Summary section shows a high-level summary of what is being compared. Additionally, a section of the
difference on the selected object and traffic columns is generated and named accordingly.

Plan 1 Uus_wan
Plan 2 us_wan_L1

Compare Interfaces

Plan 1 Plan 2

Traffic Type | TraffSim TraffSim
Traffic Level | Default Default

Qos Undifferentiated | Undifferentiated
Total Traffic | 108830 Mbps 58286 Mbps

381188

Flan 1 has 30544.1 Mbps more traffic in total than Flan 2

Creating Traffic Comparison Reports

Step 1 If comparing traffic from the open plan file to another, open the other plan file.

Reports
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Step 2
Step 3

Step 4
Step 5
Step 6
Step 7
Step 8

Reports |

Compare Traffic on |Interfaces

Flan 1

Current Plan: eurcd_net

Column: ITraFF Sim

Plan 2

Select Flan: Ieurm_hru

e |

Column: [TraFF Sim

z)

KR

In each plan file, choose the travel levels and choose either the service class or queue traffic to compare.
Choose Tools > Reports > Compare Traffic. Thisplan fileisidentified as Plan 1 in the Compare Traffic dialog box

that opens.

Choose the object type on which to compare traffic (interfaces, circuits, nodes, and so on).
Choose the traffic column in the current plan that you want to compare (Plan 1).

The default Plan 2 is the current plan file. To change this, choose a different plan file for Plan 2.
Choose the traffic column being compared for Plan 2.

Click OK.

Viewing or Exporting Reports

Upon generating areport, it opens automatically. From there you can select the various sections of the report

from the left navigation pane.

To view areport after having closed it, choose Window > Reports. All reports generated on that plan file
appear and are sel ectable from one report window.

If you want to save these reports for later use, you must save the plan file. However, running the report again
overwrites the report. To preserve the information, you can export the data by report section. Right-click any
of the sections in the left navigation pane and choose Export Tables.

Reports

4 Compare Traffic
Summary
Interfaces Diffs (46)

Compare Plans
Infrastructure Cost
Simulation Analysis

Delete
Export Tables

i

1 »
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