
IGP Simulation

This chapter describes options for simulating an IGP. WAE Design can simulate IS-IS, OSPF, and EIGRP,
as well as supports multi-topology routing for IS-IS and OSPF IGPs.

All simulations use demands. For detailed information on demands, see Traffic Demand Modeling

This section contains the following topics:

• OSPF and IS-IS, on page 1
• EIGRP, on page 3
• IGP Multipath Simulation, on page 3
• Multi-Topology Routing, on page 4
• IGP Metric Initializer , on page 5
• Viewing Shortest IGP, Latency, and TE Paths, on page 6
• Setting IGP Simulation, on page 8

OSPF and IS-IS
OSPF and IS-IS simulations are identical with the following exceptions.

• OSPF routing uses OSPF areas, if specified. By default all interfaces are assigned area zero.

• IS-IS routing uses IS-IS levels, if specified. By default, all interfaces are set to Level 2. Interfaces can
belong to Level 1, Level 2, or both. If both, then an alternate metric for Level 1 can also be specified.

You can specify IGP Process ID to an IGP Protocol. To create, delete or edit IGP Process ID, choose Edit >
IGP Process Protocols

Each interface can be associated with an IGP Process ID. Select one or more interfaces for which you want
to add IGP Process ID. Right click and choose Properties. Click Advanced tab and enter the IGP Process
ID.

OSPF Area Simulation
OSPF area membership can be specified per interface. The two interfaces on each circuit must belong to the
same area. Area names can be any string. Area zero, the backbone area, must be denoted by ‘‘0’’, ‘‘0.0.0.0’’,
or an empty string. WAE Design simulates the OSPF area routing configuration in which the areas import
LSAs from the backbone. A demand from a source node to a destination node in a different area will only be
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routed if it can reach the destination by passing through the source area, directly to area zero, and from there
directly to the destination area.

By default, all nodes in a single AS are assumed to belong to a single OSPF area. Nodes are assigned to areas,
as follows.

• If OSPF areas are not defined for interfaces, all nodes are assumed to be in the same area.

• Each interface can be assigned to only one OSPF area. Note that each node can be assigned to one or
more areas.

• If a node has an interface in an OSPF area, the node is assigned to that area.

• An Area Border Router (ABR) is a node belonging to both area 0 and other OSPF areas.

IS-IS Multi-Level Simulation
By default, IS-IS interfaces are assigned to Level 2, though you can assign them to Level 1 or to both Levels
1 and 2. (For instructions, see Setting IS-IS Multi-Level Simulation, on page 2.)

• The IGP metric defines the Level 1 metric for interfaces in Level 1, in Level 2, or in both Level 1 and 2
if these have equal metrics. However, you can change the Level 1 metric.

• If an interface is in both Level 1 and Level 2 with uneven metrics, the IGP metric defines the Level 2
metric and the Level 1 metric defines the Level 1 metric.

The IS-IS level is listed in the ISIS Level column of the Interfaces table, and the Level 1 metric is listed
in the Metric Level 1 ISIS column.

By default, all nodes in a single AS are assumed to belong to a single IS-IS level. Nodes are assigned to levels,
as follows.

• Each node can be assigned to one or more levels.

• Two Level 1 nodes are placed in different areas if any route between them (under normal operation)
passes through a Level 2 node.

• A node is assigned to a single Level 2 area if there is at least one interface that is Level 2 or both Level
1 and Level 2.

• A node is assigned to one of potentially multiple Level 1 areas if any interface is Level 1 or both Level
1 and Level 2.

• An ABR is a node belonging to both the Level 2 area and another IS-IS area.

Setting IS-IS Multi-Level Simulation
Follow these steps to set IGP metrics, IS-IS levels, and Level 1 metrics.

Step 1 Choose one or more interfaces. Right-click one and choose Properties, or double-click an interface.
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Step 2 To set the IGP metric, enter its value in the IGP Metric field or choose it from the drop-down list.

Step 3 To set IS-IS multi-level simulation, click the Advanced tab.

a) In the IGP area, set the IGP Process ID.
b) Select the level from the ISIS Level drop-down list.
c) In the Level 1 Metric field, enter the metric, and click OK.

EIGRP
The IGP Metric value for each interface is not used when EIGRP routing is selected. Instead, EIGRP uses
the following formula to derive total feasible distance (total cost) from a node to a destination subnet.

path metric to destination = (10,000/(bandwidth) + (delay) * 256

• The bandwidth is the minimum interface Capacity value along the path. This is in Mbps. For each
interface, if there is no Capacity value, the Capacity Sim value is used instead.

• The delay is the sum of the interface delays in 10s of microseconds. This is calculated by taking the sum
of the EIGRP Delay values and dividing this sum by 10.

You can set this delay in the EIGRP Delay field of an interface's Properties dialog box. Here, the value is in
microseconds.

If EIGRP Delay is not set, WAE Design uses 10 as the delay in the preceding calculation, which means 10
"10s of microseconds.”

Example delay: If there are 8 interfaces, each with an EIGRP Delay value of 15, the delay used in the calculation
is (8 x 15) / 10 = 120 / 10 = 12.

Demands show the EIGRP path metric of the path over which they flow in the Path Metric column.

IGP Multipath Simulation
By default, demands are split equally between all paths from a route of equal distance to the destination, and
there is no ECMP limit.

You can specify a maximum number of ECMP paths. In this case, demands transiting through a router are
distributed among the available paths up to this maximum ECMP value. Paths are chosen by lowest next-hop
IP address, which is the interface IP address for IGP or the destination IP address for LSPs. Paths with no IP
address are chosen last.
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To configure ECMP, follow these steps:

Step 1 Choose Edit > Network Options or click the Network Options icon in the Visualization toolbar.

Step 2 Click the Protocols tab.

Step 3 In the Max ECMP Paths field, enter the maximum number of ECMPs. A 0 (zero) means there is no limit.

Step 4 Click OK.

Multi-Topology Routing
WAE Design supports simulation of multi-topology routing. Interfaces can be assigned to one or more IGPs.
Demands and LSPs can be assigned to a specific IGP, and will only route through interfaces belonging to that
IGP. This multi-topology simulation uses these rules.

• When an interface is common to more than one topology, all IGP properties of the interface (including
the metric) must be the same in both topologies.

• The IGPs must all be defined to be of the same type, for example OSPF or IS-IS. This is not a restriction
in practice unless either the OSPF topology or the IS-IS topology uses multiple areas.

• Demands and LSPs defined with a specific topology can only route over circuits belonging to that
topology. A circuit belongs to a topology if either one of its interfaces does.

• Demands and LSPs with no defined topology have no restrictions on routing. They are routed using the
default topology, to which all interfaces belong.

Editing Topologies
To create, rename, or delete topologies, choose Edit > Topologies.

Click...Enter...Do This...To...

OK and
OK

A topology nameClick NewCreate a new topology

OK and
OK

A different topology nameSelect the topology and click RenameRename an existing topology
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Click...Enter...Do This...To...

OK—Select the topology and click DeleteRemove a topology

Adding Topologies to Objects
Follow these steps to associate interfaces, demands, or LSPs with topologies. Once you have associated the
topologies, you can view them by showing the Topology column.

Step 1 Select one or more interfaces, demands, or LSPs from their respective tables.

Step 2 Right-click one of the selected objects and choose Properties.

Step 3 Select the desired topology or topologies, as follows.

Demands and LSPsInterfaces

a. Select the desired topology from the Topology
drop-down list. You can associate one topology to
each demand or LSP.

b. Click OK.

a. Click the Advanced tab.

b. In the Topologies area, click the Edit button.

1. For each topology that you want on this interface, click
the F (false) to change it to T (true).

2. Click OK.

c. Click OK.

By selecting from a similar Topology drop-down list, you can also add a topology to LSP meshes when creating them.

IGP Metric Initializer
The IGP Metric Initializer is a quick way of setting IGP metrics based on circuit latency values. WAE Design
calculates the metric by multiplying each circuit’s Delay Sim value by the multiplier you specify. You also
set a minimum value for the resulting IGP metric. WAE Design then uses the higher of the two values.

Example: If the circuit Delay Sim value is 15, the multiplier value is 2, and the minimum value is 1, the
resulting IGP metric is 30 (Delay Sim * Multiplier). However, if the minimum value were 50, the resulting
IGP metric would be 50.

Because WAE Design updates all metrics on all selected interfaces, you can modify interfaces individually
or in groups. For example, you might select all core routers in the Interface table and then simultaneously
calculate their IGP metrics.
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Step 1 Make your selections.

• Select one or more interfaces.

• Select one or more circuits. This updates IGP metrics for both associated interfaces.

• If you make no selections, IGP metrics are calculated for all interfaces.

Step 2 Choose Initializers > IGP Metric, or right-click an interface or circuit and choose Initialize IGP Metric.

Step 3 Enter a multiplier and minimum value. Then click OK.

Viewing Shortest IGP, Latency, and TE Paths
The Shortest Paths table is dynamically generated to show routes that traffic would take between selected
nodes or between all nodes in selected sites. Columns include information about the total IGP metrics used
in the routes, as well as numerous latency columns. Because shortest paths are not objects in the plan file,
there is no associated Properties dialog box. You can, however, right-click paths to filter to interfaces or to
source and destination nodes to change their properties, as needed, to change the path.

• Shortest IGP paths are the shortest paths as calculated by IGP metric.

• Shortest latency paths are the shortest paths in an IGP network as calculated by the circuit latencies.

• Shortest TE paths are the shortest paths as calculated by the interface TE metric.

To view these shortest paths in the network plot, select them from the table (Figure 1: Shortest IGP,
Latency, and TE Paths, on page 7) using the following steps.

Filtering to the shortest IGP Path between two nodes when EIGRP is used does
not show the shortest EIGRP path. Rather, its shows the shortest path using the
traditional IGP metrics for each interface.

Note

Step 1 Select one or more nodes, or select one or more sites. If you select both, WAE Design uses the object type from which
you select the context menu. It does not use both simultaneously.

Step 2 Right-click one of the objects. For nodes, choose Filter to > Shortest Paths > <selection> . For sites, choose Filter to
intersite Shortest Paths > <selection> . The selection is any one of the following:

• Between selected nodes/sites (applicable only for multiple selections)

• With selected nodes/sites as source

• With selected nodes/sites as destination

• Through all selected nodes/sites

• Through any selected nodes/sites
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Step 3 The Shortest Paths table is populated according to your selections: shortest IGP, shortest TE, or shortest latency. To view
a path in the plot, select it from this table. The Type column identifies the path type.

What to do next

Figure 1: Shortest IGP, Latency, and TE Paths

Plotting Shortest Paths
From the Shortest Paths table, right-click one or more paths and choose Plot Shortest Paths. From here, you
can see each node in the shortest path, as well as the traffic utilization on interfaces between each node in the
path. Clicking Select Shortest Paths highlights the path in the network plot.

IGP Simulation
7

IGP Simulation
Plotting Shortest Paths



Setting IGP Simulation

Step 1 Choose Edit > Network Options or click the Network Options icon in the Visualization toolbar.

Step 2 Click the Protocols tab.

Step 3 Choose the appropriate protocol from the IGP Protocol list.

Step 4 Click OK.

Step 5 Click the Simulation tab.

Step 6 Select an option for Redistribute Routes across IGP Processes. Choose from the following options:

• No IGP Redistribution

• Shortest Exit

• Shortest Path
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