Step 1 |
configure
terminal
Router# configure terminal
|
Enters global
configuration mode.
|
Step 2 |
vrf
definition
vrf-name
Router(config)# vrf definition lisp
|
Configures a
virtual routing and forwarding (VRF) table and enters VRF configuration mode.
|
Step 3 |
rd
route-distinguisher
Router(config-vrf)# rd 1:1
|
Creates routing
and forwarding tables for a VRF.
|
Step 4 |
address-family
ipv4
[unicast ]
Router(config-vrf)# address-family ipv4
|
Enters VRF IPv4
address family configuration mode to specify an IPv4 address family for a VRF
table.
|
Step 5 |
exit-address-family
Router(config-vrf-af)# exit-address-family
|
Exits VRF
address family configuration mode and returns to VRF configuration mode.
|
Step 6 |
address-family
ipv6
Router(config-vrf)# address-family ipv6
|
Enters VRF IPv6
address family configuration mode to specify an IPv6 address family for a VRF
table.
|
Step 7 |
exit-address-family
Router(config-vrf-af)# exit-address-family
|
Exits VRF
address family configuration mode and returns to VRF configuration mode.
|
Step 8 |
exit
|
Exits VRF
configuration mode and enters global configuration mode.
|
Step 9 |
interface
type
number
Router(config)# interface tunnel 191
|
Specifies the
interface type of tunnel and the interface number and enters interface
configuration mode.
|
Step 10 |
vrf
forwarding
vrf-name
Router(config-if)# vrf forwarding lisp
|
Associates a
VRF instance configured in Step 2 with the tunnel interface configured in Step
9.
|
Step 11 |
ip
address
ip-address mask
Router(config-if)# ip address 192.168.1.6 255.255.255.252
|
Configures an
IPv4 address for the tunnel interface.
|
Step 12 |
ipv6
address
ipv6-address/mask
Router(config-if)# ipv6 address 2001:DB8:ffff::6/64
|
Configures an
IPv6 address for the tunnel interface.
|
Step 13 |
tunnel
source
interface-type
interface-number
Router(config-if)# tunnel source GigabitEthernet 0/0/0
|
Configures
the tunnel source.
|
Step 14 |
tunnel
destination
ipv4-address
Router(config-if)# tunnel destination 10.10.10.13
|
Configures
the tunnel destination IPv4 address for the tunnel interface.
|
Step 15 |
exit
|
Exits
interface configuration mode and enters global configuration mode.
|
Step 16 |
router
lisp
Router(config)# router lisp
|
Enters LISP
configuration mode ( software only).
|
Step 17 |
ipv4
alt-vrf
vrf-name
Router(config-router-lisp)# ipv4 alt-vrf lisp
|
Associates a
VRF table with the LISP ALT for IPv4 EIDs.
|
Step 18 |
ipv4
proxy-itr
ipv4-locator [ipv6-locator]
Router(config-router-lisp)# ipv4 proxy-itr 10.10.10.11 2001:db8:e000:2::2
|
Enables Proxy
Ingress Tunnel Router (PITR) functionality for IPv4 EIDs, and specifies the
IPv4 and (optionally) the IPv6 RLOCs (local to the PITR) to use when
LISP-encapsulating packets to LISP sites.
|
Step 19 |
ipv4
map-cache-limit
map-cache-limit
Router(config-router-lisp)# ipv4 map-cache-limit 100000
|
Specifies the
maximum number of IPv4 map-cache entries to be maintained by the PITR.
-
When the
map-cache reaches this limit, existing entries are removed according to the
rules described in the command reference guide. (See the
LISP
Command Reference for more details.)
-
The
default map-cache-limit is 10000. In this example, since the device is being
configured as a PITR, a larger map-cache limit is configured.
|
Step 20 |
ipv6
alt-vrf
vrf-name
Router(config-router-lisp)# ipv6 alt-vrf lisp
|
Associates a
VRF table with the LISP ALT for IPv6 EIDs.
|
Step 21 |
ipv6
proxy-itr
ipv6-locator [ipv4-locator]
Router(config-router-lisp)# ipv6 proxy-itr 2001:db8:e000:2::2 10.10.10.11
|
Enables Proxy
Ingress Tunnel Router (PITR) functionality for IPv6 EIDs, and specifies the
IPv6 and (optionally) the IPv4 RLOCs (local to the PITR) to use when
LISP-encapsulating packets to LISP sites.
|
Step 22 |
ipv6
map-cache-limit
map-cache-limit
Router(config-router-lisp)# ipv6 map-cache-limit 100000
|
Specifies the
maximum number of IPv6 map-cache entries to be maintained by the PITR.
The default
map-cache-limit is 10000. In this example, since the device is being configured
as a PITR, a larger map-cache limit is configured.
|
Step 23 |
exit
Router(config-router-lisp)# exit
|
Exits LISP
configuration mode and returns to global configuration mode.
|
Step 24 |
router
bgp
autonomous-system-number
Router(config)# router bgp 65015
|
Enters router
configuration mode for the specified routing process.
|
Step 25 |
address-family
ipv4 [unicast |
multicast |
vrf
vrf-name ]
Router(config-router)# address-family ipv4 vrf lisp
|
Specifies the
IPv4 address family and enters IPv4 address family configuration mode.
-
The
vrf keyword
and
vrf-name
argument specify the name of the VRF instance to associate with subsequent
commands.
-
In this
example, the VRF table named lisp (created in Step 2) is associated with the
BGP IPv4 VRF that carries EID prefixes in the LISP ALT.
|
Step 26 |
neighbor
ip-address
remote-as
autonomous-system-number
Router(config-router-af)# neighbor 192.168.1.5 remote-as 65011
|
Adds the IP
address of the neighbor in the specified autonomous system to the IPv4
multiprotocol BGP neighbor table of the local router.
|
Step 27 |
neighbor
ip-address
activate
Router(config-router-af)# neighbor 192.168.1.5 activate
|
Enables the
neighbor to exchange prefixes for the IPv4 unicast address family.
|
Step 28 |
exit
Router(config-router-af)# exit
|
Exits address
family configuration mode.
|
Step 29 |
address-family
ipv6 [unicast |
multicast |
vrf
vrf-name ]
Router(config-router-af)# address-family ipv6 vrf lisp
|
Specifies the
IPv6 address family and enters IPv6 address family configuration mode.
-
The
vrf keyword
and
vrf-name
argument specify the name of the VRF instance to associate with subsequent
commands.
-
In this
example, the VRF table named lisp (created in Step 2) is associated with the
BGP IPv6 VRF that carries EID prefixes in the LISP ALT.
|
Step 30 |
neighbor
ip-address
remote-as
autonomous-system-number
Router(config-router-af)# neighbor 2001:db8:ffff::5 remote-as 65011
|
Adds the IPv6
address of the neighbor in the specified autonomous system to the IPv6
multiprotocol BGP neighbor table of the local router.
|
Step 31 |
neighbor
ip-address
activate
Router(config-router-af)# neighbor 2001:db8:ffff::5 activate
|
Enables the
neighbor to exchange prefixes for the IPv6 unicast address family.
|
Step 32 |
exit
Router(config-router-af)# exit
|
Exits address
family configuration mode.
|
Step 33 |
exit
Router(config-router)# exit
|
Exits router
configuration mode.
|
Step 34 |
ip
route
ipv4-prefix
next-hop
Router(config)# ip route 0.0.0.0 0.0.0.0 10.10.10.1
|
Configures an
IPv4 static route.
|
Step 35 |
ip
route
ipv4-prefix
next-hop
Router(config)# ip route 172.16.0.0 255.255.0.0 Null0 tag 123
|
Configures an
IPv4 static route.
-
In this
example, a static route is configured to Null0 for the coarse-aggregate IPv4
EID prefix 172.16.0.0/16. This static route is required to ensure proper
operation of LISP in querying the mapping system for LISP EIDs. The tag 123 is
added to this null route as a reference point for the route map used to permit
the advertisement of this coarse aggregate to the upstream ISP BGP peer.
|
Step 36 |
ipv6
route
ipv6-prefix
next-hop
Router(config)# ipv6 route ::/0 2001:db8:e000:2::f0f
|
Configures an
IPv6 static route.
|
Step 37 |
ipv6
route
ipv6-prefix
next-hop
Router(config)# ipv6 route 2001:db8::/33 Null0 tag 123
|
Configures an
IPv6 static route.
-
In this
example, a static route is configured to Null0 for the coarse-aggregate IPv6
EID prefix 2001:db8::/33. This is required to ensure proper operation of LISP
in querying the mapping system for LISP EIDs. The tag 123 is added to this null
route as a handy reference point for the route-map used to permit the
advertisement of this coarse-aggregate to the upstream ISP BGP peer.
|
Step 38 |
exit
|
Exits global
configuration mode.
|