Step 1 |
enable
|
Enables privileged EXEC mode.
|
Step 2 |
configure
terminal
Router# configure terminal
|
Enters global configuration mode.
|
Step 3 |
interface
type
number
Router(config)# interface gigabitethernet 0/0
|
|
Step 4 |
ip
address
ip-address
mask
Router(config-if)# ip address 172.30.1.1 255.255.0.0
|
Sets a primary or secondary IP address for an interface.
|
Step 5 |
exit
|
Returns to the next highest configuration mode.
|
Step 6 |
interface
type
number
Router(config)# interface serial 0/0
|
|
Step 7 |
ip
address
ip-address
mask
Router(config-if)# ip address 172.16.0.2 255.255.255.0
|
Sets a primary or secondary IP address for an interface.
|
Step 8 |
exit
|
Returns to the next highest configuration mode.
|
Step 9 |
interface
type
number
Router(config)# interface serial 1/0
|
|
Step 10 |
ip
address
ip-address
mask
Router(config-if)# ip address 192.168.0.1 255.255.255.0
|
Sets a primary or secondary IP address for an interface.
|
Step 11 |
exit
|
Returns to the next highest configuration mode.
|
Step 12 |
router
bgp
autonomous-system-number
Router(config)# router bgp 5
|
Specifies a BGP instance.
|
Step 13 |
network
network-number
Router(config-router)# network 172.30.0.0
|
Specifies a network to be advertised by BGP.
|
Step 14 |
network
network-number
Router(config-router)# network 192.168.0.0
|
Specifies a network to be advertised by BGP.
|
Step 15 |
neighbor
{ip-address |
ipv6-address [% ]|
peer-group-name }
remote-as
autonomous-system-number
Router(config-router)# neighbor 172.16.0.1 remote-as 65000
|
Adds an entry to the routing table.
|
Step 16 |
neighbor
{ip-address |
ipv6-address [% ]|
peer-group-name }
remote-as
autonomous-system-number
Router(config-router)# neighbor 192.168.0.2 remote-as 1
|
Adds an entry to the routing table.
|
Step 17 |
neighbor
{ip-address |
peer-group-name }
remove-private-as [all [replace-as ]]
Router(config-router)# neighbor 192.168.0.2 remove-private-as all replace-as
|
Removes private AS numbers from the AS Path in outgoing updates.
|
Step 18 |
end
Router(config-router)# end
|
Ends the current configuration mode and returns to privileged EXEC mode.
|
Step 19 |
show
ip
bgp
update-group
Router# show ip bgp update-group
|
(Optional) Displays information about BGP update groups.
|
Step 20 |
show
ip
bgp
neighbors
Router# show ip bgp neighbors
|
(Optional) Displays information about BGP neighbors.
|