Step 1 |
enable
|
Enables the privileged EXEC mode. Enter your password if prompted.
|
Step 2 |
configure terminal
Router# configure terminal
|
Enters the global configuration mode.
|
Step 3 |
ipv6 unicast-routing
Router(config)# ipv6 unicast-routing
|
Enables the task of forwarding IPv6 unicast datagrams.
|
Step 4 |
vrf definition vrf-name1
Router(config)# vrf definition VRF_RED
|
Configures a VRF instance and enters the VRF configuration mode.
|
Step 5 |
rd
{ASN:nn | IP address: nn }
Router(config-vrf)# rd 1:1
|
Specifies a route distinguisher.
|
Step 6 |
route-target [import | export | both ] {ASN:nn |IP address: nn }
Router(config-vrf)# route-target import 1:1
|
Creates a route target extended community for a VRF instance. Route target extended community attributes are used to identify
a set of sites and VRF instances that can receive routes with a configured route target.
-
import — Imports routing information from the
target VPN extended community.
-
export — Exports routing information to the
target VPN extended community.
-
both — Imports both import and export routing
information to the target VPN extended community
-
ASN:nn
— Specifies an autonomous system number and an
arbitrary number.
-
IP address: nn — Specifies an IP address and an arbitrary number.
|
Step 7 |
address-family ipv6
Router(config-vrf)# address-family ipv6
|
Selects IPv6 as address family type for a VRF table and enters VRF address family configuration mode. Configures separate
route-target policies for IPv6.
|
Step 8 |
exit
Router(config-vrf-af)# exit
|
Exits the address family configuration mode.
|
Step 9 |
address-family ipv4
Router(config-vrf)# address-family ipv4
|
Selects IPv4 as address family type for a VRF table and enters VRF address family configuration mode. Configures the separate
route-target policies for IPv4.
|
Step 10 |
exit
Router(config-vrf-af)# exit
|
Exits the address family configuration mode.
|
Step 11 |
exit
|
Exits the VRF configuration mode.
|
Step 12 |
vrf definition vrf-name2
Router(config)# vrf definition VRF_GREEN
|
Configures a VRF instance and enters the VRF configuration mode.
|
Step 13 |
rd
{ASN:nn | IP address: nn }
Router(config-vrf)# rd 1:1
|
Specifies a route distinguisher.
|
Step 14 |
route-target [import | export | both ]
{ ASN:nn | IP address: nn }
Router(config-vrf)# route-target import 1:1
|
Creates a route-target extended community for a VRF instance. Route-target extended community attributes are used to identify
a set of sites and VRF instances that can receive routes with a configured route target
-
import — Imports routing information from the
target VPN extended community.
-
export — Exports routing information to the
target VPN extended community.
-
both — Imports and exports routing
information to the target VPN extended community and from the target VPN extended community.
-
ASN:nn — Specifies an autonomous system number and an
arbitrary number.
-
IP address: nn — Specifies an IP address and an arbitrary number.
|
Step 15 |
address-family ipv4
Router(config-vrf)# address-family ipv4
|
Selects IPv4 as address family for a VRF table and enters the VRF address family configuration mode. Configures separate
route-target policies for IPv4.
|
Step 16 |
exit
Router(config-vrf-af)# exit
|
Exits the address family configuration mode.
|
Step 17 |
exit
|
Exits the VRF configuration mode.
|
Step 18 |
interface gigabitethernet slot / port
Router(config)# interface gigabitethernet 3/1
|
Enters the interface configuration mode and specifies the Gigabit interface to configure.
|
Step 19 |
vrf forwarding vrf-name1
Router(config-if)# vrf forwarding VRF_RED
|
Associates a VRF instance with an interface or a subinterface.
|
Step 20 |
ipv6 address {ipv6-address prefix-length prefix-name sub-bits prefix-length}
Router(config-if)# ipv6 address 1::2/64
|
Specifies the IPv6 address assigned to the interface, and enables IPv6 processing on the interface.
|
Step 21 |
exit
|
Exits the interface configuration mode.
|
Step 22 |
interface gigabitethernet slot / port
Router(config)# interface gigabitethernet 4/5
|
Enters the interface configuration mode and specifies the Gigabit interface to configure.
|
Step 23 |
vrf forwarding vrf-name2
Router(config-if)# vrf forwarding VRF_GREEN
|
Associates a VRF instance with an interface or a subinterface.
|
Step 24 |
ip address ip-address mask
Router(config-if)# ip address 17.1.1.1 255.255.255.0
|
Assigns an IP address and subnet mask to the interface.
|
Step 25 |
exit
|
Exits the interface configuration mode.
|
Step 26 |
interface loopback interface-number
Router(config)# interface Loopback 100
|
Enters the interface configuration mode and specifies the new loopback interface.
|
Step 27 |
vrf forwarding vrf-name2
Router(config-if)# vrf forwarding VRF_GREEN
|
Associates a VRF instance with an interface or a subinterface.
|
Step 28 |
ip address ip-address
Router(config-if)# ip address 60.1.1.1 255.255.255.0
|
Assigns an IP address and subnet mask to the loopback interface.
|
Step 29 |
exit
|
Exits the interface configuration mode.
|
Step 30 |
interface tunnel tunnel-number
Router(config)# interface tunnel 10
|
Specifies a tunnel interface and enters the interface configuration mode.
|
Step 31 |
vrf forwarding vrf-name1
Router(config-if)# vrf forwarding VRF_RED
|
Associates a VRF instance with an interface or a subinterface.
|
Step 32 |
ipv6 address {ipv6-address prefix-length prefix-name sub-bits prefix-length}
Router(config-if)# ipv6 address 2001:A000:100::1/128
|
Specifies the IPv6 address assigned to the interface and enables IPv6 processing on the interface.
|
Step 33 |
tunnel source { ip-address| interface-type interface-number}
Router(config-if)# tunnel source loopback 100
|
Specifies the source interface type and number for the tunnel interface.
|
Step 34 |
tunnel mode ipv6ip [ 6rd | 6to4 | auto-tunnel | isatap ]
Router(config-if)# tunnel mode ipv6ip 6rd
|
Configures a static IPv6 tunnel interface.
|
Step 35 |
tunnel 6rd ipv4 {prefix-length length} {suffix-length length}
Router(config-if)# tunnel 6rd ipv4 prefix-len 16 suffix-len 8
|
Specifies the prefix and suffix length of the IPv4 transport address that is common to all the 6rd tunnels.
|
Step 36 |
tunnel 6rd prefix {ipv6-prefix/ prefix-length}
Router(config-if)# tunnel 6rd prefix 2001:A000::/32
|
Specifies the common IPv6 prefix on IPv6 6rd tunnels.
|
Step 37 |
tunnel 6rd br ipv4-address
Router(config-if)# tunnel 6rd br 60.1.2.1
|
Bypasses security checks on a 6rd CE router.
Note
|
Perform this step only on a CE router, not on a BR router.
|
|
Step 38 |
tunnel vrf vrf-name2
Router(config-if)# tunnel vrf VRF_GREEN
|
Configures a VRF instance with a specific tunnel destination, interface, or a subinterface.
Note
|
This command specifies the VRF instance used for the tunnel IPv4 transport address lookup.
|
|
Step 39 |
exit
|
Exits interface configuration mode.
|
Step 40 |
ipv6 route vrf vrf-name1 {ipv6-prefix / prefix-length} tunnel tunnel-number
Router(config)# ipv6 route vrf VRF_RED 2001:A000::/32 Tunnel10
|
Establishes static routes.
-
ipv6-prefix — Specifies the IPv6 network that is the destination of the static route. Can also be a host name when static host routes
are configured.
-
ipv6-address
— The IPv6 address of the next hop that can be used to reach the specified network..
|
Step 41 |
ipv6 route vrf vrf-name1 {ipv6-prefix/ prefix-length} tunnel tunnel-number ipv6-address
Router(config)# ipv6 route vrf VRF_RED 9000:1000::/64 Tunnel10 2001:A000:200::1
|
Establishes static routes.
-
ipv6-prefix — Specifies the IPv6 network that is the destination of the static route. Can also be a host name when static host routes
are configured.
-
prefix-length — Specifies the length of the IPv6 prefix.
|
Step 42 |
end
|
Ends the current configuration session.
|