Configurar o AnyConnect Remote Access VPN
no FTD
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Introduction

Este documento descreve uma configuragéo para o AnyConnect Remote Access VPN no FTD.

Prerequisites

Requirements
A Cisco recomenda que vocé tenha conhecimento destes topicos:

- Conhecimento basico de VPN, TLS e IKEv2

- Conhecimento de Autenticacao, Autorizacao e Tarifagao Basica (AAA - Basic Authentication,
Authorization, and Accounting) e RADIUS

- Experiéncia com o Firepower Management Center

Componentes Utilizados
As informacgdes neste documento sao baseadas nestas versdes de software e hardware:

. FTD 7.2.0 da Cisco



- Cisco FMC 7.2.1
- AnyConnect 4.10

The information in this document was created from the devices in a specific lab environment. All of
the devices used in this document started with a cleared (default) configuration. Se a rede estiver
ativa, certifique-se de que vocé entenda o impacto potencial de qualquer comando.

Informacdes de Apoio

Este documento fornece um exemplo de configuragado para o Firepower Threat Defense (FTD)
versao 7.2.0 e posterior, que permite que a VPN de acesso remoto use o Transport Layer
Security (TLS) e o Internet Key Exchange versao 2 (IKEv2). Como um cliente, o Cisco
AnyConnect pode ser usado, que € suportado em varias plataformas.

Configuragao

1. Prerequisites
Para passar pelo assistente de acesso remoto no Firepower Management Center:

- Crie um certificado usado para autenticacao de servidor.

- Configure o servidor RADIUS ou LDAP para autenticagao de usuario.
- Crie um pool de enderecos para usuarios VPN.

. Carregue imagens do AnyConnect para plataformas diferentes.

a) Importar o certificado SSL

Os certificados sdo essenciais ao configurar o AnyConnect. O certificado deve ter a extensao de
Nome Alternativo da Entidade com o nome DNS e/ou endereco IP para evitar erros em
navegadores da Web.

Observagao: somente usuarios registrados da Cisco tém acesso a ferramentas internas e
informagdes de bug.

Ha limitacdes para o registro manual de certificados:
- No FTD, vocé precisa do certificado CA antes de gerar o CSR.

- Se 0 CSR for gerado externamente, o método manual falhara, um método diferente devera ser
usado (PKCS12).

Ha varios métodos para obter um certificado no dispositivo FTD, mas o seguro e facil € criar uma
CSR (Certificate Signing Request, Solicitagdo de assinatura de certificado), assina-la com uma
CA (Certificate Authority, Autoridade de certificado) e importar o certificado emitido para a chave
publica, que estava em CSR. Veja como fazer isso:

- Ir para Objects > Object Management > PKI > Cert Enroliment clique em Add Cert Enroliment.



Add Cert Enroliment (7]

Name*
vpntestbbed.cisco.com
Description
|
CA Information Certificate Parameters Key Revocation

Enrollment Type: | Manual v
[ ] CA Only
Check this option if you do not require an identity certificate fo be created
from this CA
CA Certificate: Ep':“_ Iangreno .. ST2xar
YfPCilB7g

BMAV7Gzdc4VspS6ljirAhbiiaw
dBiQIQmsBeFz9JkF4..b3I8Bo
GN+gMa56Y
lt8unaZgY4l20//on88r5IWJIm

Validation Usage: IPsec Client SSL Client [ | SSL Server
| | Skip Check for CA flag in basic constraints of the CA Certificate

|| Allow Overrides

| Cancel | Save

- Selecionar Enroliment Type € cole o certificado da Autoridade de Certificagao (CA) (o certificado
usado para assinar o CSR).

- Em seguida, va para a segunda guia e selecione custom FQDN e preencha todos os campos
necessarios, por exemplo:



Add Cert Enroliment Q

Name*
vpntesthbed.cisco.com
Description
CA Information Certificate Parameters Key Revocation

Include FQDN: Use Device Hostname as FODN

Include Device's IP Address: 10.88.243.123

Common Mame (CN): vpntestbed.cisco.com

Organization Unit (OU): TAC

Organization (0): | Mexico

Locality (L): | MX

State (ST): CDMX

Country Code (C): | MX

Email (E): I tac@cisco.com

Include Device's Serial Number | |

|| Allow Overrides

Cancel Save

- Na terceira guia, selecione key Type, escolha nome e tamanho. Para RSA, 2048 bits s&o no
minimo.

- Clique em salvar e va para Devices > Certificates > Add > New Certificate.

- Em seguida selecione Device, € sOb Cert Enroliment selecione o ponto confiavel que vocé acabou
de criar, clique em Add:



Add New Certificate (7]

Add a new certificate to the device using cert enrollment object which is used to
generate CA and identify certificate.

Device®:
FTD v

Cert Enrollment®:

l vpntestbed.cisco.com| v ‘ +

Cert Enrollment Details:

MName: vpntestbed.cisco.com

- Depois, ao lado do nome do ponto de confianga, clique no 'l:::'? , em seguida Yes, e depois
copie CSR para CA e assine-o. O certificado deve ter atributos iguais aos normais de um
servidor HTTPS.

- Depois de receber o certificado da CA no formato base64, selecione-o no disco e clique em
Import. Quando isso for bem-sucedido, vocé vera:

=D -

vntesshed.ctsen.com Gicoal Seit-Signed oA (4D tRPCE

b) Configurar o servidor RADIUS

< r para Objects > Object Management > RADIUS Server Group > Add RADIUS Server Group.
- Preencha o nome e adicione o endereco IP junto com o segredo compartilhado, clique em
Save:



Edit RADIUS Server

IP Address/Hostname:*

192.168.20.7
Configure DNS at Threat Defense Platform Settings to resolve hostname
Authentication Port:* (1-65535)

1812
Key:*

Confirm Key:*

—
—a
I
an
(9 |
(]
Cad
(9 |

Accounting Port:
1813

Timeout: (1-300) Seconds
10

Connect using:
(® Routing () Specific Interface @

Default: Management/Diagnostic i

Redirect ACL:

- Depois disso, vocé vera o servidor na lista:

Marme

RadiusServer

c¢) Crie um pool de enderegos para usuarios de VPN




< r para Objects > Object Management > Address Pools > Add IPv4 Pools.
. Coloque o nome e o intervalo, a mascara nao € necessaria:

Name*

I vpn_pool ‘

IPv4 Address Range*
\ 10.72.1.1-10.72.1.150 \

Mask
‘ Specify a netmask in X.X.X.X format ‘

Description

Allow Overrides

. Configure device overrides in the address pool object to
avoid IP address conflicts in case of object is shared across
multiple devices

»  Override (0)

d) Criar perfil XML

- Faca o download do Editor de perfis no site da Cisco e abra-o.
- Ir para server List > Add...
- Coloque o Nome para Exibicdo e o FQDN. Vocé vera entradas na Lista de servidores:

[ AnyConnect Profile Editor - VPN — O *
File Help
4 -
L VPN | Server List

{§ Preferences (Part 1) . .
lllll % preferences (part 2 Profile: C:AUsers\calo\Documents\Anyconnect_profile.xml

----- % Backup Servers
----- # Certificate Pinni
= C:;tiﬁi:te I't"::gigng Hostname Host Address User Group Backup Server List SCEP Mobile Settings Certificate Pins
_____ Z Certificate Enrollment VPM(S5L) vpntestbed.dsco.... -- Inherited --
[} Mobile Policy VPN(IPSEC) vpntestbed. dsco.... - Inherited -

----- Server List

Mote: it is highly recommended that at least one server be defined in a profile. Add... ' Delete

. Clique em oke File > Save as...



e) Carregar imagens do AnyConnect

- Faca o download de imagens de pacotes do site da Cisco.
o r para Objects > Object Management > VPN > AnyConnect File > Add AnyConnect File.
- Digite o nome e selecione o arquivo PKG no disco. Clique em save:

Edit AnyConnect File (7]

Mame:*

| Wnyconnectmac4.10 |

File Name:*

| anyconnect-macos-4.10.06079-webdef | | Browse..
File Type:*

| AnyConnect Client Image v |
Description:

Cancel |

- Adicione mais pacotes com base em seus préprios requisitos.

2. Assistente de Acesso Remoto

- Ir para Devices > VPN > Remote Access > Add a new configuration.
- Nomeie o perfil e selecione o dispositivo FTD:



Targeted Devices and Protocols

This wizard will guide you through the required minimal steps to configure the Remote
Access VPN policy with a new user-defined connection profile.

Mame:*

| Anyconnect_RA |

Description:

VPN Protocols:

SSL
IPsec-IKEv2

Targeted Devices:

Available Devices Selected Devices

| Q_ Search | FTD

FTD

- Na etapa Perfil de Conexao, digite Connection Profile Name, Selecione a Authentication Server € Address
Pools que VOcé criou anteriormente:



Connection Profile:

Connection Profiles specify the tunnel group policies for a VPN connection. These policies pertain to creating the
tunnel itself, how AAA is accomplished and how addresses are assigned. They also include user attributes, which
are defined in group policies.

Connection Profile Name:* | Anyconnect_RA

I @ This name is configured as a connection alias, it can be used to connect to the VPN gateway

Authentication, Authorization & Accounting (AAA):

Specify the method of authentication (AAA, certificates or both), and the AAA servers that will be used for VPN
connections.

Authentication Method: [ AAA Only v l

RadiusServer v l -+
(LOCAL or Realm or RADIUS)
[ Fallback to LOCAL Authentication

Authentication Server:*

Authorization Server: | Use same authentication server | +
(Realm or RADIUS)

Accounting Server: | v | -
(RADIUS)

Client Address Assignment:

Client IP address can be assigned from AAA server, DHCP server and IP address pools. When multiple options are
selected, IP address assignment is tried in the order of AAA server, DHCP server and IP address pool.

] Use AAA Server (Realm or RADIUS only) @
[ ] Use DHCP Servers
Use IP Address Pools

IPvd Address Pools: | vpn_pool

N

IPv6 Address Pools: I

Group Policy:

A group policy is a collection of user-oriented session attributes which are assigned to client when a VPN
connection is established. Select or create a Group Policy object.

Group Policy:* DfitGrpPolicy v | +

Edit Group Policy

- Clique em Edit Group Policy €, na guia AnyConnect, selecione client Profilee clique em Save:



Edit Group Policy (7]

Name:*
DfitGrpPolicy

Description:

General AnyConnect Advanced

Profile

AnyConnect profiles contains settings for the VPN client functionality and
Management Profile = optional features. Firewall Threat Defense deploys the profiles during
AnyConnect client connection.

Client Modules

SSL Settings Client Profile:

Connection Settings Anyconnect_profile v | +

Custom Attributes Standalone profile editor can be used to create a new or modify existing

AnyConnect profile. You can download the profile editor from Cisco Software
Download Center.

- Na proxima pagina, selecione as imagens do AnyConnect e clique em Next.
AnyConnect Client Image

The VPN gateway can automatically download the latest AnyConnect package to the client device when the VPN
connection is initiated. Minimize connection setup time by choosing the appropriate OS for the selected package.

Download AnyConnect Client packages from Cisco Software Download Center.

Show Re-order buttons 4

AnyConnect File Object Name AnyConnect Client Package Name Operating System

Anyconnectmac4.10 anyconnect-macos-4.10.06079-webdeploy... Mac OS v ‘

- Na proxima tela, selecione Network Interface and Device Certificates:



Network Interface for Incoming VPN Access

Select or create an Interface Group or a Security Zone that contains the network interfaces users
will access for VPN connections.

Interface group/Security Zone:* | Outsied v | +

Enable DTLS on member interfaces

A All the devices must have interfaces as part of the Interface Group/Security Zone selected.

Device Certificates

Device certificate (also called Identity certificate) identifies the VPN gateway to the remote access
clients. Select a certificate which is used to authenticate the VPN gateway.

Certificate Enrollment:* vpntestbed.cisco.com v | +

Access Control for VPN Traffic

All decrypted traffic in the VPN tunnel is subjected to the Access Control Policy by default. Select
this option to bypass decrypted traffic from the Access Control Policy.

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
This option bypasses the Access Control Policy inspection, but VPN filter ACL and
authorization ACL downloaded from AAA server are still applied to VPN traffic.

- Quando tudo estiver configurado corretamente, vocé podera clicar em Finish € depois Deploy:



o o - (] L
r o el o EE, T
Remote Outside VPN

AnyConnect
User Client Device

5
ABA

Remete Access VN Policy Configurstion Additional Configuration Requirements

Firepower Management Center will configure an RA VPN Policy with the following settings " -
SaEE. g e =B Wing SeingS  After the wizard completes, the following
configuration needs to be completed for VPN to
work on all device targets.

Name: Anyconnect_RA
Device Targets: FTD

Connection Profile:
Connection Alias:
AAA:
Authentication Method:
Authentication Server:
Authorization Server:
Accounting Server;
Address Assignment:
Address from AAA:
DHCP Servers:
Address Pools (IPvd):
Address Pools (IPv6):
Group Policy:
AnyConnect Images:
Interface Objects:

Device Certificates:

Anyconnect_RA

Anyconnect_RA

AAA Only
RadiusServer (RADIUS)
RadiusServer (RADIUS)

vpn_pool
DMGrpPolicy
Anyconnectmac4.10
Qutsied

vpntestbed.cisco.com

© Access Control Policy Update

An Access Control rule must be defined to allow
VPN traffic on all targeted devices.

© NAT Exemption

If MAT is enabled on the targeted devices, you
must define a NAT Policy to exempt VPN traffic.

@ DNS Configuration

To resolve hostname specified in AAA Servers
or CA Servers, configure DNS using FlexConfig
Policy on the targeted devices.

@ Port Configuration

SSL will be enabled on port 443.
IPsec-IKEv2 uses port 500 and Client Services
will be enabled on port 443 for Anyconnect
image download.NAT-Traversal will be enabled
by default and will use port 4500.

Please ensure that these ports are not used in
NAT Policy or other services before deploying
the configuration.
Device Identity Certificate Enrollment
A Network Interface Configuration
Certificate enrollment object 'vpntestbed.cisco.com’ is not installed on one or more
targeted devices. Certificate installation will be initiated on the targeted devices on
finishing the wizard. Go to the Certificates page to check the status of the installation.

Make sure to add interface from targeted
devices to SecurityZone object 'Outsied’

- Isso copia toda a configuracao junto com os certificados e os pacotes do AnyConnect para o
dispositivo FTD.

Conexao

Para se conectar ao FTD, vocé precisa abrir um navegador, digitar o nome DNS ou o endereco IP
que aponta para a interface externa. Em seguida, efetue login com as credenciais armazenadas
no servidor RADIUS e siga as instru¢des na tela. Depois que o AnyConnect for instalado, vocé
precisara colocar o mesmo endereco na janela do AnyConnect e clicar em Connect.

LimitagOes
Atualmente sem suporte no FTD, mas disponivel no ASA:

- Nao ha suporte para a selegao de interface no servidor RADIUS no Firepower Threat
Defense6.2.3 ou em versdes anteriores. A opgao de interface é ignorada durante a
implantagao.

- Um servidor RADIUS habilitado para autorizagao dinamica requerFirepower Threat Defense
6.3 ou posterior para que a autorizacdo dinamica funcione.



- A VPN FTDposture nao oferece suporte a alteragdo de politica de grupo por meio de
autorizac&do dinamica ou alteracéo de autorizagéo (CoA) RADIUS.

- Personalizagdo do AnyConnect (Aprimoramento: ID de bug da Cisco CSCvq87631)

- Scripts do AnyConnect

- Localizagao do AnyConnect

- Integragdo com WSA

- Mapa de criptografia dindmica IKEv2 simultaneo para RA e VPN L2L (Aprimoramento: ID de

bug Cisco CSCvr52047)

- Médulos do AnyConnect (NAM, Hostscan, AMP Enabler, SBL, Umbrella, Web Security e
assim por diante) - O DART ¢ instalado por padrao (Aprimoramentos do AMP Enabler e
Umbrella: ID de bug da Cisco CSCvs03562 e ID de bug da Cisco CSCvs06642).

- TACACS, Kerberos (autenticagao KCD e RSA SDI)

- Proxy do navegador

Consideragbes sobre seguranga

Por padrao, o sysopt connection permit-vpnesta desativada. Isso significa que vocé precisa permitir o
trafego que vem do pool de enderecos na interface externa através da Politica de Controle de
Acesso. Embora a regra de pré-filtro ou de controle de acesso seja adicionada para permitir
somente o trafego VPN, se o trafego de texto simples corresponder aos critérios da regra, ele
sera permitido erroneamente.

Ha duas abordagens para esse problema. Primeiro, a op¢cao recomendada do TAC é ativar o Anti-

Spoofing (no ASA, era conhecido como Unicast Reverse Path Forwarding - uRPF) para a
interface externa e, segundo, € ativar sysopt connection permit-vpn para ignorar completamente a
inspegao Snort. A primeira opgao permite uma inspegao normal do trafego que vai para e de
usuarios de VPN.

a) Habilitar uRPF

- Crie uma rota nula para a rede usada para usuarios de acesso remoto, definida na segao C.
V& para Devices > Device Management > Edit > Routing > Static Route € Selecione Add route


https://cdetsng.cisco.com/summary/#/defect/CSCvq87631
https://cdetsng.cisco.com/summary/#/defect/CSCvr52047
https://cdetsng.cisco.com/summary/#/defect/CSCvs03562
https://cdetsng.cisco.com/summary/#/defect/CSCvs06642

Add Static Route Configuration 7

Type: @ IPvd () IPV6
Interface*
\ Nullo v \

(Interface starting with this icon [ signifies it is available for route leak)

Available Network . Selected Network

Q, Search ‘ Add ‘ objvpnusers ™
any-ipvd
FMC
GW

IPvd-Benchmark-Tests
IPvd-Link-Local
IPvd-Multicast

Gateway*

Metric:
1

(1 -254)

Tunneled: [ | (Used only for default Route)

Route Tracking:

- Em seguida, habilite o uRPF na interface onde as conexdes VPN terminam. Para localizar
iSSO, navegue até Devices > Device Management > Edit > Interfaces > Edit > Advanced > Security Configuration
> Enable Anti Spoofing.



Edit Physical Interface L]

General IPwd IPv6 Path Monitoring Hardware Configuration Manager Access Advanced
I

Information ARP Security Configuration

Enable Anti Spoofing:
Allow Full Fragment Reassembly:

Override Default Fragment Setting:

‘ Cancel |m

Quando um usuario esta conectado, a rota de 32 bits € instalada para esse usuario na tabela de
roteamento. Limpe o trafego de texto originado de outros enderegos IP nao utilizados do pool que
€ descartado pelo uRFP. Para ver uma descrigcdo de Anti-Spoofingconsulte Definir parametros de
configuracao de seguranca no Firepower Threat Defense.

b) Habilitar sysopt connection permit-vpn Opgao

. Se vocé tiver a versao 6.2.3 ou posterior, ha uma opc¢ao para fazer isso com o assistente ou

SOb Devices > VPN > Remote Access > VPN Profile > Access Interfaces.

Access Control for VPN Traffic

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)

e

LA
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L
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bypasses the inspection, but VPN Filter ACL and authorization ACL downloaded from

o

ALl server are still -\.-"'_-Il-\.-'“"l_l to VPN trafiic.

- Para versdes anteriores a 6.2.3, va para Objects > Object Management > FlexConfig > Text Object > Add Text

Object.

- Crie uma variavel de objeto de texto, por exemplo: vpnSysVar uma unica entrada com valor
sysopt.

< r para Objects> Object Management > FlexConfig > FlexConfig Object > Add FlexConfig Object.

- Crie o Flexconfig objeto com CLI connection permit-vpn.

- Insira a variavel de objeto de texto no FlexConfig Objeto na CLI com $vpnSysVar connection permit-
vpn. Clique em save:


/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F
/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F

Insert Text Object Variable

Variable Name: | wpnSysvar
Description:

Available Objects & Selected Object

[ 4, Search [T vpnSysvar

S ———

[T tepMssBytes
[T tepMssMinimum
[T threat_cetection_statistics

[T vadan_wve_only

[T vdtan_Port_and_Nve
[T wtan_wni

[T weepPassword

- Aplique a FlexConfigobjeto como Append e selecione a implantag&do para Everytime:

Edit FlexConfig Object ? %
Name: | connection_permit-vpn
Description:

Oumsern~ | E | Deploymert: Type:

Variables E]
vpnSysvar SINGLE sysopt FREEFORM:vpn.. false

[ Save J [ Cancel J

- Ir parapevices > FlexConfig € edite a politica atual ou crie uma nova com New Policy botao.
- Adicionar apenas 0s FlexConfig, clique em Save.
- Implantar a configuragao para provisionarsysopt connection permit-vpnno dispositivo.

Depois disso, no entanto, vocé nao podera usar a Politica de Controle de Acesso para

inspecionar o trafego que vem dos usuarios. Vocé ainda pode usar o filtro de VPN ou a ACL para
download para filtrar o trafego do usuario.

Se vocé vir pacotes descartados com o Snort dos usuarios VPN, entre em contato com o TAC e



mencione o bug da Cisco ID CSCvg91399.

Informagdes Relacionadas

- Suporte técnico e downloads da Cisco



https://cdetsng.cisco.com/summary/#/defect/CSCvg91399
https://www.cisco.com/c/pt_br/support/index.html?referring_site=bodynav

Sobre esta tradugao

A Cisco traduziu este documento com a ajuda de tecnologias de tradugéo automatica e
humana para oferecer conteudo de suporte aos seus usuarios no seu proprio idioma,
independentemente da localizagao.

Observe que mesmo a melhor tradugao automatica nao sera tao precisa quanto as realizadas
por um tradutor profissional.

A Cisco Systems, Inc. ndo se responsabiliza pela precisdo destas tradugdes e recomenda
que o documento original em inglés (link fornecido) seja sempre consultado.



