De documentatie van dit product is waar mogelijk geschreven met inclusief taalgebruik. Inclusief taalgebruik wordt in deze documentatie gedefinieerd als taal die geen discriminatie op basis van leeftijd, handicap, gender, etniciteit, seksuele oriëntatie, sociaaleconomische status of combinaties hiervan weerspiegelt. In deze documentatie kunnen uitzonderingen voorkomen vanwege bewoordingen die in de gebruikersinterfaces van de productsoftware zijn gecodeerd, die op het taalgebruik in de RFP-documentatie zijn gebaseerd of die worden gebruikt in een product van een externe partij waarnaar wordt verwezen. Lees meer over hoe Cisco gebruikmaakt van inclusief taalgebruik.
Cisco heeft dit document vertaald via een combinatie van machine- en menselijke technologie om onze gebruikers wereldwijd ondersteuningscontent te bieden in hun eigen taal. Houd er rekening mee dat zelfs de beste machinevertaling niet net zo nauwkeurig is als die van een professionele vertaler. Cisco Systems, Inc. is niet aansprakelijk voor de nauwkeurigheid van deze vertalingen en raadt aan altijd het oorspronkelijke Engelstalige document (link) te raadplegen.
Het doel van dit artikel is de gemeenschappelijke foutmeldingen te verzamelen die we krijgen bij het configureren van QoS-functies op Catalyst 3850 Series switches. De voorbeelden werden uitgevoerd met IOS XE versie 3.03.05SE.
Begrijpen van de MQoS-configuratie (Modular Quality of Service) (QoS) van Catalyst 3850-switches (CLI).
Er zijn geen specifieke vereisten van toepassing op dit document.
De informatie in dit document is gebaseerd op Cisco Catalyst 3850 Series-switches.
De informatie in dit document is gebaseerd op de apparaten in een specifieke laboratoriumomgeving. Alle apparaten die in dit document worden gebruikt, begonnen met de standaardconfiguratie. Als uw netwerk live is, moet u de potentiële impact van elke opdracht begrijpen.
Voorbeeld:
class-map match-any realtime
class-map match-any priority
class-map match-any missioncritical
class-map match-any transactional
class-map match-any scavenger
OF
policy-map Edge-QoS
class realtime
class priority
class missioncritical
class transactional
class scavenger
class class-default
3850(config-pmap-c)#interface Gi 1/0/1
3850(config-if)#service-policy input Edge-QoS
3850(config-if)#
*Mar 11 09:12:59.897: Empty class unsupported
Beperking(en):
Werken:
Voorbeeld:
int range Gi1/0/1 - 24
service-policy input queueing
% Range command terminated because it failed on GigabitEthernet1/0/1
Beperking(en): None
Werken:
Voorbeeld:
access-list 150 permit ip 172.16.2.0 0.0.0.255 172.16.1.0 0.0.0.255
class-map match-any SAN_TRAFFIC
match access-group 150
!
policy-map SAN_POLICY
class SAN_TRAFFIC
bandwidth remaining ratio 10
class class-default
shape average percent 10
Beperking(en): Dit is hetzelfde als de foutmelding
Werken:
- een invoerbeleid maken om de DSCP/CoS/IPP/QoS Group-markering in te stellen op toegangsverkeer dat overeenkomt met de ACL of
- Gebruik de optie beleidstarieven in plaats van een wachtrij.
access-list 150 permit ip 172.16.2.0 0.0.0.255 172.16.1.0 0.0.0.255
class-map match-any SAN_TRAFFIC
match access-group 150
!
policy-map SAN_POLICY_INPUT
class SAN_TRAFFIC
set qos-group 1
!
class-map match-any QOS-GROUP1
match qos-group 1
!
policy-map SAN_POLICY
class QOS-GROUP1
bandwidth remaining ratio 10
class class-default
shape average percent 10
Voorbeeld:
class-map queue
queue-limit cos 1 2 3 4
Beperking(en):
Werken:
class-map queue5
queue-limit cos 1 percent 10
queue-limit cos 2 percent 20
queue-limit cos 3 percent 30
queue-limit cos 4 percent 40
Voorbeeld:
!Creating class-maps queue1 and queue2
class-map queue1
match cos 5
match dscp 46
class-map queue2
match cos 2 4 3 6
match dscp 16 18 20 22 26 32 34 36
!Assigning queueing features to queue1 and queue2
policy-map queueing
class queue1
shape average percent 70
class queue2
bandwidth remaining percent 10
!Applying the policy-map queueing to interface Gi1/0/1
interface gi1/0/1
service policy output queueing
!Creating class-maps queue5 and queue6
class-map queue5
match cos 1
match dscp 8 10 12 14
class-map queue6
match cos 5
match dscp 46
!Assigning queueing features to queue5 and queue6
policy-map queueing2
class queue5
shape average percent 70
class queue2
bandwidth remaining percent 10
!Applying the policy-map queueing to interface Gi1/0/2
interface gi1/0/2
service policy output queueing2
% Order of classes in policy name queueing2 is not consistent with installed policy
Beperking(en):
Werken:
Voorbeeld:
policy-map port-queue
class dscp-1-2-3
bandwidth percent 20
queue-limit dscp 1 percent 80
queue-limit dscp 2 percent 90
queue-limit cos 3 percent 100 <<<
Werken:
Voorbeeld:
class-map queue5
match cos 1
match dscp 8 10 12 14
class-map queue6
match cos 5
match dscp 46
policy-map queueing2
class queue5
shape average percent 70
class queue2
bandwidth remaining percent 10
interface gi1/0/1
service policy input queueing2
Beperking(en):
Werken:
Voorbeeld:
3850(config-if)#auto qos voip trust
% Cannot be deleted. Tablemap being used in policy maps.
AutoQoS Error while generating commands on Gi1/0/3.
sh run
-- Output ommited
policy-map WAN-QoS
class class-default
shape average percent 20
service-policy VoIP-QoS
-- Output ommited
interface GigabitEthernet1/0/1
service-policy out WAN-QoS <- Queueing-based policy already attach to other interface in the same stream
Beperking(en):
Werken:
Voorbeeld:
policy map bw-with-table
class class-default
bandwidth percent 10
set cos dscp table default
set dscp dscp table default
int gig2/0/1
service-policy output bw-with-table
Beperking(en):
Werken:
Voorbeeld:
policy-map priority-rate
class priority-one
priority level 1
police cir 256000 conform-action transmit exceed-action set-dscp-transmit dscp table test
Beperking(en):
Werken:
Voorbeeld:
Policy-map my-policy
class voip_signal
set dscp cs2
police cir 32000 bc 8000
conform-action transmit
exceed-action set-dscp-transmit cs3
Beperking(en):
Werken:
table-map CS2toCS3
map from 24 to 16
default copy
policy-map my-policy
class voip_signal
set dscp cs2
police cir 32000 bc 8000
conform-action transmit
exceed-action set-dscp-transmit default dscp table CS2toCS3
Voorbeeld:
policy-map CiscoPhone-Input-Policy
Class Voip-Data-Class
set ip dscp ef
police cir 256000 bc 16000 be 16000
conform-action transmit
exceed-action set-dscp-transmit dscp table policed-dscp
violate-action drop
Beperking:
Werken:
policy-map CiscoPhone-Input-Policy
Class Voip-Data-Class
set ip dscp ef
police cir 256000 bc 16000 pir 512000 be 16000
conform-action transmit
exceed-action set-dscp-transmit dscp table policed-dscp
violate-action drop