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Bulk Trace Analysis

Cisco Bulk Trace Analysis ツールは、Serviceability に付属のプラグイン ソフトウェ

ア アプリケーションです。このツールは、1 つまたは複数の大きな（2MB を超

える）XML トレース ファイルから入力データを取り出し、トレース データの分

析に使用できるレポートを作成します。

この章の構成は、次のとおりです。

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

始める前に

Bulk Trace Analysis は、XML トレース ファイルを入力ファイルとして使用しま

す。XML トレース ファイルを生成するには、Trace ツールを使用してください。

XML トレース ファイルについては、次の章を参照してください。

• トレース収集の設定（P.6-1）

• トレースの設定（P.5-1）

• トレース分析の設定（P.7-1）
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Bulk Trace Analysis のダウンロード
Bulk Trace Analysis のダウンロード
Bulk Trace Analysis ツールを Serviceability からダウンロードし、クライアント PC

にインストールします。

ここでは、Bulk Trace Analysis ツールのダウンロード方法を説明します。

手順

ステップ 1 Serviceability ウィンドウから、Application > Install Plugins の順に選択します。

Serviceability Install Plugins ウィンドウが表示されます。

ステップ 2 Bulk Trace Analysis アイコンをクリックします。

ステップ 3 ウィンドウで、Save the program to disk を選択します。

ステップ 4 Bulk Trace Analysis プログラムの保存先のファイル名と場所を入力します。

ステップ 5 OK ボタンをクリックします。

関連項目

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）
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Bulk Trace Analysis プログラムのインストール
プラグインが Serviceability プログラムからダウンロードされたら、Bulk Trace

Analysis プログラムを PC にインストールします。

ここでは、Bulk Trace Analysis プログラムをクライアント PC にインストールす

る方法を説明します。

手順

ステップ 1 PC で、Bulk Trace Analysis アイコンまたはファイル名 

TraceAnalysis_installation.exe をダブルクリックします。

インストレーション ウィザード ウィンドウが表示されます。

ステップ 2 表示されるウィンドウで Next > ボタンをクリックします。

ステップ 3 Finish ボタンをクリックします。

これで、インストールされたプログラムが使用できるようになりました。

関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis の使用（P.24-4）
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Bulk Trace Analysis の使用
Bulk Trace Analysis は、1 つまたは複数の SDI XML トレース ファイルまたは SDL

XML トレース ファイルを取り出し、トレース データの分析に使用できるレポー

トを作成します。Bulk Trace Analysis では、次のレポート機能がサポートされて

います。

• プログラムの起動と終了

• レポートの作成

• レポートのオープン

• レポートの印刷

• マスタ レポートの保存

• レポート内のデータの検索

• 複数ビューを持つレポートの作成

• ビュー情報の表示

• Report Table 見出しのカスタマイズ

始める前に

Bulk Trace Analysis プログラムは、Cisco CallManager パブリッシャ システムまた

はサブスクライバ システム以外の PC にインストールする必要があります。

P.24-2 の「Bulk Trace Analysis のダウンロード」および P.24-3 の「Bulk Trace

Analysis プログラムのインストール」を参照してください。

PC 上でこのプログラムが起動され、実行中であることを確認してください。

P.24-4 の「プログラムの起動と終了」を参照してください。

プログラムの起動と終了

ここでは、Bulk Trace Analysis プログラムの起動および終了の方法を説明します。

ステップ 1 ［スタート］>［プログラム］> Cisco Bulk Trace Analysis Tool の順に選択します。

Bulk Trace Analysis Tool ウィンドウが表示されます。図 24-1 を参照してください。
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Bulk Trace Analysis の使用
ステップ 2 この項で説明されている手順に従って、レポートの作成、レポートのオープン、

およびレポートの印刷を行います。

ステップ 3 File > Exit の順に選択して、プログラムを終了します。

図 24-1 Bulk Trace Analysis ウィンドウ

1 Workplace

2 Report Table

3 Task Control and Status
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関連項目

• レポートの作成（P.24-6）

• レポートのオープン（P.24-9）

• レポートの印刷（P.24-10）

• マスタ レポートの保存（P.24-11）

• レポート内のデータの検索（P.24-12）

• 複数ビューを持つレポートの作成（P.24-13）

• ビュー情報の表示（P.24-17）

• Report Table 見出しのカスタマイズ（P.24-18）

レポートの作成

Bulk Trace Analysis では、SDI XML トレース ファイルまたは SDL XML トレース

ファイルを使用してレポートが作成されます。次の入力トレース ファイルを使

用してレポートを作成します。

• Bulk Trace Analysis プログラムの File Open ダイアログ ウィンドウで、Control
キーを押したまま複数のファイル名を選択して、複数の XML ファイルを選

択する。

• Bulk Trace Analysis プログラムの File Open ダイアログ ウィンドウにリモー

ト Cisco CallManager ノードの IP アドレスを入力して、そのノードからファ

イルを選択する。ユーザ ID とパスワードを使用する必要があります。

• Cisco CallManager Serviceability から、Trace Collection ツールを使用して収集

された zip ファイルを選択する。

注意 Bulk Trace Analysis プログラムは、オリジナルの XML トレース ファイル、また

は Trace Collection ツールが zip 圧縮したトレース ファイルしか受け入れません。

他のアプリケーション（たとえば、WinZip）によって zip 圧縮されたトレース

ファイルを使用すると、Cisco CallManager システムの動作が停止する可能性があ

ります。
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手順

ここでは、トレース ファイルからレポートを作成する方法を説明します。

ステップ 1 Bulk Trace Analysis ウィンドウから、File > New Report の順に選択します。

New File ダイアログ ウィンドウが表示されます。

ステップ 2 SDI トレース ファイルを選択する場合は、SDI ボタンをクリックします。SDL ト

レース ファイルを選択する場合は、SDL ボタンをクリックします。

ステップ 3 Browse ボタンをクリックして、トレース ソース ファイルを選択します。

Open ウィンドウが表示されます。

ステップ 4 ファイルのリストから、ソース トレース ファイルを選択します。

ステップ 5 Open ボタンをクリックします。

New File ダイアログ ウィンドウが表示され、選択したファイルが Source File

フィールドに表示されます。複数のファイルを選択するには、Control キーを押

したままファイル名をクリックします。

ステップ 6 Save Report As フィールドに表示されたデフォルトのファイル名を使用してレ

ポートを保存するには、OK ボタンをクリックします。ステップ 10 に進みます。

デフォルトのファイル名を使用しない場合は、ステップ 7 に進みます。

ステップ 7 別のファイル名を使用してレポートを保存するには、Browse ボタンをクリック

します。

ステップ 8 Save As ウィンドウで、ファイル名のフィールドにファイル名を入力するか、デ

フォルトを使用します。
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ステップ 9 Save ボタンをクリックします。

New File ダイアログ ウィンドウが表示され、選択したファイル名が Save Report

As フィールドに表示されます。

ステップ 10 OK ボタンをクリックします。

ソース ファイルのデータは、Report Table ペインに表示されます。レポート名は

Workplace Views ペインに、レポートの状況は Task Control and Status ペインに表

示されます。図 24-1 を参照してください。

ステップ 11 レポートを保存するには、File > Save の順に選択します。

ステップ 12 Save ボタンをクリックします。

関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートのオープン（P.24-9）

• レポートの印刷（P.24-10）

• マスタ レポートの保存（P.24-11）

• レポート内のデータの検索（P.24-12）

• 複数ビューを持つレポートの作成（P.24-13）

• ビュー情報の表示（P.24-17）

• Report Table 見出しのカスタマイズ（P.24-18）
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レポートのオープン

ここでは、すでに作成されているレポートを開く方法を説明します。P.24-6 の

「レポートの作成」を参照してください。

手順

ステップ 1 Bulk Trace Analysis ウィンドウから、File > Open Report の順に選択します。

Open ダイアログ ウィンドウが表示されます。

ステップ 2 ファイルのリストから、レポート ファイルを選択します。

ステップ 3 Open ボタンをクリックします。

ソース ファイルのデータは、Report Table ペインに表示されます。レポート名は

Workplace Views ペインに、レポートの状況は Task Control and Status ペインに表

示されます。

関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートの作成（P.24-6）

• レポートの印刷（P.24-10）

• マスタ レポートの保存（P.24-11）

• レポート内のデータの検索（P.24-12）

• 複数ビューを持つレポートの作成（P.24-13）

• ビュー情報の表示（P.24-17）

• Report Table 見出しのカスタマイズ（P.24-18）
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レポートの印刷

ここでは、レポートの印刷方法を説明します。

手順

ステップ 1 複数のレポートが開いている場合は、印刷するレポートを選択します。

ヒント レポートの印刷前に、File > Print Preview の順に選択してください。

ステップ 2 Bulk Trace Analysis ウィンドウで、File > Print の順に選択します。

Print ダイアログ ウィンドウが表示されます。

ヒント 用紙のレイアウトとして Landscape（横長）を選択してください。

ステップ 3 OK ボタンをクリックします。

関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートの作成（P.24-6）

• レポートのオープン（P.24-9）

• マスタ レポートの保存（P.24-11）

• レポート内のデータの検索（P.24-12）
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• 複数ビューを持つレポートの作成（P.24-13）

• ビュー情報の表示（P.24-17）

• Report Table 見出しのカスタマイズ（P.24-18）

マスタ レポートの保存

ここでは、マスタ レポートの保存方法を説明します。マスタ レポートとは、フィ

ルタ基準のないレポートを指します。

手順

ステップ 1 Workplace Views ペインから、保存するレポートを選択します。

ステップ 2 File > Save の順に選択します。

関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートの作成（P.24-6）

• レポートのオープン（P.24-9）

• レポートの印刷（P.24-10）

• レポート内のデータの検索（P.24-12）

• 複数ビューを持つレポートの作成（P.24-13）

• ビュー情報の表示（P.24-17）

• Report Table 見出しのカスタマイズ（P.24-18）
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レポート内のデータの検索

ここでは、レポート内のデータ（情報）を検索する方法を説明します。

手順

ステップ 1 Workplace Views ペインから、検索するレポートを選択します。

ステップ 2 Edit > Find の順に選択するか、双眼鏡のアイコンをクリックします。

Find ウィンドウが表示されます。

ステップ 3 検索基準（たとえば、Alarm）を入力します。

ステップ 4 表 24-1 を参考にして、その他の検索オプションを選択します。

ステップ 5 Find Next ボタンをクリックします。

一致が強調表示されます。

ステップ 6 再度検索するには、Find Next ボタンをクリックします。

ステップ 7 検索が終了したら、Cancel ボタンをクリックします。

表 24-1 検索オプション

オプション 説明

Match case 検索基準の文字（大文字と小文字も区別）と正確に一致す

るファイルを検索します。

Up Direction 検索基準に基づいて、現在のカーソル位置から上方向に

ファイルを検索します。

Down Direction 検索基準に基づいて、現在のカーソル位置から下方向に

ファイルを検索します。
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関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートの作成（P.24-6）

• レポートのオープン（P.24-9）

• レポートの印刷（P.24-10）

• マスタ レポートの保存（P.24-11）

• 複数ビューを持つレポートの作成（P.24-13）

• ビュー情報の表示（P.24-17）

• Report Table 見出しのカスタマイズ（P.24-18）

複数ビューを持つレポートの作成

ビューとは、トラブルシューティングに使用される特定の情報が表示されている

レポートを指します。1 つのレポートに複数のビューを表示できます。複数の

ビューを使用すると、さまざまな観点からトレース情報を調べることができま

す。

Bulk Trace Analysis フィルタリング基準の設定は、Trace Analysis ツールのフィル

タリング基準の設定とほぼ同じです（P.7-1 の「トレース分析の設定」を参照）。

トレース分析に組み込む情報のタイプ（たとえば、ホスト名、IP アドレス、相

関タグ）を選択できます。

相関タグのフィルタリングを選択すると、相関タグのフィルタリングを選択しな

い場合よりも多くの情報が得られます。相関タグのフィルタリングでは、トレー

ス相互間の関係が示されます。以下の例を参照してください。

相関タグを使用した例

トレース ファイルで、ユーザは Use Correlation Tag チェックボックスをオンに

し、IP Address=172.21.10.55 および Trace type=Alarm のフィルタを選択するもの

とします。Bulk Trace Analysis は、この IP アドレスとトレース タイプを持つすべ

てのトレース レコードを探し、そのトレース レコードに関連した相関タグを持
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つすべてのトレース レコードを収集します。相関タグは、検出されたすべての

トレース レコードに適用され、再度フィルタに掛けられます。トレース フィル

タは、次のレコードを検出します。

• レコード 1：IP Address=172.21.10.55, Trace type=Alarm, Ctag=3,65,100,1.1

• レコード 2：IP Address=172.21.10.55, Trace type=Error, Ctag=3,65,100,1.1

• レコード 3：IP Address=172.21.10.56, Trace type=Alarm, Ctag=3,65,100,1.1

• レコード 4：IP Address=172.21.10.57, Trace type=Trace, Ctag=3,65,100,1.3

Use Correlation Tag チェックボックスがオンになっているので、ビューには、レ

コード 1、レコード 2、およびレコード 3 が表示されます。

相関タグを使用しない例

トレース ファイルで、ユーザは、Use Correlation Tag チェックボックスをオンに

しないものとします。ユーザは、IP Address=172.21.10.55 および Trace type=Alarm

のフィルタを選択します。Bulk Trace Analysis は、この IP アドレスとトレース タ

イプを持つすべてのトレース レコードを探し、そのトレース レコードに関連し

た相関タグを持つすべてのトレース レコードを収集します。相関タグは、検出

されたすべてのトレース レコードに適用され、再度フィルタに掛けられます。ト

レース フィルタは、次のレコードを検出します。

• レコード 1：IP Address=172.21.10.55, Trace type=Alarm, Ctag=3,65,100,1.1

• レコード 2：IP Address=172.21.10.55, Trace type=Error, Ctag=3,65,100,1.1

• レコード 3：IP Address=172.21.10.56, Trace type=Alarm, Ctag=3,65,100,1.1

• レコード 4：IP Address=172.21.10.57, Trace type=Trace, Ctag=3,65,100,1.3

Use Correlation Tag チェックボックスがオンになっていないので、ビューにはレ

コード 1 だけが表示されます。

ここでは、フィルタ基準を選択し、別のビューとして保存することによって、特

定情報が入っているレポートを作成する方法を説明します。 

手順

ステップ 1 Workplace Views ペインから、別のビューを作成する対象のレポートを選択しま

す。
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ステップ 2 View > New View の順に選択し、レポート名を右クリックするか、New View ア

イコンをクリックします。

Filter ウィンドウが表示されます。

ステップ 3 トレース レコードの CTag フィールドを使用する場合は、Use Correlation Tag

チェックボックスをオンにします。P.24-13 の「相関タグを使用した例」を参照

してください。

ステップ 4 Selection Criteria 領域で、新しいビューに組み込む情報を選択します。表 24-2 を

参照してください。

ステップ 5 Time 領域で、特定の時刻と日付の範囲を選択します。

表 24-2 選択基準

オプション 説明

Use Correlation Tag 選択した選択基準に関連するすべてのトレース レ

コードをビューに含める場合は、このチェックボッ

クスをオンにします。

CallManager Host (CCM) トレースが開始された特定のホストを選択するか、

すべてのホストを選択します。

Source Device (SrcDev) トレースが作成された特定のデバイスを選択する

か、すべてのデバイスを選択します。

Source IP Address (SrcIP) トレースが作成されたデバイスの特定の IP アドレ

スを選択するか、すべての IP アドレスを選択しま

す。

Trace Type トレースが開始されたアラームまたはエラー、ア

ラームのみ、またはトレースのみなどの、トレース

タイプを選択します。
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ステップ 6 OK ボタンをクリックします。

指定された基準に合うビューが、Report Table ペインに表示され、新しいビュー

の名前（たとえば、View 2）が、Workplace Views ペインの Task 名の下に表示さ

れます。

ヒント レポートにビューを表示しない場合は、Windows のクローズ ボックスを使用し

てビューを閉じてください。

関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートの作成（P.24-6）

• レポートのオープン（P.24-9）

• レポートの印刷（P.24-10）

• マスタ レポートの保存（P.24-11）

• レポート内のデータの検索（P.24-12）

• ビュー情報の表示（P.24-17）

• Report Table 見出しのカスタマイズ（P.24-18）
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ビュー情報の表示

特定のビューのフィルタ情報を検出する必要がある場合は、その情報を表示でき

ます。ここでは、ビューのフィルタ情報を表示する方法を説明します。

手順

ステップ 1 Workplace Views ペインから、フィルタ情報を表示する対象のビューを選択しま

す。

フィルタ情報ウィンドウが表示されます。

ステップ 2 ビュー名を右クリックします。

ステップ 3 ポップアップ メニューから View Information を選択します。

ステップ 4 OK ボタンをクリックして閉じます。

関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートの作成（P.24-6）

• レポートのオープン（P.24-9）

• レポートの印刷（P.24-10）

• レポート内のデータの検索（P.24-12）

• 複数ビューを持つレポートの作成（P.24-13）

• Report Table 見出しのカスタマイズ（P.24-18）
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Report Table 見出しのカスタマイズ

レポート内の特定の列の情報を表示する場合には、それ以外の情報の列を削除で

きます。

ここでは、Report Table の見出しをカスタマイズする方法を説明します。

手順

ステップ 1 Workplace Views ペインから、Report Table 見出しをカスタマイズする対象のレ

ポートまたはビューを選択します。

ステップ 2 Edit > Customize Header の順に選択するか、Customize header アイコンをクリッ

クします。

Customize columns ウィンドウが表示されます。

ステップ 3 列を削除するには、Columns to be shown and order 領域から列を選択します。

ステップ 4 <- Remove ボタンをクリックします。

ステップ 5 列の順序を変更するには、Columns to be shown and order 領域から列を選択します。

ステップ 6 Move Up ボタンまたは Move Down ボタンをクリックします。

ステップ 7 列を追加するには、Columns not shown 領域から列を選択します。

ステップ 8 Add -> ボタンをクリックします。

ステップ 9 OK ボタンをクリックします。

見出しの配列が更新されたレポートが、Report Table ペインに表示されます。
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関連項目

• Bulk Trace Analysis のダウンロード（P.24-2）

• Bulk Trace Analysis プログラムのインストール（P.24-3）

• Bulk Trace Analysis の使用（P.24-4）

• プログラムの起動と終了（P.24-4）

• レポートの作成（P.24-6）

• レポートのオープン（P.24-9）

• レポートの印刷（P.24-10）

• マスタ レポートの保存（P.24-11）

• レポート内のデータの検索（P.24-12）

• 複数ビューを持つレポートの作成（P.24-13）

• ビュー情報の表示（P.24-17）
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