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概要

このドキュメントでは、Cisco Adaptive Security Device Manager（ASDM）を使用して、Cisco
ASA 5500 シリーズ適応型セキュリティ アプライアンスのソフトウェア イメージをアップグレー
ドする方法を説明しています。

セキュリティ アプライアンス ソフトウェアを 7.0 から 7.2 に直接アップグレード（またはダウン
グレード）する場合、または ASDM ソフトウェアを 5.0 から 5.2 直接アップグレード（またはダ
ウングレード）する場合、ASDM は機能しません。段階的にアップグレードを行う必要がありま
す。

例：ASDMソフトウェアを5.0から5.2にアップグレードするには、まず5.0から5.1にアップグレー
ドし、次に5.1から5.2にアップグレードします。同様に、セキュリティアプライアンスの場合は
、まず7.0から7.1にアップグレードしてから7.1から7.2にアップグレードします。

注：バージョン7.1.(x)から7.2(x)へのアップグレードまたはダウングレードを行う場合、古いバー
ジョンのセキュリティアプライアンスイメージは新しいASDMイメージを認識せず、新しいセキ
ュリティアプライアンスイメージは古いASDMイメージを認識しません。アップグレード手順の
詳細については、『Cisco PIX セキュリティ アプライアンス リリース ノート、バージョン
7.2(2)』の「新しいソフトウェアへのアップグレード」セクションを参照してください。

注：ASA 5550を7.1(2)より前のソフトウェアバージョンにダウングレードすることはできません

//www.cisco.com/en/US/docs/security/pix/pix72/release/notes/pixrn722.html


。 同様に、ASA 5505を7.2より前のソフトウェアバージョンにダウングレードすることはできま
せん。詳細は、『Cisco ASA 5500シリーズおよびPIX 500シリーズセキュリティアプライアンス
ハードウェアとソフトウェアの互換性』を参照してください。

注：マルチコンテクストモードでは、copy tftp flashコマンドを使用してすべてのコンテキストで
PIX/ASAイメージをアップグレードまたはダウングレードすることはできません。これは System
Exec モードのみでサポートされます。

前提条件

要件

このドキュメントに特有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

Cisco ASA 5500 7.0 以降●

Cisco ASDM 5.0 以降●

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このド
キュメントで使用するすべてのデバイスは、初期（デフォルト）設定の状態から起動しています
。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的
な影響について確実に理解しておく必要があります。

関連製品

この設定は、Cisco PIX 500 シリーズ セキュリティ アプライアンス ソフトウェア バージョン 7.0
以降にも適用できます。

表記法

ドキュメント表記の詳細については、『シスコ テクニカル ティップスの表記法』を参照してくだ
さい。

ソフトウェアのダウンロード

ASA ソフトウェア イメージおよび ASDM ソフトウェア イメージの必要なリリースバージョンは
、次のリンクからダウンロードできます

Cisco ASA ソフトウェア リリースのダウンロード（登録ユーザ専用）●

Cisco ASDM ソフトウェア リリースのダウンロード（登録ユーザ専用）●

注：このソフトウェアをCisco.comからダウンロードするには、有効なシスコユーザクレデンシ
ャルが必要です。

ASDM 5.x を使用したソフトウェア イメージのアップグレード
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//www.cisco.com/en/US/tech/tk801/tk36/technologies_tech_note09186a0080121ac5.shtml
//www.cisco.com/cisco/software/release.html?mdfid=279916854&flowid=4818&softwareid=280775065&release=8.4.4.1.ED&relind=AVAILABLE&rellifecycle=&reltype=latest
//tools.cisco.com/RPF/register/register.do
//www.cisco.com/cisco/software/release.html?mdfid=279916854&flowid=4818&softwareid=280775064&release=6.4.9&relind=AVAILABLE&rellifecycle=&reltype=latest
//tools.cisco.com/RPF/register/register.do


ASDM を使用して ASA 5500 のソフトウェア イメージをアップグレードするには、次の手順を実
行します。

ASDM の Home ウィンドウから Tools > Upgrade Software... の順に選択します。1.

ドロップダウン メニューから、アップグレードするイメージのタイプを選択します。2.

[Browse Local Files...] をクリックするか、[Local File Path] フィールドにパスを入力して、
PC 上のソフトウェア イメージの場所を指定します。

3.

[フラッシュの参照…]をクリックします。.[Browse Flash] ダイアログウィンドウが、入力し
たファイル名を自動的に表示した状態で表示されます。ファイル名が表示されていない場合
は、[File Name] フィールドに手動で入力します。完了したら、[OK] をクリックします。

4.



ローカルとリモート両方のファイル名を指定したら、[Upload Image] をクリックします。

ASDM がフラッシュにイメージを書き込んでいる間、[Status] ウィンドウが表示されます。

5.



完了すると、アップロードに成功したことを示す Information ウィンドウが表示されます。

[Information] ウィンドウで [OK] をクリックし、[Upload Image from Local PC] ウィンドウで
[Close] をクリックします。

6.

Configuration > Properties > Device Administration > Boot Image/Configuration > Edit の順に
選択して、ブート イメージの場所を変更します。

7.



Browse Flash クリックして、ASA イメージ ファイルを選択または指定します。次に [OK]
をクリックします。

File > Save Running Configuration to Flash の順に選択して、設定をフラッシュ メモリに保
存します。

8.



[Home] ウィンドウで [Tools] > [System Reload] の順に選択し、デバイスをリロードします
。

9.

リロードの詳細の確認を求める新しいウィンドウが表示されます。[Save the running
configuration at the time of reload] を選択して、次にリロードの開始時間を選択します。
Now：デバイスを即時にリブートします。Delay By：今から何分（何時間）後にデバイス
をリロードするかを指定します。Schedule at：デバイスをリロードする日時を指定します

10.



。日時を指定してのリロードが失敗した場合にデバイスの強制的リロードを即時に行うか
どうかを指定することもできます。[Reload failure, force an immediate reload after] にチェ
ックマークを付け、最大待ち時間を指定します。これは、セキュリティ アプライアンスが
シャットダウンまたはリブートを行う前に他のサブシステムに通知するための待ち時間に
なります。この時間が経過すると、即時に（強制的）シャットダウンまたはリブートが実
行されます。[Schedule Reload] をクリックします。

リロードが開始されると、[Reload Status] ウィンドウが表示され、リロードが進行中であ
ることが表示されます。ASDM を終了するオプションも表示されます。注：ASAのリロー
ド後にASDMを再起動します。

11.



ASDM 5.x を使用した ASDM イメージのアップグレード

ASDM を使用して ASA 5500 の ASDM イメージをアップグレードするには、次の手順を実行し
ます。

ASDM の Home ウィンドウから Tools > Upgrade Software... の順に選択します。1.



ドロップダウン メニューから、アップグレードするイメージのタイプを選択します。2.

Browse Local... をクリックするか、Local File Path フィールドにパスを入力して、PC 上の
ASDM イメージの場所を指定します。

3.

[フラッシュの参照…]をクリックします。.[Browse Flash] ダイアログウィンドウが、入力し
たファイル名を自動的に表示した状態で表示されます。ファイル名が表示されていない場合
は、[File Name] フィールドに手動で入力します。完了したら、[OK] をクリックします。

4.



ローカルとリモート両方のファイル名を指定したら、[Upload Image] をクリックします。

ASDM がフラッシュにイメージを書き込んでいる間、[Status] ウィンドウが表示されます。

5.



完了すると、アップロードに成功したことを示す Information ウィンドウが表示されます。

[Information] ウィンドウで [OK] をクリックし、[Upload Image from Local PC] ウィンドウで
[Close] をクリックします。

6.

Configuration > Properties > Device Administration > Boot Image/Configuration の順に選択し
て、設定に含まれる ASDM イメージのファイル名を変更します。

7.



Browse Flash クリックして、ASDM イメージ ファイルを選択または指定します。次に [OK]
をクリックします。

File > Save Running Configuration to Flash の順に選択して、設定をフラッシュ メモリに保
存します。

8.



[Home] ウィンドウで [Tools] > [System Reload] の順に選択し、デバイスをリロードします
。

9.

リロードの詳細の確認を求める新しいウィンドウが表示されます。Save the running
configuration at the time of reload をクリックして、リロードのタイミングを選択します。
Now：デバイスを即時にリブートします。Delay By：今から何分（何時間）後にデバイス
をリロードするかを指定します。Schedule at：デバイスをリロードする日時を指定します

10.



。日時を指定してのリロードが失敗した場合にデバイスの強制的リロードを即時に行うか
どうかを指定することもできます。[Reload failure, force an immediate reload after] にチェ
ックマークを付け、最大待ち時間を指定します。これは、セキュリティ アプライアンスが
シャットダウンまたはリブートを行う前に他のサブシステムに通知するための待ち時間に
なります。この時間が経過すると、即時に（強制的）シャットダウンまたはリブートが実
行されます。[Schedule Reload] をクリックします。

リロードが開始されると、[Reload Status] ウィンドウが表示され、リロードが進行中であ
ることが表示されます。ASDM を終了するオプションも表示されます。注：ASAのリロー
ド後にASDMを再起動します。

11.



ASDM 6.x を使用したソフトウェア イメージのアップグレード

注：ASDM 6.xはASAソフトウェアイメージ8.x以降でのみサポートされています。

ASDM を使用して ASA 5500 のソフトウェア イメージをアップグレードするには、次の手順を実
行します。

ASDM の Home ウィンドウから Tools > Upgrade Software from Local Computer... の順に選
択します。

1.



ドロップダウン メニューから、アップグレードするイメージのタイプを選択します。2.

[Browse Local Files...] をクリックするか、[Local File Path] フィールドにパスを入力して、
PC 上のソフトウェア イメージの場所を指定します。Flash File System のファイル パスが
自動的に確認されて表示されます。Flash File System のファイル パスが表示されない場合
は、手動で入力するか、Browse Flash をクリックしてパスを選択できます。

3.



両方のファイル パスを指定したら、Upload Image をクリックします。ASDM がフラッシュ
にイメージを書き込んでいる間、[Status] ウィンドウが表示されます。

4.

完了すると、アップロードに成功したことを示す Information ウィンドウが表示され、この
イメージをブート イメージとして設定するかどうかを尋ねられます。新しいイメージをブ
ートイメージとして設定する場合は、[Yes]をクリックします。それ以外の場合は、[No]をク
リックします。

5.

Yes をクリックした場合は、新しいイメージがブート イメージとして設定され、
Information ボックスが表示されます。[OK] をクリックします。

6.



[Home] ウィンドウで [Tools] > [System Reload] の順に選択し、デバイスをリロードします
。

7.

リロードの詳細の確認を求める新しいウィンドウが表示されます。Save the running
configuration at the time of reload を選択して、リロードのタイミングを選択します。
Now：デバイスを即時にリブートします。Delay By：今から何分（何時間）後にデバイスを
リロードするかを指定します。Schedule at：デバイスをリロードする日時を指定します。
スケジュールを設定したリロードに失敗した場合、即座にリロードを強制するかどうかを指
定することもできます。On Reload failure, force an immediate reload after にチェックマー
クを付けて、最大待ち時間を指定します。これは、セキュリティ アプライアンスがシャッ
トダウンまたはリブートを行う前に他のサブシステムに通知するための待ち時間になります
。この時間が経過すると、即時に（強制的）シャットダウンまたはリブートが実行されます
。[Schedule Reload] をクリックします。

8.



リロードが開始されると、[Reload Status] ウィンドウが表示され、リロードが進行中である
ことが表示されます。ASDM を終了するオプションも表示されます。Exit ASDM をクリッ
クし、デバイスのリロードが完了してから ASDM を再起動します。

9.



ASDM 6.x を使用した ASDM イメージのアップグレード

注：ASDM 6.xはASAソフトウェアイメージ8.x以降でのみサポートされています。

ASDM を使用して ASA 5500 の ASDM イメージをアップグレードするには、次の手順を実行し
ます。

ASDM の Home ウィンドウから Tools > Upgrade Software from Local Computer... の順に選
択します。

1.



ドロップダウン メニューから、アップグレードするイメージのタイプを選択します。2.

Browse Local Files... をクリックするか、Local File Path フィールドにパスを入力して、PC
上の ASDM イメージの場所を指定します。Flash File System のファイル パスが自動的に確
認されて表示されます。Flash File System のファイル パスが表示されない場合は、手動で
入力するか、Browse Flash をクリックしてパスを選択できます。

3.



両方のファイル パスを指定したら、Upload Image をクリックします。ASDM がフラッシュ
にイメージを書き込んでいる間、[Status] ウィンドウが表示されます。

4.

完了すると、アップロードに成功したことを示す Information ウィンドウが表示され、この
イメージをデフォルトの ASDM イメージとして設定するかどうかを尋ねられます。新しい
イメージをASDMイメージとして設定する場合は[Yes]をクリックします。それ以外の場合は
、[No]をクリックします。

5.

Yes を選択した場合は、新しいイメージが ASDM イメージとして設定され、Information ボ
ックスが表示されます。[OK] をクリックします。

6.



ウィンドウの上部にある Save をクリックして、実行コンフィギュレーションをフラッシュ
に保存します。

7.

確認のためのダイアログボックスが表示されます。[Apply] をクリックします。8.

ウィンドウの上部にある File をクリックし、Exit を選択して ASDM を閉じます。9.



確認のためのダイアログボックスが表示されます。[Yes] をクリックします。10.

ASDM を再び起動して、新しい ASDM イメージをロードします。詳細については、次のビ
デオを参照してください。Cisco Adaptive Security Device Manager(ASDM)を使用して
Cisco適応型セキュリティアプライアンス(ASA)のソフトウェアイメージをアップグレード
する方法

11.

シスコサポートコミュニティに投稿されたこのビデオでは 、ASDMを使用してCisco ASAのソフ
トウェアイメージをアップグレードする方法について説明しています。Cisco Adaptive Security
Device Manager(ASDM)を使用してCisco適応型セキュリティアプライアンス(ASA)のソフトウェ
アイメージをアップグレードする方法

https://supportforums.cisco.com/videos/2353
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https://supportforums.cisco.com/videos/2353
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CLI を使用してのソフトウェア イメージおよび ASDM イメージ
のアップグレード

PIX/ASA の ASDM イメージおよびソフトウェア イメージをアップグレードまたはダウングレー
ドするには TFTP サーバが必要です。TFTP サーバの選択に関する詳細については、『TFTP サ
ーバの選択と使用』を参照してください。

TFTP 経由でファイアウォールのフラッシュ メモリにソフトウェア イメージをダウンロードする
には、copy tftp flash コマンドを使用します。copy tftp flash コマンドは、どのセキュリティ アプ
ライアンス モデルでも使用できます。ダウンロードしたイメージは、次回のリロード（リブート
）時にセキュリティ アプライアンスで利用できるようになります。

copy tftp flash コマンドの出力は、次のとおりです。

copy tftp[:[[//location] [/tftp_pathname]]] [[flash/disk0][:[image | asdm]]]

注：ASAの場合、キーワードdisk0はcopyコマンドのフラッシュを置き換えます。

オプション パラメータの location または pathname を指定せずにこのコマンドを使用する場合は
、Cisco IOS® ソフトウェアで表示される一連の質問と同様の質問が表示されるので、場所とファ
イル名を対話形式で入力します。コロンのみを入力した場合は、tftp-server コマンドの設定から
パラメータが取得されます。その他のオプション パラメータを指定した場合、それらの値が tftp-
server コマンドに設定されている値に代わって使用されます。いずれかのオプション パラメータ
（コロンで始まる入力など）を指定した場合、コマンドは、ユーザの入力を求めるプロンプトな
しで実行されます。

場所は、IP アドレスか、またはセキュリティ アプライアンスの名前解決メカニズムによって IP
アドレスに解決される名前で指定します。このメカニズムは現在、name および names コマンド

https://supportforums.cisco.com/videos/2353
//www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a00801f7735.shtml
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による静的マッピングとなっています。セキュリティ アプライアンスは、この場所に到達する方
法を、自身のルーティング テーブル情報を通じて認識する必要があります。この情報は、IP
address、route、または RIP コマンドによって決定されます。これは、設定によって異なります
。

pathname には、サーバ上のファイルへのパスの最後となる実際のコンポーネントに加え、任意
のディレクトリ名を含めることができます。パス名にスペースを含めることはできません。スペ
ースを含むディレクトリ名が、copy tftp flash コマンド上ではなく TFTP サーバ内のディレクトリ
に設定されており、TFTP サーバがイメージのダウンロード元であるシステム上のディレクトリ
をポイントするように設定されている場合、必要なのは、システムの IP アドレスとイメージ フ
ァイル名を使用することだけです。TFTP サーバは、コマンドを受信して、自身のルート ディレ
クトリ情報から実際のファイルの場所を判断します。その後、サーバは、TFTP イメージをセキ
ュリティ アプライアンスにダウンロードします。

ソフトウェア イメージおよび ASDM イメージをアップグレードし、次回のリロード時にそれを
ブート イメージとして使用するには、次のコマンドが必要です。

ASA#copy tftp [[flash:/disk0:][software image name/asdm image name]]

!--- Command to set an image as bootup or specify the !--- ASDM image file. ASA(config)#boot

system [flash:/disk0:]/[software image name]

!--- Save active configuration to the Flash. ASA#write memory

!--- Reboot the security appliance and load !--- with the new boot image as per the

configuration file. ASA#reload

例：

ASA5510#copy tftp disk0:

Address or name of remote host []? 172.16.31.1

Source filename []? asa722-k8.bin

Destination filename [asa722-k8.bin]?

Accessing tftp://172.16.31.1/asa722-k8.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Writing file disk0:/asa722-k8.bin...

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

8312832 bytes copied in 163.350 secs (50998 bytes/sec)

ASA5510#show disk0:

-#- --length-- -----date/time------ path

  6 5124096    Jan 01 2003 00:06:22 asa702-k8.bin

  7 5623108    Feb 12 2007 00:23:48 asdm-522.bin

 10 5539756    Feb 12 2007 00:14:18 asdm-521.bin

 11 8294400    Dec 07 2006 05:47:20 asa721-24-k8.bin

 12 6002680    Dec 21 2006 03:58:30 asdm-52034.bin

 13 8312832    Feb 12 2007 22:46:30 asa722-k8.bin

23949312 bytes available (38932480 bytes used)

!--- Command to set "asa722-k8.bin" as the boot image. ASA5510(config)# boot system

disk0:/asa722-k8.bin

!--- Command to set "asdm-522.bin" as the ASDM image. ASA5510(config)# asdm image disk0:/asdm-

522.bin

ASA5510# write memory

ASA5510# reload



注：ASA上のイメージをFTPサーバからアップグレードする場合は、copy ftp flashコマンドを使
用できます。このコマンドでは、リモート IP アドレスやソース ファイル名などのパラメータを
指定できます。この手順は、TFTP に似ています。ただし、1 つの制約として、リモート IP や送
信元インターフェイスを変更することはできません（TFTP ではできます）。 TFTP モードでは
、tftp-server コマンドで指定したオプションを引用して実行することができます。FTP には、こ
のようなオプションはありません。送信元インターフェイスは、常に外部でなくてはならず、こ
れはデフォルトで、変更できません。つまり、FTP サーバは、外部インターフェイスから到達可
能である必要があります。

確認

この項では、ソフトウェア アップグレードの成功を確認する方法を説明します。

アウトプット インタープリタ ツール（登録ユーザ専用）（OIT）は、特定の show コマンドをサ
ポートします。OIT を使用して、show コマンドの出力の分析を表示します。

ASA がリロードされ、ASDM への再ログインが問題なく完了したら、デバイスで稼働しているイ
メージのバージョンを確認できます。この情報は、[Home] ウィンドウの [General] タブに表示さ
れます。

アップグレードを確認するには、次の CLI コマンドを使用します。

show version：ASA のブートに使用される現在のイメージを示します。1.
show bootvar：リロード後に使用されるイメージの優先順位を示します。2.
show asdm image：ASA によって使用される現在の ASDM イメージを表示します。3.

トラブルシュート

//www.cisco.com/en/US/docs/security/asa/asa82/command/reference/t.html#wp1526016
https://www.cisco.com/cgi-bin/Support/OutputInterpreter/home.pl
//tools.cisco.com/RPF/register/register.do
//tools.cisco.com/RPF/register/register.do


   

現在、この設定に関する特定のトラブルシューティング情報はありません。

関連情報

Cisco セキュリティ アプライアンス コマンドライン設定ガイド、フラッシュ メモリへのソフ
トウェアや設定ファイルのダウンロード

●

Cisco ASA 5500 シリーズ適応型セキュリティ アプライアンス製品のサポート●

Cisco Adaptive Security Device Manager 製品のサポート●

Cisco PIX Firewall ソフトウェア●

Cisco Secure PIX ファイアウォール コマンド リファレンス●

セキュリティ製品に関する Field Notice（PIX を含む）●

TFTP サーバの選択と使用●

PIX 設定ファイルのバックアップと復元●

Requests for Comments (RFCs)●

ASA 8.3のアップグレード – 知っておくべき情報●

テクニカル サポートとドキュメント – Cisco Systems●

//www.cisco.com/en/US/docs/security/asa/asa71/configuration/guide/mswlicfg.html#wp1053013?referring_site=bodynav
//www.cisco.com/en/US/docs/security/asa/asa71/configuration/guide/mswlicfg.html#wp1053013?referring_site=bodynav
//www.cisco.com/en/US/products/ps6120/tsd_products_support_series_home.html?referring_site=bodynav
//www.cisco.com/en/US/products/ps6121/tsd_products_support_series_home.html?referring_site=bodynav
//www.cisco.com/en/US/products/sw/secursw/ps2120/tsd_products_support_series_home.html?referring_site=bodynav
//www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a0080094885.shtml?referring_site=bodynav
//www.cisco.com/en/US/support/tsd_products_field_notice_summary.html?referring_site=bodynav
//www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a00801f7735.shtml?referring_site=bodynav
//www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a008072142a.shtml#tftp?referring_site=bodynav
http://www.ietf.org/rfc.html?referring_site=bodynav
https://supportforums.cisco.com/docs/DOC-12690?referring_site=bodynav
//www.cisco.com/cisco/web/support/index.html?referring_site=bodynav
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