はじめに
このドキュメントでは、外部Ciscoルータを使用してInter VLANルーティングを設定する設定の構築方法について説明します。
前提条件
要件
次の項目に関する専門知識があることが推奨されます。
使用するコンポーネント
このドキュメントの情報は、次のソフトウェアのバージョンに基づいています。
- CatalystスイッチCisco IOS® 15.2E
- CiscoルータCisco IOS XE 17.3
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
表記法
表記法の詳細については、『シスコ テクニカル ティップスの表記法』を参照してください。
背景説明
このドキュメントでは、外部Ciscoルータを使用してInter VLANルーティングを設定する設定について説明し、802.1Qトランキングの設定例を使用して説明します。各コマンドの実行結果は、そのコマンドの実行時に表示されます。このドキュメントで説明するシナリオでは、異なるCiscoシリーズルータと任意のCatalystスイッチを使用しても同じ結果が得られます。
トランキングとは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンクで伝送する方法です。当初、イーサネットトランキングは2つの方法で実装されていました。
トランクリンクは、2つ以上のVLAN(VLAN1とVLAN2など)からのトラフィックを、CatalystスイッチやCiscoルータ間の1つのリンクで伝送するために作成され、使用されます。
Ciscoルータは、VLAN-XとVLAN-Yの間でVLAN間ルーティングを行うために使用されます。この設定は、Catalystシリーズスイッチがレイヤ2(L2)のみであり、VLAN間でのルーティングや通信ができない場合に役立ちます。
802.1Q トランキングの場合、タグ付けされない VLAN が 1 つあります。この VLAN をネイティブ VLAN と呼びます。ネイティブ VLAN は、このポートが 802.1Q トランキング モードの場合に、タグなしのトラフィック用に使用されます。802.1Qトランキングを設定する際には、トランクリンクの両側でネイティブVLANを同じように設定する必要があることに注意してください。ルータとスイッチの間で802.1Qトランキングが設定されている場合、ネイティブVLANが一致しないというのは一般的な誤りです。
この設定例では、CiscoルータとCatalystスイッチの両方で、デフォルトでネイティブVLANはVLAN1です。ネットワークのニーズに応じて、デフォルトのVLANであるVLAN1以外のネイティブVLANを使用できます。これらのデバイスのネイティブVLANを変更するコマンドについては、このドキュメントの「設定」セクションで説明しています。
このドキュメントで紹介する設定例は、802.1Q VLANトランキングをサポートする複数のCiscoルータシリーズで使用できます。
注:サポートされている最低限のリリースが、必ずしも推奨リリースであるとは限りません。ご使用のシスコ製品に最適なメンテナンスリリースを判別するには、Bug Toolkitで製品コンポーネントごとにリストされている不具合を検索してください。
注:内部のドキュメント、ツール、および情報にアクセスできるのは、登録ユーザのみです。
設定
このセクションでは、このドキュメントで説明する機能を設定するために必要な情報を提供しています。
ネットワーク図
このドキュメントでは、次の図で示されるネットワーク設定を使用しています。
ネットワーク図コンフィギュレーション
Catalyst L2スイッチ |
!-- (Optional) Set the IP address and default gateway for VLAN1 for management purposes.
L2_Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
L2_Switch(config)#interface vlan 1
L2_Switch(config-if)#ip address 10.10.0.2 255.255.255.0
L2_Switch(config-if)#no ip directed-broadcast
L2_Switch(config-if)#no ip route-cache
L2_Switch(config-if)#exit
L2_Switch(config-if)#ip default-gateway 10.10.0.1
!-- (Optional) Set the VTP Mode. In our example, we have set the mode to be transparent.
!-- Depending on your network, set the VTP Mode accordingly.
L2_Switch(config)#vtp mode transparent
Setting device to VTP Transparent mode for VLANS.
L2_Switch(config)#
!-- Adding VLAN10 and VLAN11.
L2_Switch(config)#vlan 10-11
L2_Switch(config-vlan)#exit
L2_Switch(config)#
!-- Enable trunking on the interface GigabitEthernet 0/2.
!-- Enter the trunking encapsulation as dot1q.
L2_Switch(config)#interface gigabitEthernet 0/2
L2_Switch(config-if)#switchport trunk encapsulation dot1q
L2_Switch(config-if)#switchport mode trunk
!-- In case of dot1q, you need to make sure that the native VLAN matches across the link.
!-- On Catalyst Switches, by default, the native VLAN is 1.
!-- It is very important that you change the native VLAN on the router accordingly.
!-- The following set of commands can place on the interfaces connecting to the workstations.
L2_Switch(config)#interface gigabitEthernet 0/0
L2_Switch(config-if)#switchport mode access
L2_Switch(config-if)#switchport access vlan 11
L2_Switch(config-if)#exit
L2_Switch(config)#interface gigabitEthernet 0/1
L2_Switch(config-if)#switchport mode access
L2_Switch(config-if)#switchport access vlan 10
L2_Switch(config-if)#exit
!-- Remember to save the configuration.
L2_Switch#write memory
Building configuration... |
ルータ |
注:次のスクリーンキャプチャは、Ciscoルータで入力されたコマンドを示しています。コマンド間のコメントは、特定のコマンドと手順を説明するためにイタリック体で追加されています。 Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z.
!-- Select GigabitEthernet 1 for the trunk configuration. !-- No Layer 3 (L3) configuration is done here.
Router (config)#interface GigabitEthernet 1 Router(config-if)#no shut Router(config-if)#exit
!-- Enable dot1q on the sub-interface one for each VLAN.
!-- Configure L3 information on the sub-interface for each gateway.
Router(config)#interface gigabitEthernet 1.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface gigabitEthernet 1.11
Router(config-subif)#encapsulation dot1Q 11
Router(config-subif)#ip address 10.10.11.1 255.255.255.0
Router(config-subif)#exit
!-- (Optional) For the management VLAN 1 make sure that the native VLAN matches across the link. !-- On the switch, by default, the native VLAN is 1. !-- On the router, configure VLAN1 as the native VLAN.
Router(config)#interface gigabitEthernet 1.1
Router(config-subif)#encapsulation dot1Q 1 native
Router(config-subif)#ip address 10.10.0.1 255.255.255.0
Router(config-subif)#end
!-- Remember to save the configuration.
Router#write memory
Building configuration...
[OK]
Router# 注:この設定が機能し、workstation1とworkstation2の間で正常にpingを実行するには、ワークステーションのデフォルトゲートウェイが正しく設定されていることを確認する必要があります。workstation1のデフォルトゲートウェイは10.10.11.1である必要があり、workstation2のデフォルトゲートウェイは10.10.10.1である必要があります。 |
便利なコマンド
このセクションでは、設定が期待どおりに動作していることを確認できます。
Catalystスイッチでは、次のコマンドを使用して検証に役立てることができます。
Ciscoルータで、次のコマンドを使用します。
-
show ip route
-
show interface
コマンドのサンプル出力
Catalyst スイッチ
次のコマンドは、ポートの管理ステータスと動作ステータスを確認するために使用されます。また、トランクの両側でネイティブ VLAN が一致していることを確認するためにも使用します。ネイティブ VLAN は、このポートが 802.1Q トランキング モードの場合に、タグなしのトラフィック用に使用されます。
802.1Qトランキングの場合、出力コマンドは次のように表示されます。
L2_Switch#show interfaces gigabitEthernet 0/2 switchport
Name: Gi0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
次のコマンドは、インターフェイス(ポート)が正しいVLANに属していることを確認するために使用されます。この例では、インターフェイスGi0/1はVLAN10に属し、Gi0/0はVLAN11に属しています。その他は VLAN1 のメンバです。
L2_Switch#show vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/3
10 VLAN0010 active Gi0/1 11 VLAN0011 active Gi0/0
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
L2_Switch#
次のコマンドは、スイッチのVLANトランキングプロトコル(VTP)設定を確認するために使用されます。この例では、透過モードが使用されています。正しい VTP モードは、使用しているネットワークのトポロジによって異なります。
L2_Switch#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name :
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 5254.0000.8000
Configuration last modified by 0.0.0.0 at 3-1-24 15:21:18
Feature VLAN:
--------------
VTP Operating Mode : Transparent
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
Configuration Revision : 0
MD5 digest : 0x9F 0x7D 0x8D 0x10 0xB1 0x22 0x2F 0xE7
0x29 0x77 0x42 0xA7 0x95 0xE7 0x68 0x1C
Cisco ルータ
次のコマンドは、ルータに設定されているサブインターフェイスに関するL3ルーティング情報を示します。
Router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.10.0.0/24 is directly connected, GigabitEthernet1.1
L 10.10.0.1/32 is directly connected, GigabitEthernet1.1
C 10.10.10.0/24 is directly connected, GigabitEthernet1.10 L 10.10.10.1/32 is directly connected, GigabitEthernet1.10 C 10.10.11.0/24 is directly connected, GigabitEthernet1.11 L 10.10.11.1/32 is directly connected, GigabitEthernet1.11
次のコマンドは、インターフェイスの管理ステータスと動作ステータスを確認するために使用します。ルータインターフェイスのステータスの場合、出力コマンドは次のように表示されます。
Router#show interfaces
GigabitEthernet1 is up, line protocol is up
Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1000Mbps, link type is auto, media type is Virtual
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:14:10, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
5338 packets input, 361563 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
13 packets output, 1248 bytes, 0 underruns
Output 0 broadcasts (0 IP multicasts)
0 output errors, 0 collisions, 2 interface resets
57 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
1 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
GigabitEthernet1.1 is up, line protocol is up
Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d)
Internet address is 10.10.0.1/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1.
ARP type: ARPA, ARP Timeout 04:00:00
Keepalive set (10 sec)
Last clearing of "show interface" counters never
GigabitEthernet1.10 is up, line protocol is up Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d) Internet address is 10.10.10.1/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 10.
ARP type: ARPA, ARP Timeout 04:00:00
Keepalive set (10 sec)
Last clearing of "show interface" counters never
GigabitEthernet1.11 is up, line protocol is up Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d) Internet address is 10.10.11.1/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 11.
ARP type: ARPA, ARP Timeout 04:00:00
Keepalive set (10 sec)
Last clearing of "show interface" counters never
GigabitEthernet2 is administratively down, line protocol is down
Hardware is CSR vNIC, address is 5254.0000.004e (bia 5254.0000.004e)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1000Mbps, link type is auto, media type is Virtual
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
関連情報