はじめに
このドキュメントでは、ループバックアドレスを使用して、または使用せずにiBGPとeBGPを設定する方法について説明します。
前提条件
要件
次の項目に関する知識があることが推奨されます。
使用するコンポーネント
このドキュメントの内容は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
表記法
ドキュメントの表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。
背景説明
BGP は、TCP/IP ネットワーク内でドメイン間ルーティングを実行するための外部ゲートウェイ プロトコル(EGP)です。BGPルータは、BGPアップデートを交換する前に、各BGPピアへの接続(TCPポート179)を確立する必要があります。2つのBGPピア間のBGPセッションは、BGPピアが異なる自律システム(AS)にある場合に、外部BGP(eBGP)セッションと呼ばれます。2 つの BGP ピア間の BGP セッションは、それらのピアが同じ自律型システム内に存在する場合に、内部 BGP(iBGP)セッションと呼ばれます。
デフォルトでは、ピアルータに最も近いインターフェイスのIPアドレスを使用してピア関係が確立されます。ただし、neighbor update-source コマンドを使用すると、ループバックインターフェイスを含む任意の動作インターフェイスを指定してTCP接続を確立できます。このループバックインターフェイスを使用したピアリング方式は、BGPピア間に複数のパスが存在する場合にBGPセッションを停止できないため便利です。セッションの確立に使用された物理インターフェイスがダウンした場合、BGPセッションは切断されます。さらに、この方法では、複数のリンクがある BGP が動作するルータ間で、使用可能なパスを利用して負荷を分散することもできます。
このドキュメントの iBGP と eBGP の設定例には、ループバック アドレスを使用した場合と使用しない場合の両方があります。
注:これらの設定を使用して、ネイバー関係を確立できます。
設定
このセクションでは、次の設定例について説明します。
このセクションでは、このドキュメントで説明する機能を設定するために必要な情報を提供しています。
注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Toolを使用してください。シスコの内部情報およびツールにアクセスできるのは、登録ユーザのみです。
ネットワーク図
このドキュメントでは、次のネットワーク セットアップを使用します。
iBGP の設定
この設定では、両方のルータはAS 400内にあります。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 400
!--- Enables BGP for the autonomous !--- system 400.
neighbor 10.10.10.2 remote-as 400
!--- Specifies a neighbor 10.10.10.2 !--- in the remote AS 400, making !--- this an iBGP connection.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.10.10.1 remote-as 400
!-- Output suppressed.
end |
eBGP の設定
この設定では、ルータR1-AGSはAS 300にあり、ルータR6-2500はAS 400にあります。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
!--- Enables BGP for the autonomous !--- system 300.
neighbor 10.10.10.2 remote-as 400
!--- Specifies a neighbor 10.10.10.2 !--- in the remote AS 400, making !--- this an eBGP connection.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.10.10.1 remote-as 300
!-- Output suppressed.
end |
eBGPを使用する場合は、ピアを直接接続する必要があります。直接接続されていない場合は、neighbor ebgp-multihop コマンドを使用する必要があります。また、ルータがネイバー関係を確立するためには、IGPまたはスタティックルート経由でピアに到達するパスが存在している必要があります。上記の設定では、R1-AGSルータはAS 300に属し、R6-2500ルータはAS 400に属しています。
ループバック アドレスを使用した iBGP の設定
このセクションに示すように、ループバックアドレス(またはその他の動作可能なインターフェイス)を使用してiBGPを設定できます。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
neighbor 10.2.2.2 remote-as 300
neighbor 10.2.2.2 update-source Loopback0
!--- This command specifies that the TCP !--- connection with the specified external !--- peer should be established with the !--- address on the loopback interface.
!
ip route 10.2.2.2 255.255.255.255 10.10.10.2
!--- This static route ensures that the !--- remote peer address used for peering !--- is reachable.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 300
neighbor 10.1.1.1 remote-as 300
neighbor 10.1.1.1 update-source Loopback0
!
ip route 10.1.1.1 255.255.255.255 10.10.10.1
!-- Output suppressed.
end |
ループバック アドレスを使用した eBGP の設定
このセクションに示すように、eBGPにループバックアドレス(またはその他の動作可能なインターフェイス)を設定することもできます。複数のパスがあるネットワークで、ループバックインターフェイスをこのように使用して到達可能性を確保する方法については、『BGPネイバーとしてループバックアドレスを使用するロードシェアリング』を参照してください。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
neighbor 10.2.2.2 remote-as 400
neighbor 10.2.2.2 ebgp-multihop 2
!--- This command changes the ttl value in !--- order to allow the packet to reach the !--- external BGP peer which is not directly !--- connected or is with an interface other !--- than the directly connected interface.
neighbor 10.2.2.2 update-source Loopback0
!--- This command specifies that the TCP !--- connection with the external BGP !--- peer should be established with the !--- address on the loopback interface.
ip route 10.2.2.2 255.255.255.255 10.10.10.2
!--- This static route ensures that the !--- remote peer address used for peering !--- is reachable.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.1.1.1 remote-as 300
neighbor 10.1.1.1 ebgp-multihop 2
neighbor 10.1.1.1 update-source Loopback0
!
ip route 10.1.1.1 255.255.255.255 10.10.10.1
!-- Output suppressed.
end |
確認
このセクションでは、設定が正しく動作していることを確認する方法について説明します。特定のshowコマンドが、アウトプットインタープリタツールでサポートされています。このツールを使用すると、showコマンドの出力を分析できます。
iBGP の設定の確認
show ip bgp neighborsコマンドを使用して、TCPとボーダーゲートウェイプロトコル(BGP)の接続に関する情報を表示し、BGPピアが確立されているかどうかを確認します。次にshow ip bgp neighborsコマンドの出力は、BGPの状態がEstablishedであることを示しています。これは、BGPのピア関係が正しく確立されていることを示しています。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2, remote AS 400, internal link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:04:20
BGP table version 1, neighbor version 1
R1-AGS#
show ip bgp neighborsコマンドは、修飾子| include BGP.これにより、コマンド出力が読みやすくなり、関連する部分だけが表示されます。
また、次に示すように、show ip bgp summary コマンドを使用して、すべてのBGP接続のステータスを表示することもできます。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 400 3 3 1 0 0 00:00:26 0
eBGP の設定の確認
show ip bgp neighborsコマンドを使用して、TCPとボーダーゲートウェイプロトコル(BGP)の接続に関する情報を表示し、BGPピアが確立されているかどうかを確認します。次にshow ip bgp neighborsコマンドの出力は、BGPの状態がEstablishedであることを示しています。これは、BGPのピア関係が正しく確立されていることを示しています。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2, remote AS 400, external link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:17
BGP table version 1, neighbor version 1
また、次に示すように、show ip bgp summary コマンドを使用して、すべてのBGP接続のステータスを表示することもできます。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 400 3 3 1 0 0 00:00:26 0
ループバック アドレスを使用した iBGP の設定の確認
show ip bgp neighborsコマンドを使用して、TCPとボーダーゲートウェイプロトコル(BGP)の接続に関する情報を表示し、BGPピアが確立されているかどうかを確認します。次にshow ip bgp neighborsコマンドの出力は、BGPの状態がEstablishedであることを示しています。これは、BGPのピア関係が正しく確立されていることを示しています。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.2.2.2, remote AS 300, internal link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:28
BGP table version 1, neighbor version 1
R1-AGS#
また、次に示すように、show ip bgp summary コマンドを使用して、すべてのBGP接続のステータスを表示することもできます。
R1-AGS(9)#show ip bgp summary
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.2.2.2 4 400 3 3 1 0 0 00:00:26 0
ループバック アドレスを使用した eBGP の設定の確認
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.2.2.2, remote AS 400, external link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:16
BGP table version 1, neighbor version 1
External BGP neighbor may be up to 2 hops away.
また、次に示すように、show ip bgp summary コマンドを使用して、すべてのBGP接続のステータスを表示することもできます。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.2.2.2 4 400 3 3 1 0 0 00:00:26 0
トラブルシュート
詳細は、『BGPネイバーがアイドル、接続、アクティブ状態間を切り替わる理由』および『BGPの一般的な問題のトラブルシューティング』を参照してください。
関連情報