はじめに
このドキュメントでは、2つのブランチルータがISP経由で接続し、その間でBGPを実行する状況について説明します。
前提条件
要件
次の項目に関する知識があることが推奨されます。
- インターネットサービスプロバイダー(ISP)
- ボーダー ゲートウェイ プロトコル(BGP)
使用するコンポーネント
このドキュメントの内容は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
表記法
プロバイダーエッジ(PE)ルータを、重複した自律システム番号(ASN)を含むすべてのプレフィクスの再アドバタイズを許可するように設定するには、ルータコンフィギュレーションモードでneighbor allowas-incommandコマンドを使用します。PEルータのASNの再アドバタイズを無効にするには、このコマンドのenoformを使用します。
neighborip-address allowas-in [数値]
no neighborallowas-in [数値]
IPアドレス |
ネイバールータのIPアドレス。 |
番号 |
(オプション)PEルータのASNのアドバタイズメントを許可する回数を指定します。範囲は 1 ~10 です。数値を指定しない場合は、デフォルト値の3倍が使用されます。 |
ハブアンドスポーク構成では、PEルータは重複した自律システム番号を含むすべてのプレフィックスを再アドバタイズします。次のようにneighbor allowas-incommandコマンドを使用して、各PEルータで2つのVRFを設定し、プレフィックスの受信と再アドバタイズを行います。
1 ~ 10の数値を指定して、ASNがアドバタイズされる回数を制御します。
例
次の例は、VRFアドレスファミリVirtual Private Network(VPN;バーチャルプライベートネットワーク)IPv4 vrf1からのプレフィックスを許可するように、ASN 100を使用してPEルータを設定する方法を示しています。IPアドレス192.168.255.255のネイバーPEルータは、同じASNを持つ他のPEルータに6回再通知するように設定されます。
Router(config)#
router bgp 100
Router(config-router)#
address-family ipv4 vrf vrf1
Router(config-router)#
neighbor 192.168.255.255 allowas-in 6
背景説明
このドキュメントでは、2台のブランチルータがインターネットサーバプロバイダー(ISP)経由で接続され、ルータ間でボーダーゲートウェイプロトコル(BGP)を実行するシナリオについて説明します。2 台のブランチ ルータ(R1 および R2)は異なる場所にあるものの、同一の AS 番号を共有しています。ルートがブランチ(この場合はR1)からサービスプロバイダー(SP)ネットワークに到着した後、ユーザASでタグ付けできます。SPがルートを他のブランチルータ(R2)に渡す際、デフォルトでは、他のブランチもSPとBGPを実行し、同じAS番号を使用している場合、ルートはドロップされます。このシナリオでは、相手側の BGP がアップデートを注入できるようにするために、neighbor allowas-in コマンドを発行します。このドキュメントでは、BGP の Allowas-in 機能の理解に役立つ設定例を提供しています。
注:この機能は、真のeBGPピアでのみ使用できます。異なるコンフェデレーション サブ AS のメンバーである 2 つのピアに対しては、この機能を使用できません。
設定
このセクションでは、このドキュメントで説明する機能を設定するために必要な情報について記載しています。
注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool(登録ユーザ専用)を使用してください。
注:シスコの内部ツールおよび情報にアクセスできるのは、登録ユーザのみです。
ネットワーク図
このドキュメントでは、次のネットワーク セットアップを使用します。
ネットワーク図
コンフィギュレーション
このドキュメントでは、次のコンフィギュレーションを使用します。
ルータ A の設定 |
Router_A#interface Loopback1
ip address 10.1.1.1 255.255.255.255
!
interface Loopback2
ip address 10.2.2.2 255.255.255.255
!
interface Loopback3
ip address 10.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
no switchport
ip address 192.168.12.2 255.255.255.0
!
router eigrp 100
network 10.1.1.1 0.0.0.0
network 10.2.2.2 0.0.0.0
network 10.3.3.3 0.0.0.0
network 192.168.12.0
auto-summary
! |
ルータ R1 の設定 |
R1#interface Loopback22
ip address 10.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.12.1 255.255.255.0
!
!
router eigrp 100
network 192.168.12.0
no auto-summary
!
router bgp 121
no synchronization
bgp router-id 10.22.22.22
bgp log-neighbor-changes
network 10.22.22.22 mask 255.255.255.255
!--- This is the advertising loopback address.
redistribute eigrp 100
!--- This shows the redistributing internal routes in BGP.
neighbor 172.16.12.2 remote-as 500
!--- This shows the EBGP connection with ISP.
neighbor 172.16.12.2 ebgp-multihop 5
no auto-summary
! |
この例は、EIGRP がルータ A とルータ R1 の間で動作していることを示しています。
r1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.12.2 Fa0/0 14 01:17:12 828 4968 0 7
この例は、ルータ R1 が EIGRP を通じてルータ A からルートを学習している様子を示しています。
r1#show ip route eigrp 100
D 10.0.0.1/8 [90/156160] via 192.168.12.2, 00:02:24, FastEthernet0/0
D 10.0.0.2/8 [90/156160] via 192.168.12.2, 00:02:24, FastEthernet0/0
D 10.0.0.3/8 [90/156160] via 192.168.12.2, 00:02:24, FastEthernet0/0
この例は、ルータ R1 が BGP AS500 を動作させている ISP と BGP 接続を確立している様子を示しています。
r1#show ip bgp summary
BGP router identifier 10.22.22.22, local AS number 121
BGP table version is 19, main routing table version 19
7 network entries using 924 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 840 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2184 total bytes of memory
BGP activity 40/33 prefixes, 42/35 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.12.2 4 500 86 76 19 0 0 00:25:13 2
この例は、BGP がルートを学習したことを R1 がアナウンスしている様子を示しています。
r1#show ip bgp
BGP table version is 19, local router ID is 10.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.1 192.168.12.2 156160 32768 ?
*> 10.0.0.2 192.168.12.2 156160 32768 ?
*> 10.0.0.3 192.168.12.2 156160 32768 ?
*> 10.10.12.0/24 172.16.12.2 0 0 500 i
*> 10.22.22.22/32 0.0.0.0 0 32768 i
r> 172.16.12.0/24 172.16.12.2 0 0 500 i
*> 192.168.12.0 0.0.0.0 0 32768 ?
r1#ping 10.10.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:
!!!!!
!--- This is the connectivity with Router 2 across the Internet cloud.
ルータ R2 の設定 |
R2#interface Loopback33
ip address 10.33.33.33 255.255.255.255
!
interface Serial1/0
ip address 10.10.12.1 255.255.255.0
router bgp 121
no synchronization
bgp router-id 10.33.33.33
bgp log-neighbor-changes
network 10.33.33.33 mask 255.255.255.255
!--- This is the advertising loopback address.
neighbor 10.10.12.2 remote-as 500
!--- This is the EBGP connection with ISP.
neighbor 10.10.12.2 ebgp-multihop 5
no auto-summary |
ルータ R2 はルータ R1 からルートを学習しません。
BGP はルーティングのループを避けようとしているため、これは自然な動作です。たとえば、デフォルトでは、重複した自律システム番号(ASN)を含むすべてのプレフィクスの再アドバタイズは無効化されています。
再配布されたEIGRPルート(10.0.0.1、10.0.0.2、10.0.0.3)とR1からのBGP内部経路10.22.22.22は、インターネット経由で同じASNから発信されているためR2では受信されません。R2はAS-PATHに自身のAS番号(121)を認識するため、R2はこれらのルートを取りません。
r2#show ip bgp
BGP table version is 20, local router ID is 10.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r> 10.10.12.0/24 10.10.12.2 0 0 500 i
*> 10.33.33.33/32 0.0.0.0 0 32768 i
*> 172.16.12.0/24 10.10.12.2 0 0 500 i
重複したASNを含むすべてのプレフィックスの再アドバタイズを許可するには、ルータR2のルータコンフィギュレーションモードでneighbor allowas-inコマンドを使用します。
r2(config-router)#neighbor 10.10.12.2 allowas-in
r2#clear ip bgp*
r2#show ip bgp
BGP table version is 10, local router ID is 10.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.1 10.10.12.2 0 500 121 ?
*> 10.0.0.2 10.10.12.2 0 500 121 ?
*> 10.0.0.3 10.10.12.2 0 500 121 ?
r> 10.10.12.0/24 10.10.12.2 0 0 500 i
*> 10.22.22.22/32 10.10.12.2 0 500 121 i
* 10.33.33.33/32 10.10.12.2 0 500 121 i
*> 0.0.0.0 0 32768 i
*> 172.16.12.0/24 10.10.12.2 0 0 500 i
*> 192.168.12.0 10.10.12.2 0 500 121 ?
R1 から R2 に ping を実行してみてください。
r2#ping 10.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms
確認
現在、この設定に使用できる確認手順はありません。
トラブルシュート
エラー メッセージ
%BGP% Neighbor A.B.C.D recv bogus route : ASループのエラーメッセージが表示されます。
この通知は、CE ルータが受信した BGP ルートに AS パス独自の AS 番号が存在し、CE ルータのルータ ループと考えられることを意味します。この問題を回避するには、以前の例で説明したとおり、Allowas-in 機能を搭載した CE ルータを設定します。
関連情報