はじめに
このドキュメントでは、2 つの BGP ピア間の TCP 接続に対して Message Digest5(MD5)認証を設定する方法を説明します。
前提条件
要件
このドキュメントに関する固有の要件はありません。
使用するコンポーネント
このドキュメントの内容は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。
このドキュメントの情報は、Cisco IOS®バージョン12.4(15)T14が稼働する3600シリーズルータからのコマンド出力に基づくものです。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
表記法
表記法の詳細については、『シスコ テクニカル ティップスの表記法』を参照してください。
背景説明
2つのBGPピア間でMD5認証を設定できます。これは、ピア間のTCP接続で送信される各セグメントが検証されることを意味します。MD5認証は、両方のBGPピアで同じパスワードを使用して設定する必要があります。そうでない場合、これらのピア間の接続は確立できません。MD5認証を設定すると、Cisco IOSソフトウェアはTCP接続で送信される各セグメントのMD5ダイジェストを生成し、チェックします。
設定
このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。
注:このセクションで使用されているコマンドの詳細を取得するには、Cisco CLI Analyzerを使用してください。シスコの内部ツールおよび情報にアクセスできるのは、登録ユーザのみです。
ネットワーク図
このドキュメントでは、次のネットワーク セットアップを使用します。
コンフィギュレーション
このドキュメントでは、次のコンフィギュレーションを使用します。
ルータ 0 の設定 |
R0# !
interface Loopback70
ip address 10.70.70.70 255.255.255.255
!
interface Serial1/0
ip address 10.10.10.1 255.255.255.0
serial restart-delay 0
!
router bgp 400
no synchronization
bgp log-neighbor-changes
neighbor 10.80.80.80 remote-as 400
!--- iBGP Configuration using Loopback Address
neighbor 10.80.80.80 password cisco
!--- Invoke MD5 authentication on a TCP connection to a BGP peer
neighbor 10.80.80.80 update-source Loopback70
no auto-summary
!
ip route 10.80.80.80 255.255.255.255 10.10.10.2
!--- This static route ensures that the remote peer address used for peering is reachable.
|
ルータ 1 の設定 |
R1#
!
interface Loopback80
ip address 10.80.80.80 255.255.255.255
!
interface Serial1/0
ip address 10.10.10.2 255.255.255.0
serial restart-delay 0
!
router bgp 400
no synchronization
bgp log-neighbor-changes
neighbor 10.70.70.70 remote-as 400
!--- iBGP Configuration using Loopback Address
neighbor 10.70.70.70 password cisco
!--- Invoke MD5 authentication on a TCP connection to a BGP peer
neighbor 10.70.70.70 update-source Loopback80
no auto-summary
!
ip route 10.70.70.70 255.255.255.255 10.10.10.1
!--- This static route ensures that the remote peer address used for peering is reachable.
|
デバッグについて
R0#clear ip bgp *
*Mar 1 01:02:17.523: %BGP-5-ADJCHANGE: neighbor 10.80.80.80 Down User reset
R0#debug ip bgp
BGP debugging is on for address family: IPv4 Unicast
*Mar 1 01:03:58.159: BGP: 10.80.80.80 open failed: Connection timed out;
remote host not responding, open active delayed 1782ms (2000ms max, 28%
jitter)
*Mar 1 01:03:58.415: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 01:03:59.943: BGP: 10.80.80.80 open active, local address 10.70.70.70
*Mar 1 01:04:00.039: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(179) to
10.70.70.70(64444)
*Mar 1 01:04:00.807: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(33358)
to 10.70.70.70(179)
*Mar 1 01:04:01.991: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(179) to
10.70.70.70(64444)
*Mar 1 01:04:01.995: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(179) to
10.70.70.70(64444)
*Mar 1 01:04:05.995: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(179) to
10.70.70.70(64444)
*Mar 1 01:04:06.015: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(179) to
10.70.70.70(64444)
*Mar 1 01:04:14.023: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(179) to
70. 70.70.70(64444)
*Mar 1 01:04:14.023: %TCP-6-BADAUTH: No MD5 digest from 10.80.80.80(179) to
10.70.70.70(64444)
*Mar 1 01:04:29.947: BGP: 10.80.80.80 open failed: Connection timed out;
remote host not responding, open active delayed 3932ms (4000ms max, 28%
jitter)
*Mar 1 01:04:33.879: BGP: 10.80.80.80 open active, local address 10.70.70.70
*Mar 1 01:04:33.983: BGP: 10.80.80.80 went from Active to OpenSent
*Mar 1 01:04:33.983: BGP: 10.80.80.80 sending OPEN, version 4, my as: 400,
hold time 180 seconds
*Mar 1 01:04:33.987: BGP: 10.80.80.80 send message type 1, length (incl.
header ) 45
*Mar 1 01:04:34.091: BGP: 10.80.80.80 rcv message type 1, length (excl.
header) 26
*Mar 1 01:04:34.091: BGP: 10.80.80.80 rcv OPEN, version 4, holdtime 180 seconds
*Mar 1 01:04:34.091: BGP: 10.80.80.80 rcv OPEN w/ OPTION parameter len: 16
*Mar 1 01:04:34.095: BGP: 10.80.80.80 rcvd OPEN w/ optional parameter type 2
(Capability) len 6
*Mar 1 01:04:34.095: BGP: 10.80.80.80 OPEN has CAPABILITY code: 1, length 4
*Mar 1 01:04:34.095: BGP: 10.80.80.80 OPEN has MP_EXT CAP for afi/safi: 1/1
*Mar 1 01:04:34.095: BGP: 10.80.80.80 rcvd OPEN w/ optional parameter type 2
(Capability) len 2
*Mar 1 01:04:34.095: BGP: 10.80.80.80 OPEN has CAPABILITY code: 128, length 0
*Mar 1 01:04:34.099: BGP: 10.80.80.80 OPEN has ROUTE-REFRESH capability(old)
for all address-families
*Mar 1 01:04:34.099: BGP: 10.80.80.80 rcvd OPEN w/ optional parameter type 2
(Capability) len 2
*Mar 1 01:04:34.099: BGP: 10.80.80.80 OPEN has CAPABILITY code: 2, length 0
*Mar 1 01:04:34.099: BGP: 10.80.80.80 OPEN has ROUTE-REFRESH capability(new)
for all address-families
BGP: 10.80.80.80 rcvd OPEN w/ remote AS 400
*Mar 1 01:04:34.103: BGP: 10.80.80.80 went from OpenSent to OpenConfirm
*Mar 1 01:04:34.103: BGP: 10.80.80.80 went from OpenConfirm to Established
*Mar 1 01:04:34.103: %BGP-5-ADJCHANGE: neighbor 10.80.80.80 Up
ネイバーに対してパスワードを設定しているルータと設定していないルータとの間で BGP セッションを確立しようとすると、次のようなメッセージがコンソールに表示されます。
%TCP-6-BADAUTH: No MD5 digest from [peer's IP address]:11003 to [local
router's IP address]:179
同様に、2 つのルータにそれぞれ異なるパスワードが設定されていると、次のようなメッセージが表示されます。
%TCP-6-BADAUTH: Invalid MD5 digest from [peer's IP address]:11004 to [local
router's IP address]:179
確認
このセクションでは、設定が正常に動作していることを確認します。
-
show ip bgp neighbors | include BGP
R0#show ip bgp neighbors| include BGP
BGP neighbor is 10.80.80.80, remote AS 400, internal link
BGP version 4, remote router ID 10.80.80.80
BGP state = Established, up for 00:08:26
BGP table version 1, neighbor version 1/0
-
show ip bgp summary(隠しコマンド)
R0#show ip bgp summary
BGP router identifier 10.70.70.70, local AS number 400
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.80.80.80 4 400 75 75 1 0 0 00:08:52 0
-
show ip bgp summary(隠しコマンド)
R1#show ip bgp summary
BGP router identifier 10.80.80.80, local AS number 400
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.70.70.70 4 400 76 76 1 0 0 00:09:27 0
トラブルシュート
現在のところ、この設定に関するトラブルシューティング情報はありません。
関連情報