Créer des modeéles de certificats AC Windows
pour CUCM
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Introduction

Ce document décrit une procédure étape par étape afin de créer des modeles de certificats sur les
autorités de certification Windows Server, qui sont conformes aux exigences d'extension X.509
pour chaque type de certificat Cisco Unified Communications Manager (CUCM).

Conditions préalables

Exigences
Cisco vous recommande de prendre connaissance des rubriques suivantes :

- CUCM version 11.5(1) ou ultérieure
- Une connaissance de base de I'administration de Windows Server est également
recommandée

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de
logiciel suivantes :

- Les informations contenues dans ce document sont basées sur la version 11.5(1) ou
ultérieure de CUCM.
- Microsoft Windows Server 2012 R2 avec services AC installés.

The information in this document was created from the devices in a specific lab environment. All of
the devices used in this document started with a cleared (default) configuration. Si votre réseau



est en ligne, assurez-vous de bien comprendre l'incidence possible des commandes.

Informations générales

Il existe cinq types de certificats qui peuvent étre signés par une autorité de certification externe :

Certificat Utilisation

Présenté lors de I'enregistrement
sécurisé des périphériques, peut
signer les fichiers CTL (Certificate
Trust List)/ITL (Internal Trust List),
utilisés pour les interactions
sécurisées avec d'autres serveurs
tels que les liaisons SIP (Session

Initiation Protocol) sécurisées.

CallManager

Services affectés

-Cisco Call Manager
-Cisco CTI Manager
-Cisco TFTP

-Cisco Tomcat

Présenté pour les interactions _
HTTPS (Secure Hypertext Transfer
Protocol).

tomcat

Utilisé pour la génération de fichiers
de sauvegarde, ainsi que pour
l'interaction IPsec (IP Security)
avec le protocole MGCP (Media
Gateway Control Protocol) ou les
passerelles H323.

Utilisé pour générer des certificats
LSC (Locally Significative
Certificates) pour les téléphones.
Utilisé pour créer une connexion au
service de vérification de la
confiance (TVS), lorsque les
téléphones ne sont pas en mesure
d'authentifier un certificat inconnu.

ipsec

CAPF

TVS

Chacun de ces certificats a des exigences d'extension X.509 qui doivent étre définies, sinon, vous

Authentification unique (SSO)

‘Extension Mobility
‘Répertoire d'entreprise

-Cisco DRF Master
-Cisco DRF Local

Fonction Proxy Cisco Certificate

Authority

Service de vérification Cisco

Trust

pouvez rencontrer des comportements incorrects sur I'un des services mentionnés ci-dessus :

Utilisation de la clé
X.509

-Signature
numéerique
-Chiffrement clé
-Chiffrement des
données
-Signature
numéerique
-Chiffrement clé
-Chiffrement des
données
-Signature
numeérique
-Chiffrement clé

Certificat

CallManager Web

tomcat Web

ipsec Web

Utilisation de la clé étendue
X.509

-Authentification du serveur

-Authentification du client Web

-Authentification du serveur

-Authentification du client Web

-Authentification du serveur

-Authentification du client Web



-Chiffrement des -Systeme final IPsec

données

nSJ%%?:;LZ -Authentification du serveur
CAPF -Signe du certificat Web

. , -Authentification du client Web

-Chiffrement clé

-Signature

numérique -Authentification du serveur
TVS -Chiffrement clé Web

-Chiffrement des -Authentification du client Web

données

Pour plus d'informations, consultez le Guide de sécurité de Cisco Unified Communications
Manager

Configurer

Etape 1. Sur le serveur Windows, accédez & Gestionnaire de serveur > Outils > Autorité de
certification, comme indiqué dans l'image.

Etape 2. Sélectionnez votre autorité de certification, puis accédez & Modéles de certificat, cliquez
avec le bouton droit sur la liste et sélectionnez Gérer, comme illustré dans I'image.
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Modéle Callmanager / Tomcat / TVS

Les images suivantes affichent uniquement la création du modele CallManager, mais les mémes
étapes peuvent étre suivies pour créer les modéles de certificats pour les services Tomcat et TVS.
La seule différence est de s'assurer que le nom de service correspondant est utilisé pour chaque
nouveau modéle a I'étape 2.

Etape 1. Recherchez le modéle Web Server, cliquez dessus avec le bouton droit et sélectionnez
Duplicate Template, comme illustré dans l'image.
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Etape 2. Sous Général, vous pouvez modifier le nom, le nom d'affichage, la validité, etc. du
modéle de certificat.



SubjectMame | Sever | lssusnce Requiemerts
Supersaced Templstes | Edensions | Sacuty
| Compatibity | General | Request Handing | Cryptography | Key Aestation

Template daplay nama:
(CalManagar CLCM |
Templals nama:
[CatManager CUCH |
Walkdty perod. Rearewal pancd:
L Sfirees  + L 6f[wesks |
[[] Publish cerificate in Active Drsctony
[ ] Do not automatically reenll if a duplcate certficate edists in Active
Derectony
| ok || Camcel || Mooy || Hep |

Etape 3. Accédez & Extensions > Key Usage > Edit, comme indiqué dans l'image.



Compatibity | Genersl |nnuumlcqm1mm
Subgect Name | Server lssuance Racuments
Superseded Templaies Emr-u- Secuty |

Ta modify an exdension. sslect &. and then ook Edi

Extensions includad in this templats:
Apphcation Policies

Bamc Conslraints

Certficale Template infomation
lsusnce Polcies

Diegoription of Key Lisage:
IS@MW A
!Hml:lfmmml;wmmn
|Erhndﬂm
| OK || Cacel || Mooy || Hep |

Etape 4. Sélectionnez ces options et cliquez sur OK, comme illustré dans l'image.

- Signature numérique
- Autoriser I'échange de clés uniquement avec le chiffrement de clés (chiffrement de clés)
- Autoriser le chiffrement des données utilisateur



Properties of New Template |2

Compatibity | Genersl | Raquest Handing | Cryptography | Key Attestation
SubjectMame | Server | lssusnes Requiements

Speciy the mouinsd sigratuns and securty options for a key usage
ES A

Signature

[ Digtal signature

(] Signature is proof of origin fnorrepudiation)
[ Cenificate sgning

[ |CRL signing

Encnypiion

1) Alorw lomy mchange wihout ey snceryption fosy agresment)

(w1 Mow Rey exchangs anly wih key encryplion foy enciphesment]
[+ Alow sncryption of user data

R Y e

| OK || Cocedl || Mooy || Heb |

Etape 5. Accédez & Extensions > Application Policies > Edit > Add, comme indiqué dans l'image.



mlwlmwlwlﬁwm
Subject Name |

Superseded Terplates | Secury
T modiy an edension. selact §. and then chick Edt,




WMMMawﬂmﬂmh&

Application polices:
Server Authentication

| Make this extension critical

Etape 6. Recherchez Client Authentication, sélectionnez-le et sélectionnez OK sur cette fenétre et
la précédente, comme illustré dans l'image.



[ ok || ot || Moty || e |

Etape 7. Retournez sur le modéle, sélectionnez Apply, puis OK.



Compatibity | General | Request Handing | Cnptography | Key Attestation
SubjectMame |  Sever | lssusnce Rlequiements
 Swpeseded Templastes | Bdensors | Secumty

To mody an extension, sebect i, and then chek B3R

Descrption of Appbcation Polcs:

Chent Authentication "
Server Authenbicabon

[T I R

Etape 8. Fermez la fenétre Certificate Template Console et, de retour dans la toute premiére
fenétre, accédez a New > Certificate Template to Issue, comme indiqué dans l'image.



Fie Aoisgn  Wesw  Help
o 5 as B
o) Cortilication Aathomby [Local)
F F- Collals T8
Froodord Cortifizaton
e L LT

Piofaduiey Revpstild
Fasied Baquy

et ere Tarnplebe

Cinatwn & npws @om in ths containar.

Etape 9. Sélectionnez le nouveau modéle CallManager CUCM et cliquez sur OK, comme illustré

dans l'image.
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Etape 10. Répétez toutes les étapes précédentes pour créer des modeéles de certificats pour les
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services Tomcat et TVS, le cas échéant.

Modéle IPsec

Etape 1. Recherchez le modéle Web Server, cliquez dessus avec le bouton droit et sélectionnez

Certificate Hegquest Agert
Corifcate Requeat Agert

[ ox

Duplicate Template, comme illustré dans I'image.
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Etape 2. Sous Général, vous pouvez modifier le nom, le nom d'affichage, la validité, etc. du
modéle de certificat.

[IPSEC CUCM

Torrplabe fume
[IPSEC CLCM

Winbchty peawiiced: Fianevwal panod:

L 2lman v [ wosks

[ Publish cestficate in Active Directory

|| Do ot sutomaticaly reenrl f a duplcale cortficatle exisls in Active
Direciory

Etape 3. Accédez & Extensions > Key Usage > Edit, comme indiqué dans l'image.



Compatibity | Genersl |nnuumlcqm1mm
Subgect Name | Server lssuance Racuments
Superseded Templaies Emr-u- Secuty |

Ta modify an exdension. sslect &. and then ook Edi

Extensions includad in this templats:
Apphcation Policies

Bamc Conslraints

Certficale Template infomation
lsusnce Polcies

Diegoription of Key Lisage:
IS@MW A
!Hml:lfmmml;wmmn
|Erhndﬂm
| OK || Cacel || Mooy || Hep |

Etape 4. Sélectionnez ces options et cliquez sur OK, comme illustré dans l'image.

- Signature numérique
- Autoriser I'échange de clés uniquement avec le chiffrement de clés (chiffrement de clés)
- Autoriser le chiffrement des données utilisateur



Properties of New Template |2

Compatibity | Genersl | Raquest Handing | Cryptography | Key Attestation
SubjectMame | Server | lssusnes Requiements

Speciy the mouinsd sigratuns and securty options for a key usage
ES A

Signature

[ Digtal signature

(] Signature is proof of origin fnorrepudiation)
[ Cenificate sgning

[ |CRL signing

Encnypiion

1) Alorw lomy mchange wihout ey snceryption fosy agresment)

(w1 Mow Rey exchangs anly wih key encryplion foy enciphesment]
[+ Alow sncryption of user data

R Y e

| OK || Cocedl || Mooy || Heb |

Etape 5. Accédez & Extensions > Application Policies > Edit > Add, comme indiqué dans l'image.



Compatibity | General Hnumﬁlumulmm
Subject Name

Superseded Templates | Secusty

To modify an exdension, sslect i, and then chick Edit.




An application policy defines how a certificate can be
used.

Application polices:
Server Authentication

| Make this extension critical

Etape 6. Recherchez Client Authentication, sélectionnez-le, puis OK, comme indiqué dans I'image.



ok | Cmced || Mo [ Wb |

Etape 7. Sélectionnez Add & nouveau, recherchez IP security end system, sélectionnez-le, puis
sélectionnez OK sur ce et sur la fenétre précédente ainsi.



#n applcation pokcy (caled enhanced ey usage in Windows 2000)
defines how a cetficate can be used. Sslect the apploation poboy requrd
For walbd sgnatures of cedificabes imsd by this bemplate.

| ok || Cocel || epy || Heb |

Etape 8. De retour sur le modéle, sélectionnez Apply puis OK, comme indiqué dans l'image.



mlwlmm.lwyw
Supeseded Tempistes | Edensons Secusty

T modly an edenson, sshect i, and then chek B

Bxtensons included in ths template:
Appleation Policies

[Basic Constrmnis

Cartficale Tamplsbe famation
lssunnca Pobces

Ky Lisage

Descrpbon of Applcation Polces:

Chert futhertication ~
IP securty end system

Server Authenbcabon

[ ok || coce |[ moy |[ e |

Etape 9. Fermez la fenétre Certificate Templates Console et, de retour dans la toute premiére
fenétre, accédez a New > Certificate Template to Issue, comme illustré dans I'image.
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Etape 10. Sélectionnez le nouveau modéle IPSEC CUCM et cliquez sur OK, comme illustré dans

l'image.
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Modéle CAPF

Etape 1. Recherchez le modéle Root CA et cliquez dessus avec le bouton droit. Sélectionnez

ensuite Duplicate Template, comme indiqué dans l'image.
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Etape 2. Sous Général, vous pouvez modifier le nom, le nom d'affichage, la validité, etc. du
modéle de certificat.

Valdity peniod: Renewal penod:
| Slrean | [__6l[weeks  ~]

] Publish camtfizals in Active Disctory

] Do not automatically resrrol i a duplicate cortficate exists in Active
Dhrectony

Etape 3. Accédez a Extensions > Key Usage > Edit, comme indiqué dans l'image.



Compatblty | Gened | lssuance Requimments
Superseded Tempistes | Edensons | Secusy

To modify an edension, sesct 1, and then dick EdE.

Extensions included in this template:
Apphcation Polcies

Bxsic Constrants

Certficate Templabe Information
suance Poboes

ok || Cwcel || Ao || Hb |

Etape 4. Sélectionnez ces options et cliquez sur OK, comme illustré dans l'image.

- Signature numérique
- Signature de certificat
- signature CRL



Properties of New Template |2

Compatibity | Genersl | Raquest Handing | Cryptography | Key Attestation
SubjectMame | Server | lssusnes Requiements

Speciy the mouinsd sigratuns and securty options for a key usage
ES A

Signature

[ Digtal signature

(] Signature is proof of origin fnorrepudiation)
[ Cenificate sgning

[ |CRL signing

Encnypiion

1) Alorw lomy mchange wihout ey snceryption fosy agresment)

(w1 Mow Rey exchangs anly wih key encryplion foy enciphesment]
[+ Alow sncryption of user data

R Y e

| OK || Cocedl || Mooy || Heb |

Etape 5. Accédez & Extensions > Application Policies > Edit > Add, comme indiqué dans l'image.



mlwlmwlwlﬁwm
Subject Name |

Superseded Terplates | Secury
T modiy an edension. selact §. and then chick Edt,




An application policy defines how a certificate can be
used.

Application polices:
Server Authentication

| Make this extension critical

Etape 6. Recherchez Client Authentication, sélectionnez-le, puis sélectionnez OK, comme indiqué
dans l'image.



ok | Cmced || Mo [ Wb |

Etape 7. Sélectionnez Add & nouveau, recherchez IP security end system, sélectionnez-le, puis
cliquez sur OK dans cette fenétre et dans la fenétre précédente également, comme illustré dans
l'image.



#n applcation pokcy (caled enhanced ey usage in Windows 2000)
defines how a cetficate can be used. Sslect the apploation poboy requrd
For walbd sgnatures of cedificabes imsd by this bemplate.

| ok || Cocel || epy || Heb |

Etape 8. De retour sur le modéle, sélectionnez Apply puis OK, comme indiqué dans l'image.



mlwlmm.lwyw
Supeseded Tempistes | Edensons Secusty

T modly an edenson, sshect i, and then chek B

Bxtensons included in ths template:
Appleation Policies

[Basic Constrmnis

Cartficale Tamplsbe famation
lssunnca Pobces

Ky Lisage

Descrpbon of Applcation Polces:

Chert futhertication ~
IP securty end system

Server Authenbcabon

[ ok || coce |[ moy |[ e |

Etape 9. Fermez la fenétre Certificate Templates Console et, de retour dans la toute premiére
fenétre, accédez a New > Certificate Template to Issue, comme illustré dans I'image.
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Etape 10. Sélectionnez le nouveau modéle CAPF CUCM et cliquez sur OK, comme illustré dans

l'image.
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Générer une demande de signature de certificat

Utilisez cet exemple afin de générer un certificat CallManager avec I'utilisation des modéles
nouvellement créés. La méme procédure peut étre utilisée pour n'importe quel type de certificat. Il
vous suffit de sélectionner les types de certificat et de modéle en conséquence :

Etape 1. Sur CUCM, accédez & OS Administration > Security > Certificate Management >
Generate CSR.



Etape 2. Sélectionnez ces options et sélectionnez Generate, comme indiqué dans l'image.

- Objectif du certificat : CallManager

. Distribution : <il Eeut s'ac.;ir d'un seul serveur ou de ilusieurs réseaux SAN>
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Etape 3. Un message de confirmation est généré, comme illustré dans I'image.
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Etape 4. Dans la liste des certificats, recherchez I'entrée avec le type CSR Only et sélectionnez-la,
comme indiqué dans l'image.
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Etape 5. Dans la fenétre contextuelle, sélectionnez Download CSR, et enregistrez le fichier sur
votre ordinateur.
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Etape 6. Dans votre navigateur, accédez a cette URL et entrez vos informations d'identification
d'administrateur de contréleur de domaine : https://<votreWindowsServerlP>/certsrv/.

Etape 7. Naviguez jusqu'a Request a certificate > advanced certificate request, comme indiqué
dans l'image.
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Etape 8. Ouvrez le fichier CSR et copiez tout son contenu :
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Etape 9. Collez le CSR dans le champ de demande de certificat codé en base 64. Sous Modéle
de certificat, sélectionnez le modele correct et sélectionnez Envoyer, comme illustré dans l'image.
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Etape 10. Enfin, sélectionnez Base 64 encoded et Download certificate chain, le fichier généré
peut maintenant étre téléchargé dans CUCM.
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Vérifier

La procédure de vérification fait en fait partie du processus de configuration.

Dépannage

Aucune information de dépannage spécifique n'est actuellement disponible pour cette
configuration.



A propos de cette traduction
Cisco a traduit ce document en traduction automatisée vérifiée par une personne dans le

cadre d’un service mondial permettant a nos utilisateurs d’obtenir le contenu d’assistance
dans leur propre langue.

Il convient cependant de noter que méme la meilleure traduction automatisée ne sera pas
aussi précise que celle fournie par un traducteur professionnel.



