Introduction
À partir de la version 6.2(2) de Cisco NX-OS, vous pouvez mapper un VLAN sur le site local à un VLAN avec un ID de VLAN différent sur le site distant. Lorsque vous mappez deux VLAN avec des ID de VLAN différents sur des sites, ils sont mappés à un VLAN commun appelé VLAN de transport. Par exemple, lorsque vous mappez le VLAN 1 sur le site A au VLAN 2 sur le site B, les deux VLAN sont mappés à un VLAN de transport. Tout le trafic provenant du VLAN 1 sur le site A est traduit comme provenant du VLAN de transport. Tout le trafic arrivant sur le site B à partir du VLAN de transport est traduit en VLAN 2.
Ce document fournit un exemple de configuration pour l'exécution du mappage de VLAN sur OTV.
Il existe deux méthodes pour configurer la traduction de VLAN sur OTV :
1. Traduction de VLAN sur le port agrégé (interface interne OTV).
2. Traduction de VLAN configurée sur Overlay (actuellement non prise en charge sur les modules F3).
Ce document traite de la 1ère méthode - la traduction VLAN sur le port agrégé (interface interne OTV).
La deuxième méthode est traitée dans un document distinct.
Conditions préalables
Conditions requises
Cisco vous recommande de prendre connaissance des rubriques suivantes :
- OTV
- Canal de port virtuel (vPC)
Components Used
Les informations de ce document sont basées sur les éléments suivants :
- Commutateurs Cisco Nexus 7000 avec module Supervisor 2.
- Cartes de ligne F3
- Logiciel version : 7.3(0)DX(1)
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Configuration
Diagramme du réseau
Configurations
Vous pouvez configurer la traduction de VLAN entre le VLAN d'entrée et un VLAN local sur un port. Le trafic arrivant sur le VLAN d'entrée est mappé au VLAN local à l'entrée du port d'agrégation et le trafic qui est étiqueté en interne avec l'ID de VLAN traduit est mappé à l'ID de VLAN d'origine avant de quitter le port de commutateur. Cette méthode de configuration n'a pas de dépendance OTV.
SITE-1:
AGG VDC:
interface port-channel43
switchport
switchport mode trunk
switchport trunk allowed vlan 10
mtu 9216
interface Vlan10
no shutdown
ip address 10.10.10.1/24
OTV VDC:
N7K-Site-1-OTV# sh port-channel summary interface po43
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
b - BFD Session Wait
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
43 Po43(SU) Eth LACP Eth1/23(P) Eth2/23(P)
//vlan 10 is the local vlan and it will be mapped to vlan 30(transport vlan).
//Transport vlan is only defined in the OTV VDC.
interface port-channel43
switchport
switchport mode trunk
switchport vlan mapping enable >> This command shows up only under member ports config all
switchport vlan mapping 10 30 >> Mapping vlan 10 to vlan 30
switchport trunk allowed vlan 30
mtu 9216
interface Overlay0
description Overlay trunk to DCI
otv join-interface port-channelXX
otv control-group X.X.X.X
otv data-group X.X.X.X
otv extend-vlan 30
SITE-2:
AGG VDC:
interface port-channel43
switchport
switchport mode trunk
switchport trunk allowed vlan 20
mtu 9216
interface Vlan20
no shutdown
ip address 10.10.10.2/24
OTV VDC:
N7K-Site-2-OTV# sh port-channel summary interface po43
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
b - BFD Session Wait
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
43 Po43(SU) Eth LACP Eth1/23(P) Eth2/23(P)
//Vlan 20 is the local vlan and it will be mapped to vlan 30(transport vlan)
//Transport vlan is only defined in the OTV VDC
interface port-channel43
switchport
switchport mode trunk
switchport vlan mapping enable >> This command shows up only under member port config all
switchport vlan mapping 20 30 >> Mapping vlan 20 to vlan 30
switchport trunk allowed vlan 30
mtu 9216
interface Overlay0
description Overlay trunk to DCI
otv join-interface port-channelXX
otv control-group X.X.X.X
otv data-group X.X.X.X
otv extend-vlan 30
Vérification
N7K-Site1-OTV# show interface port-channel 43 vlan mapping
Interface Po43:
Original VLAN Translated VLAN
--------------- -----------------
10 30
N7K-Site1-otv# show vlan internal info mapping | inc Po43 next 6
ifindex Po43(0x1600002a)
vlan mapping enabled: TRUE
vlan translation mapping information (count=1):
Original Vlan Translated Vlan
------------- ---------------
10 30
N7K-Site1-AGG# sh mac address-table vlan 10
Note: MAC table entries displayed are getting read from software.
Use the 'hardware-age' keyword to get information related to 'Age'
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link, E -
EVPN entry
(T) - True, (F) - False , ~~~ - use 'hardware-age' keyword to retrieve
age info
VLAN/BD MAC Address Type age Secure NTFY Ports/SWID.SSID.LID
---------+-----------------+--------+---------+------+----+------------------
G 10 8c60.4fac.b9c2 static - F F sup-eth1(R)
* 10 8c60.4f89.71c2 dynamic ~~~ F F Po43 <------- Remote Vlan 20 mac address learned in vlan 10 in AGG VDC
N7k-Site1-OTV# sh otv route vlan 10
OTV Unicast MAC Routing Table For Overlay0
VLAN MAC-Address Metric Uptime Owner Next-hop(s)
---- -------------- ------ -------- --------- -----------
30 8c60.4f89.71c2 42 2d20h overlay F340.22.11-N77-C7706-1-otv <------ Remote Vlan 20 MAC showing up as Vlan 30 MAC in OTV VDC
30 8c60.4fac.b9c2 1 2d20h site port-channel43 <------ Local Vlan 10 MAC showing up as Vlan 30 MAC in OTV VDC
Référence
Guide de configuration OTV
Guide général de configuration de la traduction de VLAN