Introducción
Este documento describe el proceso para identificar si los problemas de calidad de audio son un problema de red o un problema con la aplicación virtualizada.
Problema
A medida que se virtualizan más aplicaciones de voz en tiempo real, resulta mucho más complejo solucionar problemas de calidad de audio. Utilice Unity Connection como asunto para esta "aplicación de voz en tiempo real".
Recopilar información
- El primer paso es determinar si las indicaciones se distorsionan cuando abandona Unity Connection. Para recopilar un paquete, capture "utils network capture eth0 file capture1 size all count 100000".
Nota: Las indicaciones de Cisco Unified Communication (CUC) son una buena línea de base para determinar la calidad indeseable. No utilice los saludos grabados por el usuario, ya que pueden ser una línea de base poco fiable.
- Analice la captura de paquetes: Wireshark, admite G.711 A-law o G.711 mu-law.
- Compruebe la calidad de la secuencia de protocolo de tabla de routing (RTP) saliente con Wireshark:
- Decodificar con la configuración predeterminada.
- Decodificar con la opción "use RTP timestamp" en Wireshark.
Posibles Causas
Si ambas secuencias descodificadas experimentan problemas de calidad de voz, el problema podría ser con el mensaje (archivo WAV) o Unity Connection.
Si la grabación predeterminada se distorsiona, pero el uso de los sellos de hora RTP es correcto, el problema podría ser con los recursos/VMware.
Si la calidad es aceptable cuando escucha la secuencia RTP usando la decodificación predeterminada, el problema podría ser con la conectividad de red entre el CUC y el teléfono.
Nota: Una sugerencia es tomar una captura de paquetes del switch donde se conecta el servidor ESXi y verificar la calidad. Si está mal, es probable que los controladores se verifiquen en el host ESXi mismo.
Solución
Si el problema indica que el problema está con Unity Connection o el archivo WAV, primero verifique la calidad de la grabación:
- Compruebe el protocolo de tiempo de red (NTP).
- Si el cliente tiene varios NTP configurados, asegúrese de que el CUC no cambie entre los dos con frecuencia.
- Verifique si los servidores NTP tienen NTPv4 (captura de paquetes): "utils ntp status".
- Utilice la GUI web para verificar la calidad.
- Asegúrese de que no haya vaciados de indicadores en CUC. Busque un error conocido: "utils core active list".
- Utilice el Editor de Copias de Seguridad de Cobra para verificar la calidad.
Si el problema indica que el problema se debe a la verificación de VMware, siga estos pasos:
- Verifique que se realice la Reserva adecuada en las Máquinas Virtuales de Unity Connection: verifique las reservas de CPU y RAM como en Plataformas Soportadas.
- Asegúrese de que la descarga de recepción grande (LRO) esté desactivada para el host ESXi (no es un problema con ESXi 5.1+). Consulte Deshabilitar LRO en Implementaciones de Aplicaciones UCS/UC para obtener más información.
- Realice una instantánea de la VM CUC. Consulte Instantáneas VMware para obtener más información.
Nota: Las instantáneas de las VM de Unity Connection no son compatibles y pueden causar problemas con la calidad de voz.
- Asegúrese de que VMware Tools esté instalado. Consulte Herramientas de VMware para obtener más información.
Nota: VMware Tools instala los controladores de tarjeta de interfaz de red (NIC) en la máquina virtual para mejorar el rendimiento de la red.
- Asegúrese de que la sincronización de VM con el host no esté marcada. Esta opción sincroniza el tiempo de la máquina virtual con el host ESXi. En el cliente Sphere, navegue hasta Seleccionar la máquina virtual y haga clic con el botón derecho del ratón en la opción Edit settings de la máquina virtual. En la pestaña Opciones, elija Herramientas VMware > Avanzadas. Asegúrese de que la casilla de verificación Sincronizar hora de invitado con host esté desactivada.