El conjunto de documentos para este producto aspira al uso de un lenguaje no discriminatorio. A los fines de esta documentación, "no discriminatorio" se refiere al lenguaje que no implica discriminación por motivos de edad, discapacidad, género, identidad de raza, identidad étnica, orientación sexual, nivel socioeconómico e interseccionalidad. Puede haber excepciones en la documentación debido al lenguaje que se encuentra ya en las interfaces de usuario del software del producto, el lenguaje utilizado en función de la documentación de la RFP o el lenguaje utilizado por un producto de terceros al que se hace referencia. Obtenga más información sobre cómo Cisco utiliza el lenguaje inclusivo.
Cisco ha traducido este documento combinando la traducción automática y los recursos humanos a fin de ofrecer a nuestros usuarios en todo el mundo contenido en su propio idioma. Tenga en cuenta que incluso la mejor traducción automática podría no ser tan precisa como la proporcionada por un traductor profesional. Cisco Systems, Inc. no asume ninguna responsabilidad por la precisión de estas traducciones y recomienda remitirse siempre al documento original escrito en inglés (insertar vínculo URL).
Este documento describe cómo configurar y resolver problemas de DHCP en un entramado VxLAN con switches Nexus 9000.
Cisco recomienda que tenga conocimiento sobre estos temas:
La información que contiene este documento se basa en las siguientes versiones de software y hardware.
La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si tiene una red en vivo, asegúrese de entender el posible impacto de cualquier comando.
Nota: cualquier pregunta sobre la configuración y la integrabilidad del software o hardware de terceros queda fuera del soporte de Cisco. El uso de herramientas de terceros es un esfuerzo para demostrar al cliente su configuración y funcionamiento con los equipos de Cisco.
nv overlay evpn
feature ospf
feature bgp
feature pim
feature netconf
feature nv overlay
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
ip pim anycast-rp 192.168.11.11 192.168.0.11
ip prefix-list direct_routes seq 5 permit 10.104.11.0/30 le 32
route-map redistribution permit 10
match ip address prefix-list direct_routes
interface Ethernet1/1
speed 1000
ip address 10.104.11.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/2
ip address 10.102.11.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/3
speed 1000
ip address 10.103.11.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface loopback0
description ANYCAST-RP
ip address 192.168.0.11/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback1
description ANYCAST-RP-CANDIDATE
ip address 192.168.11.11/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
router ospf 1
router bgp 65000
neighbor 192.168.3.3
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 192.168.4.4
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 192.168.5.5
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature dhcp
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.0a0a.0a0a
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
vlan 1,10,20,300
vlan 10
vn-segment 101010
vlan 20
vn-segment 202020
vlan 300
vn-segment 303030
spanning-tree vlan 10 priority 4096
ip prefix-list host_subnets seq 5 permit 10.10.10.0/24 le 32
ip prefix-list host_subnets seq 10 permit 192.168.20.0/24 le 32
ip prefix-list host_subnets seq 15 permit 172.16.10.8/32
route-map direct_routes_tenant-a permit 10
match ip address prefix-list host_subnets
vrf context tenant-a
vni 303030
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
interface Vlan20
no shutdown
vrf member tenant-a
no ip redirects
ip address 192.168.20.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
interface Vlan300
no shutdown
vrf member tenant-a
no ip redirects
ip forward
no ipv6 redirects
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 101010
suppress-arp
mcast-group 224.10.10.10
member vni 202020
suppress-arp
mcast-group 224.10.10.10
member vni 303030 associate-vrf
interface Ethernet1/1
ip address 10.104.11.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface loopback0
description UNDERLAY-VERIFICATION
ip address 192.168.5.5/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback100
vrf member tenant-a
ip address 172.16.10.8/32
router ospf 1
router bgp 65000
address-family ipv4 unicast
neighbor 192.168.0.11
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-a
address-family ipv4 unicast
redistribute direct route-map direct_routes_tenant-a
evpn
vni 101010 l2
rd auto
route-target import auto
route-target export auto
vni 202020 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature dhcp
feature vpc
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.0a0a.0a0a
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
vlan 1,10,300,777
vlan 10
vn-segment 101010
vlan 300
vn-segment 303030
vlan 777
name BACKUP_VLAN_ROUTING_NVE_INFRA
spanning-tree vlan 1,10,300 hello-time 4
ip prefix-list host_subnets seq 5 permit 10.10.10.0/24 le 32
ip prefix-list host_subnets seq 15 permit 172.16.10.9/32
route-map direct_routes_tenant-a permit 10
match ip address prefix-list host_subnets
vrf context tenant-a
vni 303030
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
system nve infra-vlans 777
vpc domain 1
peer-switch
peer-keepalive destination 10.88.238.195
peer-gateway
layer3 peer-router
ip arp synchronize
interface Ethernet1/3
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10,20
channel-group 10 mode active
no shutdown
interface Ethernet1/19
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
interface port-channel1
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10
vpc 10
interface mgmt0
vrf member management
ip address 10.88.238.194/29
interface loopback0
description UNDERLAY-VERIFICATION
ip address 192.168.3.3/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback1
description OVERLAY-NVE
ip address 192.168.13.1/32
ip address 192.168.13.254/32 secondary
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback10
vrf member tenant-a
ip address 172.16.10.1/32
interface loopback100
vrf member tenant-a
ip address 172.16.10.9/32
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
interface Vlan300
no shutdown
vrf member tenant-a
no ip redirects
ip forward
no ipv6 redirects
interface Vlan777
description BACKUP_UNDERLAY_INFRA-VLAN
no shutdown
no ip redirects
ip address 10.255.77.1/30
no ipv6 redirects
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface Ethernet1/2
ip address 10.102.11.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface nve1
no shutdown
host-reachability protocol bgp
advertise virtual-rmac
source-interface loopback1
member vni 101010
suppress-arp
mcast-group 224.10.10.10
member vni 303030 associate-vrf
router ospf 1
router bgp 65000
address-family ipv4 unicast
address-family l2vpn evpn
advertise-pip
neighbor 192.168.0.11
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
neighbor 192.168.88.2
remote-as 65000
description OVERLAY_BACKUP
update-source Vlan888
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-a
address-family ipv4 unicast
redistribute direct route-map direct_routes_tenant-a
evpn
vni 101010 l2
rd auto
route-target import auto
route-target export auto
vni 202020 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature dhcp
feature vpc
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.0a0a.0a0a
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
vlan 1,10,20,300,777
vlan 10
vn-segment 101010
vlan 20
vn-segment 202020
vlan 300
vn-segment 303030
vlan 777
name BACKUP_VLAN_ROUTING_NVE_INFRA
spanning-tree vlan 1,10,20,300 hello-time 4
ip prefix-list host_subnets seq 5 permit 10.10.10.0/24 le 32
ip prefix-list host_subnets seq 10 permit 192.168.20.0/24 le 32
ip prefix-list host_subnets seq 15 permit 172.16.10.10/32
route-map direct_routes_tenant-a permit 10
match ip address prefix-list host_subnets
vrf context tenant-a
vni 303030
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
system nve infra-vlans 777
vpc domain 1
peer-switch
peer-keepalive destination 10.88.238.194
peer-gateway
layer3 peer-router
ip arp synchronize
interface Ethernet1/1
ip address 10.103.11.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/19
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
interface port-channel1
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10,20
vpc 10
interface mgmt0
vrf member management
ip address 10.88.238.195/29
interface loopback0
description UNDERLAY-VERIFICATION
ip address 192.168.4.4/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback1
description OVERLAY-NVE
ip address 192.168.13.2/32
ip address 192.168.13.254/32 secondary
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback10
vrf member tenant-a
ip address 172.16.10.2/32
interface loopback100
vrf member tenant-a
ip address 172.16.10.10/32
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
interface Vlan20
no shutdown
vrf member tenant-a
no ip redirects
ip address 192.168.20.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
interface Vlan300
no shutdown
vrf member tenant-a
no ip redirects
ip forward
no ipv6 redirects
interface Vlan777
description BACKUP_UNDERLAY_INFRA-VLAN
no shutdown
no ip redirects
ip address 10.255.77.2/30
no ipv6 redirects
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface nve1
no shutdown
host-reachability protocol bgp
advertise virtual-rmac
source-interface loopback1
member vni 101010
suppress-arp
mcast-group 224.10.10.10
member vni 202020
suppress-arp
mcast-group 224.10.10.10
member vni 303030 associate-vrf
router ospf 1
router bgp 65000
address-family ipv4 unicast
address-family l2vpn evpn
advertise-pip
neighbor 192.168.0.11
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
neighbor 192.168.88.1
remote-as 65000
description OVERLAY_BACKUP
update-source Vlan888
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-a
address-family ipv4 unicast
redistribute direct route-map direct_routes_tenant-a
evpn
vni 101010 l2
rd auto
route-target import auto
route-target export auto
vni 202020 l2
rd auto
route-target import auto
route-target export auto
feature lacp
vlan 1,10
interface port-channel10
switchport
switchport mode trunk
interface Ethernet1/11
switchport
switchport access vlan 10
no shutdown
interface Ethernet1/45
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown
interface Ethernet1/46
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown
Paso 1. Active la función DHCP.
LEAF-1(config)# feature dhcp
Nota: El servidor DHCP y el servicio de comandos relay agent dhcp, ip dhcp relay e ipv6 dhcp relay están activados de forma predeterminada desde NX-OS 7.x.
Paso 2. Aplique el comando ip dhcp relay information option.
LEAF-1(config)# ip dhcp relay information option
Nota: Este comando permite al agente de retransmisión DHCP insertar y quitar información de la opción 82 en los paquetes que se reenvían.
Paso 3. Aplique el comando ip dhcp relay information option vpn.
LEAF-1(config)# ip dhcp relay information option vpn
Nota: Este comando habilita las solicitudes de retransmisión DHCP que llegan a diferentes VRF a los que pertenece el servidor DHCP.
Paso 4. Aplique el comando "ip dhcp relay address [ip address of DHCP server]".
Nota: En este ejemplo, la dirección IP del servidor DHCP es 10.10.10.150.
LEAF-1(config)# interface vlan 10
LEAF-1(config-if)# ip dhcp relay address 10.10.10.150
Paso 5. Aplique el comando "ip dhcp relay source-interface [unique loopback]".
Nota: Este comando configura la dirección IP de origen para que el agente de retransmisión DHCP administre Discover, Offer, Request y ACK, para la comunicación de unidifusión que el agente de retransmisión DHCP utiliza la dirección IP de SVI como dirección IP de origen para el agente de retransmisión DHCP. Esto no es deseado porque esta dirección IP es compartida por varios VTEPs y puede ocurrir el agujereo negro de paquetes DHCP. Para evitar esto, es necesaria una dirección IP única (que utilice una interfaz de loopback) para diferenciar cada VTEP.
LEAF-1(config)# interface vlan 10
LEAF-1(config-if)# ip dhcp relay source-interface loopback100
Paso 6. En el arrendatario correspondiente VRF dentro de BGP, redistribución de ruta directa con una lista de prefijos y un route-map que incluye la dirección IP de la interfaz de loopback.
Nota: Esta interfaz de loopback pertenece al arrendatario de SVI.
LEAF-1(config)# show running-config interface loopback 100
interface loopback100
vrf member tenant-a
ip address 172.16.10.8/32
LEAF-1(config)# ip prefix-list host_subnets seq 15 permit 172.16.10.8/32
LEAF-1(config)# route-map direct_routes_tenant-a permit 10
LEAF-1(config-route-map)# match ip address prefix-list host_subnets
LEAF-1(config-route-map)# router bgp 65000
LEAF-1(config-router)# vrf tenant-a
LEAF-1(config-router-vrf)# address-family ipv4 unicast
LEAF-1(config-router-vrf-af)# redistribute direct route-map direct_routes_tenant-a
Paso 7. Verifique que la dirección IP de la interfaz de loopback se anuncie en BGP L2VPN EVPN a los Spines con el comando: show bgp l2vpn evpn [loopback IP] vrf [tenant vrf].
LEAF-1(config)# show bgp l2vpn evpn 172.16.10.8 vrf tenant-a
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.5.5:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.8]/224, version 421
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.5.5 (metric 0) from 0.0.0.0 (192.168.5.5)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:707d.b9b8.4daf
Path-id 1 advertised to peers:
192.168.0.11 <<<< Spine
Paso 8. Verifique que la dirección IP de la interfaz de loopback esté insertada en BGP L2VPN EVPN donde se encuentra el servidor DHCP.
Nota: Si hay switches Nexus en vPC, verifique que ambos aprendan la dirección IP de la interfaz de loopback en BGP L2VPN EVPN.
LEAF-1# show bgp l2vpn evpn 172.16.10.8
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.5.5:4
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.8]/224, version 754
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW
Advertised path-id 1
Path type: internal, path is valid, is best path, no labeled nexthop
Imported to 2 destination(s)
Imported paths list: tenant-a L3-303030
Gateway IP: 0.0.0.0
AS-Path: NONE, path sourced internal to AS
192.168.5.5 (metric 45) from 192.168.0.11 (192.168.0.11)
Origin incomplete, MED 0, localpref 100, weight 0
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:707d.b9b8.4daf
Originator: 192.168.5.5 Cluster list: 192.168.0.11
Path-id 1 not advertised to any peer
Route Distinguisher: 192.168.3.3:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.8]/224, version 761
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW
Advertised path-id 1
Path type: internal, path is valid, is best path, no labeled nexthop
Imported from 192.168.5.5:4:[5]:[0]:[0]:[32]:[172.16.10.8]/224
Gateway IP: 0.0.0.0
AS-Path: NONE, path sourced internal to AS
192.168.5.5 (metric 45) from 192.168.0.11 (192.168.0.11)
Origin incomplete, MED 0, localpref 100, weight 0
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:707d.b9b8.4daf
Originator: 192.168.5.5 Cluster list: 192.168.0.11
Path-id 1 not advertised to any peer
Paso 9. Verifique que haya una ruta para el servidor DHCP en el arrendatario de origen con el comando show ip route [DHCP server IP] vrf [tenant vrf].
Nota: La entrada de ruta a utilizar debe ser de VxLAN a VRF predeterminado. Si no hay ninguna ruta disponible, verifique si VTEP conoce localmente la dirección IP del servidor DHCP.
LEAF-1# show running-config interface vlan 10
interface Vlan10
no shutdown
vrf member tenant-a <<<< source tenant
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150 <<<< DHCP server
ip dhcp relay source-interface loopback100
LEAF-1# show ip route 10.10.10.150 vrf tenant-a
10.10.10.150/32, ubest/mbest: 1/0
*via 192.168.13.254%default, [200/0], 2w0d, bgp-65000, internal, tag 65000, segid: 303030 tunnelid: 0xd0d0dfe encap: VXLAN
Paso 10. Verifique que la IP del servidor DHCP sea accesible usando la interfaz de loopback y el VRF correspondiente como un origen VRF con el comando ping [DHCP server IP] source-interface loopback [x] vrf [tenant vrf].
LEAF-1# ping 10.10.10.150 source-interface loopback 100 vrf tenant-a
PING 10.10.10.150 (10.10.10.150): 56 data bytes
64 bytes from 10.10.10.150: icmp_seq=0 ttl=126 time=1.262 ms
64 bytes from 10.10.10.150: icmp_seq=1 ttl=126 time=0.833 ms
64 bytes from 10.10.10.150: icmp_seq=2 ttl=126 time=0.808 ms
64 bytes from 10.10.10.150: icmp_seq=3 ttl=126 time=0.795 ms
64 bytes from 10.10.10.150: icmp_seq=4 ttl=126 time=0.78 ms
--- 10.10.10.150 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
Paso 11. Verifique el estado del agente de retransmisión DHCP.
LEAF-1# show ip dhcp status
Current CLI Operation: show ip dhcp status
Last CLI Operation: DME: ip dhcp relay information option enable
Last CLI Operation Status: SUCCESS
Paso 12. Verifique la opción 82, como la opción vpn y la dirección IP de retransmisión correcta bajo el agente de retransmisión.
LEAF-1# show ip dhcp relay
DHCP relay service is enabled <<<<<<
Insertion of option 82 is enabled <<<<<<
Insertion of option 82 customize circuitid is disabled
TLV format in CircuitId and RemoteId suboptions is enabled
Insertion of VPN suboptions is enabled <<<<<<<
Insertion of cisco suboptions is disabled
Global smart-relay is disabled
Relay Trusted functionality is disabled
Relay Trusted Port is Globally disabled
V4 Relay Source Address HSRP is Globally disabled
Server-ID-override-disable is disabled
Smart-relay is enabled on the following interfaces:
------------------------------------------------------
Subnet-broadcast is enabled on the following interfaces:
------------------------------------------------------
Relay Trusted Port is enabled on the following interfaces:
----------------------------------------------------------
Relay Source Address HSRP is enabled on the following interfaces:
-------------------------------------------------------------------
Helper addresses are configured on the following interfaces:
Interface Relay Address VRF Name
------------- ------------- --------
Vlan10 10.10.10.150 <<<<<<<<<
Paso 13. Verifique las estadísticas de los paquetes procesados y reenviados.
LEAF-1# show ip dhcp global statistics
Packets processed 1297177
Packets received through cfsoe 0
Packets forwarded 1297175
Packets forwarded on cfsoe 0
Total packets dropped 0
Packets dropped from untrusted ports 0
Packets dropped due to MAC address check failure 0
Packets dropped due to Option 82 insertion failure 0
Packets dropped due to o/p intf unknown 0
Packets dropped which were unknown 0
Packets dropped due to no trusted ports 0
Packets dropped due to dhcp relay not enabled 0
Packets dropped due to no binding entry 0
Packets dropped due to interface error/no interface 0
Packets dropped due to max hops exceeded 0
Packets dropped due to Queue full 0
Paso 14. Verifique las estadísticas de los paquetes de retransmisión.
LEAF-1# show ip dhcp relay statistics
----------------------------------------------------------------------
Message Type Rx Tx Drops
----------------------------------------------------------------------
Discover 260521 260520 0
Offer 289330 289330 0
Request(*) 267162 267161 0
Ack 8322 8322 0
Release(*) 181121 181121 0
Decline 1 1 0
Inform(*) 0 0 0
Nack 289280 289280 0
----------------------------------------------------------------------
Total 1295737 1295735 0
----------------------------------------------------------------------
DHCP L3 FWD:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
Non DHCP:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
DROP:
DHCP Relay not enabled : 0
Invalid DHCP message type : 0
Interface error : 0
Tx failure towards server : 0
Tx failure towards client : 0
Unknown output interface : 0
Unknown vrf or interface for server : 0
Max hops exceeded : 0
Option 82 validation failed : 0
Packet Malformed : 0
DHCP Request dropped on MCT : 0
Relay Trusted port not configured : 0
* - These counters will show correct value when switch
receives DHCP request packet with destination ip as broadcast
address. If request is unicast it will be HW switched
Paso 1. Active la función DHCP.
LEAF-1-VPC(config)#feature dhcp
Nota: El servidor DHCP y el servicio de comandos relay agent dhcp, ip dhcp relay e ipv6 dhcp relay están activados de forma predeterminada desde NX-OS 7.x.
Paso 2. Aplique el comando ip dhcp relay information option.
LEAF-1-VPC(config)#ip dhcp relay information option
Nota: Este comando permite al agente de retransmisión DHCP insertar y quitar información de la opción 82 en los paquetes que se reenvían.
Paso 3. Aplique el comando "ip dhcp relay information option vpn".
LEAF-1-VPC(config)# ip dhcp relay information option vpn
Nota: Este comando habilita las solicitudes de retransmisión DHCP que llegan a diferentes VRF a los que pertenece el servidor DHCP.
Paso 4. Aplique el comando ip dhcp relay address [ip address of DHCP server].
Nota: En este ejemplo, la dirección IP del servidor DHCP es 10.10.10.150.
LEAF-1-VPC(config)#interface vlan 10
LEAF-1-VPC(config-if)#ip dhcp relay address 10.10.10.150
Paso 5. Aplique el comando "ip dhcp relay source-interface [unique loopback]".
Nota: Este comando configura la dirección IP de origen para que el agente de retransmisión DHCP administre Discover, Offer, Request y ACK, para la comunicación de unidifusión que el agente de retransmisión DHCP utiliza la dirección IP de SVI como dirección IP de origen para el agente de retransmisión DHCP. Esto no es deseado porque esta dirección IP es compartida por varios VTEPs y puede ocurrir el agujereo negro de paquetes DHCP. Para evitar esto, es necesaria una dirección IP única (que utilice una interfaz de loopback) para diferenciar cada VTEP.
LEAF-1-VPC(config)#interface vlan 10
LEAF-1-VPC(config-if)# ip dhcp relay source-interface loopback100
Paso 6. En el arrendatario correspondiente VRF dentro de BGP, redistribución de ruta directa con una lista de prefijos y un route-map que incluye la dirección IP de la interfaz de loopback.
Nota: Esta interfaz de loopback pertenece al arrendatario de SVI.
LEAF-1-VPC(config)# show running-config interface loopback 100
interface loopback100
vrf member tenant-a
ip address 172.16.10.9/32
LEAF-1-VPC(config)# ip prefix-list host_subnets seq 15 permit 172.16.10.9/32
LEAF-1-VPC(config)# route-map direct_routes_tenant-a permit 10
LEAF-1-VPC(config-route-map)# match ip address prefix-list host_subnets
LEAF-1-VPC(config-route-map)# router bgp 65000
LEAF-1-VPC(config-router)# vrf tenant-a
LEAF-1-VPC(config-router-vrf)# address-family ipv4 unicast
LEAF-1-VPC(config-router-vrf-af)# redistribute direct route-map direct_routes_tenant-a
Paso 7. Verifique que la dirección IP de la interfaz de loopback se anuncie en BGP L2VPN EVPN a los Spines con el comando: show bgp l2vpn evpn [loopback IP] vrf [tenant vrf].
LEAF-1-VPC# show bgp l2vpn evpn 172.16.10.9 vrf tenant-a
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.3.3:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.9]/224, version 637
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.1 (metric 0) from 0.0.0.0 (192.168.3.3)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9887
Path-id 1 advertised to peers:
192.168.0.11
Paso 8. Verifique que la dirección IP de la interfaz de loopback esté insertada en BGP L2VPN EVPN donde se encuentra el servidor DHCP.
Nota: Si hay switches Nexus en vPC, verifique que ambos aprendan la dirección IP de la interfaz de loopback en BGP L2VPN EVPN.
LEAF-1-VPC# show bgp l2vpn evpn 172.16.10.9
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.3.3:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.9]/224, version 637
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.1 (metric 0) from 0.0.0.0 (192.168.3.3)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9887
Path-id 1 advertised to peers:
192.168.0.11
Paso 9. Verifique que haya una ruta para el servidor DHCP en el arrendatario de origen con el comando show ip route [DHCP server IP] vrf[tenant vrf].
Nota: La entrada de ruta a utilizar debe ser de VxLAN a VRF predeterminado. Si no hay ninguna ruta disponible, verifique si VTEP conoce localmente la dirección IP del servidor DHCP.
LEAF-1-VPC# show running-config interface vlan 10
interface Vlan10
no shutdown
vrf member tenant-a <<<< source tenant
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
LEAF-1-VPC# show ip route 10.10.10.150 vrf tenant-a
10.10.10.150/32, ubest/mbest: 1/0, attached
*via 10.10.10.150, Vlan10, [190/0], 6d07h, hmm
Paso 10. Verifique que la IP del servidor DHCP sea alcanzable usando la interfaz de loopback y el VRF correspondiente como un origen VRF con el comando ping [DHCP server IP] source-interface loopback [x] vrf [tenvrf].
LEAF-1-VPC# ping 10.10.10.150 source-interface loopback 100 vrf tenant-a
PING 10.10.10.150 (10.10.10.150): 56 data bytes
64 bytes from 10.10.10.150: icmp_seq=0 ttl=126 time=0.965 ms
64 bytes from 10.10.10.150: icmp_seq=1 ttl=126 time=0.57 ms
64 bytes from 10.10.10.150: icmp_seq=2 ttl=126 time=0.488 ms
64 bytes from 10.10.10.150: icmp_seq=3 ttl=126 time=0.524 ms
64 bytes from 10.10.10.150: icmp_seq=4 ttl=126 time=0.502 ms
--- 10.10.10.150 ping statistics ---
Paso 11. Verifique el estado del agente de retransmisión DHCP.
LEAF-1-VPC# show ip dhcp status
Current CLI Operation: show ip dhcp status
Last CLI Operation: DME: ip dhcp relay information option vpn enable
Last CLI Operation Status: SUCCESS
Paso 12. Verifique la opción 82, como la opción vpn y la dirección IP de retransmisión correcta bajo el agente de retransmisión.
LEAF-1-VPC# show ip dhcp relay
DHCP relay service is enabled <<<<<<
Insertion of option 82 is enabled <<<<<<<
Insertion of option 82 customize circuitid is disabled
TLV format in CircuitId and RemoteId suboptions is enabled
Insertion of VPN suboptions is enabled <<<<<<<
Insertion of cisco suboptions is disabled
Global smart-relay is disabled
Relay Trusted functionality is disabled
Relay Trusted Port is Globally disabled
V4 Relay Source Address HSRP is Globally disabled
Server-ID-override-disable is disabled
Smart-relay is enabled on the following interfaces:
------------------------------------------------------
Subnet-broadcast is enabled on the following interfaces:
------------------------------------------------------
Relay Trusted Port is enabled on the following interfaces:
----------------------------------------------------------
Relay Source Address HSRP is enabled on the following interfaces:
-------------------------------------------------------------------
Helper addresses are configured on the following interfaces:
Interface Relay Address VRF Name
------------- ------------- --------
Vlan10 10.10.10.150 <<<<<<<<<
Paso 13. Verifique las estadísticas de los paquetes procesados y reenviados.
LEAF-1-VPC# show ip dhcp global statistics
Packets processed 263162
Packets received through cfsoe 0
Packets forwarded 263161
Packets forwarded on cfsoe 0
Total packets dropped 0
Packets dropped from untrusted ports 0
Packets dropped due to MAC address check failure 0
Packets dropped due to Option 82 insertion failure 0
Packets dropped due to o/p intf unknown 0
Packets dropped which were unknown 0
Packets dropped due to no trusted ports 0
Packets dropped due to dhcp relay not enabled 0
Packets dropped due to no binding entry 0
Packets dropped due to interface error/no interface 0
Packets dropped due to max hops exceeded 0
Packets dropped due to Queue full 0
Paso 14. Verifique las estadísticas de los paquetes de retransmisión.
LEAF-1-VPC# show ip dhcp relay statistics
----------------------------------------------------------------------
Message Type Rx Tx Drops
----------------------------------------------------------------------
Discover 8 7 0
Offer 29304 29304 0
Request(*) 5029 5029 0
Ack 6535 6535 0
Release(*) 191482 191482 0
Decline 0 0 0
Inform(*) 3 3 0
Nack 29281 29281 0
----------------------------------------------------------------------
Total 261642 261641 0
----------------------------------------------------------------------
DHCP L3 FWD:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
Non DHCP:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
DROP:
DHCP Relay not enabled : 0
Invalid DHCP message type : 0
Interface error : 0
Tx failure towards server : 0
Tx failure towards client : 0
Unknown output interface : 0
Unknown vrf or interface for server : 0
Max hops exceeded : 0
Option 82 validation failed : 0
Packet Malformed : 0
DHCP Request dropped on MCT : 0
Relay Trusted port not configured : 0
* - These counters will show correct value when switch
receives DHCP request packet with destination ip as broadcast
address. If request is unicast it will be HW switched
Paso 1. Active la función DHCP.
LEAF-2-VPC(config)# feature dhcp
Nota: El servidor DHCP y el servicio de comandos relay agent dhcp, ip dhcp relay e ipv6 dhcp relay están habilitados de forma predeterminada desde NX-OS 7.x.
Paso 2. Aplique el comando "ip dhcp relay information option".
LEAF-2-VPC(config)# ip dhcp relay information option
Nota: Este comando permite al agente de retransmisión DHCP insertar y quitar información de la opción 82 en los paquetes que se reenvían.
Paso 3. Aplique el comando "ip dhcp relay information option vpn".
LEAF-2-VPC(config)# ip dhcp relay information option vpn
Nota: Este comando habilita las solicitudes de retransmisión DHCP que llegan a diferentes VRF a los que pertenece el servidor DHCP.
Paso 4. Aplique el comando "ip dhcp relay address [ip address of DHCP server]".
Nota: En este ejemplo, la dirección IP del servidor DHCP es 10.10.10.150.
LEAF-2-VPC(config)# interface vlan 10
LEAF-2-VPC(config-if)# ip dhcp relay address 10.10.10.150
Paso 5. Aplique el comando "ip dhcp relay source-interface [unique loopback]".
Nota: Este comando configura la dirección IP de origen para que el agente de retransmisión DHCP administre Discover, Offer, Request y ACK, para la comunicación de unidifusión que el agente de retransmisión DHCP utiliza la dirección IP de SVI como dirección IP de origen para el agente de retransmisión DHCP. Esto no es deseado porque esta dirección IP es compartida por varios VTEPs y puede ocurrir el agujereo negro de paquetes DHCP. Para evitar esto, es necesaria una dirección IP única (que utilice una interfaz de loopback) para diferenciar cada VTEP.
LEAF-2-VPC(config)# interface vlan 10
LEAF-2-VPC(config-if)# ip dhcp relay source-interface loopback 100
Paso 6. En el arrendatario correspondiente VRF dentro de BGP, redistribución de ruta directa con una lista de prefijos y un route-map que incluye la dirección IP de la interfaz de loopback.
Nota: Esta interfaz de loopback pertenece al arrendatario de SVI.
LEAF-2-VPC(config-if)# show running-config interface loopback 100
interface loopback100
vrf member tenant-a
ip address 172.16.10.10/32
LEAF-2-VPC(config)# ip prefix-list host_subnets seq 15 permit 172.16.10.10/32
LEAF-2-VPC(config)# route-map direct_routes_tenant-a permit 10
LEAF-2-VPC(config-route-map)# match ip address prefix-list host_subnets
LEAF-2-VPC(config-route-map)# router bgp 65000
LEAF-2-VPC(config-router)# vrf tenant-a
LEAF-2-VPC(config-router-vrf)# address-family ipv4 unicast
LEAF-2-VPC(config-router-vrf-af)# redistribute direct route-map direct_routes_tenant-a
Paso 7. Verifique que la dirección IP de la interfaz de loopback se anuncie en BGP L2VPN EVPN a los Spines con el comando: show bgp l2vpn evpn [loopback IP] vrf [tenant vrf].
LEAF-2-VPC(config-if)# show bgp l2vpn evpn 172.16.10.10 vrf tenant-a
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.4.4:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.10]/224, version 49
5
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.2 (metric 0) from 0.0.0.0 (192.168.4.4)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9587
Path-id 1 advertised to peers:
192.168.0.11 <<<<< Spine
Paso 8. Verifique que la dirección IP de la interfaz de loopback esté insertada en BGP L2VPN EVPN donde se encuentra el servidor DHCP.
Nota: Si hay switches Nexus en vPC, verifique que ambos aprendan la dirección IP de la interfaz de loopback en BGP L2VPN EVPN.
LEAF-2-VPC(config-if)# show bgp l2vpn evpn 172.16.10.10
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.4.4:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.10]/224, version 49
5
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.2 (metric 0) from 0.0.0.0 (192.168.4.4)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9587
Path-id 1 advertised to peers:
192.168.0.11
Paso 9. Verifique que haya una ruta para el servidor DHCP en el arrendatario de origen con el comando show ip route [DHCP server IP] vrf[tenvrf].
Nota: La entrada de ruta a utilizar debe ser de VxLAN a VRF predeterminado. Si no hay ninguna ruta disponible, verifique si VTEP conoce localmente la dirección IP del servidor DHCP.
LEAF-2-VPC(config-if)# show running-config interface vlan 10
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
LEAF-2-VPC(config-if)# show ip route 10.10.10.150 vrf tenant-a
10.10.10.150/32, ubest/mbest: 1/0, attached
*via 10.10.10.150, Vlan10, [190/0], 01:01:28, hmm
Paso 10. Verifique que la IP del servidor DHCP sea accesible usando la interfaz de loopback y el VRF correspondiente como un origen VRF con el comando ping [DHCP server IP] source-interface loopback [x] vrf [tenant vrf].
LEAF-2-VPC(config-if)# ping 10.10.10.150 source-interface loopback 100 vrf tenant-a
PING 10.10.10.150 (10.10.10.150): 56 data bytes
64 bytes from 10.10.10.150: icmp_seq=0 ttl=127 time=0.928 ms
64 bytes from 10.10.10.150: icmp_seq=1 ttl=127 time=0.475 ms
64 bytes from 10.10.10.150: icmp_seq=2 ttl=127 time=0.455 ms
64 bytes from 10.10.10.150: icmp_seq=3 ttl=127 time=0.409 ms
64 bytes from 10.10.10.150: icmp_seq=4 ttl=127 time=0.465 ms
--- 10.10.10.150 ping statistics ---
Paso 11. Verifique el estado del agente de retransmisión DHCP.
LEAF-2-VPC(config)# show ip dhcp status
Current CLI Operation: show ip dhcp status
Last CLI Operation: DME: ip dhcp relay information option vpn enable
Last CLI Operation Status: SUCCESS
Paso 12. Verifique la opción 82, como la opción vpn y la dirección IP de retransmisión correcta bajo el agente de retransmisión.
LEAF-2-VPC(config)# show ip dhcp relay
DHCP relay service is enabled <<<<<<<
Insertion of option 82 is enabled <<<<<<<<<
Insertion of option 82 customize circuitid is disabled
TLV format in CircuitId and RemoteId suboptions is enabled
Insertion of VPN suboptions is enabled <<<<<<<
Insertion of cisco suboptions is disabled
Global smart-relay is disabled
Relay Trusted functionality is disabled
Relay Trusted Port is Globally disabled
V4 Relay Source Address HSRP is Globally disabled
Server-ID-override-disable is disabled
Smart-relay is enabled on the following interfaces:
------------------------------------------------------
Subnet-broadcast is enabled on the following interfaces:
------------------------------------------------------
Relay Trusted Port is enabled on the following interfaces:
----------------------------------------------------------
Relay Source Address HSRP is enabled on the following interfaces:
-------------------------------------------------------------------
Helper addresses are configured on the following interfaces:
Interface Relay Address VRF Name
------------- ------------- --------
Vlan10 10.10.10.150 <<<<
Paso 13. Verifique las estadísticas de los paquetes procesados y reenviados.
LEAF-2-VPC(config)# show ip dhcp global statistics
Packets processed 103030
Packets received through cfsoe 0
Packets forwarded 103030
Packets forwarded on cfsoe 0
Total packets dropped 0
Packets dropped from untrusted ports 0
Packets dropped due to MAC address check failure 0
Packets dropped due to Option 82 insertion failure 0
Packets dropped due to o/p intf unknown 0
Packets dropped which were unknown 0
Packets dropped due to no trusted ports 0
Packets dropped due to dhcp relay not enabled 0
Packets dropped due to no binding entry 0
Packets dropped due to interface error/no interface 0
Packets dropped due to max hops exceeded 0
Packets dropped due to Queue full 0
Paso 14. Verifique las estadísticas de los paquetes de retransmisión.
LEAF-2-VPC# show ip dhcp relay statistics
----------------------------------------------------------------------
Message Type Rx Tx Drops
----------------------------------------------------------------------
Discover 29312 29311 0
Offer 300001 300001 0
Request(*) 29324 29324 0
Ack 1574 1574 0
Release(*) 191493 191493 0
Decline 0 0 0
Inform(*) 1540 1540 0
Nack 472890 472890 0
----------------------------------------------------------------------
Total 1026134 1026133 0
----------------------------------------------------------------------
DHCP L3 FWD:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
Non DHCP:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
DROP:
DHCP Relay not enabled : 0
Invalid DHCP message type : 0
Interface error : 0
Tx failure towards server : 0
Tx failure towards client : 0
Unknown output interface : 0
Unknown vrf or interface for server : 0
Max hops exceeded : 0
Option 82 validation failed : 0
Packet Malformed : 0
DHCP Request dropped on MCT : 0
Relay Trusted port not configured : 0
* - These counters will show correct value when switch
receives DHCP request packet with destination ip as broadcast
address. If request is unicast it will be HW switched
Paso 1. Abra el Administrador del servidor y compruebe que no hay alarmas en el servidor DHCP en el Panel.
Sugerencia: la imagen se amplía al hacer doble clic.
Paso 2. Abra la aplicación Servidor DHCP.
Paso 3. Haga clic con el botón derecho del ratón en IPv4 y haga clic en Nuevo ámbito.
Paso 4. Haga clic en Next (Siguiente).
Paso 5. Escriba un nombre y una descripción. En este ejemplo, el nombre es la subred que pertenece a la VLAN 10 y la descripción es el L2VNI como L2VNI enumerado en la VLAN 10.
Paso 6. Configure el intervalo de direcciones IP. Este es el conjunto para hosts.
Paso 6. Excluya la dirección IP compartida de la configuración de SVI en los VTEP. En este ejemplo, la interfaz VLAN 10 tiene la dirección IP.10.10.1/24.
Advertencia: si no se excluye la dirección IP de la SVI (o del gateway predeterminado), puede producirse una duplicación de las direcciones IP y afectar a la entrega del tráfico.
LEAF-1# show running-config interface vlan 10
<snip>
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
Paso 7. Configurar la duración de concesión de la dirección IP. Esto se refiere a la cantidad de tiempo que un host puede utilizar la dirección IP asignada antes de renovarla.
Paso 8. Seleccione Sí, deseo configurar estas opciones ahora.
Paso 9. Configure la dirección IP del gateway predeterminado.
Paso 10. Configure el nombre de dominio y el servidor DNS.
Paso 11. Configure el servidor WINS si corresponde. Esto se puede omitir si no se conoce la información.
Paso 12. Seleccione Sí, deseo activar este ámbito ahora.
Paso 1. Haga clic con el botón derecho del ratón en IPv4 y seleccione IPv4Scope.
Paso 2. Escriba un nombre y una descripción. En este ejemplo, name es la subred utilizada para la subred con dirección de loopbacks.
IPte: se utiliza un bucle invertido con una dirección IP única en todo el fabric VxLAN para arrendatarios VxLAN. Esto se debe anunciar en la redistribución de rutas BGP L2VPN EVPN en BGP dentro del VRF del arrendatario correspondiente en la dirección IPv4-famIPv4
LEAF-1# show running-config interface loopback 100
<snip>
interface loopback100
vrf member tenant-a
ip address 172.16.10.8/32
Paso 3. Configure el rango de direcciones IPIP. Este es el conjunto para loopbacks.
Paso 4. Configure las exclusiones (opcional porque el servidor DHCP no concede direcciones IP que pertenezcan a esta subred).
Paso 5. Omita la duración de la concesión y haga clic en Next.
Paso 6. Seleccione No, configuraré estas opciones más adelante.
Paso 7. Haga clic en Finish (Finalizar).
Paso 8. Haga clic con el botón derecho del ratón en el ámbito creado y seleccione activar.
Paso 1. Haga clic con el botón derecho del ratón en IPv4 y seleccione Nuevo superámbito.
Paso 2. Haga clic en Next (Siguiente).
Paso 3. Escriba el nombre del superámbito.
Paso 4. Seleccione todos los ámbitos que pertenezcan a VxLAN Fabric.
Paso 5. Seleccione todos los ámbitos que pertenezcan a VxLAN Fabric.
Paso 6. Verifique que todo el superámbito del fabric VxLAN esté colocado y haga clic en Finish.
Paso 1. Haga clic con el botón derecho del ratón en Directivas (última opción) dentro del alcance del host y haga clic en Nueva directiva.
Paso 2. Escriba un nombre y una descripción y haga clic en Next.
Nota: En este ejemplo, la política se crea para seleccionar IPpIPicularly de direccionamiento IP para hosts en Leaf-1 para VNI 101010 basedVNI Remote-ID (parámetro de la opción 82).
Paso 3. Haga clic en Add (Agregar). En Criterios, seleccione Información del agente de retransmisión. En Operador, seleccione Igual a. A continuación, seleccione Agent Remote ID y escriba el valor. Haga clic en Aceptar y, a continuación, en Siguiente.
Nota: El ID remoto se obtiene de la dirección MAC de la SVI a la que está asociado el SVII.
Sugerencia: se puede aplicar una política a varios ID remotos (o VTEP) agregando más condiciones y seleccionando OR en lugar de AND.
LEAF-1# show interface vlan 10
Vlan10 is up, line protocol is up, autostate enabled
Hardware is EtherSVI, address is 707d.b9b8.4daf <<<<
Internet Address is 10.10.10.1/24
<snip>
Paso 4. Configure el direccionamiento IP que el IP existente puede utilizar en los VTEP seleccionados por el ID y, a continuación, haga clic en Siguiente.
Nota: En este ejemplo, sólo hay una máquina virtual conectada a Leaf-1, por lo que sólo se requiere una dirección IP. Aquí se agrega una segunda dirección IPn caso de que se conecte otro host.
Paso 5. Seleccione la casilla a la izquierda de 003 Router en DCHP Standard Option. A continuación, escriba la dirección IP del gateway predeterminado para los hosts que pertenecen a esta política y pulse Agregar. Haga clic en Next (Siguiente).
Precaución: Puede seleccionar más de una opción, pero si no está seguro del valor que debe introducir, no lo haga. Una configuración incoherente o errónea puede provocar un comportamiento inesperado.
Paso 6. Compruebe las condiciones de la directiva y haga clic en Finalizar.
Detección recibida en LEAF-1 | Detección enviada por LEAF-1 |
Sugerencia: la imagen se amplía al hacer doble clic.
Descubrimiento recibido en COLUMNA | Detección enviada por SPINE |
Detección recibida en LEAF-1-vPC | Detección enviada por LEAF-1-vPC |
Nota: LEAF-2-vPC recibe el paquete Discovert, pero sólo se conmuta. La dirección MAC de destino pertenece al servidor DHCP.
Oferta recibida en LEAF-2-vPC | Oferta enviada por LEAF-2-vPC |
Oferta recibida en SPINE | Oferta enviada por SPINE |
Oferta recibida en LEAF-1 | Envío de oferta en LEAF-1 |
Solicitud recibida en LEAF-1 | Solicitud enviada por LEAF-1 |
Solicitud recibida en SPINE | Solicitud de envío por SPINE |
Solicitar recevPCd en LEAF-2-vPC | Solicitud de envío por vPCAF-2-vPC |
ACK recibido en LEAF-2-vPC | ACK enviado por LEAF-2-vPC |
ACK recibido en COLUMNA VERTEBRAL | ACK enviado por SPINE |
ACK recibido en LEAF-1 | ACK enviado por LEAF-1 |
Configuración de VXLAN BGP EVPN
Solución de problemas relacionados con DHCP en Nexus 9000
Guía de configuración de VXLAN NX-OS para Cisco Nexus serie 9000, versión 10.4(x)
Revisión | Fecha de publicación | Comentarios |
---|---|---|
1.0 |
29-Apr-2024 |
Versión inicial |