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C H A P T E R 1
Get Started with Cisco Optical Network Planner

• Cisco Optical Network Planner Overview, on page 1
• Supported Platforms, on page 2
• Supported Topologies , on page 3
• Supported Protection Schemes , on page 3
• Supported Services, on page 5
• Supported DWDM Channel Interfaces, on page 5
• Supported Fiber Types, on page 5
• Register New User, on page 6
• Log in to Cisco ONP Web Interface, on page 6
• Cisco ONP Home Page, on page 7
• Change Password , on page 7
• Reset Your Password, on page 7
• Sign Out from Cisco ONP, on page 8
• Cisco Secure Development Lifecycle Compliance, on page 8

Cisco Optical Network Planner Overview
Cisco Optical Network Planner (Cisco ONP) is a web application to model and test Optical Transport Networks
(OTN) and Dense Wavelength Division Multiplexing (DWDM) optical networks by using a graphical
environment. The primary purpose of Cisco ONP is to design and validate networks of NCS 1001, NCS 1004,
NCS 1010, NCS 2000, and NCS 4000 series. Using the Cisco ONP tool, you create multiple instances of a
network, modify different parameters at each instance, and compare. Cisco ONP generates a rack view of all
the sites that are deployed in the network, shows the differences between the instances, and provides a complete
Bill of Materials (BoM) for the network.

Cisco ONP models the network, generates the BoM, and provides detailed information about the network,
such as Cabling report, Optical report, Device Configuration file, and Traffic matrix.

This chapter describes the features of Cisco ONP, protection scenarios, topology and service support, CSDL
(Cisco Secure Development Lifecycle) compliance, and the setting up of the graphical display.

For more information about Cisco ONP, see the data sheet.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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Supported Platforms
Table 1: Feature History

Feature DescriptionRelease InformationFeature Name

This release supports the design of
C-band NCS 1001 networks. The
NCS 1001 is a 1RU, DWDM line
system optimized for data center
environments. It includes support
for amplifiers, PSM modules, and
various colored add/drop modules
such as MD-32-EVEN, FLD-4,
MD-48-ODD, MD-48-EVEN, and
MD-64.

Cisco ONP supports unprotected,
terminal section, and terminal path
protection over the NCS 1001
network. Also, the NCS 1001
network is compatible with optical
sources such as NCS 1004, CIM8,
Bright ZR, QDD, and CFP2.

Cisco ONP Release 24.3.1Support for NCS 1001 Network
Creation

NCS 1020 is a 10RU optical line
system that supports the OLTs and
NCS1K14-CCMD-16-C card in the
NCS 1010 networks. The NCS
1020 chassis optimizes the NCS
1010 networks design, extending
the reach of NCS 1010 networks.
With OLTs and
NCS1K14-CCMD-16-C, the NCS
1020 chassis provides a wide range
of configuration options to NCS
1010 networks.

Cisco ONP Release 24.3.1Addition of newNCS 1020 Chassis
for NCS 1010 Networks

Cisco ONP supports the following platforms:

Table 2: Supported Platforms and Releases

Recommended and Supported ReleasesPlatforms

7.10.1NCS 1001

7.11.1NCS 1004

7.11.1, 24.3.1NCS 1014

7.7.1, 7.9.1, 7.10.1, 7.11.1, 24.3.1NCS 1010

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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Recommended and Supported ReleasesPlatforms

24.3.1NCS 1020

11.0.0, 11.1.0, 12.1.0, 12.2.0, 12.3.1NCS 2000

6.5.33NCS 4000

Supported Topologies
Cisco ONP supports the following network topologies:

• Linear—In a linear topology, the nodes are arranged in a line and are connected to two other adjacent
nodes. However, the first and last nodes are not connected.

• Mesh—In a mesh topology, each node is connected to one or more nodes. This configuration provides
maximum redundancy to the network.

• Ring—In a ring topology, each node is connected to exactly two other nodes, forming a circular
configuration. It requires at least three nodes to form a ring.

Supported Protection Schemes
Table 3: Feature History

Feature DescriptionRelease InformationFeature Name

The following protection schemes
are supported:

• 1+R: For each service, Cisco
ONP automatically finds one
working path. You can define
the restoration path.

• 1+1+R: For each service,
Cisco ONP finds one working
path, and one protected path.
You can define the restoration
path.

• 1+1+R+R: For each service,
Cisco ONP finds one working
path and one protected path.
You can define the restoration
paths.

Cisco ONP Release 4.1Protection Types Supported

Cisco ONP supports the following protection schemes:

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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Figure 1: Protection Schemes

• Unprotected—In unprotected mode, the tool routes the service on the shortest path.

• 1+1—Two client signals are transmitted to separate line cards or transponder cards instead of using
Y-cable to split one client signal into two line cards or transponder cards. In client 1+1 protection, the
failure and switchover are controlled by the client system. The following figure shows 1+1 protection.

Figure 2: 1+1 Protection

• 1+R—Supported on SSON network. For each service, Cisco ONP automatically finds one working path.
You can define the restoration path.

• 1+1+R—Supported on SSON network. For each service, Cisco ONP finds one working path, and one
protected path. You can define the restoration path.

• 1+1+R+R—Supported on SSON network. For each service, Cisco ONP finds one working path and one
protected path. You can define the restoration paths.

• S+NS—Supported on both SSON and non-SSON NCS 4000-NCS 2000 network. Cisco ONP uses the
shortest path for the working service, and the next shortest path for protection. The paths are
span-disjointed but not node disjointed.

• Unprotected Disjoint—Supported on both SSON and non-SSONNCS 4000-NCS 2000 network. Cisco
ONP provides two cards following two completely disjoint paths in the network to reach their destination.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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• PSM-Channel Protection—Supported on NCS 2000 non-SSON network

Supported Services
Cisco ONP supports the following OTN demands:

• ODU-1,ODU-2,ODU-3,ODU-4

• GE – Gigabit Ethernet

• 10GE – 10-Gigabit Ethernet

• 100GE –100-Gigabit Ethernet

• 400GE –400-Gigabit Ethernet

The 400GE service is supported on the NCS 1010 networks.

• STS-3

• STS-12

• STS-48

• STS-192

• VC-4-4

• VC-4-16

• VC-4-64

• STM-64

Supported DWDM Channel Interfaces
See Supported Cards and Pluggables, on page 271 and Supported Optical Sources, on page 285 for the DWDM
channel interfaces supported by Cisco ONP.

Supported Fiber Types
Cisco ONP supports the following fiber types:

• G652-SMF

• G652-SMF-28E

• True Wave Reach

• True Wave RS

• True-Wave Plus

• True-Wave Minus

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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• True-Wave Classic

• Free-Light

• Tera-Light

• Metro-Core

• ELEAF

• NDSF (only NCS 1010)

• ALLWave (only NCS 1010)

• SMF-28 ULL (only NCS 1010)

• SMF28-Ultra (only NCS 1010)

Register New User
Use this task to register yourself as a user.

Step 1 In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.
Step 2 Click Sign Up in the Login page.
Step 3 Enter the Username, Email, and Password, and click Submit.

ClickGenerate if you want a system-generated password. Copy and paste the system-generated password in the Password
field.

Step 4 Click Ok in the Success dialog box.

Log in to Cisco ONP Web Interface
Use this task to log into the Cisco ONP web interface.

Step 1 In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.

If you are a new user, sign up. See Register New User, on page 6, for more information.

If Google Chrome browser blocks your access to Cisco ONP due to self-signed certificate security, type thisisunsafe
to proceed to the login page.

Note

Step 2 Enter the username and password in the Username and Password text boxes.
Step 3 Click Login.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
6

Get Started with Cisco Optical Network Planner
Register New User



Cisco ONP Home Page
After your login, Cisco ONP displays its home page. The home page comprises the following elements:

• Menu bar―Includes various menus such as File, Network, Export, Import, Manage, Logs, Job Monitor,
Control Panel, and Help. See Menu Bar, on page 250.

• Last Login―Shows the last date and time when the user logged in to the Cisco ONP tool.

• Last Login IP―Shows the IP address of the client through which the user logged into the Cisco ONP
tool previously.

• User name―Shows the name of the user who has currently logged in to the Cisco ONP tool, for example:
ADMIN.

• Reports tabs―Shows various reports under each tab. Report availability depends on whether a network
is analyzed or not. Reports are also available in site properties after analyzing the network.

• Network tree―Displays the network name, and network elements, such as Sites, Fibers,Waves orMedia
Channels, SRLGs, and Subnet. See Network Tree, on page 258.

To expand the Cisco ONP workable area, click the horizontal and vertical arrows on the home page. If an
empty grey window appears, ensure you are using the latest version of your browser. For detailed hardware
and software requirements, refer to the Cisco ONP Installation Guide.

Change Password
The procedure to change your existing password is:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the login icon in the top-right corner of the home page.
Step 2 Click Change Password to change the existing password.
Step 3 In the Change Password dialog box, enter the Old Password, New Password, Repeat New Password.
Step 4 Click Update.

Reset Your Password
The following procedure shows how to reset the password.

Step 1 In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.
Step 2 Click Forgot Password ? in the Cisco ONP login page. The Forgot Password page appears.
Step 3 Enter the registered email ID in the Forgot Password page.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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Step 4 Click Continue.

A verification code is generated and sent to the registered email ID.

Step 5 Enter the verification code, new password and confirm password.
Step 6 Click Continue.

Sign Out from Cisco ONP
The procedure to sign out of Cisco ONP is:

Step 1 Click the login icon in the top-right corner of the home page.
Step 2 Click Sign Out to log out of the Cisco ONP tool.

Cisco Secure Development Lifecycle Compliance
Table 4: Feature History

Feature DescriptionRelease InformationFeature Name

The following CSDL compliance
enhancements are supported:

• Displays the last login IP
address of the client.

• Allows you to set a passphrase
for encryption of credentials
during the installation of LNI
application and database.

Cisco ONP Release 4.1CSDL Compliance Enhancements

The following Cisco Secure Development Lifecycle (CSDL) compliancies are implemented:

• Check for the existence of new passphrases against a dictionary.

• Display of the last login date and time of the user in the user interface of the Cisco ONP tool.

• Display of the last login IP: The IP address of the client through which the user logged into the server,
previously.

• Warning the users through pop-up messages about the impending passphrase expiration.

• Option to allow an admin user or any user with CONFIGURATION_MANAGEMENT permission to
set the lifetime of a passphrase and the grace period to change the passphrase through the system
configuration tab.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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• Prompt for user to change the passphrase through the passphrase change dialog box, when the admin
user logs in for the first time.

• Option to allow the user to set a passphrase with a minimum of eight characters and a maximum of 127
characters as the length.

• The passphrase must include at least one lowercase alphabet, one uppercase alphabet, one number, and
one special character.

• Option to allow the user to set a passphrase or key for encryption of credentials during the installation
of Live Network Import (LNI) application. If not specified Cisco ONP uses the default key.

• Option to allow the user to set a passphrase with a minimum of eight characters and a maximum of 64
characters as the length, during the installation of Cisco ONP and LNI database.

• LNI application provides the details of all the ports used. See Ports Used in LNI, on page 36.

• Option to allow the user to generate a password using Generate Password option.

• Display of the strength of the password set by the user.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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C H A P T E R 2
Manage Users and Roles

• User Roles in Cisco ONP, on page 11
• Grant Access to a New User, on page 12
• Remove Access to a User, on page 13
• Delete a User, on page 13
• Create a New User Group, on page 13
• Assign a User to a User Group, on page 14
• Set Password Expiration for Individual User, on page 15
• Set Password Expiration for All Users, on page 15
• Lock and Unlock an Individual User Account, on page 16
• Expire the Password Set by an Individual User, on page 16
• Create a New Role, on page 16
• Assign a Role to a User Group, on page 17
• Manage Password Through Dictionary, on page 17
• Retrieve System Logs , on page 18
• Retrieve Component Logs , on page 19

User Roles in Cisco ONP
Initially, the administrator performs access control management tasks, like activating users after user sign-up,
creating user groups, roles, and assigning roles and users to user groups. The admin or user with admin access
grants access to the newly created user by activating the user. After the admin grants access, the new user will
be notified by email (sent to the email address registered while signing up). It is only then that the new user
is able to log in. By default, the following user roles are available in Cisco ONP.

1. Admin: The Admin user can create new user groups and assign user to user groups. Users are categorized
into groups. There are certain predefined user groups in Cisco ONP. You cannot edit or delete these user
groups. Admin can assign a group with a particular role. The role describes the actions that a particular
user group can perform.

2. Designer: The Designer user can design a network. There are two ways to design a network.

• Manual Design

• Import Design

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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The designer user can create a network topology of any type (linear, ring, mesh) with Traffic, OLA,
ROADM, and Passthrough sites, and assign the fibers with suitable spans between those sites. The designer
can only design the network and cannot analyze the network. The designer can view the reports, when
any user shares the analyzed network.

3. Planner: The Planner user can design and analyze a network. After the Sites, Fiber spans, and Service
demands are created, analyze the network to determine the network performance. Cisco ONP automatically
optimizes the design and summarizes the optical transmission performance. In the analyzed state, all
reports are available and updated. In the analyzed state, no aspect of the network design can be changed.

4. Reader: The Reader user can view users, user groups, roles, and permission. The Reader can also view
the network topology, layout, connections, and BOM. By default, a user is assigned in the
READ_ONLY_GROUP with a READER_ROLE.

You can also create new roles. See Create a New Role, on page 16.

Under Control Panel > Roles and Control Panel > Permissions, you can view the permissions applicable
for each role and the actions that can be performed for each permission.

Grant Access to a New User
All users with Admin role receive an email notification about new user registration.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 You can change the state of a user from INACTIVE to ACTIVE by using either of two ways:

a. From the State field, click INACTIVE in the respective user row.

b. Select a user row or multiple user rows and click Update.

• In the Update User dialog box, select the Group and State from the respective drop-down lists.

• Click Save.

Step 3 Click OK in the Success dialog box.

• After the Admin grants access, the new user gets notified by email (sent to the email address registered while
signing up). It is only then that the new user will be able to log in.

• The admin assigns a newly created user with a Role and Group that determines what actions the user can
perform.

Note

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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Remove Access to a User
Use this task to remove Cisco ONP access to a user.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control panel.

The Access Control Management page appears.

Step 2 You can change the state of a user from ACTIVE to INACTIVE by using either of two ways:

a. From the State field, click ACTIVE in the respective user row.

b. Select a user row or multiple user rows and click Update.

• In the Update User dialog box, select the Group and State from the respective drop-down lists.

• Click Save.

Step 3 Click OK in the Success dialog box.

Delete a User
Use this task to delete a user or multiple users.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control panel.

The Access Control Management page appears.

Step 2 Select the user or multiple users to be deleted under the USERS tab and click Delete.
Step 3 Click Yes in the Warning dialog box.

The message User deleted successfully appears.

Create a New User Group
Use this task to create a new user group.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USER GROUPS tab.
Step 3 Click Create.
Step 4 In the Create Group dialog box, enter the Group Name.
Step 5 Choose the appropriate role from the Role drop-down list. The available default roles are:

• ADMIN

• PLANNER

• DESIGNER

• READER

The Role drop-down list may also have user-defined roles that are listed under it.

Step 6 Click Save to save the created user group.
Step 7 Click OK in the Success dialog box.

Assign a User to a User Group
Use this task to assign a user to a user group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control panel.

The Access Control Management page appears.

Step 2 Under the USERS tab, select the user or users who are to be assigned to the new group.
Step 3 Click Update.
Step 4 In the Update User dialog box, perform the following:

• Select the appropriate group from the Group drop-down list.

• Select Active or Inactive from the State drop-down list, to activate or inactivate the user in the group, respectively.

• Click Save.

Step 5 Click OK in the Success dialog box.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
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a. A user can belong to only one group.

b. Only one role can be assigned to any group.

c. All the users of a group have the same role as that of the group.

d. By default, a new user is assigned to the Read_Only_Group.

Note

Set Password Expiration for Individual User
Use this task to set the expiration of the password set by the user.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 with Admin or Configuration_Management permission.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Select the user under the USERS tab.
Step 3 Click Update.
Step 4 In the Update User dialog box, click the PASSWORD EXPIRY tab.
Step 5 Enter values for the Lifetime, Warning and Grace fields.
Step 6 Click Save.

The password expiry settings like lifetime, warning and grace time, take effect after the existing password is
changed by the user.

Note

Step 7 Click OK in the Success dialog box.

Set Password Expiration for All Users
Use this task to set the expiration of the password for all users.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 with Admin or Configuration_Management permission.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the System Configuration tab.
Step 3 Enter values for the Lifetime, Warning and Grace fields.
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Step 4 Click Update.

The password expiry settings like lifetime, warning and grace time, take effect after the existing password is
changed by the user.

Note

Lock and Unlock an Individual User Account
Use this task to lock or unlock an individual user account.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USERS tab.
Step 3 Select the user whose account you want to lock or unlock.
Step 4 Click Lock to lock the user account, or click Unlock to unlock the locked user account.

The user of a locked account must contact the admin to unlock the user account.Note

Expire the Password Set by an Individual User
Use the following task to expire the password set by an individual user.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USERS tab.
Step 3 Select the user whose password you want to expire.
Step 4 Click Expire.

Create a New Role
Use the following task to create a new role.
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Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the ROLES tab.
Step 3 Click Create.
Step 4 In the Create Role dialog box, enter the Role Name and select the Permissions for the role.

You can select more than one permission.Note

Step 5 Click Save.
Step 6 Click OK in the Success dialog box.

Assign a Role to a User Group
Use the following task to assign a new role to a user group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USER GROUPS tab.
Step 3 Select the user group whose role is to be updated.
Step 4 Click Update.
Step 5 In the Update Group dialog box, select the desired role from the Role drop-down list, and click Save.

Step 6 Click OK in the Success dialog box.

Manage Password Through Dictionary
If a password exists in the predefined list of passwords under the Content column, the dictionary rejects the
new password set by the user. You must have Admin or Configuration_Management permission to view and
modify the dictionary.

By default, theRejection Mode toggle button is disabled. Enable theRejection Mode toggle button to verify
the password against dictionary. This password verification check against the dictionary happens during any
one of the following events:

• New user sign-up
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• Password change

• Password reset using forgot password option

The following is the procedure to verify, whether the new password set by the user exists in the list of predefined
passwords:

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the DICTIONARY tab.
Step 3 Enter the password in the Enter Passphrase text box.
Step 4 (Optional) Enter the limit (maximum number of matching passphrases) in the Enter Limit text box.
Step 5 Click Search.

The matching passphrases get displayed.

If you have entered the limit, a number of search results matching the limit gets displayed. Otherwise, all matching
passphrases get displayed.

Note

Retrieve System Logs
The System Logs page shows at logs the events that are initiated during a specific time interval. See Logs ,
on page 254.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as an admin or a user with User Management and Network
Management permission.

Step 1 Click Logs.
Step 2 Click Select Start Date, and choose the start date. Similarly, click Select End Date, and choose the end date.
Step 3 Click FILTER to retrieve the logs.

The following icons are available in the System Logs page:

DescriptionIcons

Exports the system logs to an Excel sheetExport as CSV

Exports the system logs as a zip fileExport Archive

Imports the zip fileImport Archive

Refreshes the system logs pageRefresh
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DescriptionIcons

Deletes the existing logsClear Logs

Retrieve Component Logs
The Component Logs page shows at critical logs for each event. See Logs , on page 254.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as an admin or a user with User Management and Network
Management permission.

Step 1 Go to Logs>Component Logs.
Step 2 From the Component drop-down list, choose a component.

The logs for the chosen component appear. The available components are:

• BE

• GENE

• ODE

• PCE

Step 3 In the Search field, enter the event to locate the event logs.

The action icons available in the Component Logs page are:

DescriptionIcons

Exports that the component logs as a text fileExport

Pops up the file path of the chosen component when hoveredInformation
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C H A P T E R 3
Design and Analyze Networks

• Design a Network Using Cisco ONP, on page 22
• Create Optical Subnet for Non-SSON Networks, on page 41
• Create Optical Subnet for SSON Networks, on page 42
• Create Optical Subnet for NCS 1010 Networks, on page 43
• Convert Non-SSON Network to SSON Network, on page 44
• Convert NCS 2000 Network to NCS 1010 Network, on page 45
• Share a Network, on page 46
• Analyze the Network, on page 48
• Upgrade the Analyzed Network, on page 50
• Upgrade LNI Network, on page 51
• Upgrade the Software Release of a Network , on page 55
• Plan Mode, on page 57
• Automatic Suggestion for Regeneration Sites in Plan Mode, on page 62
• Line Rate Tuner Mode, on page 64
• Import Optical Sources, on page 69
• Find Optical Sources Faster, on page 72
• Download Optical Sources, on page 73
• Delete Optical Sources, on page 74
• Layout Template for NCS 2000 Network, on page 74
• Layout Visualization, on page 78
• Spectrum Utilization and Path Finder, on page 86
• Regenerate BoM Automatically, on page 90
• Add new Pluggables, Alarm Cables and 100G Client Bandwidth Licenses to BoM, on page 90
• Export IPC Report, on page 91
• Edit the Layout Manually for NCS 1010 Networks, on page 92
• View Internal Node Connections of NCS 1010 Network, on page 94
• Design Networks with SVO Card, on page 95
• Associate OLA or DGE Sites with SVO Cards, on page 96
• Export Device NETCONF XML File, on page 96
• Upload NETCONF XML Files on SVO Web Interface, on page 99
• Export Device NETCONF XML Files for Individual Sites, on page 99
• Upload NETCONF Files to NCS 1010 Device, on page 100
• Export Cisco Optical Site Manager NETCONF XML File, on page 100
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• Upload CiscoOptical SiteManager NETCONFXML toNCS 1010Device via CiscoOptical SiteManager
Web Interface, on page 101

• Export NCS 1010 Network Planning Data for Cisco Optical Network Controller, on page 102
• Upload Planning Data into Cisco ONC, on page 102

Design a Network Using Cisco ONP
You can design a network in one of the following ways:

• Manual Design―Create a network design using a design palette.

• Import Design―Import a network design from an Excel sheet, Live Network Import or from an existing
network from CTP, or another instance of Cisco ONP.

Manually Design a Network Using Cisco ONP
Table 5: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP now provides an option
to run some operations in the
background involving database
interaction, such as Save As,
Import CPZ, and Export CPZ.
You can continue to use the Cisco
ONP interface for other operations
when these operations are running
in the background.

Cisco ONP Release 5.2Database Operations Optimization

Table 6: Feature History

Feature DescriptionRelease InformationFeature Name

Now you can include the 4K-2K
nodes in both SSON and
non-SSON networks while
designing the network. This helps
you to validate 4K-2K nodes in the
SSON design which has higher line
rates.

Cisco ONP Release 5.24K-2K SSON Network Creation
Support
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Table 7: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP now supports the
C+L-band networks that help you
plan NCS 1010 networks using the
OLT-L and ILA-L line cards to
increase your network’s bandwidth
capacity. Enhanced with L-band
related properties, the UI enables
you to design a C+L-band network
for your ever-increasing channel
demands. The following L-band
types are introduced to suit your
design needs:

• C+L—This band type adds
more channels to your
network, increasing its traffic
carrying capacity.

• C+L Futuristic—This band
type creates a network with
C-band edges and future
provisions for L-band edges
that you can cost-effectively
upgrade after exhausting the
C-band capacity.

Cisco ONP Release 5.1NCS 1010 C+L Network Design

Table 8: Feature History

Feature DescriptionRelease InformationFeature Name

You can design and validate
NCS1010 optical line system. This
feature helps to create OLT-C,
OLT-R-C, ILA-C, ILA-R-C, and
ILA-2R-C based NCS 1010
networks using fixed grid add/drop
MD-32-ODD, MD-32-EVEN and
flex grid add/drop BRK-24,
BRK-16, and BRK-8 passive
modules.

Cisco ONP Release 5.0Greenfield NCS 1010 Network
Design
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Table 9: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to perform
the following:

• Supports NCS 4K-1K-2K
multi-platforms

• Visualizes new layout for Txp
and SVO for NCS 2000 node

• Supports different OTN
service types with protection

• Edits layout for NCS 4000 and
NCS 1004 nodes

Cisco ONP Release 4.1Multi-Layer Platform (MLP)
Greenfield Design with NCS
4k-1k-2k

You can create any of the following network designs:

• Spectrum Switched Optical Network (SSON) that uses flexible spectrum allocation, where the required
minimum spectral resources are allocated adaptively based on traffic demand and network conditions

• Non-SSON network that allocates single spectrum (fixed spectrum) irrespective of the traffic demand
and network conditions

• NCS 1010 network

Perform the following steps to create a network in the Cisco ONP:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > New.

The Create New Network dialog box appears.

Step 2 From the L0 Network Platform drop-down list, choose one of the following:

• NCS 2000—To create a non-SSON network that contains NCS 2000 and NCS 4000 nodes, or an SSON network
including NCS 2000, NCS 1004, and NCS 4000 nodes

• NCS1010—To create a network that contains only NCS 1010 nodes

• NCS1001—To create a network that contains only NCS 1001 nodes

Step 3 If you want to create an SSON network, check the SSON Network check box, else leave the SSON Network check
box unchecked.

This option is not for the NCS 1010 network.

Step 4 Choose NCS (4K_1K_2K) or NCS (4K_2K) from the Traffic Type drop-down list.

If you had chosen to create an SSON Network in the previous step, you can view the Traffic Type drop-down list.
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Once the network is created you cannot change the Traffic type from 4K_1K_2K to 4K_2K or vice versa.
Hence, we recommend you export the network into an Excel sheet, do the required modification and then import
it as a new network.

Note

Step 5 Choose the System Release for NCS 2K or NCS 1010 from the drop-down list.

You cannot change the system releases that are available for NCS 4K and NCS 1K.

The Band Type drop-down list appears for NCS 1010 R7.9.1 network.

Step 6 From the Band Type drop-down list for NCS 1010, choose one of the following:

• C-Band—Only C-band edges are created and ANS is generated based on C-band. For L-band upgrade, ANS
unlock is required.

• C+L Futuristic—Only C-band edges are created and ANS is generated based on C-band and L-band. For L-band
upgrade, ANS unlock is not required.

• C+L—Both C-band and L-band edges are created and ANS is generated based on C-band and L-band.

After the creation of a NCS 1010 R7.9.1 network, if required, you can change the network band type under the
Network Application Configuration section in the Network Properties.

Note

Step 7 Click Create.

You can view a map and the design palette. For more information, see Design Palette, on page 260.

Step 8 Click the Drawing Tool icon (pencil and ruler crossed).
Step 9 Add sites to the map using the drawing tool.

a) Zoom into the map to the desired level. Click any of the site icons (ROADM, OLA or Traffic(4K-1K-2K)), and
drag it to the sites on the map. Drag or click the map where a site has to be placed, when the cursor changes to the
site icon.

SRLG is not supported in the SSON networks

Traffic node is not supported on the NCS 1010 network.

b) Click the Fiber icon and drag it to connect from one site to another site. Continue this for all sites.

By default, the fiber length is updated as 1 km for all the fibers. If you want the length to be auto updated
based on the x, y coordinates, then enable the Use Coordinates Distance property under the network
properties.

Note

Step 10 Create services between the sites (only for SSON and non-SSON networks).

Cisco ONP provides only OTN service.

a) Click the Drawing Tool icon and select OTN Service (Green in color).
b) Add the service between the existing Traffic sites on the map.

Step 11 Create circuits (for NCS 1010), media channels (for SSON), or waves (for non-SSON) between the sites.
a) Click the Drawing Tool icon, and select Circuit (purple in color), Media channel (purple in color), or Waves

(red in color).
b) Add the circuit, media channel, or waves between the existing sites on the map.
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In the left pane, you can view a network tree panel with a default network name. The network elements added are
displayed in the tree panel.

Step 12 Choose File > Save As.
Step 13 Enter a network name in the Give a Network Name dialog box.
Step 14 Click the Run in Background check box, if you want this operation to run in background.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of the
operation running in the background.

Step 15 Click Save.

Create Shared Risk Link Group
You can use the Shared Risk Link Group (SRLG) feature for routing protected services. You can create SRLGs
through the Excel import file SRLG tab or through the Cisco ONP GUI using the following procedure:

SRLG is supported only for the non-SSON network including the traffic nodes.Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the network tree panel in the left.
Step 2 Expand Fibers.
Step 3 Check the check box next to each fiber in the same SRLG.
Step 4 After all fibers are checked, right-click, and select Create SRLG.

SRLG is created with a unique name. You can rename the SRLG.

Import Network Using Excel Sheet
Use this task to import a network into Cisco ONP, using an Excel sheet.

Table 10: Feature History

Feature DescriptionRelease InformationFeature Name

The integration between CX Unified Planning Tool (UPT)
and Cisco ONP enables you to import the networks created
and analyzed in Cisco CX UPT into Cisco ONP. This helps
you avoid recreating the networks that are already created in
UPT. This feature allows you to import networks having NCS
1010 and NCS 2000 nodes into Cisco ONP.

Cisco ONP Release
5.0

CX Unified Planning
Tool Network Import
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Table 11: Feature History

Feature DescriptionRelease
Information

Feature Name

It is now possible to export the topology data of an existing network
into an Excel file. You can easily modify the exported data in Excel
and import it back into Cisco ONP to create a new network or modify
an existing network.

The following are the supported Excel formats:

• xlsx—Standard Excel with multiple sheets, each corresponding
to a network element such as Network, Sites, Circuits, Spans,
OTNdemands, and so on.

• xlsm—Macros-enabled Excel file that can filter out and display
only the applicable network element sheets based on the platform
selected in the Network sheet.

Cisco ONP has the built-in intelligence to automatically calculate the
shortest path between a source and a destination, even if only a partial
fiber path is mentioned in the imported Excel file.

Cisco ONP
Release 5.1

Export and Import
of Network
Topology in Excel
Format

By default, the system release of the Excel imported network is 11.0.Note

From Release 5.0, Cisco ONP supports import of networks created using CX UPT via Cisco ONP Import
Excel option. CX UPT does not populate the DWDMChannel Type and Add/Drop Type values in the Excel
sheet. If the values are not found in the Excel sheet, then Cisco ONP picks the default options. By default,
DWDMChannel Type is NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GBd and Add/Drop Type
isColored. We recommend you to check theDWDMChannel Type and Add/Drop Type values before importing
the Excel sheet into Cisco ONP to avoid any discrepancies.

Note

From Release 5.1, in addition to exporting the template, you can also export the entire network design data
of an existing network in the form of the Excel sheet, modify the network properties available in the Excel
sheet and reimport. The network can be exported in all modes and reimported on Design mode, Upgrade
mode, and Release Upgrade mode.

Transponders are not supported as part of Export/Import Excel. When you export an existing network with
transponder card forced, the exported Excel sheet will have the Traffic type set to Pluggable Card in
DWDMChannels/MediaChannels tab. Make necessary changes in the exported Excel sheet before you import
it into Cisco ONP.

Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6.
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Step 1 Choose Export > Excel.
a) Choose the Network Type as Template or Current Network.
b) Choose the File Type as xlsx or xlsm (Macro Enabled)

The Macros Enabled Excel sheet automatically customizes the tabs on the Excel sheet based on the platform that you
choose. It also provides additional functionalities such as selection of fibers in the path selection, wavelength count
validation in case of regen selection.

c) Click Download.

The template has the following mandatory tabs, and the respective fields to be filled in the Excel sheet.

DescriptionTabs

Label (name of the network), Platform (NCS2000(NON
SSON), NCS2000 (SSON), NCS1010, NCS 1001), Traffic
Type, NCS1010 Line Card, NCS1010 Band Type, Chassis
Type, and System Release

Network

Site Label, Type, X coordinates, Y
coordinates,X_Rearranged, Y_Rearranged, Pre Equip
Degree, Grooming Site, CLLI code, and Site Address,
Degree (Scalable upto degree), NCS1010 Line Card,
NCS1010 Band Type, Chassis Type, and State.

Sites

Span label, A (Source site name), Z (Destination site name),
Kms (Distance), Loss, Type, A_Edge, Z_Edge, AZ_Loss,
ZA_Loss, AZ_Kms, ZA_Kms, NCS1010 Band Type, and
State.

Spans

Demand Label, A (Source), Z (Destination), Y (Tertiary
Source), B (Tertiary Destination), Type, Quantity,
Protection, Primary Path, Secondary Path, and State.

Note: Y and B can be used with Unprotected Disjoint
Service.

OTNDemands-4K-2K

Demand Name, Source, Destination, Service Group, Type,
A/D Type, Protection, Primary Wavelength, Secondary
Wavelength, Primary Path, Secondary Path, First
Restoration path, Second Restoration Path, Primary ODU
Timeslot, Secondary ODU Timeslot, Primary Regen,
Secondary Regen, Trunk Mode, Baud Rate, and State.

OTNDemands-4K-1K-2K

Channel Label, Source, Destination, Primary Wavelength,
Secondary Wavelength, Protection, Traffic Type, Card
Type, A/D Type, Primary Path, Secondary Path, Primary
Regen, Secondary Regen, and State.

MediaChannels

ServiceGroup Name, Demand Types, 4K Exclusive LC
Usage, 4K Symmetric Aggregation, 1K Exclusive LC
Usage, 1KSymmetricAggregationChannel Label, and State.

ServiceGroup
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DescriptionTabs

Primary Wavelength and Secondary Wavelength (Work
and Protect Wavelength for NCS2000 non-SSON waves),
Primary Path and Secondary Path (Work and Protect Path
for NCS2000Wave/Media Channel and NCS1010 circuit),
A/D Type (Colored/Colorless/Contentionless), Traffic Type,
Primary Regen Secondary Regen State, Channel label, A,
Z, Wavelength, Protection, and Type.

DWDMChannels

Service Name, Source, Destination, Type, Protection,
Primary Wavelength, Primary Path, Primary Regen, Card
Type, Trunk Mode, A/D Type, and State.

Services-1010

Circuit Label, Source, Destination, Primary Wavelength,
Protection, Traffic Type, Card Type, A/D Type, Primary
Path, Primary Regen, Band Type, and State.

Circuits

Flex Optical Source Name.Flex Optical Source

SRLG Label, Spans, and State.SRLG

Step 2 Fill the network details in the template file or edit the current network file, and save the file.
Step 3 Choose Import > Excel, and select the Import Type.

• New—Choose this option if you want to create a new network using the design data available in the Excel sheet.

• Existing—Choose this option if you want to update an existing network with the data available in the Excel sheet.
Open the network before you import the Excel sheet. The network must be on Design mode, Upgrade mode, or
Release Upgrade mode.

You can view the data available in the Excel sheet before importing the network data. The View Data check box remains
checked by default. Uncheck it of you do not want to view the imported data.

Step 4 Browse, select the saved file, and click Import.

During the import for the Existing network, if the state is Locked, Cisco ONP does not consider the data, if the state is
Unlocked, Cisco ONP changes the existing parameter, provided the network is in upgrade mode, and if the state is New,
the parameters in the Excel is added as a new entry into the network.

During new network import, new network design is created irrespective of the State.

If there are errors in the imported data, a pop-up error message is shown in case of new import, and the errors are
available under the Elements > Messages tabs in case of updating the existing network.

Note

Cisco Transport Planner Network Import Support
You can import the networks that are created and analyzed from Cisco Transport Planner (CTP) to Cisco
ONP, to avoid recreating the networks that are already created in CTP. The CTP network files are in .mpz
format. You can, release upgrade, the imported networks.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
29

Design and Analyze Networks
Cisco Transport Planner Network Import Support



• Network must be in design-analyzed or upgrade-analyzed mode.

• You cannot import networks which are earlier than Release11.0.

Note

Supported Hardware

• Optical source files and transponders

See Supported Optical Sources, on page 285, and Supported Cards and Pluggables, on page 271.

• Contentionless, colorless, and colored point-to-point demands

• Flex network

• Gain Equalizer

The Gain Equalizer node changes as a ROADM node when you unlock the site
after the release upgrade.

Note

• ROADM-SMR-9 and SMR-20

• All flex supported amplifiers, controller cards, and chassis types

Import MPZ Design File
Use this task to import .mpz file from CTP to Cisco ONP.

Importing of mpz networks with P-Ring and A2A demands is not supported. Hence, we recommend you to
delete these demands in CTP, reanalyze the networks in CTP and import the mpz into Cisco ONP.

Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with network creation permission.

Import the required optical source files and layout template using Manage > Optical Source and Manage >
Optical Source options. For more information, refer Manage Alien and Import Layout Template for NCS
2000 Network in to Cisco ONP Database.

Delete the parameters that are not supported by Cisco ONP from the .mpz file and then import the .mpz file
to Cisco ONP.

Step 1 Choose Import > MPZ.

The Import File (.mpz) dialog box appears.

Step 2 Browse to the .mpz file stored in your local system.
Step 3 Choose 4K_1K_2K or 4K_2K from the Traffic Type drop-down list.
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If you had chosen an SSON MPZ file, you can view the Traffic Type drop-down list.

Step 4 Click Import.

The .mpz file gets imported to Cisco ONP.

If you view a blank screen when you click waves in the network tree, refresh the browser.Note

Step 5 Choose Network > Upgrade or Network > Release Upgrade to make any changes on the imported network.

• You cannot go back to design mode on the imported mpz network.

• The wave label of imported mpz network in Cisco ONP is the service name present in the CTP properties
window.

Note

Export the CPZ File
Cisco ONP stores the network design file as .cpz file in its database. You can export the design file into your
local system.

• The .cpz file of a network in the design mode includes design file, layout template, and optical source
details.

• The .cpz file of a network in the analyze mode includes a design file, analyze file, ANS file, per side
ANS file, BOM, error messages, trace files, layout template, mpz, and report.

• For the network in upgraded mode, you can export only the last child in the parent child hierarchy.

• You can export only one network at a time.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network that you want to export, from the list of networks.

The network opens.

If you view a blank screen when you open a network, refresh the browser, or log in to Cisco ONP again.Note

Step 3 Choose Export > CPZ.

The Export .cpz file dialog box appears.

Step 4 Rename the file if required.
Step 5 Click the Run in Background check box, if you want this operation to run in background.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of the
operation running in the background.
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Step 6 Click Export.
Step 7 Save the file in your local system.

Import CPZ File
You can import the cpz network design files that are exported from another Cisco ONP instance.

You can import only the networks that are exported from the current release.Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Import > CPZ.

The Import .cpz file dialog box appears.

Step 2 Click Choose file, and select a cpz network design file that you want to import into Cisco ONP, from your local system.
Step 3 Click the Run in Background check box, if you want this operation to run in background.

A notification pops-up after the background operation is completed. Go to Job Monitor to view the progression of the
operation running in the background.

Step 4 Click Import.

If the names of the optical source and layout template files available in the Cisco ONP database and the imported network
file are the same, you are prompted to confirm whether you want to overwrite the existing file.

The error message "Network already exists in the system with another user. New network will be created"
is just an information. You do not need to perform any action. Cisco ONP automatically imports as a new network
specific to the user. There is no impact on the already existing network.

Note

Step 5 Check the Overwrite Network check box, if you want to overwrite the existing file.

If you leave the check box unchecked, Cisco ONP saves the imported network as a new network.

Step 6 Choose the optical source files and layout template that you want to replace.

If you do not choose the optical source or the layout template file, the files will not be imported.

Step 7 Click Confirm.

The imported network is saved in the Cisco ONP database.
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Live Network Import
Table 12: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to import
a live deployed network having
NCS 1004, NCS 2000, and NCS
4000 nodes into Cisco ONP, using
the LNI (Live Network Import)
import template. This feature also
allows you to view network
topology, BOM, and layout report.

Cisco ONP Release 4.1Live Network Import

The Live Network Import (LNI) feature allows you to perform a live import of network having NCS 1004,
NCS 2000, and NCS 4000 nodes into Cisco ONP. You must have Network Management role to perform the
LNI operation. After importing you can visualize the complete deployed network details in Cisco ONP. Map
shows the network topology, and you can view the node, fiber, OTN service, and media channel properties
in the Network Tree, and the Entity Editor.

Perform Live Network Import
Use this task to perform live import of a network:

Before you begin

• Perform LNI only when the network is in a stable or running state. Do not perform LNI during the
maintenance period for software upgrade.

• Configure all the mandatory parameters on the circuit.

• Make sure that the following Cisco IOS XR Software Maintenance Updates (SMUs) are loaded on the
NCS 4000 devices on top of Cisco IOS XR Release 6.5.28:

• ncs4k-6.5.28.CSCvu93045.tar

• ncs4k-sysadmin-6.5.28.CSCvt67465.tar

• ncs4k-6.5.28.CSCvv79518.tar

• Make sure that there is a provision for opening three TL1 sessions per NCS 2000 device for Live data
collection. NCS 2000 devices should not be overloaded with too many TL1 sessions.

• Make sure that the fibers are configured with the same channel numbers (Spectral Density, ex: 91.0/82.0)
on both source and destination ends.

• Check the card label set for the following NCS 2000 cards and update it if they are not aligned.

Card LabelPID

AD-16-FSNCS2K-16-AD-CCOFS

SMR20-FS-CVNCS2K-20-SMRFS
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Card LabelPID

SMR20-FSNCS2K-20-SMRFS-L

SMR9-17-FSNCS2K-9-SMR17FS

SMR9-24-FSNCS2K-9-SMR24FS

SMR9-34-FSNCS2K-9-SMR34FS

SMR9-34-FSNCS2K-9-SMR34FS-L

OPT-RAMP-COP15454-M-RAMAN-COP=

OPT-RAMP-CTP15454-M-RAMAN-CTP=

OPT-EDFA-35NCS2K-OPT-EDFA-35

• You must install Microsoft Excel in the Client Machine from where the browser is launched to open
Cisco ONP application.

• Log in to Cisco ONP Web Interface, on page 6

.

Step 1 Choose Export > Download LNI Import Template, and download the template which is in the form of an Excel
sheet.

Step 2 Fill the template with the details of all the nodes belonging to the network to be imported and save the file.

The following fields are mandatory:

• Node IP

• User Name

• Password

• Connectivity Type―TL1 for NCS 2000 nodes and NETCONF for NCS 1004 and NCS 4000 nodes

• Connectivity port―830 for NCS 4000 and NCS 2000 nodes

Enter a value in the range of 60–180 in the Connectivity Timeout field or leave the field empty.Note

Step 3 Choose Import > Live Import.
Step 4 Browse and choose the saved file.
Step 5 If you want to clean the existing LNI database of the nodes and perform a fresh import, check the Fresh Import

(Cleanup LNI Database) check box.

We recommend fresh import of the live network.Note

Leave this check box unchecked, if you want to import the details of only few of the nodes which had issues during
the previous import.

LNI import is not user-specific. When you perform a fresh import, Cisco ONP overwrites all the LNI data that
are imported by the other users.

Note
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Step 6 Click Import.
Step 7 In the Device Onboarding dialog box, click OK.

If you try to import a network of unsupported version, the device collection does not happen, and an error
message "device collection failed" appears. See Supported Hardware and Software for LNI, on page 38.

Note

Step 8 Click Job Monitor, and click Check Progress for the IMPORT_LIVE_NETWORK task, to view the status of the
LNI operation in the LNI Progress dialog box. Click Refresh to see the updated status.

After LNI is completed, the job is removed from the Job Monitor page.

Step 9 Click Logs to view the list of events that are related to the LNI operation, as logs.
Step 10 After the completion of the LNI operation, choose File > Open.

The format of the LNI imported network filename is LNI_<Date>_<Time>.

Step 11 Click the imported network name to view the network under the Map tab and its corresponding network tree in the left
panel.

The aggregated node including NCS 1004, NCS 2000, and NCS 4000 is indicated in purple color, and the aggregated
node including NCS1004 and NCS 2000 is indicated in orange color in the network tree. You can view the tag Imported
from Network in the top-right corner.
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• Even If some errors occur during the LNI operation, the LNI operation is not canceled. In such case, when
you open the imported network, a warning message is displayed.

• You can view the errors under the Elements > Messages tab.

• Device collection failure is listed under critical messages.

• The reason for failure is listed under noncritical messages.

• If both NCS and Non-NCS PIDS are present in the inventory, Cisco ONP enables the Enable NCS option.
You can edit this option during upgrade after unlocking the site, if necessary.

• Service path for the restored circuits is displayed as follows in the Cisco ONP UI:

• Primary Path: Working path before restoration

• Secondary path: Protected path

• Restoration path: Current work path after restoration

If the circuit is not in the restored state, the restoration path is not shown.Note

• SSON circuits carrying protected OTN services are merged as Client 1+1 protected Media Channel. Due
to this, you may see difference in total number of SSON circuits between the imported network in Cisco
ONP and the actual network.

• If LNI is not installed properly, you may encounter the errors such as LNI failure or LNI not able to purge
the data. In such cases, we recommend starting and stopping the LNI services in the server where Cisco
ONP and LNI are installed using the following commands:

• Stop the LNI services.
root:~/$ONP_HOME# cd LNI

root:~/$ONP_HOME/LNI# bash ciscolniinstaller.sh -o stop -t update -m offlinemode

• Start the LNI services.
root:~/$ONP_HOME/LNI# bash ciscolniinstaller.sh -o start -t update -m offlinemode

Note

Wait for a minimum of five minutes after starting the services, for the LNI services to resume before triggering
a new live network import. You can

Note

Step 12 Click the BOM tab to view the BOM details of the network.

The PIDs of prototype cards are shown as "NA" in the BOM details of the LNI network.Note

You can export the CPZ, import the CPZ, and share the imported network. You can check the properties of the network
using the Entity Editor.

Ports Used in LNI
LNI application uses the following ports. If any port is shut down due to any failure, then the service is restarted
by the Docker system.
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UsageServicePort

Registration and discovery service, which holds the information about
all microservice applications

Eureka Service8761

Receives all the incoming requests, and then delegates the requests to
internal microservices like LNI Broker

API Gateway8080

Collects metrics and operation data from the devicesCollector Service8080

Responsible for device onboarding processDevice Manager8080

Provides inventory dataInventory Service8080

South bound interface plug-ins for TL1 protocol-basedNCS 2000 devicesTL1 plug-in
Service

9888

Adapter module to transform NCS 2000 device response from collector
to Cisco ONP NCMS schema-based POJO

NCS 2K Inventory
Adapter Service

8888

Adapter module to transform NCS 4000 device response from collector
to Cisco ONP NCMS schema-based POJO

NCS 4K Inventory
Adapter Service

8888

Adapter module to transform NCS 1004 device response from collector
to Cisco ONP NCMS schema-based POJO

NCS 1K Inventory
Adapter Service

8888

South bound interface plug-ins for NETCONF based 1K/4K devicesNETCONF plug-in
Service

9976

Provides interfaces for Cisco ONP BE service to trigger live network
import

LNI Broker Service8888

Provides network topology dataTopology Service8085

Provides network circuit dataCircuit Service8090

Common adapter for Topology and Circuit servicesNETCONF
Adapter Service

8024

Aggregates inventory, topology, and circuit details under NCMS
schema-based networks

Model Aggregator
Service

8888

Common adapter for Topology and Circuit ServiceTL1 Adapter
Service

8092

Data visualization and exploration tool that is used for log and time-series
analytics, applicationmonitoring, and operational intelligence use cases

The default Edge browser on Windows OS is not supported for
viewing the Kibana logs. Cisco recommends using Firefox or
Chrome browser for viewing the Kibana logs.

Note

Kibana5601

Keeps track of status of the Kafka cluster nodes, and also keeps track
of Kafka topics, partitions publish-subscribe messaging system that
enables inter service communication

Zookeeper2181
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UsageServicePort

Publish-subscribe messaging system that enables inter-service
communication

Kafka9092

Database to persist services dataPostgres5432

Supported Hardware and Software for LNI
The following table describes the software versions and hardware requirements of the network imported
through LNI.

Table 13:

ValuesProperty

Network

SSONNetwork Type

ETSIPlatform

NCS 2000: R11.1, and R11.1.1.2

NCS 1004: XR 7.0.1

NCS 4000: XR 6.5.2.8

System Release

Site/Node

4K-1K-2K: ADD/DROP, 1K-2K;Regen,
2K:ROADM/OLA

Site Type

SMR-20, SMR-9-17FS, SMR-9-34FS, SMR-9-24FSROADM

RAMAN-CTP, RAMAN-COP, EDFA35-24,
EDFA35-35

Amplifier

DEG-5/UPG-4Degree Mesh Type

4K: NCS4016, 2K:NCS2006, 1K:NCS1004Chassis Type

4K-DC, 1K-DC, 2K-DC40Power Supply

ECU-SECU

TNCS-2, TNCS-2OController Card

82Channel Rule

NCS1K4-1.2T-K9=, NCS4K-4H-OPW-QC2Line Cards

ON and OFFEvolved Mesh

2K: Separated shelves, 4K: Single shelfNode Protection
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ValuesProperty

MPO-16LC UnitMpo16Lc

MPO16TO2MPO8CableMpo16ToMpo08

YesCascaded SMR

YesEnable NCS

NoUse Payg

Yes, NoConnection Verification

MF-6RU, MF6-10RU, or MF-1RUMF Unit

Line, Multidegree, TerminalStructure

4, 8, 12Scalable upto degree

YesPower redundancy

IPv4IP Address

Fiber

AutoOSC Frame Type

YesDCN Extension

YesENE/GNE

YesLength

YesLoss

KMMeasurement Unit

NoLength based Loss

YesRaman Amplified

G652-SMF-28EFiber Type

YesConnector Loss A

YesConnector Loss B

YesCross OSC and Parallel OSC

Media Channel

NCS1004_SP_16QAM_16QAM_300G_27%SDFEC_60GBdTraffic Type

Unprotected, and 1+RProtection

Actual PathPath
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ValuesProperty

Regen siteRegen

NoMulticarrier

YesContentionless

Restored, UnrestoredCircuit State

Service

100GE, 10GE, STM-64Service Type

1+1, Unprotected, 1+R, 1+1+R, 1+1+R+RProtection

Actual PathPath

OTU4Client Type (1K)

BHInterface Type (1K)

200G, 300GTrunk Mode (1K)

60 and 69 GBdBaud Rate (1K)

ONS-QSFP28-LR4=,
QSFP-100G-SR4-S=,ONS-QSFP-4X10-MLR=

Client Pluggable

Limitations of LNI
The LNI feature has the following limitations:

• You cannot perform multiple LNI at the same time.

• Scheduled LNI is not supported.

• LNI does not support the following:

• Non-SSON Network import

• Non-Contentionless configuration import

• Circuit import with NCS 2000 Transponder or Muxponder cards

• Chassis position in layout may not be accurate in the live imported network.

Workaround: NCS 2000, NCS 1004, and NCS 4000 chassis are placed in separate racks for a better
view of the layout. You can edit the same after network upgrade and analysis.

• If X, Y coordinates are not configured in the devices, nodes are overlapped in the Cisco ONP map.

Workaround: Configure X, Y coordinates before importing the network for a better view of the topology
in Cisco ONP map; otherwise, you can drag and drop the nodes in the Cisco ONP map and adjust the
node position after importing.
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• Scalable up to degree parameter is not imported from the real device. Cisco ONP chooses the maximum
scalable up to degree based on the number of line sides and contentionless sides present on the node.

Workaround: You can unlock node after upgrading and change the scalable up to degree. After unlocking
the site, use layout template to rearrange the layout.

• Cisco ONP imports the proto-PID, if any, present in inventory, and show as N/A PID in the Cisco ONP
BOM.

• Duplicate media channel label is not supported. If there are multiple media channels with same label
present in the network, only one media channel is imported and the rest of them are discarded.

• Fiber name, source, and destination names may not match between the first and the second import. Source
and destination site names may interchange for bidirectional fibers.

• If the regenerated demand is in restored state, the restored path is shown as working or protected path,
and the service protection is shown as 1+R in Cisco ONP. The restoration details will not be available.

• Service protection type is shown as 1+1+R or 1+1+R+R only if restoration path is available. Otherwise,
service protection type will be shown as 1+1.

• Preprovisioned cards are not listed in the Cisco ONP BOM, and they are populated after successful
upgrade and analysis of the LNI network. Make sure that the cards are equipped to retrieve the PID
details.

• Fibers may not be associated with correct optical subnet if the fibers are not configured with the same
channel number at both source and destination ends. Due to this amplifier output power may not be
within valid range. Hence, you either correct channel number at both source and destination nodes and
re-import the network, or associate the fiber with correct optical subnet after network upgrade in Cisco
ONP.

Create Optical Subnet for Non-SSON Networks
An optical subnet is a collection of spans with certain associated properties. When you create a new network,
Cisco ONP automatically creates an optical subnet that is associated to the network. At least one optical subnet
must exist for each network.

Check theCurrent Subnet check box in the properties window, to make the subnet you created as the current
subnet. You cannot uncheck the Current Subnet check box.

Note

The following procedure creates an optical subnet for Non-SSON networks:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click Subnet in the network tree panel.
Step 2 Click the Ellipsis icon available in the right side of Optical Subnet.
Step 3 Click Create Optical Subnet.
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The Create Optical Subnet dialog box appears.

Step 4 From theCband Rules drop-down list, choose the C-band design rules for the new optical subnet that you want to create.
Step 5 Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

You can select new Cband rules from the Cband Rules drop-down list in the properties window.Note

You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

• Click the Ellipsis icon available in the right side of the required optical subnet and select Edit Fibers.

An Info dialog box appears displaying "Do you want to continue?.

• Click OK.

The UI freezes. You can only select a fiber from the map.

• Select the required fiber and click the Done button appearing near the zoom icon.

The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding fiber
is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only one
subnet rule will be associated with one fiber.

Note

Create Optical Subnet for SSON Networks
The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click Subnet in the network tree panel.
Step 2 Click the Ellipsis icon available in the right side of Optical Subnet.
Step 3 Click Create Optical Subnet.

The Create Optical Subnet dialog box appears.

Step 4 From the Spectral Density drop-down list, choose the spectral density for the new optical subnet that you want to create.
The Name, CBand Rules, and Maximum Number of Channels the you seenin the Create Optical Subnet dialog box,
are set based on the spectral density that you have selected.

Step 5 Click Save.
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A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

You can select a new spectral density from the Spectral Density drop-down list in the properties window.Note

You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

• Click the Ellipsis icon available in the right side of the required optical subnet and select Edit Fibers.

An Info dialog box appears displaying "Do you want to continue?.

• Click OK.

The UI freezes. You can only select a fiber from the map.

• Select the required fiber and click the Done button appearing near the zoom icon.

The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding fiber
is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only one
subnet rule will be associated with one fiber.

Note

Create Optical Subnet for NCS 1010 Networks

From Release 7.9.1, both C-Band and L-Band optical subnets appear by default for the NCS 1010 networks.

For C-Band and C+L Futuristic networks, the L-Band optical subnet contains no fiber links. To add fiber links
for the L-Band optical subnet, you must upgrade the existing network to a C+L-Band network or add an
L-Band edge for each C-Band edge.

Note

The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click Subnet in the network tree panel.
Step 2 Click the Ellipsis icon available in the right side of Optical Subnet.
Step 3 Click Create Optical Subnet.

The Create Optical Subnet dialog box appears.

Step 4 From the Band Type drop-down list, choose either C-Band or L-Band.

From R7.9.1, Band Type drop-down list is available when creating optical subnet for NCS 1010.Note
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Step 5 From the Spectral Density drop-down list, choose the spectral density for the new optical subnet that you want to create.

From Release 5.2, the range of spectral density has increased (ranges from 30 to 100).

The Name, CBand Rules or LBand Rules, and Maximum Number of Channels values that appear in the Create
Optical Subnet dialog box are set based on the spectral density that you have selected.

Step 6 Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

You can select a new spectral density from the Spectral Density drop-down list in the properties window.Note

You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

• Click the Ellipsis icon available in the right side of the required optical subnet and select Edit Fibers.

An Info dialog box appears displaying "Do you want to continue?.

• Click OK.

The UI freezes. You can only select a fiber from the map.

• Select the required fiber and click the Done button appearing near the zoom icon.

The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding fiber
is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only one
subnet rule will be associated with one fiber.

Note

Convert Non-SSON Network to SSON Network
The following procedure converts non-SSON networks to SSON networks:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a non-SSON network that you want to convert to SSON.

The network opens. Ensure that the network is in Design Mode.

Step 3 Choose Network > SSON Convert.
Step 4 Click Ok.
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The error message, "Network cannot be converted to SSON due to following errors : [Network contains waves with
invalid traffic types: [100G-SD-FEC, 200G-SD-FEC]]" appears.

Step 5 Choose Network > Entity Editor > Services.
Step 6 Expand Waves and navigate to trail, and click a trail.
Step 7 Choose any CFP-2optical source from the Src Card Type drop-down list.
Step 8 Click Update.
Step 9 Choose File > Save.
Step 10 Choose Network > SSON Convert.

In the Warning pop-up window, choose 4K-2K or 4K-1K-2K from the Traffic Type drop-down list and click Ok.
4K-1K-2K is the defalut option. After the network is coverted, you cannot change the site type from 4K-2K to 4K-1K-2K
or vice versa.

• Select SSON optical source from the Traffic Type drop-down list in the properties window.

• You cannot convert a non-SSON network with Traffic Sites to SSON.

• To convert a non-SSON network to SSON network in Analyze mode, upgrade or release upgrade the analyzed
network. In the Upgrade mode, or Release Upgrade mode network, unlock all the channels, and force CFP-2
optical source.

Convert NCS 2000 Network to NCS 1010 Network
Use the following task to convert an NCS 2000 network (both SSON and non-SSON) into to NCS 1010
network:

Table 14: Feature History

Feature DescriptionRelease InformationFeature Name

The newly introducedNCS 1010 Convert option under
the Network menu enables you to directly convert an
existing NCS 2000 network into an NCS 1010 network.
This conversion eliminates the need to build an NCS
1010 network from scratch.

Cisco ONP Release
5.1

Convert NCS 2000
Network to NCS 1010
Network

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click an NCS 2000 network (non-SSON or SSON) that you want to convert to NCS 1010 network.

The network opens. Ensure that the network is in Design Mode, Upgrade Mode or Release Upgrade Mode.
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Step 3 Choose Network > NCS 1010 Convert.
Step 4 Click Ok.

The network does not get converted and shows an error message, when"

• The network contains traffic sites.

• The fiber type is LS or TWClassic.

• The network contains OTN services.

• The traffic Type property is set to anything other than Optical Source or Pluggable Card.

• If the Traffic Type is 100G-SD-FEC or 200G-SD-FEC in non-SSON networks.

Step 5 Choose File > Save.

The following parameters get automatically updated after the conversion:

• Contentionless sides are deleted and contentionless demands are automatically changed as colorless.

• Protected channels are converted to two unprotected channels. The path, wavelength, regen sites and cards that are
configured are retained.

Share a Network
Use these steps to share a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Select a network from the list of networks.

The map of the selected network opens.

Step 3 Choose File > Share.
Step 4 Select one or more users or user groups from the Share Network dialog box.
Step 5 Click Share.

You can share the network with selected users or user groups in read-only mode.

Access a Shared Network
Use these steps to access a network shared by another user:
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open Shared Network.

The Select Network To Open dialog box appears with a list of networks that are shared by other users.

Step 2 Click a network name from the list.

The shared network opens in read-only mode.

Step 3 Choose File > Save As.
Step 4 Enter the name in the Give a network name dialog box, and click Save.

A copy of the shared network is saved.

You can work on this copy of network, depending on the privileges of your user role. For example, if your user
role is Designer, you can change the design of the saved copy of the shared network, but you cannot analyze the
shared network.

Note

Step 5 (Optional) Share the updated network with other users.

Unshare a Network
Use these steps to unshare a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network from the list of networks.

The network opens.

Step 3 Choose File > Share.
Step 4 In the Share Network dialog box, remove the name of one or more users or user groups from the list.
Step 5 Click Share.

The shared network is no longer available to the users or user groups that are removed.
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Analyze the Network
Table 15: Feature History

DescriptionRelease InformationFeature Name

The See More Details option has
been introduced in the tooltip
displayed on hovering over Sites
on the Map view of an analyzed
network. This option shows the
Amplifier data and PSD (Power
Spectral Density) profile graph. The
See More Details option avoids
navigating to the Entity Editor to
view these details.

Cisco ONP Release 5.1Detailed Tooltip for Sites on the
Map View

The Analyze tool allows you to analyze the network after design completion.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network that you want to analyze, from the list of networks.

The network opens.

Step 3 Choose Network > Analyze.

The Cisco ONP analysis progress indicator indicates the analysis status.

If there is any failure in the analysis stage, a dialog box appears with the message, “Analysis Failed.”

Step 4 Choose the Elements > Messages tab to see the list of error details in the analyzed network..

By default, it shows only the key messages when the Critical Only toggle button is enabled. If you want to view the
entire network message, disable the Critical Only toggle button.

Note

Step 5 If you find an error message under the Messages tab, resolve the error and analyze the network again. Repeat this step
until all errors are resolved.

The error message "Unexpected Situation 999" may occur when the optical simulation becomes inconsistent due
to incorrect values of properties entered or modified while designing the network. Call Cisco TAC to know the
exact cause of the error and modify the suggested property value for the successful analysis of the network.

Note

Step 6 (Optional) After the successful analysis of the network, to view the details such as Amplifier Data and PSD Profile
graph for a site, hover the mouse over a site and click See More Details.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
48

Design and Analyze Networks
Analyze the Network



The amplifier data includes output power, EOL gain, attenuator in, attenuator out, and Raman gain. The attenuator details
are not displayed for the NCS 1010 site. The PSD profile graph is displayed only for the NCS 1010 site.

Bottom-Up Flow
Bottom-up support enables step-by-step creation of a network. Adding all the services and waves on day 0
itself is not mandatory to analyze the network and view reports. Bottom-up flow enables you to build a network
over a period.

Day 0: Create a network with only the topology added. Add all sites and add fibers between them. Analyze
the network and view the reports without adding any services or waves.

Day 1: Add waves between the sites that are added on Day 0 and newly added sites and fibers. Analyze the
network and view the reports.

Day 2: Add services and tag waves that are created on Day 1 and newly added sites and fibers. Analyze the
network and view the reports.

After you have created the topology with sites and fibers added, you can add either a service or a wave. You
need not follow any specific order.

Bottom-up flow is applicable only for Non-SSON networks. In order to achieve this, you must set A2A mode
as A2A_fast in network properties. You can also set the A2A channel type as contentionless, colorless, and
colored.

Note

Idle Timeout in the Analyze Mode
If you keep the browser idle for more than 15 minutes, you are logged out of Cisco ONP. The default timeout
is set to 15 minutes. The System Admin can disable this feature by changing the enabled option in the
configuration file on the server to false. You can change the default time of 15 minutes by editing the duration
option in the configuration file.

During a long network analyze cycle, you get logged out due to idle timeout, and the network analysis runs
in the background. When you log back, the same network opens in one of the following states:

• If the analysis is still on, the analysis progress bar is shown, and you cannot perform any other action.

• If the analysis is complete, the network opens in the Analyze mode.

• If the analysis has failed, the network opens in the design mode, and you can view the reason for failure
on the Elements > Messages page.

The session time out does not redirect you to the login page always; so, reload or enter the URL again.
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Upgrade the Analyzed Network
Table 16: Feature History

DescriptionRelease InformationFeature Name

After a network is analyzed, all the
network elements get locked. With
this feature, you can selectively
unlock certain network elements to
upgrade the network further. This
helps in preventing accidental
updates to the part of the network
that does not need any
modification.

Cisco ONP Release 5.0NCS 1010 Network Upgrade
Flexibility

Cisco ONP allows you to upgrade an existing network that is in analyzed mode. You can modify certain
properties of a network element in the network while retaining the existing network layout and design in the
locked state. Upgrade is supported for NCS2K, NCS4K-2K, NCS4K-1K-2K and NCS1010 networks.

Use these steps to upgrade your network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the analyzed network that you want to upgrade.

The network opens.

Step 3 Choose Network > Upgrade.
Step 4 Click Yes in the Warning dialog box.

The message “Network Upgraded Successfully” appears. The network goes into upgrade mode and network elements
such as sites, fiber, waves (for non-SSON), media channel (for SSON), and circuits (for NCS 1010) are locked.

Step 5 Click the Ellipsis icon available in the right side of the network element that you plan to modify from the network tree
panel, and choose Unlock. You can unlock individual element and one at a time for multiple elements until the lower
level in the network tree hierarchy.

For example, you can hierarchically unlock at the node level, side level, side add/drop card level, and side amplifiers
level.

If you want to change only the add/drop between MD-32-ODD/Even or BRK_24/16/8 in the NCS 1010 network, you
can unlock the add/drop without unlocking the network elements that are higher in the hierarchy.

Step 6 You can make the following modifications according to your requirement:
a) Edit the properties of network elements.
b) Delete the network elements from the network.
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c) Add a new site, wave, services, demands, optical subnet, or fiber into the network map.

The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

You can insert a node in the upgrade mode only for the unlocked fiber. Therefore unlock the fibers that are
connected to the node and add nodes to the network.

Note

Step 7 Choose File > Save.
Step 8 Choose Network > Analyze.

After the analysis is completed, the newly added elements are locked, and the optical reports and installation parameters
of the upgraded network are updated.

When you add services or fibers while upgrading a network that has where layout template is applied, the template gets
updated with the newly added service or fiber. You can export this template, make changes and reapply it to another
network.

Step 9 Choose Network > Design to further upgrade the newly upgraded network design.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Upgrade LNI Network
Table 17: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to upgrade
andmodify the imported LNI (Live
Network Import) network as
required. You can also correct LNI
errors, reanalyze the network, and
view the updated parameters such
as BOM, layout, connections, and
optical results.

Cisco ONP Release 4.1Upgrade LNI Network

The Upgrade feature can be used to correct LNI errors, modify the network, reanalyze the network and view
updated BOM, Layout, Connections, and Optical Results.

Use these steps to upgrade the LNI network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network imported through LNI that you want to upgrade.
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The network opens.

Step 3 Choose Network > Upgrade.
Step 4 Click Yes .

The message “Network Upgraded Successfully” appears. After upgrading the network, the network goes into upgrade
mode, and network elements such as Sites, Fiber, OTN Services and Media Channels are locked.

You can modify certain properties of the network element, while retaining the existing network layout and design
locked.

Step 5 Click the Ellipsis icon available in the right side of the network element that you plan to modify from the network tree
panel, and chooseUnlock. You can unlock individual element and multiple elements until the lower level in the network
tree hierarchy.

For example, you can unlock node level, side level, side add/drop card level, and side amplifier level.

Step 6 You can make the following modifications according to your requirement:
a) Edit the properties of network elements.
b) Delete the network elements from the network.
c) Add a new site, wave, services, demands, optical subnet, or fiber into the network map.

The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

• Unlocking a media channel has few constraints. See Media Channel Unlocking Scenarios, on page 53.

• Cisco ONP automatically sets the scalable up to degree value based on certain design rules, as this value
is not present in the network that is imported through LNI. Hence, we recommend you to check and update
the actual scalable up to degree value, if necessary.

Note

Step 7 Choose File > Save.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Step 8 Choose Network > Analyze.

Analysis is successful only if a consistent and valid network is imported from LNI.Note

Step 9 If the analysis fails, go to Elements > Messages tab and check for the failure reason.
Step 10 If any validation error is thrown from any component, resolve the issue by manually changing the network or by

reimporting the LNI networks after correcting some configuration on the live network. See Possible Error Scenarios
and the Workarounds, on page 54.

Step 11 Re-Analyze the network.
Step 12 Click the Layout tab and edit the layout manually to adjust chassis or card position for NCS 4000 and NCS 1004

platforms. See
Step 13 Click the BOM tab, and the Results tab to view the BOM and optical results.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
52

Design and Analyze Networks
Upgrade LNI Network



a. If the LNI inventory has any unconnected cards, that will be removed from the Cisco ONP reports after
upgrading and analyzing the LNI network.

b. The following PIDs are added in the Cisco ONP BOM after upgrading and analyzing the LNI network.
These PIDs are not part of the LNI network BOM.

• Pre-provisioned PIDs

• Release software PIDs

• Optical cables―Cables used for Internal Patch-cord Connection (IPC) is not imported in LNI as this
data cannot be retrieved from device

• Attenuators

• SMR port license PIDs―Only SMR card PID is imported as part of LNI. If a licensed PID is retrieved,
corresponding port licenses are added after upgrading and analyzing the LNI network, based on the
number of ports used.

• USB cables―Added if preprovisioned passive cards are present.

• Blank cards―Blank cards are not imported. They are added in Cisco ONP after upgrading and analyzing
the LNI network.

Note

Media Channel Unlocking Scenarios
The following table explains the various media channel conditions and the unlocking possibilities.

Table 18:

Unlocking PossibilitiesConditions

Cisco ONP throws an error indicating that there are
OTN services associated with the media channel. You
can neither update nor delete the channel. To unlock
and delete themedia channel, unlock associated OTN
services first and then unlock the media channel.

Channel has OTN services going over it. For 4K-2K,
the service is directly mapped to the channel, and for
4K-1K-2K, the service is mapped via OTU4 trail.

Cisco ONP allows you to unlock the channel but does
not automatically clear the properties of the channel
or its child entities such as Trail and Section,
irrespective of whether the properties or user-defined
or auto-assigned. Also, the channel is not unlocked
automatically, if it has any associated OTU4.

After unlocking the channel, you can delete the
channel, but cannot update the properties of the
channel or its child entities. (When the properties of
the media channel or its child entities are
auto-assigned, only wavelength is cleared and set to
Auto, and all other properties are not cleared.)

Channel does not have OTN services going over it.
For example, in case of 4K-1K-2K, the media channel
carries empty OTU4s.
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Unlocking PossibilitiesConditions

Cisco ONP allows you to unlock the channel and
automatically clears auto-assigned properties. After
unlocking you can perform the following:

• Update various properties of the channel and its
child entities.

• Delete the channel.

Channel has neither OTN services nor OTU4(s) going
over it. In case of 4K-1K-2K networks, Media
Channel does not carry even empty OTUs.

Possible Error Scenarios and the Workarounds
Following table describes the workarounds for the errors that are shown under the Elements > Messages tab.

Table 19: Error Scenarios and the Workarounds

WorkaroundsError Message

Check the username and password of the device,
which is given in LNI input Excel and retry LNI
import with valid device credentials.

Device Authentication failure

Check for any connectivity issue in the setup, fix it
and retry LNI import.

Device collection failed or Device not reachable.

Unlock C-Band amplifiers for side A inside Site4 in
the Network tree and force the valid output power. If
not sure, set it to Auto and analyze. Cisco ONP
chooses the best value based on the configuration.

In Site4.A, output power setting is not supported by
the amplifier.

For protected OTN service or SSON service, a
minimum of two contentionless sides must be present
on the source and destination sites. Check and add
contentionless sides on the target service source and
destination site and analyze.

Cannot Route demand! Did not find any valid
Omnidirectional Side.

Only 100GE, 10GE, and STM-64 service rates are
supported. If any other service rate is present in the
network, unlock the specific service, change it to one
of the supported service types and update the ODU
time slot accordingly and analyze.

• Demand OTU3 has unrecognized type [OTU3]

• ServiceGroup does not support the demandType
OTU3 for OTU3

100GE service type must have ODU time slot in the
range of 1–80. If any other value is set, update the
correct value or leave it blank so that Cisco ONP can
set it to the correct value.

Primary OTN Demand [100GE_Flex] has invalid
Timeslot ranges. Allowed ranges are [1-80]

Unlock the site and reanalyze.Cannot complete mesh connections at Site3.

No action required. This is an information message
to the user.

No OTN demand found for NCS4K trunk port -
NCS4016-B - OTU40/8/0/1.
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WorkaroundsError Message

Unlock the corresponding fiber couple and update the
correct connector loss value to be greater than zero.
The typical value is 0.2.

Fiber between Node1.A and Node2.B has an invalid
value in connector loss value

Unlock the corresponding fiber couple and update the
correct Tot SOL Loss w/o Connectors. The value
should be greater than zero.

Fiber between Nod1.C and Node2.C has an invalid
value in Tot SOL Loss w/o Connectors.

Remove Raman forcing on the fiber, or check and
force the path for any service so that it goes through
Raman enabled span.

Span Fiber-2 is forced as Raman but no traffic is
present.

Force RAMAN-CTP or COP on the Fiber-2
connecting node interface or remove RAMAN forcing
on the Fiber-2

Couple Fiber-2 has Raman enabled on the duct but
corresponding Raman Forcing is missing.

No specific action is required for noncritical messages. These are just information messages to the user.Note

Upgrade the Software Release of a Network
Table 20: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to choose
the NCS 2000 system release to the
desired release (11.1.0, 12.0.1, or
12.1.0), while performing the
release upgrade of CTP network,
Cisco ONP network, network
imported through Excel, and LNI
network.

Cisco ONP Release 4.1Release Upgrade

You can upgrade the software version of a network that is imported from CTP, the network created in Cisco
ONP, LNI Network, and Excel imported network to any desired release. Release upgrade is supported for
both SSON and non-SSON networks having NCS 2000 nodes with ROADM,OLA, Traffic, or the Passthrough
functionality.

Release upgrade is supported starting with NCS 2000 Release 11.1.0.

NCS 2000 supports SVO from the Release 12.1.0.Note

The following table lists the releases to which the existing system release can be upgraded, for each type of
network..
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Upgrade ReleaseNetwork

• From 11.0.0 to 11.1.0, 12.1.0, 12.2.0, and 12.3.1

• From 11.1.0 to 12.1.0, 12.2.0, and 12.3.1

CTP network (.mpz)

• From 11.0.0 to 11.1.0, 12.1.0, 12.2.0, and 12.3.1

• From 11.1.0 to 12.1.0, 12.2.0, and 12.3.1

• From 12.1.0 to 12.2.0, and 12.3.1

Cisco ONP network

• From 11.0.0 to 11.1.0, 12.1.0, 12.2.0, and 12.3.1Excel imported network

11.1.0 to 12.0.1, 12.1.0, and 12.3.1

11.1.0 to 12.1.0, 12.2.0, and 12.3.1

You cannot directly release upgrade an LNI
network. Perform the following:

Note

• Upgrade the LNI network. see Upgrade
LNI Network, on page 51)

• Analyze the network. (see Analyze the
Network, on page 48

• Release upgrade the analyzed LNI
network.

LNI network

7.7.1 to 7.9.1, 7.10.1, 7.11.1, 24.31

7.9.1 to 7.10.1, 7.11.1, 24.31

7.10.1 to 7.11.1, 24.31

7.11.1 to 24.31

NCS 1010 Network

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to perform system release upgrade.

The network opens.

Step 3 Choose Network > Release Upgrade.
Step 4 Choose the System Release of NCS 2000, to which you want to upgrade, from the drop-down list.
Step 5 Click Submit.

The upgraded network is saved as a child network.
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The network elements are locked in the network tree after the release upgrade. You can unlock and modify the elements.

If the PMD coefficient does not get updated with the expected value, update the fiber type first, followed by the
PMD value when you edit the fiber properties.

Note

Plan Mode
Table 21: Feature History

Feature DescriptionRelease InformationFeature Name

This feature extends the current
implementation ofWhat-if analysis
for the OTN Services that are
connecting the aggregated nodes.
The failure report includes the
number of failed services, restored
services, and unrestored services.
This feature is supported for SSON
(4K-1K-2K and 1K-2K) and
non-SSON (4K-2K) networks.

Cisco ONP Release 4.1What-if Analysis for OTN Services

Plan mode enables you to perform what-if analysis on the existing network resources, such as failing and
restoring the fiber, OTN services, and site. This mode is applicable only for PLANNER and ADMIN roles.
This mode simulates the actual network behavior during failure and determines whether a service can be
rerouted; however, this mode does not suggest how to turn-up new wave lengths, insert new nodes, cards, or
ports, and so on.

The network can enter the Plan mode only from the Analyze mode. The what-if analysis can be done on the
NCS 2000 aggregated node (ROADM, OLA, Passthrough), Traffic node (1K-2K, 4K-2K and 4K-1K-2K),
the node created in Cisco ONP, CTP imported (mpz), and LNI imported networks.

Enter the Plan Mode
The following procedure shows how to enter the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with admin or planner role.

Step 1 Open the network in Analyze mode.
Step 2 Choose Network > Enter Plan Mode.

Switching to Plan Mode progress bar appears. The message, Entered Plan Mode successfully appears in the Success
dialog box.
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Exit the Plan Mode
The following procedure shows how to exit the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with admin or planner role.

Step 1 Open the network in the Analyze mode.
Step 2 Choose Network > Exit Plan Mode.

Fail a Fiber
The following procedure shows how to fail a fiber or a list of fibers in the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Expand the Fibers option in the network tree panel.
Step 2 Click the Ellipsis icon available in the right side of the fiber, and click Fail. You can choose multiple fibers to fail by

checking the check boxes next to the fibers.

All media channels or waves, OTN services, and demands that pass through the failed fiber fail. You can see the failed
media channels from the Map option or from the network tree.

• You can also fail a fiber or undo a fiber failure from Map.

• You can view the unrestored channel details in the failure report and the reason for restoration failure under
Elements > Messages tab.

• Failed channels are indicated with a red cross symbol, impacted fibers are marked with yellow cross symbol,
and the restored channels with a green tick symbol.

Note

Undo Fiber Failure
The following procedure shows how to undo fiber failure in the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree panel, click Fiber.
Step 2 Click the Ellipsis icon available in the right side of the failed fiber, and click Undo Fail.
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Create a Failure Set
You can click any set of fibers or sites, click the Ellipsis icon available in the right side, and fail them. The
failed fibers or sites are marked with a red cross mark beside them. You can also choose multiple fibers or
sites.

• Cisco ONP saves the user created failure sets.

• You can save multiple failure sets under a given failure group.

The following procedure shows how to create a failure set:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Ellipsis icon available in the right side of the Failure Groups option in the network tree panel.
Step 2 Click Add Failure Group.

A Failure group gets created.

Step 3 Choose the Fibers or Sites to fail by checking the check boxes next to the them.
Step 4 Click the Ellipsis icon available in the right side of the chosen Fibers or Sites and click Fail.
Step 5 Select the network name, and right-click.
Step 6 Click Add Failure Set.
Step 7 Select the Failure Group to which the failed fibers or sites must be added.

The Failure Set gets created under the Failure Group. The failed fibers or sites are added to the created Failure Set.

If networks have dark fibers (which does not carry any traffic), that path is not considered for restoration.Note

Fail a Site
The following procedure shows how to fail a site or a list of sites in the Plan mode.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Expand the Sites option in the network tree panel.
Step 2 Click the Ellipsis icon available in the right side of the site, and click Fail. You can choose multiple sites to fail by

checking the check boxes next to the sites.

You can also fail a site from the network map view.
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Undo Site Failure
The following procedure shows how to undo the site failure in the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree panel, click Site.
Step 2 Click the Ellipsis icon available in the right side of the failed site, and click Undo Fail.

You can also undo the site failure from the network map view.

Failure Report
The failure report shows the following parameters:

DescriptionReport

Shows the failed fibers in the network.Failed Fibers

Shows the failed sites in the network.Failed Sites

Shows the fibers that are impacted due to the site failure.Impacted Fibers

Shows the total number of media channels in the network.Total Channels

Shows the total number of media channels that are passing through the failed ducts
or sites in the network.

Failed Channels

Shows the total number of media channels that are restored from the failure state.Restored Channels

Shows the total number of media channels that are not restored from the failure
state due to the unavailability of alternate paths.

Unrestored Channels

Shows the fibers that have utilized greater than or equal to 80% of the bandwidth.
You can modify the threshold by updating the value in the Feature.Properties file.

• Fiber: Shows the fibers that are listed under fiber hot zones.

• Utilization Before (%): Shows the percentage of bandwidth that is utilized
before the channel restoration.

• Utilization After (%): Shows the percentage of bandwidth that is utilized
after the channel restoration.

Fiber HotZones

Shows the total number of services going through the fiber that was failed.Total Services

Shows the number of failed services going through the fiber that was failed.Failed Services

Shows the number of restored services going through the fiber that was restored.Restored Services
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DescriptionReport

Shows the number of unrestored services going through the fiber that was restored.Unrestored Services

:

Export Failure Report
The following procedure shows how to export the failure report.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Choose Export > Failure Report to export the failure report as an Excel sheet.

You can save the Excel sheet.

Export Failure Report from Map
The following procedure shows how to export the failure report from the map:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click Failure Report under Map.
Step 2 Click Export to export the failure report as an Excel sheet. You can save the Excel sheet.

Restore Failed Channels
The following procedure shows how to restore the failed fibers:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Network > Enter Plan Mode.
Step 2 Click Restore.

The message, "Restoration is in progress" appears.

Step 3 Click Failure Report to view the number of media channels that are restored or unrestored.
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Restored channels are indicated with a green color tick mark in the network tree and map.

All media channels or waves, and demands that pass through the restored fiber also get restored. The Path
Computation Element (PCE) supports the restoration of the OTN services based on the optical feasibility and
OTN constraints.

Note

Automatic Suggestion for Regeneration Sites in Plan Mode
Table 22: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP displays feasibility
report in the Plan mode. This report
automatically suggests regeneration
sites for the channels with high and
marginal risk of failure. You can
incorporate these regeneration sites
in the optical network to make the
channel optically feasible. This
feature avoids multiple iterations
required to manually create the
regeneration sites and test the
optical feasibility of large networks.

Cisco ONP Release 5.0Automatic Suggestion for
Regeneration Sites

Cisco ONP submits the networks that are not optically feasible (the channels that have marginal and high risk
of failure assessed based on the EOL and SOL indicated as red, and orange in theOptical Results page). PCE
runs a regen suggestion algorithm and suggests the regeneration sites. When you enter the plan mode, Cisco
ONP displays regen sites in the Feasibility Report displayed at the bottom of the map. You can apply the
suggested regen sites to make the network optically feasible.

Auto regen site suggestion is supported for both SSON and non-SSON network that has contentionless channels
or waves between NCS2K (ROADM) or 4K-1K-2K(TRAFFIC) sites.

If the channels have already regen forced, the regen suggestion is shown at sections level.

The Feasibility Report table includes the following fields:

Table 23: Feasibility Report

DescriptionField

Displays the list of channels (trail and sections) that
are not optically feasible.

Channel Name

Displays the color of alarm (red, orange, or yellow)Alarm

Displays the actual path of the channel as hyperlink.
If you click the link, the path is highlighted in the
map.

Paths
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DescriptionField

Displays the intermediate sites that can be used as
regen sites so that the channel becomes optically
feasible.

Suggested Regens

You can also export the report by clicking Export.

The Suggested Regen field is displayed as NA for the following reasons:

• The channels with yellow alarms, as the loss is negligible.

• When the loss is high and the number of available intermediate sites are not enough to compensate the
overall loss.

• The intermediate sites where no contentionless sides are added will not be considered for regen sites.

Apply Suggested Regen
Use this task to apply the suggested regeneration sites to make the network optically feasible.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with admin or planner role.

Step 1 Enter the Plan Mode, on page 57.
Step 2 Choose Network > Open Feasibility Report.

The Feasibility Report is displayed at the bottom of the map.

Step 3 Select the channels for which regeneration has to be applied and click Apply.
Step 4 Click Ok in the Suggested Regen Applied dialog box.
Step 5 Click Exit Plan Mode.
Step 6 Click Yes in the Warning dialog box.

The network gets auto upgraded and saved as a new network. The channels with regens applied are unlocked with the
Regen Sites property auto updated and noneditable.

Step 7 Analyze the network.

In the Optical Results page, the SOL, and EOL fields become green, and the channels are not displayed in the feasibility
report again when you switch to the plan mode.
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Line Rate Tuner Mode
Table 24: Feature History

Feature DescriptionRelease InformationFeature Name

You can now automate the calculation of optical
sources for your networks using the new Line Rate
Tuner Mode. This mode reduces human errors while
finding the correct optical source for your network
from a set of network resources.

Cisco ONP Release
5.2

Automated Selection of
Optimal Wavelength Bitrate:
Flexible Modelling

Line Rate Tuner Mode significantly reduces turnaround time, avoiding manual calculation of different
possibilities of network resources.

Enter the Line Rate Tuner Mode
Use these steps to enter the Line Rate Tuner mode.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Open the network in Analyze mode.
Step 2 Choose Network > Enter Line Rate Tuner Mode.

Switching to line rate tuner mode.. progress bar appears.

The network opens in the Line Rate Tuner Mode.

Create a Custom Optical Source
Use this procedure to create a custom optical source.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Input.

Input Tuner pane appears below the map area.

Step 3 In the network tree, select the section of the media channel that you want to add the tuner input.

In Select Input Parameters, the selected section appears with default parameter values.

Step 4 Modify the following Input Parameters as required.
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DescriptionPlatformProperty

Choose the optical family. Based on the analyzed network, Cisco ONP provides
the options. Based on the optical family chosen, the remaining parameters provide
related options.

NCS 2000
SSON

NCS 1010

Optical Family

Choose the optical source. Based on the optical sources that are already imported,
Cisco ONP provides the list of optical sources.

NCS 2000
SSON

NCS 1010

Optical Source

Choose the data rate. Based on the optical family chosen, Cisco ONP provides
options to choose the channel capacity for the new section.

NCS 2000
SSON

NCS 1010

Data Rate

Choose the bit data rate. Based on the optical family chosen, Cisco ONP provides
options to choose the speed of data transfer in the new section.

NCS 2000
SSON

NCS 1010

Bit Rate Range

Choose the baud rate range. Based on the optical family chosen, Cisco ONP provides
options to choose the minimum signal width for new each channel.

NCS 2000
SSON

NCS 1010

Baud Rate Range

Choose the FEC type. Based on the optical family chosen, Cisco ONP provides the
list of supported FEC types

NCS 2000
SSON

NCS 1010

FEC Type

Choose the Result Type. The available options are:

• Best OSNR—Provides results based on maximum OSNR margin.

• Maximum Capacity—Provides results based on the maximum capacity of the
channels.

NCS 2000
SSON

NCS 1010

Result Type

Choose optical feasibility for the new section. The available options are:

• Green

• Yellow

• Orange

• Red

Each color represents the severity of alarms that may arise in the new section.

NCS 2000
SSON

NCS 1010

Optical
Feasibility

Choose the sigma number from 0 to 3. The sigma number calculates the OSNR
margin.

NCS 2000
SSON

NCS 1010

Sigma Number
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DescriptionPlatformProperty

Choose the number of optical source results that you want for the new section.

The default value is set as 5. However, you can choose up to 15 results.

NCS 2000
SSON

NCS 1010

Number of
results

Step 5 (Optional) Click Reset to reset the modified parameters to default values.
Step 6 Click Add.

In Select Section, Tuner Input is added successfully. Please refer the below table for the added inputs message appears.

The Select Section pane provides the details of the modified section.

Table 25: Select Section Parameters

DescriptionSection Parameters

Name of the modified section.Section Label

Site name for the optical channel source.Src Site

Site name for the optical channel destination.Dst Site

Fiber paths in the section.Path

Icons to edit or delete the modified section.Actions

Step 7 (Optional) To modify or delete the section, choose the following icons as required:
ActionsIcon

Edit Input—Modifies the sectionPencil

Delete Input—Deletes the sectionTrash Bin

To edit the modified section:

a. Click the pencil icon.

b. Modify the input parameters as required.

c. Click Update to update the edited section parameters.

To delete the modified section:

a. Click the trash bin icon.

A confirmation message appears.

b. Click Yes.

Step 8 Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.
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Step 9 In Tuner Result, click Export to export the results as an Excel sheet.

Start the New Tuner Analysis
Use these steps to start a fresh tuner analysis for the new section.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Start New.

The Start New Tuner dialog box appears asking for a confirmation.

Step 3 (Optional) Check the Retain the tuner inputs check box to retain the previous input values.
Step 4 Click Yes.

The message Started new tuner successfully appears.

Step 5 Modify the input parameters of the new section.
Step 6 Click Update.
Step 7 Click Run Tuner to trigger the simulation.

The Running Tuner Analysis progress bar appears. The message, Tuner analysis completed successfully appears.

Open the Custom Optical Source Tuner Result
Use these steps to open the tuner results for the customized optical sources.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears.

Add the Custom Optical Source to the Network
Use these steps to add the custom optical sources to the network.
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Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Click Open Tuner Result.

The Tuner Result pane appears displaying the new sections and their demand channels.

The result provides the following action icons to add the optical sources to the network.

• Add Demand to Network—Click this icon to add the demand to the network.

• Download Optical Source—Click this icon to download the optical sources as an Excel sheet to review offline.

Step 3 To add the optical source to the network, perform one of the following actions:

To add manually:

For some custom optical source results, the download icon becomes disabled. In that case, go toManage >Optical
Source to download the optical result as explained in Download Optical Sources.

Note

a. Click the download icon.

The Downloading Optical Source message appears. The Excel sheet contains data in Cisco ONP format.

b. Open the Excel sheet to review the data.

c. Import optical sources as explained in Import Optical Sources.

To add automatically:

a. Click the add icon.

The No. of demands pop-up appears asking for the number of demands to add to the network.

b. Enter the demands number and click Add.

The Demand is added successfully message appears.

The new demand appears in the network tree. Along with the demand, the Cisco ONP adds the required optical source
also automatically to the server.

Exit the Line Rate Tuner Mode
Use these steps to exit the Line Rate Tuner mode.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Open the network in Line Rate Tuner mode.
Step 2 Choose Network > Exit Line Rate Tuner Mode.
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The Exiting Tuner dialog box appears.

Step 3 Choose the following action as required.
ActionsButton

Moves the network to previous state with applied changes.Previous State

Moves the network to Upgrade mode with applied changes.Upgrade

Cancels the operation.Cancel

The network exits the Line Rate Tuner mode.

Import Optical Sources
Table 26: Feature History

Feature DescriptionRelease InformationFeature Name

You can create an optical source by
defining the details of interfaces
and the corresponding optical
classes in an Excel template. This
feature provides you with the
flexibility to create any required
optical source based on existing or
new traffic resources.

Cisco ONP Release 5.0Create Optical Source using Excel
Sheet

Optical Source Wavelength is a way to connect a DWDM interface from any external element to a third-party
optical network.

Use this procedure to import an optical source:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

If you want to import the optical sources from an Excel sheet, download the template by choosing Export >
Optical Source Template. Fill the necessary details in the Interfaces and Optical Classes sheets of the
downloaded template and save the file. See Optical Parameters Available in the Excel Sheet for Optical
Sources Creation, on page 70.

The fields in the columns D, E, and F that are not mandatory are hidden by default in the Interfaces sheet of
the template. You can expand the columns and fill the details.

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears. The default optical sources available in the server are:

• OpticalSources_NCS2K_400GXP-LC_NCS4K-4H-OPW-QC2
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• NCS1004_OpticalSources_V3

• ONS-CFP2D-400G-C-OpticalSources-V2.mxd

• QDD-400G-ZRP-S-OpticalSources-V2.mxd

By default, all existing optical source files are loaded in the server.Note

Step 2 To import optical source as .mxd file:
a) Click Add.
b) Choose Optical Source (.mxd)

The Import Optical Source (.mxd) dialog box appears.

c) Click Choose File and browse to the .mxd file stored in your local system, and click Import.

After the optical source is imported, a list of related interfaces appears.

Step 3 To import the optical source from an Excel sheet:
a) Click Add.
b) Choose Optical Source (.xlsx)

The Import Optical Source (.xlsx) dialog box appears.

c) Click Choose File and browse to the .xls file (optical source template) saved in your local system, and click Import.
d) Choose the Release Version of the NSC2K network.
e) Select the interface.
f) Click Create.

After the optical source is imported, a list of related interfaces appears.

Step 4 Choose the interfaces to import by checking the check box next to them. The selected interfaces get added to the Type
drop-down list in the properties window of the network tree.

When you create waves, you can use the interfaces in the Type drop-down list.

Optical Parameters Available in the Excel Sheet for Optical Sources Creation

The following parameters are available in the Excel sheet template for creating optical sources.

Table 27: Optical Parameters for Creating Optical Sources

DescriptionParameters

The name of the interface. It should be unique for all
the interfaces that are added in the file.

Interface Name

The name of the vendor.Vendor Name

The vendor IDs.Vendor IDs
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DescriptionParameters

The name of the platform.Platform

The PID of the pluggable.Pluggable PID

It is the combination of the Data Rate and Open
Config Code. For example: R400G#5000.

Name

The forward error correction type for the given
interface.

FEC

The line rate for the given interface.Data Rate

The modulation format to be used for the interface.Mod Format

The baud rate for the given interface.Baud rate

The speed of data transfer (bits per symbol) for the
given interface.

BPS

The unique code assigned to the interface as specified
by the Open Industry Standard for optical networks.
For example: 5000.

Open Config Code

Enter the sub-mode if there are any associated with
the interface. If not, leave it blank.

Sub Mode

The trunk rate of the transponder.Trunk Rate

The bit Rate for the interfaceNominal Bit Rate

The post FEC BER Target for the interfaceBER Target

The minimum and maximum Tx Power for the
interface.

Power Min and Power Max

The overload power limit for the interfaceOvl

The Rx power sensitivity for the interface.OL Power

The Rx OSNR sensitivity for the interface.OL OSNR

The extended Rx power sensitivity.PL Power

The Rx OSNR sensitivity at the extended Rx power
sensitivity.

PL OSNR

The variance in power in the Txp.Variance

The optical class to which the interface will be
mapped.

Opt Class

The Tx OSNR contribution due to laser instability
inside the Txp.

InBand OSNR
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DescriptionParameters

The Tx OSNR contribution due to Add/Drop at 80%
and 100% channel spectral density.

Out of Band OSNR

The Software release of Cisco ONC from which this
interface will be supported.

ONC Release

It is the same as the name of the interface.Interface Type

The operating frequency range of the interface.Min and Max Frequency

Table 28: Optical Class Parameters

DescriptionClass Parameters

The name of the interface. Enter the same name of
the interface, if you are doing one to one mapping
with the interface.

Interface Type

You can create the optical classes for different optical
sources. Certain optical parameters are added in the
optical class. Based on interface properties, multiple
interfaces can be mapped to the same class.

Enter a unique alphanumeric name for the Optical
class. While creating new optical classes, we
recommend using the name starting with “X” to avoid
overlapping in the existing classes.

Opt Class

The bit rate for the given interface.Bit Rate

The baud rate for the given interface.Baud Rate

The modulation guard band coefficient.ModGB Coeff

The modulation OSNR penalty.Modulation OSNR Penalty

The filtering GuardBand at different OSNR penalties.GBf

Enter the mux/demux filtering penalty value, if there
are any.

Mux/Demux Filtering Penalty

The chromatic dispersion limit at different OSNR
penalties.

Chromatic Dispersion

Find Optical Sources Faster
Use these steps to find the optical sources faster.
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Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

By default, all existing optical source files are loaded in the server.Note

Step 2 To find the customized optical sources:

a. Check Show only line rate tuner generated sources.

The dialog box displays only the customized optical sources.

Step 3 To filter the required optical source:

a. Enter the optical source name in the Search box.

The dialog box displays the optical sources matching the typed keyword.

Download Optical Sources
Use this procedure to download an optical source:

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to download.
Step 3 Click Download and select one of the following options to download the optical sources.

• .mxd—Downloads the selected optical sources as .mxd file.

• .xlsx—Downloads only the optical sources which were created and added using the Excel template, as .xls file.
Others such as the optical sources which were directly added as .mxd file, are not included in the .xsl file.

• .xml—Downloads the optical source data as a .xml file. This file contains the application codes for circuit provisioning
in Cisco ONC, optical parameters of the interfaces, PIDs, and Vendor ID information. You can load the .xml file
into Cisco ONC to create circuits with these optical source interfaces. See Alien Import.

After the import is successful, the optical source will be present under the Application Code tab in the Service
Manager screen of the Cisco ONC application. See Service Manager.
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Delete Optical Sources
Use this procedure to delete an optical source:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to delete.
Step 3 Click Delete to delete the selected optical sources.

Layout Template for NCS 2000 Network
Layout templates are reusable templates that are used to design layout configurations for the NCS 2000
network. When you have an NCS 2000 network with fixed layout rules applicable for multiple nodes, you
can use these templates to accurately set up the layout for those nodes. These templates save you time, effort,
and they minimize errors.

Layout template is not supported for a mix of TXP and Real card label of transponders.Note

Export Layout Template
Table 29: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to export
the layout template for an
individual site or for all the sites.
The layout template export is
possible only if the network is
analyzed in CiscoONPRelease 4.1.
The export of layout template is
supported on 4K, 4K-1K-2K, and
2K nodes.

Cisco ONP Release 4.1Layout Template Enhancement

Use the following procedure to export the layout template of a specific site or all sites:
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network whose network layout template you want to export.

The network opens.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 Click the name of a site in the left side panel, for which you want to download the layout template.
Step 6 Hover the mouse pointer over the Export icon and click Layout Template for Current site or All Sites.

The Export Layout Template dialog box appears.

Step 7 Click Export.

• We recommend that you export the layout template only in the analyze mode. Exporting layout templates
in the upgrade and release upgrade modes may be inaccurate.

• You can export the layout template for node of the type 4000 and 1000, but the exported layout template
will contain only the layout of NCS 2000 nodes. To export the layout template for the node type
NCS4K-1K-2K and NCS1K-2K, perform the following:

• Right click the site name in the Layout panel, and click Export.

• Click OK to export the layout template in text format.

• The NCS 2000 layout template is in XML format.

Note

Import Layout Template for NCS 2000 Network in to Cisco ONP Database
Use the following procedure to import a template for NCS 2000 Network into the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Layout Templates.
Step 2 Click Add in the Manage Layout Template dialog box.
Step 3 Click Choose Files and select a template from your local system.
Step 4 Click Import.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
75

Design and Analyze Networks
Import Layout Template for NCS 2000 Network in to Cisco ONP Database



The template is imported to the Cisco ONP database.

Download Layout Template for NCS 2000 Network
Use the following procedure to download a template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Layout Templates.
Step 2 In the Manage Layout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Download.

Save the template into your local system.

Delete Layout Template for NCS 2000 Network
Use the following procedure to delete a NCS 2000 Network template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Layout Templates.
Step 2 In the Manage Layout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Delete to delete the template from the Cisco ONP database.

Apply NCS 2000 Layout Template into a Site
Use this task to apply the NCS 2000 Layout template into a site. The site can be NCS4K-2K, NCS1K-2K-4K,
or NCS1K-2K, but the template will be applied only to the NCS 2000 section of that site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.
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The Select Network To Open dialog box appears.

Step 2 Click the network where you want to apply the layout template into an NCS 2000 site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 In the Entity Editor window, expand Sites and choose the site.
Step 5 In the right pane, choose the required template from the Layout Template drop-down list.

Make sure that the other properties under Layout section such as Chassis Type, Power Supply, Controller
Card, Node Protection, Redundant Controller Card, and MF-Unit are

set to Auto. Otherwise the Layout Template drop-down list remains disabled.

Note

Import NCS 1000 and NCS 4000 Layout Template into NCS1K-2K and
NCS4K-1K-2K Sites

Use this task to import NCS 1000 and NCS 4000 layout templates that were exported, into 4K-2K and
NCS4K-1K-2K Sites.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network that has the site to which you want to apply the layout template.

The network opens.

Step 3 Click the Layout tab.
Step 4 Add the required NCS 4000 and/or NCS 1000 chassis, cards, and pluggables to the required slot of the added chassis.

See Edit the Layout Manually, on page 79

Step 5 Click Edit to enter the edit mode.
Step 6 Right click the name of a site on which you want to import the layout template, and click Import.
Step 7 Choose the layout template that you want to import into the site and click OK

The layout template gets applied to the site.

When you modify an exported template, ensure to rename the modified template before reapplying it to a site in
the upgrade mode so that the changes in the template reflect in the layout view.

Note
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Layout Visualization
Table 30: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to view and
adjust the position of NCS 4016
and NCS 1004 chassis and cards in
the layout. This feature is supported
only on 4K-1K-2K and 1K-2K
aggregated nodes and not supported
on stand-alone NCS 2000 node.

Cisco ONP Release 4.1Layout Visualization and Edit

This feature allows you to visualize the layout of a network, designed using Cisco ONP. You can view the
arrangement of racks, chassis inside the racks and cards inserted in the chassis. When you click a particular
Rack or Chassis or Card in theLayout panel, the corresponding Rack or Chassis or Card gets highlighted in
the Layout image. You can zoom in and zoom out the Layout image.

View Network Layout
The procedure to view the network layout is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 In the Layout panel on the left side, click the site.

The OLA sites are highlighted in green color, ROADM sites in blue color and Aggregated nodes in purple color.

Passthrough sites are not listed under layout.

For NCS 1010 network, Aggregated nodes are not available.

Note

Step 6 Click any rack under a site to visualize the rack view of the network under Layout tab.
Step 7 Click any chassis under a rack to visualize the chassis view of the network.
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When you click the Aggregated node under Layout panel, NCS 1004, NCS 2000 and NCS 4000 series chassis
are placed in separate racks.

You can click the screenshot icon to take screenshot of all racks layout of the selected site.

Note

Edit the Layout Manually
The Manual layout edit feature is used to adjust the position of NCS 4016 and NCS 1004 chassis and cards
in the layout.

The procedure to edit the layout manually is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.

Choose the network where 4K-1K-2K and 1K-2K aggregated nodes are added. This feature is not supported on NCS
2000 node.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 Click Edit to enter the Edit mode.
Step 6 Select the Chassis (4K-1K-2K and 1K-2K) or Card from a particular rack.
Step 7 Drag and drop the selected Chassis or Card from a particular rack to the empty slot in the same or different Chassis or

Rack.
Step 8 To add pluggables to a particular card, perform the following steps:

Make sure to add the required cards.Note

a) Select the Rack.

The cards available in the Rack are displayed.

b) Select the card to which you want to add pluggables.

The ports available in the card are displayed.

c) Select the pluggable for each port.

The following pluggables are displayed:
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Supported PluggablesCard

• ONS-QSFP8-LR4=

• QSFP-110G-SR4-S=

• ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-QC2

• ONS-QSFP8-LR4=

• QSFP-100G-SR4-S=

• ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-LO

• ONS-QSFP8-LR4=

• QSFP-100G-SR4=

• ONS-QSFP28-LR4-S=

• QSFP-100G-CWDM4-S=

• QSFP-100G-SM-SR=

NCS1K4-1.2T-K9=

d) Click the Tick icon.

Step 9 Click Done to save the changes in the Layout.

View the Layout Details Using Tooltip
You can hover over the Racks or Chassis or cards in the Rack and view the details using Tooltip. Click See
More Details to view the details of port no. type, pluggables and rates.

Copy the Configurations of a Particular Node to Another Node
The configuration can be copied from one node to another node only for the manual 4K-1K layout movement.
It is not supported for NCS1010 layout movement.

The procedure to copy the configurations of a particular node to another node of a different site is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note
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Step 4 Click the Layout tab.
Step 5 Select the Rack, Chassis, or Card of a particular site.
Step 6 Select the site to where you want to copy the configurations to, from the Copy To drop-down list.
Step 7 Click New Rack to add a new rack. The configuration gets copied to the new rack.
Step 8 Click Done to save the changes in the Layout.

You can also cut, copy, and delete Racks, Chassis, and Cards in the Chassis from the Layout.Note

Export Port Usage of LNI Network
Table 31: Feature History

Feature DescriptionRelease InformationFeature Name

This feature provides the
connection trace of a service across
various interfaces in a network.
This feature allows you to export
the following:

• Consolidated port usage report
based on network in addition
to the internal port details
which you can view by
hovering the mouse pointer
over the tooltip

• Port usage report based on
sites

• Port usage report only for LNI
imported networks

Cisco ONP Release 4.1Multi-Layer Connections Phase 1

Use the following procedure to export the port usage details of an LNI network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the LNI network whose port usage you want to export.

The network opens.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note
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Step 4 Click the Layout tab.
Step 5 Click the name of a site in the left side panel,for which you want to download the port usage.
Step 6 Mouse hover the Export icon and click Port Usage for Current site or All Sites.

The Export Port dialog box appears.

Step 7 Click Continue.

The port usage details are exported in the Excel sheet format.

• If you modify any services in the NCS 4000 node after upgrading the LNI network , the changes will not get
updated in the port usage details.

• The demand labels seen against the trunk ports of NCS4K-DWDM line card in the port mapping report are
not logically related to the NCS 4000 trunk ports, but are related to NCS 1004 client ports.

Note

Define Multilayer Connections for SSON Network
Table 32: Feature History

Feature DescriptionRelease InformationFeature Name

You can define Multilayer
Connections (MLC) such as cards
and pluggables for NCS 4K-1K-2K
and NCS 1K-2K aggregated nodes
in an SSON network.

This new tab in the Layout page
helps to view end-to-end MLC
trace for OTN service starting from
NCS4K IN until NCS2K
Add/Drop for LNI network. Also,
it helps to define new traces for the
newly added service and maintain
the network design and
deployment.

Cisco ONP Release 4.2NCS4K-1K-2K Multilayer
Connection Trace

Use this procedure to define the Multilayer Connections (MLC) such as cards and pluggables for 4K-1K-2K
and 1K-2K aggregated nodes in an SSON network.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network in which you want to define the multilayer connections.
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Make sure that the network is in analyzed mode and 4K, 1K, and cards are defined in the network.

The network opens.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 In the left pane, click the MLC tab.

You can also navigate to the MLC page by clicking the Ellipsis icon available in the right side of the service name in
the network tree and clicking View in MLC

You can view a table describing the following properties of the service, in the right pane:

Table 33: MLC Details

DescriptionProperties

Name of the serviceName

Name of the group to which the service belongs toGroup Name

Traffic typeType

Source siteSrc Site

Details of Rack/Slot/Card/Port in the input side of the NCS
4000 chassis in the source site

Src NCS4K In

Details of Rack/Slot/Card/Port in the output side of the
NCS 4000 chassis in the source site

Src NCS4K Out

Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the source site

Src NCS1K In

Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the source site

Src NCS1K Out

Add/Drop multiplexer and demultiplexer connected to the
NCS 2000 chassis in the source site

Src NCS2K AddDrop

Media channel between the source and destination sitesSrc NCS2K MPO

Details of Rack/Slot/Card/Port in the input side of the NCS
4000 chassis in the destination site

Dst NCS4K In

Details of Rack/Slot/Card/Port in the output side of the
NCS 4000 chassis in the destination site

Dst NCS4K Out

Details of Rack/Slot/Card/Port in the input side of the NCS
1004 chassis in the destination site

Dst NCS1K In

Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the destination site

Dst NCS1K Out
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DescriptionProperties

Add/drop multiplexer and demultiplexer that is connected
to the NCS 2000 chassis in the destination site

Dst NCS2K AddDrop

MPO cable connecting the NCS 2000 chassis in the
destination site

Dst NCS2K MPO

Media channel between the source and destination sitedMedia Channel

More notes, if anyNotes

Indicates whether the service connections are user-created
or imported through LNI.

Trace Origin

The details of source and destination NCS2K AddDrop and NCS2K MPO are not displayed for the networks
that are created in Cisco ONP Release 4.1 and migrated to Cisco ONP Release 4.2.

Note

Step 6 Click the service name to switch to the layout view.

You will view the layout and the service details in the right pane.

Step 7 Select the rack, shelf, card, and ports from the drop-down lists for NCS4K In, NCS4K Out, NCS 1K In, and NCS 1K
out, for both Source and Destination sites.

The details of the NCS 2000 chassis are auto-populated.

For LNI imported network all the details are auto-populated. If you add any new service, you can change the
details of the new service as per your requirement.

Note

Step 8 Click the Tick icon to save the changes you have done.

You can click the refresh icon to delete the changes you made after saving.

The updated details are included in the BOM.

Step 9 (Optional) To export the MLC details perform the following steps:
a) Click the Table icon to switch to the table view.
b) Choose Export > MLC Tracesto export all the details available in the MLC table.
c) Choose Export > LMP/TTI Connections to export the details of Link Management Protocol (LMP) connections

which are the connections between NCS 1004 and NCS 2000 cards, and Trail Trace Identifier (TTI) connections
which are the connections between NCS 4000 and NCS 1004 cards.

All these connections get added to the BOM.

Step 10 (Optional) Click the Filter icon to filter the services displayed in the left pane, based on the following:.

The following filter options are available:

• Source Site

• Destination Site

• Type of the traffic

• Trace Origin
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• LNI―Imported through Import Live Network option

• User Created―Created through Cisco ONP UI

• Trace Status

• Completed―User has defined all MLC details.

• Partial―User has defined only partial MLC details.

• Empty―User has not defined any MLC details.

Step 11 (Optional) Click the three vertical dots and select the following as required:

• Enable Multi Select―You can select up to the card level for different OTN.

• Expand All―Expands the services tree.

• Collapse All―Collapses the expanded services tree.

• Show Trace Status―Shows the trace status icon next to the service name.

Step 12 (Optional) Click the three horizontal dots across the service trace and select the following as required:

• Delete Trace―Deletes the respective trace.

• Locate in Map―Shows the service in the map view.

User can enable the same port number on the primary and secondaryNCS4K IN nodes for Client 1+1 and other
protection scheme.

Note
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Spectrum Utilization and Path Finder
Table 34: Feature History

Feature DescriptionRelease InformationFeature Name

The Spectrum Utilization and Path
Finder introduces the Minimal
Map, a streamlined network
visualization tool focusing on
essential data points like Sites and
Fibers, enhancing usability and
performance. General Settings
now allow individual
customization, including default
map views and spectrum utilization
colors. The Path Finder/Selector
enables interactive path selection
with options for manual and custom
path finding for multiple routing
options. The Spectrum Utilization
provides a comprehensive
visualization of used spectrum,
while the Spectrum Finder helps
locate and apply available spectrum
across fibers, offering dual-view
capabilities and multiple selection
methods. These enhancements
collectively improve network
management, planning, and
resource optimization.

Cisco ONP Release 24.3.1Spectrum Utilization and Path
Finder

Spectrum Utilization and Path Finder introduces

• Minimal Map: streamlines network visualization tool focusing Sites and Fibers.

• Path Finder/Selector: enables interactive path selection with options for manual and custom path finding.

• Spectrum Utilization: provides a comprehensive visualization of used spectrum.

• Spectrum Finder: helps to locate available spectrum across fibers and apply them on a Circuit or Media
Channel.

Find a Custom Path
The Custom Path Finder is accessible exclusively through the Minimal Map. When you choose the custom
path finder, the detailed map automatically switches to the Minimal Map.

Limitations
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• Applies to only Circuits (NCS1010/NCS1001),Waves (NCS2000NON-SSON),media channel (NCS2000
SSON).

The procedure to customize a fiber path on the map is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, select the section of the media channel/circuit that you want to add a new path.
Step 2 Click the Ellipses icon and select Custom Path Finder.

The Custom Path Finder for the selected section opens.

Step 3 In the Visualization area, choose the required map view.
ResultMap View

Shows a complete network map of the selected path with
other sites.

Complete Map

Shows only maps with chosen sites and fiber.Sub Map

Step 4 In the Options area, choose the required parameters to calculate the Path Finder.
DescriptionOption

Performs all the routing based on minimum number of hop
counts, irrespective of length of fibers

Minimum Hop

Performs all the routing based on fiber minimum length,
irrespective of hop count

Minimum Length

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Distinct Fiber Set

Calculates the number of paths based on the provided
number

Number of Path Count

Step 5 Click Calculate.

The list of paths calculated based on the chosen parameters displays.

The calculated paths table contains the path parameters.

Table 35: Path Parameters

DescriptionParameter

Displays the serial numberS.No

Displays fiber path direction based on chosen Options parametersPath

Filters the path based on fiber labelsFunnel icon
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DescriptionParameter

Provides the hop countHops

Provides the total length of the fiber pathTotal Length

Step 6 Click Export to export the chosen fiber path.
Step 7 In the Selected Service and Path area, check the service and path information and clickApply Path to apply the selected

path.

Select Path Manually
The Manual Path Selector is accessible exclusively through the Minimal Map. When you choose the manual
path selection, the detailed map automatically switches to the Minimal Map.

Limitations

• Available in Design and Upgrade modes where circuits path can be updated.

• Applies to only Circuits (NCS1010/NCS1001),Waves (NCS2000NON-SSON),media channel (NCS2000
SSON).

• Applies to regen circuits/waves/media channel.

• Additional options are applicable for Section under Network Tree.

The procedure to select a path manually on the map is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, select the section of the media channel that you want to add a new path.
Step 2 Click the Ellipses icon and select Manual Path Selection.
Step 3 In the Search field, enter the site or fiber to focus on it.
Step 4 Select the required the fibers to create a path.

The selected fibers appear on the Operation Modes pop-up pane under Fibers area.

Step 5 Click Apply.

View Spectrum Utilization and Spectrum Finder
The Spectrum Finder is accessible exclusively through the Minimal Map. When you choose the spectrum
finder, the detailed map automatically switches to the Minimal Map.

We recommend that you use the Spectrum Finder for the network in Design/Upgrade/Release Upgrade Mode
and view the Spectrum Utilization in Analyze Mode.
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The procedure to view the spectrum utilization and find a spectrum to apply for a service is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, select the section of the media channel that you want to learn the spectrum utilization per fiber.
Step 2 Click the Ellipses icon and select Spectrum Finder.

The Spectrum Finder for the selected section opens.

Step 3 In the Selected Fibers area, click +Add Fiber and choose the required fibers from the drop-down list.
Step 4 In the Visualization area, choose the required map view.

ResultMap View

Shows a complete network map of the selected path with
other sites.

Complete Map

Shows only maps with chosen sites and fiber.Sub Map

Step 5 In the Spectrum Finder area, modify the parameters as required..
DescriptionOption

Similar to Spectrum Utilization ViewTabular View

Displays multiple fibers in a vertical orientation (Y-Axis)
and the spectrum on the horizontal axis (X-Axis).

Detailed View

Enable Spectrum Selection to modify the subsequent
parameters.

Spectrum Selection

Enter the bandwidth (GHz) that is required for the network
circuit.

Spacing

Provides Distinct set of fibers. This makes sure the same
fiber is not repeated in other paths

Distinct Fiber Set

Calculates the number of paths based on the number
provided

Number of Path Count

Allows you to select overlapping wavelengths with selected
fibers, when enabled.

Allow Overlap

Zooms in and out of detailed view to granular view. Click
Defaultreset zoom.

Zoom

Displays the labels. Enable to view the labels. You can also
view the labels of existing occupied circuits.

View Labels

Shows the start, end, and central wavelengths (THz) of the
hovered spectrum when moving across the view

Hovered Spectrum
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DescriptionOption

Shows the start, end, and central wavelengths (THz) of the
selected spectrum when selecting across the view.

Selected Spectrum

Toggle to view the C-band spectrum usage.C-Band

Toggle to view the L-band spectrum usage.L-Band

Step 6 In theApply Properties to Existing Service area, check the service parameters and clickApply Wavelength andApply
Path.

Click Apply Wavelength and Apply Path to revert the changes.

Step 7 Select Apply to Service.

Regenerate BoM Automatically
You can view the new Chassis or Card added to the existing layout under the BOM tab. You can also view
the regenerated BoM after manual editing of the layout.

Add new Pluggables, Alarm Cables and 100G Client Bandwidth
Licenses to BoM

You can add new pluggables, alarm cables and 100G bandwidth licenses of NCS 1004 and NCS 4000 platforms
to the existing BoM.

The procedure to add new pluggables, alarm cables and 100G client bandwidth licenses to the existing BoM
is as follows.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.
The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the BOM tab.
Step 5 Click Add.

The New window opens.

Step 6 Enter the Cisco part number of the pluggable or alarm cable or 100G bandwidth license in the Cisco Part Number field.
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Step 7 Choose the Quantity of pluggables or alarm cables or 100G bandwidth licenses to be added.
Step 8 Click Add.

The new pluggables or alarm cables or 100G bandwidth licenses are added to the BoM list.

Export IPC Report
You can export the connections of a current site or all sites to an Excel sheet using the following procedure:

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

The network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout > IPC tabs.

You can view the patches that are listed in the left pane. Click each patch to view the details such as position, card, and
port of the source and destination sites.

The patches that you click are highlighted in the rack.

Step 5 Hover over the Export icon, and click Current site or All Sites option.

The Export IPC dialog box appears.

Step 6 Click Continue to export the connections of the current site or all sites.

The cable-type and Cable ID are included in the report only for the NCS 1010 network.
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Edit the Layout Manually for NCS 1010 Networks
Table 36: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco has introduced NCS 1010 as
a new optical line system to meet
the growing optical network needs.
Using CiscoONP you can visualize
and edit layouts for NCS 1010
chassis and patch panels.

Cisco ONP Release 5.0Layout Edit Support for NCS 1010
Networks

The Manual layout edit feature is used to adjust the position of the NCS 1010 chassis and patch panels in the
layout.

The procedure to edit the layout manually is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

You can also create a new NCS 1010 network. For more information, see Manually Design a Network Using
Cisco ONP, on page 22.

Note

Step 2 Click the network to open from the list of available networks.

Choose the NCS 1010 network.

Step 3 Choose Network > Analyze.

The network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 Click Edit to enter the Edit mode.
Step 6 In the left panel, click a site.
Step 7 Select a unit (NCS 1010 chassis or patch panel) using one of the following methods:

• In the left panel, expand the rack under a site and choose a unit.

• Or, in the Rack view, click a chassis or patch panel.

Step 8 To adjust the position of the selected units, use one of the following methods:

If necessary, click the +New Rack button to create more racks.Note

• In the Rack view, drag and drop the selected chassis or panel from a particular rack to the empty slot in the same
or different rack.
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• Swap units in the Rack view:

• Click a transponder or NCS1K14-CCMD-16 card.

The Swap with button appears.

• Click Swap with and select a slot to swap from the drop-down list.

The Swap with button appears only for NCS 1014 and NCS 1020 chassis.Note

• Cut and Paste unit in the left panel:

• Click Cut above the Rack view.

• Right-click on an empty slot in the same or different rack and click Paste.

Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

• Cut and Paste unit in the Rack view:

• Right-click the selected chassis or panel and click Cut.

• Right-click on an empty slot in the same or different rack and click Paste.

Cisco ONP disables the Paste option if you try to paste the unit in the prohibited slots.

Cisco ONP disables the Cut option if an existing cut unit is not pasted.

• Move the unit in the left panel:

• Go to Move to > Site-X > Rack-X above the Rack view to move the chassis to the same or different rack.
Or go to Move to > Site-X > + New rack above the Rack view to move the chassis to a new rack.

• Move the unit in the Rack view:

• Right-click the selected chassis or panel and go to Move to > Site-X > Rack-X to move the chassis to the
same or different rack. Or go to Move to > Site-X > + New rack to move the chassis to a new rack.

TheMove to option moves the unit automatically to the immediate empty slot. TheCut and Paste option moves
the unit to the selected empty slot.

Note

Step 9 Click Done to save the changes in the Layout.

A warning message appears when empty racks are present in the layout.

Step 10 Click OK to remove the empty racks.
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View Internal Node Connections of NCS 1010 Network
Table 37: Feature History

Feature DescriptionRelease InformationFeature Name

The Node diagram tab displays a
functional view that includes
precise connections and port
labeling of each component such
as OLT or ILA,
NCS1K-BRK-8/16/24,
AAWG-32-O, and AAWG-32-E,
for each site in an analyzed NCS
1010 network.

Cisco ONP Release 5.0View Internal Node Connections
of NCS 1010 Network

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 ChooseFileOpen.

The Select Network To Open dialog box appears.

Step 2 Click the analyzed NCS 1010 network.

The network opens.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout > Node Diagram tabs.
Step 5 Click each site in the left panel and select a side to view the functional view of the site.

The functional view includes both the combination of physical and logical connections such as:

• Degree interconnections between NCS1010 (OLT or ILA) and NCS1K-BRK-8

• Add/drop connections between NCS1010 and colorless add/drop units (NCS1K-BRK-8, NCS1K-BRK-16, or
NCS1K-BRK-24) and colored add/drop units (AAWG-32-O or AAWG-32-E)

Step 6 Hover over the cable to view the details such as name of the ports that are connected and the cable ID.
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Design Networks with SVO Card
An SVO card along with the application software provides functionality-based licenses for alarm correlation,
performance monitoring, connection verification, and Optical Time Domain Reflectometry (OTDR). You can
design a network with ROADM and TRAFFIC nodes that are equipped with SVO cards.

Features

• The SVO card is a two-slot card.

• The SVO card acts as the primary card for all the networks after Release12.1.0.

• To achieve high availability, you can have two SVO cards equipped in one node.

• You can use two 10G SFP+ pluggables to connect two SVO cards present in a node.

• You cannot have two SVO cards in the same chassis, to achieve high availability in the network.

• When designing the network, you can connect a Cisco ASR 920 Switch to the SVO cards.

• The SVO can be used as a card or as a UCS-based solution.

SVO Licenses

SVO cards require either Base License or SVO Full License (High Availability, Connection Verification,
Flex Spectrum). If you do not select SVO Full License, by default, SVO Base License and High Availability
are enabled.

The different types of SVO licenses are

• Cisco NMS: This includes features such as High Availability, Connection Verification, Flex spectrum,
and OTDR.

• Third-Party NMS: This includes features such as NBI (North Bound Interface), Alarm Correlation,
Performance Monitoring, and Circuit Provisioning.

Chassis Licensing

• Every chassis added to the network must have license after Release 12.1.0. For the release upgraded
network, a new chassis license is added after it is analyzed in Cisco ONP Release 4.0 or higher.

• There are many variants of the chassis license, such as 1-chassis, 5-chassis, 10-chassis, 20-chassis,
50-chassis, and so on. The variants of chassis license are added based on cost optimization.

• A license is required for every chassis that is added to the network after the first chassis.

• Chassis License Flush Out: You can flush out the existing chassis license and purchase a new chassis
license. If you hold the existing chassis license, the license remains active even if the site is unlocked.

• Chassis License Flush Out is supported only in the network upgrade mode.

• You can use the existing license with new changes in chassis, if you do not use the Chassis License Flush
Out option.
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Associate OLA or DGE Sites with SVO Cards
The following procedure shows how to associate OLA sites with the SVO cards:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree panel, click the Ellipsis icon available in the right side of any ROADM site.
Step 2 Click Edit SVO Associations.
Step 3 Select the OLA sites on the map to toggle the SVO connections. ClickDone at the top-right corner to confirm the selection.

You can open widgets in the map and select top section to view the association.

You can also click the Ellipsis icon available in the right side of any ROADM site from the Map and click Edit
SVO Associations. For the sites that are of DGE type, the Edit SVO Associations option is not displayed.

The tool associates the OLA and DGE sites that are not associated by you, with the SVO card during the network
analysis.

Note

Export Device NETCONF XML File
You can export the NETCONF (Network Configuration Protocol) XML files for all the individual sites in a
network or the complete network. The following procedure shows how to export NETCONF XML files for
the complete network from the Cisco ONP GUI.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.
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Table 38: Feature History

Feature DescriptionRelease InformationFeature Name

TheNETCONFXML file exported
from the NCS 1010 network design
now includes these new parameters
to support seamless Day-0
provisioning and the setup of a new
node added to the network.

• Optical cross-connects

• Gain range margin

• Tone Rates

• Raman tuning configurations

• Slot reserve

• Dmux WSS attenuation

• Unused CCMD-16 ports
shutdown

• Span baseline-deviation

• OTDR Thresholds

• APC Span-loss correction
threshold

Cisco ONP Release 24.3.1New Parameters Included in NCS
1010 NETCONF XML file

Table 39: Feature History

Feature DescriptionRelease InformationFeature Name

You can export the NETCONF
XML files for all the NCS 1010
nodes, and upload them to the NCS
1010 nodes through the Yang suite.
This enables automatic bring up of
the NCS 1010 nodes using the
NETCONF data.

Cisco ONP Release 5.0Export NETCONF File from NCS
1010 network

The network must be in Analyze mode.

Step 1 In the network tree panel, click the three dots.

A pop-up list appears.

Step 2 In the list, click Generate Device NetConf XML.

Export window appears with network name.
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Step 3 Click Export.
The message, "Success. Device NetConf exported successfully" appears.

You can download the zip file that contains NETCONF XML files of individual sites.

You can choose the destination folder to save the downloaded NETCONF XML files of individual sites.

This feature has limited scope in this release.

Note

For C+L Network, the partner band configurations are not part of the Cisco ONP-generated XML file. You must
manually configure the partner bands on the devices while bringing up the NCS 1010 C+L network.

Note

From Release 24.3.1, the following new parameters are available in the NETCONF file exported from the NCS 1010
network design:

• OSC TX Power

• Optical Cross Connect

• OTS tone rate

• OMS tone rate

• OTS tone pattern expected

• OTS tone detect OOB

• OTS tone pattern

• OTS tone frequency

• Raman pump configurations

• Line port attenuation

• Raman dual safety

The following parameters are available only when you have enabled the Enable Special Settings check box under
Network level properties.

• Raman turnup

• OTS ports shutdown

• OTDR autoscan

• Gain range margin

• OTDR excess attenuation threshold

• OTDR end of fiber threshold

• Slot reserve

• Dmux WSS attenuation

• Unused CCMD-16 ports shutdown

• Span baseline-deviation

• OTDR Thresholds
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• APC Span-loss correction threshold

Upload NETCONF XML Files on SVO Web Interface
The following procedure shows how to upload the NETCONF XML files on the SVO web interface:

Step 1 In the browser URL field, enter the IP address of the SVO line card.

The login page appears.

Step 2 Enter the username and password.
Step 3 Click Login.
Step 4 Click the hamburger icon at the top-left of the page, and select Node Configuration.
Step 5 Click the Node Setup tab.
Step 6 Click Select files .
Step 7 Browse to the NETCONF XML files exported from the Cisco ONP GUI and upload them.

If the passive unit ID in the NETCONF file exceeds the range 1–126, SVO displays an error message. Validate the XML
file and reimport.

If the value of FECmode already provisioned in the 200G-CK-C line card does not match with the value available
in the NETCONF XML file, SVO displays an error message. We recommend that you remove the provisioned
FEC settings for this card and reimport the XML file.

Note

Export Device NETCONF XML Files for Individual Sites
The following procedure shows how to export Device NETCONF XML files for individual sites from the
Cisco ONP GUI.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

The network must be in Analyze mode.

Step 1 Click the Ellipsis icon available in the right side of the site.
Step 2 In the list, click Generate Device NetConf XML.

Export window appears with network name.

Step 3 Click Export.
The message, "Success. Device NetConf exported successfully" appears.
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You can download the zip file that contains Device NETCONF XML files of individual sites.

Upload NETCONF Files to NCS 1010 Device
Use this task to upload the NETCONF files that downloaded from Cisco ONP into the NCS 1010 device using
a NETCONF client.

Step 1 Log in to the NETCONF Yang Suite which has access to the NCS 1010 device.
Step 2 Connect to the NCS 1010 device.
Step 3 Copy the NETCONF XML file content that is downloaded from Cisco ONP, and paste it into the Protocol NETCONF

Run RPC block.
Step 4 Append the following commit code at the end of the NETCONF XML file content.

<rpc xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" message-id="102">
<commit/>
</rpc>

Export Cisco Optical Site Manager NETCONF XML File
You can export the Cisco Optical Site Manager NETCONF XML files for all the individual sites in a network
or the complete network. The following procedure shows how to export CiscoOptical SiteManager NETCONF
XML files for the complete network from the Cisco ONP GUI.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Table 40: Feature History

Feature DescriptionRelease InformationFeature Name

The new Generate COSM
NetConf XML option allows you
to export from the Cisco Optical
Network Planner, the Cisco Optical
Site Manager NETCONF XML
files for all the NCS 1010 nodes.
You can then upload these files to
the NCS 1010 nodes through the
Cisco Optical Site Manager,
enabling automatic bring-up of the
NCS 1010 nodes.

Cisco ONP Release 5.2Export Cisco Optical SiteManager
(COSM) NETCONF File from
NCS 1010 network

The network must be in Analyze mode.
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Step 1 In the network tree panel, click the three dots.

A pop-up list appears.

Step 2 In the list, click Generate COSM NetConf XML.

Export window appears with network name.

Step 3 Click Export.
The message, "Success. COSM NetConf exported successfully" appears.

You can download the zip file that contains COSM NETCONF XML files of individual sites.

You can choose the destination folder to save the downloaded Cisco Optical Site Manager NETCONF XML files
of individual sites.

This feature has limited scope in this release.

Note

L-Band Configuration is not certified in Cisco Optical SiteManager for R7.11.1. A future release will be considered
for the L-Band configuration.

Note

Upload Cisco Optical Site Manager NETCONF XML to NCS 1010
Device via Cisco Optical Site Manager Web Interface

Use this task to upload the Cisco Optical Site Manager NETCONF files that you downloaded from Cisco
ONP into the NCS 1010 device using the Cisco Optical Site Manager web interface.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Log in to the Cisco Optical Site Manager UI that has access to the NCS 1010 device.
Step 2 Cross-check the device name, UID, and card layout position (Rack ID, RU Position) with CONP XML.

The Cisco Optical Site Manager device name and UID should match with the CONP XML. If any mismatch exists,
delete the device from Cisco Optical Site Manager and add back with name and UID as in the CONP XML.

Step 3 Go to Optical Setup and browse the CONP-generated XML without OXC for that device and load it.
Step 4 Click the Select files... button.

The file explorer window appears.

Step 5 Select the CONP-generated Cisco Optical Site Manager XML from your local device.
Step 6 Click Open.

A confirmation message appears.

Step 7 Click Yes.
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Step 8 Click Upload.

The COSM XML successfully uploaded message appears.

Step 9 Go to Optical Configuration > ANS parameter and verify whether the respective configurations are complete.
Step 10 After loading the Cisco Optical Site Manager XML file without optical cross connect, load the Cisco Optical Site

Manager XML with optical cross connect.
Step 11 After adding the Cisco Optical Site Manager XML file with optical cross connect, go to theOptical Cross Connections

tab and verify whether the respective configurations are complete.

Export NCS 1010 Network Planning Data for Cisco Optical
Network Controller

Table 41: Feature History

Feature DescriptionRelease InformationFeature Name

You can export the planning data
of NCS 1010 network, in the form
of a JSON file. This JSON file can
be uploaded into Cisco ONC to
configure the managed devices in
bulk.

Cisco ONP Release 5.0Export NCS 1010 Network
Planning Data for Cisco Optical
Network Controller (Cisco ONC)

Use this task to export the planning data of NCS 1010 network, which is in the form of JSON file from Cisco
ONP. This JSON file is uploaded into Cisco ONC to configure the managed devices.

You can export the planning data of NCS 1010 network only for the releases 7.7.1 and 7.9.1.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

The network must be in Analyze mode.

Step 1 In the network tree panel, click the Ellipsis icon available in the right side of the network name.
Step 2 Click Generate CONC JSON.

Step 3 In the Export File dialog box, enter the name of the JSON file.
Step 4 Click Export to download the JSON file into your local system.

Upload Planning Data into Cisco ONC
Use this task to upload the network planning data (JSON file) downloaded from the Cisco ONP.
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Step 1 Log into Cisco ONC.
Step 2 Hover over the Import icon in the left panel and click Planning Data Import.
Step 3 Click Import.
Step 4 Browse and select the JSON file that is downloaded from Cisco ONP.

You can use the planning data to configure the devices managed by Cisco ONC.
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Modify Network Properties
Table 44: Feature History

DescriptionRelease InformationFeature Name

The new network-level properties
introduced improve the accuracy of
the optical results.

• Ignore APC Penalty: When
enabled, the APC penalty is
not considered while
calculating the OSNR and
power margin.

• SOL Optimized PSD: When
enabled, an optimum PSD
value is calculated by
considering the SOL Span
losses.

Also, Cisco ONP sets PSD and
drop attenuation to specific values
for the CCMD-16 LC card
connected to the ports of the
OLT-E-C, to achieve optimal RX
power for the circuits.

Cisco ONP Release 24.3.1Improved Optical Results

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
106

Modify Network Properties
Modify Network Properties



DescriptionRelease InformationFeature Name

A new Continue Analysis On
Routing Failure check box is
introduced to improve network
analysis reliability for larger NCS
2000 networks. When a routing
failure occurs, this enhancement
moves the network to Partially
Analysed mode, and move the
network to Design or Upgrade
mode to edit properties and correct
routing.

After the analysis,

• successful routing paths
appear in the BOM and
Optical Reports tabs.

• failed routing paths are not
listed in these tabs.

• error messages for the
individual routing failures
appear in the Messages tab.

• red cross marks appear next to
the failed routing paths.

This approach prevents a single
failure from failing the entire
analysis, isolating specific issues to
enhance troubleshooting.

Cisco ONP Release 24.3.1Skip Routing Failures in NCS 2000
Network Analysis
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Table 45: Feature History

DescriptionRelease InformationFeature Name

New Network Level properties are
introduced under Advanced
Optical Settings for NCS 1010
network. You have the flexibility
to define custom values for the
following properties for the Raman
span and validate the optical circuit
feasibility.

• Amplifier Gain Range

• Connector Loss

• Minimum OSNR Margin

• Minimum Span Loss for
Raman Amplifiers

• Percentage of Fibers with
Higher Aging Loss

• Generate Cross-Connect

• Maximum OSC Reach for
NCS 1010Raman Amplifiers

• Retain Auto Placed Raman
Spans for Failure

• Freq Allocation Order

• Link Power Control

• Gain Estimator

• OTDR

Cisco ONP Release 5.2New Network Level Properties
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Table 46: Feature History

DescriptionRelease InformationFeature Name

Cisco ONP introduces the
Statistical Simulation Sigma,
Statistical Simulation Margin
Sigma, and OSNR Resolution
Bandwidth properties in this
release. When the ideal OSNR
values calculated by Cisco ONP are
not feasible to be used at the time
of deployment, you can modify the
values for these properties to
customize OSNR margin, power
margin, and G-OSNR values to fix
the fiber span issues.

Cisco ONP Release 5.1New Bandwidth Properties
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DescriptionRelease InformationFeature Name

Three new Network Level
properties are introduced to enable
you to customize the core
operations of an NCS 2000
Network. These operations ran in
the background in the earlier
releases. The new properties
available under Core Operations
as check boxes are:

• Enable LOGO
Algorithm—It runs the Local
Optimization Global
Optimization (LOGO)
algorithm to find the efficient
output power setpoint for
booster amplifiers. By default,
this Enable LOGO
Algorithm check box is
enabled.

• Log Enabled—It generates,
and stores logs only for
selected network topologies.
This saves a lot of storage
space compared to previous
implementations in which logs
were automatically generated
and saved for all topologies.

• Ignore Raman Span
Checks—It ignores the
analysis of Raman spans
between ROADM sites. This
is useful when designing
nonstandard network
topologies with more than two
Raman amplifiers between
ROADM sites. Selecting the
check box prevents Cisco
ONP from raising an error
message when analyzing such
topologies.

Cisco ONP Release 5.1New Network Level Properties
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DescriptionRelease InformationFeature Name

From this release onwards, the
BOM does not include any
UCS-based SVO server
information. It is expected that you
add the server PID and quantities
manually. Cisco ONP prompts you
to add the server by displaying the
message "UCS server is not billed
in BoM, please add it as needed."
in the Messages tab of the
Elements tab.

Cisco ONP Release 5.1BOM Customization for the
UCS-based SVO Server
Application

Use this task to modify the properties of the network.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, click the network name.

You can view the basic properties of the network at the bottom of the network tree.

Step 2 Modify the following network properties as required.

DescriptionPlatformProperty

Modify the network name as required.NCS 2000

NCS 1010

NCS 1001

Name

Check the Quick Analysis check box to quickly analyze
the network by using a less accurate algorithm.

The quick analysis option does not optimize the DCU and
amplifier placement algorithm, hence resulting in an
approximate BoM.

To receive an accurate BoM, uncheck the Quick Analysis
check box.

NCS 2000Quick Analysis
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DescriptionPlatformProperty

CiscoONP supports 100G and 200G transceivers asDWDM
interfaces.

This option is applicable only for automatically created
waves, when OTN services are present.

• 100G—The entire network chooses the 100G
wavelength for transmission.

• 200G—The entire network chooses the 200G
wavelength for transmission.

If you enable both 100G and 200G options, by default, the
entire network chooses the 200G wavelength for
transmission. If the 200G wavelength is not optically
feasible, then it selects 100G automatically for transmission.

NCS 2000DWDM Interfaces

Enter the customer name.NCS 2000

NCS 1010

NCS 1001

Customer Name

Choose ANSI (North American standard) or ETSI
(European Telecommunications Standards Institute) from
the drop-down list. ANSI networks do not allow you to
define SDH (ETSI) service demands. ETSI networks do
not allow you to define SONET (ANSI) service demands.

NCS 2000Project

Displays the type of the project, ANSI, or ETSI. You cannot
edit it.

NCS 1010

NCS 1001

Select the unit of measurement of span length. The available
options are Miles and Km.

NCS 2000

NCS 1010

NCS 1001

Measurement Unit

Choose the type of chassis. The available options are:

• NCS 1010

• NCS 1020

When you check theEnable Special Settings check
box, NCS 1020 is selected as Chassis Type by
default.

Note

NCS 1010Chassis Type

Enable this property to group all NCS1K14-CCMD-16
cards of a site in NCS1014 shelf.

NCS 1010NCS1014 Grouping
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DescriptionPlatformProperty

Choose the A2A (Any to Any) mode. The available options
are:

• A2A_None

• A2A_FAST

NCS 2000A2A Mode

The power output value is based on the chosen A2A mode.NCS 2000A2A Power Output

The demand type is based on the chosen A2A mode.NCS 2000A2A Demand Type

Choose the type of channel. You can choose multiple types.
The available options are:

• Contentionless―This property enables an N-degree
ROADM node to accommodate N wavelengths of the
same frequency from a single add or drop device.

• Colorless―The colorless property enables tuning of
channel wavelengths without changing the optical
interface of the port.

• Colored―The Colored property dedicates a separate
port for each wavelength.

NCS 2000A2A Channel Type

Indicates whether the network is an SSON network.NCS 2000SSON

Check this check box to enable the Pay As You Grow
feature on the client cards.

The PAYG feature enables you to implement a
cost-effective solution when the wavelength requirements
are comparatively less than the maximum capacity of the
network. A standard card is configured to work on
maximum supported wavelengths, whereas a PAYG license
comprises license restricted cards and a base license. So,
instead of purchasing a standard card, you can purchase a
PAYG license.

NCS 2000Use client Payg

(Display only.) By default, the Naming Convention Enabled
option is enabled by default for the networks that are created
in Cisco ONP, and you cannot edit it. By default, the sides
are named from T, S, R, Q, P, O, N, M, L, K, J, I, H, G, F,
E, and index, depending upon the used Scalable Upto
parameter.

• You can import a mpz network without naming
convention enabled, but the Cascaded SMR option
remains disabled.

• You cannot edit the label name of the side.

NCS 2000NamingConvention Enabled

System Release
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DescriptionPlatformProperty

Displays the system release of the NCS 1001 node in the
network.

NCS 1001NCS 1001

Displays the system release of the NCS 1010 node in the
network.

NCS 1010NCS 1010

Displays the system release of the NCS 4000 node in the
network.

NCS 4000NCS 4K

Displays the system release of the NCS 2000 node in the
network.

NCS 2000NCS 2K

Displays the system release of the NCS 1004 node in the
network.

NCS 1004NCS 1K (Available only on
the SSON network)

Displays the system release of the NCS 2000 node in the
network, before the Release upgrade.

NCS 2000Previous NCS 2K (Available
only on the Release upgraded
network)

Displays the system release of the NCS 1010 node in the
network, before the Release upgrade.

NCS 1010Previous NCS 1010
(Available only on the
Release upgraded network)

Choose the type of network management solution. The
available options are:

• Line Card―Chooses SVO card.

• Server―Chooses SVO application that is hosted on a
server. From Release 5.1, if you select Server, the PID
for the server does not appear in the BoM report. A
warningmessage "UCS server is not billed in the BoM,
please add it as needed." appears in the Messages tab
of the Elements tab.

• Auto―Chooses SVO card as default, for SVO solution.

NCS 2000SVO

Network Application Configuration

Enable Install with COSM to see software license for
COSM file for R7.11.1 networks.

NCS 1010Install with COSM

Check this check-box to use the x and y coordinates to
calculate the fiber length.

NCS 2000

NCS 1010

NCS 1001

Use Coordinates Distance

Check this check-box to enable the Raman tuner.NCS 1010Raman-Tuner

By default, the spectrum utilization is Short Path First. This
field is noneditable.

NCS 1010Spectrum Utilization
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DescriptionPlatformProperty

Choose the band type. The available options are:

• C-Band

• C+L Futuristic

• C+L

After creation of a network, you can change the
network band type, if required.

Note

NCS 1010

NCS 1001

Band Type

Choose the Line Card faceplate. The available options are:

• Standard Faceplate

• Enhanced Faceplate

The default option is Enhanced Faceplate. For R7.10.1
networks, Cisco ONP supports Enhanced NCS 1010 Line
Cards. For 7.11.1 networks, Cisco ONP supports Enhanced
NCS 1010 Line Cards andNCS1K14-CCMD-16-C/L cards.

NCS 1010NCS 1010 Line Card

Choose default routing priority for circuits based on
minimum distance (Length) or minimum number of hops
(Hop).

NCS 1010Routing Strategy

Choose the line card variant that will be applied to all edge
sides in the network. The options available are:

• Standard Faceplate

• Enhanced Faceplate

NCS 1010NCS1010 Line Card

Based on the number that you enter, Cisco ONP will
automatically generate up to that many Omni Edges and
run the analysis. There is no need for manual creation by
the user.

The default value is 0.

NCS 1010Max Auto Omni Allowed

Optical Algorithm Options
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DescriptionPlatformProperty

Choose the Statistical Simulation Sigma (Stat Sim Sigma)
value. The available options are 0, 1, 2, and 3. The default
value is 3.

The Stat Sim Sigma value is used in calculating the SOL
G-OSNR, EOL G-OSNR, SOL Power, EOL Power, SOL
OSNR margin, EOL OSNR margin, SOL Power margin,
and EOL Power margin displayed in the Optical Results
page. The lower the value you choose, the better is the
OSNR and power margins.

You can edit this value in Design mode, and Upgrade mode
(after unlocking the network). Analyze the network and
check theOptical Results page to view the updated OSNR
and Power values.

NCS 2000

NCS 1010

NCS 1001

Stat Sim Sigma

Choose the Stat Sim Margin Sigma value. The available
options are 0, 1, 2, and 3. The default value is 3. You can
edit this value in all modes (Design, Analyze (locked state),
Upgrade, and Release Upgrade). To view the OSNRmargin
and power values that get updated based on the value you
selected, reopen the Optical Results page.

NCS 2000

NCS 1010

NCS 1001

Stat Sim Margin Sigma

Core Operations

By default, this property is enabled. In non-SSON networks,
it is editable. In the SSON network, it is noneditable. This
algorithm enables the Cisco ONP to automatically find the
optimal output power setpoint for booster amplifiers within
a fiber span.

NCS 2000Enable LOGO Algorithm

Check this check-box to enable generation and storage of
network logs.

NCS 2000

NCS 1010

NCS 1001

Log Enabled

Check this check-box to enable network analysis to ignore
Raman span checks.

NCS 2000Ignore Raman Span Checks

Traffic Algorithm Options

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
116

Modify Network Properties
Modify Network Properties



DescriptionPlatformProperty

Check this check-box to skip routing demand failures when
analyzing the networks. Passed demands appear in the
Optical Reports tab, while failed demands are not listed in
theOptical Reports tab. Red cross marks appear next to the
failed demands in the network tree, and error messages for
these failures appear in the Messages tab. If any demand
fails during the analysis, the network enters the Partial
Analysismode. To edit the network, enter theDesignmode.

If any non-routing issue is present in the network,
then the design network will not move to thePartial
Analysis mode

Note

NCS 2000Continue Analysis On
Routing failure

Advanced Optical Settings

Check this check-box to enable the following properties
and set default values for them.

• Amplifier Gain Range Margin

• Connector Loss

• Minimum OSNR Margin

• Minimum Span loss for Raman Amplifiers

• Percentage of Fibers with Higher Ageing Loss

• Freq Allocation Order

• MC Routing Order

• Ignore APC Penalty

• SOL optimized PSD

If you check the Enable Special Settings check box, the
following parameters are added to the Device Netconf XML
file.

• Slot reserve

• Unused CCMD-16 ports shutdown

• Span baseline-deviation

• OTDR Thresholds

• Dmux WSS slice attenuation

• APC span-loss correction threshold

NCS 1010Enable Special Settings

Enter the amplifier gain range margin.

The default value is 3 dB.

NCS 1010Amplifier Gain Range
Margin
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DescriptionPlatformProperty

For all fibers the default connector loss would be set to 0.5
from 0.25.

The default value is 0.5 dB.

NCS 1010Connector Loss

Enter theminimumOSNRmargin required for the amplifier.

The default value is 1 dB.

NCS 1010Minimum OSNR Margin

This is the minimum required span loss for fiber to be
considered for Auto Raman placement.

The default value is 27 dB.

NCS 1010Minimum Span Loss for
Raman Amplifiers

Click the field and enter the values for the following fields
in the Fiber Sorting Settings window:

• Percentage of Fibers with Higher Aging Loss (default
value is 40%)

• Ageing Loss for Top Fibers (default value is 3 dB)

• Ageing Loss for Bottom Fibers (0.75 dB)

NCS 1010Percentage of Fibers with
Higher Aging Loss

Check this check-box to add Cross connect details in the
COSM XML

NCS 1010Generate Cross-Connect

Choose whether Raman amplification is Auto or User
Forced.

The default option is User Forced.

NCS 1010Raman Amplification

Choose the maximum number of Raman enabled links on
an end-to-end circuit path. The available options are 0-5,
and ALL.

NCS 1010Maximum Auto Ramans

Enter the maximum span loss for which fiber can be
considered for Auto Raman placement.

The default value is 33 dB.

NCS 1010Maximum OSC Reach for
Raman Amplifiers

Choose how to enable the Link Tuner. The available options
are Automatic-Enabled, Force-Disabled, and
On-Request-Enabled.

The default option is On-Request-Enabled, when the
Enable Special Settings check-box is checked, and the
Automatic-Enabled check-box is unchecked.

NCS 1010Link Tuner
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DescriptionPlatformProperty

By default this check-box remains checked, when the
Enable Special Settings check-box is checked. Automatic
Power Control (APC) penality occurs due to the inherent
error in regulating the set-point for power. This penalty is
considered while calculating the OSNR and power margin.
When this property is enabled, this penalty is ignored during
the calculation and thus providing accurate optical results.

NCS 1010Ignore APC Penality

In general, automatically placed Raman will be retained
only if the circuit becomes feasible with those Raman
placements. Otherwise, it will be removed automatically.
If you want to retain it, check this check-box.

It is disabled by default.

NCS 1010Retain Auto Placed Raman
Spans for Failure

Choose how to calibrate the Raman gain. The available
options are Automatic, Automatic-On-request, and
No-calibration.

The default option is No-Calibration.

NCS 1010Raman Gain Auto Tuner

By default this check-box remains checked, when the
Enable Special Settings check-box is checked. When
enabled, an optimumPSD value is calculated by considering
the SOL Span losses.

NCS 1010SOL Optimized PSD

Choose the Freq Allocation Order. The available options
are:

• FROM-LOWER-FREQ

• FROM-HIGHER-FREQ

The default option is FROM-HIGHER-FREQ.

NCS 1010Freq Allocation Order

Choose how to enable the Link Power Control. The
available options are Automatic-Enabled, Force-Disabled,
and On-Request-Enabled.

The default option is On-Request-Enabled , when the
Enable Special Settings check-box is checked, and
Automatic-Enabled when the check-box is unchecked.

NCS 1010Link Power Control

Choose how to enable the Gain Estimator. The available
options are Automatic-Enabled, Force-Disabled, and
On-Request-Enabled.

The default option is On-Request-Enabled , when the
Enable Special Settings check-box is checked, and
Automatic-Enabled when the check-box is unchecked.

NCS 1010Gain Estimator

Choose whether to enable or disable the OTDR.

The default option is Enabled.

NCS 1010OTDR
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DescriptionPlatformProperty

Choose routing order for the multicarriers:

• CREATION: Based on the Freq Allocation Order
chosen, the tool allocates frequency based on order
carrier creation.

• NO-OF-CARRIERS: Based on the Freq Allocation
Order chosen, the tool allocates frequency to circuits
based on the number of carriers.

The default option is CREATION.

NCS 1010MC Routing Order

Step 3 Click Update.
Step 4 Tomodify the advanced properties of the service, click Show Advanced Properties or chooseNetwork >Entity Editor.
Step 5 In the Entity Editor window, click the Site tab.
Step 6 Click the network, and modify the properties in the right pane.
Step 7 Click Update.

Modify Site Properties
Use this task to modify the properties of the site.

Before you begin

Table 47: Feature History

Feature DescriptionRelease InformationFeature Name

This enhancement allows you to
extend the contentionless sides in
a ROADM site, increasing the
number of provisioned
contentionless sides in the NCS
2000 networks. New contentionless
sides increase the number of traffic
channels in the NCS 2000
networks. The new Reserve
Cascaded SMR Port property
reserves more SMR ports to extend
the Layer-2 contentionless sides in
a ROADM site.

Cisco ONP Release 5.2Layer-2 SMR Enhancement to
Support Second and Third Port
Extension
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Table 48: Feature History

Feature DescriptionRelease InformationFeature Name

You can enable the Colored
Add/Drop property. This feature
supports the use of contentionless
and colored demands that are
connected to the same port of an
SMR card. With the Shared SMR
Port enabled, you can create and
validate the contentionless and
colored configuration on a
16-degree SMR-20 node.

Cisco ONP Release 4.2Shared SMR Port

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Sites, and click a site.

You can view the basic properties of the site at the bottom of the network tree.

Step 2 Modify the following site properties as required.

DescriptionPlatformProperty

General

Enter the site name, either alphanumeric or numeric.NCS 2000

NCS 1010

NCS 1001

Name

Choose the type of site. For example, ROADM, OLA,
PASSTHROUGH, or a Traffic site.

• You can add a passthrough site as a place holder. You
cannot add services or waves to this site and therefore
cannot generate the report. Later, you can convert the
passthrough site to a ROADM, OLA, or the Traffic
site in the design mode.

• OLA is an optical line amplifier site that is used only
for amplification. You cannot add service or waves on
this site.

• You cannot add a Traffic site of the type 4K-2K into
an SSON network.

NCS 2000Type

Choose the type of site. For example, ROADM, OLA, or
PASSTHROUGH.

NCS 1010

Displays the type of site.NCS 1001
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Choose the type of MPO cable. The options available are:

• Auto

• 16MPO-MPO

• 24MPO-MPO

NCS 1010MPO Cable

The default value is FLEX NG-DWDM for all nodes. This
field is noneditable.

NCS 2000Node Type

Choose the configuration from the drop-down list. This
option is available only for the Traffic site. The available
options are:

• Large CO - NCS 4016

• Small Site - NCS 4016

• Small Site - NCS 4009

NCS 2000Equipment Configuration

Choose the traffic type. The available options are:

• 4K_1K_2K (for SSON)

• 1K_2K (for SSON)

• 4K_2K (non- SSON)

NCS 2000Traffic Type (only for Traffic
site)

Indicates whether the network is an SSON network.NCS 2000SSON

This property is noneditable at site level. This property
enables you to select an SVO card as Server or Line card
at the network level.

NCS 2000SVO

Layout

Choose the type of chassis. The chassis type is supported
for all the sites except the passthrough.

The available options are:

• M6 Chassis

• M15 Chassis

• Auto

M15 is the default option when you choose Auto.

NCS 2000Chassis Type

Choose the type of chassis. The available options are:

• NCS 1010

• NCS 1020

NCS 1010
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Enable this property to group all NCS1K14-CCMD-16
cards of a site in NCS1014 shelf.

NCS 1010NCS1014 Grouping

Choose the type of Power Supply. The available options
are Auto, AC Power, and DC Power.

The default option is Auto.

NCS 2000

NCS 1010

NCS 1001

Power Supply

Choose the type of cables to be used for the AC power
supply. Cables are listed based on the country type and the
Chassis type selected.

NCS 2000

NCS 1010

NCS 1001

UTS AC Power Cables

C Band

Choose the type of the site. The available options for
ROADM and Traffic sites are:

• Multi-degree

• Line

• Terminal

For OLA and PASSTHROUGH, it is Line, and you cannot
edit it.

NCS 2000Structure

Choose the type of the site. The available options for
ROADM sites are:

• Multi-degree

• Line

• Terminal

For OLA and PASSTHROUGH, it is Line, and you cannot
edit it.

NCS 1010

Choose the type of the site. The available options are:

• Terminal

• Terminal-Section

• Terminal-Path

NCS 1001
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Displays the site functionality. Following is the functionality
available for each type of sites:

• Optical Cross Connect (OXC) for ROADM and traffic
site

• Auto or Line Amplifier for OLA site, Cisco ONP
downgrades OLA site to passthrough if OLA is not
required.

• Passthrough for passthrough site

NCS 2000Functionality

Displays the site functionality. ROADM is the default
functionality for all site types.

NCS 1010

Displays site functionality.NCS 1001

This parameter determines themaximumnumber of degrees,
ducts, or line sides that can be supported by the site.

For an NCS 2000 site, the available options are 2, 4, 8, 12,
and 16. The default option is 4. The network is scalable up
to 16 degrees for ROADM and Traffic sites. Choose 2 to
have a LINE ROADM site.

For OLA, the value is 2 and is noneditable.

NCS 2000Scalable up to Degree

For an NCS 1010 site, the available options are 7, 9, 15,
17, 23, 25, and 31.

If you chooseLine Card Faceplate asEnhanced Faceplate,
for NCS 1010 site, the available options are 3…15, 23, and
31.

NCS 1010

Choose the type of site. The available options are:

• Auto

Note When you choose Auto, the default option is
SMR-20.

• SMR-20

• SMR-9

The Site type is Line for the OLA site.

NCS 2000Site Type

For NCS 1010 site, the only option is OLT, and it is not
editable.

NCS 1010

Displays the type of site, and it is noneditable.NCS 1001
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DescriptionPlatformProperty

Displays the platform. For example, NCS 1010 , NCS 1001,
or NCS 2000.

NCS 2000

NCS 1010

NCS 1001

L0 Platform

Step 3 Click Update.
Step 4 To modify advanced properties of the site, click Show Advanced Properties, or choose Network > Entity Editor.
Step 5 In the Entity Editor window, expand Sites under the network tree, choose the site, and modify the following properties

that are displayed in the right pane. For more information on entity editor, see Entity Editor, on page 262.

DescriptionPlatformProperties

General

Enter a string holding the CLLI code.NCS 1004

NCS 2000

NCS 4000

CLLI Code

Enter the site address.NCS 2000

NCS 1010

NCS 1001

Site Address

By default, this option is unchecked. When you enable this
feature on the network, it is automatically enabled on the
associated sites of the network.

NCS 2000Evolved Mesh

Displays the status of the network. It shows whether the
network is Up or Down.

NCS 2000Status

Choose the Node Protection. The available options are:

• Same shelf

• Separated shelves

NCS 2000Node Protection

Displays the fan-out module. The default option is
MF-MPO-16LC.

The MPO-16 to 16-LC fan-out module is a double slot
module with one MPO-16 connector (COM) and eight LC
duplex connectors. The MPO-16 connector is compatible
with the SMR20 FS EXP and 16-AD-CCO FS units.

NCS 2000Mpo16Lc

Choose the required Mpo16 to Mpo8 converter. The
available options are:

• MPO16ToMPO8Cable

• MF-2MPO_ADP

NCS 2000Mpo16ToMpo8
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Choose the required Mpo cable. The available options are:

• Auto

• 16MPO-MPO

• 24MPO-MPO

NCS 1010MPO Cable

Enable this option to add Layer-2 contentionless sides.NCS 2000Cascaded SMR

This property becomes available when you enable
Cascaded SMRfor NCS 2000 networks from
Release 11.1.x.

Note

Choose the number of ports to reserve for the cascaded
SMR. The available options are:

• 1, 2, and 3 if Scalable Upto Degree is 12 and 16.

• 1 and 2 if Scalable Upto Degree is 8.

• 1 if Scalable Upto Degree is 12 and 4.

NCS 2000Reserve Cascaded SMRPort

By default, this check-box remains checked for a newly
created network. You cannot edit it.

NCS 2000Flex Spectrum

When you enable this option, it indicates that OTN traffic
can be groomed at this site.

NCS 2000

NCS 4000

Grooming Site

Check this check box to use the ONS-MPO-MPOLC-10
breakout cable to interconnect the client ports of the
MR-MXP card with the NCS2K-MF-MPO-20LC passive
module.

NCS 2000MR-MXP BreakOut Cable

Check this check box to use the NCS2K-MF-8X10G-FO
passive module only for 10G on the client-side of the
NCS2K-400G-XP card. By default, this passive module is
enabled.

NCS 20008X10G-FO

Choose the required band type for NCS 1010 R7.9.1.NCS 1010

NCS 1001

Band Type

Choose whether the Line Card faceplate is Standard
Faceplate or Enhanced Faceplate.

If you assigned a Scalable Upto Degree value that
is supported for both standard and enhance at the
site level, then you can select Standard Faceplate
in one side andEnhanced Faceplate in another side.

Note

NCS 1010NCS 1010 Line Card

Bill of Material
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DescriptionPlatformProperties

Choose whether the License Suite is Essential (RTU +
SIA3) or Advanced (RTU + SIA3).

NCS 1010License Suite

Choose whether the License Suite is:

• Essential (RTU + SIA3)

• Advanced (RTU + SIA3)

• Essential (RTU + SIA5)

• Advanced (RTU + SIA5)

NCS 1010NCS1k Line card license

This feature enables NCS features on all sites in the network.NCS 2000Enable NCS

The Pay As You Grow (PAYG) functionality significantly
reduces the initial setup cost and enables the purchase of
another wavelength capacity on a need basis.

PAYG enables port-based cost or licensing for SMR-9 and
SMR-20 cards.

NCS 2000Use PAYG

Enable this check box to:

• Validate the correct optical interconnection between
the optical cards inside a Flex ROADM.

• Measure the insertion loss of the external passive path.

• Validate the quality of the connections to the patch
panel.

• Check if the insertion loss is within the expected value.

The following cards support connection verification:

• SMR20 FS CV

• MF-DEG-5-CV

• MF-MPO-16LC-CV

• MF-UPG-4-CV

NCS 2000Connection Verification

By default, this check-box remains checked for newly
created network. You cannot edit it. This option enables
displaying of the new SMR-20 PID in the BOM page.

You can enable this option when you unlock an mpz
network where SMR-20 is selected, during an upgrade or
release upgrade.

NCS 2000New FS-SMR PID

Layout
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DescriptionPlatformProperties

Choose the type of chassis. The available options are:

• M6, and M15 Chassis for OLA

• M6 Chassis for ROADM and Traffic

• M15 Chassis for ROADM and Traffic

• Auto for all nodes

Chassis type is not supported for the passthrough
site.

Note

NCS 2000Chassis Type

Choose the type of chassis. The available options are:

• NCS1010

• NCS1020

NCS 1010

Enable this property to group all NCS1K14-CCMD-16
cards of a site in NCS1014 shelf.

NCS 1010NCS1014 Grouping

Choose the type of Power Supply.

For an NCS 2000 site, the available options are based on
the chassis type:

• Auto for all types of chassis

• AC Power, DC power for M15 and M2 chassis

• AC Power, DC Power, AC2 Power, DC40 Power, and
DC20 Power for M6 chassis

NCS 2000Power Supply

The options available for the NCS 1010 site are Auto, AC
Power, and DC power.

NCS 1010

NCS 1001
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Choose the type of the controller card.

For an NCS 2000 site, the default controller card is TNCS-2.
The available options are based on the chassis type chosen.
By default, controller cards that are supported by M15
chassis are listed. The available options are:

• Auto

• TNC/TSC, TNC-E/TSC-E, TNCS, TNCS-0, TNCS-2,
and TNCS-20 for M2 chassis

• TNC/TSC, TNC-E/TSC-E, TNCS, TNCS-0, TNCS-2,
and TNCS-20 for M6 chassis

• TNCS, TNCS-0 TNCS-2, TNCS-20 for M15 chassis

NCS 2000Controller Card

The following options are available for the NCS 1010 site:

• Auto

• NCS1010-CNTRL-K9

• NCS1010-CNTRL-B-K9

NCS1010-CNTRL-B-K9 appears for networks from
R7.11.1.

If you enable Advanced Optical Settings, Cisco
ONP takes the default controller card as
NCS1010-CNTRL-B-K9, elseNCS1010-CNTRL-K9.
However, you can still change the controller later.

Note

NCS 1010

CONP takes NCS1K-CNTLR2 as default.NCS 1001

Choose whether to use a redundant controller card.

When you select Chassis Type as NCS1020, you
can force Redundant Controller Card to Yes.

Note

NCS 2000

NCS 1010

NCS 1001

Redundant Controller Card
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Choose the required layout template.

After the chosen layout template is applied, all
layout properties will be reset and disabled.

Note

After design analysis, if the applied layout template
is not considered for card placement in the layout,
check for the error message (non-critical) under the
Elements > Messages tab. If you see a
template-related error which indicates that there is
a mismatch between the cards that are defined in
the template and the cards that are created on the
site, perform the following:

Note

• Export the template from the Layout page,
and modify it as required.

• Import the modified template using the
Manage > Layout Template option.

• Switch to Designmode and apply the template
to the site using the Entity Editor.

• Reanalyze the network to get the correct layout
populated.

NCS 2000Layout Template

Choose the type of cables to be used for the AC power
supply. Cables are listed based on the country type and the
Chassis type selected.

NCS 2000

NCS 1010

NCS 1001

UTS AC Power Cables

Choose the redundant power scheme from the drop-down
list to configure the number of working and protected power
units for the chassis.

For an NCS 2000 site, the options available are based on
the chassis type. For M15 chassis, the options available are
1+0, 1+1, 2+0, 2+1, 3+0, 3+1, 2+2, 3+1 is the default
redundancy power scheme for M15 DC chassis and 2+2 is
the default redundancy power scheme for M15 AC chassis.
For example, if you choose 3+1 redundant power scheme,
there are 3 working power units and 1 protected power unit.

For an M6 chassis, the options available are Auto, Yes, and
No.

NCS 2000Redundant Power Scheme

The options available are Auto, 1+0, and 1+1.NCS 1010

NCS 1001
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This option is available only for the OLA site. By default,
this check box remains checked. This option indicates that
MF-2LC-ADP can be shared with EDRA amplifiers and
not with RAMAN amplifiers irrespective of the default
selection.

NCS 2000Raman Adapter Share

Choose the External Connection Unit (ECU) type from the
drop-down list. The options available are based on the
chassis type. By default, the ECU applicable for M15 is
listed.

• ECU—Has 12 USB 2.0 ports and supports
IEEE1588v2 PTP, time-of-day (ToD), and
pulse-per-second (PPS) inputs.

• ECU-S—Similar to ECU except that it has eight USB
2.0 ports and two USB 3.0 ports.

• ECU60-S—Variant of ECU-S introduced for the NCS
2006 when the shelf is powered at –60VDC nominal
input voltage.

ECU-S and ECU60-S are supported only for M6 chassis.

NCS 2000ECU Type

Choose the mechanical frame for the passive optical
modules from the drop-down list. The options available are
Auto, MF-6RU/MF-10RU, and MF-1RU.

• The NCS2K-MF-1RU has four slots for the passive
optical modules.

• The NCS2K-MF-6RU supports up to 14 single-slot
passive optical modules such as any combination of
NCS2K-MF-DEG-5,CS2K-MF-UPG-4, orConnection
Verification (CV) units.

• The NCS2K-MF10-6RU supports up to 10 double-slot
passive optical modules such as
NCS2K-MF-MPO-16LC=.

NCS 2000MF Unit

For NCS 1010 site, the available options are Auto,MF-4RU,
and MF-1RU.

NCS 1010

MF-1RU is the default option. This property is noneditable.NCS 1001

If you check this check-box, ROADM, and transponder
cards are placed in different chassis.

NCS 2000Chassis Disaggregation

Map

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
131

Modify Network Properties
Modify Site Properties



DescriptionPlatformProperties

It represents the longitudinal location of the site. Longitude
can be positive or negative (-180 to 180). Negative is west
of Greenwich, and positive is eastward.

NCS 2000

NCS 1010

NCS 1001

X Coordinate

It represents the latitudinal location of the site. Latitude can
be positive or negative (- 90–90), north and south of the
Equator.

NCS 2000

NCS 1010

NCS 1001

Y Coordinate

Check this check box to lock the site position on the map.NCS 2000

NCS 1010

NCS 1001

Position Lock

C Band

Check this check box to connect Contentionless unit
16-AD-CCOFS and Colored unit MD-48-ODD/Even to the
same MPO port of SMR-20. When Shared SMR port is
enabled, MD-48-ODD/EVEN unit connects to the specific
side of SMR-20 through MPO-8LC and UPG-4 instead of
directly connecting to SMR-20 through MPO-16LC.

Shared SMR port becomes disabled, ifNote

• Degree Mesh Type property is
PPMESH8-5AD

• Or, Site Type property is SMR-9 and Scalable
Upto Degree property is 8

NCS 2000Shared SMR Port

Choose the mesh type for the Flex NG-DWDM site. The
available options are:

• DEG-5/UPG-4

• PPMESH8-5AD

DEG-5/UPG-4 is the default value.

NCS 2000Degree Mesh Type

Displays the type of degree. For example, BRK-8.NCS 1010Degree Type

This parameter determines the number of degrees to be
considered for the site hardware placement on day 0.

For NCS 2000, the values can be None, Auto, 4, 8, 12 or
16. The default option is None. If you choose None, only
the sides that are present in the Cisco ONP GUI are shown.
The values in the drop-down list are populated based on the
value of Scalable Upto Degree parameter.

NCS 2000Pre Equip Degree

For NCS 1010 site, the options available are Yes and No.NCS 1010
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SVO

Allows you to flush out the existing chassis license and
purchase a new chassis license.

NCS 2000Chassis License Flush Out

You can choose one of the following options from the
drop-down list.When you chooseAuto, ONS_SC+-10G_SR
is the default option.

• Auto

• ONS-SC +- 10G-SR

• ONS-SC +-10G-LR

The SVO pluggables are not applicable for
UCS-based SVO network design.

Note

NCS 2000SVO Pluggables

Cisco NMS

Enable this check box to add High Availability (Feature
and License), Connection Verification license, Flex
Spectrum license, and OTDR license packaged in it.

NCS 2000SVO Full License

Enable this check box to add the High Availability feature
to the license package.

NCS 2000High Availability

Enable this check box to add the Connection Verification
feature to the license package.

NCS 2000Connection Verification
License

Enable this check box to add the Flex Spectrum feature to
the SVO license package. For SSON networks, the Flex
Spectrum license is enabled by default.

NCS 2000SVO Flex Spectrum License

Enable this check box to add the OTDR feature to the
license package.

NCS 2000OTDR License

3rd party NMS

Enable this check box to add NBI (North Bound Interface),
Alarm Correlation, Performance Monitoring, and Circuit
Provisioning features to the license package.

NCS 20003rd party Full License

Enable this check box to add the NBI feature to the license
package.

NCS 2000NBI

Enable this check box to add the Alarm Correlation feature
to the license package.

NCS 2000Alarm Correlation

Enable this check box to add the Performance Monitoring
feature to the license package.

NCS 2000Performance Monitoring
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Enable this check box to add the Circuit Provisioning feature
to the license package.

NCS 2000Circuit Provisioning

Enhanced Face Plate Options

Choose the port type for interconnect degree priority. The
available options are:

• LC Ports

• MPO Group

The default option is LC Ports.

This field appears only when you selectNCS 1010
Line Card as Enhanced Faceplate.

Note

NCS 1010Degree Priority

This property is noneditable and appears for networks from
R7.11.1.

NCS 1010Add/Drop Shelf Type

Step 6 Click Update.

Add Contentionless Side to a Site
Contentionless functionality on a site refers to the contentionless add or drop ability of an N-degree ROADM
node to accommodate N wavelengths of the same frequency from a single add or drop device. For a ROADM
to be contentionless, the number of drop units must be equal to ROADM degrees.

Use the following procedure to add contentionless sides to a ROADM or traffic site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to add contentionless sides to a site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 Click the site to which you want to add contentionless sides.
Step 5 Click the Add Contentionless Side icon.
Step 6 Enter the appropriate value in the Enter number of contentionless sides field.

The number of contentionless sides that can be added to a site depends on the type of site, the Scalable Upto Degree
property. The following table explains the same.
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Table 49: Contentionless Sides for Layer-1 SMR

Number of Contentionless SidesScalable Upto DegreeSite Type

164SMR-20

128SMR-20

812SMR-20

416SMR-20

8LineSMR-20

8TerminalSMR-20

54SMR-9

18SMR-9

Step 7 To add layer-2 SMR-20 contentionless sides, perform the following steps:
a) Check the Evolved Mesh check box.
b) Choose Site Type as SMR-20 or Auto.
c) Check the Cascaded SMR check box.
d) Choose Degree Mesh Type as DEG-5/UPG-4.
e) Click Update.

You can add 20 more contentionless sides on each site for layer-2 SMR.

Step 8 To add an extended layer-2 SMR-20 contentionless side, choose the Reserve Cascaded SMR Port value.

The Reserve Cascaded SMR Port drop-down property is available for NCS 2000 networks from R11.1.x.Note

Based on the N-degree and Layer-2 SMR, you can add more contentionless sides on each site for the extended layer-2
SMR, sacrificing some Layer-1 contentionless sides. The following table explains the same.

Table 50: Contentionless Sides for Extended Layer-2 SMR

No. of
Contentionless Sides
with 3rd Port Layer-2

No. of
Contentionless
Sides with 2nd Port
Layer-2

No. of
Contentionless
Sides with 1st Port
Layer-2

No. of Contentionless
Sides for Layer-1 Side

Scalable
Upto
Degree

Site TypeReserve
Cascaded
SMR
Port

UnsupportedUnsupported20164SMR-201

UnsupportedUnsupported20128SMR-20

UnsupportedUnsupported20812SMR-20

UnsupportedUnsupported20416SMR-20
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No. of
Contentionless Sides
with 3rd Port Layer-2

No. of
Contentionless
Sides with 2nd Port
Layer-2

No. of
Contentionless
Sides with 1st Port
Layer-2

No. of Contentionless
Sides for Layer-1 Side

Scalable
Upto
Degree

Site TypeReserve
Cascaded
SMR
Port

UnsupportedUnsupportedUnsupportedUnsupported4SMR-202

Unsupported2020118SMR-20

Unsupported2020712SMR-20

Unsupported2020316SMR-20

UnsupportedUnsupportedUnsupportedUnsupported4SMR-203

UnsupportedUnsupportedUnsupportedUnsupported8SMR-20

202020612SMR-20

202020216SMR-20

Step 9 Click OK.

Modify Number of Contentionless Side Ports for a Site
Use this task to modify the number of contentionless ports for a side in a ROADM site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to modify the number of contentionless ports for a side in a ROADM site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 Expand a ROADM site and select a contentionless side.

You can view the properties of the side in the right panel.

Step 5 From the Contentionless Ports drop-down list, choose the required number of ports.

Click Update.

Modify Contentionless Side to a Site in Upgrade Mode
Use the following procedure to modify contentionless sides to a ROADM or traffic site in upgrade mode.
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Limitation

• Supports networks from R11.1.x.

• NCS 2000 networks have the limitation of Passive units count up to 126. When you add the second and
third L2 contentionless sides, the passive units count goes beyond the limit. In such cases, the tool allows
the analysis and notifies the limitation via an error message, The passive units in this design (count) has
exceeded the maximum supported passive units on the NE SW (126). Please review the design with Cisco
before proceeding for deployment.

Before you begin

Set the following conditions.

1. Enable Evolved Mesh.

2. Set Site Type as SMR-20 or Auto

3. Enable Cascaded SMR.

4. Set Degree Mesh Type as DEG-5/UPG-4.

5. Set Scalable Upto Degree.

If the above Prerequisites are not met, you must unlock the site to modify the contentionless sides.

Step 1 Choose Network > Entity Editor.
Step 2 Click the site to which you want to modify the contentionless sides.
Step 3 Check the Cascaded SMR check box if not enabled already.

The Reserve Cascaded SMR Port drop-down appears.

Step 4 Choose the SMR port value in Reserve Cascaded SMR Port.

To reduce the Layer-2 SMR sides:

a. Choose a lower value.

b. Click Update.

If SMR ports are available, the update becomes successful. Else, an error message appears. Perform the following
actions:

1. Unlock the site.

2. Start over from Step 1.

To increase the Layer-2 SMR sides:

a. Choose a higher value.

b. Click Update.

If SMR ports are available, the update becomes successful. Else, an error message appears. Perform the following
actions:

1. Unlock the site.
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2. Delete the lowest contentionless side in Layer-1 SMR site.

3. Start over from Step 1.

Step 5 Click the site to which you want to add contentionless sides.
Step 6 Click the Add Contentionless Side icon.
Step 7 Enter the appropriate value in the Enter number of contentionless sides field.

The number of contentionless sides that can be added to a site depends on the type of site, the Scalable Upto Degree
property.

Step 8 Click OK.

Add L-Band Side to a Site
Use the following procedure to add L-Band sides to an NCS 1010 R7.9.1 site:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to add the L-Band sides to a site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 To add the L-Band sides, choose one of the following options:

• Click the site to which you want to add the L-Band sides.

If you add an L-Band side to a site, the corresponding attached sides from other sites also automatically add
L-Band sides. A pop-up message appears to indicate the addition of L-Band sides.

Note

• Or, expand the site and click on a side to add L-Band to the selected side only.

Step 5 Click the Add L-Band icon.

The L-Band side appears under the required site or side.

If ILA or pass-through sites are present in APC domain, then the end-to-end path in the L-band becomes enabled
automatically.

Note
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Add Omni-Directional Side to a Site
Table 51: Feature History

DescriptionRelease InformationFeature Name

You can now include both colorless
and colored omnidirectional
configurations when designing an
NCS 1010 network.

New Properties Added:

• Add Omni-Directional icon
(under Entity Editor): Use this
icon to add the required
number of omnidirectional
sides.

• Omni Variant (under Side
Properties): Select the desired
Add/Drop stage, such as Dual
OLT or 4x4 COFS.

• Max Auto Omni Allowed
(under Network Properties):
Cisco ONP automatically
generates the omni edges
based on the number entered.

This omnidirectional setup
enhances the flexibility of the
multidegree topology, allowing
channels to be routed through any
optical degree during a fiber cut
without needing physical fiber
reconnections.

Cisco ONP Release 24.3.1Omnidirectional Configuration
Support for NCS 1010 Network

The omnidirectional configuration allows you to add/drop traffic to/from any of the node directions in a
multidegree topology. This configuration gives flexibility to the multidegree topology to route channels
through any of the optical degrees during fiber cut without the need for changing the physical fiber connections.

Omni edges are not supported on a Terminal site.Note

Use the following procedure to add omnidirectional sides to an NCS 1010 site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.
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The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to add contentionless sides to a site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 Click the site to which you want to add contentionless sides.
Step 5 Click the Add Omni-Directional icon.
Step 6 Enter the appropriate value in the Enter number of Omni Directional sides field.

The number of omnidirectional sides that can be added to a site depends on the Scalable Upto Degree property.

Step 7 Click OK.

The omnidirectional sides are created under the site and are labeled as omni-1, and omni-2 and so on. Also, a tag called
Omni is added to the Omni side to indicate it as an omnidirectional side.

You can add L-band functionality to the side by clicking the Add L-Band icon.

Cisco ONPwill automatically generate up to the number of Omni Edges specified in theMax Auto Omni Allowed
field under Network properties. Manual creation by the user is not required.

Note

Modify Fiber Properties
Use this task to modify the properties of fiber.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 In the network tree, expand Fiber, and select a fiber or click a fiber on the map. The selected fiber will be highlighted in
orange.

You can view the basic properties of the fiber at the bottom of the network tree.

Step 2 Modify the following fiber properties as required.

DescriptionPlatformProperty

General

By default, the name of the fiber is based on the number of
fibers between the source and destination sites. You can
edit the name.

NCS 2000

NCS 1010

NCS 1001

Name

Displays the source site name. This field is noneditable.NCS 2000

NCS 1010

NCS 1001

Source
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DescriptionPlatformProperty

Displays the destination site name. This field is noneditable.NCS 2000

NCS 1010

NCS 1001

Destination

Indicates whether a standard single fiber is used to transmit
the data in both directions.

NCS 2000

NCS 1010

NCS 1001

Bidirectional
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DescriptionPlatformProperty

Select the fiber type. Cisco ONP supports the following
fibers, and the default fiber type is G652-SMF.

• G652-SMF

• G652-SMF-28E

• True Wave Reach

• True Wave RS

• True-Wave Plus

• True-Wave Minus

• True-Wave Classic

• Free-Light

• Tera-Light

• Metro-Core

• ELEAF

• NDSF

• ALLWave

• SMF-28 ULL

• SMF28-Ultra

NCS 2000Fiber Type

NCS 1010
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DescriptionPlatformProperty

Select the fiber type. Cisco ONP supports the following
fibers, and the default fiber type is G652-SMF.

• G652-SMF

• G652-SMF-28E

• True Wave Reach

• True Wave RS

• True-Wave Plus

• True-Wave Minus

• True-Wave Classic

• Free-Light

• Tera-Light

• Metro-Core

• ELEAF

• NDSF

• ALLWave

• SMF-28 ULL

• SMF28-Ultra

• G652-SMF

• G652-SMF-28E

• True Wave Reach

• True Wave RS

• Free-Light

• Tera-Light

• ELEAF

NCS 1001
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DescriptionPlatformProperty

Displays the span length of the fiber connecting a source
and destination site. If necessary, change the span length
manually.

• The Cisco ONP tool automatically updates the fiber
length to 1 km or 1 mile. If you change the fiber length,
then the tool updates the same in the network tree and
the map accordingly.

• In the network tree pane, expand Fiber and select the
fiber couple, A-Z and Z-A. The properties pane
displays the fiber couple name, source side, destination
side, its span length, loss, and, Polarization Mode
Dispersion (PMD) value.

• You can enter the different span length and loss values
for the individual fibers in a fiber couple.

NCS 2000

NCS 1010

NCS 1001

Length

Displays the status of the network, whether the network is
being deployed or not. If the network is not deployed, it
shows the status as UNDISCOVERED.

NCS 2000

NCS 1010

NCS 1001

Network status

Displays the status of the fiber in a business perspective
view. If fiber is not deployed, it shows the status as
FUTURE. This field is noneditable.

NCS 2000

NCS 1010

NCS 1001

Business status

Choose the measurement unit (Km or Miles) for the fiber
span. You can set the measurement unit only for the duct,
but not for the fiber pair (couple) or fiber.

NCS 2000

NCS 1010

NCS 1001

Measurement Units

Enter the aging loss value for the fiber.NCS 2000

NCS 1010

NCS 1001

Ageing Loss [dB]

Check this check box to enable the default use of data
connection network (DCN) extension on each span in the
project. This setting implies that the optical service channel
(OSC) channel is not used to connect the two nodes.

NCS 2000

NCS 1010

NCS 1001

DCN Extension
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DescriptionPlatformProperty

Choose the OSC frame type. The options available are:

• Auto

• OC3 Frame

• GE Frame

• FE Frame

The default option is Auto. When set in Auto, Cisco ONP
uses FE Frame as the preferred frame type.

NCS 2000OSC FrameType

Enter the number to fiber aging factor.NCS 2000

NCS 1010

NCS 1001

Ageing Factor

Physical

The fiber loss value is automatically calculated based on
length and loss coefficient, when you check this option.

NCS 2000

NCS 1010

NCS 1001

Length-Based Loss

Enter the start of life fiber loss value for each span,
excluding the connector concentrated loss.

NCS 2000

NCS 1010

NCS 1001

Tot SOL Loss w/o
connectors

Raman Amplification

Enable Raman Amplification on the ducts.

When you enable Raman amplification for NCS
2000 system release 12.2, the side property Enable
C+L Band S/C is automatically disabled and vice
versa.

Note

NCS 2000Raman Amplified

Step 3 Click Update.
Step 4 To modify the advanced properties of the fibers, click Show Advanced Properties, or chooseNetwork > Entity Editor.
Step 5 Click the FIBER tab in the Entity Editor window.
Step 6 Choose the fiber and modify the following properties in the right pane.

DescriptionPlatformProperty

General

Enter the aging loss value.NCS 2000

NCS 1010

NCS 1001

Ageing loss [dB]
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DescriptionPlatformProperty

Enable the default use of data connection network (DCN)
extension on each span in the network.

NCS 2000

NCS 1010

NCS 1001

DCN Extension

Choose the OSC frame type. The options available are Auto,
OC3 Frame, Gigabit Ethernet Frame, and Fast Ethernet
Frame. The default option is Auto.When set in Auto, Cisco
ONP uses Fast Ethernet Frame as the preferred frame type.

NCS 2000

NCS 1010

OSC Frame Type

Enter the number to factor fiber aging. This factor is
multiplied by the SOL total span loss without connectors.

NCS 2000

NCS 1010

NCS 1001

Aging Factor

Physical

Connector Loss at Source Site [dB]NCS 2000

NCS 1010

NCS 1001

Connector Loss A

Connector Loss at Destination Site [dB]NCS 2000

NCS 1010

NCS 1001

Connector Loss B

Factors

Loss is calculated based on the loss coefficient.NCS 2000

NCS 1010

NCS 1001

Loss Coefficient [dB/km]

Displays the PMD coefficient.NCS 2000

NCS 1010

NCS 1001

PMD Coefficient

Displays the secondary order dispersion for C-band.NCS 2000

NCS 1010

NCS 1001

QD C-Band

Displays the secondary order dispersion for L-band.NCS 2000

NCS 1010

NCS 1001

CD C-Band
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DescriptionPlatformProperty

Displays the random dispersion value.NCS 2000

NCS 1010

NCS 1001

RD Factor

Extended

Displays the effective mode area [µm^2]NCS 2000

NCS 1010

NCS 1001

Effective Mode Area

Displays the Stimulated Raman Scattering tilt coefficient
on the band.

NCS 2000

NCS 1010

NCS 1001

SRS tilt coefficient

Displays the Rayleigh Scattering capture coefficient.NCS 2000

NCS 1010

NCS 1001

DRBS coefficient

Nonlinear index of refraction [1e-16 cm^2/W]NCS 2000

NCS 1010

NCS 1001

N2

Length of individual fibers for sigmaDSP [Km]NCS 2000

NCS 1010

NCS 1001

LFBR

Totals

(The properties under Totals are noneditable)

Displays the total loss EOL calculation.NCS 2000

NCS 1010

NCS 1001

Loss EOL

Displays the total loss SOL calculation.NCS 2000

NCS 1010

NCS 1001

Loss SOL

Displays the total chromatic dispersion for the C-band.NCS 2000

NCS 1010

NCS 1001

CD C-Band
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DescriptionPlatformProperty

Displays the secondary order dispersion for C-band.NCS 2000

NCS 1010

NCS 1001

QD C-Band

Displays the random dispersion value.NCS 2000

NCS 1010

NCS 1001

RD

Displays the Polarization Mode Dispersion (PMD) value.NCS 2000

NCS 1010

NCS 1001

PMD

Step 7 Click Update.

Modify Fiber Couple Properties
Use this task to modify properties of the fiber couple.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Fiber, and drill down up to a fiber couple and click the fiber couple.

You can view the basic properties of the fiber couple at the bottom of the network tree.

Step 2 Modify the following fiber couple properties as required.

DescriptionPlatformProperty

General

By default, fiber couple is named based on the fiber name
followed by COUPLE-AZ or COUPLE-ZA. The sides that
are connected by the fiber couple are indicated inside
brackets. The name is noneditable.

• NCS 2000

• NCS 1010

• NCS 1001

Name

Displays the source side name. This field is noneditable.• NCS 2000

• NCS 1010

• NCS 1001

Source Side
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DescriptionPlatformProperty

Displays the destination side name. This field is noneditable.• NCS 2000

• NCS 1010

• NCS 1001

Destination Side

Automatically displays the span length of the fiber
connecting a source and destination side. Change the span
length manually, if necessary.

You can enter the different span length and loss values for
the individual fibers in a fiber couple.

• NCS 2000

• NCS 1010

• NCS 1001

Length

Factors

Enter the value of the SOL fiber loss per kilometer used to
calculate the loss of each span in the network.

• NCS 2000

• NCS 1010

• NCS 1001

Loss coefficient [dB]

Totals

Displays the total loss SOL calculation.• NCS 2000

• NCS 1010

• NCS 1001

Loss SOL

Displays the total loss EOL calculation.• NCS 2000

• NCS 1010

• NCS 1001

Loss EOL

Physical

Enter the start of life fiber loss value for each span,
excluding the connector concentrated loss.

• NCS 2000

• NCS 1010

• NCS 1001

Tot SOL Loss w/o
connectors

Step 3 Click Update.
Step 4 To modify advanced properties of the fiber couple, click Show Advanced Properties, or choose Network > Entity

Editor.
Step 5 Click the FIBER tab in the Entity Editor window.
Step 6 Choose the fiber and drill down to the fiber couple, and modify the following properties in the right pane.

DescriptionPlatformProperty

Physical
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DescriptionPlatformProperty

Connector Loss at Source Site [dB]• NCS 2000

• NCS 1010

Connector Loss A

Connector Loss at Destination Site [dB]• NCS 2000

• NCS 1010

Connector Loss B

Factors

Displays the PMD coefficient.• NCS 2000

• NCS 1010

• NCS 1001

PMD coefficient

Totals

(The properties under Totals are noneditable)

Displays the PMD value.• NCS 2000

• NCS 1010

• NCS 1001

PMD

Displays the total loss EOL calculation.• NCS 2000

• NCS 1010

• NCS 1001

Loss EOL

Displays the total loss SOL calculation.• NCS 2000

• NCS 1010

• NCS 1001

Loss SOL

Displays the total chromatic dispersion for the C-band.• NCS 2000

• NCS 1010

• NCS 1001

CD C-Band

Displays the secondary order dispersion for C-band.• NCS 2000

• NCS 1010

• NCS 1001

QD C-Band
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DescriptionPlatformProperty

Displays the random dispersion value.• NCS 2000

• NCS 1010

• NCS 1001

RD

Step 7 Click Update.

Modify Service Properties
Use this task to modify the properties of the service.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Services and click a service.

You can view the basic properties of the service at the bottom of the network tree.

Step 2 Modify the following service properties as required.

DescriptionPlatformProperty

General

By default, the service name is based on the source and
destination sites and the number of services between them.
You can edit the name.

For example, if there are two services between site 1 and
site 2, the names of the services are Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

NCS 2000Name

Choose the types of service.NCS 2000Type
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DescriptionPlatformProperty

Choose the protection type from the drop-down list. Options
available are:

• Unprotected

• 1+1

• Disjoint

• S+NS

• 1+R

• 1+1+R

• 1+1+R+R

For more information on protection types, see Supported
Protection Schemes , on page 3.

NCS 2000Protection

Displays the source site name.NCS 2000Source

Displays the destination site name.NCS 2000Destination

Step 3 Click Update.
Step 4 To modify advanced properties of the service, click Show Advanced Properties or choose Network > Entity Editor.
Step 5 In the Entity Editor window, click the Service tab.
Step 6 Choose the service under the network tree, and modify the following properties in the right pane.

DescriptionPlatformProperty

General

From the drop-down list, select the possible site as a tertiary
source.

NCS 2000Tertiary Source
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DescriptionPlatformProperty

From the drop-down list, select the possible site as a tertiary
destination.

Tertiary source and tertiary destination are enabled only
when you select the protection scheme as Unprotected
Disjoint.

You can select either tertiary destination or both tertiary
source and tertiary destination.

• If you select only the tertiary destination, the demand
is created between the source and destination and
between the source and tertiary destination. These do
not have common fibers in the path, which are disjoint.

• If you select both tertiary source and tertiary
destination, two unprotected demands are created
between the source to destination, and tertiary source
to tertiary destination. The demands are disjoint to
each other.

NCS 2000Tertiary Destination

Primary Path Forcing

Cisco ONP automatically selects the shortest path as
working path and also allows you to force the path
manually.

NCS 2000Path

Primary path fiber is forcing path for working trail.NCS 2000Fiber

Displays the platform of the regeneration siteNCS 2000Regeneration Platform

Choose the regeneration site.NCS 2000Regen Sites

Click Edit to choose the wavelength. The default option is
Auto.

NCS 2000Wavelength

Enter the ODU timeslot value.NCS 2000ODU Timeslot

Displays the selected Wavelength.NCS 2000Section Wavelength(s)

Choose the type of source channel. The available options
are:

• Auto—This is the default option. Auto option is the
contentionless demand.

• Contentionless

• Colorless

• Colored

NCS 2000Src Channel Type

Choose the type of destination channel.NCS 2000Dst Channel Type

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
153

Modify Network Properties
Modify Service Properties



DescriptionPlatformProperty

Secondary Path Forcing (Available only for (1+1)

Secondary path is the protected path when the primary path
fails. This path is the second best path after the primary
path.

NCS 2000Path

Secondary path fiber is for protected service, forcing path
for the protected trail.

NCS 2000Fiber

Displays the platform of the regeneration siteNCS 2000Regeneration Platform

Choose the regeneration site.NCS 2000Regen Sites

Click Edit to choose the wavelength. The default option is
Auto.

NCS 2000Wavelength

Enter the ODU timeslot value.NCS 2000ODU Timeslot

Displays the selected Wavelength.NCS 2000Section Wavelength(s)

Choose the type of source channel.NCS 2000Src Channel Type

Choose the type of destination channel.NCS 2000Dst Channel Type

Restoration 1 Path Forcing (Available for 1+R, 1+1+R, 1+1+R+R)

Cisco ONP automatically selects the first restoration path.NCS 2000Path

Choose the first restoration path fibers.NCS 2000Fiber

Restoration 2 Path Forcing (Available for 1+1+R+R)

Cisco ONP automatically selects the second restoration
path.

NCS 2000Path

Choose the second restoration path fibers.NCS 2000Fiber

NCS 1 K Domain

Displays the client type. By default, client type is OTU4.NCS 2000Client Type

Displays the interface type. By default, interface type is
BH.

NCS 2000Interface Type

Choose whether the trunk mode is 200G or 300G. By
default, Trunk Mode is 200G.

Based on the selected trunk mode, Baud rates are
filtered.

Note

NCS 2000Trunk Mode

Choose whether the Baud rates mode as 60 or 69GBd.NCS 2000Baud Rate
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• Ensure that you force both primary and secondary path fiber or channel for protected service. Also ensure
that the wave type is same for both primary and secondary paths. While doing path forcing, make sure that
you perform an end-to-end path forcing from the source to the destination. Analysis fails if the partial path
is forced.

• Force the wave path for the wave, which is tagged to the service.

• In case of protection type: 1+1+R+R, 1+1+R, and 1+R, you can force a path in restoration path1 or restoration
path2 Fiber that is forced in primary or secondary path Fiber.

Note

Step 7 Click Update.

Modify Service Properties for NCS 1010
Table 52: Feature History

Feature DescriptionRelease InformationFeature Name

You can now create optical services for the NCS 1010 network.
You can include cards such as NCS1K14-2.4T-K9,
NCS1K14-2.4T-X-K9, and NCS1K4-QXP-K9 as native
transponder instead of optical sources and check the feasibility
of the network. You can generate the traffic report and BoMwith
the exact count of cards and pluggables based on the
requirements, along with licensing details for the OLT card and
the transponders.

Cisco ONP Release
24.3.1

Transponder
Support on NCS
1010 Network

From Release 24.3.1, you can add services between two NCS 1010 or NCS 1020 sites. Use this task to modify
the properties of the service.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Services and click a service.

You can view the basic properties of the service at the bottom of the network tree.

Step 2 Modify the following service properties as required.

DescriptionPlatformProperty

General

The services are named as Service-1, Service-2, and so on.
You can edit the name.

NCS 1010Name

Choose the traffic type as 100GE or 400GE.NCS 1010Type
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DescriptionPlatformProperty

Protection is not supported for the NCS 1010 network. The
only option available is Unprotected.

NCS 1010Protection

Displays the source site name.NCS 1010Source

Displays the destination site name.NCS 1010Destination

Check this check box to enable encryption on the service.

Encrypted and non-encrypted serviceswill not be aggregated
and they use separate trunks.

NCS 1010Encryption

Step 3 Click Update.
Step 4 Tomodify the advanced properties of the service, click Show Advanced Properties or chooseNetwork >Entity Editor.
Step 5 In the Entity Editor window, click the Service tab.
Step 6 Choose the service under the network tree, and modify the following properties in the right pane.

DescriptionPlatformProperty

Primary Path

Path of the service.NCS 1010Path

Choose the fiber.NCS 1010Fiber

Choose the regeneration site.NCS 1010Regen Sites
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DescriptionPlatformProperty

Choose if a new circuit is to be created or an existing circuit
to be used. The available options are:

• Auto: The system will automatically choose whether
to create a new circuit or use an existing one.

• Create New: A new circuit will be created, and no
existing circuits will be used.

• Existing circuits ( Displays the name of the circuits
that are already created): Select an existing circuit to
use. If you need to specify a particular circuit, provide
the circuit name.

When you select an existing circuit with the
following conditions:

Note

• Traffic Type is set to Line card under the
circuit properties.

• Trunk Mode and Baud Rate are already
defined under the Trail properties

You will not be able to select Trunk Mode and
Baud Rate under the Service properties. To edit
these properties change the traffic type and change
the Channel property to Auto.

NCS 1010Channel

Displays whether it is a C-type to L-type band.NCS 1010Band Type

Choose the wavelength for the regen site that is selected.NCS 1010Section Wavelengths

Choose the trunk mode of the line card. The trunk rate is
from 400G to 1200G for NCS1K14-2.4T-K9 and
NCS1K14-2.4T-x-K9, from 100G to 400G for
NCS1K4-QXP-K9.

NCS 1010Trunk mode

Displays the baud rate suitable for the trunk rate.NCS 1010Baud Rate

Click Edit to choose the wavelength. The default option is
Auto.

NCS 1010Wavelength

Primary Channel Source

Choose the card for the service. The available options are:

• NCS1K14-2.4T-K9

• NCS1K14-2.4T-X-K9

• NCS1K4-QXP-K9

NCS 1010Card Type

Displays the type of modulation.NCS 1010Modulation
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DescriptionPlatformProperty

This property is enabled when the NCS1k14-2.4T-X-K9
card is selected. When selected, the routing will be based
on Muxponder mode and supports Trunk modes 600G or
1000G.

NCS 1010Bundle Mode

This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:

• 1_E

• 0_S

NCS 1010Sub Mode

Displays the type of FEC supported on the chosen card.NCS 1010FEC

Choose the Add/drop type. The available options are:

• Colored

• Colorless

• Omni-colored

• Omni-colorless

NCS 1010Src Add/Drop Type

Choose the client pluggable for the selected card.NCS 1010Client Interface

This property is enabled only when a trunkmode is selected.
Choose the client port.

NCS 1010Client Port

The trunk pluggables that are applicable for the selected
card is displayed. Choose the required trunk pluggable.

NCS 1010Trunk Type

Primary Channel Destination

Choose the card for the service. The available options are:

• NCS1K14-2.4T-K9

• NCS1K14-2.4T-X-K9

• NCS1K4-QXP-K9

NCS 1010Card Type

Displays the type of modulation.NCS 1010Modulation

This property is enabled when the NCS1k14-2.4T-X-K9
card is selected. When selected, routing will be based on
Muxponder mode and supports Trunk modes 600G or
1000G.

NCS 1010Bundle Mode

This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:

• 1_E

• 0_S

NCS 1010Sub Mode
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DescriptionPlatformProperty

Displays the type of FEC supported on the chosen card.FEC

Choose the Add/drop type. The available options are:

• Colored

• Colorless

• Omni-colored

• Omni-colorless

NCS 1010Dst Add/Drop Type

Choose the client pluggable for the selected card.NCS 1010Client Interface

This property is enabled only when a trunkmode is selected.
Choose the client port.

NCS 1010Client Port

The trunk pluggables that are applicable for the selected
card is displayed. Choose the required trunk pluggable.

NCS 1010Trunk Type

Step 7 Click Update.

Services Aggregation
Table 53: Feature History

Feature DescriptionRelease InformationFeature Name

Services aggregation feature allows
two or more services to share the
same trunk port or channel. By
default, the services are added to
the DefaultGroup. You can also
export the aggregation reports.

Cisco ONP Release 4.1Services Aggregation

Services aggregation indicates whether two or more services can share the same trunk port or channel. The
aggregation is defined based on the properties of the Service Group. When you add services to the Traffic
site (of the type 1K-2K-4K) in an SSON network, aDefaultGroup is created under the Services in the network
tree. The services that you add, are associated to the DefaultGroup.

Create a New Service Group
Use this task to create a new service group:

Before you begin

Log in to Cisco ONP Web Interface, on page 6
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Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network, where you want to create a new service group.

The network opens.

Step 3 Click the Ellipsis icon available in the right side of Services under the network tree and choose Create Service Group.

A new service group gets created under the Services.

Modify Service Group Properties
Use this task to modify the properties of service group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Services and click a service group.

You can view the basic properties of the service at the bottom of the network tree.

Step 2 Modify the following service properties as required.

DescriptionPlatformProperty

General

By default, the service name is based on the source and
destination sites and the number of services between them.
You can edit the name.

For example, if there are two services between site 1 and
site 2, the name of the services are Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

NCS 2000Name

Choose the demand type. For default group all demand
types are available, and you cannot edit them.

NCS 2000Demand Types

Indicates whether the service group is a default group or a
user created group.

NCS 2000Default Group

NCS 4 K
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DescriptionPlatformProperty

Indicates whether the services belonging to this group must
have an exclusive Line Card (LC) or not.

For example, when you check this check box, neither the
Client LC nor the Trunk LC of the services belonging to
this group can be shared by services belonging to any other
groups.

NCS 4000Exclusive LC Usage

Indicates whether this group allows aggregation of only
symmetric services. Services are symmetric if they have
same protection scheme. Following are the various
protection schemes:

• Unprotected

• 1+R

• 1+1

• 1+1+R

• 1+1+R+R

For Example, all “1+1” services are symmetrical.

If you check this check box, this service group allows
aggregation of only symmetrical services.

For example, “Unprotected” can be aggregated only with
“Unprotected”, “1+R” only with “1+R”, “1+1” only with
“1+1”, and so on.

If this check box is unchecked, this service group allows
aggregation of symmetrical and unsymmetrical services
together.

For example, “Unprotected” can be aggregated with either
“Unprotected”, “1+R”, “1+1” “1+1+R” or “1+1+R+R”.

See Aggregation Rules, on page 161.

NCS 4000Symmetric Aggregation

NCS 1 K

Same as NCS 4 K.NCS 1004Exclusive LC Usage

Same as NCS 4 K.NCS 1004Symmetric Aggregation

Step 3 Click Update.

Aggregation Rules
Following are the rules for any two services (symmetrical or nonsymmetrical) to be aggregated:
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• The services must have the same Source and Destination.

• The services must have same paths for the same path types.

For example:

• For symmetric aggregation between two “1+1” services, the working path of the first service must
match with the working path of the second service and the protection path of the first service must
match with the protection path of the second service.

• For non-symmetric aggregation between “1+1” and “1+1+R” services, the working path of the first
service must match with the working path of the second service and the protection path of the first
service must match with the protection path of the second service. The restoration path of second
service can be anything.

• The services must be configured to use same wavelength for same path types.

• If the wavelength is set to “auto”, it is flexible to be aggregated with other “auto" wavelength or a fixed
wavelength.

• The services must be configured to use same trunk mode for same path types.

• The services must be configured to use same regeneration sites for same path types.

Demand Type is not used as a constraint for aggregation (except for trunk capacity availability).Note

Associate a Service to the Newly Created Group
By default, the services are associated to the DefaultGroup. But you can change the group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, click the service that you want to associate to a group.

You can view the basic properties of the network at the bottom of the network tree.

Step 2 Choose the group from the Service Group drop-down list.
Step 3 Click Update.

For an LNI imported network, by default, all the services are present in the Default group. Only when you upgrade
the LNI imported network for the first time, you can move the services to other newly created Service Groups
without having to unlock them. On subsequent upgrades, you must unlock the services to facilitate the movement
between Service Groups. Also, the Service Groups are in locked state in the upgrade mode, unless a complete
Network-level unlock has been performed.

Note
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What to do next

Export Aggregation Reports
Use this task to export the service aggregation reports:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click an analyzed network.

The network opens.

Step 3 Choose Export > Service Aggregation.
Step 4 Save the aggregation report in the form of an Excel sheet to your local system.

Modify Wave Properties
Table 54: Feature History

Feature DescriptionRelease InformationFeature Name

The PSM-channel option is now
available as a Protection Type
under theWave properties for NCS
2000 non-SSON networks. This
option allows you to use PSM
channel trunk protection with the
PSM card during network design,
in addition to existing client
protection. You can verify the
optical feasibility for both working
and protection paths, providing all
necessary parameters and
connections for deployment.

Cisco ONP Release 24.3.1PSM Support on Non-SSON
Network

Use the following task to modify the properties of the wave.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Waves, and click a wave.
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You can view the basic properties of the wave at the bottom of the network tree.

Step 2 Modify the following wave properties as required.

DescriptionPlatformProperty

General

By default, the wave is named based on the source and
destination sites and the number of waves between them.
You can edit the name.

For example, if there are two waves defined between site
1 and site 2, the waves are named as Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

NCS 2000Label

Displays the source site name.NCS 2000Source Site

Displays the destination site name.NCS 2000Destination Site

Choose the traffic type from the drop-down list. The
available options are:

• Optical Source

• 100GE

• 10GE LAN PHY

• 40GE LAN PHY

• Fiber Channel 10G

• Fiber Channel 16G

• Fiber Channel 8G

• OC-192/STM-64

• OTU2

• OTU2e

• OTU4

• Pluggable Card

NCS 2000Traffic Type
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DescriptionPlatformProperty

Choose the protection type.

• Unprotected

• Client 1+1

• PSM-Channel

The PSM-channel option is available only for non-SSON
networks. PSM-channel is not supported with the colorless
Add/Drop MF-6AD-COFS.

When you select the PSM-Channel option, the Protection
Switch Module (PSM) for the Cisco ONS15454
Multiservice Transport Platform (MSTP) (15454-PSM card)
is placed in the network to provide protection at the trunk
level. The PSM card splits the traffic originated by
transponder trunk across the working and protected TX
ports.

For more information on protection types, see Supported
Protection Schemes , on page 3.

NCS 2000Protection Type

Check this check box to change a present wave to a forecast
wave.

NCS 2000Forecast

Check this check box to enable encryption.NCS 2000Encryption

Step 3 Click Update.

Modify Media Channel Properties
Use the following task to modify properties of the media channel.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Media Channels, and click a media channel.

You can view the basic properties of the media channel at the bottom of the network tree.

Alternatively, you can chooseNetwork >Entity Editor > Services, expandMedia Channels, and click a media channel
to view the properties.

Step 2 Modify the following properties as required.

DescriptionPlatformProperty

General
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DescriptionPlatformProperty

By default, the media channel is named based on the source
and destination sites and the number of media channels
between them. You can edit the name.

For example, if there are two media channels between site
1 and site 2, they are named as Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

NCS 2000Label

Displays the source site name.NCS 2000Source Site

Displays the destination site name.NCS 2000Destination Site

Choose the traffic type from the drop-down list. The
available options are:

• Optical Source

• 100GE

• 10GE LAN PHY

• 40GE LAN PHY

• Fiber Channel 10G

• Fiber Channel 16G

• Fiber Channel 8G

• OC-192/STM-64

• OTU2

• OTU2e

• OTU4

• Pluggable Card

NCS 2000Traffic Type

Choose the protection type.

• Unprotected

• Client 1+1

For more information on protection types, see Supported
Protection Schemes , on page 3.

For Client 1+1, ensure that the sites have contentionless
sides for the analysis to be successful. By default, Cisco
ONP finds both span and node disjoint path for Client1+1
protected waves, but allows you to force span and node
disjoint path.

NCS 2000Protection Type

Check this check box to change a present wave to a forecast
wave.

NCS 2000Forecast
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DescriptionPlatformProperty

Check this check box to enable encryption.NCS 2000Encryption

Step 3 Click Update.

Modify Circuit Properties
Use the following task to modify the properties of the circuit in an NCS 1010 network.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Circuits, and click a circuit.

You can view the basic properties of the circuit at the bottom of the network tree.

Step 2 Modify the following circuit properties as required.

DescriptionPlatformProperty

General

By default, the circuit is named based on the source and
destination sites and the number of circuits between them.
You can edit the name.

For example, if there are two circuits defined between site
1 and site 2, the circuits are named as Site-1-Site-2-1 and
Site-1-Site-2-2, respectively.

NCS 1010

NCS 1001

Label

Displays the source site name.NCS 1010

NCS 1001

Source Site

Displays the destination site name.NCS 1010

NCS 1001

Destination Site
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DescriptionPlatformProperty

Choose the traffic type from the drop-down list. The
available options are:

• Optical Source

• Pluggable Card

• Line Card

If you select Line card as the Traffic Type in the Circuit
properties, you can only select a transponder card as the
Card Type under the Service properties.

QDD interfaces (both as optical source and
pluggable) are not supported with colorless BRK-8,
BRK-16, and BRK-24 configurations.

Note

NCS 1010

NCS 1001

Traffic Type

Choose the protection type. Currently, we support only
Unprotected.

NCS 1010

NCS 1001

Protection Type

The Encryption property gets enabled when you select Line
card as the Traffic Type.

NCS 1010Encryption

Check this check box to change a present wave to a forecast
wave.

NCS 1010

NCS 1001

Forecast

Step 3 Click Update.

Modify Trail Properties
Use this task to modify the properties of the trail.

Table 55: Feature History

DescriptionRelease InformationFeature Name

The Bright ZR+ pluggable can now
be included in the network design
by choosing them asCard Type or
Client Interface under the Trail
properties. This selection is
available for all types of sites. The
Bright ZR+ pluggable has high
transmit optical power up to 0dBm,
high transmit OSNR, and
high-densityQSFP-DD form factor.

Cisco ONP Release 5.1Bright ZR+ Pluggable Support
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Table 56: Feature History

DescriptionRelease InformationFeature Name

You can now choose from the full
array of supportedCard Types and
Client Interfaces under the Trail
properties option for the multilayer
nodes. Previously, only a limited
set of cards were available for
selection. With this enhancement,
you can design diverse networks
leveraging the unique
functionalities of all types of cards.

Cisco ONP Release 5.1Multilayer Nodes Enhancements

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Waves, Media Channels or Circuits, drill down up to a trail and click a trail.

The basic properties of the trail are displayed at the bottom of the network tree.

Step 2 Modify the following trail properties as required.

DescriptionPlatformProperty

General

Displays the name of the trail.NCS 2000

NCS 1010

NCS 1001

Label

Select a fiber from the drop-down list.NCS 2000

NCS 1010

NCS 1001

Path of Wave

Select the regeneration site.NCS 2000

NCS 1010

Regen Sites

Displays the source site name.NCS 2000

NCS 1010

NCS 1001

Source Site

Displays the destination site name.NCS 2000

NCS 1010

NCS 1001

Destination Site
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DescriptionPlatformProperty

Click Edit to choose the wavelength. The default option is
Auto.

NCS 2000 (Non-SSON)Wavelength

Click Edit to choose the central wavelength. The default
option is Auto.

If you select L-Band as Band Type, the L-band
wavelength options appear along with C-band
wavelengths for NCS 1010 R7.9.1.

Note

NCS 2000

NCS 1010

NCS 1001

Central Wavelength [nm]

Indicates whether the transmission is a multicarrier
transmission.

NCS 2000

NCS 1010

Multicarrier

The trunk mode can be edited only when you choose
400G-XP-LC as Card Type.

NCS 2000Trunk Mode

The trunk mode can be edited only when the Traffic Type
is set to Line card under the circuit properties.

NCS 1010

Trunk mode is noneditable. Auto is default option.NCS 1001

Enter values 2–16 to add the required number of carriers to
the channel. The default value is 1.

If you select Colorless or Omni-Colorless as
Add/Drop Type and Auto or OLT/LC/AddDrop as
Add/Drop Connector, this property becomes
editable.

Note

When you enable bundle mode in line circuit, this
value is 2 and non-editable.

Note

NCS 1010Number Of Carrier(s)

Choose the baud rate that is suitable for the selected trunk
rate.

NCS 1010Baud Rate

Displays the value of the penalties that are caused by the
different filter types (OADM, and ROADM).

NCS 2000

NCS 1010

Filtering Penality

Step 3 To modify the advanced properties of the trail, click Show Advanced Properties or choose Network > Entity Editor.
Step 4 In the Entity Editor window, click the Service tab.
Step 5 Expand Waves, Media Channels or Circuits, under the network tree, drill down to the trail, click the trail, and modify

the following properties that are displayed in the right pane.

DescriptionPlatformProperty

General

Displays the forward optical signal to noise ratio.NCS 2000 (non-SSON)OSNR Forward [dB]

Displays the reverse optical signal to noise ratio.NCS 2000 (non-SSON)OSNR Reverse [dB]
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DescriptionPlatformProperty

Choose the required band type for the circuit.

When you select L-Band as Band Type, then the
Add/Drop Type field automatically selects
Colorless and becomes disabled.

Note

NCS 1010Band Type

This property is noneditable. C-Band is the default option.NCS 1001

OTN (non-SSON)

Displays the Optical Data Unit timeslot.NCS 2000 (non-SSON)ODUTimeslot

Displays the SRLGs associated with the trail.NCS 2000 (non-SSON)SRLGs

Displays the number of OTN hops.NCS 2000 (non-SSON)OTN Hops

Displays the number of OTN services on the trail.NCS 2000 (non-SSON)Quantity

Source
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DescriptionPlatformProperty

Choose the card used in the source site. See Supported Cards
and Pluggables, on page 271 and SupportedOptical Sources,
on page 285 for more information on the list of supported
cards.

FromRelease 5.1, Bright ZR+ pluggables are supported for
all the types of sites. Also, there are no limitations on the
type of cards that can be chosen for the multilayer nodes.

Note • Non-SSON

• Colored and colorless—Baud rates less
than 42 are supported and listed.

• Contentionless—Mean power less than
–4.4 is supported and listed.

• SSON

• Colored—Baud rates less than 65 are
supported and listed.

• Colorless—All interfaces supported and
listed.

• Contentionless—Mean power less than
–4.4 are supported and listed.

Mean power = (ochData.txRange.max +
ochData.txRange.min)/2

If contentionless is selected for the source channel
type, the QDD interfaces are not supported.

NCS 2000

NCS 1010

Card Type

Choose a card type from the drop-down list.NCS 1001
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DescriptionPlatformProperty

Choose the pluggable from the drop-down list. The
pluggables suitable for the chosen card type are displayed.

See Supported Cards and Pluggables, on page 271 for more
information on the list of supported pluggables.

FromRelease 5.1, Bright ZR+ pluggables are supported for
all the types of sites. Also, there are no limitations on the
type of cards that can be chosen for the multilayer nodes.

The pluggable FR-1(QSFP-100G-FR-S) is supported on
the client ports of the 400G-XP LC starting fromNCS 2000
Release 11.1.0.

The pluggable ERL (QSFP-100G-ERL-S) is supported on
the client ports of the 400G-XP LC with 100G traffic type
starting from NCS 2000 Release 11.1.3.

When you export the NCS 2000 R11.1.3 network,
the Cisco ONP exports the NCS 2000 R11.1.0
report. You must edit the exported report for
R11.1.3.

Note

NCS 2000

NCS 1010

Client Interface

This property is noneditable. Auto is the default option.NCS 1001

Choose the type of Add/Drop. The available options are:

• Auto

• Contentionless

• Colorless

• Colored

NCS 2000Add/Drop Type

Choose the type of Add/Drop. The available options are:

• Auto

• Colorless

• Colored

• Omni-Colorless

• Omni-Colored

NCS 1010

This property is noneditable. Colored is the default option.NCS 1001
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DescriptionPlatformProperty

This property appears when you select Add/Drop
Type as Colorless.

Note

Choose the type of Add/Drop Connector. The available
options are:

• Auto—Auto is OLT/LC/AddDrop.

• OLT/LC/Add/Drop—Combination of OLT LC ports
and CCMD-16 LC ports

• OLT/LC—Direct OLT LC ports

• OLT/MPO/Add/Drop—Combination of OLTLC ports
and break out units such as BRK-8, BRK-16, BRK-24
MPO ports

This property is applicable only for Enhanced NCS
1010 line cards from R7.11.1.

Note

NCS 1010Add/Drop Connector

Displays the type of modulation.NCS 1010Modulation

This property is enabled when the NCS1k14-2.4T-X-K9
card is selected. When selected, the routing is based on
Muxponder mode and supports Trunk modes 600G or
1000G.

NCS 1010Bundle Mode

This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:

• 1_E

• 0_S

NCS 1010Sub Mode

Displays the type of FEC supported on the chosen card.NCS 1010FEC

Choose the trunk type from the drop-down list.NCS 2000

NCS 1010

Trunk Type

This property is noneditable. Auto is the default option.NCS 1001

Choose the contentionless side from the drop-down list.NCS 2000Contentionless Side

Enter a launch power value. Default option is Auto.NCS 1010

NCS 1001

Launch Power

Destination

The destination card type is auto populated based on the
source card type chosen.

NCS 2000

NCS 1010

Card Type

Choose the card type from the drop-down list.NCS 1001
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DescriptionPlatformProperty

Choose the pluggable from the drop-down list. The
pluggables suitable for the chosen card type are displayed.

NCS 2000

NCS 1010

Client Interface

This property is noneditable. Auto is the default option.NCS 1001

Choose the trunk type from the drop-down list.NCS 2000

NCS 1010

Trunk Type

This property is noneditable. Auto is the default option.NCS 1001

Choose the type of the Add/Drop. The available options
are:

• Auto

• Contentionless

• Colorless

• Colored

NCS 2000Add/Drop Type

Choose the type of the Add/Drop. The available options
are:

• Auto

• Colorless

• Colored

• Omni-Colorless

• Omni-Colored

NCS 1010

Colored is the default option.NCS 1001
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DescriptionPlatformProperty

This property appears when you select Add/Drop
Type as Colorless.

Note

Choose the type of Add/Drop Connector. The available
options are:

• Auto—Auto is OLT/LC/AddDrop.

• OLT/LC/Add/Drop—Combination of OLT LC ports
and CCMD-16 LC ports

• OLT/LC—Direct OLT LC ports

• OLT/MPO/Add/Drop—Combination of OLTLC ports
and break out units such as BRK-8, BRK-16, BRK-24
MPO ports

This property is applicable only for Enhanced NCS
1010 line cards.

Note

NCS 1010Add/Drop Connector

Displays the type of modulation.NCS 1010Modulation

This property is enabled when the NCS1k14-2.4T-X-K9
card is selected. When selected, the routing is based on
Muxponder mode and supports Trunk modes 600G or
1000G.

NCS 1010Bundle Mode

This field is applicable only for the NCS1K4-QXP-K9 card.
Choose the required sub mode. The available options are:

• 1_E

• 0_S

NCS 1010Sub Mode

Displays the type of FEC supported on the chosen card.NCS 1010FEC

Choose the trunk pluggable.NCS 1010Trunk Type

Choose the contentionless side from the drop-down list.NCS 2000Contentionless Side

Enter a launch power value. Default option is Auto.NCS 1010

NCS 1001

Launch Power

Step 6 Click Update.

Modify Section Properties
Use this task to modify properties of the section.
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Waves, drill down up to section and click a section.

You can view the basic properties of the section at the bottom of the network tree.

Step 2 Modify the section properties as required.

Section and trail have the same properties. ReferModify Trail Properties, on page 168 for the descriptions of the properties.

Step 3 Click Update.

Modify Side Properties
Table 57: Feature History

Feature DescriptionRelease InformationFeature Name

In addition to the SMR-20 card, the colorless Add/Drop
configuration can now be added to both SSON and
non-SSON networks using the SMR-9 card, providing
more flexibility to use the available SMR-9 ports for
add/drop functionality.

Cisco ONP Release
24.3.1

Colorless Add/Drop
Configuration with SMR-9
Card

Table 58: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP now supports the passive module,
NCS2K-RMN-CTP-C+L (C- and L-band
counterpropagating Raman amplifier), starting from the
NCS 2000 system release 12.3.1 for SSON and non-SSON
networks.

Cisco ONP Release
5.0

NCS2K-RMN-CTP-C+L
support

Table 59: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP supports the passive
module, NCS2K-MF-CL-SC (C
and L-band combiner and splitter),
starting from the NCS 2000 system
release 12.2 for SSON and
non-SSON networks. This feature
enables combining C and L band
wavelengths.

Cisco ONP Release 4.2Support for NCS2K-MF-CL-SC (C
and L-band combiner and splitter)

Use this task to modify the properties of a side in a site.
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, Choose Sites > Site > Site domain > Side.
Step 2 To modify the side properties, perform the following steps:

a) Click Show Advanced Properties.
b) In the right pane of the Entity Editor window, modify the following properties of the side.

You cannot edit the properties of the Pass through site side.Note

DescriptionPlatformOptions

General

Displays the label of the side.

Editable for NCS 1001.

For L-band nodes, the suffix L is added to the
side label.

Note

NCS 2000

NCS 1010

NCS 1001

Label

Displays the type of the side. You cannot edit this
property.

NCS 2000

NCS 1010

NCS 1001

Type

Select the type of omnidirectional add/drop stage. The
available options are:

• Dual OLT (the default option)

• 4x4 COFS (supports only C-band Omni colorless)

You can choose 4x4 COFS only if the Structure
under the Sites properties is Line.

In a site, all Omni edges must have the same
Omni Variant. Changing the Omni Variant for
one edge updates the variant for all edges.

Note

NCS 1010Omni Variant

Enter the number of omnidirectional ports.

It is applicable only for the 4x4COFS Omni variant. The
available values range from 1 through 4, with a default
value of 4.

NCS 1010Omni Directional Ports

Enter the node addressNCS 1010

NCS 1001

Node Address
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DescriptionPlatformOptions

Choose the MPO cable. The available options are:

• Auto

• 16MPO-MPO

• 24MPO-MPO

NCS 1010MPO Cable

Enter the number of colorless ports.

From Release 24.3.1, this property is enabled for the
SMR-9 card.

NCS 2000Colorless Ports (Displayed
for Line side)

Choose the number of contentionless ports.NCS 2000Contentionless Ports
(Displayed for
Contentionless side)
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DescriptionPlatformOptions

Cisco ONP supports the following passive modules:

• NCS2K-MF-CL-SC (C and L-band combiner and
splitter), starting from the NCS 2000 system release
12.2 for SSON and non-SSON networks. Check this
check box to enable the NCS2K-MF-CL-SC card.
This card is supported for ROADM,OLA, and traffic
nodes, but not on the passthrough node.

When you enable this option on a side:Note

• It is automatically enabled on the side
that is connected to the selected side
through a fiber.

• The fiber property Raman Amplified is
automatically disabled, and the
opposite way.

• This card introduces a certain amount
of attenuation and insertion loss that is
reflected in the ANS parameters.

The NCS2K-MF-CL-SC module does not
appear in the layout.

• NCS2K-RMN-CTP-C+L (C- and L-band
counterpropagating Raman amplifier), starting from
the NCS 2000 system release 12.3 for SSON and
non-SSON networks. Check this check box to enable
the NCS2K-RMN-CTP-C+L card.

When you enable this option on a side:Note

• If you enable the fiber property Raman
Amplified, then the
NCS2K-RMN-CTP-C+L card is
automatically forced.

• If you disable the fiber property Raman
Amplified, then the NCS2K-MF-CL-
SC card is automatically forced.

• Fiber property Raman Amplified is
automatically disabled for NCS 2000
system release 12.2.

The NCS2K-RMN-CTP-C+L module
appears in the layout.

NCS 2000Enable C+L Band S/C
(Displayed for Line side
type)
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DescriptionPlatformOptions

Choose the required band type.

The available options are:

• C-Band

• C+L Futuristic

NCS 1010

NCS 1001

Band Type

Choose whether the Line Card faceplate is Standard
Faceplate or Enhanced Faceplate.

If you assigned a Scalable Upto Degree value
that is supported for both standard and enhance
at the site level, then you can select Standard
Faceplate in one side and Enhanced Faceplate
in another side.

Note

NCS 1010NCS 1010 Line Card

Choose the type of OSC pluggable. The available options
are:

• CWDM-SFP-1510

• CWDM-SFP-1610

• ONS-SC-Z3-1510

• ONS-SC-Z3-1610

• ONS-SE-155-1510

NCS 1001OSC Pluggable

Bill of Material

Choose whether the License Suite is Essential (RTU
+SIA3) or Advanced (RTU +SIA3).

NCS 1010License Suite

Layout

Choose the type of Power Supply. The available options
are Auto, AC Power, and DC Power.

The default option is Auto.

With the Auto option, the default power supply is selected
as DC Power.

NCS 1010

NCS 1001

Power Supply

Choose the type of chassis. The available options are:

• NCS 1010

• NCS 1020

NCS 1010Chassis Type
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DescriptionPlatformOptions

Choose the type of the controller card. The available
options are:

• Auto

• NCS1010-CNTRL-K9

• NCS1010-CNTRL-B-K9

NCS 1010Controller Card

NCS1K-CNTLR2 is default.NCS 1001

Displays the redundant controller card, if any. Else
displays No.

NCS 1010

NCS 1001

Redundant Controller Card

Choose the type of cables to be used for the AC power
supply. You can choose the cables when the Power
Supply is set as AC Power or DC Power.

NCS 1010

NCS 1001

UTS AC Power Cables

Choose the redundant power scheme from the drop-down
list to configure the number of working and protected
power units for the chassis. The available options are
Auto, 1+0, and 1+1.

NCS 1010

NCS 1001

Redundant Power Scheme

Choose the mechanical frame for the passive optical
modules from the drop-down list. The options available
are Auto, MF-1RU, and MF-4RU.

NCS 1010

NCS 1001

MF Unit

Enhanced Face Plate Options

Choose the port type for interconnect degree priority. The
available options are:

• LC Ports

• MPO Group

The default option is LC Ports.

This field appears only when you select NCS
1010 Line Card as Enhanced Faceplate.

Note

NCS 1010Degree Priority

Choose the number of LC ports to reserve for Direct
Add/Drop connection. The range of values is 0–14. This
property appears for networks from R7.10.1.

The chosen option will not be used for Degree
Connection.

NCS 1010Direct LC Add/Drop

c) Click Update.
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Modify C-Band Amplifier Properties
Table 60: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to edit the
crosstalk values of the Raman COP
amplifier in the SSON network,
starting from NCS 2000 Release
11.1.

Cisco ONP Release 4.1Manual Editing of Raman COP
values

Table 61: Feature History

Feature DescriptionRelease InformationFeature Name

The Inline Amplifier option allows
you to enable an inline amplifier in
the network. You can simulate the
optical feasibility of the network
with and without an inline
amplifier. Based on the colorless or
colored add/drop type selected and
the QSFP-DD pluggable status, a
default inline amplifier is enabled
for the network.

Cisco ONP Release 4.2Inline Amplifier

Use this task to modify the properties of a c-band amplifier in a site.

Make sure that SMR card is forced on the site before you update the c-band amplifier properties.Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 In the network tree, choose Sites > Site > Site domain > Side > C-Band.
Step 2 To modify the amplifier properties, perform the following steps:

a) Click C-Band Amplifier.

You can view the properties of the C-Band Amplifier at the bottom of the network tree. For more information, see
Supported Amplifiers, on page 291.

b) Modify the following properties of the amplifier:

You can also modify the properties by choosing the C-Band Amplifier under Network > Entity Editor.
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DescriptionPlatformOptions

General

Enter a Power Spectral Density (PSD) value.NCS 1010PSD Shape

Enter Central PSD and Tilt values.NCS 1010Dual Band PSD Shape

The default value is Auto. You can enter a value.NCS 2000Raman COP Tilt

The default value is Auto. You can enter a value.NCS 2000

NCS 1010

Pre Tilt

The default value is Auto. You can enter a value.NCS 2000

NCS 1010

Raman Tilt

The default value is Auto. You can enter a value.NCS 2000

NCS 1010

Booster Tilt
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DescriptionPlatformOptions

Choose whether inline amplifier can be forced. The
available options are:

• Yes―EDFA17 or EDFA35 amplifier is chosen as
the default amplifier when you choose colored
add/drop module MD-64-C or colorless add/drop
MF-6AD-CFS, respectively. See Modify Add/Drop
Multiplexer Properties, on page 192.

• No―No amplifier can be forced.

• Auto

• EDFA17 amplifier is chosen as the default
amplifier when any one of the demands
aggregated in MD-64-C has low launch power
optical resource or QSFP-DD pluggable is
forced.

• EDFA35 amplifier is chosen as the default
amplifier when any one of the demands
aggregated in MF-6AD-CFS has low launch
power optical resource or QSFP-DD pluggable
is forced.

When you configureMF-6AD-CFS+EDFA35 in
an SSON or non-SSON network, the optical
results show system error for the demands of the
same or different types. This error affects the
what-if analysis. Hence we recommend choosing
the appropriate channel and client attenuators so
that the inline amplifier works at the proper gain
range.

Note

You can view the amplifier added in the IPC, BOM, and
Layout tabs, after the successful analysis.

Note • When you add a QDD demand while
upgrading a network where the Inline
Amplifier property is set as no, the inline
amplifier can be included in the network
only if you unlock the side and set the Inline
amplifier property as Auto or Yes.

• Default colorless configuration does not
require inline amplifier.

• When there are no demands passing through
the colored or colorless Add/Drop device,
the forced Inline amplifier is not placed.

NCS 2000Inline Amplifier
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DescriptionPlatformOptions

From Fiber

Choose a preamplifier from the drop-down list. The
default value is Auto. To enable this field for ROADM
and Traffic nodes, you must choose SMR-9 or SMR-20
from the Site Type drop-down list under the Site
properties.

If you choose SMR-9, the available options are:

• SMR9-FS-EDFA17-PRE

• SMR9-FS-EDFA24-PRE

• SMR9-FS-EDFA24-PRE

If you choose SMR-20, the available options are:

• SMR20-FS-EDFA17-PRE

• SMR20-FS-EDFA24-PRE

For the OLA site, the available options are:

• EDFA35-35-PRE

• EDFA35-24-PRE

• OPT -EDFA-17

• OPT -EDFA-24

NCS 2000Pre Amp

The options available for NCS 1010 are:

• Auto

• Normal

• Extended

NCS 1010

The options available for NCS 1001 are:

• Auto

• NCS1001-PRE-1

• NCS1001-PRE-2

NCS 1001

The default value is Auto. You can enter a value.NCS 2000

NCS 1001

Output Power
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DescriptionPlatformOptions

This field is enabled only when you choose a preamplifier.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

NCS 2000Attenuator In

This field is enabled only when you choose a preamplifier.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

NCS 2000Attenuator Out

To Fiber
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DescriptionPlatformOptions

The default value is Auto. To enable this field for
ROADM and Traffic nodes, you must choose SMR-9 or
SMR-20 from the Site Type drop-down list under the
Site properties.

If you choose SMR-20, the default booster is
20SMR-FS-BST.

If you choose SMR-9, default booster is
SMR9-FS-EDFA-BST.

For the OLA node, the available options are:

• EDFA35-35-BST

• EDFA35-24-BST

• OPT -EDFA-17

• OPT -EDFA-24

NCS 2000Booster

For NCS 1010, it is OLT-C-EDFA-BstNCS 1010

The option available for NCS 1001 is:

• NCS1001-BST

NCS 1001

The default value is Auto. You can enter a value.NCS 2000

NCS 1001

Output Power

This field is enabled only when you choose a booster.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

NCS 2000Attenuator In
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DescriptionPlatformOptions

This field is enabled only when you choose a booster.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

NCS 2000Attenuator Out

Raman Amplification
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DescriptionPlatformOptions

Choose the Raman amplifier from the drop-down list.

To force the RAMAN amplifier on NCS 2000
node, you must enable RAMAN amplified on
the fiber, else the Raman Amp is disabled, and
network analysis fails.

Note

When you enable the fiber property Raman
amplified and the side property Enable C+L
Band S/C for NCS 2000 node, Raman Amp is
automatically forced as RAMAN-C+L.

Note

The available options for NCS 2000 ROADM and Traffic
sites are:

• RAMAN-CTP

• RAMAN-COP-CTP

Raman Amp can be forced only between two nodes.

The available options for the OLA site are:

• EDRA1-26

• EDRA1-35

• EDRA2-26

• EDRA2-35

• RAMAN-CTP

NCS 2000Raman Amp

The available options for NCS 1010 ROADM site are:

• Auto

• None

• Raman

For NCS 1010 network, when Raman is forced
on one side, Raman is automatically forced on
all connected sides (APC Domain). If there are
passthrough nodes connected, Raman will be
automatically enabled on both sides of the
passthrough nodes.

Note

NCS 1010

Enter a value.NCS 2000Raman CTP Gain

Enter a value. This field is enabled only when you choose
RAMAN-COP-CTP.

NCS 2000Raman COP Gain

Displays the Raman gain.NCS 1010Raman Gain
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DescriptionPlatformOptions

By default, this option is disabled. Enable it to edit the
crosstalk values of the Raman COP amplifier.

Static data is supported from Release 11.1 for
SSON network.

Note

NCS 2000Static Data

Edit the value of average linear crosstalk.NCS 2000Linear XT Avg

Edit the value average linear crosstalk sigma.NCS 2000Linear XT Six

Edit the value of average nonlinear crosstalk.NCS 2000NonLinear XT Avg

Edit the value of average nonlinear crosstalk sigma.NCS 2000NonLinear XT Sig

Raman crosstalk values are present in the ANS file under logoparameters section.Note

c) Click Update.

Modify L-Band Amplifier Properties
Use this task to modify the properties of an L-band amplifier in a site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 In the network tree, choose Sites > Site > Site domain > Side > L-Band.
Step 2 To modify the amplifier properties, perform the following steps:

a) Click L-Band Amplifier.

You can view the properties of the L-Band Amplifier at the bottom of the network tree. For more information, see
Supported Amplifiers, on page 291.

b) Modify the following properties of the amplifier:

You can also modify the properties by choosing the L-Band Amplifier under Network > Entity Editor.

DescriptionPlatformOptions

General

Enter a Power Spectral Density (PSD) value.NCS 1010PSD Shape

Enter Central PSD and Tilt values.NCS 1010Dual Band PSD Shape

The default value is Auto. You can enter a value.NCS 1010Pre Tilt

The default value is Auto. You can enter a value.NCS 1010Raman Tilt

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
191

Modify Network Properties
Modify L-Band Amplifier Properties



DescriptionPlatformOptions

The default value is Auto. You can enter a value.NCS 1010Booster Tilt

From Fiber

The options available for NCS 1010 are:

• Normal

• Extended

NCS 1010Pre Amp

To Fiber

For NCS 1010, it is OLT-L-EDFA-BstNCS 1010Booster

c) Click Update.

Modify Add/Drop Multiplexer Properties
Table 62: Feature History

DescriptionRelease InformationFeature Name

The new property, Colorless Port
Distribution is introduced under
the Add/Drop Multiplexer
properties. This property allows
you to select the number of CCMD
cards to connect to the LC ports of
the enhanced OLT and determine
the number of channels for each
chosen CCMD card. It provides the
flexibility to choose the desired
number of CCMD cards and
distribute the colorless ports across
them.

Cisco ONP Release 24.3.1User-Defined Colorless Ports
Distribution for CCMD Card in
NCS 1010 Network
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Table 63: Feature History

Feature DescriptionRelease InformationFeature Name

You can create and validate network designs by choosing colored
and colorless add/drop multiplexers and demultiplexers, and
interlever under C-Band > Add/Drop. The following options
are supported in this release:

Cisco ONP Release
4.2

Modify Properties of
Add/Drop
Multiplexer and
Demultiplexer

Network SupportedOptionsType of Add/Drop

• SSON

• Non-SSON

• Direct SMR

• MF-6AD-CFS

Colorless

• SSON

• Non-SSON

• MD-64-C

• MD-48-ODD

• MD-48-EVEN

• MD-48-ODD+
MD-48-EVEN

Colored

• Non-SSON• MpoCable

• MD-48-CM

Interlever

Use this task to modify the properties of the add/drop multiplexer in a site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, Choose Sites > Site > Site domain > Side > C-Band.
Step 2 To modify the Add/Drop multiplexer card properties, perform the following steps:

a) Click Add/Drop.
You can view the properties of the add/drop multiplexer at the bottom of the network tree.

b) Modify the following properties of the add/drop multiplexer:

You can also modify the properties by choosing the Add/Drop under Network > Entity Editor.

DescriptionPlatformOptions

General
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DescriptionPlatformOptions

Choose the colored add/drop multiplexer and demultiplexer: The
available options are:

• MD-64-C―Passive optical multiplexer and demultiplexer
module (for SSON network)

• None

• Auto

To mix 16-AD-CCOFS and MD-48-ODD/EVEN on the same
MPO port of SMR-20 and connect MD-48-ODD/EVEN to
SMR-20 viaMPO-8LC and UPG-4, enable Shared SMR port and
force the required colored Add/Drop.

The following options are added automatically based on the
colored demands created and the wavelengths forced in the
non-SSON network.

• MD-48-ODD

• MD-48-EVEN

• MD-48-ODD + MD-48-EVEN

NCS 2000Colored Add/Drop

The options available for NCS 1010 are:

• Auto

• None

• MD-32-EVEN

• MD-32-ODD

• MD-32- ODD+MD-32-EVEN

NCS 1010

The options available for NCS 1001 are:

• Auto

• MD-64

• MD-32-EVEN

• MD-48-EVEN

• MD-48-ODD

• MD-48-ODD+MD-48-EVEN

• FLD-4 (10 variants)

Choose a Add/Drop type with a Baud rate that matches
the Optical Source Baud rates.

Note

NCS 1001
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DescriptionPlatformOptions

Choose the colorless add/drop multiplexer and demultiplexer. The
available options for NCS 2000 are:

• Auto

• Direct SMR―SMR-20 and SMR-9 cards that are directly
connected to the colorless channels throughMF-MPO-16-LC
and MF-MPO-8-LC respectively.

• MF-6AD-CFS―6 Port Add/Drop Module (supported only
for ROADM starting from NCS 2000 system release 11.0,
and traffic site).

If you choose MF-6AD-CFS for a side, we
recommend you to choose the same for other sides
of the site.

Note

NCS 2000Colorless Add/Drop

The options available for NCS 1010 are:

• Auto

• None

• BRK-8

• BRK-16

• BRK-24

QDD optical sources are not supported (both as optical
source and pluggable) with colorless BRK-8, BRK-16,
or BRK-24 configurations.

Note

NCS 1010

Choose the interlever type from the drop-down list. The available
options are:

• Auto

• MpoCable

• MD-48-CM

Interlever Type property is visible and editable only for
Line sides of Multi-Degree nodes having Site Type
property as SMR-9 and Scalable Upto Degree property
as 8 under the C-Band tab at the Site level.

Note

NCS 2000Interlever Type

MPO Connector Add/Drop

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
195

Modify Network Properties
Modify Add/Drop Multiplexer Properties



DescriptionPlatformOptions

MPO Connector Add/Drop appears for networks from
R7.10.1.

Note

The options available for NCS 1010 are:

• Auto

• None

• BRK-8

• BRK-16

• BRK-24

QDD optical sources are not supported (both as optical
source and pluggable) with colorless BRK-8, BRK-16,
or BRK-24 configurations.

Note

NCS 1010Colorless Add/Drop

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

For the R7.10.1 network, you can assign a maximum of
48 colorless ports. The assigned ports are applicable to
the MPO ports.

For the R7.11.1 network, you can assign a maximum of
128 colorless ports.

Note

NCS 1010Colorless Ports

LC Connector Add/Drop

LC Connector Add/Drop appears for networks from
R7.11.1.

Note

The options available for NCS 1010 are:

• Auto

• None

• NCS1K14-CCMD-16C

NCS 1010Colorless Add/Drop
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DescriptionPlatformOptions

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

For the R7.10.1 network, you can assign a maximum of
48 colorless ports. The assigned ports are applicable for
the LC ports.

For the R7.11.1 network, you can assign a maximum of
128 colorless ports.

Note

NCS 1010Colorless Ports
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DescriptionPlatformOptions

• Click the field to open the Colorless Ports Distribution
pop-up window.

• Choose the CCMD card (NCS1K14-CCMD-16C) for each
of the LC ports (A/D 4 - A/D 17).

• Select the number of ports for each CCMD card, ensuring
the total does not exceed 128.

• Click Submit.

When allocating LC ports, the priority is as follows:

1. Degree connection

2. Direct LC ports

Only the remaining LC ports can be allocated to CCMD cards.

If the Degree Priority under Site Properties is set to LC Ports, the
number of CCMD cards that can be forced on the line side edges
depends on the number of degrees (including omni and line
degrees, depending on the scalable degree) and the Direct LC
ports.

This is explained in the following formula:

If Degree Priority is LC_Ports, Maximum number of CCMDs
Allowed = 14 - (scalableUptoDegree - 1) - Direct LC add/drops
- Number of Omni Edges

The number of ports that you have selected is displayed in the
field.

When the Enable Special Settings under the Network properties
is enabled and if the Colorless Ports Distribution has not been
set previously, it will default to 16,16,0. In this case three LC ports
already used for CCMD card.

For omnidirectional sides, you can select the CCMD card
for all the LC ports.

Note

After successful analysis of the network, you can view the port
distribution under the Layout > Node Diagram tab.

Currently, this property is only supported for the enhanced plate.

NCS 1010Colorless Ports
Distribution

c) Click Update.
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Modify L-Band Add/Drop Multiplexer Properties
Use this task to modify the properties of the add/drop multiplexer in a site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, Choose Sites > Site > Site domain > Side > L-Band.
Step 2 To modify the Add/Drop multiplexer card properties, perform the following steps:

a) Click Add/Drop.
You can view the properties of the add/drop multiplexer at the bottom of the network tree.

b) Modify the following properties of the add/drop multiplexer:

You can also modify the properties by choosing the Add/Drop under Network > Entity Editor.

DescriptionPlatformOptions

General

The options available for NCS 1010 are:

• Auto

• None

• BRK-8

• BRK-16

• BRK-24

Only L-band optical sources are supported. Pluggables
are not supported in L-band networks.

Note

NCS 1010Colorless Add/Drop

MPO Connector Add/Drop

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
199

Modify Network Properties
Modify L-Band Add/Drop Multiplexer Properties



DescriptionPlatformOptions

MPO Connector Add/Drop appears for networks from
R7.10.1.

Note

The options available for NCS 1010 are:

• Auto

• None

• BRK-8

• BRK-16

• BRK-24

QDD optical sources are not supported (both as optical
source and pluggable) with colorless BRK-8, BRK-16,
or BRK-24 configurations.

Note

NCS 1010Colorless Add/Drop

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

For the R7.10.1 network, you can assign a maximum of
48 colorless ports. The assigned ports are applicable for
the MPO ports.

For the R7.11.1 network, you can assign a maximum of
128 colorless ports.

Note

NCS 1010Colorless Ports

LC Connector Add/Drop

LC Connector Add/Drop appears for networks from
R7.11.1.

Note

The options available for NCS 1010 are:

• Auto

• None

• NCS1K14-CCMD-16L

NCS 1010Colorless Add/Drop
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DescriptionPlatformOptions

Enter the number of colorless ports. The default value is 0. If you
do not change the default value, Cisco ONP automatically
calculates the number of colorless ports based on the number of
circuits added and colorless add/drop units forced.

For the R7.10.1 network, you can assign a maximum of
48 colorless ports. The assigned ports are applicable for
the LC ports.

For the R7.11.1 network, you can assign a maximum of
128 colorless ports.

Note

NCS 1010Colorless Ports
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DescriptionPlatformOptions

• Click the field to open the Colorless Ports Distribution
pop-up window.

• Choose the CCMD card (NCS1K14-CCMD-16L) for each
of the LC ports (A/D 4 - A/D 17).

• Select the number of ports for each CCMD card, ensuring
the total does not exceed 128.

• Click Submit.

When allocating LC ports, the priority is as follows:

1. Degree connection

2. Direct LC ports

Only the remaining LC ports can be allocated to CCMD cards.

If the Degree Priority under Site Properties is set to LC Ports, the
number of CCMD cards that can be forced on the line side edges
depends on the number of degrees (including omni and line
degrees, depending on the scalable degree) and the Direct LC
ports.

This is explained in the following formula:

If Degree Priority is LC_Ports, Maximum number of CCMDs
Allowed = 14 - (scalableUptoDegree - 1) - Direct LC add/drops
- Number of Omni Edges

The number of ports that you have selected is displayed in the
field.

When the Enable Special Settings under the Network properties
is enabled and if the Colorless Ports Distribution has not been
set previously, it will default to 16,16,0. In this case three LC ports
already used for CCMD card.

For omnidirectional sides, you can select the CCMD card
for all the LC ports.

Note

After successful analysis of the network, you can view the port
distribution under the Layout > Node Diagram tab.

Currently, this property is only supported for the enhanced plate.

NCS 1010Colorless Ports
Distribution

c) Click Update.
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Modify Client Properties
Use this task to modify the properties of a client-side attenuator in a site.

Before you begin

Table 64: Feature History

Feature DescriptionRelease InformationFeature Name

You can set up channel attenuators
for QSFP-DD demands. You can
choose different channel attenuators
based on the specific configuration
and check for the optical feasibility
of the channel.

Cisco ONP Release 4.2Channel Attenuators

Log in to Cisco ONP Web Interface, on page 6

Step 1 In the network tree, choose Sites > Site > Site domain > Side > Clients > Channel-Attenuators.
Step 2 In the right pane of the Entity Editor window, modify the following properties of the client-side attenuator.

DescriptionPlatformProperties

General

This column displays the selected wavelength.NCS 2000Wavelength

Choose an RX-Attenuator from the drop-down list. The
default option is Auto.

You must select a wavelength to edit this field.Note

NCS 2000RX-Attenuator

Choose a TX-Attenuator from the drop-down list. The
default option is Auto.

You must select a wavelength to edit this field.Note

NCS 2000TX-Attenuator

Click Edit to select a Flex Grid or Fixed Grid wavelength.

Select Fixed Grid (64-Chs) for SSON network
with NCS1K-MD-64-C card.

Note

NCS1K-MD-64-C card has First Channel limitation
for Colored sites. First Channel (196.1 THz) in
Fixed Grid (64-Chs) wavelength supports only
Terminal Add/Drop sites and not ROADM sites.

Note

NCS 2000New Wavelength - Auto

Click Add to select a wavelength.NCS 1001New Wavelength
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Step 3 Click Update.

Sort the Network Elements
You can sort the sites, services, fibers, waves, and SRLG in ascending or descending order. This feature is
helpful for huge networks, to find out the required site, fiber, waves, or SRLG names quickly. Click the
Ellipsis icon available in the right side of the network element, for example Sites and choose Ascending or
Descending. You can sort based on alphabets, numbers, or alphanumeric.

Regeneration Support
In optical networks, as the fiber length increases, a loss in the signal ratio and power could occur due to
attenuation and dispersion. You require a regenerator to recreate the weak and distorted optical signals through
reamplification, regeneration, and retiming processes. The regenerators remove noise and distortion, convert
the optical signal to electrical signal, and then convert the signals back to optical signals (OEO conversion).
Cisco ONP supports creation of regeneration sites in the network.

A regenerator site can only be a ROADM site.Note

Create a Regeneration Site
Table 65: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to assign
different wavelengths for different
sections of the Regen sites.

Cisco ONP Release 4.1Wavelength Forcing at the Section
Level

Use the following procedure to create a regeneration site in the network.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Select a network from the list of networks. This opens the selected network’s map.

You can also add a regeneration site when you are designing a new network or upgrading a network.

Step 3 In the network tree, expand Waves, select a wave and drill down to its trail.
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If the network is an SSON network or NCS 1010 network, you see Media Channels or Circuits respectively.
instead of waves. Expand Media Channels or Circuits , and drill down to its trail.

Note

Step 4 Click the trail.

You can view the properties of the trail at the bottom of the network tree.

Step 5 From the Regen Sites drop-down list, select a regeneration site.

If you select a fiber from the Path of Wave drop-down list, you cannot select any regeneration site to force a
path. Similarly, if you select a regeneration site, you cannot force a path for the wave. However, if you want to
force a fiber, select the fiber from the Path of Wave drop-down list available under the section properties.

Note

Step 6 (Optional) Select the wavelength of each section in the properties for non-SSON network.

For the SSON network, you can select the wavelength only at the trial level.Note

Step 7 Click Update.

A new section is added along with the existing section under the trail, whenever a regeneration site is created. Regeneration
can be performed using any two cards back-to-back or with a dedicated regenerator card.

Step 8 Click Analyze to analyze the network.

After analysis, if you click trail or section in the network tree, the map highlights the trail in orange color, and the section
in green color.

You can assign different wavelengths for different sections. The Central Wavelength is denoted as a *, when
different wavelengths are assigned for different sections.

Note

Multidegree ROADM
In multidegree ROADM, sites have two or more sides and face two or more fibers spans. You can select the
degree of a node from the Cisco ONP GUI. The values are 2, 4, 8, 12, and 16 for Evolved Mesh (EV) ON
and OFF scenarios. The default value is 4. Degrees 5, 9, and 13 are not supported. EV flag is editable.

Prerequisites for Cascaded SMR

• The Structure field under C Band in the Entity Editor must be Multidegree.

• The Site Type field under C Band in the Entity Editor must be SMR-20.

• The Evolved Mesh check box under General in the Entity Editor must be checked.

• The Degree Mesh Type field under C Band in the Entity Editor must be Auto or DEG-5/UPG-4.

• The Mpo16TOMpo8 field under General in the Entity Editor must be MPO16To2MPO8 cable.

• By default, the Cascaded SMR check box is unchecked, but you can edit in the design mode as a site
property. Check the Cascaded SMR check box for contentionless side creation. L2 SMR is supported
for both SSON and Non-SSON networks.

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
205

Modify Network Properties
Multidegree ROADM



• You can edit theCascaded SMR check box whenEvolved Mesh is ON and the SMR-20 card is selected.
You can create Layer 2 SMR sides only after you check the Cascaded SMR check box.

• You can create contentionless sides manually and force the contentionless ports. The default value is 16
for the contentionless ports. The range of values is 0–16.

Limitations

• Supports only contentionless add/drop demands.

• Supports Layer-2 SMR for SMR-20 card only.
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C H A P T E R 5
Configure a Network

This chapter describes the various ways of configuring the network designed through Cisco ONP.

• Configure a NCS 2000 Network for Contentionless Functionality, on page 207
• Configure an NCS 2000 Network for Colorless Functionality, on page 208
• Configure an NCS 2000 Network for Colored Functionality, on page 209
• Configure a Network with Mixed Add/Drop Multiplexers and Demultiplexers, on page 209
• Configure an NCS 1010 Network for Colorless Functionality, on page 213
• Configure an NCS 1010 Network for Colored Functionality, on page 214
• Configure an NCS 1010 Network with Mixed Add/Drop Multiplexers and Demultiplexers, on page 215
• Configure an NCS 1010 C+L-Band Network with Mixed Add/Drop Multiplexers and Demultiplexers,
on page 215

• Configure an NCS 1010 Network for Omnidirectional Functionality, on page 216

Configure a NCS 2000 Network for Contentionless Functionality
Use the following procedure to configure the contentionless functionality in a network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Add contentionless sides to the required sites. See Add Contentionless Side to a Site, on page 134.
Step 3 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the service connecting the site and set the Src Channel Type property as Auto or Contentionless. Similarly,

click the trail under the wave (for non-SSON) or Media Channel (for SSON) and set the Src Channel Type property
as Auto or Contentionless.

Contentionless is the default option when you select Auto.Note

c) Click Update.

Step 4 Analyze the network by choosing Network > Analyze.
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Configure an NCS 2000 Network for Colorless Functionality
Use the following procedure to configure the colorless functionality in a network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the service connecting the site and set the Src Channel Type property as Colorless. Similarly, click the trail

under the wave (for non-SSON) or Media Channel (for SSON) and set the Src Channel Type property as Colorless.
c) Under the Site > Side properties, choose the Line type side from which you want to create the colorless demand, and

enter the number of Colorless Ports.

From Release 24.3.1, you can select the colorless ports for the SMR-9 card.

The number of colorless ports forMF-6AD-CFS depends on the Scalable Upto Degree property. The following table
explains the same.

Table 66: Colorless Ports for SSON and Non-SSON Networks

Maximum Number of Colorless
Ports for Non-SSON

Maximum Number of Colorless
Ports for SSON

Scalable Upto
Degree

Site Type

72724SMR-20

72728SMR-20

242412SMR-20

242416SMR-20

9696LineSMR-20

96120TerminalSMR-20

d) Click Update.

Step 3 Under the C-Band properties, choose MF-6AD-CFS or Direct SMR as the Colorless Add/Drop.
Step 4 Click Update..
Step 5 Analyze the network by choosing Network > Analyze.

You can see the colorless Add/Drop unit getting added in the layout and BOM.
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Configure an NCS 2000 Network for Colored Functionality
Use the following procedure to configure the colored functionality in a network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the service connecting the site and set the Src Channel Type property as Colored. Similarly, click the trail

under the wave (for non-SSON) or media channel (for SSON) and set the Src Channel Type property as Colored.
c) Click Update.

Step 3 For SSON network, perform the following:
a) Under the C-Band properties, choose MD-64-C as the Colored Add/Drop.

MD-64-C is supported from NCS 2000 Release 12.x.Note

b) Click Update..

For non-SSON network, by default, MD-48-ODD or MD-48-EVEN is added as the Colored Add/Drop when Share
SMR Port is not enabled.

If you chooseMD-48-EVEN orMD-48-ODD, make sure to select an even wavelength for theWavelength property
under Trail.

Note

Step 4 When Share SMR Port port is enabled, you can select the Colored Add/Drop by using the following steps:
a) Under the C-Band properties, choose MD-48-ODD, MD-48-EVEN, or MD-48-ODD+MD-48-EVEN as the Colored

Add/Drop.

The above mentioned Add/Drop units are supported from NCS 2000 Release 11.x.Note

b) Click Update.

Step 5 Analyze the network by choosing Network > Analyze.

You can see the colored Add/Drop unit getting added in the layout and BOM.

Configure a Network with Mixed Add/Drop Multiplexers and
Demultiplexers

Use the following procedure to configure mixed wavelengths in a network:

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
209

Configure a Network
Configure an NCS 2000 Network for Colored Functionality



Table 67: Feature History

Feature DescriptionRelease InformationFeature Name

You can configure different
functionalities in the network created
in Cisco ONP. Mixed wavelengths
such as colorless and contentionless,
colored and contentionless, can be
added/dropped on the same side or
direction. The following mixed
configurations are supported:

• Colored
(MD-48-ODD/MD-48-EVEN)
and Contentionless
(16-AD-CCOFS)without shared
SMR port

• Colored and Contentionless
(MD-64-C and 16-AD-CCOFS)

• Colored (MD-64-C) and
Colorless (Direct SMR)

• Colored (MD-48) and
Contentionless (16-AD-CCOFS)
with Shared SMR Port

• Colorless and
MD-48-ODD/MD-48-EVEN

• Colorless and 16-AD-CCOFS

Cisco ONP Release 4.2Support for Mixed Add/Drop
Configuration

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Set the properties of the network under the Entity Editor for different combinations of the functionalities, as described

in the following table:
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Table 68: Supported Mixed Configurations

Properties to be SetPossible Mixed ConfigurationsSupported
Network Type

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one wave. Set the Src Channel Type and
Dst Channel Type to beContentionless for
the second wave created on the same site.
Both wavelengthsmust add/drop in the same
side or direction.

• By default, MD-48-ODD orMD_48-EVEN
is added as the Colored Add/Drop in the
BOM and layout, when you set theChannel
Type as Colored and when Shared SMR
Port is disabled.

By default, 16-AD-CCOFS is added in the
BOM and layout, when you set theChannel
Type as Contentionless.

Colored (MD-48-ODD/MD-48-EVEN) and
Contentionless (16-AD-CCOFS) without shared
SMR port

Non-SSON

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one media channel. Set the Src Channel
Type and Dst Channel Type to be
Contentionless for the secondmedia channel
created on the same site. Both channels must
add/drop in the same side or direction.

• Colored Add/Drop―MD-64-C under the
side.

Colored and Contentionless (MD-64-C and
16-AD-CCOFS)

SSON

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one media channel. Set the Src Channel
Type andDst Channel Type to beColorless
for the second media channel created on the
same site. Both channels must add/drop in
the same side or direction.

• Enter the number of Colorless Ports under
the Line Side properties.

• Colored Add/Drop―MD-64-C

Colorless Add/Drop―Direct SMR

Colored (MD-64-C) and Colorless (Direct SMR)SSON
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Properties to be SetPossible Mixed ConfigurationsSupported
Network Type

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one wave. Set the Src Channel Type and
Dst Channel Type to beContentionless for
the second wave created on the same site.
Both wavelengthsmust add/drop in the same
side or direction.

• Check the Shared SMR Port check box,
under the Site properties.

• Colored Add/Drop―MD-48-ODD,
MD-48-EVEN, or MD-48-ODD and
MD-48-EVEN

If you choose MD-48-EVEN, make sure to
select an even wavelength for the
Wavelength property under Trail.

Colored (MD-48) and Contentionless
(16-AD-CCOFS) with Shared SMR Port

Non-SSON

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colorless for
the wave.

• Enter the number of Colorless Ports under
the Line Side properties.

• By default, MD-48-ODD/MD-48-EVEN is
added as colored Add/Drop in the BOM and
layout, when any colored demand is added
in the non-SSON network.

Colorless and MD-48-ODD/MD-48-EVENNon-SSON

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colorless for
the wave or media channel.

• Channel Type―Colorless for onewave and
Contentionless for another wave created on
the same site. Both wavelengths must
add/drop in the same side or direction.

Colorless and Contentionless (16-AD-CCOFS)SSON

MF-6AD-CFS colorless configuration cannot be mixed with any other configurations.Note

The following is the list of mixed configurations that are not supported by Cisco ONP.
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Table 69: Unsupported Mixed Configurations

Mixed ConfigurationsNetwork Type

Colored (MD-64-C) and Colorless (MF-6AD-CFS)SSON

Contentionless and Colorless (MF-6AD-CFS)SSON

Colored (MD-64-C), Contentionless, and Colorless
(MF-6AD-CFS)

SSON

Colored (MD-64-C) and Layer-2 ContentionlessSSON

Contentionless and Colorless (MF-6AD-CFS)Non-SSON

Colored (MD-48) and Colorless (MF-6AD-CFS)Non-SSON

Colorless (Direct SMR) and Colorless (MF-6AD-CFS)Non-SSON

Colored, Contentionless, and Colorless (MF-6AD-CFS)Non-SSON

Configure an NCS 1010 Network for Colorless Functionality
Use the following procedure to configure the colorless functionality in an NCS 1010 network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the trail under the circuit set the Src Channel Type property as Colorless.
c) Click Update.

Step 3 Under the C-Band properties, choose BRK-8, BRK-16 or BRK-24 as the Colorless Add/Drop.

The Maximum number of colorless ports depends on the scalable up to degree. The following table explains the same.

Table 70: Colorless Ports for NCS 1010 Networks

Maximum Number of Colorless Ports SupportedMPO Port Used for
Degree Interconnect

Scalable Upto Degree

BRK-8BRK-16BRK-24

24487247

22446619

1632483, 415
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Maximum Number of Colorless Ports SupportedMPO Port Used for
Degree Interconnect

Scalable Upto Degree

BRK-8BRK-16BRK-24

1428421, 217

816242, 3, 423

612181, 2, 325

0001, 2, 3, 431

306090NATerminal

2448724Line

Colorless configuration is not supported for scalable upto degree 31.Note

Step 4 Click Update.
Step 5 Analyze the network by choosing Network > Analyze.

You can see the colorless Add/Drop unit getting added in the layout and BOM.

Configure an NCS 1010 Network for Colored Functionality
Use the following procedure to configure the colored functionality in an NCS 1010 network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the trail under the circuit and set the Src Channel Type property as Colored.
c) Click Update.

Step 3 Under the C-Band properties, choose MD-32-EVEN, MD-32-ODD, or MD-32- ODD+MD-32-EVENas the Colored
Add/Drop.

Step 4 Click Update.
Step 5 Analyze the network by choosing Network > Analyze.

You can see the colored Add/Drop unit getting added in the layout and BOM.
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Configure an NCS 1010 Network with Mixed Add/Drop
Multiplexers and Demultiplexers

Use the following procedure to configure mixed wavelengths in an NCS 1010 network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Set the properties under the Entity Editor for different combinations of the functionalities:

For example, set the source Add/Drop Type and destination Add/Drop Type to Colored for one circuit. Set the Src
Channel Type and Dst Channel Type to Colorless for the second circuit created on the same site. Both channels must
add/drop in the same side or direction.

You can choose any combination of the colored or colorless add/drop.

When the Scalable Upto Degree is 31, the colorless configuration is not supported, and hence mixed configuration
is also not supported for Scalable Upto Degree 31.

Note

Configure an NCS 1010 C+L-Band Network with Mixed Add/Drop
Multiplexers and Demultiplexers

Use the following procedure to configure mixed wavelengths in an NCS 1010 C+L-Band network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Set the properties under the Entity Editor for different combinations of the functionalities:

For example, set the source Add/Drop Type and destination Add/Drop Type to Colored or Colorless for the C-band
circuit. Set Band Type as L-band for the second circuit created on the same site. Both channels must add/drop in the
same side or direction.

You can choose any combination of the colored or colorless add/drop for C-band circuits. However, for L-band circuits,
colorless add/drop is the default value.

When Scalable Upto Degree is 31, only C-band colored configuration is supported. Colorless cannot be created
as all colorless ports are exhausted and hence mixed configuration is also not supported for Scalable Upto Degree
31.

Note
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Configure an NCS 1010 Network for Omnidirectional
Functionality

Use the following procedure to configure colored and colorless omnidirectional functionalities in an NCS
1010 network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 22 .
Step 2 Add Omnidirectional sides to the required sites. See Add Omni-Directional Side to a Site, on page 139. You can also use

the Max Auto Omni Allowed property under the network properties. Based on the number that you enter, Cisco ONP
will automatically generate up to that many Omni Edges and run the analysis.

Step 3 Select the Omni variant and type of omnidirectional add/drop stage.
a) In the Entity Editor window, click the Sites tab.
b) Choose the omnidirectional side under the required site, and set the following properties.

Omni Variant: Select the type of omni variant as Dual OLT or 4x4 COFS. The available options are:

Omni Directional Ports: Enter the number of omnidirectional ports.

Step 4 Select the type of omnidirectional add/drop stage.
a) In the Entity Editor window, click the Services tab.
b) Choose the required service and set the Src Add/Drop Type and Dst Add/Drop Type as omni-colored or

omni-colorless.
c) Choose the trail under the service, and set the Add/Drop Type as omni-colred or omni-colorless.

Step 5 Click Update.
Step 6 Analyze the network by choosing Network > Analyze.

You can see the Omni Add/Drop unit getting added in the layout and BOM.
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View Network Reports

Table 71: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP Release 24.3.1Deployability and Debuggability
Enhancements
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Feature DescriptionRelease InformationFeature Name

Cisco ONP enhances the
debuggability and deployability of
the network with the following
improvements in Optical sources,
and various reports available in the
Results page:

• Optical Sources: Including
new optical parameters such
as vendor name, vendor ID,
and submode in the
downloaded optical souce
Excel file to improve
inperoperability with Cisco
Optical Network Controller.

• BOM: The exported Excel file
includes these updates:

• Sales BOM Sheet:
Providing information
tailored for sales
personnel.

• Net BOM Sheet:
Providing the site-wise
BOM count and
categories of elements
such as Chassis,
Controllers,Mux-Demux
units, Line Cards, Fillers,
and more, offering a
comprehensive overview
of all network elements
in the analyzed network.

• IPC:

• Consolidating the IPC
Cabling Report and the
IPC Patch Report into a
unified view with
additional columns,
streamlining connection
details and eliminating
the need to access
multiple sources.

• Highlighting patches
when clicked.

• Optical Reports: Filtering
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Feature DescriptionRelease InformationFeature Name

results by any column
available in the report for
more precise data analysis.

• Elements > Messages:
Providing links to navigate to
the respective object in the
network tree, allowing users
to take the necessary action to
correct errors.
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Table 72: Feature History

DescriptionRelease InformationFeature Name

Cisco ONP now provides a
simplified approach to navigate to
the Results tab to view reports for
analyzed multinode network
topologies with the following
enhancements:

• Click the Ellipsis icon
available in the right side of
a particular site in the network
tree to view:

• BOM details

• Optical Reports

• Click the Ellipsis icon
available in the right side of
a particular
circuit/media/wave in the
network tree to view:

• Optical Report

• Traffic Report

• New IPC tab —The IPC tab
is introduced in Cabling
Reports to intuitively view
the internal patch connections
for a site.

• Search Box—TheResults tab
is enhancedwith a Search Box
at the top. You can use this
search box to find a particular
site in the topology by
entering the site name.

Cisco ONP Release 5.1Simplified Navigation to Results
Tab

• Network Reports, on page 221

Network Reports
Cisco ONP provides network reports, which are listed under the report availability tabs. Reports are available
depending on whether a network is analyzed, or not. Reports are also available in site properties after analyzing
the network.

Cisco ONP provides the following reports:
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• Dashboard

• Elements

• Map

• BOM

• Layout

• Results

The Cisco ONP home page has multiple tabs to access the reports of the analyzed network. You can also view
the reports for specific site, fiber, or wave properties by clicking the respective report in the Network Tree
pane.

From Release 5.1, a search box is introduced in the BOM and Results tab. You can use the search box in the
BOM, Optical Report, Traffic Report, and Cabling Report tabs to search for any specific site, fiber, or
wave in the reports.

From Release 24.3.1, the Reports tabs that you open, do not refresh when you toggle between tabs.

View Reports in the Dashboard Tab
The Dashboard tab provides the total count of sites, fibers, SRLGs, services, waves/media channels/circuits,
and messages that exist in the network.

View Reports in the Elements Tab
The Elements tab provides detailed reports of the network elements and messages.

DescriptionReport

Shows the site information, which consists of the name of the sites, type and
their X and Y coordinate values.

Sites

Shows the information about the fiber length between the source and the
destination for the corresponding sites.

You can sort and filter the fiber details available in each column of the table.

Fibers

Shows the service type, source and destination sites for particular service,
quantity, protection type, and status.

For each service, the report shows the primary path, secondary path, and their
status.

Services
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DescriptionReport

The Waves report shows the number of waves available in the network and
the wave utilization. Click each wave to view the following details:

• Wave—Consists of a wave UID and its source and destination sites.

• Wave Details—Provides details of wave OSNR, channel path, OTN
services associated to wave and excluded channels.

• Channels—Port details of the source and destination cards, the
wavelength that is used, and its utilization demands.

• Optical Results—Provides details of optical parameters such as OSNR,
SOL, EOL, Power margin, CD, and PMD.

Waves

Lists the names of created SRLGs and their fiber details. Click Export at the
bottom to export the report in .xlsx format.

SRLGs

Shows messages that are related to errors occurred while analyzing the
network. By default, only critical messages for the analyzed network are
listed here. You can disable the Critical Only toggle button to view all
messages.

Click the link in the Target column to navigate to the respective object in the
network tree and take the necessary action to correct the error.

Messages

Click the Pop-up icon to view the reports in a larger, resizable window.Note

View Details of the BOM Report
Table 73: Feature History

Feature DescriptionRelease InformationFeature Name

The following new licensed PIDs
for the SMR-20 card are displayed
on the BOM page so that you can
view the price details and consider
ordering.

• NCS2K-FSSMR-2LIC=

• E-NCS2K-1P-LIC=

• E-NCS2K-5P-LIC=

• E-NCS2K-10P-LIC=

Cisco ONP Release 4.2Support for New PIDs for SMR-20
Card
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Table 74: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to perform
the following:

• Compare the BOMs of two or
more LNI imported networks.

• Upgrade brownfield network.

• Upgrade the Cisco ONP
network with traffic sites.

Cisco ONP Release 4.1MLP Brownfield with Diff BOM

The Bill of Materials (BOM) report includes these components:

• Detailed price lists for each site.

• Categories of elements such as Chassis, Controller, Mux-Demux, Line Card, Filler, and more.

• The overall BOM for the entire network.

To view the BOM for OTN and DWDM separately, click on each site.

You can compare the BOM of the existing network with other networks using the Compare with: Other
Networks option.

You can export the BOM details in the form of a spreadsheet, by clicking Export and saving it to your local
system.

From Release 24.3.1, the exported Excel file includes these updates:

• Sales BOM Sheet: Contains information tailored for sales personnel.

• Net BOM Sheet: Now includes the site-wise BOM count, providing a comprehensive overview of all
network elements in the analyzed network.

We recommend that you export the BOM report only in the analyze mode. Exporting the reports in the upgrade
and release upgrade modes may be inaccurate.

You can also compare the BOM of LNI imported networks.Note

From Release 4.2, Cisco ONP supports the listing of new licensed PIDs for the SMR-20 card. The PIDs are
chosen based on the demand. This is applicable only for the newly designed and upgraded networks.

• NCS2K-FSSMR-2-LIC=―20-port FS-SMR licensed to enable two ports

• E-NCS2K-1P-LIC=―Software license to enable one port on licensed 20-port FS-SMR

• E-NCS2K-5P-LIC=―Software license to enable five ports on licensed 20-port FS-SMR

• E-NCS2K-10P-LIC=―Software license to enable ten ports on licensed 20-port FS-SMR

Note
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From Release 5.1, Cisco ONP allows you to view the BoM details for any particular site. You must analyze
the network to view the BoM details of individual sites. The following steps allow you to check the PID
information for a selected site.

1. In the network tree, expand Site and click the Ellipsis icon available in the right side of the required site.

2. Click Open BoM.

The Cisco ONP opens the BoM tab and provides the BoM details of the selected site.

3. Expand the Site to view the PID information.

Note

From Release 5.2, Cisco ONP supports listing of new licensed PIDs for the NCS 1010 R7.11.1 networks.
This is applicable only for the newly designed and upgraded networks.

• NCS1K10-ATO=―NCS 1010 ATO

• SF-NCS1K10-7111K9S=―Software license to download the COSMNETCONFXML file for the COSM
UI.

• NCS1K4-CCMD-C=―16-port, C-Band Colorless Coherent Multiplexer/Demultiplexer with an EDFA

• NCS1K4-CCMD-L=―16-port, L-Band Colorless Coherent Multiplexer/Demultiplexer with an EDFA

Note

From Release 24.3.1, Cisco ONP supports listing of new licensed PIDs for the NCS 1020 R24.3.1 and NCS
1001 R7.10.1 networks. This is applicable only for the newly designed and upgraded networks.

• NCS1020-SA=―NCS 1020 Shelf Assembly

• NCS1020-FAN=―NCS 1020 Fan for NCS 1014 Slots

• NCS1020-FAN-BLANK=―NCS 1020 Fan Blank

• CWDM-SFP-1510=―CWDM 1510 NM SFP Gigabit Ethernet and 1G/2G FC

• CWDM-SFP-1610=―CWDM 1610 NM SFP Gigabit Ethernet and 1G/2G FC

• ONS-SC-Z3-1510=―SFP - OC48/STM16/GE, CWDM, 1510 nm, Commercial Temp

• ONS-SC-Z3-1610=―SFP - OC48/STM16/GE, CWDM, 1610 nm, Commercial Temp

• ONS-SE-155-1510=―SFP - OC3/STM1 CWDM, 1510 nm, EXT

Note
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From Release 24.3.1, Cisco ONP supports listing of new licensing PIDs and smart bandwidth licensing PIDs
for the NCS 1014 Transponder cards. This is applicable only for the newly designed and upgraded networks.

• S-NCS1K14-L-100U= : NCS 1014 100G Client Capacity Smart License - 400-600

• S-NCS1K14-L-100L= : NCS 1014 100G Client Capacity Smart License - 700-900

• S-NCS1K14-L-100M= : NCS 1014 100G Client Capacity Smart License - 1T-1.2T

• NCS1K14-2.4T-K9= : Network Convergence System 1014 2.4T Line Card

• NCS1K14-2.4T-X-K9=: Network Convergence System 1014 2.4T-X Line Card

• NCS1K4-QXP-K9=: NCS1004 3.2T QSFP-DD DCO Transponder

• ESS-TXP-SIA3: Essential Coherent DWDM interface SIA 36-59 months

• ESS-TXP-SIA5: Essential Coherent DWDM interface SIA 60-120 months

• ESS-TXP-RTU: Essential Coherent line card interface RTU

• ADV-TXP-SIA3: Advance Coherent DWDM interface SIA 36-59 months

• ADV-TXP-SIA5: Advance Coherent DWDM interface SIA 60-120 months

• ADV-TXP-RTU: Advance Coherent line card interface RTU

Note

View Details of Layout and Internal Connections
To get the details of layout and internal connections, perform the following steps:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Layout tab on the Cisco ONP home page.
Step 2 Type the site name in the search box, or select a site from the Sites drop-down list.

The site layout is displayed with its racks and cards. Hover the mouse pointer over the transponder card to view the details
of slot, PID of the card, and ports. Expand the Ports to view details, such as wavelength and trunk mode. Similarly, hover
the mouse pointer over chassis to know the total power consumption.

SVO supports up to 50 UIDs, beyond which, the site layout displays incorrect UID for the chassis.

Step 3 Click the IPC tab to view the selected site's internal patch connections.

Export Internal Connections
Cisco ONP allows you to export internal fiber connection in two ways, either at Site-level or Network-level.
To export the details, Click the Ellipsis icon available in the right side of the internal fiber connection or site,
and click Export.
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View End-to-End OCH Connections
Table 75: Feature History

Feature DescriptionRelease InformationFeature Name

You can now view the end-to-end
OCH connection details in the
graphical form for the analysed
NCS 1010 networks. The new
OCH tab inLayout displays all the
OCH connectivity from source to
destination in:

• Degree Connection View:
Displays the source and
destination site's connectivity.

• Functional View: Displays
the end-to-end port and card
connections from source to
destination through the fiber.

Cisco ONP Release 24.3.1View the End-to-End Optical
Channel (OCH) Connectivity from
Source to Destination

To view the end-to-end OCH connectivity from source to destination, perform the following steps:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Layout tab on the Cisco ONP homepage.
Step 2 Click the OCH tab.

The OCH Pipes pane appears to display the sites and sections in the circuits tree.

Step 3 Click the ellipses (3 vertical dots) icon next to the Circuits.

A pop-up list appears to display the view options.

Table 76: Option Descriptions

DescriptionsOptions

Expands all the items in the circuits tree.Expand All

Collapses all the items in the circuits tree.Collapse All

Step 4 Use the search bar or filter icon to select the required source and destination sites.
DescriptionIcon/Field

Locates the site based on the typed-in site name.Search

Filters the circuit based on Source Site and Destination
Site.

Filter
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DescriptionIcon/Field

Resets the filter conditions.Reset

Based on the unit that you select in the circuit tree, you can see the site connectivity or the detailed end-to-end OCH
connectivity.

Then you can see the...If you click the...

source and destination site connectivity only.circuit in the OCH tree

end-to-end OCH connectivity, including intermediate nodes and cards connectivity.sections in the OCH tree

Step 5 In the graphical area, use the action icons to view the source and destination sites connectivity.

Table 77: Action Icons

DescriptionIcons

Zooms in for a closer view of the specific connectionZoom In

Zooms out for a larger view of the entire connectionZoom Out

Resets the zoom-in/zoom-out view to the default viewFit View

Locks the view at a specific area

Unlocks the view

Lock/Unlock

Downloads the end-to-end circuit connection as PNG imageDownload PNG

• Degree Connection View: Displays the source and destination site's
connectivity

• Functional View: Displays the end-to-end port and card connections from
source to destination through the fiber

Switch to Degree Connection View /
Switch to Functional View

Reverts the nodes to the default positionReset All Nodes Position

Export End-to-End OCH Connections
To view the end-to-end OCH connectivity from source to destination, perform the following steps:

Step 1 In the graphical area, click the download icon.

The Export pop-up list appears to display the circuit options.
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Table 78: Option Descriptions

DescriptionsOptions

Provides details of the end-to-end OCH connectivity for the circuit that you
selected

Current Circuit

Provides details of the end-to-end OCH connectivity for all the circuitsAll Circuits

Step 2 Click the required option to export the end-to-end OCH connectivity details in an excel sheet.

View Power Consumption and Unit Weight Report
Table 79: Feature History

Feature DescriptionRelease
Information

Feature Name

Now, you can generate the power consumption and unit weight
report for each product ID (PID). In the layout tab, you can see the
power consumption and unit weight values and export them into
Excel as a report for a single site or all sites. With prior knowledge
of power consumption and weight details for each PID, you can
plan and design an energy-efficient network.

The new options that allow you to view and export the reports are:

• Show Typical Power Consumption

• Show Max Power Consumption

• Show Unit Weight

• Power Consumption & Weight

Cisco ONP
Release 5.2

Power Consumption
and Unit Weight
Report

The Power Consumption and Unit Weight report includes power consumption and weight details of cards
and shelves in each individual site. To view the Power Consumption and Unit Weight of each site, perform
the following steps.

The power consumption of the Power Supply Unit (PSU) is not included in the total power consumption for
the NCS 1001, NCS 1010, NCS 1014, and NCS 1020 chassis. To determine the total power consumption for
these chassis, add eight percent of the aggregated power consumption of all the cards inside the chassis to
cover the PSU power consumption.

Remember

You must upgrade and analyze the LNI network to view the power consumption and weight report.Note
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Layout tab on the Cisco ONP home page.
Step 2 Click the ellipses (3 vertical dots) icon next to the Sites.

A pop-up list appears to display the following options.

Table 80: Option Descriptions

Options

Expands all the items in the layout tree.Expand All

Collapses all the items in the layout tree.Collapse All

Check the Show Typical Power Consumption check box to view the typical power
consumption values of each card and shelf in watts.

Show Typical Power
Consumption

Check the Show Max Power Consumption check box to view the power consumption
values of each card and shelf in watts.

Max Power Consumption for a shelf is the sum of cards and modules.

The total power consumption of an NCS 2000, NCS 4000, or NCS 1000 shelf
changes based on AC or DC power supply.

Note

• For DC power supply, total power consumption of the shelf includes all
Cards, DC power module, and fan tray.

• For AC power supply in NCS 2000 M6 only, total power consumption of
the shelf includes all cards, fan tray, 10% of power consumed by all cards,
and 5W of Cooling Unit power consumption.

Show Max Power
Consumption

Check the Show Unit Weight check box to view the weight of each card and shelf in
kilogram.

Unit Weight for a shelf is the sum of cards and modules.

Show Unit Weight

Step 3 Choose the options as required.

Export Power Consumption and Unit Weight Report
To export the power consumption and weight report of each shelf and card, perform the following steps:

Step 1 In the graphical area, click the download icon.

The Export pop-up list appears displaying the following options.
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Table 81: Option Descriptions

Options

Provides details of the site that you selected.Current
site

Provides details of all the site.All Sites

Step 2 Click the option as required.
Step 3 Click Power Consumption & Weight to export the optical reports details in an Excel sheet.

We recommend that you export the power consumption and weight report only in the analyze mode. Exporting the reports
in the upgrade and release upgrade modes may be inaccurate.

Compare the Installation Parameters of Two Networks
Table 82: Feature History

Feature DescriptionRelease InformationFeature Name

This feature improves the user
experience while comparing the
installation parameters and optical
reports of two networks.

Cisco ONP Release 4.1UI Revamp of Optical Reports

Use this task to compare the installation parameters of two networks.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Results tab on the Cisco ONP home page.
Step 2 Click Installation Parameters.
Step 3 Click Other Networks.
Step 4 From the list of networks, choose the network to compare with.

You can find a new parameter called diffBy.

You can click Clear to stop the comparison of two networks.Note

Step 5 Click Export Report to export the comparison report.

Compare the Optical Report of Two Networks
Use this task to compare the optical report of two networks.
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Results tab on the Cisco ONP home page.
Step 2 Click Optical Report.
Step 3 Click Other Networks.
Step 4 From the list of networks, choose the network to compare with.

You can find two values in the optical parameters such as Protection, SOL, EOL, SE, P/F, Source, Src Colorless, Src
Contentionless, Destination, Dst Colorless, Dst Contentionless, Wavelength, Src Tx Type, Dst Tx type, Span, Suggested
Regen Locations, BER Target, SOL OSNR, EOL OSNR, SOL OSNR margin, EOL OSNR margin, SOL RX, EOL RX,
SOL Power Margin, EOL Power Margin, SOL Overload, EOL Overload, Residual CD, CD robustness, Single-Channel
NLE Status, Multi-Channel NLE Status, Min GB, Filtering Penalty, PMD, RX Atten, TX Atten, Encryption, SNLE
Components, MNLE Components, OSNR Penalties and POWER Penalties.

You can click Clear to stop the comparison of two networks.Note

Step 5 Click Export Report to export the comparison report.

View the Results of Analysed Network
Use this task to view the details of optical reports, installation parameters, traffic reports, and cabling reports.

Optical results are available only in Upgrade and Release Upgrade modes. You can refer to the optical results
data to check and correct the optically not feasible channels. After making the necessary corrections, analyze
again to update the optical results based on the newmodifications in the Upgrade and Release Upgrademodes.

Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Results tab on the Cisco ONP home page.
By default, the Optical Report tab appears. Each row in the tab shows the performance of one optical path. See Optical
Report, on page 234.

From Release 5.1, the OSNR RBW drop-down list allows you to select the OSNR Resolution bandwidth between 0.5
nm and 0.1 nm. The default value is 0.5 nm. This value can be changed in all the modes such as Design mode, Analyzed
mode, Upgrade mode, and Release upgrade mode. When you change the value to 0.1 nm the SOL G-OSNR and EOL
G-OSNR value increases to 7dB.

From Release 5.1, Cisco ONP allows you to view the optical report for any particular optical path. You must analyze the
network to view the optical report of an individual optical path. The following steps allow you to check the wave and
aggregated wave information for a selected circuit.

a. In the network tree, expand Circuits/Waves/Media Channels and click the Ellipsis icon available in the right side
of the required optical path.
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b. Click Open Results.

The Cisco ONP opens the Optical Report tab and provides the details of the selected optical path.

c. Expand the optical path to view the wave information.

From Release 24.1.1, you can view the multicarrier sites highlighted in the Optical Report tab, and organized in
the Installation Report tab.

Note

Step 2 Click Export Report to export the optical reports details in an Excel sheet.

We recommend that you export the optical report only in the analyze mode. Exporting the reports in the upgrade and
release upgrade modes may be inaccurate.

Step 3 Click the Installation Parameters tab.

The Installation Parameters report shows the values to be set (provisioned) at the installation time on each site in the
network.

To view the installation parameters for Automatic Node Setup (ANS) and Automatic Node Provisioning (ANP), click
the ANS , and ANP tabs. See Installation Parameters, on page 236

Step 4 Click the Traffic Report tab.

You can view the aggregated demand channel data in the form of the traffic reports. See Traffic Reports, on page 237.

To view the traffic report for any particular optical path, do the following:

a. In the network tree, expand Circuit and click the Ellipsis icon available in the right side of the required
optical path.

b. Click Open Results.

The Cisco ONP displays the traffic report for the selected optical path.

By default, clickingOpen Results opensOptical Result under theResults tab. Youmust clickTraffic
Report to view traffic reports.

Note

c. Expand the optical path to view the wave information.

In Release 5.1, you can view traffic report for all imported networks except the imported .mpz networks. To view
the traffic report for individual optical path in imported .mpz networks, you must manually search in the Search
box.

Note

Step 5 Click the Cabling Report tab. See Cabling Report, on page 238

You can view the patch cord connections related to internal patch connections and multi-shelf management. This report
is available for the networks starting from NCS 2000 system Release 12.1.0.

From Release 5.1, Cisco ONP allows you to view the internal patch connections for any particular site. You must analyze
the network to view the IPC details of individual sites. The following steps allow you to check the IPC information for
a selected site.

a. In the network tree, expand Site and click the Ellipsis icon available in the right side of the required site.

b. Click Open Cabling Report.

The Cisco ONP opens the Cabling Report tab. By default, the IPC tab appears and provides the IPC details of the
selected site.
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c. Expand the Site to view the internal patch connections.

Use the Search box on top of the reports to search for any specific site or wave in the reports. The following steps help
you to find any specific information in the reports.

a. Enter the name of the specific site or wave in the Search box.

b. Choose equals or contains from the drop-down list.

c. Click the Search icon to search for the required site or wave.

Optical Report
From Release 24.3.1, you can filter the results by any column available in the report for more precise data
analysis. For reports represented as colored icons, you can use the first letter of the color (e.g., "g" for green)
to filter the results.

Table 83: Optical Report

Optical Parameter

Displays the ID number of the wave and aggregated waves. ID is automatically
generated based on the site name.

Name

Displays the protection type of the wave.Protection

Displays whether the path type is Protected or Working path for NCS 1001.Protection Type

Displays an icon indicating the results summary of the analysis that is run with
Start of Life (SOL) fiber loss values:

• Green indicates success.

• Yellow indicates success with a marginal failure risk.

• Orange indicates that the channel has a higher risk of failure.

• Red indicates failure.

SOL

Displays an icon indicating the results summary of the analysis that is run with
End of Life (EOL) fiber loss values. The indicator shows the optical performance
for the path at the end of the fiber life:

• Green indicates success.

• Yellow indicates success with a marginal failure risk.

• Orange indicates that the channel has a higher risk of failure.

• Red indicates failure.

EOL

Indicates a system-related error that may impact the analysis of the design. If
the indicator is red, review themessages that are reported at the end of the analysis
or determine which units or sites have a problem.

SE
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Optical Parameter

Displays the present or forecast services indication.P/F

Displays the name of the source site and side; for example, Site 1-E.Source

Displays whether the colorless functionality is enabled on source ports.Src Colorless

Displays whether the contentionless functionality is enabled on source ports.Src Contentionless

Displays the name of the destination site and side; for example, Site 1-E.Destination

Displays whether the colorless functionality is enabled on destination ports.Dst Colorless

Displays whether the contentionless functionality is enabled on destination ports.Dst Contentionless

Displays the wavelength of the optical channel.Wavelength

Displays the band type of the optical path.Band Type

Displays the type of DWDM unit or pluggable port module that is used at the
source of the specific Optical Channel (OCH) trail. The class of the DWDMunit
is also displayed.

Src Tx Type

Displays the type of DWDM unit or pluggable port module that is used at the
destination of the specific OCH Trail. The class of the DWDM unit is also
displayed.

Dst Tx type

Displays the total span length (source to destination) for this path in kilometers.Span

Displays the regeneration locations.Suggested Regen
Locations

Displays the bit error rate (BER) target for this channel, based on the capability
of the channel’s optical interface. It is 1.0E-15 for the interfaces using forward
error correction (FEC) and 1.0E-12 for interfaces without FEC.

BER Target

Displays the start of life average Optical Signal to Noise Ratio (OSNR) value
at the receiver.

SOL OSNR

Displays the end of life average OSNR value at the receiver.EOL OSNR

Displays the SOL OSNR margin calculation. It is the difference between the
OSNR value at certain power of the working point of the receiver client and the
working area boundary.

SOL OSNR margin

Displays the EOL OSNR margin calculation, which is the difference between
the OSNR value at a certain power of the working point of the receiver client
and the working area boundary.

EOL OSNR margin

Displays the SOL average power that is received at the destination site in dBm.SOL RX

Displays the EOL average power that is received at the destination site in dBm.EOL RX

Displays the SOL power budget margin at the receiver in decibels. It is defined
as the offset between the receiver working point and the BER curve with margin.
A positive value indicates that there are no power problems.

SOL Power Margin

Displays the EOL power budget margin at the receiver in decibels. It is defined
as the offset between the receiver working point and the BER curve with margin.
A positive value indicates that there are no power problems.

EOL Power Margin
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Optical Parameter

Displays the SOL overload margin at the receiver in decibels. A positive value
indicates that there are no overload problems.

SOL Overload

Displays the EOL overload margin at the receiver in decibels. A positive value
indicates that there are no overload problems.

EOL Overload

Displays the chromatic dispersion (CD) margin of the demand.Residual CD

Displays the robustness to chromatic dispersion of the receiver.CD robustness

Displays the status of alarms if any nonlinear effect (NLE) is present in the
demand.

Single-Channel NLE
Status

Provides the status of the nonlinear effect (NLE) on a particular channel or
demand due to other channels or demands.

Multi-Channel NLEStatus

Displays the minimum Guard Band (GB) requirement between channels on the
40G CP-DQPSK MXP and 40G CP-DQPSK ME MXP cards, and other
transponders in a mixed any-to-any connectivity.

Min GB

Displays the value of the penalties that are caused by different filter types
(OADM, ROADM, and arrayed waveguide grating (AWG)).

Filtering Penalty

Displays the calculated total PolarizationMode dispersion (PMD) for each circuit.
If the overall PMD for the link overcomes the maximum that is allowed, the
PMD value is displayed in a red-colored font. The maximum allowed value
depends on the client interface. For these special cases, the network must be
manually resolved by contacting a Cisco TAC team.

PMD

Displays the attenuation at the input of the receiver.RX Atten

Displays the attenuation at the output of the receiver.TX Atten

Displays the encryption type of the channel. Possible values are N/A, Yes, No.Encryption

Installation Parameters

Table 84: ANS Parameters

DescriptionParameter

Displays the name of the siteName

Displays the line sideSide

Displays the rack, shelf number, and slot position of the card where the patch cord
originates.

Position

Displays the name of the card.Unit

Displays the port number where the patch cord originates.Port

Displays the port ID.Port ID

Displays the name of the port.Port Label
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DescriptionParameter

Displays the name of the parameter to be set, such as RX Power Low, PSDShape, PSD,
Gain, AmpliGainRange, AddAttenuation, DropAttenuation, Control Mode,
MinExpSpanLoss, MaxExpSpanLoss and so on.

For the CCMD-16 LC card connected to the ports of the OLT-E-C, the PSD is set using
a specific formula and the VOA drop attenuation is set to 0dB to have optimal RX power
for the circuits.

Parameter

Displays the name of the value to be set for the parameter.Value

Displays the measurement unit for the related installation parameter value, such as dBm.Measurement
Unit

Indicates with a Yes or No which parameters must be manually set using the Cisco
Transport Controller (CTC) interface.

Manual Set

Table 85: ANP Parameters

DescriptionParameter

Displays the name of the site.Name

Displays the unit (slot number) of the passive units in the shelf.Unit ID

Displays the shelf identifier.Shelf ID

Displays the rack number.Rack Number

Identifies the rack position in the shelf.Rack Position

Identifies the slot position in the shelf for the card.Slot Position

Displays the card type.Equipment
Type

Displays the details of the card type.Description

Traffic Reports

Table 86: Traffic Reports

DescriptionTraffic Report

Categorizes each demand type. Each demand is further
categorized into service, trails, and sections.

Demand

Displays the sections under every service.Section

Displays the site name for the optical channel source.Src Site

Displays the band type for the optical path.Band Type
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DescriptionTraffic Report

Displays the rack, shelf ID, and slot identifiers for the
source of the optical channel.

Src Position

Displays the unit name for the optical channel source.Src Card

Displays the site name for the optical channel
destination.

Dst Site

Displays the rack, shelf ID, and slot identifiers for the
destination of the optical channel.

Dst Position

Displays the unit name for the optical channel
destination.

Dst Card

Displays the client service type of the demand; for
example, OC-48.

Client Service Type

Displays the protection type of the demandProtection Type

Displays whether the demand is encrypted or not,
values are NA, Yes, No.

Encryption

Displays the wavelength value of the optical channel,
and the serial number of the wavelength in the
wavelength band.

Wavelength

Displays the latency time for the current circuit. This
value includes all the latency components for the
circuit, including fiber and DWDM units on the path.

Max Latency (for NCS 2000 network)

Displays the latency time for the fiber.Fiber Latency (for NCS 1010 and NCS 1001)

Cabling Report
The IPC Cabling Report and the IPC Patch Report are now consolidated into a single, unified view with
additional columns. This streamlines connection details and eliminates the need to access multiple sources.

Table 87: IPC

DescriptionParameter

Displays the name of the site.Name

Displays the source unit.Src Unit Type

Displays the rack, shelf, and slot position of the card
from which the patch cord originates.

Src Position

Displays the name of the port.Src Port Label

Displays the assigned rack number.SrcFicBay
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DescriptionParameter

Displays the type of shelf or the shelf name.SrcShelfName

Displays the type of shelf or the shelf name.SrcShelfNumber

Displays the unique ID assigned to the shelf. The
unique ID will be used in COSM XML to posh the
configuration to the device.

SrcShelfUniqueId

Displays the rack unit position in layout.SrcRUPosition

Displays the card slot number within the Shelf .SrcCardNumber

Displays the type of cable.Cable

Displays the source unit.Dst Unit Type

Displays the rack, shelf, and slot position of the card
from which the patch cord terminated.

Dst Position

Displays the name of the port.Dst Port Label

Displays the assigned rack number.DstFicBay

Displays the type of shelf or the shelf name.DstShelfName

Displays the assigned shelf number.DstShelfNumber

Displays the unique ID assigned to the shelf. The
unique ID will be used in COSM XML to posh the
configuration to the device.

DstShelfUniqueId

Displays the rack unit position in layout.DstRUPosition

Displays the card slot number within the Shelf .DstCardNumber

Indicates whether a cable connection will be
automatically generated or requires manual
configuration for NCS 2000 networks.

ManuallySet/AutomaticallySet

Table 88: MSM

DescriptionParameter

Displays the name of the site.Name

Displays the source unit.Src Unit Type

Displays the rack, shelf, and slot position of the card
from which the patch cord originates.

Src Position

Displays the source unit ID.Src ID

Displays the name of the port.Src Port Label
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DescriptionParameter

Displays the type of cable.Cable Type

Displays the source unit.Dst Unit Type

Displays the rack, shelf, and slot position of the card
from which the patch cord terminated.

Dst Position

Displays the destination unit ID.Dst ID

Displays the name of the port.Dst Port Label

Displays whether the connection relates to a present
or forecast circuit.

W/P

Confidential Banner
Table 89: Feature History

Feature DescriptionRelease InformationFeature Name

This feature indicates the
confidentiality of the reports or
results generated by Cisco ONP for
a network. The CONFIDENTIAL
banner is placed in all the exported
reports. It is placed in the first row
and first cell of the Excel sheet,
followed by a blank row and the
contents of the exported report.

Cisco ONP Release 4.1Confidential Banner

Table 90: Feature History

Feature DescriptionRelease InformationFeature Name

The Confidential Banner string can
be customized as required. An
admin user can modify the banner
string when the
confidentialBanner.enabled field
is set to true in the
feature.properties file.

Cisco ONP Release 4.2Customizable Confidential Banner

The CONFIDENTIAL banner is to be present in all the exported reports. It is placed in the first row, first
cell of the Excel sheet (.xslx), followed by a blank row and the contents of the exported report.

The exported reports include:

• Sites

• Fibers
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• Services

• Waves

• Traffic

• Failure (Plan and Restore)

• BOM

• Media Channel

• SRLG

• Messages

• Optical Result

• Failure Group

• Cabling Report

• Service Aggregation

• IPC (Individual and All sites)

• The CONFIDENTIAL banner is present in all the sheets, if multiple sheets are present in the xlsx file.

• The CONFIDENTIAL banner is updated, only when you export the reports in .xlsx format.

• The server admin can customize the banner string CONFIDENTIAL in the confidentialBanner.content
field as required. The admin must set the confidentialBanner.enabled field to true in the feature.properties
file to enable banner change. By default, the confidentialBanner.enabled value is set to false.

Note
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C H A P T E R 7
Backup and Restore Cisco ONP Database

• Backup Database, on page 243
• Restore Database Using Script, on page 246

Backup Database
Based on the database backup configuration on the server, as set by the system admins, you can take the
backup of the complete database on a daily, weekly, or monthly basis. Only system admins can access the
backup folders and restore them. Backup archive is stored on highly durable NFS share. The following backup
archives are available:

• Archives for the last 7 days

• Weekly archives for the last 4 weeks

• Monthly archives for the last 6 months

You can change the duration for monthly archives.Note

Setup Backup

Before you begin

• Ensure that highly durable 2 TB NFS storage is available to store database archives.

• Ensure that the storage is accessible from the Cisco ONP environment. Set up rules that are defined by
the Cisco ONP network and appropriate ACL (Access Control List) to permit or deny access to the
storage.

Step 1 Log into the Cisco ONP server, where you have installed Cisco ONP by using the tar archive.
Step 2 Create a folder for backup. Ideally it should be mounted on a reliable object storage (like NFS).
Step 3 Copy backup, rotation, and setup backup scripts from ONP/images folder to the new folder created in step 2.
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Example:
$ cd

$ mkdir cnp_backups

$ tree ~/cnp_backups/

/home/ciscocnp/cnp_backups/

├── backup_postgres.sh

└── rotation.sh

└── setup_backup.sh

Ensure that all scripts have necessary permissions:
$ chmod +x backup_postgres.sh

$ chmod +x rotation.sh

$ chmod +x setup_backup.sh

$ ls -l | grep .sh

-rwxrwxr-x 1 ciscocnp ciscocnp 518 Jan 16 05:23 backup_postgres.sh

-rwxrwxr-x 1 ciscocnp ciscocnp 1412 Feb 1 05:50 rotation.sh

Step 4 Copy restore_postgres.sh from /ONP/images/.

Perform Manual Backup
Perform the following steps for the backup operation:

Step 1 Browse to the location, where the backup_postgres.sh script is stored.
Step 2 Execute the rotation.sh script using the following command:

user@server:~/cnp_backups$ bash rotation.sh

This command creates necessary folder structure.

Step 3 Execute the backup_postgres.sh script using the following command:

Example:
user@server:~/cnp_backups$ bash backup_postgres.sh

The backup file gets stored in the daily backup folder (backup.daily) with the current time stamp.

Schedule a Backup

Schedule a Backup Using Script
Use this task to schedule the backup operation using script:
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Step 1 Log in to the Cisco ONP server.
Step 2 Execute the rotation.sh script using the following command:

user@server:~/cnp_backups$ bash rotation.sh

This command creates necessary folder structure.

Step 3 Execute the setup_backup.sh script using the following command:

Example:
user@server:~/cnp_backups$ bash setup_backup.sh

The backup file gets stored in the daily backup folder (backup.daily) with the current time stamp.

Step 4 Enter the path in the user prompt to store the file.
Backup files are stored in your required file path as following:
/user-defined path/backups/backup.daily

Schedule a Backup Using Crontab
Use this task to schedule the backup operation using Crontab:

Step 1 Log in to the Cisco ONP server.
Step 2 Configure the Crontab job using the following command.

user@server~/cnp_backups$ sudo crontab -e

Step 3 Modify the Crontab.sh script to schedule the backup.

Example:

The following example shows the scheduling of the backup operation, at 3 a.m daily.
0 3 * * * /home/ciscocnp/cnp_backups/backup_postgres.sh

Syntax to Schedule the Backup Using Crontab
Use the following syntax to schedule backup in Crontab:
m h dom mon dow

Where:

• m—Minutes (0–59)

• h—Hours (1–23)

• dom—Day of the month

• mon—Month of the year

• dow—Day of the week
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To define the time, you can provide concrete values for minute (m), hour (h), day of the month (dom), month
(mon), and day of the week (dow), or use the wildcard, '*' in these fields (for 'any').

The backup jobs start based on the cron's system daemon's notion of time and time zones.Note

Restore Database Using Script
You can restore the database using script, which is available at the following location:

/ONP/Images/restore_postgres.sh

Execute the following command:
$ sudo bash restore_postgres.sh DB backup archive file path.

For example:
$ sudo bash restore_postgres.sh /backups/backup.daily/2019-05-05-23-58.archive

The database backup is created and a confirmation prompt appears asking to delete the database.
!!! WARNING! Complete Restore Operation will replace Existing Database with Backup Database
(Recommended) !!!
Do you want Complete Restore? (Yes/No) [default - Yes]

Enter Yes to delete the database and restore the database with backup file.

Enter No to not delete the database and apply only missing data(s) from backup file.
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A P P E N D I X A
Cisco ONP UI Reference

This appendix chapter describes the various options available in the Cisco ONP UI.
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Table 91: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP Release 24.3.1User Interface Enhancements
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Feature DescriptionRelease InformationFeature Name

Cisco ONP improves the user
experience with these user interface
enhancements:

• Maps:

• Providing an option to
increase the workable
area.

• Switching to zoommode
that automatically centers
the map on the selected
node.

• Highlighting nodes and
fibers selected in the
network tree on the map.

• Entity Editor: Adding
tooltips for some of the
properties.

• Results:

• Including Raman
information in the Fiber
Details that are exported
from Export>Fibers.

• Introducing Export
Report button to export
Optical Reports/BOM
differences between two
networks in CONP.

• Maintaining the recent
view in the Results tab
view when switching to
the Map or BoM tabs.

• Enabling editing of EOL
Aging Loss with Aging Loss
[dB] property in both the
entity editor and Properties
pane.

• Updating optical sources with
minimum system release
information for user visibility
in the Manage Optical
Source dialog box.
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Feature DescriptionRelease InformationFeature Name

• Adding an OMNI marker to
identify the Omni-Directional
sides in the NCS 2000
networks.

• Component Logs:
Streamlining logmanagement,
this Logs menu option
provides direct access to
critical component logs such
as cnp Backend (BE), ODE,
GENE, and PCE through the
user interface.

• Menu Bar, on page 250
• Network Tree, on page 258
• Design Palette, on page 260
• Entity Editor, on page 262

Menu Bar
The following table describes the options available in the Cisco ONP GUI menu bar.

DescriptionOptions

Includes the common file options such as New, Open, Open Shared, Save, Save As, Share,
and Delete

File

Includes Entity Editor, Analyze, and SSON ConvertNetwork

Includes options to export reports of CPZ, sites, fibers, SRLGs, services, waves, media
channels, optical results, service aggregation, BOM, and messages. Export enables you to
download excel and LNI templates

Export

Imports different types of files (CPZ, Excel, LNI, and MPZ) and designs a network in Cisco
ONP

Import

Manages Layout Templates and Optical SourcesManage

Displays logs events that are initiated during a specific period, such as user login, user logout,
password change, and LNI - start, failed, and completed

Logs

Checks and manages tasks running in the backgroundJob Monitor

Manages users, user groups, user roles, permissions, system configuration, and dictionaryControl Panel

Includes options to change the default map view and personalize the color code for spectrum
utilization

Preferences

Displays the Cisco ONP versionHelp

Shows last date and time when the user logged in to Cisco ONP, and last login with IP detailsLast Login
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DescriptionOptions

Shows name of the user who has currently logged in to Cisco ONPUsername

File
The File menu includes common file options such as New, Open, and Delete.

DescriptionOptions

Creates a new network. By default, NCS 1010 is created. To create NCS 2000 networks,
change L0 Network Platform to NCS2000. You can check the SSON Network check box
and select System Release for NCS 2K to create an SSON network.

New

Opens a saved network. The network name in blue-colored font indicates that the network is
in the Design mode, and the network name in green-colored font indicates that the network
is in the Analyze mode.

If you view a blank screen when you open a network, refresh the browser, or log in
to Cisco ONP again.

Note

Open

Opens a shared network.Open Shared

Saves a network.Save

Saves the network with a new name.Save As

Shares a network or networks.Share

Deletes a network or networks.Delete

Network
The Network menu includes options such as Entity Editor, Analyze, and SSON Convert in the design mode.
It includes options such as Entity Editor, Design, Upgrade, and Enter Plan Mode in the Analyze mode.

DescriptionOptions

Use this option to edit various properties of an element in the networkEntity Editor

Analyzes the network after completing the designAnalyze

Converts a Non-SSON network to an SSON networkSSON Convert

Switches from Analyze mode to Design, Upgrade, or Release Upgrade modeDesign

Upgrades an existing network that is in the Analyze modeUpgrade

Upgrades the NCS 2K or NCS 1010 System Release of a networkRelease Upgrade

Switches to the Plan modeEnter Plan Mode

Exits the plan modeExit Plan Mode
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DescriptionOptions

Enters the link rate tuner modeEnter Link Rate Tuner
Mode

Opens the tuner input table to add parameters for custom optical sourcesOpen Tuner Input

Runs the tuner input options to provide custom optical source results.Run Tuner

Starts fresh tuner analysisStart New

Opens the already analyzed tuner resultsOpen Tuner Result

Exits the link rate tuner modeExit Link Rate Tuner Mode

Restores failed fibers and nodesRestore

Expands the Failure Report from the bottom of the Map. Data is populated
after Restore.

Open Failure Report

Expands the Feasibility Report from the bottom of theMap. The report displays
the data regarding Auto Regen Suggestions for channel feasibility.

Open Feasibility Report

Export
The Export menu includes options to export reports of Sites, Fibers, Services, SRLG, Waves, Messages, and
BOM.

DescriptionOptions

Export the .cpz design file of a network into your local system.CPZ

Exports site details such as x and y coordinates, grooming site flag, CLLI
code, site address, site type, and site name.

Sites

Exports fiber details such as length, loss to fiber, source and destination site,
source and destination edge.

FromRelease 24.3.1, the exported fiber details contains the Raman information.

Fibers

Exports service details such as name, type, path, quantity, and protection.Services

Exports details about created SRLGs.SRLGs

Exports wave details such as Label, Source and Destination sites, Card Type,
Wavelength, Utilization, Source port, Destination port, Demands, OTNHops,
OSNR,OSNRMarginEOL, StatusEOL, ExcludedChannels, and Path ofWave.

Waves (Available for
non-SSON network)

Exports media channel details such as Media Channel Label, Media Carrier
Label, Source and Destination sites, Card Type, Wavelength, Utilization,
Source port, Destination port, Demands, OTN Hops, OSNR,
OSNRMarginEOL, StatusEOL, Excluded Channels, and Path of Media
channel.

Media Channels (Available
for SSON network)
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DescriptionOptions

Exports circuits details such as Circuit Label, Carrier Label, Source and
Destination sites, Card Type, Traffic Type, Wavelength, Utilization, Source
port, Destination port, Demands, OTN Hops, OSNR, OSNRMarginEOL,
StatusEOL, Excluded Circuits, and Path of Circuit.

Circuits (Available for
NCS1010 network)

Shows the complete log of the analysis, including critical errors.Messages

Download sample Excel file that can be used as a reference for creating
networks using the Import Excel feature.

Excel

Download sample LNI file that can be used as a reference for creating networks
using the Import feature.

LNI Template

Download sample Optical Source Excel file that can be used as a reference
for creating User Defined/customOptical Source using theManage >Optical
Sources feature.

Optical Source Template

Exports details about pricing and quantity of the network equipmentBOM

This option is available only in the plan mode. You can add failed fibers to a
failure group.

Failure Groups

This option is available only in the plan mode. It shows the failed fibers, total
channels, failed channels, restored channels, and fiber hotzones.

Failure Report

Exports details such as protection type, SOL, EOL, source, and destinationOptical Results

Exports the Device Netconf XML file and COSM Netconf file.Device Configuration

Import
The Import menu imports an Excel file, a CPZ file, or an MPZ file.

DescriptionOptions

Imports the .cpz network design files that are exported from another Cisco ONP instanceCPZ

Imports an Excel file containing all the design parametersExcel

Imports a live deployed network by retrieving configurations of the nodes, provided in the LNI
input Excel sheet

Live

Imports the .mpz network design files from CTP to Cisco ONP, to avoid recreating the networks
that are already created in CTP

MPZ

Manage
You can manage layout templates and optical sources.
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DescriptionOptions

Imports reusable templates to design layout configurations for a networkLayout
Templates

Imports an optical source from your local systemOptical Sources

Logs

System Logs

The System Logs option allows an admin user, or user with USER MANAGEMENT, and NETWORK
MANAGEMENT permissions to view at logs the events that are initiated during a specific time interval.
Examples of events are user login, user logout, password change, Live Network Import (LNI)-start, failed,
completed and analysis-start, and failed.

The SYSTEM LOGS page includes the following fields:

DescriptionField

Provides the date and time of the specific eventTime Stamp

Shows the type of event, which includes user login, user logout, password
change, and so on

Event Type

Describes the event, which includes user login success, user logout
success, and so on

Description

Shows the user who has initiated specific eventsUsername

Shows the IP address of the device from where the event is initiatedEvent Source

Events that are captured in the System Logs are:

DescriptionEvent

New user sign-up for Cisco ONPSIGNUP

User log in to Cisco ONPLOGIN

User state change from Active to Inactive and the converseUSER STATE CHANGE

User role change, such as admin to planner, and so onUSER ROLE CHANGE

User log out from Cisco ONPLOGOUT

Deletion of a particular userUSER DELETION

User enters invalid login credentialsUNAUTHORIZED

Successful initiation of Live Network ImportLNI_START

Successful completion of live import of a networkLNI_COMPLETE

Cancellation of Live Network ImportLNI_CANCEL
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DescriptionEvent

Imported Live network data is successfully purgedLNI_PURGE

Analysis of LNI network started successfullyANALYZE_LNI_START

Analysis of LNI network completed successfullyANALYZE_LNI_END

Populating of L0 DesignData initiatedLNI_POPULATE_DESIGN_DATA

Starting of the network analysisANALYZE START

Completion of the network analysisANALYZE END

Cancellation of the network analysisANALYZE CANCEL

Entering the Upgrade modeUPGRADE NETWORK

Entering the Plan modePLAN_INIT

Exiting the Plan modePLAN_END

Checking for alternate paths to restore failed media channels or wavesPLAN_REROUTE

Restoration of failed media channels or waves in progressPLAN_PROGRESS

Upgrading the system release of the network is in progress.RELEASE_UPGRADE_NETWORK

Component Logs

The Component Logs option allows you to access logs for multiple critical components such as cnp Backend
(BE), ODE, GENE, and PCE, directly through the user interface. This streamlines the process, eliminating
the need for server access and manual file navigation. This enhancement simplifies log management, aiding
in performance monitoring, troubleshooting, and system insights.

The Component Logs page includes the fields:

DescriptionField

Provides the date and time of the specific eventTime Stamp

Describes the events for the selected componentLogs

Provides list of critical components to choose from. The available
components are:

• BE

• ODE

• GENE

• PCE

Component

Locates specific log entries based in the entered valueSearch
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DescriptionField

Allows you to navigate through logs page by pagePages

Job Monitor
The Job Monitor menu checks and manages tasks running in the background.

You can access this menu if you have ADMIN, NETWORK_MANAGEMENT, or NETWORK_PLANNING
role.

The JOB MONITOR page has the following options:

DescriptionOptions

Refreshes the display information.Refresh

Applies one or more of the following filter options:

Task Type: Filters the display information based on the task type.

Select Start Date: Filters the display information based on the start date of the
task.

Select End Date: Filters the display information based on the end date of the task.

Username: Filters the display information based on the username.

Filter

The date on which the task is started by the user.Created Date

Name of the user who initiated the job.User Name

Name of the network on which the task is running.Network Name

The type of background task: Valid values are ANALYZE and EPNM_IMPORT.Task Type

The current state of the task.Messages

Enables you to cancel or stop an ongoing background task:

• The Admin can cancel any of the running background tasks. Other valid
users can cancel only their own tasks.

• If you want to cancel your ongoing network analysis, you can open Cisco
ONP at the browser in incognito mode, or contact the Admin.

• After a task is cancelled, it gets removed from the job monitor. You can
check the status of a cancelled task from System logs page. Click Logs to
open the System logs page.

Cancel

Enables you to view the status of the LNI operation.Check Progress

Removes all the completed tasks from the Job Monitor page.Clear all Completed
Tasks
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Control Panel
Apart from designing, analyzing, and creating BOM for a network, a user with admin rights can activate,
manage, and delete users and their roles.

To navigate to the control panel page, click Control Panel.

The admin or any user with USER_MANAGEMENT role can lock, unlock an individual user account, and
manually expire the individual user password. For more information, see Manage Users and Roles, on page
11.

Preferences
This menu contains the General Settings option to customize Cisco ONP settings such as the default map
view and spectrum utilization percentage.

DescriptionField

Allows choosing the default map view and applying color codes for
spectrum usage percentage

• Default Map: Choose the Detailed or Minimal map from the
drop-down list.

• Spectrum Utilization Percentage: Click and drag to change the
color code to indicate spectrum usage.

General Settings

Help
This menu provides information about the Cisco ONP version.

DescriptionField

Provides the Cisco ONP version.About
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Network Tree
Table 92: Feature History

Feature DescriptionRelease InformationFeature Name

Now, you can use the Ellipsis icon
at the right side of each element in
the Network tree to perform various
actions such as Expand All,
Collapse All, Enable Multi-Select,
and so on. Also, you have multiple
entity-level options to filter the
elements under the Network tree.
These enhancements make the
Network tree more intuitive.

Cisco ONP Release 5.2Network Tree Enhancements

The left pane of the Cisco ONP home page comprises a network tree. The network tree includes various
network elements. When you click each element, the respective property is displayed under the network tree.
You can edit the properties. For more information on editing the network properties, see Modify Network
Properties, on page 105.

Table 93: Network Tree Elements

DescriptionNetwork Tree Elements

Displays the name of the network.Network name

Customer premise equipment that is located in a rack
within a building.

When you click a site name in the network tree, the
site will be highlighted in orange on the map.

Whenmultiselect is enabled, the network tree displays
checkboxes for each site, fiber, and circuit. Selecting
multiple sites from the network tree highlights the
same sites on the map.

Sites

Optical fiber connecting two sites.Fiber

A fiber couple consists of two different fibers
(clockwise and counterclockwise), one for
transmission and another for reception.

Fiber Couple

Service is the circuit through which traffic flows
between nodes.

When you add services to the Traffic site (of the type
1K-2K-4K) in an SSON network, a DefaultGroup is
created under the Services in the network tree. You
can also create a new service group.

Services
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DescriptionNetwork Tree Elements

The wave or Media channel represents a DWDM
channel. In a wave hierarchy, for each wave, there is
a trail. When you expand a trail, there is a section
under each trail. The trail is an optical path or a
network section joining two traffic nodes. It can have
more than one section depending on whether the trail
has a regenerator site. For more information on
regeneration, see Regeneration Support, on page 204.

Waves or Medial Channel or Circuits

Shared Risk Link Group (SRLG) is useful for routing
the protected services. If there are Fiber 1 and Fiber
2 in the network, they are assumed to be diverse and
are used as alternates for protection purposes. If Fiber
1 and Fiber 2 are in an SRLG, they are not true
alternates, and they share the same risk of failure.
Therefore, if Fiber1 fails, Fiber 2 also fails, and Fiber
2 cannot be used as a protected path.

SRLG

An optical subnet is a collection of spans with certain
associated properties.When you create a new network,
Cisco ONP automatically creates an optical subnet
that is associated to the network. At least one optical
subnet must exist for each network.

Optical subnet

Use the Search box on top of the network tree to search for any specific site, fiber, or wave in the network
tree panel. Click the Refresh icon to refresh your search.

Now, you can filter the elements available in the network tree using the Filter icon available next to the Search
box. The following table explains the various filter options available.

Table 94: Network Tree Elements

Options Available Under Each FilterFilters

Entity TypeNetwork Filter

Site Type, and DWDM Site TypeSites Filter

Source Site, Destination Site, Source Edge,
Destination Edge, and Raman

Fibers Filter

Protection Type, Source Site, Destination Site, Src
Add-Drop Type, and Dst Add-Drop Type

Services Filter

Protection Type, Source Site, Destination Site, Src
Add-Drop Type, and Dst Add-Drop Type

Waves, Medial Channel, or Circuits Filter
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Design Palette
Table 95: Feature History

Feature DescriptionRelease
Information

Feature Name

The new intuitive map display allows you to virtually rearrange
networks for a clutter-free view without impacting the original design.
This display simplifies adding new nodes to complex networks. Save
the last modified network in the new view to retain the latest
rearrangement. The new icons in the Design Palette that enable the
intuitive display are:

• Switch to Intuitive Arrangement/Switch to Coordinates
Arrangement—Toggles the map between the intuitive and
original displays.

• Rearrange nodes—Overrides node coordinates and rearranges
the map in a presentable manner.

Cisco ONP
Release 5.2

Intuitive Map
Display

At the right of the Cisco ONP home page, there is the design palette. You can use this design palette to create
a network design. It consists of the following six icons:

DescriptionIcons

Click this icon to toggle between Normal and Zoom modes.

Zoom Mode: Highlights the selected node and automatically centers the map on
the selected node. The size of labels, such as fiber and service names, adjusts
according to the mode.

Normal Mode: Highlights the selected node on the map. Autozoom is disabled.
You need to manually move the map to view the selected node if it is not visible.

Switch to Zoom Mode/
Switch to Normal Mode

Click this icon to magnify the map.Zoom In

Click this icon to minimize the map.Zoom Out

Click this icon to reset the map to its original size.Reset Zoom

Click this icon to toggle between the intuitive and coordinates display. Save the
last modified network in the Intuitive view to retain the latest rearrangement. The
saved networks retain the map designs when reopened or shared with others.When
you export the network as CPZ or Excel files, the exported files include both
original and modified or rearranged coordinate data.

Switch to Intuitive
Arrangement/Switch to
Coordinates
Arrangement

Click this icon to rearrange the map in a presentable fashion.Rearrange nodes
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DescriptionIcons

The Drawing Tool consists of the following icons:

• Traffic Site: Select this icon, and click the working area to create traffic sites
in the network.

• ROADM Site: Select this icon, and click the working area to create ROADM
sites.

• OLA Site: Select this icon, and click the working area to create OLA sites.

• Passthrough Site: Select this icon, and click the working area to create
passthrough sites.

• Link: Click this icon, and drag and drop between sites to create a fiber link.

• OTN Service: Click this icon to create OTN service between sites.

• DWDM channel: Click this icon to add a wave or medial channel between
sites.

• Select: The Select icon looks similar to the cursor tool. Click this icon to
select a node, link service, and so on.

Drawing Tool

Use this icon to view or hide layers such as fiber link, service, text, and channel.
The following are the four toggle icons:

• Toggle Fiber: Click this icon to view or hide fiber link details from the
network.

• Toggle Service: Click this icon to view or hide service details from the
network.

• Toggle Wave: Click this icon to view or hide the channel or wave details
from the network.

• Toggle Text: Click this icon to view or hide the text from the network.

• Toggle SVO associations: Click this icon to remove or add SVO associations.

• Expand/Collapse All Demands: Click this icon to expand the waves or
media channels so that you can view them clearly. Click this icon again to
collapse the waves and media channels to their original shape and position.

The eye symbol in the icon indicates that you are currently viewing the respective
details.

Layers Window

The icon below the Drawing Tool is the Zoom Tool. You can change the display
of the working area by using this function. Click the arrow to view two sliders.

• Map Fade: Move the Map Fade slider from right to left to fade the map
from the background.

• Zoom In/Out: To magnify the map, move the Zoom in or out slider from
left to right.

Zoom Tool
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DescriptionIcons

Click the Zoom Elements icon to view four sliders.

• Media Channel Width: Move this slider from left to right to increase the
channel width.

• Path Spread: Move this slider from left to right to increase the space between
the paths.

• Fiber Width: Move this slider from left to right to increase the fiber width.

• Service Width: Move this slider from left to right to increase the service
width.

Zoom Elements

This icon shows the failed media channels in the map. Failed ones are marked
with a red cross mark.

Show Failed (available
only in plan mode)

This icon shows the total number of impactedmedia channels, demands, or services
that are working or failed in the entire network.

Traffic Monitor
(available only in plan
mode)

Click this icon to toggle between Minimal Map and Detailed Map.

Switch to Minimal Map: Focuses on Sites and Fibers, allowing you to view
spectrum utilization, and supporting the spectrum and path finder.

Switch to Detailed Map: Displays all network components for a comprehensive
view.

Switch to Minimal
Map/Switch to Detailed
Map

Entity Editor
The Entity Editor allows you to edit various properties of an element in the network. Choose Network >
Entity Editor to open the Entity Editor window. The following table explains the operations that you can
perform in the Entity Editor window.

Some properties in the Entity Editor are enhanced with descriptions in the form of tooltips.

DescriptionOptions

Includes check boxes to filter the network elements
displayed under each tab:

• For the SITE tab, you can choose whether to
display OTN (only traffic node), DWDM
(ROADM,OLA, or pass-through) node, or both.

• For the FIBER tab, you can choose the fiber
connecting a particular source and destination
sites.

• For the SERVICE tab, you can choose to display
either services, waves, or both.

Left pane filter
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DescriptionOptions

Displays all properties of the selected network
element. You can modify the properties as required.

Right pane properties

Searches for a particular network element.Search

Refreshes the network elements that are listed under
each tab.

Refresh

Expands or collapses the network elements available
in the network tree under each tab.

Expand/Collapse

Use this option to make a similar selection. For
example, select a ROADM site, and click the Select
Similar icon. All ROADM sites are selected.

You can change a property in all the selected sites at
one time.

Allows you to identify and compare the property
difference. For example, if a property is different
among the selected sites, that property is dimmed.
You can select an option that is applied to all the
selections.

Select Similar

Deselects all selections that you make under the
network tree.

Un-Select All

Deletes the selected network elements.Delete

Contentionless functionality on a site refers to the
contentionless add/drop ability of an N-degree
ROADMnode to accommodate Nwavelengths of the
same frequency from a single add/drop device. For a
ROADM to be contentionless, the number of drop
units have to be equal to ROADM degrees.

• Click the ROADM site to which you want to add
contentionless sides.

• Click the Add Contentionless Side icon.

• Enter the appropriate value in theEnter number
of contentionless sides field.

• Click OK.

After adding the contentionless side, you can edit the
contentionless port property of the side at the right
pane. You can select any of the values ranging from
1 to16. The default value is 16.

Add Contentionless Sides (available only under the
Site tab for the NCS 2000 network)
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DescriptionOptions

Use this icon to add L-Band sides to an NCS 1010
R7.9.1 site

• Click the site or side to which you want to add
L-band sides.

• Click the Add L-Band icon.

Add L-Band (available only under the Site tab for
NCS 1010 site)

Omnidirectional functionality on a site refers to the
ability to route channels through any of the optical
degrees in a multidegree topology during fiber cut
without the need for physical fiber reconnections.

• Click the ROADM site to which you want to add
omnidirectional sides.

• Click the Omni-Directional icon.

• Enter the appropriate value in theEnter number
of Omni Directional sides field.

• Click OK.

Add Omni-Directional (available only under the Site
tab for the NCS 1010 network)

Use this option to clone a service or wave that is
connected between two sites.

• Select a wave and click Copy.

• Enter the quantity in theClone Service/DWDM
Channel dialog box, and click OK.

The label of the new wave has –1 appended to the
label of the cloned wave. For example,
Site-2-Site3-1-1 is the label of the new wave that is
created by cloning the wave Site-2-Site3-1. You can
rename the label.

You can also clone a service in a similar way.

Copy (available only under the Service tab)
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A P P E N D I X B
Supported ROADMs, Add/Drop Cards, and
Modules

• Supported ROADMs, Add/Drop Cards, and Modules, on page 265

Supported ROADMs, Add/Drop Cards, and Modules
Cisco ONP supports the following ROADM, Add/Drop cards and modules:

Table 96: NCS 2000 ROADM Cards

Product DescriptionProduct

9-port Single Module ROADM - 20—34-dB Gain - Flex SpectrumNCS2K-9-SMR34FS=

9-port Single Module ROADM - 12—24-dB Gain - Flex SpectrumNCS2K-9-SMR24FS=

9-port Single Module ROADM - 0—17-dB Gain - Flex SpectrumNCS2K-9-SMR17FS=

20-port Single Module ROADM - Switchable Gain Flex SpectrumNCS2K-20-SMRFS=

20-port SMR - Switch. Gain Flex Spectrumwith ConnectionVerificationNCS2K-20-SMRFS-CV=

Table 97: NCS 2000 ADD/DROP Line Cards and Optical Passive Modules

Product DescriptionProduct

4- to 12-degree 16-port Contentionless Add/Drop UnitNCS2K-16-AD-CCOFS=

6-port Colorless Flex Spectrum Add/Drop MF UnitNCS2K-MF-6AD-CFS=

MPO-16 to 16xLC Fan-Out MF Unit with Integrated MonitoringNCS2K-MF-MPO-16LC=

MPO-16 to 16xLC Fan-Out with Connection VerificationNCS2K-MF-M16LC-CV=

ONS 15216 48-channel Mux/DeMux Exposed Faceplate Patch Panel
Odd

15216-MD-48-ODD=

ONS 15216 48-channel Mux/DeMux Exposed Faceplate Patch Panel
Even

15216-MD-48-EVEN=
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Product DescriptionProduct

ONS 15216 Mux/Demux Plugin Coupler/De-Interleaver Module15216-MD-48-CM=

NCS 1000 64-channel Odd Mux/Demux Patch Panel—C-bandNCS1K-MD-64-C=

Table 98: NCS 2000 Controller Cards and Common Equipment

Product DescriptionProduct

NCS 2006 30A DC Power FilterNCS2006-DC=

NCS 2006 1500W AC Power SupplyNCS2006-AC=

NCS 2015 Shelf Assembly - DC PowerNCS2015-SA-DC=

NCS 2015 Shelf Assembly - AC PowerNCS2015-SA-AC=

NCS 2000 Transport Node Controller, version 2NCS2K-TNCS-2-K9=

NCS2000 Transport Node Controller with 2x OTDR/OSC, version 2NCS2K-TNCS-2O-K9=

Transport Node Controller for NCS2002, 2006, and 2015 chassisNCS2K-TNCS-K9=

NCS 2000 Transport Node Controller with 2x OTDR/OSCNCS2K-TNCS-O-K9=

Shelf Virtualization Orchestrator - LC, FullNCS2K-SVO-K9=

Protection Switching Module (PSM) card for NCS 2000NCS2K-PSM=

Table 99: NCS 2000 Series Passive Optical Modules

Product DescriptionProduct

6RU Mechanical Frame for Passive Units—14 slots with USB HubNCS2K-MF-6RU=

6RU Mechanical Frame for Passive Units—10 slots with USB HubNCS2K-MF10-6RU=

1RU Mechanical Frame—4 slotsNCS2K-MF-1RU=

4-degree Upgrade Mesh Interconnection MF UnitNCS2K-MF-UPG-4=

4-degree Upgrade Mesh Interconnect with Connection VerificationNCS2K-MF-UPG-4-CV=

Up to 5-degree Mesh Interconnection MF UnitNCS2K-MF-DEG-5=

5-degree Mesh Interconnect with Connection VerificationNCS2K-MF-DEG-5-CV=

2RU 8-degree Mesh Patch Panel—5-Add/Drop Port + MonitoringNCS2K-PPMESH8-5AD=

Table 100: NCS 4000 Chassis and NCS 1004 Line Cards

Product DescriptionProduct

NCS 4016 shelf assembly - DC PowerNCS4016-SA-DC=
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Product DescriptionProduct

NCS 4016 shelf assembly - AC PowerNCS4016-SA-AC=

NCS 4009 shelf assembly - DC PowerNCS4009-SA-DC=

NCS 4000 400G Packet/OTN/WDM—QSFP28/CFP2 line cardNCS4K-4H-OPW-QC2=

NCS 4000 24-port low rate OTN—SFP line cardNCS4K-24LR-O-S=

Network Convergence System 1004 four line card slotsNCS1004=

Table 101: NCS 1010 Line Cards, Chassis, and PSUs

Product DescriptionProduct

NCS 1010 Optical Line Terminal—C-bandNCS1K-OLT-C=

NCS 1010 Optical Line Terminal—L-bandNCS1K-OLT-L=

NCS 1010 Optical Line Terminal with Raman—C-bandNCS1K-OLT-R-C=

NCS 1010 In-Line Amplifier—C-bandNCS1K-ILA-C=

NCS 1010 In-Line Amplifier—L-bandNCS1K-ILA-L=

NCS 1010 In-Line Amplifier with 2x Raman—C-bandNCS1K-ILA-2R-C=

NCS 1010 In-Line Amplifier with 1x Raman—C-bandNCS1K-ILA-R-C=

NCS 1010 Shelf AssemblyNCS1010-SA=

NCS 1010 DC Power Supply UnitNCS1010-DC-PSU=

NCS 1010 AC Power Supply UnitNCS1010-AC-PSU=

NCS 1010 Optical Line Terminal—C-band, enhancedNCS1K-E-OLT-C=

NCS 1010 Optical Line Terminal with Raman—C-band, enhancedNCS1K-E-OLT-R-C=

NCS 1010 Optical Line Terminal—L-band, enhancedNCS1K-E-OLT-L=

NCS 1010 In-Line Amplifier with 1x Raman—C-band, enhancedNCS1K-E-ILA-R-C=

NCS 1010 In-Line Amplifier with 2x Raman—C-band, enhancedNCS1K-E-ILA-2R-C=

NCS 1010 In-Line Amplifier with 1x Raman west facing—C-band,
enhanced

NCS1K-E-ILA-R-C-2=

NCS 1014 2.4T Line CardNCS1K14-2.4T-K9=

Table 102: NCS 1010 Passive Modules

Product DescriptionProduct

NCS 1000 shelf for four passive modulesNCS1K-BRK-SA=
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Product DescriptionProduct

NCS 1000 MTP/MPO to 8-port passive breakout moduleNCS1K-BRK-8=

NCS 1000 MTP/MPO to 24-port colorless channels passive breakout
module

NCS1K-BRK-24=

NCS 1000 MTP/MPO to 16-port colorless channels passive breakout
module

NCS1K-BRK-16=

NCS 1000 32-channel OddMux/Demux Patch Panel - 150GHz—C-bandNCS1K-MD-32O-C=

NCS 1000 32-channel Even Mux/Demux Patch Panel -
150GHz—C-band

NCS1K-MD-32E-C=

NCS 1000 16-port Colorless Mux/Demux Optical Line Card—C-bandNCS1K14-CCMD-16-C

NCS 1000 16-port Colorless Mux/Demux Optical Line Card—L-bandNCS1K14-CCMD-16-L

Table 103: NCS 1020 Chassis and Modules

Product DescriptionProduct

NCS 1020 Shelf AssemblyNCS1020-SA=

NCS 1010, 1012, 1020 Controller, 112500-bps Default Console Baud
Rate

NCS1010-CTR2-K9=

NCS 1010, 1012, 1020 Controller, 9600-bps Console Baud RateNCS1010-CTR2-B-K9=

NCS 1020 Fan for NCS 1014 SlotsNCS1020-FAN=

NCS 1020 Fan BlankNCS1020-FAN-BLANK=

Filler / Blank for NCS 1010 Slot on NCS 1012, 1020, PassiveNCS1010-FLR-P=

Filler / Blank for NCS 1010 Slot on NCS 1012, 1020, Active, with Fan
slots

NCS1010-FLR-A=

Filler / Blank for Controller Slot on NCS 1012, 1020NCS1010-CTR2-FLR=

Network Convergence System 1014 Blank cardNCS1K14-BLANK=

Table 104: NCS 1001 Chassis, Modules, and Pluggables

Product DescriptionProduct

Network Convergence System 1001 line system 3 slotsNCS1001-K9=

Network Convergence System 1001 Control cardNCS1K-CNTLR2=

Network Convergence System 1001 amplifier moduleNCS1K-EDFA=

Network Convergence System 1001 protection moduleNCS1K-PSM=

Network Convergence System 1001 AC power supply unit - 2KW
normal operating temperature, 600W short term high temperature

NCS1K-2KW-AC2=
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Product DescriptionProduct

Network Convergence System 1001 DC power supply unit - 2KW
normal operating temperature, 600W short term high temperature

NCS1K-2KW-DC=

Network Convergence System 1001 line system FanNCS1K1-FAN=

SFP OC-48/STM-16/GE, CWDM, 1510 nmONS-SC-Z3-1510=

SFP OC-3/STM-1, CWDM, 1510 nm EXT; SFP Pluggable Optics
Module

ONS-SE-155-1510

CWDM 1510-nm SFP; Gigabit Ethernet 1 and 2 Gb Fibre ChannelCWDM-SFP-1510

CWDM 1610-nm SFP; Gigabit Ethernet 1 and 2 Gb Fibre ChannelCWDM-SFP-1610

SFP OC-48/STM-16/GE, CWDM, 1610 nmONS-SC-Z3-1610=

Product DescriptionProduct

ONS Multiplexer/Demultiplexer Patch Panel Even Extended15216-MD-48-ODDE

ONS Multiplexer/Demultiplexer Patch Panel Odd Extended15216-MD-48-EVENE

ONS Coupler and Splitter15216-MD-48-CME

OSC Combiner and Splitter15216-FLD-OSC

NCS 1000 64 channels Odd Multiplexer/Demultiplexer Patch
Panel-C-band

NCS1K-MD-64-C

NCS 1000 32 channels Even Multiplexer/Demultiplexer Patch Panel,
No-loopback - 150GHz - C-band

N1K-MD-32E-C
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A P P E N D I X C
Supported Cards and Pluggables

• Supported Transponder Cards and Pluggables, on page 271

Supported Transponder Cards and Pluggables
Table 105: Feature History

Feature DescriptionRelease InformationFeature Name

QSFP-100G-FR-S= pluggable is
supported on the QSFP ports of the
400G-XPLC transponder cardwith
100GE data rate.

Cisco ONP Release 4.1Pluggable Support

The new QSFP-100G-ERL-S
pluggable enables you to design
and validate topologies for NCS
2000 R11.1.3 networks. This
pluggable is supported on the QSFP
ports of the 400G-XP-LC
transponder card with 100GE data
rate. You can select this pluggable
from the Client Interface
drop-down list at trail level
properties for the 400G-XP-LC
transponder card.

Cisco ONP Release 5.1QSFP-100G-ERL-S Pluggable

Cisco ONP supports the following transponders and pluggables for NCS 2000 networks:
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Table 106: Supported Transponder Cards and Pluggables for NCS 2000 Network

Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_200G

NoYes (only
for
100GE)

• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4)

• LR-1(CPAK-100G-LR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

SD-FEC_20• 100GE

• OTU4

200G-CK-LC
+ MR-MXP
(200G MXP
mode)

Auto,
TRK_100G

YesYes• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4

• LR-1(CPAK-100G-LR4)

SD-FEC_20100GE200G-CK-LC
+ MR-MXP
(100G TXP
mode)

Auto,
TRK_100G

YesYes• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4

• LR-1(CPAK-100G-LR4)

SD-EFEC100GE200G-CK-LC
+ MR-MXP
(100G TXP
mode)

Auto,
TRK_100G

YesYes• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4

• LR-1(CPAK-100G-LR4)

SD-FEC100GE200G-CK-LC
+ MR-MXP
(100G TXP
mode)

Auto,
TRK_100G

YesYes• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-MLR)

• SR-1(QSFP-40G-SR4)

• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

SD-FEC_20• 10GE

• 10GE
LAN
PHY

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
(100G MXP
mode)
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_100G

YesYes• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-MLR)

• SR-1(QSFP-40G-SR4)

• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

SD-EFEC• 10GE

• 10GE
LAN
PHY

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
(100G MXP
mode)

Auto,
TRK_100G

YesYes• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-MLR)

• SR-1(QSFP-40G-SR4)

• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

SD-FEC• 10GE
LAN
PHY

• 10GE

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
(100G MXP
mode)

Auto,
TRK_100G

YesYes• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• LR-1(QSFP-40G-LR4)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• SR-1(QSFP-40G-SR-BD)

SD-FEC_20• 10GE

• 10GE
LAN
PHY

• 40GE

200G-CK-LC
+ MR-MXP
(100G MXP
mode 2*10G
2*40G
MODE)

Auto,
TRK_100G

YesYes• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD)

SD-EFEC• 10GE

• 40GE

200G -
CK-LC +
MR - MXP
(100G MXP
mode 2*10G
2*40G
MODE)
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_100G

YesYes• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD)

SD-FEC• 10GE

• 40GE

200G -
CK-LC +
MR -MXP
(100G MXP
mode 2*10G
2*40G
MODE)

Auto,
TRK_100G

NoYes for
OTU2e

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR (ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-
FEC_20

• 10GE

• OC192

• OTU2

• OTU2e

200G -
CK-LC
+10x10G
-LC

Auto,
TRK_100G

NoYes for
OTU2e

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER (ONS-SC+-10G-ER)

• ZR (ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-EFEC• 10GE

• OC192

• OTU2

• OTU2e

200G -
CK-LC
+10x10G
-LC

Auto,
TRK_100G

NoYes for
OTU2e

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-FEC• 10GE

• OC192

• OTU2

• OTU2e

200G-CK-LC
+ 10x10G
-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_200G

NoYes for
100GE
and
OTU2

• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4)

• LR-1(CPAK-100G-LR4)

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-
FEC_20

• 100GE

• 10GE

• OC192

• OTU2

200G -
CK-LC +
MR-MXP
(200G Mxp
100G+10*10G
Mode)

Auto,
TRK_200G

YesYes• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD)

SD-
FEC_20

• 10GE

• 10GE
LAN
PHY

• 40GE

200G-CK-LC
+ MR-MXP
+ MR-MXP
(200G Mxp
4*40G +
4*10G
Mode)

Auto,
TRK_200G

YesYes• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

• LR-1(ONS-QSFP-4*10G-MLR)

• ZR(ONS-SC+-10G-ZR)

SD-
FEC_20

• 10GE

• OC192

• OTU2

200G-CK-LC
+ 10x10G
-LC +
MR-MXP
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_200G

YesYes• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

• LR-1(ONS-QSFP-4*10G-MLR)

• ZR(ONS-SC+-10G-ZR)

SD-FEC_20• 10GE

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
+ MR-MXP

Auto,
TRK_100G

NoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

EFEC,
SD-FEC_20

• 10GE

• OC192

100GS -
CK-LC +
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

FEC• 10GE

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - LC-C
+
10x10G-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER (ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

EFEC• 10GE

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - LC-C
+
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER (ONS-SC+-10G-ER)

• ZR (ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

HG-FEC• 10GE

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - LC-C
+
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

FEC• 10GE

• 10GE
LAN
PHY

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - CK-
LC-C +
10x10G-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

EFEC• 10GE

• 10GE
LAN
PHY

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G
-CK-LC-C +
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

HG-FEC• 10GE

• 10GE
LAN
PHY

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G -
CK-LC-C +
10x10G-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

TRK_100G,
TRK_200G

YesYes• SR-1(QSFP-100G-SR4-S)

• LR-1(QSFP-100G-LR4-S)

• LR-1(QSFP-28-LR4)

• SR-1(QSFP-100G-SM-SR)

• SR-1(QSFP-40/100G-SRBD)

• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-LR)

• SR-1(QSFP-40G-SR4)

• ER(ONS-QSFP-4*10G-MER)

• LR-1(QSFP-40G-LR4)

SR-1(QSFP-40G-SR-BD

• LR-1(ONS-QC16GFC-LW)

• LR-1(ONS-QC16GFC-SW)

• LR-1(ONS-QSFP28-LR4)

• FR-1 (QSFP-100G-FR-S)
(only for 100GE)

• ER-1
(QSFP-100G-ERL-S)
(only for 100GE)

SD-FEC_25-
NO_DE

• 100GE

• 10GE
LAN
PHY

• 10GE

• 40GE

• Fiber
Channel
10G

• Fiber
Channel
16G

• Fiber
Channel
8G

• OC192
/STM64

• OTU2

• OTU2e

• OTU4

400G-XP-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

TRK_100G,
TRK_200G

YesYes• SR-1(QSFP-100G-SR4-S)

• LR-1(QSFP-100G-LR4-S)

• LR-1(QSFP-28-LR4)

• SR-1(QSFP-100G-SM-SR)

• SR-1
(QSFP-40/100G-SRBD)

• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-LR)

• SR-1(QSFP-40G-SR4)

• ER(ONS-QSFP-4*10G-MER)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD

• LR-1(ONS-QC16GFC-LW)

• LR-1(ONS-QC16GFC-SW)

• LR-1(ONS-QSFP28-LR4)

• FR-1 (QSFP-100G-FR-S)
(only for 100GE)

• LR-1
(QSFP-100G-ERL-S)
(only for 100GE)

SD-FEC_15
-NO_DE

• 100GE

• 10GE
LAN
PHY

• 10GE

• 40GE

• Fiber
Channel
10G

• Fiber
Channel
16G

• Fiber
Channel
8G

• OC192
/STM64

• OTU2

• OTU2e

• OTU4

400G-XP-LC

AutoNoNoSR-1(CPAK-100G-SR10)FEC• 100GE

• OTU4

100G-LC-C

AutoNoNoSR-1(CPAK-100G-SR10)EFEC• 100GE

• OTU4

100G-LC-C

AutoNoNoSR-1(CPAK-100G-SR10)HGFEC• 100GE

• OTU4

100G-LC-C

AutoNoNo• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

FEC• 100GE

• 40GE

• OTU4

100G -
CK-LC-C
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

AutoNoNo• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

EFEC• 100GE

• 40GE

• OTU4

100G -
CK-LC-C

AutoNoNo• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

HGFEC• 100GE

• 40GE

• OTU4

100G -
CK-LC-C

Auto,
TRK_100G

NoYesSR-1(CPAK-100G-SR10)FEC100GE100GS -
CK-LC

Auto,
TRK_100G

NoYEsLR-1(CPAK-100G-LR4)EFEC100GE100GS -
CK-LC

Auto,
TRK_100G

NoYesSR-1(CPAK-100G-SR10)SD-FEC_20100GE100GS -
CK-LC

Auto,
TRK_100G

NoYes (for
100GE)

• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

FEC• 100GE

• OTU4

200G -
CK-LC
(100G Mode
only)

Auto,
TRK_100G

NoYes (for
100GE)

• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

EFEC• 100GE

• OTU4

200G -
CK-LC
(100G Mode
only)

Auto,
TRK_100G

NoYes (for
100GE)

• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

SD-FEC_20• 100GE

• OTU4

200G-CK-LC
(100G Mode
only)

Cisco ONP supports the following transponders and pluggables for NCS 2000 networks:
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Table 107: Supported Transponder Cards and Pluggables for NCS 1010 Network

Trunk ModeEncryptionPluggables SupportedFEC modeTraffic
Type

Transponder /
Muxponder

• Auto

• 400G

• 500G

• 600G

• 700G

• 800G

• 900G

• 1000G

• 1100G

• 1200G

NoClient Pluggables:

• Auto

• QDD-400G-FR4-S

• QDD-400-AOC1M

• QDD-400G-DR4-S

• QDD-4x100G-LR-S

Trunk Pluggables:

• Auto

• CIM-C-K9

SD_FEC_15100GE

400GE

NCS1K14-2.4T-K9

• Auto

• 400G

• 500G

• 600G

• 700G

• 800G

• 900G

• 1000G

• 1100G

• 1200G

YesClient Pluggables:

• Auto

• QDD-400G-FR4-S

• QDD-400-AOC1M

• QDD-400G-DR4-S

• QDD-400G-LR4-S

• QDD-4x100G-LR-S

• QDD-4x100G-FR-S

Trunk Pluggables:

• Auto

• CIM-C-K9

SD_FEC_15100GE

400GE

NCS1K14-2.4T-x-K9
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Trunk ModeEncryptionPluggables SupportedFEC modeTraffic
Type

Transponder /
Muxponder

• Auto

• 100G

• 200G

• 300G

• 400G

YesClient Pluggables:

• Auto

• QDD-400G-FR4-S

• QDD-400-AOC1M

• QDD-400G-DR4-S

• QDD-4x100G-LR-S

• QSFP-100G-DR-S

• QSFP-100G-LR4-S

• QSFP-100G-LR-S

• ONS-QSFP-28-LR4

• QSFP-100G-CWDM4-S

• QSFP-100G-FR-S

• QSFP-100G-SR4-S

Trunk Pluggables:

• Auto

• QDD-400G-ZRP-S

• QDD-400G-ZR-S

OFEC

CFEC

100GE

400GE

NCS1K4-QXP-K9

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
283

Supported Cards and Pluggables
Supported Cards and Pluggables



Cisco Optical Network Planner Configuration Guide, Release 24.3.1
284

Supported Cards and Pluggables
Supported Cards and Pluggables



A P P E N D I X D
Supported Optical Sources

• Supported Optical Sources, on page 285

Supported Optical Sources
Table 108: Feature History

Feature DescriptionRelease InformationFeature Name

Optical Sources enable you to simulate the optical
feasibility of the network with the 400G and other
interfaces that are not natively modeled in Cisco ONP.
The following Optical Sources are introduced in this
release:

• ONS-CFP2D-400G-C-OpticalSources-V 2.mxd

• QDD-400G-ZRP-S-OpticalSources-V2.mxd

Cisco ONP Release 4.2New Optical Source and
Pluggable Support

Cisco ONP supports the following optical sources:

From Release 24.3.1, the optical sources for NCS 2000 networks are tagged with System Release to indicate
from when the optical sources support the network release.

Note

• OpticalSources_NCS2K_400GXP-LC_NCS4K-4H-OPW-QC2 DWDM Line Card

• 400GXP_100G_25%_DE

• 400GXP_200G_15%_DE

• 100G-SD-FEC

• 400GXP_100G_15%_DE

• 200G-SD-FEC

• 400GXP_100G_15%

Cisco Optical Network Planner Configuration Guide, Release 24.3.1
285



• 400GXP_200G_15%

• 400GXP_200G_25%DE

• NCS1004_OpticalSources_V3

• NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GBd

• NCS1004_SP_16QAM_300G_27%SDFEC_69GBd

• NCS1004_QPSK_200G_27%SDFEC_69GBd

• NCS1004_16QAM_32QAM_400G_27%SDFEC_62GBd

• NCS1004_16QAM_400G_27%SDFEC_69GBd

• NCS1004_SP_16QAM_16QAM_300G_27%SDFEC_60GBd

• NCS1004_32QAM_500G_27%SDFEC_69GBd

• NCS1004_L_Band_OpticalSources_V3

• NCS1004_L_200G_QPSK_27%SDFEC_69GBd

• NCS1004_L_200G_QPSK_SP_16QAM_27%SDFEC_60GBd

• NCS1004_L_300G_SP_16QAM_16QAM_27%SDFEC_60GBd

• NCS1004_L_300G_SP_16QAM_27%SDFEC_69GBd

• NCS1004_L_400G_16QAM_32QAM_27%SDFEC_62GBd

• NCS1004_L_400G_16QAM_27%SDFEC_69GBd

• QDD and CFP2-DCO variants

• ONS-CFP2D-400G-C-OpticalSources-V2.mxd
1

• CFP2_200OR_TXP_FOIC2_OFEC_15_DE_ON_4Q_1S_BR63_1

• CFP2_300OR_TXP_FOIC3_OFEC_15_DE_ON_8Q_1S_BR63_1

• CFP2_400OR_TXP_FOIC4_OFEC_15_DE_ON_16Q_1S_BR63_1

• ONS-CFP2D-400G-C-OpticalSources-V2.mxd
2

• CFP2_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_0S_BR60_1

• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_8Q_1E_BR40_1

• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_16Q_1E_BR30_1

• CFP2_400ZR_TXP_GAUI8_CFEC_15_DE_ON_16Q_0S_BR59_8

• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_0S_BR60_1

• CFP2_100ZR+_TXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR30_1

1 The optical source interfaces are supported for SSON networks.
2 The optical source interfaces are supported for SSON and non-SSON networks.
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• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR60_1

• CFP2_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_1E_BR60_1

• CFP2_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_1E_BR60_1

• CFP2_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_0S_BR60_1

• CFP2_100OR_TXP_FOIC1_OFEC_15_DE_ON_4Q_1S_BR31_6

• CFP2_200OR_TXP_FOIC2_OFEC_15_DE_ON_8Q_1S_BR42_1

• CFP2_200OR_TXP_FOIC2_OFEC_15_DE_ON_16Q_1E_BR31_6

• QDD-400G-ZRP-S-OpticalSources-V2.mxd
2

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR60_1

• QDD_400ZR_TXP_GAUI8_CFEC_15_DE_ON_16Q_0S_BR59_8

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_0S_BR60_1

• QDD_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_1E_BR60_1

• QDD_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_0S_BR60_1

• QDD_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_1E_BR60_1

• QDD_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_0E_BR60_1

• QDD_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_0E_BR60_1

• QDD_100ZR+_TXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR30_1

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_16Q_1E_BR30_1

• QDD_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_0S_BR60_1

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_8Q_1E_BR40_1

• From Release 24.3.1, CONP supports QDD-400G-ZR-S Optical Sources.

QDD_400ZR_TXP_GAUI8_CFEC_15_DE_ON_16Q_0S_BR59_8

• Bright ZR+ Optical Sources

• Bright-400G-FOIC4-OFEC-16QAM-1-E_BR63_14

• Bright-400G-FOIC4-OFEC-16QAM-1-S_BR63_14

• Bright-300G-FOIC3-OFEC-8QAM-1-S_BR63_14

• Bright-200G-FOIC2-OFEC-QPSK-1-S_BR63_14

• Bright-200G-FOIC2-OFEC-8QAM-1-E_BR42_09

• Bright-200G-FOIC2-OFEC-16QAM-1-E_BR31_57

• Bright-200G-FOIC2-OFEC-16QAM-1-S_BR31_57

• Bright-100G-FOIC1-OFEC-QPSK-1-S_BR31_57
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• Bright-100G-FOIC1-OFEC-DQPSK-1-S_BR31_57

• Bright-400G-400ZR-CFEC-16QAM-1-S_BR59_84

• Bright-400G-400ZRP-OFEC-16QAM-1-E_BR60_14

• Bright-400G-400ZRP-OFEC-16QAM-1-S_BR60_14

• Bright-300G-300ZRP-OFEC-8QAM-1-E_BR60_14

• Bright-300G-300ZRP-OFEC-8QAM-1-S_BR60_14

• Bright-200G-200ZRP-OFEC-QPSK-1-S_BR60_14

• Bright-200G-200ZRP-OFEC-8QAM-1-E_BR40_09

• Bright-200G-200ZRP-OFEC-16QAM-1-E_BR30_07

• Bright-100G-100ZRP-OFEC-QPSK-1-S_BR30_07

• Bright-100G-OTU4-SCFEC-DQPSK-1-S_BR27_95

• From Release 24.3.1, CONP supports the DP04QSDD-HE0 Optical Sources.

Bright_100G_100ZRP_OFEC_QPSK_1S_BR30_07

• Bright_200G_200ZRP_OFEC_16QAM_1E_BR30_07

• Bright_400G_400ZRP_OFEC_16QAM_1S_BR60_14

• Bright_200G_200ZRP_OFEC_8QAM_1E_BR40_09

• Bright_400G_400ZRP_OFEC_16QAM_1E_BR60_14

• Bright_300G_300ZRP_OFEC_8QAM_1E_BR60_14

• Bright_300G_300ZRP_OFEC_8QAM_1S_BR60_14

• Bright_200G_200ZRP_OFEC_QPSK_1S_BR60_14

• Bright_400G_400ZR_CFEC_16QAM_1S_BR59_84

Delete any of the old versions of Bright ZR+ optical sources that may be present
in the server. The latest list of optical resources will be automatically loaded after
Cisco ONP, Release 5.1 software is installed.

Note

• Bright_ZRP_OpticalSources_V2

The Rx OSNR sensitivity is improved for the Bright_400G_400ZRP_OFEC_16QAM_1E_BR60_14
interface in the new version.

The latest list of optical resources will be automatically loaded after Cisco ONP, Release 5.2 software
is installed.

• CIM8_OpticalSource_V10

• CIM8_900G_15FEC_Eth_ZR_BR138
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• CIM8_700G_15FEC_Eth_ZR_BR128

• CIM8_800G_15FEC_Eth_ZR_BR108

• CIM8_800G_15FEC_Eth_ZR_BR138

• CIM8_900G_15FEC_Eth_ZR_BR118

• CIM8_1000G_15FEC_Eth_ZR_BR128

• CIM8_1000G_15FEC_Eth_ZR_BR138

• CIM8_800G_15FEC_Eth_ZR_BR118

• CIM8_800G_15FEC_Eth_ZR_BR128

• CIM8_400G_15FEC_Eth_ZR_BR88

• CIM8_400G_15FEC_Eth_ZR_BR128

• CIM8_500G_15FEC_Eth_ZR_BR88

• CIM8_500G_15FEC_Eth_ZR_BR128

• CIM8_600G_15FEC_Eth_ZR_BR98

• CIM8_600G_15FEC_Eth_ZR_BR128

• CIM8_700G_15FEC_Eth_ZR_BR98

• CIM8_400G_15FEC_Eth_ZR_BR108

• CIM8_900G_L_15FEC_Eth_ZR_BR138

• CIM8_800G_L_15FEC_Eth_ZR_BR138

• CIM8_400G_L_15FEC_Eth_ZR_BR128

• CIM8_500G_L_15FEC_Eth_ZR_BR138

• CIM8_1000G_L_15FEC_Eth_ZR_BR138

• CIM8_700G_L_15FEC_Eth_ZR_BR138

• CIM8_600G_L_15FEC_Eth_ZR_BR138

• From Release 24.3.1, CONP supports the CIM8 Optical Sources:

• CIM8_600G_15FEC_Eth_ZR_BR138

• CIM8_1200G_15FEC_Eth_ZR_BR138

• CIM8_700G_15FEC_Eth_ZR_BR138

• CIM8_500G_15FEC_Eth_ZR_BR138

• CIM8_1100G_15FEC_Eth_ZR_BR138
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NCS 1004 is supported as an optical source.Note

The following optical source files are not supported in NCS 2000 Release 11.0:

• NCS1004_16QAM_32QAM_400G_27%SDFEC_62GBd

• NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GB

Hence, we recommend you to upgrade the system release of the network to Release 11.1, or force the optical
source files that are supported for the Release 11.0.

Note
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A P P E N D I X E
Supported Amplifiers

• Supported Amplifiers, on page 291

Supported Amplifiers
Cisco ONP supports the following amplifiers:

Table 109: Cisco ONP Supported NCS 2000 Amplifiers

DescriptionAmplifier

Raman Amp C-Band15454-M-RAMAN-CTP

Raman Amp C-Band15454-M-RAMAN-COP

Erbium Doped Fiber Amplifier (EDFA) that can function in dual gain with
maximum gain of 35 dB

EDFA 35 for OLA node

21dBm EDFA + Bst 26dB Span - C-BandNCS2K-EDRA2-26C

21dBm EDFA 26dB Span - C-BandNCS2K-EDRA1-26C

21dBm EDFA + Bst 35dB Span - C-BandNCS2K-EDRA2-35C

21dBm EDFA35dB Span - C-BandNCS2K-EDRA1-35C

• RAMAN-CTP is supported on all nodes.

• EDRAs are supported on the OLA node.

• For ROADM and Traffic nodes, the booster amplifier and preamplifier are in-built. The booster is
20SMR-FS-BST.

Note
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Table 110: Cisco ONP Supported NCS 1010 Amplifiers

DescriptionAmplifier

Tilt Uncontrolled Range
Gain (dB)

Standard Range Gain (dB)Lower Range Gain (dB)

C-Band

312416OLT-C-Bst

252212OLT-C-Pre-Normal

353217OLT-C-Pre-Extended

20178ILA-C-Normal

333013ILA-C-Extended

23178ILA-R-C-Normal

363013ILA-R-C-Extended

20178ILA-2R-C-Normal

333013ILA-2R-C-Extended

20178E-ILA-R-C-Normal

333013E-ILA-R-C-Extended

20178E-ILA-2R-C-Normal

333013E-ILA-2R-C-Extended

20178E-ILA-C-R-2-Normal

333013E-ILA-C-R-2-Extended

L-Band

32.525.517.5OLT-L-Bst

26.323.313.3OLT-L-Pre-Normal

39.336.318.3OLT-L-Pre-Extended

22.819.810.8ILA-L-Normal

35.832.815.8ILA-L-Extended
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Troubleshoot

• Troubleshooting Tasks, on page 293

Troubleshooting Tasks
The following table describes the common error messages that are related to Cisco ONP configuration and
the workarounds:

Table 111: Troubleshooting Tasks for Cisco ONP Configuration

WorkaroundProbable Reason for the ErrorWarning Message or Error

Check and add the required number
of contentionless sides on the target
service or wave source and
destination sites.

Required contentionless sides are
not created on add/drop sites. For
protected service or wave, minimum
two contentionless sides are
required on the add/drop sites.

Cannot Route demand! Didn't find
any valid Contentionless Side.

For linear topology, change the
demand protection to unprotected.

For ring topology, ensure that at
least two nodes and fiber-disjoint
paths are available and the forced
wavelength is unconfined in the
end-to-end path.

Force the required number of
colorless ports.

Disjoint path is not available for
protected demand.

Or

Forced wavelength may be already
used for other demand in the same
path.

Or

The number of colorless demands
created is more than the colorless
ports forced on the interfaces.

Error: No valid path from
<source> to <destination>

For linear topology, change the
demand protection to unprotected.

For ring topology, ensure that at
least two nodes and fiber-disjoint
paths are available and the forced
wavelength is unconfined in the
end-to-end path.

Disjoint path is not available for
protected demand.

Or

Forced wavelength may be already
used for other demands in the same
path.

Error: Traffic subnet constraints
prevent routing of section.
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WorkaroundProbable Reason for the ErrorWarning Message or Error

If the Cascaded SMR flag is
enabled, create only contentionless
demands on those nodes. Else,
reduce the number of contentionless
sides, colorless ports, or colored
demands that are created, to get
successful network analysis.

The number of contentionless sides,
colorless ports that are forced, and
colored demand exceed SMR-20
port capacity.

Or

The Cascaded SMR flag is enabled,
and colored or colorless demand is
created.

Error: The sum of CoDem and
Non-CoDem colorless ports and
ports that are used for
Omnidirectional and Contentional
sides cannot exceed 20 when the
TYPE is SMR-20.

Change the fiber type to the one that
is supported by Cisco ONP.

The fiber connecting these sides is
not supported by Cisco ONP.

Couple between<source>.<side>
and <destination>.<side> is of
invalid type.

Connect the fiber to the nodes in the
ring network.

Any of the sites are connected to the
fiber in the Ring/Linear network.

Unconnected nodes or sites are
present in the network.

Force the correct path on the
Wave/Media Channel.

Wrong path has been forced on the
wave or media channel.

Unfeasible forcing

Clear the contents of
postgresdb_cnp folder before
running the restore command: rm
-rf
/var/lib/postgresdb_cnp/*cannot

Restore database script attempts to
write data in the postgres database,
but the data with the same index is
already present.

E11000 duplicate key error
collection: CnpDB.dbchangelog
index: _id_ dup key: { :
ObjectId('') }

Unlock the mentioned entity or
unlock the complete site.

There is an issue with setting up
connection in the lock mode.

Cannot complete mesh
connection.

Check the path and choose the
correct primary path and secondary
path fibers.

Or

Remove all the fibers that are forced
to set the Path of Wave property as
Auto.

Invalid path has been forced.Path constraints prevent routing.

Force the wavelength as per optical
subnet rule or change the optical
subnet rule.

Forced Wavelength is not part of
the Optical subnet rule.

Traffic subnet constraints prevent
routing.

Set the property MF Unit to Auto
and then force the template.

Template is applied when properties
such as ECU, MF Unit are forced.

MF Unit value MF1-RU is not
supported in RPT, so resetting the
value to default for <site name>.
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WorkaroundProbable Reason for the ErrorWarning Message or Error

Modify the Interlever forcing on the
line side to MD-48-CM.

In non-SSON traffic, the ROADM
site with the properties (DEG-8,
SMR-9, number of contentionless
sites is equal to 1) has 96 colored
waves.

The Interlever Type is property
set to Auto or MpoCable.

Please force MD-48-CM as
Interlever Type for {0}.

Delete the extra contentionless
sides.

During upgrade or Release upgrade,
colorless port is forced on SMR-9,
and more than one contentionless
side is added in the imported MPZ
network.

The sum of forced CoDem and
Non-CoDem colorless ports and
colored demands can't be greater
than 9 for type SMR-9.

Check the restoration path. It must
not have any dark fiber.

Plan mode restoration fails because
the presence of dark fiber in the
restoration path makes it difficult to
find it.

No Route Found.

Correct the wave such that the
wavelength is supported by the
optical subnet C-band rule.

Two fibers are occupied by a wave
with the same wavelength.

The fiber belongs to a subnet where
the wavelength is not supported. For
example, a wave with an even
wavelength is forced through a fiber
belonging to the C40 channel or
C48 channel subnet rules.

Wavelength Forced {0} in this
{1} is already in use / not as per
current optical subnet channel
rule.

Before you convert the site type to
traffic, modify the optical source
wave to be feasible.

ROADM sites having waves with
optical source other than 100,
200SDFEC are converted to traffic
sites.

tm.unsupported_client_pluggable.msg
=Incompatible Client Interface
forcing.

Refresh the browser and try again.Slow internet connectivity, or idle
session.

Error Message

Upload proper .MPZ file.The MPZ file that you are trying to
upload does not have a valid file
extension.

Please provide a valid .mpz
network file.

Close MPZ file in the CTP tool
before uploading it to Cisco ONP .

MPZ file remains open in the CTP
tool.

Failed to import mpz file, please
make sure the MPZ file is not in
use and retry.

Restart the Postgres database
container or reinstall the Build.

Failed to connect to Postgres DB on
opening Control Panel tab.

Cannot connect to
Server;(Password).
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WorkaroundProbable Reason for the ErrorWarning Message or Error

Fix the syntax and reapply the
template.

The applied layout template file has
syntax error such as extra SPACE,
TAB, missing symbols such as <,
>.

Null pointer exception

Refresh the browser or log in again
to Cisco ONP.

Intermediate network disconnection.Object not found in cache.

Log in again to Cisco ONP.Idle time-outSession does not exist.

Force another wavelength that is
next to the currently forced one.

Forced wavelength is not a feasible
central wavelength based on the
configuration.

Forced/Locked wavelength is not
feasible for spectrum to be
allocated for the demand/MCH
<Site-1-Site-3-1>. Insufficient
spectrum around the forced central
wavelength.

Make sure that the alternate path has
waves associated with the fiber and
has sufficient bandwidth available.

Insufficient spectral width due to
the following reasons:

• The alternate path has no
waves (dark fiber).

• Optical parameters are not
feasible.

• Wavelength dos not have
sufficient bandwidth.

Route could not be
found/Alternate path not
found/<Optically not feasible>.

Change Evolved Mesh to Off,
reduce Scalable upto degree to 8,
change Site Type to SMR-20, or
Remove contentionless or colorless
forcing.

Check if it is 8 degrees, SMR-9
node with Evolved Mesh ON and
contentionless and colorless/colored
mixed add/drop configuration.

Error: Could not find any valid
flex configuration for the traffic
matrix defined at <Site-1.A> This
could be because of configuration
limitations, invalid forcings, or
equipment restrictions.

• Enable Quick analysis.

• After successful analysis,
check the optical report and
look for the waves that require
regeneration.

• Split the long haul demand
between the intermediate short
distance nodes that are
equivalent to regen site.

• Disable Quick analysis and
analyze.

Check if Quick analysis under
Network property is disabled.

Single hop path Site-1~Site-3
needs regeneration but has no
regenerator hosting sites.
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WorkaroundProbable Reason for the ErrorWarning Message or Error

Check the source node configuration
(such as scalable upto degree,
number of colored and colorless
circuits or port forcing,and colored
add/drop card forcing).

Required Add/Drop card cannot be
placed on the source node.

Missing SOURCE TermPoint for
PceServiceRequest

Check the destination node
configuration (such as scalable upto
degree, number of colored and
colorless circuits or port forcing,and
colored add/drop card forcing).

Required Add/Drop card cannot be
placed on the destination node.

Missing DESTINATION
TermPoint for PceServiceRequest

• Check the colored add/drop
forcing and the number of
colored demands routing on the
path.

• Check the number of colorless
demands, ports, and add/drop
cards forced on the path.

• Check the optical subnet
defined on the path and the
type of service used.

Spectrum allocation failed for the
mentioned service

Service allocation failed: No
resource available

Check the card type forced for the
colored circuit. Circuits with a
maximum spectrum of 75GHz can
be used with colored add/drop
MD-32-ODD/EVEN. For example,
a circuit that has an interface with
rate greater than 60-bit rate or
60GBd cannot work with 75GHz
fixed grid add/drop with 82%
spectral density. Change to colorless
add/drop BRK-24 or change to
interface type having less spectral
occupancy.

Spectrum allocation failed for the
mentioned service

Service allocation failed:
[PCE-WAL00028] - No free
spectrum available to allocate
circuit: [PCE-WAL00028]

Force MF Unit as MF-4RUCheck if MF Unit is forced as
MF-1RU. Only 3 USB ports
available with NCS 1010OLT-C-R.
Maximum of only 3 Passives can be
connected to OLT line cards. So, for
Scalable upto degree >25, since
USB ports are not available to
connect to passive colorless
Add/Drop, error appears.

Colorless configuration is not
supported for Scalable Upto
Degree [25]
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WorkaroundProbable Reason for the ErrorWarning Message or Error

1. 1. Force L-band on all
intermediate nodes on the
L-band circuit route path.

2. 2. Try to force other available
path or add new path if
spectrum is exhausted on all
available paths.

1. If it is an L-band Circuit,
L-band forcing may be missing
in the intermediate nodes.

2. Complete spectrum is utilized
in the path if forced, or on all
the available path between
source and destination.

Error: No free spectrum available
to allocate circuit

Keep only two OLA sites between
Terminal sites.

The NCS 1001 network has more
than two OLA sites between
Terminal sites.

Untested System Configuration:
Number of OLA sites between
Terminal sites is more than 2.
Please contact support before
deployment.
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