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C H A P T E R 14

Alarm Monitoring and Management

This chapter describes Cisco Transport Controller (CTC) alarm management. To troubleshoot specific 
alarms, refer to the Cisco ONS 15454 Troubleshooting Guide. Chapter topics include:

• 14.1 Overview, page 14-1

• 14.2 Documenting Existing Provisioning, page 14-1

• 14.3 Viewing Alarm Counts on the LCD for a Node, Slot, or Port, page 14-2

• 14.4 Viewing Alarms, page 14-3

• 14.5 Alarm Severities, page 14-10

• 14.6 Alarm Profiles, page 14-10

• 14.7 Suppressing Alarms, page 14-14

• 14.8 Provisioning External Alarms and Controls, page 14-15

• 14.9 Audit Trail, page 14-16

14.1 Overview
The CTC detects and reports SONET alarms generated by the Cisco ONS 15454 and the larger SONET 
network. You can use CTC to monitor and manage alarms at the card, node, or network level. Default 
alarm severities conform to the Telcordia GR-253 standard, but you can reset alarm severities in 
customized alarm profiles or suppress CTC alarm reporting. For a detailed description of the standard 
Telcordia categories employed by Optical Networking System (ONS) nodes, refer to the 
Cisco ONS 15454 Troubleshooting Guide.

Note ONS 15454 alarms can also be monitored and managed through Transaction Language One (TL1) or a 
network management system (NMS).

14.2 Documenting Existing Provisioning
In the card-, node-, or network-level CTC view, choose File > Print to print CTC information in graphical 
or tabular form on a Windows-provisioned printer. Choose File > Export to export card, node, or network 
information as editable delineated text files to other applications. Printing and exporting data are useful 
for record keeping or troubleshooting purposes. 
14-1
isco ONS 15454 Reference Manual, R4.6



Chapter 14      Alarm Monitoring and Management
14.3 Viewing Alarm Counts on the LCD for a Node, Slot, or Port
Print card-, node-, or network-level CTC information in graphical or tabular form on a 
Windows-provisioned printer, or export card, node, or network information as editable delineated text 
files to other applications. This feature is useful for viewing the node inventory, circuit routing, or alarm 
data in network record-keeping and troubleshooting.

Whether you choose to print or export data, you can choose from the following options:

• Entire frame—Prints or exports the entire CTC window including the graphical view of the card, 
node, or network. This option is available for all windows.

• Tabbed view—Prints or exports the lower half of the CTC window containing tabs and data. The 
printout includes the selected tab (on top) and the data shown in the tab window. For example, if you 
print the History window Tabbed view, you print only history items appearing in the window. This 
option is available for all windows.

• Table Contents—Prints or exports CTC data in table format without graphical representations of 
shelves, cards, or tabs. This option applies to all windows except:

– Provisioning > General > General, Power Monitor windows

– Provisioning > Network > General, RIP windows

– Provisioning > Security > Policy, Access, or Legal Disclaimer windows

– Provisioning > SNMP window

– Provisioning > Timing window

– Provisioning > UCP > Node window

– Provisioning > WDM-ANS > Provisioning window

– Maintenance > Cross-Connect > Cards window

– Maintenance > Database window

– Maintenance > Diagnostic window

– Maintenance > Protection window

– Maintenance > Timing > Source window

The Table Contents option prints all the data contained in a table with the same column headings. 
For example, if you print the History window Table Contents view, you print all data included in the 
table whether or not items appear in the window.

The above items are also not available for the Export option.

14.3 Viewing Alarm Counts on the LCD for a Node, Slot, or Port
You can view node, slot, or port-level alarm counts and summaries using the buttons on the ONS 15454 
LCD panel. The Slot and Port buttons toggle between display types; the Slot button toggles between 
node display and slot display, and the Port button toggles between slot and port views. Pressing the 
Status button after you choose the display mode changes the display from alarm count to alarm summary.

The ONS 15454 has a one-button update for some commonly viewed alarm counts. If you press the Slot 
button once and then wait eight seconds, the display automatically changes from a slot alarm count to a 
slot alarm summary. If you press the Port button to toggle to port-level display, you can use the Port 
button to toggle to a specific slot and to view each port’s port-level alarm count. Figure 14-1 shows the 
LCD panel layout.
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14.4 Viewing Alarms
Figure 14-1 Shelf LCD Panel 

14.4 Viewing Alarms
In the card-, node-, or network-level CTC view, click the Alarms tab to display the alarms for that card, 
node, or network. The Alarms window shows alarms in conformance with Telcordia GR-253. This means 
that if a network problem causes two alarms, such as loss of frame (LOF) and loss of signal (LOS), CTC 
only shows the LOS alarm in this window because it supersedes the LOF and replaces it. 

In Release 4.6, the Path Width column has been added to the Alarms and Conditions tabs. This column 
expands upon alarmed object information contained in the AID string (such as “STS-4-1-3”) by giving 
the number of STSs contained in the alarmed path. For example, the Path Width will tell you whether a 
critical alarm applies to an STS1 or an STS48c. The column reports the width as a 1, 3, 6, 12, 48 etc. as 
appropriate, understood to be “STS-n.” 

Table 14-1 lists the column headings and the information recorded in each column.
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Table 14-1 Alarms Column Descriptions

Column Information Recorded

New Indicates a new alarm. To change this status, click either the Synchronize button or the 
Delete Cleared Alarms button.

Date Date and time of the alarm.

Node Node where the alarm occurred (appears only in network view).

Object TL1 access identifier (AID) for the alarmed object. For an STSmon or VTmon, the 
object.

Eqpt Type Card type in this slot.

Slot Slot where the alarm occurred (appears only in network and node view).

Port Port where the alarm is raised. For STSTerm and VTTerm, the port refers to the upstream 
card it is partnered with.

Path Width Indicates how many STSs are contained in the alarmed path. This information 
compliments the alarm object notation, which is explained in Table 14-3.

Sev Severity level: CR (critical), MJ (major), MN (minor), NA (not-alarmed), NR 
(not-reported).

ST Status: R (raised), C (clear).

SA When checked, indicates a service-affecting alarm.

Cond The error message/alarm name. These names are alphabetically defined in the “Alarm 
Troubleshooting” chapter of the Cisco ONS 15454 Troubleshooting Guide.

Description Description of the alarm.
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14.4.1 Viewing Alarms With Each Node’s Time Zone
Table 14-2 lists the color codes for alarm and condition severities. The inherited (I) and unset (U) 
severities are only listed in the network view Provisioning > Alarm Profiles tab. They are not currently 
implemented.

In network view, CTC identifies STS and VT alarm objects using a TL1-type access identifier (AID), as 
shown in Table 14-3.

14.4.1 Viewing Alarms With Each Node’s Time Zone
By default, alarms and conditions are displayed with the time stamp of the CTC workstation where you 
are viewing them. But you can set the node to report alarms (and conditions) using the time zone where 
the node is located by clicking Edit > Preferences, and clicking the Display Events Using Each Node’s 
Timezone check box.

Num An incrementing count of alarm messages. 

Ref The reference number assigned to the alarm.

Table 14-1 Alarms Column Descriptions (continued)

Column Information Recorded

Table 14-2 Color Codes for Alarm and Condition Severities

Color Description

Red Raised Critical (CR) alarm

Orange Raised Major (MJ) alarm

Yellow Raised Minor (MN) alarm

Magenta Raised Not-Alarmed (NA) condition

Blue Raised Not-Reported (NR) condition

White Cleared (C) alarm or condition

Table 14-3 Network View STS and Alarm Object Identification

Object STS or VT AID Port No.

MON object STS-Slot-Port-STS
For example, STS-6-1-6

VT1-Slot-Port-STS-VT_Group-VT
For example, VT1-6-1-6-1-1

Port=1

TERM object Upstream_Slot-Port-STS
For example, STS-6-3-6 

Upstream_Slot-Port-STS-VT_Group-VT
For example, VT1-6-3-6-1-1 

Port=1
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14.4.2 Controlling Alarm Display
14.4.2 Controlling Alarm Display
You can control the display of the alarms shown on the Alarms window. Table 14-4 shows the actions 
you can perform in the Alarms window.

14.4.3 Filtering Alarms
The alarm display can be filtered to prevent display of alarms with certain severities or alarms that 
occurred between certain dates. You can set the filtering parameters by clicking the Filter button at the 
bottom-left of the Alarms window. You can turn the filter on or off by clicking the Filter tool at the 
bottom-right of the window. CTC retains your filter activation setting. For example, if you turn the filter 
on and then log out, CTC keeps the filter active the next time your user ID is activated.

14.4.4 Viewing Alarm-Affected Circuits
A user can view which ONS 15454 circuits are affected by a specific alarm by positioning the cursor 
over the alarm in the Alarm window and right-clicking. A shortcut menu displays (Figure 14-2). When 
the user selects the Select Affected Circuits option, the Circuits window opens to show the circuits that 
are affected by the alarm (Figure 14-3).

Table 14-4 Alarm Display

Button/Check box/Tool Action

Filter button Allows you to change the display on the Alarms window to show only 
alarms that meet a certain severity level, occur in a specified time frame, 
and/or reflect specific conditions. For example, you can set the filter so that 
only critical alarms display on the window.

If you enable the Filter feature by clicking the Filter icon button in one CTC 
view, such as node view, it is enabled in the others as well (card view and 
network view).

Synchronize button Updates the alarm display. Although CTC displays alarms in real time, the 
Synchronize button allows you to verify the alarm display. This is 
particularly useful during provisioning or troubleshooting.

Delete Cleared Alarms 
button

Deletes alarms that have been cleared.

AutoDelete Cleared 
Alarms check box

If checked, CTC automatically deletes cleared alarms.

Filter tool Enables or disables alarm filtering in the card, node, or network view. When 
enabled or disabled, this state applies to other views for that node and for 
all other nodes in the network. For example, if the Filter tool is enabled in 
the node (default login) view Alarms window, the network view Alarms 
window and card view Alarms window also show the tool enabled. All other 
nodes in the network also show the tool enabled.
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14.4.5 Conditions Tab
Figure 14-2 Select Affected Circuits Option 

Figure 14-3 Viewing Alarm-Affected Circuits

14.4.5 Conditions Tab
The Conditions window displays retrieved fault conditions. A condition is a fault or status detected by 
ONS 15454 hardware or software. When a condition occurs and continues for a minimum period, CTC 
raises a condition, which is a flag showing that this particular condition currently exists on the 
ONS 15454. 
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14.4.6 Controlling the Conditions Display
The Conditions window shows all conditions that occur, including those that are superseded. For 
instance, if a network problem causes two alarms, such as loss of frame (LOF) and loss of signal (LOS), 
CTC shows both the LOF and LOS conditions in this window (even though LOS supersedes LOF). 
Having all conditions visible can be helpful when troubleshooting the ONS 15454. If you want to 
retrieve conditions that obey a root-cause hierarchy (that is, LOS supersedes and replaces LOF), you can 
exclude the same root causes by checking a check box in the window.

Fault conditions include reported alarms and not-reported or not-alarmed conditions. Refer to the trouble 
notifications information in the Cisco ONS 15454 Troubleshooting Guide for more information about 
alarm and condition classifications.

14.4.6 Controlling the Conditions Display
You can control the display of the conditions on the Conditions window. Table 14-5 shows the actions 
you can perform in the window.

14.4.6.1 Retrieving and Displaying Conditions

The current set of all existing conditions maintained by the alarm manager can be seen when you click 
the Retrieve button. The set of conditions retrieved is relative to the view. For example, if you click the 
button while displaying the node view, node-specific conditions are displayed. If you click the button 
while displaying the network view, all conditions for the network (including ONS 15454 nodes and other 
connected nodes) are displayed, and the card view shows only card-specific conditions.

You can also set a node to display conditions using the time zone where the node is located, rather than 
the time zone of the PC where they are being viewed. See the “Viewing Alarms With Each Node’s Time 
Zone” section on page 14-4 for more information.

14.4.6.2 Conditions Column Descriptions

Table 14-6 lists the Conditions window column headings and the information recorded in each column.

Table 14-5 Conditions Display

Button Action

Retrieve Retrieves the current set of all existing fault conditions, as maintained by 
the alarm manager, from the ONS 15454.

Filter Allows you to change the Conditions window display to only show the 
conditions that meet a certain severity level or occur in a specified time. For 
example, you can set the filter so that only critical conditions display on the 
window.

There is a Filter icon button on the lower-right of the window that allows 
you to enable or disable the filter feature.

Table 14-6 Conditions Column Description

Column Information Recorded

New Indicates a new condition.

Date Date and time of the condition.
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14.4.7 Viewing History
14.4.6.3 Filtering Conditions

The condition display can be filtered to prevent display of conditions (including alarms) with certain 
severities or that occurred between certain dates. You can set the filtering parameters by clicking the 
Filter button at the bottom-left of the Conditions window. You can turn the filter on or off by clicking 
the Filter tool at the bottom-right of the window. CTC retains your filter activation setting. For example, 
if you turn the filter on and then log out, CTC keeps the filter active the next time your user ID is 
activated.

14.4.7 Viewing History
The History window displays historic alarm or condition data for the node or for your login session. You 
can chose to display only alarm history, only events, or both by checking check boxes in the History > 
Node window. You can view network-level alarm and condition history, such as for circuits, at that level. 
At the node level, you can see all port (facility), card, STS, and system-level history entries. For example, 
protection-switching events or performance-monitoring threshold crossings appear here. If you 
double-click a card, you can view all port, card, and STS alarm or condition history that directly affects 
the card. 

The ONS 15454 can store up to 640 critical alarm messages, 640 major alarm messages, 640 minor alarm 
messages, and 640 condition messages. When any of these limits is reached, the ONS 15454 discards 
the oldest events in that category.

Note In the Preference dialog General tab, the Maximum History Entries value only applies to the Session 
window.

Different views of CTC display different kinds of history:

• The History > Session window is shown in network view, node view, and card view. It shows alarms 
and conditions that occurred during the current user CTC session. 

Object TL1 AID for the condition object. For an STSmon or VTmon, the object.

Eqpt Type Card type in this slot.

Slot Slot where the condition occurred (appears only in network and node view).

Port Port where the condition occurred. For STSTerm and VTTerm, the port refers to the 
upstream card it is partnered with.

Sev1 Severity level: CR (critical), MJ (major), MN (minor), NA (not-alarmed), NR 
(not-reported).

SA1 Indicates a service-affecting alarm (when checked).

Cond The error message/alarm name; these names are alphabetically defined in the “Alarm 
Troubleshooting” chapter of the Cisco ONS 15454 Troubleshooting Guide.

Description Description of the condition.

Node Node where the alarm occurred (appears only in network view).

1. All alarms, their severities, and service-affecting statuses are also displayed in the Condition tab unless you choose to filter 
the alarm from the display using the Filter button.

Table 14-6 Conditions Column Description (continued)

Column Information Recorded
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14.4.7 Viewing History
• The History > Node window is only shown in node view. It shows the alarms and conditions that 
occurred on the node since CTC software was operated on the node. 

• The History > Card window is only shown in card view. It shows the alarms and conditions that 
occurred on the card since CTC software was installed on the node. 

Tip Double-click an alarm in the History window to display the corresponding view. For example, 
double-clicking a card alarm takes you to card view. In network view, double-clicking a node alarm takes 
you to node view.

If you check the History window Alarms check box, you display the node history of alarms. If you check 
the Events check box, you display the node history of Not Alarmed and transient events (conditions). If 
you check both check boxes, you retrieve node history for both. 

14.4.7.1 History Column Descriptions

Table 14-7 lists the History window column headings and the information recorded in each column.

14.4.7.2 Retrieving and Displaying Alarm and Condition History

You can retrieve and view the history of alarms and conditions, as well as transients (passing 
notifications of processes as they occur) in the CTC history window. The information in this window is 
specific to the view where it is shown (that is, network history in the network view, node history in the 
node view, and card history in the card view). 

The node and card history views are each divided into two tabs. In node view, when you click the 
Retrieve button, you can see the history of alarms, conditions, and transients that have occurred on the 
node in the History > Node window, and the history of alarms, conditions, and transients that have 
occurred on the node during your login session in the History > Session window. In the card-view history 
window, after you retrieve the card history, you can see the history of alarms, conditions, and transients 
on the card in the History > Card window, or a history of alarms, conditions, and transients that have 
occurred during your login session in the History > Session window.

Table 14-7 History Column Description

Column Information Recorded

Date Date and time of the condition.

Object TL1 AID for the condition object. For an STSmon or VTmon, the object.

Sev Severity level: critical (CR), major (MJ), minor (MN), not-alarmed (NA), not-reported 
(NR).

Eqpt Type Card type in this slot (only displays in network view and node view).

ST Status: raised (R), cleared (C), or transient (T).

Description Description of the condition.

Port Port where the condition occurred. For STSTerm and VTTerm, the port refers to the 
upstream card it is partnered with.

Cond Condition name.

Slot Slot where the condition occurred (only displays in network view and node view).

SA Indicates a service-affecting alarm (when checked).
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14.5 Alarm Severities
You can also filter the severities and occurrence period in these history windows, but you cannot filter 
out not-reported conditions or transients.

14.5 Alarm Severities
ONS 15454 alarm severities follow the Telcordia GR-253 standard, so a condition maybe Alarmed—at 
a severity of Critical (CR), Major (MJ), or Minor (MN)—severities of Not Alarmed (NA) or Not 
Reported (NR). These severities are reported in the CTC software Alarms, Conditions, and History 
windows at all levels: network, shelf, and card.

ONS equipment provides a standard profile named “Default” listing all alarms and conditions with 
severity settings based on Telcordia GR-253 and other standards, but users can create their own profiles 
with different settings for some or all conditions and apply these wherever desired. (See the “Alarm 
Profiles” section on page 14-10.) For example, in a custom alarm profile, the default severity of a carrier 
loss (CARLOSS) alarm on an Ethernet port could be changed from major to critical. The profile allows 
setting to Not Reported or Not Alarmed, as well as the three alarmed severities.

Critical and Major severities are only used for service-affecting alarms. If a condition is set as Critical 
or Major by profile, it will raise as Minor alarm in the following situations: 

• In a protection group, if the alarm is on a standby entity (side not carrying traffic)

• If the alarmed entity has no traffic provisioned on it, so no service is lost. 

Because of this possibility of being raised at two different levels, the alarm profile pane shows Critical 
as “CR / MN” and Major as “MJ / MN.”

14.6 Alarm Profiles
The alarm profiles feature allows you to change default alarm severities by creating unique alarm profiles 
for individual ONS 15454 ports, cards, or nodes. A created alarm profile can be applied to any node on 
the network. Alarm profiles can be saved to a file and imported elsewhere in the network, but the profile 
must be stored locally on a node before it can be applied to the node, its cards, or its cards’ ports. 

CTC can store up to ten active alarm profiles at any time to apply to the node. Custom profiles can take 
eight of these active profile positions, and two are reserved by CTC. The reserved Default profile 
contains Telcordia GR-253 severities. The reserved Inherited profile allows port alarm severities to be 
governed by the card-level severities, or card alarm severities to be determined by the node-level 
severities.

If one or more alarm profiles have been stored as files from elsewhere in the network onto the local PC 
or server hard drive where CTC resides, you can utilize as many profiles as you can physically store by 
deleting and replacing them locally in CTC so that only eight are active at any given time.

14.6.1 Creating and Modifying Alarm Profiles
Alarm profiles are created in the network view using the Provisioning > Alarm Profiles tabs. Figure 14-4 
shows the default list of alarm severities. A default alarm severity following Telcordia GR-253 standards 
is preprovisioned for every alarm. After loading the default profile or another profile on the node, you 
can use the Clone feature to create custom profiles. After the new profile is created, the Alarm Profiles 
window shows the original profile—frequently Default—and the new profile.
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14.6.1 Creating and Modifying Alarm Profiles
Figure 14-4 Network View Alarm Profiles Window

Note The alarm profile list contains a master list of alarms that is used for a mixed node network. Some of 
these alarms might not be used in all ONS nodes.

Note The Default alarm profile list contains alarm and condition severities that correspond when applicable 
to default values established in Telcordia GR-253.

Note All default or user-defined severity settings that are Critical (CR) or Major (MJ) are demoted to Minor 
(MN) in non-service-affecting situations as defined in Telcordia GR-474. 

Tip To see the full list of profiles including those available for loading or cloning, click the Available button. 
You must load a profile before you can clone it. 

Note Up to 10 profiles, including the two reserved profiles — Inherited and Default — can be stored in CTC.

Wherever it is applied, the Default alarm profile sets severities to standard Telcordia GR-253 settings. 
In the Inherited profile, alarms inherit, or copy, severity from the next-highest level. For example, a card 
with an Inherited alarm profile copies the severities used by the node housing the card. If you choose the 
Inherited profile from the network view, the severities at the lower levels (node and card) are copied from 
this selection. 
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14.6.2 Alarm Profile Buttons
You do not have to apply a single severity profile to the node-, card-, and port-level alarms. Different 
profiles can be applied at different levels. You could use the inherited or default profile on a node and 
on all cards and ports, but apply a custom profile that downgrades an alarm on one particular card. For 
example, you might choose to downgrade an OC-N unequipped path alarm (UNEQ-P) from Critical 
(CR) to Not Alarmed (NA) on an optical card because this alarm raises and then clears every time you 
create a circuit. UNEQ-P alarms for the card with the custom profile would not display on the Alarms 
tab. (But they would still be recorded on the Conditions and History tabs.) 

When you modify severities in an alarm profile:

• All Critical (CR) or Major (MJ) default or user-defined severity settings are demoted to Minor (MN) 
in Non-Service-Affecting (NSA) situations as defined in Telcordia GR-474. 

• Default severities are used for all alarms and conditions until you create a new profile and apply it. 

• Changing a severity to TR or U does not change its display or its default severity.

14.6.2 Alarm Profile Buttons
The Alarm Profiles window displays six buttons on the right side. Table 14-8 lists and describes each of 
the alarm profile buttons and their functions. 

14.6.3 Alarm Profile Editing
Table 14-9 lists and describes the five profile-editing options available when you right-click an alarm 
item in the profile column (such as Default). 

Table 14-8 Alarm Profile Buttons

Button Description

Load Loads a profile to a node or a file.

Store Saves profiles on a node (or nodes) or in a file.

Delete Deletes profiles from a node.

Compare Displays differences between alarm profiles (for example, individual alarms that 
are not configured equivalently between profiles).

Available Displays all profiles available on each node.

Usage Displays all entities (nodes and alarm subjects) present in the network and which 
profiles contain the alarm. Can be printed.

Table 14-9 Alarm Profile Editing Options

Button Description

Store Saves a profile in a node or in a file.

Rename Changes a profile name.

Clone Creates a profile that contains the same alarm severity settings as the profile 
being cloned.

Reset Restores a profile to its previous state or to the original state (if it has not yet 
been applied).

Remove Removes a profile from the table editor.
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14.6.4 Alarm Severity Options
To change or assign alarm severity, left-click the alarm severity you want to change in the alarm profile 
column. Seven severity levels appear for the alarm:

• Not-reported (NR)

• Not-alarmed (NA)

• Minor (MN)

• Major (MJ) 

• Critical (CR)

• UNSET: Unset/Unknown (not normally used)

• Inherited (I)

Inherited and Unset only appear in alarm profiles. They do not appear when you view alarms, history, or 
conditions. 

14.6.5 Row Display Options
In the network view, the Alarm Profiles window displays two check boxes at the bottom of the window:

• Hide reference values—Highlights alarms with non-default severities by clearing alarm cells with 
default severities.

• Hide identical rows—Hides rows of alarms that contain the same severity for each profile. 

14.6.6 Applying Alarm Profiles
In CTC node view, the Alarm Behavior window displays alarm profiles for the node. In card view, the 
Alarm Behavior window displays the alarm profiles for the selected card. Alarm profiles form a 
hierarchy. A node-level alarm profile applies to all cards in the node except cards that have their own 
profiles. A card-level alarm profile applies to all ports on the card except ports that have their own 
profiles.

At the node level, you can apply profile changes on a card-by-card basis or set a profile for the entire 
node. At the card-level view, you can apply profile changes on a port-by-port basis or set alarm profiles 
for all ports on that card. Figure 14-5 shows the E1000-4 card view of an alarm profile.
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14.7 Suppressing Alarms
Figure 14-5 Card View of an E1000-4 Card Alarm Profile

14.7 Suppressing Alarms
ONS 15454 nodes have an alarm suppression option that clears raised alarm messages for the node, 
chassis, one or more slots (cards), or one or more ports. After they are cleared, these alarms change 
appearance from their normal severity color to white and they can be cleared from the display by clicking 
Synchronize. Alarm suppression itself raises an alarm called AS-CMD that is shown in applicable 
Alarms windows. Node-level suppression is shown in the node view Alarms window, and card or 
port-level suppression is shown in all views. The AS-CMD alarm itself is not cleared by the suppress 
command. Each instance of this alarm indicates its object separately in the Object column.

A suppression command applied at a higher level does not supersede a command applied at a lower level. 
For example, applying a node-level alarm suppression command makes all raised alarms for the node 
appear to be cleared, but it does not cancel out card-level or port-level suppression. Each of these 
conditions can exist independently and must be cleared independently. 

Suppression causes the entity alarm to behave like a Not-Reported event. This means that the alarms, 
having been suppressed from view in the Alarms window, are now only shown in the Conditions window. 
The suppressed alarms are displayed with their usual visual characteristics (service-affecting status and 
color-coding) in the window. The alarms still appear in the History window.

Note Use alarm suppression with caution. If multiple CTC or TL1 sessions are open, suppressing the alarms 
in one session suppresses the alarms in all other open sessions.
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14.8 Provisioning External Alarms and Controls
External alarm inputs can be provisioned on the AIC or AIC-I cards for external sensors such as an open 
door and flood sensors, temperature sensors, and other environmental conditions. External control 
outputs on these two cards allow you to drive external visual or audible devices such as bells and lights. 
They can control other devices such as generators, heaters, and fans.

You provision external alarms in the AIC card view Provisioning > External Alarms tab and controls in 
the AIC card view Provisioning > External Controls tab. Up to 4 external alarm inputs and four external 
controls are available with the AIC card. Up to 12 external alarm inputs and four external controls are 
available with the AIC-I card. If you also provision the alarm extension panel (AEP) with the AIC-I, 
there are 32 inputs and 16 outputs. 

14.8.1 External Alarm Input
You can provision each alarm input separately. Provisionable characteristics of external alarm inputs 
include:

• Alarm type

• Alarm severity (CR, MJ, MN, NA, and NR)

• Alarm-trigger setting (open or closed); open means that the normal condition is no current flowing 
through the contact, and the alarm is generated when current does flow; closed means that normal 
condition is to have current flowing through the contact, and the alarm is generated with current 
stops flowing

• Virtual wire associated with the alarm

• CTC alarm log description (up to 63 characters)

Note If you provision an external alarm to raise upon an open contact before you physically connect 
to the ONS equipment, the alarm will raise until you do create the physical connection.

Note When you provision an external alarm, the alarm object is ENV-IN-nn. The variable nn refers to 
the external alarm’s number, regardless of the name you assign.

14.8.2 External Control Output
You can provision each alarm output separately. Provisionable characteristics of alarm outputs include:

• Control type.

• Trigger type (alarm or virtual wire).

• Description for CTC display.

• Closure setting (manually or by trigger). If you provision the output closure to be triggered, the 
following characteristics can be used as triggers:

– Local NE alarm severity—A chosen alarm severity (for example, major) and any higher-severity 
alarm (in this case, critical) causes output closure.
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– Remote NE alarm severity—Similar to local NE alarm severity trigger setting, but applies to 
remote alarms.

– Virtual wire entities—You can provision an alarm that is input to a virtual wire to trigger an 
external control output.

14.9 Audit Trail
The ONS 15454 keeps a human-readable audit trail of all system actions such as circuit creation or 
deletion, and security events such as login and logout. You can archive this log in text form on a PC or 
network. You can access the log by clicking the Maintenance > Audit tabs. The log capacity is 
640 entries; when this limit is reached, the oldest entries are overwritten with new events. When the log 
is 80 percent full, an AUD-LOG-LOW condition is raised. When the log is full and entries are being 
overwritten, an AUD-LOG-LOSS condition occurs.

Tip You can save the audit trail to prevent loss of information that applies to alarms.

This window contains the columns listed in

Table 14-10 Audit Trail Window Columns

Heading Explanation

Date Date when the action occurred.

Num Incrementing count of actions.

User User ID that initiated the action.

P/F Pass/Fail (that is, whether or not the action was executed).

Operation Action that was taken.
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