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Introduction
Cisco WAE is a model-driven path visibility and path computation engine that simulates, automates, and 
optimizes multi-vendor, multi-layer networks by leveraging time-series traffic and flow data. For more 
information on Cisco WAE, visit http://www.cisco.com/go/wae.
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New Features
New Features
This section contains the following new features:

• WAE Design

• WAE Live

• WAE Collection

• WAE System

• WAE Modeling

• Schema Changes

• CLI Changes

• API Changes

• Documentation Changes

WAE Design
The following table describes all new features related to WAE Design.

Feature Description

New Tools/Optimization Tool Enhancements

New tool to perform capacity planning 
optimization on plan files.

(Tools > Capacity Planning Optimization)

Enables capacity planning to address increased 
traffic and congestion.

To alleviate congestion, the optimizer enables:

• Upgrade of existing circuits by adding more 
capacity to them.

• Augmentation of these circuits with associated 
port circuits.

• Addition of parallel circuits to existing circuits.

• Specification of new adjacencies between 
nodes that were not initially connected.

The optimizer operates on both Layer 3 and Layer 1 
and provides failure set optimization options.

For more information, see the “Capacity Planning 
Optimization” chapter in the WAE Design User 
Guide.

New LSP Setup Bandwidth Optimization tool.

(Tools > LSP Setup BW Optimization)

Creates/removes LSPs for specified LSP groups and 
shares Setup BW evenly within each group.

For more information, see the “LSP Setup 
Bandwidth Optimization” chapter in the WAE 
Design User Guide.
2
Cisco WAN Automation Engine Release Notes, Release 6.4

http://www.cisco.com/c/en/us/td/docs/net_mgmt/wae/6-4/design/user/guide/WAE_Design_User_Guide.html
http://www.cisco.com/c/en/us/td/docs/net_mgmt/wae/6-4/design/user/guide/WAE_Design_User_Guide.html
http://www.cisco.com/c/en/us/td/docs/net_mgmt/wae/6-4/design/user/guide/WAE_Design_User_Guide.html
http://www.cisco.com/c/en/us/td/docs/net_mgmt/wae/6-4/design/user/guide/WAE_Design_User_Guide.html


   

New Features
New SR-TE BW optimization tool.

(Tools > SR-TE BW Optimization)

The Segment Routing (SR) TE Bandwidth (BW) 
Optimization tool enables:

• Reduction of the traffic utilization of selected 
interfaces to below a specified threshold.

• Analysis on how well congestion mitigation 
works when using segment routing over 
different failure scenarios.

For more information, see the “SR-TE Bandwidth 
Optimization” chapter in the WAE Design User 
Guide.

New LSP Disjoint Optimization tool.

(Tools > LSP Disjoint Path Optimization)

Extended support for LSP disjointness includes:

• Enhancements to the disjointness algorithm 
that enable the optimization tools to find 
disjointness under a broader set of constraints.

• Enhancements to Inter-Area for disjointness— 
the LSP Disjoint Path Optimization tool tries to 
find disjoint LSP paths for Inter-Area LSPs.

For more information, see the “LSP Disjoint Path 
Optimization” chapter in the WAE Design User 
Guide.

Enhancements to the LSP Loadshare 
Optimization tool.

(Tools > LSP Loadshare Optimization)

It is possible to specify a subset of interfaces whose 
utilization should be optimized. The produced 
reports are enhanced.

Enhancement to optimize inter-AS SR LSPs. See 
also the Simulation of Inter-AS SR LSPs.

(Tools > SR-TE Optimization)

The SR-TE Optimization tool is extended to create 
Segment Lists for inter-AS SR LSPs.

For more information, see the “SR-TE 
Optimization” chapter in the WAE Design User 
Guide.

Layer 1 Enhancements

Ability to set the number of new L1 circuits that 
are created when they are being duplicated.

For more information, see the “Simulation” chapter 
(“Duplicate L1 Objects”) in the WAE Design User 
Guide.

Ability to set L1 node type. For more information, see the “Layer 1 Simulation” 
chapter (“Create L1 Nodes”) in the WAE Design 
User Guide.

Enhancement to find L1 links that are causing 
lambda blocking.

For more information, see the “Layer 1 Simulation” 
chapter (“Lambda Assignments”) in the WAE 
Design User Guide.

Addition of a Network Option that controls 
whether Layer 1 rerouting has converged under 
failures.

The Simulation tab includes the new option: “Layer 
1 rerouting convergence under failures.”

Option to fail the L1 object causing the Worst 
Case L1 Utilization on a selected L1 Link.

—

Feature Description
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L1 Simulation Enhancements. The Simulator includes L1 simulation 
enhancements with respect to parallel L1 Links and 
routing and Lambda assignment.

Visualization Enhancements

Enhancement to easily view association between 
L1 links and LSPs and demands.

Selecting a Demand in the network plot 
automatically highlights the associated L1 Links 
that are carrying the Demand. Selecting an LSP in 
the network plot automatically highlights the 
associated L1 Links that are carrying the LSP.

For more information, see the “Layer 1 Simulation” 
chapter (“Multi-Layer Views”) in the WAE Design 
User Guide. 

Improvements to readability of L1 link text. The text displayed for L1 Links is easier to read 
especially in cases where L1 Links are colored with 
darker colors.

Improvements to the visualization of L1 link 
utilization.

L1 Links are colored based on their utilization and 
worst-case utilization. The thresholds and 
corresponding colors are the same as in L3.

Patch File Enhancements

Additional plan attributes for LSP-related 
objects are now supported.

The create_patch and apply_patch tools consider 
more properties with respect to LSPs, LSP Paths, 
Named Paths, Named Path Hops, Segment Lists, 
and Segment List Hops.

New location and improvements to creating, 
applying, and viewing patches.

(Tools > Patches)

For more information, see the “Patch Files” chapter 
in the WAE Design User Guide.

RSVP-TE and SR Simulation Enhancements

SR LSPs can now be specified as segment list 
hops in segment lists associated to SR LSPs 
(Binding SIDs).

For more information, see the “Segment Routing 
Simulation” chapter in the WAE Design User 
Guide.

Simulation of Inter-AS SR LSPs. It is possible to simulate inter-AS SR LSPs. For 
more information, see the “Segment Routing 
Simulation” chapter (“Routing Inter-AS SR LSPs”) 
in the WAE Design User Guide.

Support of Extended Admin Groups for LSPs 
and LSP Paths.

For more information, see the “RSVP TE 
Simulation” chapter (“Affinities”) in the WAE 
Design User Guide.

Usability Enhancements

Usability enhancement to close tabbed windows. In the WAE Design main window, users can now 
close tabbed windows by clicking on the “X” in the 
top right corner of the tab, instead of having to 
explicitly select the File > Close menu.

Ability to simultaneously plot multiple demands 
in the same Demand Plot.

For more information, see the “Traffic Demand 
Modeling” chapter (“View Demand Plots”) in the 
WAE Design User Guide.

Feature Description
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Usability enhancement to the SR-TE 
Optimization tool when setting up constraints.

Users no longer need to pre-tag nodes that should be 
avoided and then type in the name of the tag in the 
Constraints dialog box. For more information, see 
the “SR-TE Optimization” chapter (“Constraints”) 
in the WAE Design User Guide.

Usability enhancement to improve L1 Circuit 
creation and association to Port Circuits.

For more information, see the “Layer 1 Simulation” 
chapter (“Create L1 Circuits”) in the WAE Design 
User Guide.

Usability enhancement in Network Options. Layer 3 and Layer 1 simulation convergence modes 
are grouped together in the Simulation tab of the 
Network Options.

Improvements to “Save to”/”Open from” menus. The following menus:

• File > Open from/Save to WAE

• File > Open from/Save to > Design Archive

were changed to:

• File > Open from/Save to > WAE Automation 
Server

• File > Open from/Save to > Archive

Usability enhancement to the API 
Documentation.

The API documentation has been updated to “WAE 
Design API.”

Deprecated

The mate_jasper tool is no longer supported. —

Feature Description
5
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WAE Live
The following table describes all new features related to WAE Live.

Feature Description

Option to select the Collector Server network. Ability to select which network on the Collector 
Server to insert a plan file into WAE Live.

For more information, see the “Multi-Network 
Management” chapter in the WAE Live 
Administration Guide.

Option to add a remote network link. Ability to add a remote network link in a 
multi-network environment.

For more information, see the Multi-Network 
Management” chapter (“Adding a Remote 
Network Link”) in the WAE Live Administration 
Guide.

Ability to use plan files from external archives. The WAE Live and WAE Collector server plan 
files can be separate from each other for the 
purpose of collecting plan file data from external 
archives.

For more information, see the “Data Source 
Settings” chapter (“Collecting Plan Files from 
External Archives”) in the WAE Live 
Administration Guide.

Explore UI Enhancements

Ability to filter Interface Queues based on 
interface descriptions in the Explore view.

The Explore Interfaces UI includes a new 
description column in the Interfaces table that 
enables:

• Filtering on interface descriptions.

• Creating reports on interface queues with 
descriptions.

• Creating user-defined properties with 
interface queue descriptions.
6
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WAE Collection
The following table describes all new features related to collection configuration.

Numerous enhancements in the Explore table. The Explore table includes the following 
enhancements:

• LSPs tab

– Enables hop selection in the Actual Path 
column, which takes you to the 
appropriate interfaces in the Interfaces 
table.

– The Related Objects button enables 
filtering on both LSP source and 
destination nodes.

• Interfaces tab—Enables filtering on both 
local and remote interfaces.

• Nodes tab

– Enables filtering on the LSP destination 
and actual path.

– The Related Objects menu LSPs menu 
changed LSPs to explicitly state LSPs 
Source.

Enhancement to WAE Live graph performance. Performance is improved for the initial loading of 
WAE Live graphs with more than one month 
worth of data by sending sampled data rather than 
sending every data point to the UI.

Feature Description

Feature Description.

Collector Server (WAE Collector UI)

All WAE Collector UI configuration features are described in the “Collecting Network Information” 
chapter (“Collecting Basic Information Using the WAE Collector UI”) in the WAE Platform 
Configuration Guide.

Multiple network data collection using the UI. Ability to configure collection on more than one 
network.

For more information, see the “Add Additional 
Networks for Collection” section.

New management IP editing capability on the 
Node List table.

Ability to edit the Management IP address for one 
or more nodes directly on the Node List table.

For more information, see the “View and Manage 
the Node List” section (“Edit Node Credentials”).
7
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New option to set collection storage history. Ability to configure how long or how many 
collections to store in the collector server.

For more information, see the “Configure 
Collection History” section.

Advanced (Manual) Collection

New multi-layer collection capability. Ability to collect inventory and topology 
information from a multi-layer (Layer 1 and 
Layer 3) network. Layer 1 (optical) collection has 
been tested with Cisco DWDM networks with 
Cisco Network Convergence Systems (NCS) 2000 
and Cisco ONS 15454.

For more information, see the “Collecting 
Multi-Layer Information” chapter in the WAE 
Platform Configuration Guide.

Option to remove amplifier L1 links and nodes 
from topology collection.

For more information, see the “Collecting 
Multi-Layer Information” chapter in the WAE 
Platform Configuration Guide.

Option to collect feasibility metric and limit 
information in L1 circuits.

For more information, see the “Collecting 
Multi-Layer Information” chapter (“Collecting 
Feasibility Properties for L1 Circuits”) in the 
WAE Platform Configuration Guide.

Option to collect failed L1 links. For more information, see the “Collecting 
Multi-Layer Information” chapter (“Collecting 
Inactive or Failed L1 Circuit Objects”) in the WAE 
Platform Configuration Guide.

Support for point-to-multipoint (P2MP) RSVP 
LSP collection from Cisco IOS XR and Juniper 
devices.

The parse_configs and snmp_find_rsvp tools 
have been enhanced to support P2MP LSPs and 
paths.

Note P2MP collection has been tested on Cisco 
IOS XR 5.1.3.

Extended support for Segment Routing (SR) LSPs 
and paths from IS-IS to OSPFv2.

The parse_configs tool has been modified.

Feature Description.
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WAE System
The following table describes all new features related to the WAE System.

WAE Modeling

Network Model Manager

The Network Model Manager is a new WAE UI tool that can be used to augment the network model 
generated by the Collector Server with traffic demand and visual layout information (by applying a 
template plan file). It then stores the augmented plan file in WAE Design Archive. For more information, 
see the “Viewing a Network Model” chapter in the WAE Platform Configuration Guide.

Schema Changes
Refer to the /opt/cariden/software/mate/current/docs/table_schema.html file for a complete reference.

New Columns in Plan Tables

Feature Description

Ability to show or hide components from the 
WAE System Settings page.

Administrators can configure which applications 
can be hidden from the WAE UI. For more 
information, see the “User Management” chapter 
in the WAE System Administrator Guide.

New WAE Statistics > Database Info page. You can now view and monitor database 
information such as space usage, read/write cache 
rate percentage, and disk input/output 
performance from the WAE Statistics > Database 
Info page.

For more information, see the “Services and 
Statistics” chapter in the WAE System 
Administrator Guide.

Option to set the time zone on a per-user basis. For more information, see the “User 
Management” chapter in the WAE System 
Administrator Guide.

Plan Table New Column Type Description

<L1Links> WCFailures Derived L1 failures causing the worst case utilization.

<L1Nodes> Type Plan Identified node type as a reconfigurable optical add-drop 
multiplexer (ROADM) or an amplifier.

<LSPPaths> Tags Plan Tags assigned to the LSP Path.
9
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CLI Changes
WAE Design, WAE Live, and WAE Collector CLI tools are located in the 
/opt/cariden/software/mate/current/bin. For available CLI options and descriptions, execute the CLI tool 
with the -help option.

New CLI Tools

New CLI Options

The following table describes all new CLI options.

CLI Tool Description

WAE Design Optimization

capacity_planning_opt Optimizes capacity planning by upgrading existing circuits and 
creating new circuits to meet maximum utilization thresholds. L1 
circuits may be optionally created.

lsp_setup_BW_opt Adds or removes LSPs for each LSP group and shares the setup 
bandwidth evenly within each group.

lsp_disjoint_path_opt Optimizes routing of LSPs to respect disjoint path requirements and 
to minimize the specified path metric.

sr_te_bw_opt Mitigates congestion by rerouting demands via private SR LSPs with 
optimized routings. Interfaces whose utilization exceed the given 
threshold are considered to be congested.

sr_te_bw_analysis Provides segment routing congestion mitigation analysis across 
different scenarios. More detailed information on SR congestion 
mitigation can be found in the sr_te_bw_opt tool.

Multi-Layer Collection

wae-ml Provides the multi-layer services needed for multi-layer data 
collection.

This tool is available in $WAE_ROOT/bin. For more information, see 
the “Collecting Multi-Layer Information” chapter in the WAE 
Platform Configuration Guide. 

access_netconf Merges L1 model with the L3 model.

CLI Tool Option Description

WAE Live Server

mld mld -createnetwork New CLI option to the mld command to create 
networks.

WAE Design
10
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Removed or Deprecated CLIs

The following table describes all removed or deprecated CLI features.

API Changes

New APIs

The following table describes all new API features. WAE Design API documentation is located in 
$CARIDEN_HOME/docs/api/design.

lsp_loadshare_opt -opt-interfaces-table 
<file>

This is a table of interfaces whose utilization 
should be optimized. Default is all.

sr_te_opt -avoid-nodes-table 
<file>

Segment List (SL) entries will be created to route 
away from any nodes in this table. Default is none. 
If nodes are additionally specified via the 
-avoid-nodes-tag option, the union of these 
nodes should be considered.

CLI Tool Option Description

Feature Description

explicit_LSP_path_init The following options of the 
explicit_LSP_path_init tool are deprecated:

• -routing-selection

• -strict-circuit-priority

• -strict-srlg-priority

• -strict-node-priority

• -strict-site-priority

• -strict-l1link-priority

Feature Description

WAE Design APIs

CapacityPlanningOptimizer Optimizes capacity planning by upgrading 
existing circuits and creating new circuits to meet 
maximum utilization thresholds. L1 circuits may 
be optionally created.

LSPDisjointPathOptimizer Optimize routing of LSPs to respect disjoint path 
requirements and to minimize the specified path 
metric.

SRTEOptimizer Finds the shortest segment route for a given set of 
SR LSPs.

SRTEBWOptimizer Mitigates congestion on selected interfaces.
11
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Removed or Deprecated APIs

The following table describes all removed or deprecated API features.

Documentation Changes
The Cisco WAE Plan Table Schema and CLI Reference document has been removed from the Cisco WAE 
documentation set. The Cisco WAE Server Installation Guide is available only on Cisco.com: 
http://www.cisco.com/c/en/us/support/routers/quantum-wan-automation-visibility-engine/products-inst
allation-guides-list.html.

NodeConfiguredSRLGs The NodeConfiguredSRLGs enables users to 
associate a set of SRLGs to a Node for LSP 
routing purposes. To specify the set of SRLGs, 
WAE Design uses a set of SRLG keys. The 
NodeConfiguredSRLGs returns the set of SRLGs 
configured on a particular node.

CreatePatch The new CreatePatch tool uses the 
com.cisco.wae.design.tools function. The 
CreatePatch.run(network1, network2) returns 
a string containing the XML patch.

ApplyPatch Applies the operations defined in the patch to a 
network.

L1NodeLayoutPropertiesRecord Support for setting/getting L1 Node Layout 
Properties in the API.

ColumnRecords ColumnRecords now supports all ColumnData 
content.

SimAnalysis.populateResultsFromNetwork(net) Preserves worst-case simulation analysis data 
from a plan file read into API. Populates API 
result records from SimAnalysis results of a 
previous run that is saved in the Network. 

rehome() New method for the circuit class rehome(). 
Provides the ability to re-home circuits.

Feature Description

Feature Description

The Design API function to generate patch files 
using the PlanComparator tool has been removed. 
This is replaced by the CreatePatch API tool in 
6.4.

The actual function call that was removed is: 
com.cisco.wae.design.tools.PlanComparator.
generatePatch(network1, network2), which 
would return a string containing the XML patch.

The “import OSPF” function has been removed. This function is not a part of the WAE Design 
schema, so there is no need to expose it via the 
API.
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Open Source
Open Source
A list of open source software used in WAE can be found in Open Source Software Used in Cisco WAN 
Automation Engine.

Bugs
The following are descriptions of the open and resolved bugs in Cisco WAE Release 6.4. The bug ID 
links you to the Cisco Bug Search tool.

Open Bugs

Resolved Bugs

Using the Bug Search Tool
Use the Bug Search tool to search for a specific bug or to search for all bugs in a release.

Step 1 Go to http://tools.cisco.com/bugsearch.

Step 2 At the Log In screen, enter your registered Cisco.com user name and password; then, click Log In. The 
Bug Search page opens.

Note If you do not have a Cisco.com user name and password, you can register for them at 
http://tools.cisco.com/RPF/register/register.do.

Step 3 To search for a specific bug, enter the bug ID in the Search For field and press Return.

Table 1 Open Bugs

Bug ID Description

CSCva21574 Collector Server log files increase in size and takes up too much disk space on the server.

Table 2 Resolved Bugs

Bug ID Description

CSCuy05290 The ml_restore command fails with permission issues.

CSCuy13871 Sometimes after running ifx_env.sh, the environment is only partially configured and 
ml_bakcup fails.

CSCuz02936 After server installation, wae-mld is not started without manual intervention.

CSCuz67029 In WAE Live, if you edit a report and click Run, the changes you made will not be integrated 
in the report.

CSCva12875 Incorrect LSP status for Alacatel Lucent 7950XRS devices.
13
Cisco WAN Automation Engine Release Notes, Release 6.4

http://tools.cisco.com/bugsearch
http://www.cisco.com/c/en/us/support/routers/quantum-wan-automation-visibility-engine/products-licensing-information-listing.html
http://www.cisco.com/c/en/us/support/routers/quantum-wan-automation-visibility-engine/products-licensing-information-listing.html
https://tools.cisco.com/bugsearch/bug/CSCuz67029
http://tools.cisco.com/RPF/register/register.do
https://tools.cisco.com/bugsearch/bug/CSCva21574
https://tools.cisco.com/bugsearch/bug/CSCuy05290
https://tools.cisco.com/bugsearch/bug/CSCuy13871
https://tools.cisco.com/bugsearch/bug/CSCuz02936
https://tools.cisco.com/bugsearch/bug/CSCva12875


   

Known Limitations
Step 4 To search for bugs in the current release:

a. In the Search For field, enter a problem, feature, or a product name (for example, Cisco WAN 
Automation Engine) and press Return. (Leave the other fields empty.)

b. When the search results are displayed, use the filter tools to find the types of bugs you are looking 
for. You can search for bugs by modified date, status, severity, and so forth.

To export the results to a spreadsheet, click the Export Results to Excel link.

Known Limitations
This section describes the limitations and restrictions for Cisco WAE.

WAE Design
In some Linux installations with Xfce desktop installed, the documentation does not open from the WAE 
Design GUI Help menu. The workaround is to do one of the following:

• Open the help files from a terminal in the $CARIDEN_HOME/docs directory.

• Install a default browser.

• Install the following packages:

yum install evince
yum groupinstall "X Window System"
yum groupinstall "Desktop"
yum groupinstall "General Purpose Desktop"

WAE Collector and WAE Network Interface (NI)
• Due to vendor MIB limitations, Collector cannot represent QoS traffic on interfaces that have more 

than one VLAN configured. If a network contains such interfaces, their queue traffic statistics are 
omitted from the collection. The total traffic on these interfaces is still measured. As a result, per 
class-of-service demands estimated through Demand Deduction are less accurate. Estimates of 
traffic totals over all classes of services, however, are not affected.

• Due to lack of MIB support, SR tunnel type is not collected for Cisco IOS XR routers through 
SNMP.

• Collection of interface egress shaping rate for Alcatel-Lucent devices does not support LAG 
interfaces.

WAE NI

• The interval for continuous LSP discovery in WAE NI cannot be less than 60 seconds.

• LSP's ActualPathHop cannot be resolved when using continuous collection. As a workaround, use 
interval-based collection.
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Known Limitations
Collector

• Juniper MIBs do not support P2MP LSPs.

• If upgrading the Collector server from 5.6x to 6.1x or 6.2, the 
$CARIDEN_ROOT/etc/collector/server/db-persistence/DiscoveryEngineImplementation.db 
file must be removed prior to starting the web server. Since installation automatically starts the web 
server, the recommendation is to remove this prior to installation.

• OSPFv3 and IPv6 IS-IS databases cannot be collected. The workaround is to use a manual snapshot.

• SNMPv3 is not an available option when configuring default credentials.

• snmp_find_interfaces 

– Does not support association of a GRE tunnel with the physical interface it uses to reach the 
tunnel destination since the IP-Tunnel MIB lacks this information.

– Does not update LAG port status if LAGs are discovered running both parse_configs and 
snmp_find_interfaces. The workaround is to run only snmp_find_interfaces.

• Juniper routers: Signaled standby LSP path option is not available from the standard MPLS-TE MIB 
for Juniper routers. Only the active path option name is collected. 

• Cisco IOS XR routers

– IGP topology collected through parse_igp and login_find_igp_db 

– IS-IS link-state database with TE extensions contains incorrect interface “admin-weights” 
(TE metric) on Intel-based routers.

– IPv6 IS-IS link-state database does not contain IPv6 interface addresses or parallel interfaces. 
This information is only available when Cisco IOS XR supports IS-IS IPv6 TE extensions. The 
snmp_find_interfaces tool collects this information.

– MAC Accounting is not supported.

– snmp_find_rsvp does not set the Standby value in the <LSPPaths> table for signaled backup 
paths or collect named affinities configured with affinity-maps.

• BGP peers

– find_bgp does not build BGP pseudo-nodes among internal ASNs.

– find_bgp does not collect BGP peers under PE-CE VRFs.

• parse_configs 

– Does not accurately detect the bandwidth of some Juniper ‘ge’ interfaces that have a capacity 
of 10 Gbps. 

– Collects POS bundles, but has limitations due to unavailability of the port OperStatus property.

• TE Extended Admin Groups (EAGs), also known as extended affinities, are only supported from 
Juniper and parse_configs.

• There is no support for building port circuits for LAG members that are not within the same IGP 
(inter-AS circuits)

• It is not possible to distinguish between physically connected and unconnected LAG ports that are 
down for LAG port matching.

• snmp_find_ospf_db cannot be used when routers have a large number of links that cannot fit into a 
single PDU.

• find_bgpls does not support multi-area OSPF or multi-level IS-IS, non-TE-enabled interfaces, and 
pseudo-nodes. The workaround is to use SNMP- or login-based discovery.
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Known Limitations
• get_inventory does not collect Juniper multi-chassis router hardware inventory.

• Segment routing 

– SR protected adjacency SIDs are not supported.

– Concurrent RSVP-TE and SR-TE paths are not supported on the same LSP.

Deployer

Cisco Open SDN Controller (OSC)

During detailed PCEP tunnel creation or when modifying PCEP tunnels, affinity values are 
misinterpreted if multiple affinities are specified. This limits you to specifying one affinity for 
IncludeAffinity, IncludeAnyAffinity, and ExcludeAffinity, and each of these values must be a number 
within [0,31].

NSO Controller

• LSP affinities are deployed, while interfaces affinities require separate provisioning.

• LSPs that exist in the network by another controller cannot be updated. 

• Deployment of each RSVP-TE named-path or SR-TE segment-list is limited to a single LSP.

• Cisco IOS XR: WAE client specifies the XR LSP signaled-name, while NSO service and device use 
tunnel-id. The workaround is to deploy all Cisco IOS XR LSPs using the tunnel-id and to make sure 
that existing LSPs are not redeployed.

• NEDs (NSO console) 

– For Cisco IOS XR, there is no option to give the IP address of the LSP directly; you can only 
specify a loopback address. There is no option to give tunnel affinity values directly; you can 
only specify an affinity-map name.

– For Junos, there is no inter-domain keyword, which is used only when an inter-area LSP is 
created.

WAE System

Installation and Startup

• The WAE NI server and the WAE Core server cannot reside on the same device or on the same VM. 
Note that the Cisco WAE Server Installation Guide assumes that they are on the same device. If 
needed, contact your support representative for further installation details.

• If the OS is using an old CA certificate to verify the integrity of the EPEL repository, you might see 
this error from the OS vendor:

Error: Cannot retrieve metalink for repository: epel. Please verify its path and try 
again.

– One workaround is to perform an offline installation. For instructions, refer to the “Offline 
Installation” chapter in the Cisco WAE Server Installation Guide.

– Another workaround is to change https to http.
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Known Limitations
Note This is not a secure solution. For information on how to resolve OS security issues, contact your 
OS vendor.

1. In the /etc/yum.repos.d/epel.repo file, change the first instance of https to http.

sudo vim /etc/yum.repos.d/epel.repo

Change https to http in the following line:

mirrorlist=[https://mirrors.fedoraproject.org/metalink-repo=epel-6&arch=$basearch]

2. Execute yum to clean up makecache.

sudo yum clean all && yum makecache

3. Rerun the installer. For detailed installation instructions, see the Cisco WAE Server Installation 
Guide. 

sudo bash wae-k9-<version>.bin

• The $CARIDEN_HOME directory is not automatically added to $PATH (only $CARIDEN_HOME/bin is). If 
not in $CARIDEN_HOME/bin, to start the WAE Design GUI from the command line, you must specify 
its full path.

/opt/cariden/software/mate/current/mate

Web Server

The embedded_web_server tool is deprecated. The recommendation is to use the wae-web-server 
service, which is constantly monitored to be brought up automatically.

By default, this web service starts upon installation completion. Therefore, if you stop the web server 
using the embedded_web_server tool (embedded_web_server -action stop), the web server does not 
stop. The workaround is the following:

service wae-svcs-mon stop
embedded_web_server -action stop

WAE Statistics UI

The WAE Statistics page does not open in all browsers. The workaround is the following:

1. Click the WAE Statistics link. The URL format is https://<server_IP>:8443. Example:

https://192.0.2.14:8443 

2. Copy the URL of this page to another browser window.

3. In the new browser, change the URL port from 8443 to 8843. Example:

https://192.0.2.14::8843 Ex

4. Follow the browser messages to accept the connection and add it as an exception.
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Accessibility Features
Web User Management

Both the System UI and the WAE Design Archive UI have local user management capabilities. If both 
are used to configure users, WAE uses the most recently updated information. The recommendation is 
to use only the System UI to manage local users.

License Check Failures on Newer Linux Distributions

Some newer Linux distributions have started using a new way (via biosdevname) of naming hardware 
devices, including the network interfaces. This causes some software that depends on the traditional 
naming (for example, eth0, eth1) to fail on license checks, including MATE.

The workaround is to append biosdevname=0 to the kernel line of the grub configuration file and reboot. 
(Syntax varies among distributions.)

After reboot, you should be able to use ifconfig to verify that the NICs are named eth0 (or eth1, ...) 
instead of the biosdevname names (such as p34p1).

Java Memory

Certain tools (such as parse_configs) may require more memory to start than what is available. The 
symptom is an error message similar to the following:

Error occurred during initialization of VM.
Could not reserve enough space for object heap.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

The workaround is to set the maximum memory to a low enough value in the CARIDEN_JAVA_OPTIONS 
variable before calling the tool. An example setting is as follows:

set CARIDEN_JAVA_OPTIONS=-Xmx1000m

Accessibility Features
For a list of accessibility features in Cisco WAE, visit Cisco's Voluntary Product Accessibility Template 
(VPAT) website, or contact accessibility@cisco.com.

All product documents are accessible except for images, graphics and some charts. If you would like to 
receive the product documentation in audio format, braille, or large print, contact 
accessibility@cisco.com.

Related Documentation 
For related documentation, see the Cisco WAE 6.4 Documentation Roadmap.
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