Introduction
Beginning with Cisco NX-OS Release 6.2(2), you can map a VLAN on the local site to a VLAN with a different VLAN ID on the remote site. When you map two VLANs with different VLAN IDs across sites, they get mapped to a common VLAN called the transport VLAN. For example, when you map VLAN 1 on Site A to VLAN 2 on Site B, both VLANs are mapped to a transport VLAN. All traffic originating from VLAN 1 on Site A is translated as going from the transport VLAN. All traffic arriving at Site B from the transport VLAN is translated to VLAN 2.
This document provides a configuratione example for accomplishing Vlan mapping across OTV.
There are 2 methods to configure vlan translation across OTV:
1. Vlan translation on trunk port (OTV Internal Interface)
2. Vlan mapping configured on Overlay (currently not supported on F3 modules).
This document will discuss the 2nd method - Vlan mapping configured on Overlay.
The first method is covered in a separate document.
Prerequisites
Requirements
Cisco recommends that you have knowledge of these topics:
- OTV
- Virtual port channel (vPC)
Components Used
- Cisco Nexus 7000 Series Switches with Supervisor 2 Module.
- M2 and F2 linecards. This config should work with other linecards as well except F3. F3 modules currently do not support Vlan mapping on Overlay interface.
- SW version: 6.2.18
- Feature (Vlan translation) support started: 6.2.2
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Configure
Network Diagram
Configurations
SITE-1:
AGG VDC:
interface Vlan100
no shutdown
no ip redirects
ip address 10.1.1.1/24
interface port-channel10
switchport
switchport mode trunk
mtu 9216
OTV VDC
interface Overlay1
otv join-interface Ethernetx/y
otv control-group xx.xxx.xx.xx
otv data-group xx.xxx.xxx.xx
otv extend-vlan 100 <+++++++++++++ Extend Local Vlan 100
otv vlan mapping 100 to 200 <+++++++++++++ Local Vlan 100 mapped to remote Vlan 200
no shutdown
SITE-2:
AGG VDC:
interface Vlan200
no shutdown
no ip redirects
ip address 10.1.1.3/24
interface port-channel10
switchport
switchport mode trunk
mtu 9216
OTV VDC:
interface Overlay1
otv join-interface Ethernetx/y
otv control-group xx.xxx.xx.xx
otv data-group xx.xxx.xxx.xx
otv extend-vlan 200 <+++++++++++++ Extend Local Vlan 200. NOTE: No need to map Vlans at this site.
no shutdown
Verify
SITE-1:
OTV VDC:
+++++++
N7K-Site1-OTV# sh otv vlan-mapping overlay 1
Original VLAN -> Translated VLAN
--------------------------------
100 -> 200 <++++++ Vlan 100 mapped to 200 when traffic is sent/received on Overlay
N7K-Site1-OTV# sh otv route | inc 8478.ac0c.7b45
100 8478.ac0c.7b45 1 00:05:14 site port-channel10 <++++++ Local Vlan 100 SVI MAC learned from internal interface
N7K-Site1-OTV# sh otv route | inc 8478.ac0c.7b46
100 8478.ac0c.7b46 42 00:05:23 overlay N7K-Site2-OTV <+++++ Remote Vlan 200 SVI MAC learned in Vlan 100 on OTV VDC
SITE-2:
OTV VDC:
++++++++
N7K-Site2-OTV# sh otv vlan-mapping overlay 1
Original VLAN -> Translated VLAN
-------------------------------- <++++++ No need for translation at this site. Traffic is received/sent in Vlan 200
N7K-Site2-OTV# sh otv route | inc 8478.ac0c.7b45
200 8478.ac0c.7b45 42 00:02:51 overlay N7K-Site1-OTV <++++ Remote Vlan 100 SVI MAC learned in Vlan 200 in OTV VDC
N7K-Site2-OTV# sh otv route | inc 8478.ac0c.7b46
200 8478.ac0c.7b46 1 00:10:45 site port-channel10 <+++++ Local Vlan 200 SVI MAC learned from internal interface
Reference:
OTV Configuration guide