The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
This document describes how to to configure, verify, and troubleshoot Quality of Service (QoS) on Cisco Catalyst 6800ia host ports. QoS is supported on 6800ia host ports in Cisco IOS® Software Release 152.1.SY and later on a Catalyst 6800 parent Virtual Switching System (VSS).
There are no specific requirements for this document.
The information in this document is based on these software and hardware versions:
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Configuration mode on a Catalyst 6800ia is disabled and all QoS configurations for 6800ia host ports must be done from the parent. QoS for 6800ia host port is configured with a policy-map. When applied to the interfaces, this policy-map pushes the relevant configuration internally to the 6800ia and then programs the hardware queues.
6800ia host ports have 1p3q3t architecture in transmit (TX) direction. All configuration examples in this document apply only to TX queues on a 6800ia.
When there is no explicit QoS configuration present on the 6800ia interfaces in default state, the 6800ia host interface can look similar to this example output:
6880-VSS#show run int gi101/1/0/1
interface GigabitEthernet101/1/0/1
switchport
switchport trunk allowed vlan 500
switchport mode access
switchport access vlan 500
load-interval 30
end
6880-VSS#show queueing interface gi101/1/0/1
Interface GigabitEthernet101/1/0/1 queueing strategy: Weighted Round-Robin
Port QoS is disabled globally
Queueing on Gi101/1/0/1: Tx Enabled Rx Disabled
Trust boundary disabled
Trust state: trust DSCP
Trust state in queueing: trust DSCP
Default COS is 0
Queueing Mode In Tx direction: mode-dscp
Transmit queues [type = 1p3q3t]:
Queue Id Scheduling Num of thresholds
-----------------------------------------
1 Priority 3
2 WRR 3
3 WRR 3
4 WRR 3
WRR bandwidth ratios: 100[queue 2] 100[queue 3] 100[queue 4] 0[queue 5]
queue-limit ratios: 15[Pri Queue] 25[queue 2] 40[queue 3] 20[queue 4]
queue thresh dscp-map
---------------------------------------
1 1 32 33 40 41 42 43 44 45 46 47
1 2
1 3
2 1 16 17 18 19 20 21 22 23 26 27 28 29 30 31 34 35 36 37 38 39
2 2 24
2 3 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
3 1 25
3 2
3 3 0 1 2 3 4 5 6 7
4 1 8 9 11 13 15
4 2 10 12 14
4 3
This example shows how you can configure bandwidths for 6800ia TX queues:
class-map type lan-queuing match-any ltest
match dscp 32
class-map type lan-queuing match-any ltest1
match dscp 24
class-map type lan-queuing match-any ltest2
match dscp default
policy-map type lan-queuing ltest
class type lan-queuing ltest
priority
class type lan-queuing ltest1
bandwidth remaining percent 30
class type lan-queuing ltest2
bandwidth remaining percent 20
class class-default
Note: When you apply a lan-queueing policy-map to one port on a 6800ia stack, it propagates the changes to all ports in the stack.
6880-VSS#conf t
6880-VSS(config)#int gi101/1/0/1
6880-VSS(config-if)#service-policy type lan-queuing output ltest
Propagating [attach] lan queueing policy "ltest" to Gi101/1/0/1 Gi101/1/0/2 Gi101/1/0/3
Gi101/1/0/4 Gi101/1/0/5 Gi101/1/0/6 Gi101/1/0/7 Gi101/1/0/8 Gi101/1/0/9 Gi101/1/0/10
Gi101/1/0/12 Gi101/1/0/13 Gi101/1/0/14 Gi101/1/0/15 Gi101/1/0/16 Gi101/1/0/17
Gi101/1/0/18 Gi101/1/0/19 Gi101/1/0/20 Gi101/1/0/21 Gi101/1/0/22 Gi101/1/0/23
Gi101/1/0/24 Gi101/1/0/25 Gi101/1/0/26 Gi101/1/0/27 Gi101/1/0/28 Gi101/1/0/29
Gi101/1/0/30 Gi101/1/0/31 Gi101/1/0/32 Gi101/1/0/33 Gi101/1/0/34 Gi101/1/0/35
Gi101/1/0/36 Gi101/1/0/37 Gi101/1/0/38 Gi101/1/0/39 Gi101/1/0/40 Gi101/1/0/41
Gi101/1/0/42 Gi101/1/0/43 Gi101/1/0/44 Gi101/1/0/45 Gi101/1/0/46 Gi101/1/0/47 Gi101/1/0/48
Propagating [attach] lan queueing policy "ltest" to Gi101/2/0/1 Gi101/2/0/2
Gi101/2/0/3 Gi101/2/0/4 Gi101/2/0/5 Gi101/2/0/6 Gi101/2/0/7 Gi101/2/0/8
Gi101/2/0/9 Gi101/2/0/10 Gi101/2/0/11 Gi101/2/0/12 Gi101/2/0/13 Gi101/2/0/14
Gi101/2/0/15 Gi101/2/0/16 Gi101/2/0/17 Gi101/2/0/18 Gi101/2/0/19 Gi101/2/0/20
Gi101/2/0/21 Gi101/2/0/22 Gi101/2/0/23 Gi101/2/0/24 Gi101/2/0/25 Gi101/2/0/26
Gi101/2/0/27 Gi101/2/0/28 Gi101/2/0/29 Gi101/2/0/30 Gi101/2/0/31 Gi101/2/0/32
Gi101/2/0/33 Gi101/2/0/34 Gi101/2/0/35 Gi101/2/0/36 Gi101/2/0/37 Gi101/2/0/38
Gi101/2/0/39 Gi101/2/0/40 Gi101/2/0/41 Gi101/2/0/42 Gi101/2/0/43 Gi101/2/0/44
Gi101/2/0/45 Gi101/2/0/46 Gi101/2/0/47 Gi101/2/0/48
Propagating [attach] lan queueing policy "ltest" to Gi101/3/0/1 Gi101/3/0/2
Gi101/3/0/3 Gi101/3/0/4 Gi101/3/0/5 Gi101/3/0/6 Gi101/3/0/7 Gi101/3/0/8
Gi101/3/0/9 Gi101/3/0/10 Gi101/3/0/11 Gi101/3/0/12 Gi101/3/0/13 Gi101/3/0/14
Gi101/3/0/15 Gi101/3/0/16 Gi101/3/0/17 Gi101/3/0/18 Gi101/3/0/19 Gi101/3/0/20
Gi101/3/0/21 Gi101/3/0/22 Gi101/3/0/23 Gi101/3/0/24 Gi101/3/0/25 Gi101/3/0/26
Gi101/3/0/27 Gi101/3/0/28 Gi101/3/0/29 Gi101/3/0/30 Gi101/3/0/31 Gi101/3/0/32
Gi101/3/0/33 Gi101/3/0/34 Gi101/3/0/35 Gi101/3/0/36 Gi101/3/0/37 Gi101/3/0/38
Gi101/3/0/39 Gi101/3/0/40 Gi101/3/0/41 Gi101/3/0/42 Gi101/3/0/43 Gi101/3/0/44
Gi101/3/0/45 Gi101/3/0/46 Gi101/3/0/47 Gi101/3/0/48
Propagating [attach] lan queueing policy "ltest" to Gi101/4/0/1 Gi101/4/0/2
Gi101/4/0/3 Gi101/4/0/4 Gi101/4/0/5 Gi101/4/0/6 Gi101/4/0/7 Gi101/4/0/8
Gi101/4/0/9 Gi101/4/0/10 Gi101/4/0/11 Gi101/4/0/12 Gi101/4/0/13 Gi101/4/0/14
Gi101/4/0/15 Gi101/4/0/16 Gi101/4/0/17 Gi101/4/0/18 Gi101/4/0/19 Gi101/4/0/20
Gi101/4/0/21 Gi101/4/0/22 Gi101/4/0/23 Gi101/4/0/24 Gi101/4/0/25 Gi101/4/0/26
Gi101/4/0/27 Gi101/4/0/28 Gi101/4/0/29 Gi101/4/0/30 Gi101/4/0/31 Gi101/4/0/32
Gi101/4/0/33 Gi101/4/0/34 Gi101/4/0/35 Gi101/4/0/36 Gi101/4/0/37 Gi101/4/0/38
Gi101/4/0/39 Gi101/4/0/40 Gi101/4/0/41 Gi101/4/0/42 Gi101/4/0/43 Gi101/4/0/44
Gi101/4/0/45 Gi101/4/0/46 Gi101/4/0/47 Gi101/4/0/48
6880-VSS(config-if)#
6880-VSS(config-if)#end
6880-VSS#show run int gi101/1/0/1
interface GigabitEthernet101/1/0/1
switchport
switchport trunk allowed vlan 500
switchport mode access
switchport access vlan 500
load-interval 30
service-policy type lan-queuing output ltest
end
6880-VSS#show queueing int gi101/1/0/1
Interface GigabitEthernet101/1/0/1 queueing strategy: Weighted Round-Robin
Port QoS is disabled globally
Queueing on Gi101/1/0/1: Tx Enabled Rx Disabled
Trust boundary disabled
Trust state: trust DSCP
Trust state in queueing: trust DSCP
Default COS is 0
Class-map to Queue in Tx direction
Class-map Queue Id
----------------------------
ltest 1
ltest1 4
ltest2 3
class-default 2
Queueing Mode In Tx direction: mode-dscp
Transmit queues [type = 1p3q3t]:
Queue Id Scheduling Num of thresholds
-----------------------------------------
1 Priority 3
2 WRR 3
3 WRR 3
4 WRR 3
WRR bandwidth ratios: 50[queue 2] 20[queue 3] 30[queue 4]
queue-limit ratios: 15[Pri Queue] 100[queue 2] 100[queue 3] 100[queue 4]
queue thresh dscp-map
---------------------------------------
1 1 32
1 2
1 3
2 1 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
23 25 26 27 28 29 30 31 33 34 35 36 37 38 39 40 41 42 43
44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
2 2
2 3
3 1 0
3 2
3 3
4 1 24
4 2
4 3
Note: If you do not specify buffer weight for a certain class, by default it takes 100%.
Queue 1: 15 / [15+100+100+100] = 4
Queue 2: 100 / [15+100+100+100] ~ 31
Weights are also derived for other queues.
6880-VSS#remote command fex 101 show mls qos int gi1/0/1 buffer
GigabitEthernet1/0/1
The port is mapped to qset : 1
The allocations between the queues are : 4 31 31 34
6880-VSS#remote command fex 101 show mls qos int gi1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : enabled
Shaped queue weights (absolute) : 0 0 0 0
Shared queue weights : 0 127 51 76
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1
6880-VSS#remote command fex 101 show mls qos int gi1/0/1 statistic
GigabitEthernet1/0/1 (All statistics are in packets)
dscp: incoming
-------------------------------
0 - 4 : 0 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 13 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
dscp: outgoing
-------------------------------
0 - 4 : 0 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 9118500
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 516236 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 20 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
cos: incoming
-------------------------------
0 - 4 : 106 0 0 0 0
5 - 7 : 0 0 0
cos: outgoing
-------------------------------
0 - 4 : 41 0 0 9118505 516236
5 - 7 : 0 0 0
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 516255 35 5
queue 1: 12 0 0
queue 2: 0 0 0
queue 3: 9118520 0 0
output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0
queue 2: 0 0 0
queue 3: 49823 0 0
Policer: Inprofile: 0 OutofProfile: 0
This example shows how you can configure bandwidths and buffers for 6800ia TX queues:
Note: If you do not specify buffer weight for a certain class, by default it takes 100%.
policy-map type lan-queuing ltest
class type lan-queuing ltest
priority
queue-buffers ratio 15
class type lan-queuing ltest1
bandwidth remaining percent 30
queue-buffers ratio 30
class type lan-queuing ltest2
bandwidth remaining percent 20
queue-buffers ratio 40
class class-default
queue-buffer ratio 15
6880-VSS#sh queueing int gi101/1/0/1
Interface GigabitEthernet101/1/0/1 queueing strategy: Weighted Round-Robin
Port QoS is disabled globally
Queueing on Gi101/1/0/1: Tx Enabled Rx Disabled
Trust boundary disabled
Trust state: trust DSCP
Trust state in queueing: trust DSCP
Default COS is 0
Class-map to Queue in Tx direction
Class-map Queue Id
----------------------------
ltest 1
ltest1 4
ltest2 3
class-default 2
Queueing Mode In Tx direction: mode-dscp
Transmit queues [type = 1p3q3t]:
Queue Id Scheduling Num of thresholds
-----------------------------------------
1 Priority 3
2 WRR 3
3 WRR 3
4 WRR 3
WRR bandwidth ratios: 50[queue 2] 20[queue 3] 30[queue 4]
queue-limit ratios: 15[Pri Queue] 15[queue 2] 40[queue 3] 30[queue 4]
queue thresh dscp-map
---------------------------------------
1 1 32
1 2
1 3
2 1 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
22 23 25 26 27 28 29 30 31 33 34 35 36 37 38 39 40 41
42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
2 2
2 3
3 1 0
3 2
3 3
4 1 24
4 2
4 3
6880-VSS#remote command fex 101 sh mls qos int gi1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : enabled
Shaped queue weights (absolute) : 0 0 0 0
Shared queue weights : 0 127 51 76
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1
6880-VSS#remote command fex 101 sh mls qos int gi1/0/1 buffers
GigabitEthernet1/0/1
The port is mapped to qset : 1
The allocations between the queues are : 15 15 40 30
6880-VSS#remote command fex 101 sh mls qos int gi1/0/1 statistic
GigabitEthernet1/0/1 (All statistics are in packets)
dscp: incoming
-------------------------------
0 - 4 : 0 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 491 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
dscp: outgoing
-------------------------------
0 - 4 : 0 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 57864687
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 29364400 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 775 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
cos: incoming
-------------------------------
0 - 4 : 5323 0 0 0 0
5 - 7 : 0 0 0
cos: outgoing
-------------------------------
0 - 4 : 1718 0 0 57864691 29364400
5 - 7 : 0 0 0
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 29365402 1883 5
queue 1: 793 98 0
queue 2: 0 0 0
queue 3: 530554174 0 0
output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 10 0
queue 1: 1 24093 0
queue 2: 0 0 0
queue 3: 2309351 0 0
Policer: Inprofile: 0 OutofProfile: 0
There is currently no verification procedure available for this configuration.
This section provides information you can use to troubleshoot your configuration.
The Output Interpreter Tool (registered customers only) supports certain show commands. Use the Output Interpreter Tool in order to view an analysis of show command output.
Note: Refer to Important Information on Debug Commands before you use debug commands.
6880-VSS#attach fex 101
Attach FEX:101 ip:192.168.1.101
Trying 192.168.1.101 ... Open
????????FEX-101>en
Password: cisco
FEX-101#
FEX-101#debug platform qos-manager all
QM verbose debugging is on
QM cops debugging is on
QM events debugging is on
QM Statistics debugging is on
FEX-101#exit
[Connection to 192.168.1.101 closed by foreign host]
6880-VSS#conf t
6880-VSS(config)#int gi101/1/0/1
6880-VSS(config-if)# service-policy type lan-queuing output ltest
Propagating [attach] lan queueing policy "ltest" to Gi101/1/0/1
Gi101/1/0/2 Gi101/1/0/3 Gi101/1/0/4 Gi101/1/0/5 Gi101/1/0/6 Gi101/1/0/7 Gi101/1/0/8
Gi101/1/0/9 Gi101/1/0/10 Gi101/1/0/12 Gi101/1/0/13 Gi101/1/0/14 Gi101/1/0/15 Gi101/1/0/16
<snip>
6880-VSS(config-if)#end
6880-VSS#remote command fex 101 show log
<snip>
May 20 06:43:18.208: HQM: hulc_fex_qos_priority_handler: hulc_fex_qos_priority_handler:
****Setting Priority Queue (FEX-101)
May 20 06:43:18.208: HQM: hulc_fex_qos_priority_handler: hulc_fex_qos_priority_handler:
subopcode=2 startport=0 endport=0 size=4 (FEX-101)
May 20 06:43:18.208: HQM: hulc_f
_fex_qos_priority_handler:QueueNum=1 PriorityQueue=1 queuetype=2 thresholdsnum=3 (FEX-101)
May 20 06:43:18.212: HQM: hulc_fex_qos_priority_handler: hulc_fex_qos_priority_handler:
idb=GigabitEthernet1/0/1 (FEX-101)
May 20 06:43:18.212: HQM: hulc_fex_qos_priority_handler: hulc_fex_qos_priority_handler:
idb=GigabitEthernet1/0/2 (FEX-101)
May 20 06:43:18.212: HQM: hulc_fex_qos_priority_handler: hulc_fex_qos_priority_handler:
idb=GigabitEthernet1/0/3 (FEX-101)
<snip>
hulc_fex_qos_srr_weight_setting:****Setting weight for queues**** (FEX-101)
May 20 06:43:18.232: HQM: hulc_fex_qos_srr_weight_setting: hulc_fex_qos_srr_weight_setting:
subopcode=2 startport=0 endport=0 size=4 (FEX-101)
May 20 06:43:18.232: HQM: hulc_fex_qos_srr_weight_setting: hulc_fex_qos_srr_weight_setting:
QueueNum=1 RRType=0 WeightRelative=0 WeightAbsolute=0 (FEX-101)
20 06:43:18.232: HQM: hulc_fex_qos_srr_weight_setting: hulc_fex_qos_srr_weight_setting:
ratio is 0 for queue 1 (FEX-101)
May 20 06:43:18.232: HQM: hulc_fex_qos_srr_weight_setting: hulc_fex_qos_srr_weight_setting:
QueueNum=2 RRType=0 WeightRelative=33 WeightAbsolute=0 (FEX-101)
<snip>
20 06:43:19.110: HQM: hulc_fex_qos_buffer_conf: **Setting buffer for output queues** (FEX-101)
May 20 06:43:19.110: HQM: hulc_fex_qos_buffer_conf: hulc_fex_qos_buffer_conf:
subopcode=2 startport=0 endport=0 size=4 (FEX-101)
May 20 06:43:19.110: HQM: hulc_fex_qos_buffer_conf: hulc_fex_qos_buffer_conf:
queuenum=1 size=15 (FEX-101)
May 20 06:43:19.110: HQM: hulc_fex_qos_buffer_conf:
hulc_fex_qos_buffer_conf: queuenum=2 size=25 (FEX-101)
May 20 06:43:19.110: HQM: hulc_fex_qos_buffer_conf:
hulc_fex_qos_buffer_conf: queuenum=3 size=40 (FEX-101)
May 20 06:43:19.110: HQM: hulc_fex_qos_buffer_conf:
hulc_fex_qos_buffer_conf: queuenum=4 size=20 (FEX-101)
May 20 06:43:19.110: HQM: hqm
20 06:43:19.113: HQM: s88g_qd_get_queue_threshold: s88g_qd_get_queue_threshold:
max_limit = 3200, set to 350. (FEX-101)
May 20 06:43:19.113: HQM: s88g_qd_get_queue_threshold: s88g_qd_get_queue_threshold:
max_limit = 3200, set to 350. (FEX-101)
<snip>
hulc_fex_qos_qthresh_map:****Setting dscp to output queue map**** (FEX-101)
May 20 06:43:19.169: HQM: hulc_fex_qos_qthresh_map: hulc_fex_qos_qthresh_map:
subopcode=2 startport=0 endport=0 size=1 (FEX-101)
May 20 06:43:19.169: HQM: hulc_fex_qos_qthresh_map: hulc_fex_qos_qthresh_map: DscpBma
20 06:43:19.169: HQM: hulc_fex_qos_qthresh_map: hulc_fex_qos_qthresh_map
dscp=32 iterator=0 (FEX-101)
May 20 06:43:19.169: HQM: hulc_fex_qos_qthresh_map: hulc_fex_qos_qthresh_map
dscp=33 iterator=1 (FEX-101)
May 20 06:43:19.169: HQM: hulc_fex_qos_qthresh_map: hulc_fex_qos_qthresh_map
dscp=40 iterator=2 (FEX-101)
<snip>
Revision | Publish Date | Comments |
---|---|---|
1.0 |
13-Jul-2015 |
Initial Release |