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This document describes how to configure NetFlow Secure Event Logging (NSEL) on Firepower Threat
Defense (FTD) viaFirepower Management Center (FMC).

Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

* Knowledge of FMC
* Knowledge of FTD
» Knowledge of the FlexConfig Policy

Components Used

The information in this document is based on these software and hardware versions:

e FTD version 6.6.1
« FMCversion 6.6.1

The information in this document was created from the devices in a specific lab environment. All of the
devices used in this document started with a cleared (default) configuration. If your network islive, ensure
that you understand the potential impact of any command.

Background Information

This document describes how to configure NetFlow Secure Event Logging (NSEL) on Firepower Threat
Defense (FTD) viaFirepower Management Center (FMC).

The FlexConfig text objects are associated with variables used in the predefined FlexConfig objects.
Predefined FlexConfig objects and associated text objects are found in FMC to configure NSEL. There are



four predefined FlexConfig objects within the FMC and three predefined text objects. Predefined
FlexConfig objects are read-only and cannot be modified. In order to modify the parameters of NetFlow, the
objects can be copied.

The four predefined objects are listed in the table:

FlexConfig Object Name Description

Netflow Add Destination Creates and configures a NetFlow export destination
Netflow_Set Parameters Sets globla parameters for NetFlow export
Netflow_Delete_Destinations Deletes a NetFlow export destination
Netwflow_Clear_Parameters Restores Netflow export global default settings

The three predefined text objects are listed in the table:

Text Object Name Description

o Define the single NetFlow export destination’s interface, destination IP
netflow_Destination
address and UDP port number for NetFlow.

netwflow_Event_Types Define NetFlow events based on event type

Define values for active refresh-interval, delay flow-create and template
netflow_Parameters )
timeout-rate.

Configure

This section describes how to configure NSEL on FMC through a FlexConfig Policy.

Step 1. Set the parameters of the Text Objects for Netflow.

In order to set the variable parameters, navigate to Objects > FlexConfig > Text Objects. Edit the
netflow_Destination object. Define the multiple variable type and count set to 3. Set the interface name,
destination I P address and port.

In this configuration example, the interface is DMZ, the NetFlow Collector IP addressis 10.20.20.1 and the
UDP port is 2055.



Edit Text Object @

Name:
Description:
Variable Type Count
Multiple 3 =
1 DMZ

2 10.20.20.1
3 2055

% Note: Default values for netflow_Event_Types and netflow_Parameters are used.

Step 2. Configure an Extended Access List Object to match specific traffic.

In order to create an Extended Access List on FMC, navigate to Objects > Object M anagement and on the
left menu, under Access List select Extended.Click Add Extended Access List.

Fill inthe Name field. In this example, the nameisflow_export_acl. Click the Add button. Configure the
Access Control entries to match specific traffic.

In this example traffic from host 10.10.10.1 to any destination and traffic between host 172.16.0.20 and
192.168.1.20 is excluded. Any other traffic isincluded.



Edit Extended Access List Object

Name

[ how, export_aci |

Entries (3)

Sequence Action Source Source Port
1 @Elock 10.10.10.1 Any

2 @Block 172.16.0.20 Any

3 SAllow Any Any

Allow Overrides

Step 3. Configure a FlexConfig Object.

Destination
Any
192.168.1.20

Any

Destination Port

Any
Any

Any

In order to configure the FlexConfig Objects navigate to Objects > FlexConfig > FlexConfig Objectsand

click on Add FlexConfig Object button.

Define the class map that identifies traffic for which NetFlow events need to be exported. In this example,

the name of the object isflow_export_class.

Select the Access List created in Step 2. Click on Insert > Insert Policy Object > Extended ACL Object
and assign aname. Then, click on Add button. In this example, the name of the variableisflow_export_acl.

Click Save.



Insert Extended Access List Object Variable ®

Variable Name:

flow_export_acl

Description:
Available Objects C' Selected Object
Q_ Search D4 flow_export_acl v

flow_export_acl

Add the next configuration linesin the blank field right and include the variable previously
defined ($flow_export_acl.) in the match access-list configuration line.

Notice that a$ symbol begins the variable name. This helps define that a variable comes after it.

<#root>

class-map flow_export_class
match access-Tist

$f | ow_export _acl

Click on Save when finished.



Edit FlexConfig Object @
Name:
flow_export_class

Description:

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.
Insert ~ Deployment: Everytime + | Type: | Append

class-map flow export class
match access-list Sflow export acl|

v Variables
Name Dimension Default Value Property ) Override Description
(Type:Name)
low_export_class SINGLE flow_export_acl EXD_ACL:A...

f\-‘.‘\:;\r l-:: | m

Step 4. Configure the Netflow Destination

In order to configure the Netflow Destination, navigate to Objects > FlexConfig > FlexConfig Objectsand
filter by Netflow. Copy the object Netflow_Add_Destination. The Netflow_Add_Destination_Copy is
created.

Assign the class created in Step 3. You can create a new policy map to apply the flow-export actions to the
defined classes.

In this example, the classisinserted in the current policy (global policy).

<#root>

## destination: interface_nameif destination_ip udp_port
## event-types: any subset of {all, flow-create, flow-denied, flow-teardown, flow-update}
flow-export destination $netflow_Destination.get(0) $netflow_Destination.get(1l) $netflow_Destination.ge
policy-map global_policy
class

fl ow _export_cl ass

#foreach ( $event_type in $netflow_Event_Types )
flow-export event-type $event_type destination $netflow_Destination.get(1l)



#end

Click on Save when finished.
Edit FlexConfig Object (1]

Name:

| Netflow_Add Destination_Copy

Description:

Create and configure a NetFlow
export destination.

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CL| before deployment.
Insert » Deployment: Once v | Type: | Append v

fi# destination: interface nameif destination ip udp port
#4 event-types: any subset of {all, flow-create, flow-denied, flow-teardown, flow-update}
flow-

policy-map global pOI_J_cy -----------------------------------
class flow export class
#foreach (_$event__type in $netflow Event Types )
flow-export event-type $event type destination $netflow Destination.get (1)

#end
v Variables
Name Dimension Default Value r;\?:::ime] Override Description
netflow_Event_Types MULTIPLE [all] FREEFORM: false This variable provides the glo...
netflow_Destination MULTIPLE [DMZ, 10.20.20.... FREEFORM:... false This variable defines a single ...

Step 5. Assign the FlexConfig Policy to the FTD

Navigate to Devices > FlexConfig and create a new policy (unlessthere is already one created for another
purpose and assigned to the same FTD). In this example, the FlexConfig is already created. Edit the
FlexConfig Policy and Select the FlexConfig objects created in previous steps.

In this example, the default Netflow export parameters are used, therefore, the Netflow _Set Parametersis
selected. Save the changed and deploy.



FI EXCDI“Iﬁg policy You have unsaved changes [ Preview Config 1 m

Enter Description
Palicy Assignments (1)

" Selected Prepend FlexConfigs
Available FlexConfig C FlexCanfig Object

netflow b4

L] Mame Description

~ User Defined
=2 Netfhow Add Destinal
7 Metfiow_Delete_Destination_Copy
of Matflow_export_Copy
"8 Netflow_Set_Parameters_Copy
* Systam Dafined
"B Metfow_Add_Destination o7 Selected Append FlexConfigs
«f Netfiow_Clear_Parameters " Marme Description
o5 Netflow_Delete_Destination

[ oo sormrens [ o

2 Netflow_Add_Destination_Copy Create and configure a MetFlow export destination. Ow

3 Metflow_Set_Parameters Set global parameters for NetFlow export, %

How To

N Note: In order to match all traffic without the need to match specific traffic, you can skip from Steps 2
through 4 and use the predefined NetFlow Objects.

FlexConfigPolicy You have unsaved changes | F Config

Enter Description
Policy Assignmants (1)

"% Selected Prepend FlexConfigs
Available FlexConfig C FlexCenfig Object

netilow b4

¥ Mame Deseription

~ User Defined
" Metflow_aAdd_Destination_Copy
o7 Metflow_Delete_Destination_Copy
o Metflow_export_Copy
"8 Metfiow_Set_Parameters_Copy
 System Defined

=7 Metflow_Clear_Parameters

o Name Description
= Metfiow_Delete_Destination
. 1 Natflow_Set_Paramatars Set global parameters for NetFlow export. aw
B Netflow_Set
2 Metflow _Add_Destination Create and configure a NetFlow expor destination, Q, i
Fre—

N Note: To add asecond NSEL collector to which NetFlow packets are sent. In Step 1, add 4 variables
to add the second Netflow collector | P address.



Edit Text Object ')

MName:

Description:

Variable Type Count
Multiple v 4 5

1 DMZ
10.20.20.1
2055

E- I 5 R

10.20.20.2

Multiple-Netfl ow-Text-Object

In Step 4., add the configuration line: flow-
export destination $netflow_Destination.get(0) $netflow_Destination.get(1) $netflow_Destination.get(2)

Edit the variable $netflow_Destination.get for the correspondence variable. In this example the variable
valueis 3. For example:

flow-export destination $netflow_Destination.get(0) $netflow_Destination.get(1l) $netflow_Destination.ge
flow-export destination $netflow_Destination.get(0) $netflow_Destination.get(3) $netflow_Destination.ge

Also, add the second variable $netflow_Destination.get in the configuration line: flow-export event-
type $event_type destination $netflow_Destination.get(1). For example:

flow-export event-type $event_type destination $netflow_Destination.get(1l) $netflow_Destination.get(3)

Validate this configuration as seen in the image below:



Edit FlexConfig Object [ 2]

Name:
Netflow_Add_Destination_Copy |

Description:

Create and configure a NetFlow
export destination.

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

‘ Insert » ‘ Deployment: | Once v | Type: | Append v

## destination: interface nameif destination_ip udp_port
## event-types: any subset of {all, flow-create, flow-denied, flow-teardown, flow-update}

flow-

policy-map global policy
class flow export class
#foreach { Sevent_type in $netflow_Event_ Types )
flow=-export event=-
type jevent type destination $netflow Destination.get(l)$netflow Destination.get(3)

fend
¥ Variables
Name Dimension Default Value ?;S::E‘;me: Override Description
netflow_Event_Types MULTIPLE [all] FREEFORM:... false This variable provides the glo...
netflow_Destination MULTIPLE [DMZ, 10.20.20.... FREEFORM:... false This variable defines a single ...

Cancel

Verify

The NetFlow configuration can be verified within the FlexConfig Policy. In order to preview the
configuration click on Preview Config. Select the FTD and verify the configuration.



Preview FlexConfig @

Select Device:
FTD-b

exit
INTERFACE_END

H#HitHFlex-config Appended CLI #H#
class-map flow_export_class
match access-list flow_export_acl

flow-export destination DMZ 10.20.20.1 2055
policy-map global_policy
class flow_export_class
flow-export event-type all destination 10.20.20.1

flow-export active refresh-interval 1
no flow-export delay flow-create 1
flow-export template timeout-rate 30

Close

Accessthe FTD trough Secure Shell (SSH) and use the command system support diagnostic-cli and run
these commands:

> system support diagnostic-cli
Attaching to Diagnostic CLI ... Press 'Ctrl+a then d' to detach.
Type help or '?' for a 1list of available commands.

firepower# show access-1list flow_export_acl

access-1ist flow_export_acl; 3 elements; name hash: Oxe30fladf

access-1list flow_export_acl Tine 1 extended deny object-group ProxySG_ExtendedACL_34359742097 object 10
access-1list flow_export_acl Tine extended deny ip host 10.10.10.1 any (hitcnt=0) 0x3d4f23a4
access-1list flow_export_acl Tine extended deny object-group ProxySG_ExtendedACL_34359742101 object 17
access-1list flow_export_acl Tine extended deny ip host 172.16.0.20 host 192.168.1.20 Chitcnt=0) 0x134
access-1list flow_export_acl Tine extended permit object-group ProxySG_ExtendedACL_30064776111 any any
access-1ist flow_export_acl Tine 3 extended permit ip any any (hitcnt=0) 0x759f5ecf

w W NN

firepower# sh running-config class-map flow_export_class
class-map flow_export_class
match access-list flow_export_acl

firepower# show running-config policy-map



|

policy-map type inspect dns preset_dns_map
parameters

message-length maximum client auto
message-length maximum 512

no tcp-inspection

policy-map type inspect ip-options UM_STATIC_IP_OPTIONS_MAP
parameters

eool action allow

nop action allow

router-alert action allow

policy-map global_policy

class 1inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

inspect icmp

inspect icmp error

inspect ip-options UM_STATIC_IP_OPTIONS_MAP
inspect snmp

class flow_export_class

flow-export event-type all destination 10.20.20.1
class class-default

set connection advanced-options UM_STATIC_TCP_MAP

firepower# show running-config | include flow

access-1list flow_export_acl extended deny object-group ProxySG_ExtendedACL_34359742097 object 10.10.10.
access-1list flow_export_acl extended deny object-group ProxySG_ExtendedACL_34359742101 object 172.16.0.
access-1list flow_export_acl extended permit object-group ProxySG_ExtendedACL_30064776111 any any
flow-export destination DMZ 10.20.20.1 2055

class-map flow_export_class

match access-1list flow_export_acl

class flow_export_class

flow-export event-type all destination 10.20.20.1

Related I nfor mation
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