Introduction
This document describes how to understand and troubleshoot the Bridge Virtual Interface (BVI) and the Bridge Domain Interface (BDI).
Prerequisites
Requirements
There are no requirements for this article.
Components Used
The information in this document is based on ISR router (for BVI) and ASR1K (for BDI).
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
Background Information
BVI and BDI routed interfaces represent a set of interfaces that are bridged. For example, you want to bridge two interfaces on the router, and you want them to be in the same Layer-2 broadcast domain. The BVI/BDI interface would act as the routed interface for those two bridged physical interfaces. All the packet traffic must pass through the BVI/BDI interfaces.
BVI Connection for 2 PCs to Routers
BVI on Cisco IOS®
A router does not configure two or more Layer-3 interfaces in the same broadcast domain (that is, two or more interfaces in the same subnet). Use the BVI interface to connect two PCs to the router as part of the same subnet and still have Internet access from both the PCs.
You can use BVI to do this.
Term
|
Definition
|
Bridge-group
|
Groups the physical interfaces into one logical group.
|
Interface BVI
|
A Layer-3 that can be routed, logical interface.
|
ISR 3
|
ISR 1
|
ISR 2
|
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
interface GigabitEthernet0/0/1
bridge-group 1
!
interface GigabitEthernet0/0/2
bridge-group 1
!
interface BVI 1
ip address 10.10.10.10
255.255.255.0
|
int fa0/0
ip address 10.10.10.1
255.255.255.0
|
int fa0/0
ip address 10.10.10.2
255.255.255.0
|
BDI on Cisco IOS XE
BDI is similar to BVI except that it runs on Cisco IOS XE.
Term
|
Definition
|
Bridge domain
|
Represents a Layer 2 broadcast domain.
|
Bridge domain interface
|
Is a logical interface that allows bidirectional flow of traffic between a Layer-2 bridged network and a Layer-3 routed network.
|
Ethernet Virtual Circuit (EVC)
|
Is an end-to-end representation of a single instance of a Layer-2 service offered by a provider to a customer. In the Cisco EVC Framework, the bridge domains are made up of one or more Layer-2 interfaces known as Service Instances. A Service Instance is the instantiation of an EVC on a given port on a given router. Service instance is associated with a bridge domain based on the configuration.
|
ASR Connection on Two Switches
BDI on Cisco IOS XE Platform Examples
A) Fa0/1 on both the switches are Layer-3 interfaces and are in the same broadcast domain.
BDI configuration on ASR is not required if the motive is to just establish connectivity between the two switches.
ASR 1K
|
SW1
|
SW2
|
interface GigabitEthernet1/2/3
no ip address
negotiation auto
cdp enable
service instance 100 ethernet
encapsulation untagged
bridge-domain 100
!
interface GigabitEthernet1/2/4
no ip address
negotiation auto
cdp enable
service instance 100 ethernet
encapsulation untagged
bridge-domain 100
|
interface FastEthernet0/1
no switchport
ip address 10.1.1.1 255.255.255.0
|
interface FastEthernet0/1
no switchport
ip address 10.1.1.3 255.255.255.0
|
Next Steps
1. Ping SW2 from SW1:
BGL.Q.16-3500-1#ping 10.1.1.3
2. Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
Note: If you want to route outside of the ASR, BDI interface configuration is required:
interface BDI100
ip address 10.1.1.1 255.255.255.0
B) Bridge multiple VLANs between the two switches.
Configure separate Ethernet virtual circuits (EVC) under the physical interface for each of the VLANs. Bridge-domain is not supported under the sub-interface.
There are two VLANs; VLAN 100 and VLAN 200 to be bridged:
ASR 1K
|
SW1
|
SW2
|
interface GigabitEthernet1/2/3
no ip address
negotiation auto
cdp enable
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100
!
service instance 200 ethernet
encapsulation dot1q 200
rewrite ingress tag pop 1 symmetric
bridge-domain 200
Exact same config under Gig1/2/4
interface GigabitEthernet1/2/4
no ip address
negotiation auto
cdp enable
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100
!
service instance 200 ethernet
encapsulation dot1q 200
rewrite ingress tag pop 1 symmetric
bridge-domain 200
|
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan100
ip address 10.1.1.1 255.255.255.0
interface Vlan200
ip address 10.1.1.2 255.255.255.0
|
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan100
ip address 10.1.1.3 255.255.255.0
interface Vlan200
ip address 10.1.1.2 255.255.255.0
|
Next Steps
1. Ping int vlan100 and vlan200 on SW2 from SW1:
BGL.Q.16-3500-1#ping 10.1.1.3
2. Type escape sequence to abort:
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
BGL.Q.16-3500-1#ping 10.1.1.3
3. Type escape sequence to abort:
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
EPC
monitor capture CAP interface gig1/2/3 efp 100 both match ipv4 any any
Packet Tracer
debug platform condition interface gig1/2/3 efp-id 100 ipv4 both
EFP ID = 100 (service instance number)
Related Information