This document describes how to configure each Multicast VPN (mVPN) profile within the Cisco IOS® for IPv6 only.
Before you proceed with the configuration that is described in this document, verify whether there is support for an mVPN profile on the specific platform that runs Cisco IOS.
The information in this document is based on all versions of Cisco IOS.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
An mVPN profile is configured for the global context or per Virtual Routing/Forwarding (VRF). Only the newer way to define a VRF (VRF definition) can be used in order to enable IPv6 for mVPN profiles. Here is an example:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
!
address-family ipv6
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
Multicast-routing for IPv6 must be enabled for the profiles in the global context. Additionally, the Protocol Independent Multicast Version 6 (PIMv6) must be enabled on the global loopback interface. This is true if the ipv6 multicast-routing command is enabled, and if the loopback interface has an IPv6 address or the ipv6 enable command is configured on the loopback interface.
ipv6 multicast-routing
Multicast routing for IPv6 must be enabled on the VRF for the profiles in the VRF context.
ipv6 multicast-routing vrf one
It is a good practice to enable the logging of Multipoint Label Distribution Protocol (MLDP) with this global command for the profiles with MLDP:
mpls mldp logging notifications
The PIM for IPv6 is enabled by default on the interfaces in the global or VRF context if the respective ipv6 multicast-routing or ipv6 multicast-routing vrf one command is configured.
interface Ethernet0/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
ipv6 address 2001:DB8:1::1/64
This means that the ipv6 pim command is enabled by default on the interfaces. For the profiles with VRF, 6 Virtual Provider Edge (6VPE) must be fully operational for the unicast traffic. For the profile 7, 6 Provider Edge (6PE) must be fully operational for the unicast traffic.
This section describes how to configure the mVPN profiles within the Cisco IOS.
The VPN-ID that is configured for the VRF is only required for the profiles that use MLDP as the core tree protocol and Default Multicast Distribution Tree (MDT).
vrf definition one
rd 1:1
vpn id 1000:2000
â¦
For the profiles with Default MDT and Generic Routing Encapsulation (GRE), if mVPN is enabled for IPv4 and IPv6, then the same Default MDT must be used for both of the Address Families (AFs).
You cannot mix different profiles for the different AFs.
For the profiles with Partitioned MDT with MLDP, if mVPN is enabled for IPv4 and IPv6, a different Partitioned MDT is signaled for each AF for the same root PE router. The MLDP tree will have a different Global Identifier (GID) in the Opaque value. The same Label Switched Path Virtual Interface (LSPVIF) interface is used for both AFs.
Here is an example where profile 14 is used for both AFs IPv4 and IPv6:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
address-family ipv6
mdt auto-discovery mldp
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
The Source 10.100.1.6 and 2001:DB8:2::6 are behind the same Source PE router PE2. The Multicast Routing Information Database (MRIB) entry for the IPv4 Multicast Group and the IPv6 Multicast Group uses a different Label Switched Multicast (LSM) entry or MLDP entry in the database on the ingress PE router, so both groups are forwarded on different MLDP trees.
PE2#show mpls mldp database opaque_type gid
LSM ID : 5 Type: P2MP Uptime : 02:18:54
FEC Root : 10.100.1.2 (we are the root)
Opaque decoded : [gid 65536 (0x00010000)]
Opaque length : 4 bytes
Opaque value : 01 0004 00010000
Upstream client(s) :
None
Expires : N/A Path Set ID : 5
Replication client(s):
MDT (VRF one)
Uptime : 02:18:54 Path Set ID : None
Interface : Lspvif1
10.100.1.4:0
Uptime : 00:32:50 Path Set ID : None
Out label (D) : 20 Interface : Ethernet2/0*
Local label (U): None Next Hop : 10.1.2.4
LSM ID : 6 Type: P2MP Uptime : 00:37:06
FEC Root : 10.100.1.2 (we are the root)
Opaque decoded : [gid 131072 (0x00020000)]
Opaque length : 4 bytes
Opaque value : 01 0004 00020000
Upstream client(s) :
None
Expires : N/A Path Set ID : 6
Replication client(s):
MDT (VRF one)
Uptime : 00:37:06 Path Set ID : None
Interface : Lspvif1
10.100.1.4:0
Uptime : 00:18:38 Path Set ID : None
Out label (D) : 22 Interface : Ethernet2/0*
Local label (U): None Next Hop : 10.1.2.4
PE2#show ip mfib vrf one 232.1.1.1
Entry Flags: C - Directly Connected, S - Signal, IA - Inherit A flag,
ET - Data Rate Exceeds Threshold, K - Keepalive
DDE - Data Driven Event, HW - Hardware Installed
ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
MS - MoFRR Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
NS - Negate Signalling, SP - Signal Present,
A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
MA - MFIB Accept, A2 - Accept backup,
RA2 - MRIB Accept backup, MA2 - MFIB Accept backup
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts: Total/RPF failed/Other drops
I/O Item Counts: FS Pkt Count/PS Pkt Count
VRF one
(10.100.1.6,232.1.1.1) Flags:
SW Forwarding: 374/0/100/0, Other: 122/0/122
Ethernet0/0 Flags: A
Lspvif1, LSM/6 Flags: F
Pkts: 374/0
PE2#show ipv6 mfib vrf one route FF3E::4000:1
Entry Flags: C - Directly Connected, S - Signal, IA - Inherit A flag,
ET - Data Rate Exceeds Threshold, K - Keepalive
DDE - Data Driven Event, HW - Hardware Installed
ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
MS - MoFRR Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
NS - Negate Signalling, SP - Signal Present,
A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
MA - MFIB Accept, A2 - Accept backup,
RA2 - MRIB Accept backup, MA2 - MFIB Accept backup
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts: Total/RPF failed/Other drops
I/O Item Counts: FS Pkt Count/PS Pkt Count
VRF one
(2001:DB8:2::6,FF3E::4000:1)
Ethernet0/0 A
Lspvif1, LSM/5 F
This section describes the required configurations for each profile.
Use this configuration for profile 0:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt default 232.1.1.1
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv4 mdt
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Use this configuration for profile 1:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profile 2 is not currently supported in the Cisco IOS, and the MLDP does not support Partitioned MDT with Multipoint-to-Multipoint (MP2MP).
Use this configuration for profile 3:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery pim
mdt default 232.1.1.1
route-target export 123:456
route-target import 123:456
exit-address-family
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profile 4 is not currently supported in the Cisco IOS, and MLDP does not support Partitioned MDT with MP2MP.
Profile 5 is not currently supported in the Cisco IOS, and PIM signaling is not supported over Partitioned MDT.
Use this configuration for profile 6:
vrf definition one
rd 1:1
!
address-family ipv6
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
ipv6 multicast-routing vrf one
ipv6 multicast vrf one mpls source Loopback0
ipv6 multicast vrf one mpls mldp
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Use this configuration for profile 7:
ipv6 multicast-routing
ipv6 multicast mpls source Loopback0
ipv6 multicast mpls mldp
interface Ethernet0/0
ip address 10.2.2.2 255.255.255.0
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 2001:DB8:2::6 remote-as 65002
!
!
address-family ipv6
redistribute connected
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-label
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profile 8 is not currently supported in the Cisco IOS.
Use this configuration for profile 9:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profile 10 is not currently supported in the Cisco IOS, and BGP-AD is not supported for Point-to-Multipoint Traffic Engineering (P2MP TE).
Use this configuration for profile 11:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery pim
mdt default 232.1.1.1
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Use this configuration for profile 12:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
Use this configuration for profile 13:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Use this configuration for profile 14:
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery mldp
mdt strict-rpf interface
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 2001:DB8:2::6 remote-as 65002
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate exit-address-family
Profile 15 is not currently supported in the Cisco IOS, and MLDP does not support Partitioned MDT with MP2MP.
Profile 16 is not currently supported in the Cisco IOS.
Use this configuration for profile 17:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp p2mp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
Profile 18 is not currently supported in the Cisco IOS.
Profile 19 and Ingress Replication (IR) are not currently supported in the Cisco IOS.
Profile 20 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
Profile 21 and IR are not currently supported in the Cisco IOS.
Profile 22 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
Profile 23 and IR are not currently supported in the Cisco IOS.
Profile 24 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
Profile 25 and IR are not currently supported in the Cisco IOS.
Profile 26 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
There is currently no verification procedure available for these configurations.
There is currently no specific troubleshooting information available for these configurations.
Revision | Publish Date | Comments |
---|---|---|
1.0 |
15-Jun-2015 |
Initial Release |