This document provides a sample configuration for ISDN with the use of IP.
There are no specific requirements for this document.
This document is not restricted to specific software and hardware versions.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Refer to Cisco Technical Tips Conventions for more information on document conventions.
In this section, you are presented with the information to configure the features described in this document.
Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.
This document uses this network setup:
This document uses these configurations:
C2503 |
---|
C2503#write terminal ###### Current configuration: ! version 10.2 ! hostname C2503 ! enable password test ! username C4000 password cisco !--- See the username explanation in the !--- Explanation of the C2503 Configuration section of this document. isdn switch-type basic-dms100 ! interface Ethernet0 ip address 172.16.10.1 255.255.255.0 ! interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 ip address 172.16.20.1 255.255.255.0 encapsulation ppp bandwidth 56 dialer idle-timeout 300 dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234 dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789 dialer hold-queue 5 dialer load-threshold 100 dialer-group 1 isdn spid1 408555432101 5554321 isdn spid2 408555987601 5559876 ppp authentication chap ! router igrp 1 network 172.16.0.0 ! ip route 192.168.24.0 255.255.255.0 172.16.20.2 access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 ! ! dialer-list 1 list 100 ! line con 0 line aux 0 line vty 0 4 password test login ! end |
C4000 |
---|
C4000#write terminal ###### Current configuration: ! version 10.2 ! hostname C4000 ! enable password test ! username C2503 password cisco !--- See the username explanation in the !--- Explanation of the C4000 Configuration section of this document. isdn switch-type basic-dms100 ! interface Ethernet0 ip address 192.168.24.65 255.255.255.0 ! interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 ip address 172.16.20.2 255.255.255.0 encapsulation ppp bandwidth 56 dialer idle-timeout 300 dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321 dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876 dialer hold-queue 5 dialer load-threshold 100 dialer-group 1 isdn spid1 415555123401 5551234 isdn spid2 415555678901 5556789 ppp authentication chap ! router igrp 1 network 172.16.0.0 network 192.168.24.0 ! ip route 172.16.10.0 255.255.255.0 172.16.20.1 access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 ! ! dialer-list 1 list 100 ! line con 0 line aux 0 line vty 0 4 password test login ! end |
C2503#write terminal ###### Current configuration: ! version 10.2 ! hostname C2503 ! enable password test ! username C4000 password cisco
The username C4000 is the host name of the remote router. The dialer map command, which this section explains, uses this username. The username is not case sensitive during authentication. However, the name that you configure with the dialer map command is case sensitive. You must exactly match the host name of the remote router, which is "C4000".
Note: In router C2503, the name that you configure with the username command must exactly match the name that you configure with the dialer map command. You issue the username command in global configuration mode.
The Challenge Handshake Authentication Protocol (CHAP) authentication process uses the password. The password is case sensitive and must match the remote router password exactly.
Note: In order to avoid confusion, this configuration example uses the unencrypted form of the password cisco. In the actual configuration, the password appears in its encrypted form: 7 13061E010803. In this password, 7 denotes the encryption type and 13061E010803 is the encrypted form of the password cisco. When you issue or make changes to the username command, always enter the password in its unencrypted form and do not enter the encryption type (7). The encryption type is set automatically.
isdn switch-type basic-dms100—The ISDN switch type must match the equipment of your carrier. If you change the switch type, you must reload the router in order for the new switch type to take effect.
interface Ethernet0 ip address 172.16.10.1 255.255.255.0 interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 ip address 172.16.20.1 255.255.255.0
encapsulation ppp—Use PPP encapsulation instead of High-Level Data Link Control (HDLC) in order to allow the use of CHAP authentication.
bandwidth 56—The default bandwidth setting for a BRI interface is 64 kbps. If you configure your dialer map statements with the speed 56 option, include the bandwidth statement.
Note: This command does not control the speed of your ISDN line. The command sets the correct reference point for:
The BRI port show interface statistics
The dialer load-threshold command
Interior Gateway Routing Protocol (IGRP)/Enhanced IGRP (EIGRP) routing metrics
dialer idle-timeout 300—This command sets the number of seconds that the ISDN connection remains open if no interesting traffic is being routed. The timer is reset each time that an interesting packet is forwarded.
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
Use the dialer map command with CHAP authentication in order to place the initial call to the remote router when interesting traffic is forwarded to the BRI interface. When the connection becomes active, the dialer idle-timeout command determines the length of time for the connection to remain active. A dialer map statement is necessary for each ISDN phone number that will be called. However, be aware that two dialer map statements that point to the same location can activate both B channels when you may only want to use one channel.
The command parameters for this example are:
172.16.20.2—The IP address of the remote router BRI interface
In order to determine this address, issue the show interface bri 0 command at the remote router console prompt.
name C4000—The host name of the remote router
The name is case sensitive and must match the name that you configure for the username command.
speed 56—Sets the dialer speed to 56 kbps for ISDN circuits that are not 64 kbps end to end
Include this parameter in the dialer map statements of both routers. Most installations in North America must be configured for 56 kbps.
broadcast—Allows the forwarding of broadcast packets
Unless the dialer-list command specifies broadcast packets as interesting packets, the packets are only forwarded when the ISDN link is active.
14155551234 and 14155556789—The remote router ISDN telephone numbers
dialer hold-queue 5—This command allows interesting packets to be queued until establishment of the ISDN connection. In this example, five interesting packets are to be queued.
dialer load-threshold 100—This command configures bandwidth on demand. The command sets the maximum load before the dialer places another call through the second B channel. The load is the calculated weighted average load value for the interface, where 1 is unloaded and 255 is fully loaded. The actual load value to configure depends on the characteristics of your particular network. In this example, the second B channel is activated when the load reaches 39 percent of maximum utilization, which is 100 divided by 255.
dialer-group 1—The dialer-group 1 command enables dialer list 1 on the BRI interface, which determines which packets are interesting and will activate the ISDN connection.
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
Use the isdn spid commands if your carrier assigns service profile identifiers (SPIDs) to your ISDN lines.
ppp authentication chap—This command enables CHAP authentication.
router igrp 1 network 172.16.0.0
ip route 192.168.24.0 255.255.255.0 172.16.20.2—This ip route command creates a static route to the remote router network via the remote router BRI interface. This is a requirement because dynamic routes are lost when the ISDN link is down.
The command parameters for this example are:
192.168.24.0—The target network
255.255.255.0—The target network mask
A 255 in an octet position specifies that an exact match for that octet is necessary. A 0 in an octet position specifies that any value matches.
172.16.20.2—The address of the next hop that can be used to reach the target network
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255—This access-list command determines which IP packets are interesting and will activate the ISDN link. The access list to create depends on your particular network design.
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0—This access-list command defines all broadcast packets as uninteresting.
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0255.255.255.255—This access-list command defines all other IP packets as interesting.
dialer-list 1 list 100—This command points to access list 100, which determines which IP packets are interesting.
line con 0 line aux 0 line vty 0 4 password test login ! end
C4000#write terminal ###### Current configuration: ! version 10.2 ! hostname C4000 ! enable password test ! username C2503 password cisco
The username C2503 is the host name of the remote router. The dialer map command, which this section explains, uses this username. The username is not case sensitive during authentication. However, the name that you configure with the dialer map command is case sensitive. You must exactly match the host name of the remote router, which is "C2503".
Note: In router C4000, the name that you configure with the username must exactly match the name that you configure with the dialer map command. You issue the username command in global configuration mode.
The CHAP authentication process uses the password. The password is case sensitive and must match the remote router password exactly.
Note: In order to avoid confusion, this configuration example uses the unencrypted form of the password cisco. In the actual configuration, the password appears in its encrypted form: 7 13061E010803. In this password, 7 denotes the encryption type and 13061E010803 is the encrypted form of the password cisco. When you issue or make changes to the username command, always enter the password in its unencrypted form and do not enter the encryption type (7). The encryption type is set automatically.
isdn switch-type basic-dms100—The ISDN switch type must match the equipment of your carrier. If you change the switch type, you must reload the router in order for the new switch type to take effect.
interface Ethernet0 ip address 192.168.24.65 255.255.255.0 interface Serial0 no ip address shutdown ! interface Serial1 no ip address shutdown ! interface BRI0 ip address 172.16.20.2 255.255.255.0 encapsulation ppp
encapsulation ppp—Use PPP encapsulation instead of HDLC in order to allow the use of CHAP authentication.
bandwidth 56—The default bandwidth setting for a BRI interface is 64 kbps. If you configure your dialer map statements with the speed 56 option, include the bandwidth statement.
Note: This command does not control the speed of your ISDN line. The command sets the correct reference point for:
The BRI port show interface statistics
The dialer load-threshold command
IGRP/EIGRP routing metrics
dialer idle-timeout 300—This command sets the number of seconds that the ISDN connection remains open if no interesting traffic is being routed. The timer is reset each time that an interesting packet is forwarded.
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321 dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876
Use the dialer map command with CHAP authentication in order to place the initial call to the remote router when interesting traffic is forwarded to the BRI interface. When the connection becomes active, the dialer idle-timeout command determines the length of time for the connection to remain active. A dialer map statement is necessary for each ISDN phone number that will be called. However, be aware that two dialer map statements that point to the same location can activate both B channels when you may only want to use one channel.
The command parameters for this example are:
172.16.20.1—The IP address of the remote router BRI interface
In order to determine this address, issue the show interface bri 0 command at the remote router console prompt.
name C2503—The host name of the remote router
The name is case sensitive and must match the name that you configure for the username command.
speed 56—Sets the dialer speed to 56 kbps for ISDN circuits that are not 64 kbps end to end
Include this parameter in the dialer map statements of both routers. Most installations in North America must be configured for 56 kbps.
broadcast—Allows the forwarding of broadcast packets
Unless the dialer-list command specifies broadcast packets as interesting packets, the packets are only forwarded when the ISDN link is active.
14085554321 and 14085559876—The remote router ISDN telephone numbers
dialer hold-queue 5 —This command allows interesting packets to be queued until establishment of the ISDN connection. In this example, five interesting packets are to be queued.
dialer load-threshold 100—This command configures bandwidth on demand. The command sets the maximum load before the dialer places another call through the second B channel. The load is the calculated weighted average load value for the interface, where 1 is unloaded and 255 is fully loaded. The actual load value to configure depends on the characteristics of your particular network. In this example, the second B channel is activated when the load reaches 39 percent of maximum utilization, which is 100 divided by 255.
dialer-group 1—The dialer-group 1 command enables the dialer list 1 on the BRI interface, which determines which packets are interesting and will activate the ISDN connection.
isdn spid1 415555123401 5551234
isdn spid2 415555678901 5556789
Use the isdn spid commands if your carrier assigns SPIDs to your ISDN lines.
ppp authentication chap—This command enables CHAP authentication.
router igrp 1 network 172.16.0.0 network 192.168.24.0
ip route 172.16.10.0 255.255.255.0 172.16.20.1—This ip route command creates a static route to the remote router network via the remote router BRI interface. This is a requirement because dynamic routes are lost when the ISDN link is down.
The command parameters for this example are:
172.16.0.0—The target network
255.255.0.0—The target network mask
A 255 in an octet position specifies that an exact match for that octet is necessary. A 0 in an octet position specifies that any value matches.
172.16.20.1—The address of the next hop that can be used to reach the target network
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255—This access-list command determines which IP packets are interesting and will activate the ISDN link. The access list to create depends on your particular network design.
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0—This access-list command defines all broadcast packets as uninteresting.
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255—This access-list command defines all other IP packets as interesting.
dialer-list 1 list 100—This command points to access list 100, which determines which IP packets are interesting.
line con 0 line aux 0 line vty 0 4 password test login ! end
There is currently no verification procedure available for this configuration.
There is currently no specific troubleshooting information available for this configuration.
Revision | Publish Date | Comments |
---|---|---|
1.0 |
29-Jan-2008 |
Initial Release |