In dem Dokumentationssatz für dieses Produkt wird die Verwendung inklusiver Sprache angestrebt. Für die Zwecke dieses Dokumentationssatzes wird Sprache als „inklusiv“ verstanden, wenn sie keine Diskriminierung aufgrund von Alter, körperlicher und/oder geistiger Behinderung, Geschlechtszugehörigkeit und -identität, ethnischer Identität, sexueller Orientierung, sozioökonomischem Status und Intersektionalität impliziert. Dennoch können in der Dokumentation stilistische Abweichungen von diesem Bemühen auftreten, wenn Text verwendet wird, der in Benutzeroberflächen der Produktsoftware fest codiert ist, auf RFP-Dokumentation basiert oder von einem genannten Drittanbieterprodukt verwendet wird. Hier erfahren Sie mehr darüber, wie Cisco inklusive Sprache verwendet.
Cisco hat dieses Dokument maschinell übersetzen und von einem menschlichen Übersetzer editieren und korrigieren lassen, um unseren Benutzern auf der ganzen Welt Support-Inhalte in ihrer eigenen Sprache zu bieten. Bitte beachten Sie, dass selbst die beste maschinelle Übersetzung nicht so genau ist wie eine von einem professionellen Übersetzer angefertigte. Cisco Systems, Inc. übernimmt keine Haftung für die Richtigkeit dieser Übersetzungen und empfiehlt, immer das englische Originaldokument (siehe bereitgestellter Link) heranzuziehen.
In diesem Dokument wird die Bereitstellung eines doppelseitigen virtuellen L2 Ethernet VPN (EVPN) Virtual Extensible LAN (VXLAN) vPC auf dem Nexus 9000 beschrieben.
Cisco empfiehlt, dass Sie über Kenntnisse in folgenden Bereichen verfügen:
Die Informationen in diesem Dokument basierend auf folgenden Software- und Hardware-Versionen:
Die Informationen in diesem Dokument beziehen sich auf Geräte in einer speziell eingerichteten Testumgebung. Alle Geräte, die in diesem Dokument benutzt wurden, begannen mit einer gelöschten (Nichterfüllungs) Konfiguration. Wenn Ihr Netzwerk in Betrieb ist, stellen Sie sicher, dass Sie die möglichen Auswirkungen aller Befehle verstehen.
Leaf-1# show run
hostname Leaf-1
cfs eth distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.2222.3333
ip pim rp-address 10.10.10.10 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8
vlan 1-10
vlan 2
vn-segment 10002
vlan 10
vn-segment 10010
route-map PERMIT-ALL permit 10
vrf context test
vni 10002
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
interface Vlan2
no shutdown
vrf member test
no ip redirects
ip forward
no ipv6 redirects
interface Vlan10
no shutdown
vrf member test
no ip redirects
ip address 172.16.2.100/25
fabric forwarding mode anycast-gateway
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback1
member vni 10002 associate-vrf
member vni 10010
suppress-arp
mcast-group 239.1.1.1
interface Ethernet1/1
mtu 9216
ip address 172.16.0.1/24
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/29
switchport
switchport mode trunk
no shutdown
interface loopback0
ip address 10.1.1.1/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
interface loopback1
ip address 10.2.1.1/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
router ospf 100
router-id 10.1.1.1
router bgp 6500
router-id 10.1.1.1
address-family ipv4 unicast
address-family l2vpn evpn
advertise-pip
neighbor 10.10.10.10
remote-as 6500
update-source loopback0
address-family ipv4 unicast
address-family l2vpn evpn
send-community
send-community extended
vrf test
address-family ipv4 unicast
evpn
vni 10010 l2
rd auto
route-target import auto
route-target export auto
Spine-1# show run
cfs eth distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature vpc
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.2222.3333
ip pim rp-address 10.10.10.10 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8
vlan 1,100
route-map PERMIT-ALL permit 10
vrf context management
interface Ethernet1/1
mtu 9216
ip address 172.16.0.2/24
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/29
mtu 9216
ip address 172.16.2.2/24
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/31
mtu 9216
ip address 172.16.1.2/24
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface loopback0
ip address 10.10.10.10/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
router ospf 100
router-id 10.10.10.10
router bgp 6500
router-id 10.10.10.10
address-family ipv4 unicast
address-family l2vpn evpn
neighbor 10.1.1.1
remote-as 6500
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 10.1.1.3
remote-as 6500
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 10.1.1.4
remote-as 6500
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
Leaf-2(config)# show run
hostname Leaf-2
cfs ipv4 distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature vpc
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.2222.3333
ip pim rp-address 10.10.10.10 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8
vlan 1-2,10
vlan 2
vn-segment 10002
vlan 10
vn-segment 10010
route-map PERMIT-ALL permit 10
vrf context management
vrf context test
vni 10002
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vpc domain 1
peer-switch
peer-keepalive destination 10.201.182.26
virtual peer-link destination 10.1.1.3 source 10.1.1.4 dscp 56
peer-gateway
ip arp synchronize
interface Vlan1
no ip redirects
no ipv6 redirects
interface Vlan2
no shutdown
vrf member test
no ip redirects
ip forward
no ipv6 redirects
interface Vlan10
no shutdown
vrf member test
no ip redirects
ip address 172.16.2.100/25
no ipv6 redirects
fabric forwarding mode anycast-gateway
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
spanning-tree port type network
vpc peer-link
interface port-channel20
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 20
interface port-channel40
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 40
interface nve1
no shutdown
host-reachability protocol bgp
advertise virtual-rmac
source-interface loopback1
member vni 10002 associate-vrf
member vni 10010
suppress-arp
mcast-group 239.1.1.1
interface Ethernet1/7
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/8
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/46
mtu 9216
port-type fabric
ip address 172.16.2.1/24
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface loopback0
ip address 10.1.1.4/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
interface loopback1
ip address 10.2.1.4/32
ip address 10.2.1.10/32 secondary
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
icam monitor scale
router ospf 100
router-id 10.1.1.4
router bgp 6500
router-id 10.1.1.4
address-family ipv4 unicast
address-family l2vpn evpn
advertise-pip
neighbor 10.10.10.10
remote-as 6500
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
vrf test
address-family ipv4 unicast
evpn
vni 10010 l2
rd auto
route-target import auto
route-target export auto
Leaf-3(config-if-range)# show run
hostname Leaf-3
cfs ipv4 distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature vpc
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.2222.3333
ip pim rp-address 10.10.10.10 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8
vlan 1-2,10
vlan 2
vn-segment 10002
vlan 10
vn-segment 10010
route-map PERMIT-ALL permit 10
vrf context management
vrf context test
vni 10002
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vpc domain 1
peer-switch
peer-keepalive destination 10.201.182.25
virtual peer-link destination 10.1.1.4 source 10.1.1.3 dscp 56
peer-gateway
ip arp synchronize
interface Vlan1
no ip redirects
no ipv6 redirects
interface Vlan2
no shutdown
vrf member test
no ip redirects
ip forward
no ipv6 redirects
interface Vlan10
no shutdown
vrf member test
no ip redirects
ip address 172.16.2.100/25
no ipv6 redirects
fabric forwarding mode anycast-gateway
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
spanning-tree port type network
vpc peer-link
interface port-channel20
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 20
interface port-channel40
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 40
interface nve1
no shutdown
host-reachability protocol bgp
advertise virtual-rmac
source-interface loopback1
member vni 10002 associate-vrf
member vni 10010
suppress-arp
mcast-group 239.1.1.1
interface Ethernet1/7
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/8
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/47
mtu 9216
port-type fabric
ip address 172.16.1.1/24
ip ospf network point-t-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/48
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 20 mode active
no shutdown
interface loopback0
ip address 10.1.1.3/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mod
interface loopback1
ip address 10.2.1.3/32
ip address 10.2.1.10/32 secondary
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
icam monitor scale
router ospf 100
router-id 10.1.1.3
router bgp 6500
router-id 10.1.1.3
address-family ipv4 unicast
address-family l2vpn evpn
advertise-pip
neighbor 10.10.10.10
remote-as 6500
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
vrf test
address-family ipv4 unicast
evpn
vni 10010 l2
rd auto
route-target import auto
route-target export auto
Leaf-4(config-if)# show run
hostname Leaf-4
cfs eth distribute
feature lacp
feature vpc
vlan 1,10,20
vpc domain 2
peer-switch
peer-keepalive destination 10.201.182.29 source 10.201.182.28
peer-gateway
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
spanning-tree port type network
vpc peer-link
interface port-channel20
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 20
interface port-channel40
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 40
interface Ethernet1/7
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/8
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/45
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 10 mode active
no shutdown
interface Ethernet1/47
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 20 mode active
no shutdown
Leaf-5(config-if)# show run
cfs eth distribute
feature lacp
feature vpc
vlan 1,10,20
vpc domain 2
peer-switch
peer-keepalive destination 10.201.182.28 source 10.201.182.29
peer-gateway
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
spanning-tree port type network
vpc peer-link
interface port-channel20
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 20
interface port-channel40
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
vpc 40
interface Ethernet1/7
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/8
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 40 mode active
no shutdown
interface Ethernet1/45
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 10 mode active
no shutdown
interface Ethernet1/47
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20
channel-group 20 mode active
no shutdown
Host-A(config-if)# show run
hostname Host-A
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature nv overlay
vlan 1-2,10,20
vrf context test
interface Vlan10
no shutdown
vrf member test
ip address 172.16.1.101/25
interface Ethernet1/45
switchport
switchport mode trunk
no shutdown
HOST-B(config-if)# show run
hostname HOST-B
feature ospf
feature bgp
feature pim
feature interface-vlan
feature lacp
vlan 1-2,10,20
vrf context test
interface Vlan10
no shutdown
vrf member test
ip address 172.16.1.102/25
interface port-channel10
switchport
switchport mode trunk
interface Ethernet1/3
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown
interface Ethernet1/4
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown
Verwenden Sie diesen Abschnitt, um zu überprüfen, ob Ihre Konfiguration ordnungsgemäß funktioniert.
HOST-B(config-if)# ping 172.16.1.101 vrf test
PING 172.16.1.101 (172.16.1.101): 56 data bytes
64 bytes from 172.16.1.101: icmp_seq=0 ttl=254 time=1.007 ms
64 bytes from 172.16.1.101: icmp_seq=1 ttl=254 time=0.608 ms
64 bytes from 172.16.1.101: icmp_seq=2 ttl=254 time=0.539 ms
64 bytes from 172.16.1.101: icmp_seq=3 ttl=254 time=0.522 ms
64 bytes from 172.16.1.101: icmp_seq=4 ttl=254 time=0.514 ms
--- 172.16.1.101 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.514/0.638/1.007 ms
HOST-B(config-if)# show ip arp 172.16.1.101 vrf test
Flags: * - Adjacencies learnt on non-active FHRP router
+ - Adjacencies synced via CFSoE
# - Adjacencies Throttled for Glean
CP - Added via L2RIB, Control plane Adjacencies
PS - Added via L2RIB, Peer Sync
RO - Re-Originated Peer Sync Entry
D - Static Adjacencies attached to down interface
IP ARP Table
Total number of entries: 1
Address Age MAC Address Interface Flags
172.16.1.101 00:00:04 4ce1.7638.2f37 Vlan10
Host-A(config-if)# ping 172.16.1.102 vrf tes
PING 172.16.1.102 (172.16.1.102): 56 data bytes
64 bytes from 172.16.1.102: icmp_seq=0 ttl=254 time=1.047 ms
64 bytes from 172.16.1.102: icmp_seq=1 ttl=254 time=0.86 ms
64 bytes from 172.16.1.102: icmp_seq=2 ttl=254 time=0.708 ms
64 bytes from 172.16.1.102: icmp_seq=3 ttl=254 time=0.509 ms
64 bytes from 172.16.1.102: icmp_seq=4 ttl=254 time=0.485 ms
--- 172.16.1.102 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.485/0.721/1.047 ms
Host-A(config-if)#
Host-A(config-if)# show ip arp 172.16.1.102 vrf test
Flags: * - Adjacencies learnt on non-active FHRP router
+ - Adjacencies synced via CFSoE
# - Adjacencies Throttled for Glean
CP - Added via L2RIB, Control plane Adjacencies
PS - Added via L2RIB, Peer Sync
RO - Re-Originated Peer Sync Entry
D - Static Adjacencies attached to down interface
IP ARP Table
Total number of entries: 1
Address Age MAC Address Interface Flags
172.16.1.102 00:05:07 4ce1.7638.3257 Vlan10
Host-A(config-if)#
Dieser Abschnitt enthält Informationen, die Sie zur Fehlerbehebung bei Ihrer Konfiguration verwenden können.
Leaf-2(config-if-range)# show spanning-tree
VLAN0001
Spanning tree enabled protocol rstp
Root ID Priority 32769
Address 0023.04ee.be01
Cost 0
Port 0 ()
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 003a.9c28.2cc7
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Eth1/47 Desg FWD 4 128.185 P2p
VLAN0002
Spanning tree enabled protocol rstp
Root ID Priority 32770
Address 0023.04ee.be01
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32770 (priority 32768 sys-id-ext 2)
Address 0023.04ee.be01
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Eth1/47 Desg FWD 4 128.185 P2p
VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0023.04ee.be01
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 0023.04ee.be01
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10 Desg FWD 4 128.4105 (vPC peer-link) Network P2p
Po40 Desg FWD 1 128.4135 (vPC) P2p
Eth1/47 Desg FWD 4 128.185 P2p
Leaf-2(config-if-range)# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
b - BFD Session Wait
S - Switched R - Routed
U - Up (port-channel)
p - Up in delay-lacp mode (member)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
channel
--------------------------------------------------------------------------------
10 Po10(SU) Eth NONE --
20 Po20(SD) Eth LACP Eth1/5(D)
40 Po40(SU) Eth LACP Eth1/7(P) Eth1/8(P)
Leaf-2(config-if-range)# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 2
Peer Gateway : Enabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Delay-restore Orphan-port status : Timer is off.(timeout = 0s)
Operational Layer3 Peer-router : Disabled
Virtual-peerlink mode : Enabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po10 up 10
vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
20 Po20 down* success success -
40 Po40 up success success 10
Leaf-3(config-if-range)# show spanning-tree
VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0023.04ee.be01
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 0023.04ee.be01
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10 Root FWD 4 128.4105 (vPC peer-link) Network P2p
Po40 Desg FWD 1 128.4135 (vPC) P2p
Leaf-3(config-if-range)# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 2
Peer Gateway : Enabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Delay-restore Orphan-port status : Timer is off.(timeout = 0s)
Operational Layer3 Peer-router : Disabled
Virtual-peerlink mode : Enabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po10 up 10
vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
20 Po20 down* success success -
40 Po40 up success success 10
Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.
Leaf-4(config-if)# show spanning-tree
VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0023.04ee.be01
Cost 5
Port 4105 (port-channel10)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 0023.04ee.be02
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10 Root FWD 4 128.4105 (vPC peer-link) Network P2p
Po20 Desg FWD 1 128.4115 (vPC) P2p
Po40 Root FWD 1 128.4135 (vPC) P2p
VLAN0020
Spanning tree enabled protocol rstp
Root ID Priority 32788
Address 0023.04ee.be02
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)
Address 0023.04ee.be02
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10 Root FWD 4 128.4105 (vPC peer-link) Network P2p
Po20 Desg FWD 1 128.4115 (vPC) P2p
Po40 Desg FWD 1 128.4135 (vPC) P2p
Leaf-4(config-if)# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 2
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 2
Peer Gateway : Enabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled
Virtual-peerlink mode : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po10 up 10,20
vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
20 Po20 up success success 10,20
40 Po40 up success success 10,20
Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.
Leaf-4(config-if)# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
b - BFD Session Wait
S - Switched R - Routed
U - Up (port-channel)
p - Up in delay-lacp mode (member)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
10 Po10(SU) Eth LACP Eth1/45(P)
20 Po20(SU) Eth LACP Eth1/47(P)
40 Po40(SU) Eth LACP Eth1/7(P) Eth1/8(P)
Leaf-5(config-if)# show spanning-tree
VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0023.04ee.be01
Cost 1
Port 4135 (port-channel40)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 0023.04ee.be02
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10 Desg FWD 4 128.4105 (vPC peer-link) Network P2p
Po20 Desg FWD 1 128.4115 (vPC) P2p
Po40 Root FWD 1 128.4135 (vPC) P2p
VLAN0020
Spanning tree enabled protocol rstp
Root ID Priority 32788
Address 0023.04ee.be02
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)
Address 0023.04ee.be02
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10 Desg FWD 4 128.4105 (vPC peer-link) Network P2p
Po20 Desg FWD 1 128.4115 (vPC) P2p
Po40 Desg FWD 1 128.4135 (vPC) P2p
Leaf-5(config-if)# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 2
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 2
Peer Gateway : Enabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled
Virtual-peerlink mode : Disabled
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po10 up 10,20
vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
20 Po20 up success success 10,20
40 Po40 up success success 10,20
Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.
Leaf-1# show bgp l2vpn evpn
BGP routing table information for VRF default, address family L2VPN EVPN
BGP table version is 558, Local Router ID is 10.1.1.1
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid, >-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist, I-injected
Origin codes: i - IGP, e - EGP, ? - incomplete, | - multipath, & - backup, 2 - best2
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10.1.1.1:32777 (L2VNI 10010)
*>i[2]:[0]:[0]:[48]:[003a.9c28.2cc7]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>i[2]:[0]:[0]:[48]:[003a.9c28.2f67]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>l[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[0]:[0.0.0.0]/216
10.2.1.1 100 32768 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
* i 10.2.1.10 100 0 i
*>l[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[32]:[172.16.1.101]/272
10.2.1.1 100 32768 i
* i[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[32]:[172.16.1.102]/272
10.2.1.10 100 0 i
*>i 10.2.1.10 100 0 i
Route Distinguisher: 10.1.1.3:3
*>i[2]:[0]:[0]:[48]:[003a.9c28.2f67]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
Route Distinguisher: 10.1.1.3:32777
*>i[2]:[0]:[0]:[48]:[003a.9c28.2f67]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[32]:[172.16.1.102]/272
10.2.1.10 100 0 i
Route Distinguisher: 10.1.1.4:3
*>i[2]:[0]:[0]:[48]:[003a.9c28.2cc7]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
Route Distinguisher: 10.1.1.4:32777
*>i[2]:[0]:[0]:[48]:[003a.9c28.2cc7]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[32]:[172.16.1.102]/272
10.2.1.10 100 0 i
Route Distinguisher: 10.1.1.1:3 (L3VNI 10002)
*>i[2]:[0]:[0]:[48]:[003a.9c28.2cc7]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>i[2]:[0]:[0]:[48]:[003a.9c28.2f67]:[0]:[0.0.0.0]/216
10.2.1.10 100 0 i
*>l[2]:[0]:[0]:[48]:[005d.73b2.9647]:[0]:[0.0.0.0]/216
10.2.1.1 100 32768 i
* i[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[32]:[172.16.1.102]/272
10.2.1.10 100 0 i
*>i 10.2.1.10 100 0 i
Leaf-1#
Leaf-1# show mac address-table
Legend:
* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
age - seconds since last seen,+ - primary entry using vPC Peer-Link,
(T) - True, (F) - False, C - ControlPlane MAC, ~ - vsan,
(NA)- Not Applicable
VLAN MAC Address Type age Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
* 10 4ce1.7638.2f37 dynamic NA F F Eth1/29
C 10 4ce1.7638.3257 dynamic NA F F nve1(10.2.1.10)
G - 0000.2222.3333 static - F F sup-eth1(R)
G - 005d.73b2.9647 static - F F sup-eth1(R)
G 2 005d.73b2.9647 static - F F sup-eth1(R)
G 10 005d.73b2.9647 static - F F sup-eth1(R)
Leaf-1#
Leaf-2(config-if-range)#
Leaf-2(config-if-range)# show bgp l2vpn evpn
BGP routing table information for VRF default, address family L2VPN EVPN
BGP table version is 45, Local Router ID is 10.1.1.4
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid, >-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist, I-injected
Origin codes: i - IGP, e - EGP, ? - incomplete, | - multipath, & - backup, 2 - best2
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10.1.1.1:3
*>i[2]:[0]:[0]:[48]:[005d.73b2.9647]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
Route Distinguisher: 10.1.1.1:32777
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[32]:[172.16.1.101]/272
10.2.1.1 100 0 i
Route Distinguisher: 10.1.1.4:32777 (L2VNI 10010)
*>l[2]:[0]:[0]:[48]:[003a.9c28.2cc7]:[0]:[0.0.0.0]/216
10.2.1.10 100 32768 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
*>l[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[0]:[0.0.0.0]/216
10.2.1.10 100 32768 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[32]:[172.16.1.101]/272
10.2.1.1 100 0 i
*>l[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[32]:[172.16.1.102]/272
10.2.1.10 100 32768 i
Route Distinguisher: 10.1.1.4:3 (L3VNI 10002)
*>l[2]:[0]:[0]:[48]:[003a.9c28.2cc7]:[0]:[0.0.0.0]/216
10.2.1.10 100 32768 i
*>i[2]:[0]:[0]:[48]:[005d.73b2.9647]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[32]:[172.16.1.101]/272
10.2.1.1 100 0 i
Leaf-2(config-if-range)#
Leaf-3(config-if-range)# show bgp l2vpn evpn
BGP routing table information for VRF default, address family L2VPN EVPN
BGP table version is 89, Local Router ID is 10.1.1.3
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid, >-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist, I-injected
Origin codes: i - IGP, e - EGP, ? - incomplete, | - multipath, & - backup, 2 - best2
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10.1.1.1:3
*>i[2]:[0]:[0]:[48]:[005d.73b2.9647]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
Route Distinguisher: 10.1.1.1:32777
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[32]:[172.16.1.101]/272
10.2.1.1 100 0 i
Route Distinguisher: 10.1.1.3:32777 (L2VNI 10010)
*>l[2]:[0]:[0]:[48]:[003a.9c28.2f67]:[0]:[0.0.0.0]/216
10.2.1.10 100 32768 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
*>l[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[0]:[0.0.0.0]/216
10.2.1.10 100 32768 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[32]:[172.16.1.101]/272
10.2.1.1 100 0 i
*>l[2]:[0]:[0]:[48]:[4ce1.7638.3257]:[32]:[172.16.1.102]/272
10.2.1.10 100 32768 i
Route Distinguisher: 10.1.1.3:3 (L3VNI 10002)
*>l[2]:[0]:[0]:[48]:[003a.9c28.2f67]:[0]:[0.0.0.0]/216
10.2.1.10 100 32768 i
*>i[2]:[0]:[0]:[48]:[005d.73b2.9647]:[0]:[0.0.0.0]/216
10.2.1.1 100 0 i
*>i[2]:[0]:[0]:[48]:[4ce1.7638.2f37]:[32]:[172.16.1.101]/272
10.2.1.1 100 0 i
Überarbeitung | Veröffentlichungsdatum | Kommentare |
---|---|---|
1.0 |
18-Oct-2022 |
Erstveröffentlichung |