Einführung
In diesem Dokument wird beschrieben, wie Sie ein Problem mit Call Studio im Customer Voice Portal (CVP) beheben können, wenn Projekte aus Call Studio 10.5 nicht in Call Studio 11.0 oder Call Studio 11.5 importiert werden können.
Voraussetzungen
Anforderungen
Cisco empfiehlt, über Kenntnisse in folgenden Bereichen zu verfügen:
- CVP Call Studio
- CVP-Anrufserver
Die Informationen in diesem Dokument basieren auf den folgenden Softwareversionen:
- CVP-Server 11.5
- CVP Call Studio 11.5
Problem
Call Studio-Skripts wurden in Call Studio, Version 10.5, entwickelt. Beim Importieren in CallStudio, Version 11.0/11.5, ist der Import bei wenigen Skripts fehlgeschlagen, und es wurde eine Fehlermeldung angezeigt.
Fehlermeldung
Diese Fehlermeldung wird beim Importieren des Call Studio-Skripts "Import des Call Studio-Projekts fehlgeschlagen: Project enthält Start des Call-Elements mit demselben Namen wie ein anderes Element im Hauptfluss. Ab Call Studio 10.5(1) muss der Name des Call-Elements eindeutig sein. Benennen Sie die vorherige Version von Call Studio um, und versuchen Sie es erneut."
Mögliche Ursachen
Ab Call Studio 11.0 darf kein Element denselben Namen wie das "Start of Call"-Element haben.
Dies ist die Ursache für die Fehlermeldung, die Sie für den Import der älteren Apps sehen können, die die gleiche Fehlermeldung erlaubt haben.
Lösung
Empfohlene Maßnahmen
Schritt 1: Importieren Sie das problematische Projekt als reguläres Projekt in Call Studio 11.5 (kein Call Studio-Projekt). Das Projekt wird erfolgreich importiert.
Schritt 2: Suchen Sie nach dem Namen des Start-of-Call-Elements der Anwendung.
Schritt 3: Wenn Sie auf einer Seite der Anwendung mehr als einen Eintrag finden, dann ist dies die Ursache des Importfehlers.
Schritt 4: Erstellen Sie auf der Hauptseite ein neues Page Entry-Element neben dem Start-of-Call-Element.
Schritt 5: Zeigen Sie den Ausgangszustand dieses neuen Elements auf dasselbe Element, auf das das Start-of-Call-Element zeigt.
Schritt 6: Verweisen Sie auf das auf der Hauptseite erstellte Seiteneingabeelement, indem Sie die Anschlüsse für Seiteneinträge mit demselben Namen wie das Start-of-Call-Element angeben.
Schritt 7: Die Anwendung ist jetzt mit Call Studio 11.0 / 11.5 kompatibel, speichern und exportieren.
Schritt 8: Löschen Sie das importierte Projekt, und importieren Sie es erneut als vorhandenes Call Studio-Projekt.
Hinweis: Dieser Defekt CSCvb95979 wurde für das Problem geöffnet.