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Preface 

Purpose 
This document explains how to install the Cisco Unified Contact Center Management 
Portal (Unified CCMP) components. 

Audience 
This document is intended for System Administrators with knowledge of their 
Unified Contact Center Enterprise (Unified CCE) system architecture. Microsoft 
SQL Server database administration experience is also helpful. 

Organization 
The sections of this guide are as follows: 
 

Chapter 
1 

Planning Your Installation Introduces Unified CCMP, including its integration with 
Unified CCE. 

Chapter 
2 

Installation Guidelines 
and Requirements 

Lists the prerequisites for Unified CCMP installation and 
provides recommendations for pre installation platform 
configuration. 

Chapter 
3 

Windows and SQL 
Component Installation 

Describes how to setup the Microsoft SQL Server. 

Chapter 
4 

Unified CCMP 
Component Installation 

Provides instructions for the installation of all Unified CCMP 
components. 

Chapter 
5 

Unified CCMP 
Component Configuration 

Describes post-installation configuration of Unified CCMP, 
including setting up replication and uploading .wav files for 
voice announcements. The procedure for configuring a 
Unified CCMP server cluster is detailed as well as how to use 
the Unified CCMP Replication Manager to replicate data 



Preface  
Related Documentation  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  xi   

 

between Database servers. Web and Database component 
server performance checklists are also provided. 

Chapter 
6 

Post Installation Steps Describes the post-installation options and the system checks 
for the Unified CCMP platform. 

Chapter 
7 

Upgrading From a 
Previous Version 

Explains the various options for upgrading an existing 
installation of Unified CCMP without losing your data. 

Chapter 
8  

Single-Sided Upgrade Describes how to upgrade a single-sided deployment. 

Chapter 
9 

Total Outage Upgrade Describes how to upgrade a dual-sided deployment in one 
operation. 

Chapter 
10 

Split Side Upgrade Describes how to upgrade a dual-sided deployment in two 
stages, a side at a time. 

Chapter 
11  

Upgrade From Version 
8.5(1) or Earlier 

Describes how to upgrade from Unified CCMP 8.5(1) or 
earlier. 

Chapter 
12 

Uninstalling Unified 
CCMP 

Describes how to remove Unified CCMP from your servers. 

Chapter 
13 

Troubleshooting Describes how to enable logging for the Unified CCMP 
Installer and how to apply database permissions after the 
Installer has completed. 

Related Documentation 
Documentation for Cisco Unified ICM/Contact Center Enterprise & Hosted, as well 
as related documentation, is accessible from Cisco.com at: 
http://www.cisco.com/cisco/web/psa/default.html. 
• Related documentation includes the documentation sets for Cisco CTI Object 

Server (CTIOS), Cisco Agent Desktop (CAD), Cisco Agent Desktop - Browser 
Edition (CAD-BE), Cisco Unified Customer Voice Portal (CVP),Cisco Unified 
IP IVR, Cisco Unified Intelligence Center, and Cisco Support Tools. 

• For documentation for these Cisco Unified Contact Center products, go to 
http://www.cisco.com/cisco/web/psa/default.html, click Voice and Unified 
Communications, then click Customer Contact, then click Cisco Unified 
Contact Center Products or Cisco Unified Voice Self-Service Products, then 
click the product/option you are interested in. 

• For troubleshooting tips for these Cisco Unified Contact Center products, go to 
http://docwiki.cisco.com/wiki/Category:Troubleshooting, then click the 
product/option you are interested in. 

• Documentation for Cisco Unified Communications Manager is accessible from: 
http://www.cisco.com/cisco/web/psa/default.html. 

http://www.cisco.com/cisco/web/psa/default.html
http://www.cisco.com/cisco/web/psa/default.html
http://docwiki.cisco.com/wiki/Category:Troubleshooting
http://www.cisco.com/cisco/web/psa/default.html


Preface  
Product Naming Conventions  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  xii   

 

• Technical Support documentation and tools are accessible from: 
http://www.cisco.com/en/US/support/index.html. 

• The Product Alert tool is accessible from (sign in required): 
http://www.cisco.com/cgi-bin/Support/FieldNoticeTool/field-notice. 

• For information on the Cisco software support methodology, refer to Software 
Release and Support Methodology: ICM/IPCC available at (sign in required): 
http://www.cisco.com/en/US/partner/products/sw/custcosw/ps1844/prod_bulletin
s_list.html.  

For a detailed list of language localizations, refer to the Cisco Unified ICM/Contact 
Center Product and System Localization Matrix available at the bottom of the 
following page: 
http://www.cisco.com/en/US/products/sw/custcosw/ps1001/prod_technical_reference
_list.html. 

Product Naming Conventions 
In this release, the product names defined in the table below have changed. The New 
Name (long version) is reserved for the first instance of that product name and in all 
headings. The New Name (short version) is used for subsequent instances of the 
product name. 

Note This document uses the naming conventions provided in each GUI, which 
means that in some cases the old product name is in use. 
 

Old Product Name New Name (long version) New Name (short version) 

Cisco IPCC Enterprise 
Edition 

Cisco Unified Contact Center 
Enterprise 

Unified CCE 

Cisco IPCC Hosted Edition Cisco Unified Contact Center 
Hosted 

Unified CCH 

Cisco Intelligent Contact 
Management (ICM) 
Enterprise Edition 

Cisco Unified Intelligent 
Contact Management (ICM) 
Enterprise Unified ICM 

 Cisco Intelligent Contact 
Management (ICM) Hosted 
Edition 

Cisco Unified Intelligent 
Contact Management (ICM) 
Hosted 

Cisco CallManager/Cisco 
Unified CallManager 

Cisco Unified Communications 
Manager 

Unified CM 

Conventions 
This document uses the following conventions: 

http://www.cisco.com/en/US/support/index.html
http://www.cisco.com/cgi-bin/Support/FieldNoticeTool/field-notice
http://www.cisco.com/en/US/partner/products/sw/custcosw/ps1844/prod_bulletins_list.html.
http://www.cisco.com/en/US/partner/products/sw/custcosw/ps1844/prod_bulletins_list.html.
http://www.cisco.com/en/US/products/sw/custcosw/ps1001/prod_technical_reference_list.html.
http://www.cisco.com/en/US/products/sw/custcosw/ps1001/prod_technical_reference_list.html.
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Convention Description 

boldface font Boldface font is used to indicate commands, such as entries, keys, buttons, 
folders and submenu names. For example: 
• Choose Edit > Find 
• Click Finish 

italic font Italic font is used to indicate the following: 
• To introduce a new term; for example: A skill group is a collection of 

agents who share similar skills 
• For emphasis; for example: Do not use the numerical naming 

convention 
• A syntax value that the user must replace; for example: IF (condition, 

true-value, false-value) 
• A book title; for example: Refer to the Cisco CRS Installation Guide 

window font Window font, such as Courier, is used for the following: 
• Text as it appears in code or that the window displays; for example: 

<html><title>Cisco Systems, Inc. </title></html>  
< > Angle brackets are used to indicate the following: 

• For arguments where the context does not allow italic, such as ASCII 
output 

• A character string that the user enters but that does not appear on the 
window, such as a password 

Obtaining Documentation and Submitting a Service Request 
For information on obtaining documentation, submitting a service request, and 
gathering additional information, see the monthly What’s New in Cisco Product 
Documentation, which also lists all new and revised Cisco technical documentation, 
at: 

Hhttp://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.htmlH 

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple 
Syndication (RSS) feed and set content to be delivered directly to your desktop using 
a reader application. The RSS feeds are a free service and Cisco currently supports 
RSS version 2.0. 

Documentation Feedback 
You can provide comments about this document by sending an email message to the 
following address: 

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html
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mailto:ccbu_docfeedback@cisco.com 

We appreciate your comments. 

mailto:ccbu_docfeedback@cisco.com
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1. Planning Your Installation 
A successful installation of Unified CCMP requires some understanding of the 
platform components, the environment in which they are deployed and how they are 
configured in a cluster of linked servers. File systems and storage options are also 
discussed as well as user accounts and security considerations in an internet facing 
environment. 

Deployment Specifics 
Unified CCMP Resource Management deployments are limited to standard and 
hosted Unified CCE deployments, with the following restrictions: 

Each configured Unified CCE instance must have its own: 
• Unified ICM instance. 
• Dedicated Admin Workstation Real Time Distributor Server. Multiple 

Distributor instances on a single server are not allowed. 
• Dedicated Admin Workstation CMS Server. Multiple CMS Server instances on a 

single server are not allowed. 

Unified CCMP is only supported on Unified CCE 7.1 and later. 

System Architecture 

Infrastructure Software 
Windows 2008 Server R2 with Service Pack 1. 

SQL Server 2008 R2 Standard Edition with Service Pack 1. 

Deployment Models 
In many environments, Unified CCMP is installed using a dual-sided deployment 
model to provide load balancing, resiliency, and high availability. For deployments 
that require layered security, such as Internet-facing environments, both sides are 
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split across separate database servers and App/Web servers are separated by a 
demilitarized zone (DMZ).  

Because Unified CCMP scales up with equipment and scales out with servers, a 
variety of cost-effective deployment models are possible. Review the Hardware and 
System Software Specification (Bill of Materials) for Cisco Unified ICM / Contact 
Center Enterprise & Hosted carefully prior to deployment model selection. 

Each of the following deployment models assumes the possibility of a dual-sided 
server configuration that replicates data between sites. 
• Single Tier (Dedicated Server). All Unified CCMP components are installed on 

a single dedicated server.  
• Two Tier (Secure Deployment). Unified CCMP Application and Web 

components are hosted on one server. The Provisioning, Data Import and 
Database components are hosted on a second server.  

Unified CCMP Architecture 
A Unified CCMP installation comprises the following components. 
• Database Server The Portal database stores configuration and audit information. 
• Application Server The application server delivers application services such as 

search and security to the Unified CCMP Web Server. 
• Web Server The web server is the Unified CCMP front end through which users 

gain access to the application. 
• Data Import Server the Data Import Server imports configuration items and 

changes to configuration items such as agents, call types and skill groups from 
Unified CCE. 

• Provisioning Server the Provisioning Server applies configuration changes 
submitted by Unified CCMP users to Unified CCE. 

Depending on the deployment model chosen the components may reside on different 
servers. 

Figure 1, below, describes the software installation layout for a single tier 
deployment. All components reside on a single server. Optionally, a second side can 
be included for resilience. 
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Figure 1: Unified CCMP software component layout for a single tier 
deployment. 

 

Figure 2, below, describes the software installation layout for a dual tier deployment. 
The web server and application server components reside on a separate server. 
Optionally, a second side can be included for resilience. 

Figure 2: Unified CCMP software component layout for a dual tier 
deployment. 
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2. Installation Guidelines and Requirements 

Installation Prerequisite Checklist 
Each Unified CCMP component requires prerequisite software and Windows features 
to be installed in order to operate correctly.  

A mandatory check is performed before each part of the installation that checks the 
required pre-requisite software elements. If this check does not find the required 
software then the installation will not proceed. 

Windows Feature Requirements 
The following Windows 2008 R2 features are required on all Servers hosting Unified 
CCMP: 
• Microsoft .NET Framework 4.5  
• TCP Activation 
• Named Pipes Activation 
• File Server 

In addition to these features the following components must also be enabled on the 
associated servers: 
• Machines hosting the Database Server component 

• Incoming Remote Transactions 
• Outgoing Remote Transactions 

• Machines hosting the App/Web Server Component 
• IIS Elements 

• Static Content 
• Default Document 
• Directory Browsing 
• HTTP Errors 
• ASP.NET 
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• .NET Extensibility 
• ISAPI Extensions 
• ISAPI Filters 
• HTTP Logging 
• Request Monitor 
• Basic Authentication 
• Windows Authentication 
• Request Filtering 
• Static Content Compression 
• IIS Management Console 
• IIS 6 Management Compatibility 

• Web Server (IIS) Tools 

Windows feature requirements for each component are tested by the Unified CCMP 
deployment utility contained on the DVD. Should the required features be missing 
then they may be configured by clicking on the Windows features enabled option 
from within the deployment tool.  

A summary of the software prerequisites for Unified CCMP is as follows. Some 
prerequisites software is distributed with Unified CCMP and will be installed 
automatically if it is missing from the server.  
 

 

Pre-requisite software that is not distributed with Unified CCMP is marked in bold in 
the list below and must be installed on the appropriate servers before the Unified 
CCMP installation is performed. 

Database Server Component 
• Windows Server 2008 R2 SP1 
• Microsoft SQL Server 2008 R2 SP1 64-bit Standard Edition 
• Microsoft SQL Server 2008 R2 Workstation Components  
• J2SE Runtime Environment 6.0 (Update 30) 

App/Web Server Component 
• Windows Server 2008 R2 SP1 
• ASP .NET State Service Enabled 
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General Guidelines 
• Do not install any Unified CCMP component on a domain controller. 
• Install Internet Explorer (IE) 7 or later on all the machines from which Unified 

CCMP will be accessed. 
• Unified CCMP does not support SQL Server named instances. All SQL Server 

installations must use the default instance name. 

Server Requirements 
• Unified CCMP servers should be configured to use the US English character set. 
• Unified CCMP server names must consist of alphanumeric characters only, 

without underscores or hyphens. 
• Using the Windows Time Service, ensure the date and time are synchronized 

across all Unified CCMP servers. Unified CCMP will not be able to synchronize 
application data correctly between servers otherwise, and this may cause 
unexpected behavior. 

• Configure Microsoft Terminal Services for remote configuration and support. 
• In the Event Viewer, set the Application Log, Security Log and System Log to 

Overwrite events as needed. 

Network and Environment Configuration 
This section describes the network interaction performed by the various components 
of Unified CCMP. Its content can be used by network administrators to configure 
network requirements to ensure that Unified CCMP obtains the required access levels 
for each component.  

IPV6 Support 
Unified CCMP runs on systems equipped with IPv6 hardware, but requires that all 
Unified CCMP Servers have an IPv4 address and IPv6 disabled on the NIC used by 
Unified CCMP. 

Firewalls 
In many Unified CCMP configurations, Firewalls will be deployed both between the 
Unified CCMP servers (to create a DMZ) and possibly between Unified CCMP DB 
servers and the Unified CCE AWs. Care must be taken in these configurations to 
ensure that the correct firewall ports are opened to both-way traffic. 

The Windows 2008 R2 platform incorporates its own software based firewall that 
must be configured to allow the various components of Unified CCMP to 
communicate with one another in a distributed environment. When configuring the 
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Windows firewall it is recommended that port restrictions are limited to only the 
servers that require the specified communications channels. 

The incoming firewall requirements for the Unified CCMP software components are 
listed in the tables below. 
 

 

These tables do not include standard Windows ports such as DNS and Kerberos. 
Ports are also required to access all Unified CCMP servers for support purposes 
(either Terminal Services or Remote Desktop). 

Web Server Port Usage 
 

Application 
Protocol/Service 

Protocol Incoming 
Ports 

Used by Usage 

HTTP TCP 80 End User Web application 

HTTPS TCP 443 End User Web application 

Unified CCMP Database Server Port Usage 
 

Application 
Protocol/Service 

Protocol Incoming 
Ports 

Servers Requiring 
Access 

Usage 

SQL Server TCP 1433 Database Servers and 
Application Servers 

General 

DTC TCP 2103 Database Servers Audit Archive 

DTC TCP 2105 Database Servers Audit Archive 

DTC (RPC) TCP 135 Database Servers Audit Archive 

DTC (RPC) TCP 5000-
5100** 

Database Servers Audit Archive 

NetBIOS File Share UDP 137-138 Database Servers and 
Application Servers 

Replication, Unified 
CVP File Upload 

NetBIOS File Share TCP 139 Database Servers and 
Application Servers 

Replication, Unified 
CVP File Upload 

SMB (DFS) TCP 445 Database Servers and 
Application Servers 

Unified CVP File 
Upload File*** 
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ConAPI Local Registry TCP 2099* Unified CCE Admin 
Workstation 

Provisioning 

ConAPI Local Port TCP 3333* Unified CCE Admin 
Workstation 

Provisioning 

* Default value for Side A - use configured in Cluster Configuration. 

** Dynamically assigned RPC port range used by MSDTC. Configured in registry: 
  HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet 
After each change the machine must be restarted. 

*** Only required if Unified CVP Media File Upload is configured. If configured, 
also ensure that required ports for the Distributed File Systems are open on the 
Domain Controller. 

Cisco Unified CCE Port Usage 
 

Application 
Protocol/Service 

Protocol Incoming 
Ports 

Servers Requiring 
Access 

Usage 

SQL Server TCP 1433 Database Servers and 
Application Servers 

Importing Dimension 
Data, Provisioning 
Activities, Real-time 
Reports.  

ConAPI Remote Registry TCP 2099* Database Servers Provisioning 

CMS Node UDP 9000 Database Servers Ping Port for ConAPI 
services 

Web Service API TCP 443 Database Servers Provisioning 

* Default value for Side A - use configured in Cluster Configuration. 

Domain Controllers for Unified CCE Instances Port Usage 
 

Application 
Protocol/Service 

Protocol Incoming 
Ports 

Servers Requiring 
Access 

Usage 

LDAP TCP 389 Database Servers and 
Application Servers 

Supervisor domain 
account provisioning 
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Cisco Unified CM Port Usage 
 

Application 
Protocol/Service 

Protocol Incoming 
Ports 

Servers Requiring 
Access 

Usage 

AXL Web Service 
(HTTPS) 

TCP 443 Database Servers Importing and 
Provisioning 

Other Information 
When configuring DTC and File Sharing on the Windows 2008 R2 firewall then the 
appropriate options within the Windows 2008 R2 Firewall Exceptions list may be 
selected. These options are labeled as follows: 
• Distributed Transaction Coordinator 
• File and Printer Sharing. 

Security Guidelines 
This section describes the security-related considerations for your installation. To 
secure your system, it is recommended that you take the following steps: 
• Disable anonymous sessions on all CCMP servers (see section ‘Disable 

Anonymous Sessions on all CCMP Servers’ on page 14 for instructions). This 
prevents anonymous users from enumerating usernames and shares, and using 
this information to guess passwords or perform social engineering attacks. For 
more information, consult the Microsoft documentation 
http://technet.microsoft.com/en-us/library/dd349805(WS.10).aspx#BKMK_38 
(checked May 2013). 

• Disable cached logins on all CCMP servers (see section ‘Disable Cached Logins 
on all CCMP Servers’ on page 15 for instructions). This prevents attackers from 
accessing the cached login information and using a brute force attack to 
determine user passwords. If cached logins are disabled, windows domain users 
will be unable to log in if the connection to the domain controller is unavailable. 
For more information, consult the Microsoft documentation 
http://technet.microsoft.com/en-us/library/dd349805(WS.10).aspx#BKMK_27 
(checked May 2013). 

• Configure SSL for the Portal application (see section ‘Securing Unified CCMP 
with SSL’ on page 48 for instructions). This ensures that all data passed between 
the client computer and the CCMP App/Web server is transmitted privately. 

http://technet.microsoft.com/en-us/library/dd349805(WS.10).aspx#BKMK_38
http://technet.microsoft.com/en-us/library/dd349805(WS.10).aspx#BKMK_27
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3. Windows and SQL Component Installation 

Windows – All Servers 

Turn off FIPS Compliance Checking 
Ensure that FIPS compliance checking is turned off. To do this: 

1. Click Start > All Programs > Administrative Tools > Local Security Policy 
from the start menu. 

2. Open Local Policies folder and click Security Options to see the list of policies. 

3. Ensure the policy System cryptography: Use FIPS compliant algorithms for 
encryption, hashing, and signing is disabled. 

4. Close the window. 

Disable UAC 
User Account Control (UAC) is a Windows feature that was introduced to protect the 
operating system from malicious programs. UAC must be disabled on all servers 
before Unified CCMP installation begins. If UAC is enabled it may cause issues with 
the software used to install Unified CCMP. To disable UAC perform the following 
steps: 

1. Click Start > Control Panel > User Accounts > User Accounts > Change 
User Account Control settings. 

2. Use slide bar to select Never Notify option to disable UAC. 

3. Click OK. 

4. Restart your machine to commit the new UAC settings. 

UAC can be safely re-enabled after Unified CCMP installation is complete. 
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SQL Server  
Follow these installation instructions to install SQL Server on the server(s) that will 
be hosting the Unified CCMP Database: 

1. When presented with the SQL Server Installation Center select the Installation 
menu option from the left of the window.  

2. Select New installation or add features to an existing installation. 

3. The Setup Support Rules window will display validating the system for the 
installation of SQL Server 2008 R2. Once validation passes click the OK button 
to proceed. 

4. Enter the product key for SQL Server 2008 R2 and click Next. 

5. Read the license terms for SQL Server 2008 R2, if you agree with the terms 
check the I accept the license terms checkbox and click Next. 

6. You will be prompted to install the Setup Support Files. Click Install. 

7. Once the Setup of Support Files is complete you will be presented with a 
summary of checks. Review the results and make any necessary changes. If you 
see a warning saying that Windows Firewall is enabled, you can safely ignore it. 
When you are satisfied, click Next to proceed. 

8. Select the SQL Server Feature Installation option and click Next. 

9. Select the following Instance Features: 
• Database Engine Services  

• SQL Server Replication  
• Client Tools Connectivity 
• Management Tools – Basic 

• Management Tools – Complete 

10. Update the installation directories to install in the required locations. Click Next. 

11. Installation Rules will then be checked. Correct any issues that have been 
flagged by the Installation Rules check and then click Next to proceed.  

12. The Instance Configuration window is displayed. Select Default Instance, with 
an Instance ID of MSSQLSERVER. Update the Instance root directory to be 
installed on the required drive, click Next to proceed.  

13. The Disk Space Requirements summary window is displayed, click Next.  

14. In the Server Configuration window, on the Service Accounts tab, set the 
following service configuration: 
• Locate the SQL Server Agent entry in the Service column, and set the 

corresponding Account Name to NT AUTHORITY\SYSTEM and the 
Startup Type to Automatic. 
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• Locate the SQL Server Database Engine entry in the Service column and set 
the corresponding Account Name to NT AUTHORITY\SYSTEM. 

15. In the Server Configuration window, on the Collation tab, ensure that the 
Database Engine is configured with Latin1_General_CI_AS (Latin1_General, 
Case In-sensitive, Accent Sensitive) collation. Click Next to proceed.  

16. The Database Engine Configuration window is displayed.  
• Select Mixed Mode authentication and enter a password for the sa user.  
• In the Specify SQL Server administrators panel click the Add Current User 

button. Also add any other accounts that require administrator permissions to 
the Database, for example, Domain Admins, Service Accounts etc.  

• Click Next to proceed. 

17. The Error Reporting window is displayed. Click Next to proceed.  

18. The Installation Configuration Rules window is displayed and installation 
checks are performed. Correct any reported problems and click Next to proceed.  

19. Review the installation summary and click Install to begin installing SQL 
Server 2008 R2. 

20. Once the installation is complete click the Close button. Installation of SQL 
Server 2008 R2 is complete.  

 

 

When the SQL Server 2008 R2 installation is complete, locate and install SQL 
Server 2008 R2 Service Pack 1 before proceeding. 

Post-Installation Configuration 

SQL Server – Database Server 

Configure Distributed Transaction Coordinator (DTC) 
Configure Distributed Transaction Coordinator (DTC) as follows: 

1. Click Start > All Programs > Administrative Tools > Component Services. 
The Component Services management tool is displayed. 

2. Expand Component Services > Computers > My Computer > Distributed 
Transaction Coordinator. 

3. Right-click on Local DTC and select Properties.  The Local DTC Properties 
window is displayed. 

4. Select Security tab. 
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• Ensure that Security Settings has Network DTC Access selected, and that 
Transaction Manager Communication has Allow Inbound and Allow 
Outbound selected. 

• Set Transaction Manager Communication to No Authentication 
Required. 

• Click OK and accept the prompt to restart the MSDTC Service. 

5. Close the Component Services window. 

Configure SQL Server Network Protocols 
To configure SQL Server network protocols follow these steps: 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > 
Configuration Tools > SQL Server Configuration Manager to open the SQL 
Server Configuration Manager. 

2. In the left hand pane, expand SQL Server Network Configuration and click 
Protocols for MSSQLSERVER.  

3. In the right hand pane right click on Named Pipes, select Enable, and click OK 
at the confirmation message. 

4. In the right hand pane, right click on TCP/IP, select Enable, and click OK at 
the confirmation message. 

5. In the left hand pane, click on SQL Server Services, then right click on SQL 
Server (MSSQLSERVER) and select Restart to restart the SQL Server 
process. 

6. Close the SQL Server Configuration Manager window. 

Configure Windows Server 2008 R2 Firewall for SQL Server 
By default the Windows Server 2008 R2 Firewall will not allow incoming traffic for 
SQL Server.  If the Windows firewall is enabled, follow these steps to create a rule to 
allow SQL Server traffic: 

1. Click Start > All Programs > Administrative Tools > Server Manager. 

2. In the left hand pane, expand Configuration > Windows Firewall with 
Advanced Security and click on Inbound Rules. A list of firewall rules is 
displayed. 

3. In the Actions pane, click New Rule.  The New Inbound Rule Wizard is 
displayed. 

4. Select Port as the rule type and click Next. 

5. Select TCP as the protocol and enter 1433 as the specific local port. Click Next. 
The Action options are displayed. 

6. Choose Allow the connection. Click Next.  The Profile options are displayed. 
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7. Select the profile options that are appropriate to your deployment and click 
Next. 

8. Enter a name for the rule and click Finish to create the rule. The new rule 
appears in the list of inbound rules as an enabled rule. 

9. Close the Server Manager window. 

SQL Server Backup Guidelines 
• Regularly backup the SQL Server databases and truncate transaction logs to 

prevent them becoming excessively large. 
• Schedule backups for quiet times of the day. 

Required User Accounts 

Unified CCMP Service Accounts 
Unified CCMP Services are installed to run under Windows system accounts (such as 
Network Service) by default.  

Accounts for Replication 
You will need to create the following domain user account for Unified CCMP. Using 
Active Directory, create this account with the following attributes: 
• Password never expires 
• User cannot change password 

sql_agent_user 
A domain account is used by SQL Server to replicate data between SQL Server 
databases. By default Unified CCMP assumes this will be sql_agent_user, but a 
different account name may be specified during installation. For a single-sided 
installation, Unified CCMP can create this account automatically as a local user. 

Optional Security Configuration 

Disable Anonymous Sessions on all CCMP Servers 
 

 

This step is optional, although it is recommended for maximum security. See section 
‘Security Guidelines’ on page 9 for more information. 

This security setting applies to all CCMP servers. There are several ways to 
configure this security setting. This section describes two possible ways.  

One way is to use the Group Policy Editor to view the following path 
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Computer Configuration\Windows Settings\Security Settings\Local 
Policies\Security Options 

then enable the setting  
Network access: Do not allow anonymous enumeration of SAM accounts 
and shares. 

Alternatively, you can update the registry directly as follows: 

1. From the Windows Start Menu, click Run, then type regedit. 

2. In the left hand pane, select the 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa 
node. 

3. In the right hand pane, if the REG_DWORD value restrictanonymous is 
present, set it to 1, otherwise, create it and set it to 1. Click OK. 

4. Close the registry editor. 

Disable Cached Logins on all CCMP Servers 
 

 

This step is optional, although it is recommended for maximum security. See section 
Security Guidelines’ on page 9 for more information. 

This security setting applies to all CCMP servers. There are several ways to 
configure this security setting. This section describes two possible ways.  

One way is to use the Group Policy Editor to view the following path  
Computer Configuration\Windows Settings\Security Settings\Local 
Policies\Security Options  

then set the following setting to 0 
Interactive logon: Number of previous logons to cache (in case domain 
controller is not available). 

Alternatively, you can update the registry directly as follows: 

1. From the Windows Start Menu, click Run, then type regedit. 

2. In the left hand pane, select the 
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows 
Nt\CurrentVersion\Winlogon node. 

3. In the right hand pane, if the REG_SZ value CachedLogonsCount is present, 
set it to 0, otherwise, create it and set it to 0. Click OK. 

4. Close the registry editor. 
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4. Unified CCMP Component Installation 

Planning Your Installation 
For dual-sided systems, perform a complete installation on the Side A servers, and 
then a complete installation on the Side B servers. It is recommended that you install 
the components in the order described here. 

Recording Your Settings 
During the installation procedure, there will be occasions where you need to record 
what settings you chose for later reference. It is recommended that you store the 
following information in a secure location, for future reference: 
 

System Settings 

Database Catalog Name  

sql_agent_user Password  

Cryptographic Passphrase  

Administrator Password  

Java.RMI.Hostname  

Unified CCE  

Application Name  

Application Key  

RMI Registry Port  

LocalPort  
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The Unified CCMP Installer 

Start the Unified CCMP Installer 
1. Insert the Unified CCMP DVD. If auto-run is enabled on the server, a window 

opens automatically showing a list of Unified CCMP components under the 
heading ‘Server Installation’ on the left hand side.  

 

 

If auto-run is disabled and you do not see the Installation Components screen, 
double-click the autorun.bat file located on the DVD to launch the Unified CCMP 
installer manually. 

  

If UAC has not been disabled, launch the installation manually by right-clicking on 
the autorun.bat file located on the DVD and selecting run as administrator option. 

 

Some anti-virus software may state that the autorun.hta script file is malicious. 
Please ignore and continue with the installation. 

2. Follow the steps in the sections below to install each component, but read the 
information about prerequisites in the rest of this section first.  

Before you can install a Unified CCMP component, the prerequisites for that 
component must be present. The Unified CCMP Installer checks the prerequisites for 
each component as follows:  

• When you click on a component to install it, the installer displays a list of 
prerequisites for that component and checks that each prerequisite is present. 
As each prerequisite check completes, you will see a green tick (check 
successful) or a red cross (check failed). The Install option for that 
component is only available when all prerequisite checks are successful. 

• Where possible, the Unified CCMP DVD includes redistributable packages 
for prerequisites, so if a prerequisite check fails, you can click on the link in 
the Unified CCMP Installer to install the missing prerequisite. Once all the 
prerequisite software is installed, you can click on the component again, then 
click Rerun to rerun the tests. 

• When all the prerequisites display a green tick, you will be able to click 
Install to install the chosen component. 

Unified CCMP Database Server Installation 
This section details how to install the Unified CCMP Database Server component. 

Install the Database Installer 
This process does not install the database directly. It just installs the Database 
Installer which is then used to install the database.  
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On the Side A Database Server: 

1. To install the Unified CCMP Database Installer, in the Unified CCMP Installer, 
select Database Server, and wait until the prerequisite checks have completed. 
If any checks fail, fix them as described above. When all checks have passed, 
click Install to begin the Database Server Installation. The Setup window 
displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 

4. In the Cryptography Configuration window: 
• Passphrase Create a cryptographic passphrase of between 6 and 35 

characters. This passphrase is used for encrypting and decrypting system 
passwords and must be the same for all servers in the Unified CCMP 
installation. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

The cryptographic passphrase is a vital piece of information and will be needed when 
installing later components and when adding or replacing servers in the future. Be 
sure to record and retain it. 

If you are upgrading from a previous version of Unified CCMP, or adding a new 
server to an existing cluster, you must use the same cryptographic passphrase as was 
originally used. If you do not know the cryptographic passphrase, stop the 
installation immediately and contact your vendor. If you continue the installation 
with a new passphrase you will be unable to access your existing data. 

5. In the Configure Database window: 
• Catalog Name Enter the name for the database catalog that will be used for 

Unified CCMP. It is recommended that you use the default name of Portal. 
• Connect Using Select the login credentials you want to use: 

• Windows Authentication Credentials of Application This is the 
recommended option 

• SQL Server authentication using the login and password below. This 
option should only be selected if you are using a database catalog on a 
different domain. For this option you must enter your SQL Server Login 
ID and Password in the fields provided. 

• Click Next. 
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6. In the Destination Folder window, you can click Change to change the location 
for the installation of the Database Server. It is not necessary to install all 
Unified CCMP components in the same location. 

7. Click Install. 

 

During the Database Install Tool Installation, the J2SE pre-requisite will be 
automatically installed if it is not already present.  A Security Alert dialog box stating 
that ‘Revocation Information for the security certificate for this site is not available’ 
may be displayed in some circumstances. If this dialog box appears click Yes to 
continue. 

8. When the installation has completed, if you want to set up your database now, 
check the Launch Database Management Utility (or Database Installer) 
check box. You can also set up your database manually at a later date. 

9. Click Finish. 

Database Setup 
If you selected the Launch Database Management Utility check box after installing 
the Database component, the database setup wizard will launch automatically. 
Otherwise you can launch the database install tool manually from Start > All 
Programs > Management Portal > Database > Database Installer. 

The wizard will guide you through the process of installing a database. 

1. Click Next to go through each window in turn. You will need to enter the 
following details: 

2. In the Select an Action to Perform window: 
• Install a new database You can maintain this database at a later date by 

running the installer again and selecting the appropriate option. 

3. In the SQL Server Connection Details window: 
• Server Name Enter the name of the machine that is to be the Database 

Server. This should normally be left as the default (local). 
• Database Name Enter or select the name of the database catalog that will be 

used for Unified CCMP. It is recommended that you use the default name of 
Portal. This should match the database catalog name specified when you 
installed the database installer. If not, you will see a warning message. 

• Connect Using. Select the login credentials you want to use: 
• The Windows account information I use to logon to my computer. 

This is the recommended option. 
• The SQL Server login information assigned by the system 

administrator. This option should only be selected if you are using a 
database catalog on a different domain. For this option you must enter 
your SQL Server Login Name and Password in the fields provided. 
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• Click Test Connection. This makes sure the connection to the SQL Server is 
established. If the connection can be established, you will see the message 
‘Connection succeeded but database does not exist’.  

• Click Next to continue. 

4. In the Setup Replication window, if this database installation is not side B of a 
replicated system, just click Next. If this database installation is side B of a 
replicated system, select Replicated Configuration and set up the replication 
folder share as follows: 
• Share Name The name of the share for the ReplData folder. By default this 

is ReplData. 
• Folder Path The path of the ReplData folder. This is configured in SQL 

Server, and is by default C:\Program Files\Microsoft SQL 
Server\MSSQL\repldata. 

• Click Next when you have finished. 

5. In the Configure the Location of Data Files window, if you are not using a 
custom installation of SQL Server, accept the defaults and click Next. If you are 
using a custom installation of SQL Server, configure the data files as follows: 
• Select the check box or boxes beside the file group or file groups you want to 

change. 
• To change the Location, browse to the new location. 
• To change the Max Size, specify the amount of space that should be 

allocated for the chosen file group or file groups. The default value is based 
on Unified CCMP’s analysis of your system. 

• To specify a different Initial Size, first uncheck Set Initial Size to Max Size,  
• You can also choose an unlimited file size by selecting Unrestricted Size, 

but this is not recommended. 
• Click Update to save your changes to the selected file group or file groups. 
• Click Default (in the top right corner of the window) to restore the settings 

for all file groups to their default. 
• Click Next when you have finished. 

6. The Configure SQL Server Agent Service Identity window sets up a user 
account that is used by SQL Server for replication: 
• Account Type The type of user account that will be used. For a distributed 

installation, this must be Domain. 
• User Name The name of the user account. This defaults to sql_agent_user. 

If you used a different name when setting up the account, enter that name 
instead. If you have specified a domain user, you will need to prefix the user 
name with the domain name, followed by a backslash. 
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• Automatically create the user account if missing If you have not already 
created the user account on the domain, set it up now as described in section 
Accounts for Replication on page 14 before continuing. For a single-sided 
single server system, it is possible to create a local user automatically by 
selecting this check box. Use of a local user will mean system re-installation 
when adding a second side in the future. 

• Password Create a password for the new user, conforming to your individual 
system’s complexity requirements. 

• Confirm Password You will not be able to continue until the contents of this 
field are identical to the password entered above. 

• Click Next. 

7. In the Web Application Servers Network Service Configuration window, 
enter the details of each remote App/Web Server to be used in the installation. 
This information only needs to be entered in Unified CCMP deployment models 
where the web application servers are on a different machine from the database 
server itself. 
• Domain The network domain the web server is on, for example ACMEDOM 
• Machine Name The name of the machine, for example WEBSERVERA 
• Click Add to add each Web Server to the list. 
• When all Web Servers have been added, click Next. 

8. In the Ready to install the Database window, click Next to begin installation. 
Installation will take several minutes. 

9. Click Close to close the installer. 

Database Replication 
For replicated systems this installation needs to be repeated for side B. It is 
recommended that you complete the side A installation of all components before 
installing side B. 

See section Configuring Replication in Chapter 5 for information about configuring 
database replication. 

App/Web Server Component 
In most installations, the App/Web Server component should be installed on a 
different physical machine to the Database Server component. 

This section details how to install and configure the Unified CCMP App/Web 
component. 
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App/Web Installation 

1. To install the Unified CCMP App/Web component, in the Unified CCMP 
Installer, select App/Web Server, and wait until the prerequisite checks have 
completed. If any checks fail, fix them as described above. When all checks 
have passed, click Install to begin the App/Web Server installation. The 
Management Portal: Application Server Component window displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. If the Management Portal: Application Server Components Dialog is displayed, 
click Install to install the additional required components. 

4. If the Microsoft .NET 4.5 Framework pre-requisite is missing, it will be installed 
at this point. Click Install to install the component and follow the on screen 
instructions. When the .NET 4.5 Framework is complete, restart the server to 
continue the installation of the App/Web Server. 

5. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 

6. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component. 
• Confirm Passphrase You will not be able to continue until the contents of 

this field are identical to the passphrase entered above. 
• Click Next to continue. 

 

 

You must use the same cryptographic passphrase for all servers in the Unified CCMP 
installation. If you do not know the cryptographic passphrase, stop the installation 
immediately and contact your vendor. If you continue the installation with a new 
passphrase you will be unable to access your existing data. 

7. In the Destination Folder window, you can click Change to change the location 
that the App/Web Server components are installed to. Click Next to continue. 

8. In the Configure Database window: 
• SQLServer Name Enter the name of the machine that is to be the Database 

Server. The default of localhost is valid only when installing on the Database 
Server. Otherwise, specify the name of the machine where you installed the 
database above. For a dual-sided system enter the name of the side A 
database server when installing the side A App/Web Server Components and 
enter the name of the side B database server when installing the side B 
App/Web Server Components. 
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• Catalog Name Enter or select the name you selected while installing the 
Database Server component. By default this is Portal. 

• Connect Using Select the login credentials you want to use: 
• Windows authentication. This is the recommended option. 
• SQL Server authentication. This option should only be selected if you 

are using a database catalog on a different domain. For this option you 
must enter your SQL Server Login Name and Password in the fields 
provided. 

• Click Next to continue. 

9. Click Install. 

10. When the installation has completed, click Finish. 
 

 

The machine will restart once the installation is complete.  

Support Tools 
Unified CCMP includes support for integration with the Cisco Real Time Monitoring 
Tool (RTMT). This allows remote monitoring and support for your Unified CCMP 
installation. To use RTMT you need to install the Diagnostic Framework component 
of Unified CCMP which provides access to relevant support APIs.  These APIs can 
be used by the RTMT for gathering trace levels, log files etc. 

1. To install the Diagnostic Framework component, start the Unified CCMP 
Installer, click Support Tools and select Diagnostic Framework. The 
Management Portal: Diagnostic Framework InstallShield Wizard window 
displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 

• Click Next. 

4. In the Destination Drive window click Update to change the default drive where 
the Diagnostic Framework will be installed. Click Next when you have finished. 

5. In the Select Certificate window, select the type of certificate installed with the 
Diagnostic Framework.  
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• Self-Signed Certificate – A new certificate will be generated by the installer. 
This type of certificate should be used only for lab or test deployments. 

• Trusted Certificate – An existing certificate issued by a valid certificate 
server will be associated at a later date. This option should be used for 
production deployments.  

• Click Next. 

6. Click Install. 

7. When the installation is completed, click Finish.  

The installation of the Diagnostic Framework component is now complete. 

 



Chapter 5: Unified CCMP Component Configuration  
Configuring Unified CCE Admin Workstations  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  25   

 

 

5. Unified CCMP Component Configuration 
Unified CCMP will normally be hosted on multiple servers for performance and data 
security. This chapter describes how to configure the server cluster and perform data 
replication. It also provides performance tuning checklists for the Web and Database 
components. 

This section describes the following steps: 
• configuring Unified CCE admin workstations 
• configuring Unified CCE Admin workstations for provisioning 
• configuring the Unified CCMP cluster 
• configuring replication 
• configuring unified CVP media file upload. 

Configuring Unified CCE Admin Workstations 
 

 

If Unified CCMP uses SQL Server Authentication to connect to Unified CCE no 
configuration of the AWDB is required. However, the SQL login used for the 
connection must have the appropriate permissions on the AWDB and the HDSDB. 

If SQL Server Authentication is not in use for AW SQL connections then the 
following configuration is required: 

1. Login to the AW as a user with local administrative privileges. 

2. Open the SQL Server Management Studio, by clicking Start > All Programs > 
Microsoft SQL Server > SQL Server Management Studio Connect to the 
server. 

3. Open up the Security folder, and right-click Logins. 

4. Select New Login from the drop-down list. The Login – New window displays. 

5. Add SQL logins for the Network Service accounts of each server hosting 
Unified CCMP (Database Servers and App/Web Servers), by filling in the fields 
as follows: 
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• General page: 
• Login Name, enter the machine name in the form 

<DOMAIN>\<MACHINENAME>$, for example 
ACMEDOM\ACMEWEBA$. This configures access for the 
NETWORK SERVICE account from the Unified CCMP server. 

• Authentication, select Windows Authentication unless connecting to a 
server on a different domain 

• User Mapping page: 
• Users mapped to this login. select the checkboxes for AWDB and 

HDSDB 
• Database role membership for. AWDB and HDSDB, check the Public 

and db_datareader checkboxes. 

6. Click OK. 

Configuring Unified CCE Admin Workstations for Provisioning 
Cisco Unified Contact Center Enterprise (Unified CCE) components must be 
correctly configured before Unified CCMP can connect to them for Provisioning. 

Configuration Overview 
For each Unified CCE instance that Unified CCMP Resource Management connects 
to, certain essential criteria must be met: 
• Unified CCMP Resource Management uses Cisco ConAPI for the Provisioning 

connections; this interface requires that ALL connections are made to a Primary 
Distributor AW. If the AW is dual-sided, both sides must be Primary 
Distributors. 

An Application Instance must be configured on each AW for Unified CCMP to 
connect to. If support for provisioning multimedia resources is required, the 
Application Instance must be configured to Application Type: <Other> instead of 
the standard Cisco Voice.  

Multiple Unified CCE instances can be supported, but each requires a distinct 
primary Distributor AW to connect to: 
• ConAPI only supports connection to one Application Instance on each physical 

server. You must therefore have a separate physical AW distributor for each 
instance. 

• Parent/Child AW configurations are Supported as multiple instances in Unified 
CCMP. 

 

 

Please contact your vendor if you have any queries about this configuration. 



Chapter 5: Unified CCMP Component Configuration  
Configuring Unified CCE Admin Workstations for Provisioning  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  27   

 

Before beginning cluster configuration, you must set up the ConAPI application 
instance and the CMS server on your Unified CM and Unified CCE instances. 
 

 

This is only necessary on deployments that include resource management. 

Common ConAPI Credentials 
To create an application instance, you must run Configuration Manager on the 
Unified CCE AW as follows: 

1. Open Configuration Manager. This can normally be done from Start > 
Program Files > Cisco Unified CCE Tools > Administration Tools > 
Configuration Manager 

 

If you are connecting to the Unified CCE server using Remote Desktop, you will 
need to set the /admin switch in order to run Configuration Manager. 

2. Under Tools > List Tools you will find the Application Instance List. Double-
click this to open it. 

3. Click Retrieve to display the list of configured application instances. You can 
use an application instance from this list for Unified CCMP or create a new one. 
To create a new application instance, click Add, and enter the following details: 
• Name A unique name to be used for the application instance. 
• Application Key A password to be used by Unified CCMP to connect. This 

may be between 1 and 32 characters. 
• Confirm Application Key Ensure that no typographical errors were made 

while choosing the application key. 
• Application Type Select Cisco Voice. 
• Permission Level Give the application full read/write permissions. 

4. Record these details for use during the configuration of the cluster. 

5. Click Save and then click Close. 

CMS Server Setup 
Before configuring the Unified CCMP server cluster you must ensure that the CMS 
Server(s) are set up correctly on each Unified CCE. 

Firstly, check that the CMS Node option was selected when the Admin Workstation 
was configured. You can determine if this was the case by looking for a cmsnode and 
a cms_jserver process running on the Unified CCE. 

If these processes are not present, set the CMS Node option on the Unified CCE. See 
the Cisco Unified CCE Installation Guide for details on how to do this. 
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A new application connection must be defined on each configured Unified CCE 
instance for each Database Server (this connection is used by the Data Import Server 
component). This ensures that in a dual-sided system, the alternate side can also 
connect to the Unified CCE in a failover scenario. To do this: 

1. On the Unified CCE being configured, go to Start > Program Files > Cisco 
Unified CCE Tools > Administration Tools > CMS Control on the Unified 
CCE being configured. This opens the CMS control console. 

2. Click Add to the right hand side of the window to launch the Application 
Connection Details window and fill in the fields as follows: 
• ICM Distributor AW link This should be the name of the Unified CCMP 

Database Server, all in capital letters, with ‘Server’ appended, such as 
CCMPDBServer. 

• ICM Distributor AW RMI registry port This is the port on the Unified 
CCE AW for the Unified CCMP Provisioning service to connect to. This will 
usually be 2099, however if the Unified CCMP Provisioning service is 
connecting to multiple Unified CCE instances each should use a different 
port. 

• Application link This should be the name of the Unified CCMP Database 
Server, all in capital letters, with ‘Client’ appended, such as CCMPDBClient. 

• Application RMI registry port This is the port on the Unified CCMP 
Database Server for the Unified CCE AW to connect to. For convenience, 
this should be the same as for the ICM Distributor AW RMI registry port. 
Each Unified CCE AW must connect to a different port on the Database 
Server. You should record this information for future use. 

 

 

Each Unified CCE that Unified CCMP will be provisioning must use a unique port 
on the Database Server. 

• Application host name The server name, such as CCMPAppServer. 

3. Click OK, and OK again to cycle the CMSJServer, save your changes and close 
the CMS control console. 

Configuring the Unified CCMP Cluster 
Use the Cluster Configuration tool in the Unified CCMP Integrated Configuration 
Environment (ICE) to: 
• configure the servers in the Unified CCMP cluster (the Unified CCMP servers, 

Unified CCEs and Unified CMs) 
• set up the equipment mappings between remote tenants and Unified CCMP 

resources. 
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Follow the instructions in this section to configure your system when you first install 
it. For more information about using the ICE tools to modify your system 
configuration at a later date, see the Integrated Configuration Management section of 
the Administration Guide for Cisco Unified Contact Center Management Portal. 

Starting the ICE Cluster Configuration Tool 
To start ICE, on the A Side database server: 

1. Go to Start > All Programs > Management Portal > Configuration Tools > 
Integrated Configuration Environment. 

2. The Database Connection window is displayed. In this window specify the 
following: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Ensure this option is set to Windows Authentication. 

3. Click OK to open ICE. When ICE starts, the Cluster Configuration tool is 
loaded as the default tool. You can use the Tool drop-down in the toolbar to 
switch to other ICE tools. 

Setup Servers 
The Setup tab of the ICE Cluster Configuration tool displays setup wizards to 
configure the following cluster components: 
• Unified CCMP Servers 
• Cisco Unified CCE Servers 
• Cisco Unified CM Servers 
• Cisco Unified CVP Servers. 

To start setting up your servers, in the ICE Cluster Configuration tool, select the 
Setup tab in the left hand pane. This displays a series of wizards to set up the servers. 
The following sections explain how to use each of the wizards. 

Setup Unified CCMP Servers Wizard 
The Setup Unified CCMP Servers wizard configures the servers on which Unified 
CCMP components are installed. The wizard guides you through the steps to 
configure all Unified CCMP components based on your chosen deployment model.  
 

 

If you plan to use windows authentication to connect to the Unified CCMP database 
(rather than SQL authentication), you must have administrator permission on the 
database server on which the application is running.  
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The exact windows displayed by the wizard may depend on the options you choose 
as you complete each step below. 

To set up the Unified CCMP servers: 

1. In the ICE Cluster Configuration tool, select the Setup tab and click Setup 
UCCMP Servers to start the wizard. Click Next to go through each window in 
turn. 

2. In the Select Deployment Type dialog box select your chosen deployment type. 
For more information on the supported deployment models of Unified CCMP 
see section Deployment Models. 

3. In the Configure Redundancy dialog box select whether you would like to 
configure a single-sided or a dual-sided system. Click Next. 

4. If you are performing a two tier deployment then you will be asked to enter the 
Number of Web Servers for each side. Enter the number of app/web servers for 
each side that you would like to configure in your deployment. For dual-sided 
configurations you must configure an equal number of app/web servers on each 
side of the system. Click Next. 

5. Click Next.  

6. In the Configure Servers dialog boxes, enter the server names for each of the 
Unified CCMP servers. The number of dialog boxes and servers to specify will 
depend on the deployment options you chose above.  

7. In each dialog box, enter the following, then click Next: 
• Primary Server 

• Sever Name: This is the non-domain qualified machine name. 
• Server Address: This is defaulted to Server Name. This can be changed 

to an IP Address or a domain qualified name of the server. 
• Secondary Server: 

• If you chose a dual-sided setup, provide the corresponding details for the 
side B server. 

8. Click Next and enter the relevant server information until you reach the 
Configure Relational Database Connection dialog box. 

9. In the Configure Relational Database Connection dialog box enter the 
following details about how each Unified CCMP component connects to the 
Unified CCMP Relational database: 
• Catalog: This is the name of the Unified CCMP Relational database. The 

default is Portal. 
• Authentication: Select the authentication mode to connect to Unified CCMP 

relational database. 
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• Windows Authentication. The default recommended authentication 
mode. 

• SQL Authentication. Only select this option if you are using a database 
server on a different domain. For this option you must enter your SQL 
Server Login Name and Password in the fields provided. 

• Click Next. 

10. The Deployment Summary dialog box summarizes the choices you have made. 
If you want to print the deployment summary, click the Print button below the 
summary list.  

11. Check the deployment details, and if you are satisfied, click Next. 

12. A confirmation message is displayed to indicate that the wizard has completed 
successfully. Click Exit to close the wizard. 

13. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

 

 

Once you have made the required configuration changes, stop and restart all Unified 
CCMP services to ensure that all changes are propagated correctly. If you are 
planning to make other setup changes, you can wait until you have completed all 
your changes, and then stop and restart the Unified CCMP services once. 

Configure Cisco Unified CCE Servers Wizard  
The Configure Cisco Unified CCE Servers wizard configures Cisco Unified CCE 
instances. This wizard guides you through the steps to: 
• add a new Cisco Unified CCE instance to the deployment 
• update an existing Cisco Unified CCE instance in the deployment 
• remove an existing Cisco Unified CCE instance from the deployment.  

Unified CCE Deployment Models 
Unified CCE offers a number of different deployment models depending on 
customers’ requirements. Unified CCMP supports the following Unified CCE 
deployments: 
• Administration Server and Real-time Data Server (AW) 
• Configuration-only Administration Server  
• Administration Server and Real-Time and Historical Data Server (AW-HDS)  
• Administration Server, Real-Time and Historical Data Server, and Detail Data 

Server (AW-HDS-DDS) 
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Unified CCMP Connection Requirements 
To configure the different deployment models Unified CCMP requires a connection 
to: 
• Unified CCE real-time AWDB for data import 
• Unified CCE AW for Unified CCMP Provisioning Server requests.  
 

 

This wizard attempts to connect to Cisco Unified CCE Servers using SQL 
Connection. The connection credentials should be known prior to starting the 
configuration. 

 

If you require resource management (provisioning), you will also need to know the 
login details for a user with appropriate access to the Unified CCE used for 
provisioning. On the domain controller, this user must be in the domain security 
group <Server>_<UCCE-Instance>_Config, where <Server> is the name of the 
server running Unified CCE and <UCCE-Instance> is the name of the Unified CCE 
Instance on this server. 

To configure the Cisco Unified CCE servers: 

1. In the ICE Cluster Configuration tool, select the Setup tab and click Configure 
Cisco Unified CCE Servers to start the wizard. Click Next to go through each 
window in turn. 

2. In the Select Task dialog box select the action. The options are: 
• Add a new instance 
• Modify an existing instance 
• Remove an existing instance 

 

 

The Modify and Remove options are only enabled if at least one Cisco Unified CCE 
has already been configured.  

3. In the Specify Resource Name dialog box, specify the name for the instance 
being configured. You can use the default name or choose another name. 

4. In the Select Required Components dialog box, select all the required 
components in the deployment. 
• Admin Workstation. Select this component for all configurations. 
• ConAPI Server (Provisioning). Select this component if you require 

resource management. 

5. In the Configure Redundancy dialog box, select whether you want to configure a 
single-sided or a dual-sided setup. 

6. In the Configure AW Server dialog box, enter the following: 
• Primary Server: 
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• Sever Name: This is the non-domain qualified machine name where the 
Admin Workstation and ConAPI components are deployed. 

• Server Address: This defaults to Server Name. This may be changed to 
an IP Address or a domain qualified name of the server. 

• Secondary Server: 
• If you chose a dual-sided setup, provide the corresponding server details 

for the side B server. 

7. In the Configure Connection Details dialog box, enter the authentication details 
to connect to the Admin Workstation database. 
• Windows Authentication. This is the default recommended authentication 

mode. 
• SQL Authentication. If this mode is chosen then specify the SQL Server 

User name and the corresponding password to connect to the databases. 

8. In the Select Unified CCE Instance dialog box select the AW instance to be used 
in the deployment. Click Next. 

9. If you selected the ConAPI Server (Provisioning) option above then you will 
see the following dialog boxes: 
• In the Configure Primary Unified Config Web Service dialog box (only 

shown when the Unified CCE instance is running Unified CCE version 9.0 or 
later), enter the following details 
• URL. This is the auto-generated URL of the primary unified config web 

service on the Unified CCE 
• User Name. This is a username with appropriate access to the Unified 

CCE that the web service is running on. This user must be in the domain 
security group <Server>_<UCCE-Instance>_Config, where <Server> 
is the name of the server running Unified CCE and <UCCE-Instance> is 
the name of the Unified CE Instance on this server. For Unified CCE 
version 9.0(1) or 9.0(2), enter the username as <domain>\<user> and for 
Unified CCE version 9.0(3) or later, enter the username as 
<user>@<domain>, where <user> is the Unified CCE username, and 
<domain> is the name of the domain. 

• Password. This is the password for the user. 
• In the Configure Primary ConAPI RMI Ports dialog box enter the following 

ConAPI details: 
• Local Registry Port. This is the port on the Unified CCE for the Unified 

CCMP Provisioning service to connect to. This will usually be 2099. 
• Remote Registry Port. This is the port on the Unified CCMP Database 

Server for the Unified CCE to connect to. This will usually be 2099. 
• Local Port. This is selected as the designated port for live provisioning 

traffic between the Unified CCE and Unified CCMP servers. It must be 
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uniquely assigned for each Unified CCE and any firewalls between the 
CICM and Unified CCMP server must be configured to allow both-way 
traffic on this port. 

 

 

If dual-sided setup is being configured you will need to provide these details for the 
Secondary (Side B) server in the next window. 

• In the Configure ConAPI Application Instance dialog box enter the following 
details: 
• Application Name. The name of the application to be used for 

provisioning Unified CCE from Unified CCMP. Specify the name of the 
application you configured in section Common ConAPI Credentials. 

• Application Key. Use the password for the application you specified 
above. 

• In the Multi Media Support dialog box, select Yes if you are using a Cisco 
Unified Web and E-Mail Interaction Manager application instance to provide 
support for non-voice interactions. The default is No. 

• In the Purge On Delete dialog box select Yes if you want to purge items from 
Unified CCE automatically when they are deleted from Unified CCMP. The 
default is Yes. 

• In the Self Skilling Enabled dialog box select Yes if you want to allow agents 
to reskill themselves. The default is No. 

• In the Supervisor Active Directory Integration dialog box select Yes if you 
want to enable support for associating existing Active Directory user 
accounts for Unified CCE Supervisors. The default is No. If you select Yes 
then you will be prompted to provide Active Directory information so that 
Windows user accounts can be listed.  

10. In the Configure Linked Unified CM Servers dialog box select the configured 
Unified Communications Manager servers that the Unified CCE being 
configured is capable of routing calls to.  

 

 

The Configure Linked Unified CM Servers window only appears if at least one 
Unified CM server is already configured. You will be able to link the Unified CM 
servers to the Unified CCE from the Unified CM Configuration Wizard. You may 
also modify the Unified CCE once the Unified CM servers are configured and link 
the Unified CM later. 

11. The Summary dialog box summarizes the details of the Unified CCE being 
configured and the settings you have chosen. If you want to print the summary, 
click the Print button below the summary list.  

12. Check the details, and if you are satisfied, click Next. 
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13. A confirmation message is displayed to indicate that the wizard has completed 
successfully. Click Exit to close the wizard. 

14. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

Configure Cisco Unified CM Servers Wizard 
The Configure Cisco Unified CM Servers wizard configures Cisco Unified CM 
instances. This wizard guides you through the steps to: 
• add a new Cisco Unified CM instance to the deployment 
• update an existing Cisco Unified CM instance in the deployment 
• remove an existing Cisco Unified CM instance from the deployment.  

To configure the Cisco Unified CM servers: 

1. In the ICE Cluster Configuration tool, select the Setup tab and click Configure 
Cisco Unified CM Servers to start the wizard. Click Next to go through each 
window in turn. 

2. In the Select Task dialog box, select the action. The options are: 
• Add a new instance 
• Modify an existing instance 
• Remove an existing instance 

 

 

The Modify and Remove options are only enabled if at least one Cisco Unified CM 
has already been configured. 

3. In the Specify Resource Name dialog box, specify a name for the instance being 
configured. You can use the default name or choose another name. 

4. In the Configure Unified CM Servers dialog box enter the following: 
• Primary Server 

• Sever Name: This is the non-domain qualified machine name where the 
Cisco Unified CM components are deployed. 

• Server Address: This defaults to Server Name. This can be changed to 
an IP Address or a domain qualified name of the server. 

 

 

When configuring a Unified CM Cluster ensure that only the publisher of the cluster 
is configured.  

 

Redundancy is not supported for Unified CM configuration. The Secondary Server 
option is always disabled. 
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5. In the Select Version dialog box select the version of Unified CM being 
configured from the drop-down list. 

6. In the Connection Details dialog box enter the following details: 
• URL. This is used to access the Unified CM AXL interface. The default is 

the default URL for the Unified CM version that has been selected. It is 
recommended that you use the default URL. 

• User Name. This is the name of the Unified CM Administrator user. This is 
the user name that the Unified CCMP components use when connecting to 
the Unified CM AXL web service. 

• Password. This is the Unified CM Administrator user’s password. 

7. In the Configure Linked Unified CCE Servers dialog box select the configured 
Cisco Unified CCE servers that can route calls to the Unified CM being 
configured. 

 

 

The list will be empty if no Cisco Unified CCE servers have been configured. You 
will be able to link the Unified CM server to the Unified CCEs from the Cisco 
Unified CCE Configuration Wizard. You can also modify the Unified CM once the 
Cisco Unified CCE servers are configured and link the Unified CM later. 

8. The Summary dialog box summarizes the details of the Unified CM being 
configured and the settings you have chosen. If you want to print the summary, 
click the Print button below the summary list.  

9. Check the details, and if you are satisfied, click Next. 

10. A confirmation message is displayed to indicate that the wizard has completed 
successfully. Click Exit to close the wizard. 

11. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

Configure Cisco Unified CVP Servers Wizard 
The Configure Cisco Unified CVP Servers wizard configures Cisco Unified CVP call 
server instances. This wizard guides you through the steps to: 
• add a new Cisco Unified CVP instance to the deployment 
• update an existing Cisco Unified CVP instance in the deployment 
• remove an existing Cisco Unified CVP instance from the deployment.  

Configuring a Cisco Unified CVP Call Server 
To configure a Cisco Unified CVP call server: 

1. In the ICE Cluster Configuration tool, select the Setup tab and click Configure 
Cisco Unified CVP Servers to start the wizard. Click Next to go through each 
window in turn. 
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2. In the Select Task dialog box select the action. The options are: 
• Add a new instance 
• Modify an existing instance 
• Remove an existing instance 

 

 

The modify and remove options are only enabled if at least one Cisco Unified CVP 
call server has already been configured. 

3. In the Specify Resource Name dialog box, specify a name for the instance being 
configured. You can use the default value, or change it. 

4. In the Configure Unified CVP Server dialog box enter the following: 
• Primary Server: 

• Sever Name: This is the non-domain qualified machine name where the 
Cisco Unified CVP Call Server component is deployed. 

• Server Address: This defaults to Server Name. You can change this to 
an IP Address or a domain qualified name of the server. 

 

 

The Unified CVP Call Server configuration does not support redundancy, so the 
Secondary Server option is always disabled. 

5. In the Configure Unified CCE Server dialog box, select the Unified CCE that is 
linked to the Unified CVP being configured. 

6. The Summary dialog box summarizes the details of the Unified call server being 
configured and the settings you have chosen. If you want to print the summary, 
click the Print button below the summary list.  

7. Check the details, and if you are satisfied, click Next. 

8. A confirmation message is displayed to indicate that the wizard has completed 
successfully. Click Exit to close the wizard. 

9. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

Create Tenants and Map to Contact Center Equipment 
The Equipment Mapping tab of the ICE Cluster Configuration tool allows you to 
create new tenants and folders and associate them with the contact center equipment 
you have just configured. Use this tool to: 
• create the Unified CCMP folder structure for your deployment 



Chapter 5: Unified CCMP Component Configuration  
Configuring the Unified CCMP Cluster  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  38   

 

• specify the rules for importing resources into your Unified CCMP folder 
structure from the contact center equipment (for example, Unified CCE, Unified 
CM). 

Creating Tenants and Folders 
To create a Unified CCMP tenant: 

1. In the ICE Cluster Configuration tool, select the Equipment Mapping tab. In 
the center pane, right click on the root node and select Add Tenant. 

2. In the Name field enter the name of the tenant, and optionally, in the 
Description field, enter a description.  

3. Select File > Save to save your changes. If you exit the tool without saving your 
changes you will be asked whether you want to save your changes when you exit 
the tool. 

To create a Unified CCMP folder: 

1. In the ICE Cluster Configuration tool, select the Equipment Mapping tab. In 
the center pane, right click on the folder tree at the location where you want to 
add the folder and select Add Folder. 

2. In the Name field enter the name of the folder, and optionally, in the 
Description field, enter a description.  

3. Select File > Save to save your changes. If you exit the tool without saving your 
changes you will be asked whether you want to save your changes when you exit 
the tool. 

Creating an Equipment Mapping 
To create an equipment mapping between a tenant or folder and the contact center 
equipment: 

1. In the ICE Cluster Configuration tool, select the Equipment Mapping tab. In 
the folder tree, select the tenant or folder into which you want to import the 
resources from the contact center equipment. 

2. In the adjoining pane select the check box or check boxes next to each item of 
contact center equipment that you want to associate with the selected folder or 
tenant. 

3. Highlight each selected item of contact center equipment in turn, and, in the 
right hand pane, select one of the following check boxes: 
• Default Import Location. All the resources imported from the highlighted 

contact center equipment will be placed in the selected folder or tenant in 
Unified CCMP.  

• Remote Tenant Mapping, and select a remote tenant from the drop-down 
list. All resources imported from the highlighted contact center equipment 



Chapter 5: Unified CCMP Component Configuration  
Configuring Replication  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  39   

 

associated with the selected remote tenant will be placed in the selected 
folder or tenant in Unified CCMP. 

 

 

If Remote Tenant Mapping is selected then any resources on the contact center 
equipment that are not associated with the selected remote tenant will be placed in 
the source equipment subfolder under the Unallocated folder. 

4. Select File > Save to save your changes. If you exit the tool without saving your 
changes you will be asked whether you want to save your changes when you exit 
the tool. 

Configuring Replication 
In a dual-sided Unified CCMP deployment setup, SQL Server Replication is used to 
replicate Unified CCMP databases. Replication between these databases is setup and 
monitored using the Replication Manager application which is available in the 
Unified CCMP ICE Replication Manager tool. 
 

 

The user running the Unified CCMP Replication Manager must have administrator 
permissions in both Windows and SQL Server, for both the targeted publisher and 
subscriber servers. 

 

Before configuring replication you should have already configured Unified CCMP 
resources in dual-sided mode and saved the configuration using the Cluster 
Configuration tool detailed in section Configuring the Unified CCMP Cluster. 

 

Always run Replication Manger on the Unified CCMP publisher database server. 

To start the Unified CCMP Integrated Configuration Environment, proceed as 
follows: 

1. Go to Start > All Programs > Management Portal > Configuration Tools > 
Integrated Configuration Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

3. Click OK to open Unified CCMP Integrated Configuration Environment. 

4. The Cluster Configuration tool is open by default. From the Tool drop-down 
list select Replication Manager. 
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The Replication Manager offers two modes of operation; Setup and Monitor. Setup 
is used to configure or disable replication and Monitor is used to monitor the health 
of a configured Unified CCMP Replication. 

Setup 
Setup is used to configure or disable SQL Server Replication for the Unified CCMP 
databases in a dual-sided environment. Click the Setup tab to see the replication 
setup details and to configure or disable replication as required by your deployment. 

The Setup tab is divided into logical groups of property settings where some 
information may be modified if required. 

Unified CCMP Database Server Properties 
This section shows the configured Publisher and the Subscriber for Unified CCMP 
database. The Server Name and Catalog Name for each are defaulted to the values 
used when the Unified CCMP servers were configured with the ICE Cluster 
Configuration tool. 
• Server Name: This is fixed for both the Publisher and Subscriber and cannot be 

changed from the Replication Manager. They rely on configurations made 
previously through the Cluster Configuration tool. 

• Catalog Name: For both Publisher and Subscriber these represent the names of 
the respective Unified CCMP databases. The default values are those that were 
used when the Unified CCMP databases were configured using Cluster 
Configuration tool. It is recommended that the default be used.  

 

 

If the Catalog Name for Publisher or Subscriber is changed, a Unified CCMP 
database with the new name must already exist on the respective server. 

Distributor Properties 
This section describes the properties for the SQL Server Replication Distributor. By 
default the Distributor is created on the Unified CCMP Database Subscriber Server. 
• Server Name: This is the name of the subscriber server hosting the Portal 

database as configured using the Cluster Configuration tool. 
• Catalog Name: This is the name that will be assigned to the distribution 

database. The recommended default is distribution_portal. 
• Data Folder: This is the folder path on the distributor server where the data file 

for the distribution database will be created. 
• Log Folder: This is the folder path on the distributor server where the transaction 

log file for the distribution database will be created. 
• Distribution Share: This is the distribution share folder where replication 

snapshot files will be generated. 
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• Override Distributor Admin Password: When replication is performed an 
auto-generated password is used as part of the process to establish connectivity. 
The generated password is alpha-numeric with both upper and lower case 
characters. It will also contain a special character and will be 14 characters long. 
If the generated password does not meet with the complexity requirements of the 
server then check the check box and specify a password of your choice. 

 

 

In most cases the recommended defaults for these properties are valid and should be 
used. If you are performing an upgrade, be particularly careful with the Data Folder 
property, as the default path is different from previous versions. Make sure you use 
the path that you specified when the database was set up.  

Configure or Disable Replication 
Click Configure to start the replication configuration process. Progress messages 
will be logged into the Replication Output window informing you of the steps being 
performed as the DB is replicated. 

If SQL Server Replication is already configured all of the controls will be disabled 
except the Disable button. Click Disable to disable replication. Progress messages 
will be logged into the Replication Output window. 
 

 

After you click Configure, it may take several minutes to set up replication. If data 
has already been imported into the database to be replicated, then it will take longer 
to set up replication. Once replication has been set up, the Replication Manager will 
display the Monitor tab. 

Monitor 
The Monitor tab allows you to monitor the general health of SQL Server Replication 
between Unified CCMP databases. The Monitor can also be used start or stop various 
replication agents. The Monitor will show the details only if SQL Server Replication 
is currently configured. 

The top left pane shows the list of Publishers and Publications on each Publisher.  

Click on a publication in the top left pane to see the corresponding subscriptions in 
the Subscriptions tab in the top right hand pane. The Agents tab lists other agents 
like Snapshot Agent, LogReader Agent and Queue Reader Agent if available for the 
selected publication. The list of agents depends on the Publication being viewed. 

Click on the listed subscriptions or agents to see their session details in the bottom 
left pane. This pane will list all the agent sessions in the last 24 hours. Click on each 
session to see the actions performed during the session in the bottom right pane. This 
pane provides information about failures of any agents if any. 

To stop or start the various replication agents, right click on the agent and select Stop 
or Start in the shortcut menu. 
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By default, the Monitor refreshes every 5 seconds. 

Configuring Unified CVP Media File Upload 
 

 

This configuration is only required where Unified CCMP Resource Management is 
deployed. 

The Unified CVP media file upload allows you to provision WAV media files 
directly to the Unified CVP media server. This allows the associated WAV 
announcement for a Network VRU Script in Unified CCE to be replaced in near real-
time. This solution requires your Unified CVP media server or servers to be hosted 
on Microsoft Windows 2000 Server, Microsoft Windows Server 2003 or Microsoft 
Windows Server 2008. The Unified CVP media servers and the web servers hosting 
Unified CCMP must belong to the same domain. 

Unified CCMP writes media files to a domain share called PortalMedia on the 
domain controller. We recommend the use of Microsoft Distributed File System 
(DFS) to access the file system on the Unified CVP media servers. If you have 
multiple Unified CVP media servers, then Microsoft File Replication can be used to 
keep the announcement files in step across the servers. 

This section describes how to set up Microsoft DFS and Microsoft File Replication to 
support Unified CVP media file upload.  

Preparing the Configuration 
Before configuring the Unified CVP Media File Upload solution for your network 
perform the following tasks: 

1. Make a note of the Host Name and IP Addresses of the Unified CVP media 
server or servers. 

2. Make a note of the User Name and Password of a user with administrator rights 
on the domain so that you can configure DFS and File Replication. 

3. Ensure that Microsoft DFS, File Replication and Remote Procedure Call 
services are installed and running on the Unified CVP media servers and the 
domain controller. 

Domain Controllers Running Windows Server 2003 
Follow the instructions in this section to configure Unified CVP media file upload if 
your domain controller is running Windows Server 2003. 
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Configuring DFS for Unified CVP Media File Upload 
This section describes how to create the shared folder to be used by each Unified 
CVP media server in the domain (Windows Server 2003 domain controllers only).  

1. Login to the Domain Controller as a user with administrator rights.  

2. Click Start > Program Files > Administrative Tools > Distributed File 
System to open the Distributed File System configuration utility. 

3. Right-click on the Distributed File System node in the left of the screen and 
select New Root option to open the New Root Wizard. 

4. Ensure that the option for Domain Root is selected in the Root Type window. 

5. Follow the wizard by entering the default values. When you reach the Host 
Server window enter the Host Name of the Domain Controller. 

6. For the Root Name field enter PortalMedia in the field provided. 

7. For the Folder to Share, select the folder to contain the Unified CVP media 
files that are uploaded. 

 

 

This folder requires full access security permissions for the Domain Computers 
group. Configure this for both the shared permissions and the security credentials. 

8. Click Finish to complete the action and add the root to the DFS utility. 

Configuring DFS Root Targets 
For each media server that the Unified CVP Media File Upload will add files to, 
perform the following actions on the domain controller (Windows Server 2003 
domain controllers only): 

1. Right-click on the new root and select New Root Target. 

2. Enter the server name for the Unified CVP media server. 

3. For the Folder to Share, select the folder to contain the Unified CVP media 
files that are uploaded. 

 

 

This folder requires full access security permissions for the Domain Computers 
group. Configure this for both the shared permissions and the security credentials. 

4. Click Next to create the Root Target. 

Configuring File Replication for Unified CVP Media File Upload 
DFS shares must be setup on all the machines to which the media files should be 
copied, and file replication enabled among all of them. 
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The following steps will take you through the process of replicating files between the 
DFS shares (Windows Server 2003 domain controllers only). To enable this 
functionality you will need to ensure that the File Replication service is set to 
Automatic and is currently running.  

To begin file replication: 

1. Login to the Domain Controller as an administrative user. 

2. Click Start > Program Files > Administrative Tools > Distributed File 
System to open the Distributed File System configuration utility. 

3. Right-click Distributed File System node in the left hand panel and select Show 
Root option 

4. Select PortalMedia node. 

5. Right-click PortalMedia node located in the left hand panel of the Distributed 
File System window. Select Configure Replication option from the menu. The 
Configure Replication Wizard displays. 

6. When prompted to select the initial master, select the share located on the 
domain controller. 

7. Select Full Mesh topology for the replication set. 

8. Click Finish to set up replication between the selected folders. 

Domain Controllers Running Windows Server 2008 
Follow the instructions in this section to configure Unified CVP Media File Upload if 
your domain controller is running Windows Server 2008. 

Create Shared Namespace 
To create a namespace on the domain controller to be used for replication (Windows 
Server 2008 domain controllers only): 

1. Login to the Domain Controller as a user with administrator rights.  

2. Click Start > Program Files > Administrative Tools > Server Manager to 
open the Server Manager utility. 

3. In Server Manager, expand the Roles node, the File Services node, and the DFS 
Management node to see the Namespaces node. Right click on Namespaces, 
and select New Namespace to run the New Namespace Wizard. 

4. In the Namespace Server window, enter the name of the primary Unified CCMP 
database server and click Next. 

5. In the Namespace Name and Settings window, enter PortalMedia for the 
namespace name.  
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The namespace name specified here must match the name shown by the ICE System 
Properties Manager tool, Media Upload group, Media Share property. The default is 
PortalMedia. 

6. Click Edit Settings, review the shared folder permissions, and change them as 
required, if necessary. Click OK, then click Next. 

7. In the Namespace Type window, select Domain-based namespace and click 
Next. 

8. Review the namespace settings, and click Create to create the namespace you 
have specified. When the namespace has been created, click Close. 

Configure Replication 
To configure replication using the namespace you have just created (Windows Server 
2008 domain controllers only): 

1. On the domain controller, in the Server Manager utility, expand the Roles node, 
the File Services node, and the DFS Management node to see the Replication 
node. Right click on Replication, and select New Replication Group to run the 
New Replication Group Wizard. 

2. In the Replication Group Type window, select Multipurpose replication 
group, and click Next. 

3. In the Name and Domain window, enter a name for the replication group, for 
example, sharePortalMedia. Click Next. 

4. In the Replication Group Members window, click Add, and in the Select 
Computers window, enter the name of one of the CVP media servers to be 
included in the replication group. Click OK to add the specified server to the 
replication group. 

5. Repeat the step above to add each of the remaining CVP media servers to the 
replication group. 

6. Click Next. 

7. In the Topology Selection Window, select Full mesh and click Next. 

8. In the Replication Group Schedule and Bandwidth window, select Replicate 
continuously using the specified bandwidth and click Next. 

9. In the Primary Member window, choose one of the CVP media servers in the 
replication group to be the Primary member, and click Next. 

10. In the Folders to Replicate window, click Add, then Browse. Select the folder 
on the primary server where the CVP media files are stored and click OK. 

11. In the Local path on Other Members window, select one of the other CVP media 
servers in the replication group and click Edit.  
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12. In the Edit window, select Enabled, then Browse, and locate the folder on this 
server where the CVP media files are stored. Click OK.  

13. Repeat the previous two steps for any other CVP media servers in the list of 
servers. Click Next. 

14. Review the replication settings, and click Create to set up the replication you 
have specified. When the replication has been set up, click Close. 

Share and Publish the Replicated Folder 
To share and publish the replicated folder (Windows Server 2008 domain controllers 
only): 

1. On the domain controller, in the Server Manager utility, expand the Roles node, 
the File Services node, and the DFS Management node to see the Replication 
node. Click on the replication group you created above, and select the 
Replicated Folders tab. 

2. In the Publishing Method window, select Share and Publish the Replicated 
Folder in a Namespace and click Next. 

3. In the Share Replicated Folders window, select one of the CVP media servers in 
the replication members section, and click Edit. Review the shared folder 
permissions, and change them as required, if necessary. Click OK. 

4. Repeat the step above to set the folder permissions for each of the remaining 
CVP media servers in the replication group. Click Next when you have finished. 

5. In the Namespace Path window, to set Parent folder in namespace, click 
Browse, select \\<domain>\PortalMedia from the list (this is the namespace 
you created above) and click OK. 

6. In the Namespace Path window, enter the New folder name as CVP. Click Next.  

7. Review the settings and click Share to publish the replicated folder. 

Configure the Replicated Folder for Media File Upload 
To configure Unified CCMP to use the replicated folder for CVP media file upload 
(Windows Server 2008 domain controllers only): 

1. On the Unified CCMP database server, select Start > All Programs > 
Management Portal> Configuration Tools > Integrated Configuration 
Environment. The Database Connection dialog box is displayed. 

2. Enter the database information for the primary database server and click OK. 

3. In the ICE Cluster Configuration tool, in the Tools drop-down, select System 
Properties Manager and on the Global tab, navigate to the Media Upload 
group.  
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4. Change the Media Share property from the default value of PortalMedia to 
PortalMedia\CVP. 

5. Select File > Save to save your changes. If you exit the tool without saving your 
changes you will be asked whether you want to save your changes when you exit 
the tool. 

6. Close ICE. 

Testing the Replication Configuration 
You have now created and configured a DFS replicated location for Unified CCMP 
to upload media files to. This is of the form \\<DomainName>\PortalMedia and can 
be accessed by any machine in the domain. Files written to this location will be 
replicated to the specified folders on the servers in the replication group. 

You can confirm that replication is working by creating a file in 
\\<DomainName>\PortalMedia and ensuring that it is copied to all replication 
destinations. 
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6. Post Installation Steps 

Securing Unified CCMP with SSL 
 

 

This step is optional. Follow the instructions in this section if you want to use Secure 
Sockets Layer (SSL) to secure Unified CCMP. This step is optional, although it is 
recommended for maximum security. 

Introduction 
To secure the Unified CCMP web servers using SSL you need to: 
• obtain a digital certificate (see section Obtaining a Digital Certificate); 
• configure SSL (see section Configuring SSL). 

Obtaining a Digital Certificate 
A digital certificate may be obtained in any of the following ways: 
• purchased from an external certificate authority, for public use; 
• generated internally, for secure use within the issuing organization; 
• generated as a self-certified certificate, for local use (this option is not normally 

recommended except for testing purposes). 

If you do not already have a suitable certificate, you can request or generate one as 
follows: 
 

 

Take care to specify the certificate name (common name, or friendly name, 
depending on the type of certificate) exactly as specified below. The certificate will 
not work otherwise. 

1. Open Internet Information Services (IIS) Manager and select the web server 
in the folder hierarchy.  

2. Select the Features View tab, and in the IIS group, click on Server 
Certificates. 
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3. Create a digital certificate in one of the following ways: 
• To request an external certificate: 

• In the Actions pane, select Create Certificate Request to display the 
Request Certificate dialog box. 

• In the Common Name field, enter the URL of the web server. If you 
have a load-balanced system, this must be the URL of the load-balanced 
node, not the URL of any of the individual servers. 

• Complete the other fields as appropriate, and click Next. 
• In the Cryptographic Service Provider Properties dialog box leave the 

default settings and click Next. 
• Specify a file name for the certificate, and then click Finish. 
• When you receive the certificate from the certificate authority, repeat 

steps 1 and 2 above to show the Server Certificates and Action panes, 
and in the Action pane, select Complete Certificate Request. 

• Enter the file name of the certificate, and a Friendly Name of your choice 
and click OK. 

• To generate an internal certificate: 
• Select Create Domain Certificate in the Actions pane to display the 

Distinguished Name Properties dialog box. 
• Enter the URL of the web server in the Common Name field. If you 

have a load-balanced system, this must be the URL of the load-balanced 
node, not the URL of any of the individual servers. 

• Complete the other fields as appropriate, and click Next. 
• In the Online Certification Authority dialog box specify your online 

authority and a friendly name. Click Finish. 
• To generate a self-certified certificate: 

• Select Create Self-Signed Certificate in the Actions pane to display the 
Create Self-Signed Certificate dialog box.  

• Enter the URL of the web server in the Friendly Name field. If you have 
a load-balanced system, this must be the URL of the load-balanced node, 
not the URL of any of the individual servers. 

Configuring SSL 
Once you have a suitable digital certificate, configure SSL as follows: 

1. Open Internet Information Services (IIS) Manager, expand the folder tree 
below the web server and select the web site that the Unified CCMP web 
application resides on. 
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2. In the Actions pane, select Edit Site > Bindings to display the Site Bindings 
dialog box.  

3. If there no existing binding for https, click Add to display the Add Site Binding 
dialog box.  
• Set the IP Address to All Unassigned, and Port to 443, unless your system 

has been set up differently. If you are unsure, contact your system 
administrator. 

• Set SSL Certificate to point to your certificate. 
• Click OK.  

4. If there is an existing binding for https, select it and click Edit to display the 
Edit Site Binding dialog box, edit the settings to the values in step 3 above and 
click OK. 

5. In the folder tree, select the Portal application,  

6. Select the Features View tab, and click on SSL Settings in the IIS group. 

7. Tick Require SSL, and leave the default Ignore for Client Settings. 

8. In the Actions pane, click Apply to apply these settings. 

9. Close IIS Manager. 

Additional Manual Updates to Configure SSL 
To complete the configuration of SSL, the CCMP Web Application configuration file 
requires manual updating. 

1. From the location where you installed Unified CCMP (this will normally be 
C:\Program Files\ Management Portal), navigate to the \Web folder and open 
the XML file web.config using a text editor. 

 

Some text editors, such as WordPad, may not save an XML file correctly, which can 
cause problems. Always back up the configuration file before making changes. 

2. Locate the section beginning <authentication mode=”Forms”>, for example 

<authentication mode="Forms"> 
 <forms name="ExonyAuthentication" loginUrl="~/logon.aspx" 
 protection="All" timeout="20" slidingExpiration="true" 
 requireSSL="false"></forms> 
</authentication> 
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3. Change requireSSL=”false” to requireSSL=”true”, for example: 

<authentication mode="Forms"> 
 <forms name="ExonyAuthentication" loginUrl="~/logon.aspx" 
 protection="All" timeout="20" slidingExpiration="true" 
 requireSSL="true"></forms> 
</authentication> 

4. Locate the section beginning <system.web>, for example: 

<system.web> 
 <httpRuntime requestValidationMode="2.0" 
 enableVersionHeader="false"></httpRuntime> 
</system.web> 

Add the line <httpCookies requireSSL=”true” />, for example: 

<system.web> 
 <httpCookies requireSSL=”true” /> 
 <httpRuntime requestValidationMode="2.0" 
 enableVersionHeader="false"></httpRuntime> 
</system.web> 

5. Save the file and close the text editor. 

Other Security Configuration 
To limit malicious code from intercepting web pages and modifying them to 
reference content outside the domain, you may also perform the following optional 
security configuration: 

1. From the location where you installed Unified CCMP (this will normally be 
C:\Program Files\Management Portal), navigate to the \Web folder and open 
the XML file web.config using a text editor. 

 

Some text editors, such as WordPad, may not save an XML file correctly, which can 
cause problems. Always back up the configuration file before making changes. 

2. Locate the section beginning <httpProtocol>, for example: 

<httpProtocol> 
 <customHeaders> 
  <clear></clear> 
  <add name="X-UA-Compatible" 
   value="IE=EmulateIE10"></add> 
 </customHeaders> 
</httpProtocol> 

3. Add the following lines, between <customHeaders> and </customHeaders>  

<remove name=”X-Powered-By” /> 
<add name="X-Content-Type-Options" value="nosniff" /> 
<add name="X-FRAME-OPTIONS" value="SAMEORIGIN" /> 
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for example: 

<httpProtocol> 
 <customHeaders> 
  <clear></clear> 
  <remove name=”X-Powered-By” /> 
  <add name="X-Content-Type-Options" value="nosniff" /> 
  <add name="X-FRAME-OPTIONS" value="SAMEORIGIN" /> 
  <add name="X-UA-Compatible" 
   value="IE=EmulateIE10"></add> 
 </customHeaders> 
</httpProtocol> 

4. Locate the <httpRuntime> tag, for example 

<httpRuntime requestValidationMode="2.0"> 
</httpRuntime> 

5.  Add the attribute enableVersionHeader=”false”, for example: 

<httpRuntime requestValidationMode="2.0" 
enableVersionHeader="false"> 
</httpRuntime> 

6. Save the file and close the text editor. 

Configuring Single Sign-On 

Overview 
By default, Unified CCMP users need to login to Unified CCMP every time they 
connect. Unified CCMP can optionally be configured to use Single Sign-On (SSO), 
which links each Unified CCMP user account to their Windows user account and 
allows users to connect to Unified CCMP without logging in.  
 

 

Users cannot use SSO over a proxy connection. 

 

 

Setting up SSO will disable any existing Unified CCMP users which are not in 
domain login format. You will need to set up new Unified CCMP user accounts for 
all existing users. 

Administrator Account Setup 
 

 

It is vital that the new SSO administrator account is set up correctly since the existing 
Unified CCMP administrator account is disabled when SSO is configured. 
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1. Login to Unified CCMP as ‘administrator’. 

2. In User Manager, create a user account to be the new administrator account. 
The login name should be of the form <DOMAIN>\<your domain login>, for 
example ACMEDOM\jsmith. The password should conform to the password 
security specified in System Settings, but will never be used 

3. Click New User and open Groups tab. 

4. Click Add to Group. 

5. Select the checkbox for the Administrators group. 

6. Close and save. 

Configuring SSO Authentication for Unified CCMP 
To configure SSO for Unified CCMP using ICE: 

1. On the App/Web server, select Start > All Programs > Management Portal > 
Configuration Tools > Integrated Configuration Environment. 

2. In the Database Connection window specify the following: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you used the default value, this will be 
Portal. 

• Authentication Ensure this option is set to Windows Authentication. 

3. In ICE, in the Tools drop-down, select System Properties. The System 
Properties tool is displayed. 

4. In the Global properties tab, locate the Login Authentication Configuration 
group, Login Authentication Mode property. 

5. Using the drop-down beside the property value, change the value from Portal to 
Active Directory. 

6. Click Save to save the configuration change, then Exit. 

7. On the App/Web server, go to the location where Unified CCMP was installed 
(usually C:\Program Files\Management Portal), right-click on the Web folder 
and click Properties. 

8. Select the Security tab, and ensure that all domain users have Read and Read & 
Execute permissions on this folder. 

9. Click Advanced and ensure that Include inheritable permissions from this 
object’s parent is selected. If this option is not selected, click Change 
Permissions, select it, and click OK. 

10. Click OK to close the properties dialog. 
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11. From a command window, execute the iisreset command. 

Users will now be able to access Unified CCMP directly from their domain account 
without needing to log in again. 
 

 

Depending on the way that Active Directory is configured in your installation, you 
may also need to change additional properties in the Login Authentication 
Configuration group in ICE System Properties. The default settings will be 
sufficient for most installations, but in some cases, you may need to change one or 
both of Active Directory Binding Options and Active Directory Context Type 
properties too.  

 

For more information about the Active Directory Binding Options and Active 
Directory Context Type properties, see the Administration Guide for Unified 
CCMP. For information about the values to choose for your Active Directory 
configuration, consult your Windows system administrator. 

Managing Users with Single Sign-On 
Once SSO has been set up, create a Unified CCMP login in the form 
<DOMAIN>\<Windows domain login> for Unified CCMP each user. Existing Unified 
CCMP user accounts will no longer be valid. 

The first time a user accesses Unified CCMP using SSO a dialog box may appear 
requesting their Windows username and password. To sign in automatically in future, 
they will need to add the Unified CCMP website to the list of local intranet sites in 
their browser. 

To add the Unified CCMP website to the list of local intranet sites in Internet 
Explorer: 

1. Click Tools > Internet Options, and select the Security tab. 

2. Select the Local intranet zone and click the Sites button. 

3. Click Advanced to add the Unified CCMP site to IE's list of local intranet sites. 

4. Enter the URL of the Unified CCMP website in Add this website to the zone, 
and click Add. 

5. Click OK when prompted until you are returned to the browser window. 

Performance Configuration Checklists 
The following performance tuning steps ensure optimal performance of Unified 
CCMP. 



Chapter 6: Post Installation Steps  
System Reset  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  55   

 

Web Server 
 

Done Description 

 Create a new page file, on a non-system drive, of minimum 1.5 x system memory and 
maximum 2 x system memory. 

 Defragment the page file and registry hives using 
http://www.sysinternals.com/Utilities/PageDefrag.html. 

Database Server 
 

Done Description 

 Create a new page file, on a non-system drive, of minimum 1.5 x system memory and 
maximum 2 x system memory. 

 Defragment page file and registry hives using 
http://www.sysinternals.com/Utilities/PageDefrag.html 

 Ensure the Portal database is set to Simple Recovery Mode on all systems 

System Reset 
Reboot the servers after installation has finished, making sure that the Unified CCMP 
services start automatically on boot. 

Logging into Unified CCMP 
Unified CCMP can now be opened from Start > All Programs > 
Management Portal > Web > Management Portal. This will open a web page, 
which you can bookmark. 

For login to a new system, use the username ‘administrator’ and a blank password. 
You will be prompted to change this. If you are logging into an upgraded system, the 
administrator password will not have changed from that previously used. 
 

 

If you lose the administrator password, it cannot be reset except by another user with 
equal permissions.  It is recommended that you note down the chosen password and 
keep it somewhere secure. 

System Checks 
Once the system is installed and configured, you should run through the following 
checks to ensure that data is imported and the system running normally. 
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1. Log in to the Unified CCMP web application using the pre-configured 
Administrator user and confirm that the Home Page successfully displays. 

2. Check that, on each Unified CCMP server, all the installed Unified CCMP 
services are started in services.msc. 

3. Use the following SQL statement to confirm that resource data is being imported 
to the database: 

Select count(*) from TB_DIM_AGENT 

This query should return a value of at least 3. 
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7. Upgrading From a Previous Version 
This chapter and the following chapters describe how to upgrade from a previous 
version of Unified CCMP to Unified CCMP 9.1. 

The upgrade process for Unified CCMP depends on your deployment model and the 
version of Unified CCMP that you are upgrading from. For example, a upgrading a 
single server system is simpler than upgrading a resilient two-tier system where 
down-time must be minimized. This chapter describes several separate methods for 
upgrade. Read this chapter, then choose the method that best suits your system 
configuration and upgrade requirements. 

Which Upgrade Procedure? 
The upgrade procedure you choose depends on your Unified CCMP deployment 
model and your requirements for the upgrade. 

This table lists the different upgrade procedures described in this document and the 
scenarios where they can be used. 
 

Upgrade Procedure 

Upgrade Requirement 

Single-
sided 
system 

Dual-sided 
system 

Minimal 
downtime 

Simple 
process 

Dual-sided 
with different 
s/w versions 

Single-Sided Upgrade (see 
Chapter 8) 

     

Total Outage Upgrade (see 
Chapter 9) 

     

Split Side Upgrade (see 
Chapter 10) 

     

Upgrade from Unified CCMP 
*.5(1) or earlier (see Chapter 11) 

     
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Distributed Architecture 
Unified CCMP employs a distributed architecture for dual-sided systems.  

When upgrading the platform the design and architecture must be considered to 
ensure the minimal amount of down-time is achieved and no data loss is incurred.  

Resilience is achieved by the use of a second side of the system containing the same 
components as the primary side. 

SQL Server replication is used to replicate data from Side A to Side B and Side B to 
Side A.  

Failover information for the individual Unified CCMP components is stored in the 
databases on side A and B. This information is also replicated using SQL Server 
replication. This means that both sides have knowledge of the primary and secondary 
server configuration made through the Unified CCMP Integrated Configuration 
Management tool, even when replication has been removed. 

Figure 3: Replication and Failover Connections 

CCMP Database Server A

Provisioning Server

Data Import Server
Portal

CCMP Web/Application Server A

Application Server

Web Server

CCMP Database Server A

Provisioning Server

Data Import Server
Portal

CCMP Web/Application Server A

Application Server

Web Server

Primary

Secondary

Primary

SQL Replication

 

When a replicated system is upgraded one side at a time, it is possible for the 
individual components of Unified CCMP to fail-over to the other non-upgraded side. 
This will result in data inconsistencies as some data is entered to side A and some to 
side B with no replication running to synchronize the two sides.  

There are two ways to upgrade resilient systems: 
• If it is acceptable for the system to be completely unavailable whilst the upgrade 

is performed, then use the Total Outage Upgrade method. This is the quicker 
upgrade method. 
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• If high-availability is required, then use the Split-Sided Upgrade method. This 
method maximizes the system up time during the upgrade but adds additional 
complexity. 
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Validating an Upgrade 
After you have upgraded your installation of Unified CCMP, check that the system is 
functional following the upgrade with the following tests. 
 

Check Success Criteria 

Unified CCE Provisioning Tests 

Log in to the side A Web server (Portal) and create a new 
Skill Group. This tests provisioning from the side A web 
server. Run this test against each configured Unified CCE 
instance. 

The Skill Group should be 
successfully created, and visible on 
side A, and, if applicable, side B. 

Log in to the side A Web server (Portal) and create a new 
Agent  This tests provisioning from the side A web server. 
Run this test against each configured Unified CCE instance. 

The Agent should be successfully 
created and visible on side A, and, 
if applicable, side B. 

Create a new Skill Group on the AW using the Cisco Skill 
Group Explorer tool. Wait a few minutes and check that the 
Skill Group is imported into Unified CCMP. 

The Skill Group should be visible 
on side A, and, if applicable, on 
side B. 

CUCM Provisioning Tests 

Log in to the side A Web server (Portal) and create a new IP 
Phone. This tests Unified CM provisioning from the side A 
web server. 

The IP Phone should be 
successfully created, and be visible 
on side A, and, if applicable, on 
side B. 

Replication Tests (dual-sided deployments only) 

Log in to the side B Web server (Portal) and create a new 
Skill Group. This tests Unified CCE provisioning from the 
side B Web server. Run this test against each configured 
Unified CCE instance. 

The Skill Group should be 
successfully created, and visible on 
side A.  
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Create a new Skill Group on the AW using the Cisco Skill 
Group Explorer tool. Wait a few minutes and check that the 
Skill Group is imported into Unified CCMP. 

The Skill Group should be visible 
on side A and side B. 

Log in to the side B Web server (Portal) and create a new IP 
Phone. This tests Unified CM provisioning from the Side B 
web server. 

The IP Phone should be visible on 
side A and side B. 
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8. Single-Sided Upgrade 

Overview 
This chapter describes the steps involved to upgrade a single-sided deployment. The 
description assumes that you have a two tier deployment (separate database and 
app/web servers). 
 

 

Only use these instructions if you are upgrading from Unified CCMP 8.5(2) or later. If 
you are upgrading from Unified CCMP 8.5(1) or earlier, follow the instructions in 
Chapter 11. 

 

Before you proceed with the upgrade please ensure you have the original 
cryptographic passphrase entered during the original Unified CCMP installation as 
you will need it at several points during the upgrade. 

Checklist 
 

Step Complete 

Prepare the in place Unified CCMP servers  

Configure DTC  

Stop the Unified CCMP Services   

Backup the Unified CCMP Portal databases   

Delete the ReportServer and ReportServerTempDB database catalogs 
from the DB Server (upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3) only)  

Uninstall SQL Server Components from Web Server (upgrading from 
Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  
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Step Complete 

Uninstall SQL Server Components from Database Server (upgrading 
from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Uninstall Existing Unified CCMP Software  

Uninstall the Data Import Sever Component (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Provisioning Server Component (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Database Installer Component (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Application Server Component (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Web Application Component (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Database Component (upgrading from Unified CCMP 9.0 
only)   

Uninstall the App/Web Server Component (upgrading from Unified 
CCMP 9.0 only)   

Install SQL Server and restore the Portal database 

Install SQL Server 2008 R2 and SQL Server 2008 R2 SP1 (upgrading 
from Unified CCMP 8.5 or earlier only)   

Configure SQL Agent Service account (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only)  

Restore the Portal database (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Add network service accounts (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Install new Unified CCMP Components and upgrade Portal database  

Install the Unified CCMP Database Installer  

Upgrade the Unified CCMP Portal database   

Remove 32 bit application support (upgrading from Unified CCMP  
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Step Complete 

8.5(2) or Unified CCMP 8.5(3) only) 

Install the Unified CCMP App/Web Server  

Configure the Unified CCE Config Web Service (upgrades from Unified 
CCMP 9.0 only)  

Restart and Validate 

Restart the Unified CCMP Services   

Validate the upgrade  

Prepare the in place Unified CCMP Servers 

Configure DTC 
Distributed Transaction Coordinator (DTC) must be configured on all Database 
Servers. DTC is used for Unified CCMP audit archiving. To configure DTC follow 
these steps: 

1. Click Start > All Programs > Administrative Tools > Component Services. 
The Component Services management tool is displayed. 

2. Expand Component Services > Computers > My Computer > Distributed 
Transaction Coordinator. 

3. Right-click on Local DTC and select Properties.  The Local DTC Properties 
window is displayed. 

4. Select Security tab. 

5. In Security Settings ensure that Network DTC Access Transaction Manager 
Communication has Allow Inbound and Allow Outbound selected. 

6. Set Transaction Manager Communication to No Authentication Required. 

7. Click OK and accept the prompt to restart the MSDTC Service. 

Stop the Unified CCMP Services 
Before starting the upgrade, stop the Unified CCMP services on all servers. 

Data Import Server Service 
To stop the Unified CCMP: Data Import Server service: 

1. On the database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 
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3. Right-click the UCCMP: Data Import Server service from the list of services. 

4. Select Stop. 

5. Close the Services window. 

Partition Table Manager Service 
To stop the Unified CCMP: Partition Table Manager service: 

1. On the database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Partitioning Table Manager service from the list of 
services. 

4. Select Stop. 

5. Close the Services window. 

Provisioning Server Service  
To stop the Unified CCMP: Provisioning Server service: 

1. On the database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Provisioning Server service from the list of services. 

4. Select Stop. 

5. Close the Services window. 

System Monitoring Services, Application Search Services and 
Reporting Services 
To stop the System Monitoring Services service, Application Search Services service 
and Reporting Services service: 

1. On the App/Web server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the Unified CCMP: System Monitoring Services service from the 
list of services. 

4. Select Stop. 

5. At the message: “When UCCMP: System Monitoring Services stops, these other 
services will also stop. Do you want to stop these services?” click Yes. 

6. Close the Services window. 
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Back up the Unified CCMP Portal Database 
Back up the Unified CCMP Portal database so that you can restore it in the event of a 
failure. 

1. Start SQL Server Management Studio as follows: 
• If you are upgrading from Unified CCMP 8.5(2) or 8.5(3) or earlier, on the 

Side A database server, click Start > All Programs > Microsoft SQL 
Server 2005 > SQL Server Management Studio.  

• If you are upgrading from Unified CCMP 9.0(x), on the Side A database 
server, click Start > All Programs > Microsoft SQL Server 2008 R2 > 
SQL Server Management Studio 

2. Connect to the Database Engine using Windows Authentication. 

3. Navigate to the Portal database. 

4. Right-click Portal and select Tasks > Back Up.  

5. Amend the Destination as appropriate using the Remove and Add features 

6. Click OK. 

7. Close the SQL Server Management Studio window. 

Delete ReportServer and ReportServerTempDB Databases 
 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

SQL Server Reporting Services is not required for Unified CCMP 9, so the Reporting 
Services Databases can be removed. 

1. Click Start > All Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio. 

2. Connect to the Database Engine using Windows Authentication 

3. Navigate to the ReportServer database. 

4. Right-click ReportServer and select Delete. The Delete Object window 
displays. 

5. Check the Close Existing Connections checkbox. 

6. Click OK to delete the database. 

7. Repeat Steps 3 to 6 and delete the ReportServerTempDB database. 
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Do not delete the Portal database. 

Uninstall SQL Server Components from Web Server 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Microsoft SQL Server 2005 Reporting Services components are not required for 
Unified CCMP 9.0(1) and above and must be removed. 

On the Web Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the SQL Server Reporting Services service from the list of 
services. 

4. Select Stop. 

5. Close the Services window. 

6. Click Start > Control Panel > Uninstall a program. The Programs and 
Features window displays. 

7. Select Microsoft SQL Server 2005 

8. Click Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 

9. Select the MSSQLSERVER: Reporting Services Instance and the 
Workstation components (if present). Click Next. 

10. Review the Confirmation dialog box and click Finish to uninstall the SQL 
Server components. 

11. When the uninstallation procedure completes, close the Programs and Features 
window. 

Uninstall SQL Server Components from Database Server 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Before installing Microsoft SQL Server 2008 R2, Microsoft SQL Server 2005 must 
be removed. 

On the Database Server: 

1. Click Start > Run. The Run window displays. 
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2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click each of the SQL Server services in turn from the list of services and 
select Stop. 

4. When all the SQL Server services are in the Stopped state, close the Services 
window. 

5. Click Start > Control Panel > Uninstall A Program. The Programs and 
Features window displays. 

6. Select Microsoft SQL Server 2005. 

7. Click  Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 

8. Select the MSSQLSERVER: Database Engine and the Workstation Components 
(if present). Click Next. 

9. Review the Confirmation screen and click Finish to uninstall the SQL Server 
components. 

10. When the uninstallation procedure completes. Close the Programs and Features 
window. 

Uninstall Existing Unified CCMP Software 

Uninstall the Data Import Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Data Import Server component: 

1. On the database server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Data Import Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Data Import Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Provisioning Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Provisioning Server component:  



Chapter 8: Single-Sided Upgrade  
Uninstall Existing Unified CCMP Software  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  69   

 

1. On the database server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Provisioning Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Provisioning Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. Manually delete the folder: C:\Program Files\Management 
Portal\Provisioning Server\Config if it exists. 

Uninstalling the Database Installer Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

The Database Installer is the tool that maintains the database catalog. Uninstalling 
this does not remove the Unified CCMP Portal Database (which is upgraded later in 
the process). To remove the Database Installer component: 

1. On the database server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Database Install Tool. 

3. Click the Uninstall option, and confirm. 

Uninstall the Application Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Application Server component:  

1. On the App/Web server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Application Server. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 
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Uninstall the Web Application Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Web Application component:  

1. On the App/Web server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Web Application. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Web Application. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Database Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Database components:  

1. On the Database server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Database Components. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Database Components. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Application Server Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Application Server component:  

1. On the App/Web server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Application Server Components. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server Components. 
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4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. When the uninstall is complete, the App/Web server will reboot automatically. 

Install SQL Server and Restore the Portal Database 

Install SQL Server  

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Install SQL Server 2008 R2 as described in section SQL Server on page 11, then 
follow the post installation configuration steps to configure DTC, SQL Server 
Network Protocols and any required Firewall rules as described in section Post-
Installation Configuration on page 12. 

When the SQL Server 2008 R2 installation is complete, locate and install SQL Server 
2008 R2 Service Pack 1 before proceeding. 

Configure SQL Agent Service Account 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

After installing SQL Server 2008 R2 SP1, configure the SQL Server Agent account 
to run under the SQL Agent User account defined in the Required User Accounts 
section. 

On the Database Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right click the SQL Agent Service and select Properties. The Properties 
window displays. 

4. Select the Log On tab. 

5. Select the This account radio button. 

6. Enter the username and password of the SQL Server Agent user account. 

7. Click OK. A notification message displays confirming that a service restart will 
be required for the change to take effect. 

8. Click OK. 

9. Right click the SQL Agent Service and select Restart. Check that the service 
returns to the Started state. 
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Restore the Portal Database 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

After installing SQL Server 2008 R2, restore the Portal database backup. 

On the database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Right click the Database folder and Click Restore Database. 

3. In the Restore Database window choose From Device and Add the location of 
the portal back up file from the same side database server. You may need to 
copy the backup file to a local file in order to access it. 

4. Select the backup file to restore the Portal database from and click OK.  

5. Select the check box next to the backup set you just added . 

6. Select the Portal database as the restore destination from the To Database drop-
down list.  

7. Select Options and choose Overwrite the existing database. This will restore 
the database to the same location as the previous database. If you would like to 
choose a different location, update the Restore As path for each file to your 
preferred data file location.  

8. Click OK to start the restore.  

Add Network Service Accounts 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

You must also add the NETWORK SERVICE account for the web server to the 
database logins with appropriate access permissions.  Before this can be done the 
existing accounts must be deleted from the Portal database logins. 

On the database server: 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Locate and expand the Portal database. A list of folders is displayed. 
3. Expand the Portal > Security > Users folder. A list of database logins is 

displayed. 
4. Right click and Delete any occurrences of the NETWORK SERVICE account. 

Do not delete the entry for the NETWORK SERVICE account for the local 



Chapter 8: Single-Sided Upgrade  
Install New Unified CCMP Components and Upgrade Portal Database  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  73   

 

machine (NT AUTHORITY\ NETWORK SERVICE). For remote web server 
machines in the deployment the NETWORK SERVICE logins will be of the 
form <DOMAIN>\<WEBSERVER MACHINE NAME>$. For example 
CISCO\WEBSERVERA$ if your webserver is called WEBSERVERA and 
belongs to the CISCO domain. 

5. Expand the Security folder. A list of folders is displayed. 
6. Right Click the Logins folder and select New Login. 
7. Ensure the Windows authentication option is selected and enter the NT 

AUTHORITY\NETWORK SERVICE account for the Side A webserver  in the 
form <DOMAIN>\<WEBSERVER MACHINE NAME>$. 

8. Click User Mapping in the Select a page panel. 
9. Check the Portal database in the Users mapped to this login pane. Ensure that 

the User column correctly contains the Network Service account for the web 
server. 

10. Check the portalapp_ role, portalrs_role and portalreporting_role in the 
Database Role Membership pane. 

11. Click OK. 

Install New Unified CCMP Components and Upgrade Portal 
Database  

This section describes how to install the new Unified CCMP components and 
upgrade the portal database for this release of Unified CCMP. 

Running the Unified CCMP Installer 
1. Insert the Unified CCMP DVD. If auto-run is enabled on the server, a window 

opens automatically showing a list of Unified CCMP components under the 
heading ‘Server Installation’ on the left hand side.  

 

 

If auto-run is disabled and you do not see the Installation Components screen, 
double-click the autorun.bat file located on the DVD to launch the Unified CCMP 
installer manually. 

  

If UAC has not been disabled, launch the installation manually by right-clicking on 
the autorun.bat file located on the DVD and selecting run as administrator option. 

 

Some anti-virus software may state that the autorun.hta script file is malicious. 
Please ignore and continue with the installation. 

2. Follow the steps in the sections below to install each component, but read the 
information about prerequisites in the rest of this section first.  
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Before you can install a Unified CCMP component, the prerequisites for that 
component must be present. The Unified CCMP Installer checks the prerequisites for 
each component as follows:  
• When you click on a component to install it, the installer displays a list of 

prerequisites for that component and checks that each prerequisite is present. As 
each prerequisite check completes, you will see a green tick (check successful) or 
a red cross (check failed). The Install option for that component is only available 
when all prerequisite checks are successful. 

• Where possible, the Unified CCMP DVD includes redistributable packages for 
prerequisites, so if a prerequisite check fails, you can click on the link in the 
Unified CCMP installer to install the missing prerequisite. Once all the 
prerequisite software is installed, you can click on the component again, then 
click Rerun to rerun the tests. 

• When all the prerequisites display a green tick, you will be able to click Install to 
install the chosen component. 

Install the Unified CCMP Database Installer 
This process does not upgrade the database directly. It just installs the Database 
Installer which is then used to upgrade the database. On the Database Server: 

1. To install the Unified CCMP Database Installer, in the Unified CCMP Installer, 
select Database Server, and wait until the prerequisite checks have completed. 
If any checks fail, fix them as described above. When all checks have passed, 
click Install to begin the Database Server Installation. The Setup window 
displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 

4. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
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installation with a new passphrase you will be unable to access your existing data. 

5. In the Configure Database window: 
• Database Name Enter the name of the database catalog for Unified CCMP. 

By default this is Portal. 
• Connect Using Select the login credentials you want to use: 

• Windows Authentication Credentials of Application This is the 
recommended option. 

• SQL Server Authentication using the login and password below This 
option should only be selected if you are using a database catalog on a 
different domain. For this option you must enter your SQL Server Login 
Name and Password in the fields provided. 

• Click Next. 

6. In the Destination Folder window, you can click Change to change the location 
where the Database components are installed. It is not necessary to install all 
Unified CCMP components in the same location. 

7. Click Install to install the Database Installer.  
 

 

During the Database Install Tool Installation, the J2SE pre-requisite will be 
automatically installed if it is not already present.  A Security Alert dialog box stating 
that ‘Revocation Information for the security certificate for this site is not available’ 
may be displayed in some circumstances. If this dialog box appears click Yes to 
continue. 

8. When the installation has completed, to upgrade your database immediately after 
installing the Database Installer, select the Launch Database Management 
Utility check box at the end of the installation before clicking Finish. 

9. Click Finish. 

Upgrade the Unified CCMP Portal Database 
Once the Database Installer is installed, it can be used to upgrade the database. 

1. If you selected the Launch Database Management Utility check box when you 
installed the Database Installer, the Database Installer launches automatically 
after it has been installed. Otherwise, launch the Database Installer manually 
from Start > All Programs > Management Portal > Database > Database 
Installer. The Database Installer is a wizard which guides you through the steps 
to upgrade the database.  

2. Click Next to begin the upgrade process.  

3. In the Database Setup Window choose Upgrade an Existing Database. Click 
Next to continue. 
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4. In the SQL Server Connection Details window, take the following actions: 
• Server Name - select the Microsoft SQL Server where the Unified CCMP 

database is located. In this case this is the machine running the application, 
and so it must be left as the default (local). 

• Database Name - enter or select the name of the database catalog that was 
originally used for the Unified CCMP database. 

• Connect Using - select the login credentials you want to use: 
• The Windows account information you use to log in to your 

computer. This is the recommended option. 
• The Microsoft SQL Server login information assigned by the system 

administrator. Only select this option if you are using a database 
catalog on a different domain. For this option you must enter your Login 
Name and Password in the fields provided. 

• Test Connection – click to make sure the connection to the Microsoft SQL 
Server is established. If you see the message ‘Connection succeeded but 
database does not exist’ then you must rectify this problem before 
continuing. Check that the database catalog name and security credentials are 
correct.  

• When the database connection details have been tested and the connection is 
successful, click Next. 

5. Click Next to perform the upgrade. 

6. When the Portal database upgrade is complete, click Close to close the Database 
Installation Tool. 

Remove 32-Bit Application Support 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Some components used by earlier versions of Unified CCMP ran as 32-bit 
applications on a 64-bit operating system. Prior to installing the App/Web Server, 
remove 32-bit application support on the Servers where App/Web Server component 
will be installed: 

1. Click Start > All Programs > Accessories then right-click Command prompt 
and select Run as administrator. 

2. Copy the following script and paste into the command window: 
cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set 
w3svc/AppPools/Enable32bitAppOnWin64 0 

3. Press Enter to execute the script.  The script should return the following output: 
Enable32bitAppOnWin64           : (BOOLEAN) False 
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The App/Web Server component can now be installed. 

Install the Unified CCMP App/Web Server 
Install the new App/Web Server components on the App/Web Server.  

1. To install the Unified CCMP App/Web component, in the Unified CCMP 
Installer, select App/Web Server, wait until the prerequisite checks have 
completed and click Install. The Management Portal: Application Server 
Component window displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. If the Management Portal: Application Server Components Dialog is displayed, 
click Install to install the additional required components. 

4. If the Microsoft .NET 4.5 Framework pre-requisite is missing, it will be installed 
at this point. Click Install to install the component and follow the on screen 
instructions. When the .NET 4.5 Framework is complete, restart the server to 
continue the installation of the App/Web Server. 

5. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting 

6. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 

7. In the Destination Folder window, you can click Change to change the location 
that the App/Web Server components are installed to. 

8. In the Configure Database window: 
• SQLServer Name Enter the name of the machine that is to be the Database 

Server. The default of localhost is valid only when installing on the Database 
Server. 
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• Catalog Name Enter or select the name you selected while installing the 
Database Server component. By default this is Portal. 

• Connect Using Select the login credentials you want to use: 
• Windows authentication This is the recommended option. 
• The SQL Server authentication This option should only be selected if 

you are using a database catalog on a different domain. For this option 
you must enter your SQL Server Login Name and Password in the fields 
provided. 

9. Click Install. 

10. When the installation has completed, click Finish. 
 

 

The machine will restart once the installation is complete.  

Configure the Unified CCE Config Web Service 
On the database server, the Unified CCE Config Web Service must be configured for 
each connected Unified CCE Server that is running Unified CCE 9.0 or later.  

 

This step is only required if you are upgrading from Unified CCMP 9.0. Earlier 
versions of Unified CCMP were not able to connect to Unified CCE Servers running 
Unified CCE 9.0. 

To configure the Unified CCE Config Web Service: 

1. On the database server, Go to Start > All Programs > Management Portal > 
Configuration Tools > Integrated Configuration Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

3. Click OK to open Unified CCMP Integrated Configuration Environment. 

4. Select the Setup tab and click Configure Cisco Unified CCE Servers to start 
the wizard. Click Next to go through each window in turn. 

5. In the Select Task dialog box select Modify an existing instance. 

6. Select the Unified CCE instance you want to modify and click Next. 

7. Complete the dialog boxes as follows: 
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• In the Configure Primary Unified Config Web Service dialog box, enter the 
following details 
• URL. This is the auto-generated URL of the primary unified config web 

service on the Unified CCE 
• User Name. This is a username with appropriate access to the Unified 

CCE that the web service is running on. This user must be in the domain 
security group <Server>_<UCCE-Instance>_Config, where <Server> 
is the name of the server running Unified CCE and <UCCE-Instance> is 
the name of the Unified CE Instance on this server. 

• Password. This is the password for the user. 
• In the Configure Primary ConAPI RMI Ports dialog box enter the following 

ConAPI details: 
• Local Registry Port. This is the port on the Unified CCE for the Unified 

CCMP Provisioning service to connect to. This will usually be 2099. 
• Remote Registry Port. This is the port on the Unified CCMP Database 

Server for the Unified CCE to connect to. This will usually be 2099. 
• Local Port. This is selected as the designated port for live provisioning 

traffic between the Unified CCE and Unified CCMP servers. It must be 
uniquely assigned for each Unified CCE and any firewalls between the 
CICM and Unified CCMP server must be configured to allow both-way 
traffic on this port. 

• In the Configure ConAPI Application Instance dialog box enter the following 
details: 
• Application Name. The name of the application to be used for 

provisioning Unified CCE from Unified CCMP. Specify the name of the 
application you configured in section Common ConAPI Credentials. 

• Application Key. Use the password for the application you specified 
above. 

• In the Multi Media Support dialog box, select Yes if you are using a Cisco 
Unified Web and E-Mail Interaction Manager application instance to provide 
support for non-voice interactions. The default is No. 

• In the Purge On Delete dialog box select Yes if you want to purge items from 
Unified CCE automatically when they are deleted from Unified CCMP. The 
default is Yes. 

• In the Self Skilling Enabled dialog box select Yes if you want to allow agents 
to reskill themselves. The default is No. 

• In the Supervisor Active Directory Integration dialog box select Yes if you 
want to enable support for associating existing Active Directory user 
accounts for Unified CCE Supervisors. The default is No. If you select Yes 
then you will be prompted to provide Active Directory information so that 
Windows user accounts can be listed.  
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8. The Summary dialog box summarizes the details of the Unified CCE being 
configured and the settings you have chosen. Check the details, and if you are 
satisfied, click Next. 

9. A confirmation message is displayed to indicate that the wizard has completed 
successfully. Click Exit to close the wizard. 

10. Click Configure Cisco Unified CCE Servers again, and repeat the steps above 
to configure the remaining Unified CCE Servers that are running Unified CCE 
9.0 or later. 

11. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

Restart and Validate 

Restart the Unified CCMP Services 
Following an upgrade it is good practice to restart all Unified CCMP services. 

To restart a service: 

1. Click Start > Run. 

2. Enter Services.msc and then click OK. 

3. If the selected service is in the Started state, right click the service name and 
click Restart. If the selected service is not started, right-click the service name 
and click Start. 

All Unified CCMP services on both Database and App/Web Servers should be 
restarted. 
 

 

After starting the System Monitoring Service and Application Service on the web 
server, you will need to wait a few minutes before logging in to allow the services to 
load completely. 

Validate the Upgrade 
Check that the system is functional following the upgrade using the validation tests in 
the section Validating an Upgrade on page 60. 
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9. Total Outage Upgrade 

Overview  
This chapter describes the steps involved to upgrade a dual-sided deployment, where 
all servers will be taken down and upgraded at once. The description assumes that 
you have a two tier deployment (separate database and app/web servers). 
 

 

Only use these instructions if you are upgrading from Unified CCMP 8.5(2) or later. 
If you are upgrading from 8.5(1) or earlier, follow the instructions in Chapter 11. 

 

Before you proceed with the upgrade please ensure you have the original 
cryptographic passphrase entered during the original Unified CCMP installation as 
you will need it at several points during the upgrade. 

Checklist 
 

Step Complete 

Prepare the in place Unified CCMP servers  

Configure DTC  

Stop the Unified CCMP Services   

Remove database replication   

Backup the Side A and Side B Portal databases   

Delete the ReportServer and ReportServerTempDB database 
catalogs from the DB Servers (upgrading from Unified CCMP 8.5(2) 
or Unified CCMP 8.5(3) only)  
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Step Complete 

Uninstall SQL Server components from the Unified CCMP Web 
servers (upgrading from Unified CCMP 8.5(2) or Unified CCMP 
8.5(3) only)  

Uninstall SQL Server components from the Unified CCMP Database 
servers (upgrading from Unified CCMP 8.5(2) or Unified CCMP 
8.5(3) only)  

Uninstall Existing Unified CCMP Software  

Uninstall the Data Import Server from both Database Servers  
(upgrading from Unified CCMP 8.5(2) or 8.5(3) only)   

Uninstall the Provisioning Server from both Database Servers 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Database Installer from both Database Servers 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Application Server from both App/Web Servers 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Web Application from both App/Web Servers 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)   

Uninstall the Database Component from both Database Servers 
(upgrading from Unified CCMP 9.0 only)  

Uninstall the App/Web Server Component from both App/Web 
Servers (upgrading from Unified CCMP 9.0 only)  

Install SQL Server 2008 R2 and Restore the Portal Database 

Install SQL Server 2008 R2 and SQL Server 2008 R2 SP1 (upgrading 
from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Configure SQL Agent Service Account (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Restore the Portal Database (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Add the SQL Agent User (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  
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Step Complete 

Add Network Service Accounts (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only)  

Install the new Unified CCMP Components and upgrade the Portal database  

Install the new Unified CCMP Database Installer on both database 
servers  

Upgrade the Unified CCMP Portal database on both database servers   

Remove 32 bit replication (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Install the Unified CCMP App/Web Servers on both App/Web 
Servers.   

Configure the Unified CCE Config Web Service (upgrades from 
Unified CCMP 9.0 only)  

Restore Replication  

Restore replication between the Side A and Side B databases.   

Reconfigure replication  

Confirm replication is working   

Restart and Validate  

Restart the Unified CCMP Services   

Validate the upgrade  

Prepare the in place Unified CCMP Servers 

Configure DTC 
Distributed Transaction Coordinator (DTC) must be configured on all Database 
Servers. DTC is used for Unified CCMP audit archiving. To configure DTC follow 
these steps: 

On the Side A Database Server: 

1. Click Start > All Programs > Administrative Tools > Component Services. 
The Component Services management tool is displayed. 



Chapter 9: Total Outage Upgrade  
Prepare the in place Unified CCMP Servers  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  84   

 

2. Expand Component Services > Computers > My Computer > Distributed 
Transaction Coordinator. 

3. Right-click on Local DTC and select Properties.  The Local DTC Properties 
window is displayed. 

4. Select Security tab. 

5. In Security Settings ensure that Network DTC Access Transaction Manager 
Communication has Allow Inbound and Allow Outbound selected. 

6. Set Transaction Manager Communication to No Authentication Required. 

7. Click OK and accept the prompt to restart the MSDTC Service. 

Repeat the process on the Side B Database Server. 

Stop the Unified CCMP Services 
Before starting the upgrade stop the Unified CCMP services on all servers. 

Data Import Server Service 
To stop the Unified CCMP: Data Import Server service: 

1. On the Side A database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Data Import Server service from the list of services. 

4. Select Stop. 

5. Close the Services window. 

Repeat the steps above on the Side B database server. 

Partition Table Manager Service 
To stop the Unified CCMP: Partition Table Manager service: 

1. On the Side A database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Partitioning Table Manager service from the list of 
services. 

4. Select Stop. 

5. Close the Services window 

Repeat the steps above on the Side B database server. 



Chapter 9: Total Outage Upgrade  
Prepare the in place Unified CCMP Servers  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  85   

 

Provisioning Server Service  
To stop the Unified CCMP: Provisioning Server service: 

1. On the Side A database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Provisioning Server service from the list of services. 

4. Select Stop. 

5. Close the Services window. 

Repeat this process on the Side B database server. 

System Monitoring Services, Application Search Services and 
Reporting Services 

1. On the App/Web server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the Unified CCMP: System Monitoring Services service from the 
list of services. 

4. Select Stop. 

5. At the message: “When UCCMP: System Monitoring Services stops, these other 
services will also stop. Do you want to stop these services?”, click Yes. 

6. Close the Services window. 

Repeat this process on the Side B App/Web server. 

Remove Database Replication 
Before the upgrade can proceed, database replication must be removed. 

Removing Replication – Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 

 

Follow these instructions if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To remove database replication: 

1. Ensure you are logged in to the Side A database server as a domain level user 
with administrative rights over both database servers. 

2. In your Windows desktop, click Start > Programs > Management Portal > 
and click the Configuration Management application. 

3. Click OK to login. 

4. Click UCCMP Servers. 
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5. Click the Report Server Databases tab. 

6. Click Replication. 

7. Click Unreplicate. 

8. Click Execute. 

9. Click Yes when prompted to remove replication. This step may take some time 
to complete. 

10. Once complete, Click Close. 

11. Click OK. 

12. Select the UCCMP Database tab. 

13. Click Replication. 

14. Click Unreplicate. 

15. Click Execute. 

16. Click Yes when prompted to remove replication. This step may take some time 
to complete. 

17. Once complete, Click Close. 

18. Click OK. 

19. Click Close 

20. Exit Configuration Manager. 

Removing Replication– Unified CCMP 9.0 

 

Follow these instructions if you are upgrading from Unified CCMP 9.0. 

To remove database replication: 

1. Ensure you are logged in to the Side A database server as a domain level user 
with administrative rights over both database servers. 

2. In your Windows desktop, click Start > Programs > Management Portal > 
Configuration Tools > Integrated Configuration Environment. 

3. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 
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4. Click OK to open Unified CCMP Integrated Configuration Environment. 

5. The Cluster Configuration tool is open by default. From the Tool drop-down 
list select Replication Manager. 

6. Click the Setup tab to see the replication setup details. 

7. Click Disable to remove replication from the Unified CCMP database. When 
prompted, click Yes to proceed with replication removal. 

Replication removal may take several minutes. Wait for the ‘Replication Removed’ 
message to display in the Output Window and then exit the Integrated Configuration 
Environment. 

Back up the Unified CCMP Portal Databases 
Back up the Unified CCMP Portal databases so that you can restore them in the event 
of a failure. 

1. Start SQL Server Management Studio as follows: 
• If you are upgrading from Unified CCMP 8.5(2) or 8.5(3) or earlier, on the 

Side A database server, click Start > All Programs > Microsoft SQL 
Server 2005 > SQL Server Management Studio.  

• If you are upgrading from Unified CCMP 9.0(x), on the Side A database 
server, click Start > All Programs > Microsoft SQL Server 2008 R2 > 
SQL Server Management Studio 

2. Connect to the Database Engine using Windows Authentication. 

3. Navigate to the Portal database. 

4. Right-click Portal and select Tasks > Back Up.  

5. Amend the Destination as appropriate using the Remove and Add features 

6. Click OK. 

7. Close the SQL Server Management Studio window. 

Repeat this process for the Unified CCMP Portal database on the Side B database 
server. 

Delete ReportServer and ReportServerTempDB Databases 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 
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SQL Server Reporting Services is not required for Unified CCMP 9 and so the 
Reporting Services Databases can be removed. 

On the Side A database Server: 

1. Click Start > All Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio. 

2. Connect to the Database Engine using Windows Authentication. 

3. Navigate to the ReportServer database. 

4. Right-click ReportServer and select Delete. The Delete Object window 
displays. 

5. Check the Close Existing Connections checkbox. 

6. Click OK to delete the database. 

7. Repeat Steps 3 to 6 and delete the ReportServerTempDB database. 
 

 

Do not delete the Portal database. 

Repeat the steps in this section on the Side B Database server. 

Uninstall SQL Server Components from Web Servers 

 

This step is only required if you are upgrading from Unified CCMP 8.5 (2) or 
Unified CCMP 8.5(3). 

Microsoft SQL Server 2005 Reporting Services components are not required for 
Unified CCMP 9.0(1) and above and must be removed. 

On the Side A Web Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the SQL Server Reporting Services service from the list of 
services. 

4. Select Stop. 

5. Close the Services window. 

6. Click Start > Control Panel > Uninstall a program. The Programs and 
Features window displays. 

7. Select Microsoft SQL Server 2005. 

8. Click Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 
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9. Select the MSSQLSERVER: Reporting Services Instance and the 
Workstation components (if present). Click Next. 

10. Review the Confirmation dialog box and click Finish to uninstall the SQL 
Server components. 

11. When the uninstallation procedure completes, close the Programs and Features 
window. 

Repeat this process on the side B web server. 

Uninstall SQL Server Components from Database Servers 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Before installing Microsoft SQL Server 2008 R2, Microsoft SQL Server 2005 must 
be removed. 

On the Side A Database Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click each of the SQL Server services in turn from the list of services and 
select Stop. 

4. When all the SQL Server services are in the Stopped state, close the Services 
window. 

5. Click Start > Control Panel > Uninstall A Program. The Programs and 
Features window displays. 

6. Select Microsoft SQL Server 2005 

7. Click  Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 

8. Select the MSSQLSERVER: Database Engine and the Workstation Components 
(if present). Click Next. 

9. Review the Confirmation screen and click Finish to uninstall the SQL Server 
components. 

10. When the uninstallation procedure completes. Close the Programs and Features 
window. 

Repeat this process on the side B database server. 
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Uninstall Existing Unified CCMP Software 

Uninstall the Data Import Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Data Import Server component: 

1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Data Import Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Data Import Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Repeat this process on the Side B database server. 

Uninstall the Provisioning Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Provisioning Server component:  

1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Provisioning Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Provisioning Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. Manually delete the folder: C:\Program Files\Management 
Portal\Provisioning Server\Config if it exists. 

Repeat this process on the Side B database server. 

Uninstalling the Database Installer Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(3) or Unified 
CCMP 8.5(3). 
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The Database Installer is the tool that maintains the database catalog. Uninstalling 
this does not remove the Unified CCMP Portal Database (which is upgraded later in 
the process). To remove the Database Installer component: 

1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Database Install Tool. 

3. Click the Uninstall option, and confirm. 

Repeat this process on the Side B database server. 

Uninstall the Application Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Application Server component:  

1. On the Side A Web server, click Start > Control Panel > Uninstall a program. 
The Programs and Features window displays. 

2. Select Management Portal: Application Server. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Repeat this process on the Side B Web server. 

Uninstall the Web Application Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Web Application component:  

1. On the Side A Web server, click Start > Control Panel > Uninstall A 
Program. The Programs and Features window displays. 

2. Select Management Portal: Web Application. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Web Application. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Repeat this process on the Side B Web server. 
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Uninstall the Database Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Database components:  

1. On the Side A Database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Database Components. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Database Components. 

4. Click Yes. The Setup Status window displays.  The extent of the 
uninstallation progress displays on the progress bar. 

Repeat this process on the Side B Database server. 

Uninstall the Application Server Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Application Server components:  

1. On the Side A App/Web server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Application Server Components. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server Components. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. When the uninstall is complete, the App/Web server will reboot automatically. 

Repeat this process on the Side B App/Web server. 

Install SQL Server and Restore the Portal Database 

Install SQL Server  

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

On the Side A database server: 
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• Install SQL Server 2008 R2 as described in section SQL Server on page 11, then 
follow the post installation configuration steps to configure DTC, SQL Server 
Network Protocols and any required Firewall rules as described in section Post-
Installation Configuration on page 12 of this document. 

• When the SQL Server 2008 R2 installation is complete, locate and install SQL 
Server 2008 R2 Service Pack 1 before proceeding. 

Repeat these steps for the B side database server. 

Configure SQL Agent Service Account 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

After installing SQL Server 2008 R2 SP1, configure the SQL Server Agent account 
to run under the SQL Agent User account defined in the Required User Accounts 
section. 

On the Side A Database Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right click the SQL Agent Service and select Properties. The Properties 
window displays. 

4. Select the Log On tab. 

5. Select the This account radio button. 

6. Enter the username and password of the SQL Server Agent user account. 

7. Click OK.  A notification message displays confirming that a service restart will 
be required for the change to take effect. 

8. Click OK. 

9. Right click the SQL Agent Service and select Restart. Check that the service 
returns to the Started state. 

Repeat this process on the Side B database server. 

Restore the Portal Database 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 
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After installing SQL Server 2008 R2, restore the Portal database backup. 

On the Side A database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Right click the Database folder and Click Restore Database. 

3. In the Restore Database window choose From Device and Add the location of 
the portal back up file from the same side database server. You may need to 
copy the backup file to a local file in order to access it. 

4. Select the backup file to restore the Portal database from and click OK.  

5. Select the check box next to the backup set you just added. 

6. Select the Portal database as the restore destination from the To Database drop-
down list.  

7. Select Options and choose Overwrite the existing database. This will restore 
the database to the same location as the previous database. If you would like to 
choose a different location, update the Restore As path for each file to your 
preferred data file location.  

8. Click OK to start the restore.  

Repeat the process on the Side B Database Server to restore the Side B portal 
database backup to the Side B database server.  

Once the Portal databases have been restored they must then be upgraded. 

Add the SQL Agent User 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

For a dual-sided system, the SQL Agent User must be re-added. 

On the Side A database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Expand the security folder; a list of subfolders is displayed. 

3. Right Click the Logins folder and select New Login 

4. Ensure the Windows authentication option is selected and enter the SQL Agent 
User domain and login name in the form <DOMAIN>\<LOGIN>. For example 
CISCO\sql_agent_user if your user is called sql_agent_user and belongs to the 
CISCO domain. 

5. Click User Mapping in the Select a page panel. 
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6. Check the Portal database in the Users mapped to this login pane. The User 
column will auto-populate with the domain username for the SQL Agent User. 

7. Check the db_owner role in the Database Role Membership pane. 

8. Click OK to apply the changes. 

Repeat these steps on the Side B Database Server. 

Add Network Service Accounts 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

You must also add the NETWORK SERVICE account for all web servers to the 
database logins with appropriate access permissions.  Before this can be done the 
existing accounts must be deleted from the Portal database logins. 

On the A side database server: 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Locate and expand the Portal database. A list of folders is displayed. 

3. Expand the Portal > Security > Users folder. A list of database logins is 
displayed. 

4. Right click and Delete any occurrences of the NETWORK SERVICE account 
for all remote web servers in the deployment. Do not delete the entry for the 
NETWORK SERVICE account for the local machine (NT AUTHORITY\ 
NETWORK SERVICE). For remote web server machines  in the deployment 
the NETWORK SERVICE logins will be of the form 
<DOMAIN>\<WEBSERVER MACHINE NAME>$. For example 
CISCO\WEBSERVERA$ if your webserver is called WEBSERVERA and 
belongs to the CISCO domain. 

5. Expand the Security folder. A list of folders is displayed. 

6. Right Click the Logins folder and select New Login. 

7. Ensure the Windows authentication option is selected and enter the NT 
AUTHORITY\NETWORK SERVICE account for the Side A webserver  in the 
form <DOMAIN>\<WEBSERVER MACHINE NAME>$. 

8. Click User Mapping in the Select a page panel. 

9. Check the Portal database in the Users mapped to this login pane. Ensure that 
the User column correctly contains the Network Service account for the web 
server. 

10. Check the portalapp_ role, portalrs_role and portalreporting_role in the 
Database Role Membership pane. 
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11. Click OK. 

12. Repeat steps 6 to 11 add the NT AUTHORITY\NETWORK SERVICE account 
for each web server in the deployment. 

Repeat these steps on the Side B database server to re-add the Web Server Network 
Service database logins there. 

Install New Unified CCMP Components and Upgrade Portal 
Database 

This section describes how to install the new Unified CCMP components and 
upgrade the portal database for this release of Unified CCMP. 

Running the Unified CCMP Installer 
1. Insert the Unified CCMP DVD. If auto-run is enabled on the server, a window 

opens automatically showing a list of Unified CCMP components under the 
heading ‘Server Installation’ on the left hand side.  

 

 

If auto-run is disabled and you do not see the Installation Components screen, 
double-click the autorun.bat file located on the DVD to launch the Unified CCMP 
installer manually. 

  

If UAC has not been disabled, launch the installation manually by right-clicking on 
the autorun.bat file located on the DVD and selecting run as administrator option. 

 

Some anti-virus software may state that the autorun.hta script file is malicious. 
Please ignore and continue with the installation. 

2. Follow the steps in the sections below to install each component, but read the 
information about prerequisites in the rest of this section first.  

Before you can install a Unified CCMP component, the prerequisites for that 
component must be present. The Unified CCMP Installer checks the prerequisites for 
each component as follows:  
• When you click on a component to install it, the installer displays a list of 

prerequisites for that component and checks that each prerequisite is present. As 
each prerequisite check completes, you will see a green tick (check successful) or 
a red cross (check failed). The Install option for that component is only available 
when all prerequisite checks are successful. 

• Where possible, the Unified CCMP DVD includes redistributable packages for 
prerequisites, so if a prerequisite check fails, you can click on the link in the 
Unified CCMP installer to install the missing prerequisite. Once all the 
prerequisite software is installed, you can click on the component again, then 
click Rerun to rerun the tests. 
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• When all the prerequisites display a green tick, you will be able to click Install to 
install the chosen component. 

Install the Unified CCMP Database Installer 
This process does not upgrade the database directly. It just installs the Database 
Installer which is then used to upgrade the database. 

On the Side A Database Server: 

1. In the Unified CCMP Installer, select Database Server, and wait until the 
prerequisite checks have completed. If any checks fail, fix them as described 
above. When all checks have passed, click Install to begin the Database Server 
Installation. The Setup window displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 

4. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 

5. In the Configure Database window: 
• Database Name Enter the name of the database catalog for Unified CCMP. 

By default this is Portal. 
• Connect Using Select the login credentials you want to use: 

• Windows Authentication Credentials of Application This is the 
recommended option. 

• SQL Server Authentication using the login and password below This 
option should only be selected if you are using a database catalog on a 
different domain. For this option you must enter your SQL Server Login 
Name and Password in the fields provided. 
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• Click Next. 

6. In the Destination Folder window, you can click Change to change the location 
that the Database components are installed to. It is not necessary to install all 
Unified CCMP components to the same location. 

7. Click Install to install the Database Installer.  
 

 

During the Database Install Tool Installation, the J2SE pre-requisite will be 
automatically installed if it is not already present.  A Security Alert dialog box stating 
that ‘Revocation Information for the security certificate for this site is not available’ 
may be displayed in some circumstances. If this dialog box appears click Yes to 
continue. 

8. When the installation has completed, to upgrade your database immediately after 
installing the Database Installer, select the Launch Database Management 
Utility check box at the end of the installation before clicking Finish. 

9. Click Finish. 

Repeat the steps above to install the Database Installer process on the Side B 
Database Server. 

Upgrade the Unified CCMP Portal Database 
Once the Database Installer is installed, it can be used to upgrade the database. 

On the Side A Database Server: 

1. If you selected the Launch Database Management Utility check box when you 
installed the Database Installer, the Database Installer launches automatically 
after it has been installed. Otherwise, launch the Database Installer manually 
from Start > All Programs > Management Portal > Database > Database 
Installer. The Database Installer is a wizard which guides you through the steps 
to upgrade the database.  

2. Click Next to begin the upgrade process.  

3. In the Database Setup Window choose Upgrade an Existing Database. Click 
Next to continue. 

4. In the SQL Server Connection Details window, take the following actions: 
• Server Name - select the Microsoft SQL Server where the Unified CCMP 

database is located. In this case this is the machine running the application, 
and so it must be left as the default (local). 

• Database Name - enter or select the name of the database catalog that was 
originally used for the Unified CCMP database. 

• Connect Using - select the login credentials you want to use: 
• The Windows account information you use to log in to your 

computer. This is the recommended option. 
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• The Microsoft SQL Server login information assigned by the system 
administrator. Only select this option if you are using a database 
catalog on a different domain. For this option you must enter your Login 
Name and Password in the fields provided. 

• Test Connection – click to make sure the connection to the Microsoft SQL 
Server is established. If you see the message ‘Connection succeeded but 
database does not exist’ then you must rectify this problem before 
continuing. Check that the database catalog name and security credentials are 
correct.  

• When the database connection details have been tested and the connection is 
successful, click Next. 

5. Click Next to perform the upgrade. 

6. When the Portal database upgrade is complete, click Close to close the Database 
Installation Tool. 

Repeat the Portal database upgrade steps on the Side B database server. 

Remove 32-Bit Application Support 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Some components used by earlier versions of Unified CCMP ran as 32-bit 
applications on a 64-bit operating system. Prior to installing the App/Web Server, 
remove 32-bit application support on the Servers where App/Web Server component 
will be installed: 

1. Click Start > All Programs > Accessories then right-click Command prompt 
and select Run as administrator. 

2. Copy the following script and paste into the command window: 
cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set 
w3svc/AppPools/Enable32bitAppOnWin64 0 

3. Press Enter to execute the script.  The script should return the following output: 
Enable32bitAppOnWin64           : (BOOLEAN) False 

If you are installing a dual-sided deployment, the steps in this section must be carried 
out on the web servers on both sides of the deployment. 

The App/Web Server component can now be installed. 

Install the Unified CCMP App/Web Server 
Install the new App/Web Server components on the A and B Side App/Web Servers.  

On the Side A Web Server: 
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1. To install the Unified CCMP App/Web component, in the Unified CCMP 
Installer, select App/Web Server, wait until the prerequisite checks have 
completed and click Install. The Management Portal: Application Server 
Component window displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. If the Management Portal: Application Server Components Dialog is displayed, 
click Install to install the additional required components. 

4. If the Microsoft .NET 4.5 Framework pre-requisite is missing, it will be installed 
at this point. Click Install to install the component and follow the on screen 
instructions. When the .NET 4.5 Framework is complete, restart the server to 
continue the installation of the App/Web Server. 

5. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 

6. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 

7. In the Destination Folder window, you can click Change to change the location 
that the App/Web Server components are installed to. 

8. In the Configure Database window: 
• SQLServer Name Enter the name of the machine that is to be the Database 

Server. The default of localhost is valid only when installing on the Database 
Server. Enter the name of the side A database server when installing the side 
A App/Web Server Components and enter the name of the side B database 
server when installing the side B App/Web Server Components.  

• Catalog Name Enter or select the name you selected while installing the 
Database Server component. By default this is Portal. 

• Connect Using Select the login credentials you want to use: 
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• Windows authentication This is the recommended option. 
• The SQL Server authentication This option should only be selected if 

you are using a database catalog on a different domain. For this option 
you must enter your SQL Server Login Name and Password in the fields 
provided. 

9. Click Install. 

10. When the installation has completed, click Finish. 
 

 

The machine will restart once the installation is complete.  

Repeat the installation steps on the Side B Web Server. 

Configure the Unified CCE Config Web Service 
On the Side A database server, the Unified CCE Config Web Service must be 
configured for each connected Unified CCE Server that is running Unified CCE 9.0 
or later.  

 

This step is only required if you are upgrading from Unified CCMP 9.0. Earlier 
versions of Unified CCMP were not able to connect to Unified CCE Servers running 
Unified CCE 9.0. 

To configure the Unified CCE Config Web Service: 

1. On the Side A database server, Go to Start > All Programs > 
Management Portal > Configuration Tools > Integrated Configuration 
Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

3. Click OK to open Unified CCMP Integrated Configuration Environment. 

4. Select the Setup tab and click Configure Cisco Unified CCE Servers to start 
the wizard. Click Next to go through each window in turn. 

5. In the Select Task dialog box select Modify an existing instance. 

6. Select the Unified CCE instance you want to modify and click Next. 

7. Complete the dialog boxes as follows: 
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• In the Configure Primary Unified Config Web Service dialog box, enter the 
following details 
• URL. This is the auto-generated URL of the primary unified config web 

service on the Unified CCE 
• User Name. This is a username with appropriate access to the Unified 

CCE that the web service is running on. This user must be in the domain 
security group <Server>_<UCCE-Instance>_Config, where <Server> 
is the name of the server running Unified CCE and <UCCE-Instance> is 
the name of the Unified CE Instance on this server. 

• Password. This is the password for the user. 
• In the Configure Primary ConAPI RMI Ports dialog box enter the following 

ConAPI details: 
• Local Registry Port. This is the port on the Unified CCE for the Unified 

CCMP Provisioning service to connect to. This will usually be 2099. 
• Remote Registry Port. This is the port on the Unified CCMP Database 

Server for the Unified CCE to connect to. This will usually be 2099. 
• Local Port. This is selected as the designated port for live provisioning 

traffic between the Unified CCE and Unified CCMP servers. It must be 
uniquely assigned for each Unified CCE and any firewalls between the 
CICM and Unified CCMP server must be configured to allow both-way 
traffic on this port. 

• In the Configure ConAPI Application Instance dialog box enter the following 
details: 
• Application Name. The name of the application to be used for 

provisioning Unified CCE from Unified CCMP. Specify the name of the 
application you configured in section Common ConAPI Credentials. 

• Application Key. Use the password for the application you specified 
above. 

• In the Multi Media Support dialog box, select Yes if you are using a Cisco 
Unified Web and E-Mail Interaction Manager application instance to provide 
support for non-voice interactions. The default is No. 

• In the Purge On Delete dialog box select Yes if you want to purge items from 
Unified CCE automatically when they are deleted from Unified CCMP. The 
default is Yes. 

• In the Self Skilling Enabled dialog box select Yes if you want to allow agents 
to reskill themselves. The default is No. 

• In the Supervisor Active Directory Integration dialog box select Yes if you 
want to enable support for associating existing Active Directory user 
accounts for Unified CCE Supervisors. The default is No. If you select Yes 
then you will be prompted to provide Active Directory information so that 
Windows user accounts can be listed.  



Chapter 9: Total Outage Upgrade  
Reinstate Replication  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  103   

 

8. The Summary dialog box summarizes the details of the Unified CCE being 
configured and the settings you have chosen. Check the details, and if you are 
satisfied, click Next. 

9. A confirmation message is displayed to indicate that the wizard has completed 
successfully. Click Exit to close the wizard. 

10. Click Configure Cisco Unified CCE Servers again, and repeat the steps above 
to configure the remaining Unified CCE Servers that are running Unified CCE 
9.0 or later. 

11. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

Reinstate Replication 

Restore Unified CCMP Database Replication 
Now you must reinstate replication between the Side A and Side B databases. 
Replication between the Portal databases is set up and monitored using the 
Replication Manager application which is available in the Unified CCMP Integrated 
Configuration Environment (ICE) tool. 
 

 

The user running the Unified CCMP Replication Manager must have administrator 
permissions in both Windows and SQL Server, for both the targeted publisher and 
subscriber servers. 

 

Always run Replication Manger on the Unified CCMP publisher database server. 

To restore replication: 

1. Go to Start > All Programs > Management Portal > Configuration Tools > 
Integrated Configuration Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

3. Click OK to open Unified CCMP Integrated Configuration Environment. 

4. The Cluster Configuration tool is open by default. From the Tool drop-down 
list select Replication Manager. 
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5. Click the Setup tab to see the replication setup details and to configure or 
disable replication. Details of the displayed fields are contained in the 
Configuring Replication section of Chapter 5 of this document. 

6. The values used when replication was first set-up are displayed. Verify that the 
Distributor Properties Data Folder and Log Folder reflect the current data 
directory for SQL Server. 

 

 

In most cases the recommended defaults are valid and should be used. 

7. Click Configure to start the replication configuration process. Progress 
messages will be logged into the Replication Output window informing you of 
the steps being performed as the database is replicated. 

8. You may be prompted to save pending changes to the database before 
continuing. If so, click Yes to save pending changes and continue. 

 

After you click Configure, it may take several minutes to set up replication. Once 
replication has been set up, the Replication Manager will display the Monitor tab. 

Confirm Replication is Working 
The Monitor tab allows you to monitor the general health of SQL Server Replication 
between Unified CCMP databases. 

To confirm that replication is working: 

1. In the Replication Manager, click the Monitor tab. 

2. In the top left hand pane, select the [Portal]:BaseSubWin publication. 

3. In the bottom right hand pane (called Actions in selected session), look for a 
message that starts “Delivered snapshot from . . . )”. When you see this message, 
replication is working correctly. 

4. Close the ICE tool. 

Restart and Validate 

Restart the Unified CCMP Services 
Following an upgrade it is good practice to restart all Unified CCMP services. 

To restart a service: 

1. Click Start > Run 

2. Enter Services.msc and then click OK. 
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3. If the service is in the Started state, right click the service name and click 
Restart. If a service is not started, right-click the service name and click Start. 

All UCCMP services on all Database and App/Web Servers should be restarted. 
 

 

After starting the System Monitoring Service and Application Service on the web 
servers, you will need to wait a few minutes before logging in to allow the services to 
load completely. 

Validate the Upgrade 
Check that the system is functional following the upgrade using the validation tests in 
the section Validating an Upgrade on page 60. 
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10. Split Side Upgrade 

Overview 
This chapter describes the steps involved to upgrade a dual-sided deployment, where 
the upgrade will be split, and one side will be upgraded at a time. Until the second 
side is upgraded, you will be running two different versions of the software side by 
side. 

This upgrade configuration temporarily breaks the replication and communication 
channels between the two sides of the system so each side can operate independently 
as a single-sided system. When replication is restored, the configuration from side A 
of the system will replace all configuration on side B of the system.  

Use this mode of operation with caution. Unified CCE and Unified CM changes 
committed to side B will be imported from the AW onto Side A, but any Unified 
CCMP specific configuration items (for example folders, users, security etc.) that are 
added, changed or deleted on Side B will not be reflected on Side A, even after 
replication is restored.  

This process has two parts.  
• Part 1 - split the dual-sided system and upgrade side A (see section Checklist for 

Split Side Upgrade Part 1 on page 107). 
• Part 2 - upgrade the split side B and restore replication (see section Checklist for 

Split Side Upgrade Part 2 on page 131). 
• The description assumes that you have a two tier deployment (separate database 

and app/web servers). 
 

 

Only use these instructions if you are upgrading from Unified CCMP 8.5(2) or later. 
If you are upgrading from 8.5(1) or earlier, follow the instructions in Chapter 11.It is 
not possible to perform a split side upgrade in this case. 

 

Before you proceed with the upgrade please ensure you have the original 
cryptographic passphrase entered during the original Unified CCMP installation as 
you will need it at several points during the upgrade. 
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Checklist for Split Side Upgrade Part 1 
The first part of the split side upgrade splits the dual-sided system and upgrade side 
A. 
 

Step Complete 

Prepare the in place Unified CCMP servers  

Configure DTC.  

Stop all Unified CCMP Services on the A-Side Unified CCMP 
servers.   

Remove database replication.   

Backup the Side A and Side B Portal databases.   

Delete the ReportServer and ReportServerTempDB database 
catalogs from the Side A DB Server  (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only).  

Uninstall SQL Server Components from Side A Web Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Uninstall SQL Server Components from Side A Database Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Uninstall Existing Unified CCMP Software on Side A  

Uninstall the Data Import Server from the Side A Database Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 
only).   

Uninstall the Provisioning Server from the Side A Database Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 
only).   

Uninstall the Database Installer from the Side A Database Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 
only).   

Uninstall the Application Server from the Side A App/Web Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 
only).   

Uninstall the Web Application from the Side A App/Web Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 
only).   
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Step Complete 

Uninstall the Database Component from the Side A App/Web Server 
(upgrading from Unified CCMP 9.0 only)  

Uninstall the App/Web Server Component from the Side A App/Web 
Server (upgrading from Unified CCMP 9.0 only)  

Install SQL Server 2008 R2 and Restore the Portal Database 

Install SQL Server 2008 R2 and SQL Server 2008 R2 SP1 (upgrading 
from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Configure SQL Agent Service Account (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Restore the Portal Database (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Add the SQL Agent User (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Add Network Service Accounts (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only)  

Install the new Unified CCMP Components and upgrade the Portal 
database (Side A) 

Install the new Unified CCMP Database Installer on the Side A 
database server.  

Upgrade the Unified CCMP Portal database on the side A database 
server.   

Remove 32-bit application support (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only)  

Install the Unified CCMP App/Web Servers on the side A App/Web 
Servers.  

Finalize Configuration and Restart 

Force failover connections to the active side.   

Update side B to enable provisioning and import (optional).  

Update provisioning on the Unified CCE AW  

Update provisioning on the side B database server  
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Step Complete 

Configure the Unified CCE Config Web Service (upgrades from 
Unified CCMP 9.0 only)  

Restart the Unified CCMP Services   

Prepare the in place Unified CCMP Servers 

Configure DTC 
Distributed Transaction Coordinator (DTC) must be configured on all Database 
Servers. DTC is used for Unified CCMP audit archiving. To configure DTC follow 
these steps: 

On the Side A Database Server: 

1. Click Start > All Programs > Administrative Tools > Component Services. 
The Component Services management tool is displayed. 

2. Expand Component Services > Computers > My Computer > Distributed 
Transaction Coordinator. 

3. Right-click on Local DTC and select Properties. The Local DTC Properties 
window is displayed. 

4. Select Security tab. 

5. In Security Settings ensure that Network DTC Access has Allow Inbound and 
Allow Outbound selected. 

6. Set Transaction Manager Communication to No Authentication Required. 

7. Click OK and accept the prompt to restart the MSDTC Service. 

Repeat the process on the Side B Database Server. 

Stop the Unified CCMP Services (Side A) 
Before starting the upgrade stop the Unified CCMP services on all A side servers. 

Data Import Server Service 
To stop the Unified CCMP: Data Import Server service: 

1. On the Side A database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Data Import Server service from the list of services. 

4. Select Stop. 
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5. Close the Services window. 

Partition Table Manager Service 
To stop the Unified CCMP: Partition Table Manager service: 

1. On the Side A database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Partitioning Table Manager service from the list of 
services. 

4. Select Stop. 

5. Close the Services window. 

Provisioning Server Service  
To stop the Unified CCMP: Provisioning Server service: 

1. On the Side A database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Provisioning Server service from the list of services. 

4. Select Stop. 

5. Close the Services window. 

System Monitoring Services, Application Search Services and 
Reporting Services 

1. On the side A App/Web server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the Unified CCMP: System Monitoring Services service from the 
list of services. 

4. Select Stop. 

5. At the message: “When UCCMP: System Monitoring Services stops, these other 
services will also stop. Do you want to stop these services?”, click Yes. 

6. Close the Services window. 

Remove Database Replication 
Before the upgrade can proceed, database replication must be removed. 
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Removing Replication – Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 

 

Follow these instructions if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

1. Ensure you are logged in to the Side A database server as a domain level user 
with administrative rights over both database servers. 

2. In your Windows desktop, click Start > Programs > Management Portal > 
and click the Configuration Management application. 

3. Click OK to login. 

4. Click UCCMP Servers. 

5. Click the Report Server Databases tab. 

6. Click Replication. 

7. Click Unreplicate. 

8. Click Execute. 

9. Click Yes when prompted to remove replication. This step may take some time 
to complete. 

10. Once complete, Click Close. 

11. Click OK. 

12. Select the UCCMP Database tab. 

13. Click Replication. 

14. Click Unreplicate. 

15. Click Execute. 

16. Click Yes when prompted to remove replication. This step may take some time 
to complete. 

17. Once complete, Click Close. 

18. Click OK. 

19. Click Close 

20. Exit Configuration Manager. 

Removing Replication– Unified CCMP 9.0 

 

Follow these instructions if you are upgrading from Unified CCMP 9.0. 
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1. Ensure you are logged in to the Side A database server as a domain level user 
with administrative rights over both database servers. 

2. In your Windows desktop, click Start > Programs > Management Portal > 
Configuration Tools > Integrated Configuration Environment. 

3. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

4. Click OK to open Unified CCMP Integrated Configuration Environment. 

5. The Cluster Configuration tool is open by default. From the Tool drop-down 
list select Replication Manager. 

6. Click the Setup tab to see the replication setup details. 

7. Click Disable to remove replication from the Unified CCMP database. When 
prompted, click Yes to proceed with replication removal. 

Replication removal may take several minutes. Wait for the ‘Replication Removed’ 
message to display in the Output Window and then exit the Integrated Configuration 
Environment. 

Back up the Unified CCMP Portal Databases (Side A) 
Back up the Unified CCMP Side A Portal database so that you can restore it in the 
event of a failure. 

1. Start SQL Server Management Studio as follows: 
• If you are upgrading from Unified CCMP 8.5(2) or 8.5(3) or earlier, on the 

Side A database server, click Start > All Programs > Microsoft SQL 
Server 2005 > SQL Server Management Studio.  

• If you are upgrading from Unified CCMP 9.0(x), on the Side A database 
server, click Start > All Programs > Microsoft SQL Server 2008 R2 > 
SQL Server Management Studio 

2. Connect to the Database Engine using Windows Authentication 

3. Navigate to the Portal database. 

4. Right-click Portal and select Tasks > Back Up.  

5. Amend the Destination as appropriate using the Remove and Add features 

6. Click OK. 

7. Close the SQL Server Management Studio window. 
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Delete ReportServer and ReportServerTempDB Databases (Side A) 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

SQL Server Reporting Services is not required for Unified CCMP 9, so the Reporting 
Services Databases can be removed. 

On the Side A database Server: 

1. Click Start > All Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio. 

2. Connect to the Database Engine using Windows Authentication 

3. Navigate to the ReportServer database. 

4. Right-click ReportServer and select Delete. The Delete Object window 
displays. 

5. Check the Close Existing Connections checkbox. 

6. Click OK to delete the database. 

7. Repeat Steps 3 to 6 and delete the ReportServerTempDB database. 
 

 

Do not delete the Portal database. 

Uninstall SQL Server from Web Server (Side A) 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Microsoft SQL Server 2005 Reporting Services components are not required for 
Unified CCMP 9.0(1) and above and must be removed. 

On the Side A Web Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the SQL Server Reporting Services service from the list of 
services. 

4. Select Stop. 

5. Close the Services window. 

6. Click Start > Control Panel > Uninstall a program. The Programs and 
Features window displays. 
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7. Select Microsoft SQL Server 2005. 

8. Click Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 

9. Select the MSSQLSERVER: Reporting Services Instance and the 
Workstation components (if present). Click Next. 

10. Review the Confirmation dialog box and click Finish to uninstall the SQL 
Server components. 

11. When the uninstallation procedure completes, close the Programs and Features 
window. 

Uninstall SQL Server from Database Server (Side A) 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Before installing Microsoft SQL Server 2008 R2, Microsoft SQL Server 2005 must 
be removed. 

On the Side A Database Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click each of the SQL Server services in turn from the list of services and 
select Stop. 

4. When all the SQL Server services are in the Stopped state, close the Services 
window. 

5. Click Start > Control Panel > Uninstall A Program. The Programs and 
Features window displays. 

6. Select Microsoft SQL Server 2005. 

7. Click  Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 

8. Select the MSSQLSERVER: Database Engine and the Workstation Components 
(if present). Click Next. 

9. Review the Confirmation screen and click Finish to uninstall the SQL Server 
components. 

10. When the uninstallation procedure completes. Close the Programs and Features 
window. 
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Uninstall Existing Unified CCMP Software on Side A 

Uninstall the Data Import Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Data Import Server component: 

1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Data Import Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Data Import Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Provisioning Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Provisioning Server component:  

1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Provisioning Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Provisioning Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. Manually delete the folder: C:\Program Files\Management 
Portal\Provisioning Server\Config if it exists. 

Uninstall the Database Installer Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

The Database Installer is the tool that maintains the database catalog. Uninstalling 
this does not remove the Unified CCMP Portal Database (which is upgraded later in 
the process). To remove the Database Installer component: 
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1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Database Install Tool. 

3. Click the Uninstall option, and confirm. 

Uninstall the Application Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Application Server component:  

1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Application Server. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Web Application Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Web Application component:  

1. On the Side A database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Web Application. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Web Application. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Database Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Database components:  
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1. On the Side A Database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Database Components. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Database Components. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Application Server Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Application Server components:  

1. On the Side A App/Web server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Application Server Components. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server Components. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. When the uninstall is complete, the App/Web server will reboot automatically. 

Install SQL Server and Restore the Portal Database (Side A) 

Install SQL Server  

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

On the Side A database server, install SQL Server 2008 R2 as described in section 
SQL Server on page 11, then follow the post installation configuration steps to 
configure DTC, SQL Server Network Protocols and any required Firewall rules as 
described in section Post-Installation Configuration on page 12. 

When the SQL Server 2008 R2 installation is complete, locate and install SQL Server 
2008 R2 Service Pack 1 before proceeding. 
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Configure SQL Agent Service Account 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

After installing SQL Server 2008 R2 SP1, configure the SQL Server Agent account 
to run under the SQL Agent User account defined in the Required User Accounts 
section. 

On the Side A Database Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right click the SQL Agent Service and select Properties. The Properties 
window displays. 

4. Select the Log On tab. 

5. Select This account. 

6. Enter the username and password of the SQL Server Agent user account. 

7. Click OK.  A notification message displays confirming that a service restart will 
be required for the change to take effect. 

8. Click OK. 

9. Right click the SQL Agent Service and select Restart. Check that the service 
returns to the Started state. 

Restore the Portal Database 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

After installing SQL Server 2008 R2, restore the Portal database backup. 

On the Side A database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Right click the Database folder and Click Restore Database. 

3. In the Restore Database window choose From Device and Add the location of 
the portal back up file from the same side database server. You may need to 
copy the backup file to a local file in order to access it. 

4. Select the backup file to restore the Portal database from and click OK.  

5. Select the check box next to the backup set you just added.  
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6. Select the Portal database as the restore destination from the To Database drop-
down list.  

7. Select Options and choose Overwrite the existing database. This will restore 
the database to the same location as the previous database. If you would like to 
choose a different location, update the Restore As path for each file to your 
preferred data file location.  

8. Click OK to start the restore.  

Add the SQL Agent User 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

For a dual-sided system, the SQL Agent User must be re-added. 

On the Side A database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Expand the security folder; a list of subfolders is displayed. 

3. Right Click the Logins folder and select New Login. 

4. Ensure the Windows authentication option is selected and enter the SQL Agent 
User domain and login name in the form <DOMAIN>\<LOGIN>. For example 
CISCO\sql_agent_user if your user is called sql_agent_user and belongs to the 
CISCO domain. 

5. Click User Mapping in the Select a page panel. 

6. Check the Portal database in the Users mapped to this login pane. The User 
column will auto-populate with the domain username for the SQL Agent User. 

7. Check the db_owner role in the Database Role Membership pane. 

8. Click OK to apply the changes. 

Add Network Service Accounts 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

You must also add the NETWORK SERVICE account for all web servers to the 
database logins with appropriate access permissions.  Before this can be done the 
existing accounts must be deleted from the Portal database logins. 

On the A side database server: 
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1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Locate and expand the Portal database. A list of folders is displayed. 
3. Expand the Portal > Security > Users folder. A list of database logins is 

displayed. 
4. Right click and Delete any occurrences of the NETWORK SERVICE account 

for all remote web servers in the deployment. Do not delete the entry for the 
NETWORK SERVICE account for the local machine (NT AUTHORITY\ 
NETWORK SERVICE). For remote web server machines  in the deployment 
the NETWORK SERVICE logins will be of the form 
<DOMAIN>\<WEBSERVER MACHINE NAME>$. For example 
CISCO\WEBSERVERA$ if your webserver is called WEBSERVERA and 
belongs to the CISCO domain. 

5. Expand the Security folder. A list of folders is displayed. 
6. Right Click the Logins folder and select New Login. 
7. Ensure the Windows authentication option is selected and enter the NT 

AUTHORITY\NETWORK SERVICE account for the Side A webserver  in the 
form <DOMAIN>\<WEBSERVER MACHINE NAME>$. 

8. Click User Mapping in the Select a page panel. 
9. Check the Portal database in the Users mapped to this login pane. Ensure that 

the User column correctly contains the Network Service account for the web 
server. 

10. Check the portalapp_ role, portalrs_role and portalreporting_role in the 
Database Role Membership pane. 

11. Click OK. 
12. Repeat steps 6 to 11 to add the NT AUTHORITY\NETWORK SERVICE 

account for each web server in the deployment. 

Install New Unified CCMP Components and Upgrade Database 
(Side A) 

Running the Unified CCMP Installer 

1. Insert the Unified CCMP DVD. If auto-run is enabled on the server, a window 
opens automatically showing a list of Unified CCMP components under the 
heading ‘Server Installation’ on the left hand side.  

 

 

If auto-run is disabled and you do not see the Installation Components screen, 
double-click the autorun.bat file located on the DVD to launch the Unified CCMP 
installer manually. 
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If UAC has not been disabled, launch the installation manually by right-clicking on 
the autorun.bat file located on the DVD and selecting run as administrator option. 

 

Some anti-virus software may state that the autorun.hta script file is malicious. 
Please ignore and continue with the installation. 

2. Follow the steps in the sections below to install each component, but read the 
information about prerequisites in the rest of this section first.  

Before you can install a Unified CCMP component, the prerequisites for that 
component must be present. The Unified CCMP Installer checks the prerequisites for 
each component as follows:  
• When you click on a component to install it, the installer displays a list of 

prerequisites for that component and checks that each prerequisite is present. As 
each prerequisite check completes, you will see a green tick (check successful) or 
a red cross (check failed). The Install option for that component is only available 
when all prerequisite checks are successful. 

• Where possible, the Unified CCMP DVD includes redistributable packages for 
prerequisites, so if a prerequisite check fails, you can click on the link in the 
Unified CCMP installer to install the missing prerequisite. Once all the 
prerequisite software is installed, you can click on the component again, then 
click Rerun to rerun the tests. 

• When all the prerequisites display a green tick, you will be able to click Install to 
install the chosen component. 

Install the Unified CCMP Database Installer 
This process does not upgrade the database directly. It just installs the Database 
Installer which is then used to upgrade the database.  

On the Side A Database Server: 

1. To install the Unified CCMP Database Installer, in the Unified CCMP Installer, 
select Database Server, and wait until the prerequisite checks have completed. 
If any checks fail, fix them as described above. When all checks have passed, 
click Install to begin the Database Server Installation. The Setup window 
displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 
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4. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 

5. In the Configure Database window: 
• Database Name Enter the name of the database catalog for Unified CCMP. 

By default this is Portal. 
• Connect Using Select the login credentials you want to use: 

• Windows Authentication Credentials of Application This is the 
recommended option. 

• SQL Server Authentication using the login and password below This 
option should only be selected if you are using a database catalog on a 
different domain. For this option you must enter your SQL Server Login 
Name and Password in the fields provided. 

• Click Next. 

6. In the Destination Folder window, you can click Change to change the location 
that the Database Server component is installed to. It is not necessary to install 
all Unified CCMP components to the same location. 

7. Click Install to install the Database Installer.  
 

 

During the Database Install Tool Installation, the J2SE pre-requisite will be 
automatically installed if it is not already present.  A Security Alert dialog box stating 
that ‘Revocation Information for the security certificate for this site is not available’ 
may be displayed in some circumstances. If this dialog box appears click Yes to 
continue. 

8. When the installation has completed, to upgrade your database immediately after 
installing the Database Installer, select the Launch Database Management 
Utility check box at the end of the installation before clicking Finish  

9. Click Finish. 

Upgrade the Unified CCMP Portal Database 
Once the Database Installer is installed, it can be used to upgrade the database. 
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On the Side A Database Server: 

1. If you selected the Launch Database Management Utility check box when you 
installed the Database Installer, the Database Installer launches automatically 
after it has been installed. Otherwise, launch the Database Installer manually 
from Start > All Programs > Management Portal > Database > Database 
Installer. The Database Installer is a wizard which guides you through the steps 
to upgrade the database.  

2. Click Next to begin the upgrade process.  

3. In the Database Setup Window choose Upgrade an Existing Database. Click 
Next to continue. 

4. In the SQL Server Connection Details window, take the following actions: 
• Server Name - select the Microsoft SQL Server where the Unified CCMP 

database is located. In this case this is the machine running the application, 
and so it must be left as the default (local). 

• Database Name - enter or select the name of the database catalog that was 
originally used for Unified CCMP. 

• Connect Using - select the login credentials you want to use: 
• The Windows account information you use to log in to your 

computer. This is the recommended option. 
• The Microsoft SQL Server login information assigned by the system 

administrator. Only select this option if you are using a database 
catalog on a different domain. For this option you must enter your Login 
Name and Password in the fields provided. 

• Test Connection – click to make sure the connection to the Microsoft SQL 
Server is established. If you see the message ‘Connection succeeded but 
database does not exist’ then you must rectify this problem before 
continuing. Check that the database catalog name and security credentials are 
correct.  

• When the database connection details have been tested and the connection is 
successful, click OK to continue. 

5. Click Next to perform the upgrade. 

Remove 32-Bit Application Support 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Some components used by earlier versions of Unified CCMP ran as 32-bit 
applications on a 64-bit operating system. Prior to installing the App/Web Server, 
remove 32-bit application support on the Servers where App/Web Server component 
will be installed: 



Chapter 10: Split Side Upgrade  
Install New Unified CCMP Components and Upgrade Database (Side A)  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  124   

 

1. Click Start > All Programs > Accessories then right-click Command prompt 
and select Run as administrator. 

2. Copy the following script and paste into the command window: 
cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set 
w3svc/AppPools/Enable32bitAppOnWin64 0 

3. Press Enter to execute the script.  The script should return the following output: 
Enable32bitAppOnWin64           : (BOOLEAN) False 

The App/Web Server component can now be installed. 

Install the Unified CCMP App/Web Server 
Install the new App/Web Server components on the side A App/Web Servers.  
1. To install the Unified CCMP App/Web component, select App/Web Server in 

the Unified CCMP Installer Window, wait until the prerequisite checks have 
completed and click Install. The Management Portal: Application Server 
Component window displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. If the Management Portal: Application Server Components Dialog is displayed, 
click Install to install the additional required components. 

4. If the Microsoft .NET 4.5 Framework pre-requisite is missing, it will be installed 
at this point. Click Install to install the component and follow the on screen 
instructions. When the .NET 4.5 Framework is complete, restart the server to 
continue the installation of the App/Web Server. 

5. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting 

6. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 
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7. In the Destination Folder window, you can click Change to change the location 
that the App/Web Server components are installed to. 

8. In the Configure Database window: 
• SQLServer Name Enter the name of the machine that is to be the Database 

Server. The default of localhost is valid only when installing on the Database 
Server. Enter the name of the side A database server. 

• Catalog Name Enter or select the name you selected while installing the 
Database Server component. By default this is Portal. 

• Connect Using Select the login credentials you want to use: 
• Windows authentication This is the recommended option. 
• The SQL Server authentication This option should only be selected if 

you are using a database catalog on a different domain. For this option 
you must enter your SQL Server Login Name and Password in the fields 
provided. 

9. Click Install. 
10. When the installation has completed, click Finish. 
 

 

The machine will restart once the installation is complete.  

Finalize Configuration and Restart 

Force Failover Connections to the Active Side 
To operate the two sides as independent systems, add host file entries to point 
failover connections to the current active side. This reduces the possibility that a 
failover will occur to the database on the other side when replication is down.  

Since the failover information is held in the database, both sides know about the other 
side, even though they are currently not replicated or running the same version of 
Unified CCMP. If a failover occurs then data integrity will be lost. To avoid this, 
when operating in single-sided mode add the failover connections to the hosts file on 
each machine to point back to the active side.  

For example, in the deployment shown in Figure 4, the host file entries are : 

Unified CCMP DBA 
127.0.0.1       Unified CCMP DBB 

Unified CCMP DBB 
127.0.0.1       Unified CCMP DBA 
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Unified CCMP WEBA 
<IP ADDRESS OF CCMPDBA>       Unified CCMP DBB 

127.0.0. 1       Unified CCMP WEBB  

Unified CCMP WEBB 
<IP ADDRESS OF CCMPDBB>       Unified CCMP DBA 

127.0.0. 1       Unified CCMP WEBA 

Figure 4: Host File Entries For Failover in Single-sided Mode . 

 

These entries must be removed once the upgrade is complete and the B-Side is re-
replicated with Side A. 

Update Side B to Enable Provisioning and Import (Optional) 
If the sides of the system are to be run independently for some time, you may need to 
enable provisioning and import to run on both Side A and Side B at the same time. 

To do this, follow the “Manual Provisioning/Import Failover” steps described in the 
Administration Manual for the version of Unified CCMP that is currently running on 
the B Side database server.  

Update Provisioning on the Unified CCE AW 
Update the CMS Control console on the Unified CCE AW to use unique ports for the 
side B Provisioning Server.  

On the AW: 

1. Click Start>Programs>Cisco Unified CCE Tools>Administration Tools  and 
select the CMS Control application. 

2. If the B side connection exists in the Application Connections then ensure it 
has different port numbers to the A side connection. 
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3. If the B side connection doesn’t exist then make a note of the A side connection 
details. 

4. Click Add. 

5. Enter the details as for the A side but update the Server Name and Hostname 
details to that of the B side, and use different port numbers.  

6. Click OK. 

7. Click Apply 

8. You will be notified that CMSJserver will restart. Please confirm this. 

Update Provisioning on the Side B Database Server 
To update provisioning on the side B database server, you must change the side B 
Provisioning Server ConAPI ports to match those on the Unified CCE AW. 

Update Provisioning – Unified CCMP 8.5(2) or Unified CCMP 8.5(3) 

 

Follow these instructions if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

1. On the side B database server, in your Windows desktop, click Start > 
Programs > Management Portal  and select the Configuration Management 
application. 

2. Click OK to login. 

3. Click Communication Servers. 

4. Click the Unified ICM tab. 

5. Select the appropriate Instance from the list. 

6. Update the port numbers to match those used in the CMS Control Console 

7. Click OK 

8. You will be informed that the Provisioning Services need to be restarted. Click 
OK. 

9. Click Close. 

10. Exit Configuration Manager. 

Update Provisioning – Unified CCMP 9.0 

 

Follow these instructions if you are upgrading from Unified CCMP 9.0. 
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1. On the side B database server, in your Windows desktop, click Start > 
Programs > Management Portal > Configuration Tools > Integrated 
Configuration Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

3. Click OK to open Unified CCMP Integrated Configuration Environment. 

4. The Cluster Configuration tool is open by default. Select the Connections tab 
on the left hand side.  

5. In the list of connections, locate the ConAPI connection to the Unified CCE AW 
and click on it. To reduce number of connections shown in the list, so you can 
find the relevant connection more easily, you may want to click the blue filter 
arrow on the right hand side of the window near the top, and select the following 
filter options: 
• Connection Source, Resource Type: Provisioning Service 
• Connection Destination, Resource Type: Cisco CICM 
• Connection Destination, Component Type: ConAPI 

6. On the Details tab for the connection, update the port numbers to match those 
used in the CMS Control Console. 

7. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

8. You will be informed that the Provisioning Services need to be restarted. Click 
OK. 

9. Click Close. 

Configure the Unified CCE Config Web Service 
On the Side A database server, the Unified CCE Config Web Service must be 
configured for each connected Unified CCE Server that is running Unified CCE 9.0 
or later.  

 

This step is only required if you are upgrading from Unified CCMP 9.0. Earlier 
versions of Unified CCMP were not able to connect to Unified CCE Servers running 
Unified CCE 9.0. 

To configure the Unified CCE Config Web Service: 
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1. On the Side A database server, Go to Start > All Programs > 
Management Portal > Configuration Tools > Integrated Configuration 
Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

3. Click OK to open Unified CCMP Integrated Configuration Environment. 

4. Select the Setup tab and click Configure Cisco Unified CCE Servers to start 
the wizard. Click Next to go through each window in turn. 

5. In the Select Task dialog box select Modify an existing instance. 

6. Select the Unified CCE instance you want to modify and click Next. 

7. Complete the dialog boxes as follows: 
• In the Configure Primary Unified Config Web Service dialog box, enter the 

following details 
• URL. This is the auto-generated URL of the primary unified config web 

service on the Unified CCE 
• User Name. This is a username with appropriate access to the Unified 

CCE that the web service is running on. This user must be in the domain 
security group <Server>_<UCCE-Instance>_Config, where <Server> 
is the name of the server running Unified CCE and <UCCE-Instance> is 
the name of the Unified CE Instance on this server. 

• Password. This is the password for the user. 
• In the Configure Primary ConAPI RMI Ports dialog box enter the following 

ConAPI details: 
• Local Registry Port. This is the port on the Unified CCE for the Unified 

CCMP Provisioning service to connect to. This will usually be 2099. 
• Remote Registry Port. This is the port on the Unified CCMP Database 

Server for the Unified CCE to connect to. This will usually be 2099. 
• Local Port. This is selected as the designated port for live provisioning 

traffic between the Unified CCE and Unified CCMP servers. It must be 
uniquely assigned for each Unified CCE and any firewalls between the 
CICM and Unified CCMP server must be configured to allow both-way 
traffic on this port. 

• In the Configure ConAPI Application Instance dialog box enter the following 
details: 



Chapter 10: Split Side Upgrade  
Finalize Configuration and Restart  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  130   

 

• Application Name. The name of the application to be used for 
provisioning Unified CCE from Unified CCMP. Specify the name of the 
application you configured in section Common ConAPI Credentials. 

• Application Key. Use the password for the application you specified 
above. 

• In the Multi Media Support dialog box, select Yes if you are using a Cisco 
Unified Web and E-Mail Interaction Manager application instance to provide 
support for non-voice interactions. The default is No. 

• In the Purge On Delete dialog box select Yes if you want to purge items from 
Unified CCE automatically when they are deleted from Unified CCMP. The 
default is Yes. 

• In the Self Skilling Enabled dialog box select Yes if you want to allow agents 
to reskill themselves. The default is No. 

• In the Supervisor Active Directory Integration dialog box select Yes if you 
want to enable support for associating existing Active Directory user 
accounts for Unified CCE Supervisors. The default is No. If you select Yes 
then you will be prompted to provide Active Directory information so that 
Windows user accounts can be listed.  

8. The Summary dialog box summarizes the details of the Unified CCE being 
configured and the settings you have chosen. Check the details, and if you are 
satisfied, click Next. 

9. A confirmation message is displayed to indicate that the wizard has completed 
successfully. Click Exit to close the wizard. 

10. Click Configure Cisco Unified CCE Servers again, and repeat the steps above 
to configure the remaining Unified CCE Servers that are running Unified CCE 
9.0 or later. 

11. To save and action your changes, either click the Save icon in the tool bar or 
select File > Save from the menu. 

Restart the Unified CCMP Services 
Following an upgrade it is good practice to restart all Unified CCMP services. 

To restart a service: 

1. Click Start > Run 

2. Enter Services.msc and then click OK. 

3. If the service is in the Started state, right click the service name and click 
Restart. If a service is not started, right-click the service name and click Start. 

All UCCMP services on the side A Database and App/Web Servers should be 
restarted. 
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After starting the System Monitoring Service and Application Service on the web 
servers, you will need to wait a few minutes before logging in to allow the services to 
load completely. 

Checklist for Split Side Upgrade Part 2 
The second part of the split side upgrade applies the upgrade to side B and restores 
replication. 
 

Step Complete 

Prepare the in place Unified CCMP servers  

Stop all Unified CCMP Services on the B-Side Unified CCMP 
servers.   

Backup the Side A and Side B Portal databases.   

Delete the ReportServer and ReportServerTempDB database 
catalogs from the Side B DB Server (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only). 

 Uninstall SQL Server Components from Side B Web Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Uninstall SQL Server Components from Side B Database Server 
(upgrading from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Uninstall Existing Unified CCMP Software on Side B  

Uninstall the Unified CCMP Data Import Server from the Side B 
Database Server(upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3) only).   

Uninstall the Unified CCMP Provisioning Server from the Side B 
Database Server (upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3) only).   

Uninstall the Unified CCMP Database Installer from the Side B 
Database Server (upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3) only).   

Uninstall the Unified CCMP Application Server from the Side B 
App/Web Server (upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3) only).   
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Step Complete 

Uninstall the Unified CCMP Web Application from the Side B 
App/Web Server (upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3) only).   

Uninstall the Database Component from the Side B App/Web Server 
(upgrading from Unified CCMP 9.0 only)  

Uninstall the App/Web Server Component from the Side B App/Web 
Server (upgrading from Unified CCMP 9.0 only)  

Install SQL Server 2008 R2 and Restore the Portal Database 

Install SQL Server 2008 R2 and SQL Server 2008 R2 SP1 (upgrading 
from Unified CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Configure SQL Agent Service Account (upgrading from Unified 
CCMP 8.5(2) or Unified CCMP 8.5(3) only)  

Restore the Portal Database (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Add the SQL Agent User (upgrading from Unified CCMP 8.5(2) or 
Unified CCMP 8.5(3) only)  

Add Network Service Accounts (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only)  

Upgrade the Portal database and install the Unified CCMP 
Components   

Install the Database Installer on the Side B Database Server.  

Do one of the following: 
• (Option 1) Upgrade the Portal database on the side B database 

server  
• (Option 2) Restore the Side B Database from the Side A Database 

Backup.   

Remove 32-bit application support (upgrading from Unified CCMP 
8.5(2) or Unified CCMP 8.5(3) only)  

Install the Unified CCMP App/Web Servers on the side B App/Web 
Servers.  

Finalize Configuration 
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Step Complete 

Stop forcing failover connections to the active side.   

Restore Unified CCMP database replication  

Confirm replication is working  

Restart and Validate 

Restart the Unified CCMP Services   

Validate the upgrade  

Prepare the in place Unified CCMP Servers 

Stop the Unified CCMP Services 
Before starting the upgrade stop the Unified CCMP services on all B side servers. 

Data Import Server Service 
To stop the Unified CCMP: Data Import Server service: 

1. On the Side B database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Data Import Server service from the list of services. 

4. Select Stop. 

5. Close the Services window. 

Partition Table Manager Service 
To stop the Unified CCMP: Partition Table Manager service: 

1. On the Side B database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Partitioning Table Manager service from the list of 
services. 

4. Select Stop. 

5. Close the Services window. 

Provisioning Server Service  
To stop the Unified CCMP: Provisioning Server service: 
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1. On the Side B database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Provisioning Server service from the list of services. 

4. Select Stop. 

5. Close the Services window. 

System Monitoring Services, Application Search Services and 
Reporting Services 

1. On the side B App/Web server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the Unified CCMP: System Monitoring Services service from the 
list of services. 

4. Select Stop. 

5. At the message: “When UCCMP: System Monitoring Services stops, these other 
services will also stop. Do you want to stop these services?”, click Yes. 

6. Close the Services window. 

Back up the Unified CCMP Portal and Report Server Databases 
Back up the Unified CCMP Portal databases so that you can restore them in the event 
of a failure. 

1. Start SQL Server Management Studio as follows: 
• If you are upgrading from Unified CCMP 8.5(2) or 8.5(3) or earlier, on the 

Side A database server, click Start > All Programs > Microsoft SQL 
Server 2005 > SQL Server Management Studio.  

• If you are upgrading from Unified CCMP 9.0(x), on the Side A database 
server, click Start > All Programs > Microsoft SQL Server 2008 R2 > 
SQL Server Management Studio 

2. Connect to the Database Engine using Windows Authentication. 

3. Navigate to the Portal database. 

4. Right-click Portal and select Tasks > Back Up.  

5. Amend the Destination as appropriate using the Remove and Add features 

6. Click OK 

7. Close the Services window. 

8. Repeat this process for the Unified CCMP Portal database on the Side B 
database server.  
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Delete ReportServer and ReportServerTempDB Databases (Side B) 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

SQL Server Reporting Services is not required for Unified CCMP 9, so the Reporting 
Services Databases can be removed. 

On the Side B database Server: 

1. Click Start > All Programs > Microsoft SQL Server 2005 > SQL Server 
Management Studio. 

2. Connect to the Database Engine using Windows Authentication 

3. Navigate to the ReportServer database. 

4. Right-click ReportServer and select Delete. The Delete Object window 
displays. 

5. Check the Close Existing Connections checkbox. 

6. Click OK to delete the database. 

7. Repeat Steps 3 to 6 and delete the ReportServerTempDB database. 
 

 

Do not delete the Portal database. 

Uninstall SQL Server Components from Web Server (Side B) 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Microsoft SQL Server 2005 Reporting Services components are not required for 
Unified CCMP 9.0(1) and above and must be removed. 

On the Side B Web Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the SQL Server Reporting Services service from the list of 
services. 

4. Select Stop. 

5. Close the Services window. 

6. Click Start > Control Panel > Uninstall a program. The Programs and 
Features window displays. 
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7. Select Microsoft SQL Server 2005. 

8. Click Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 

9. Select the MSSQLSERVER: Reporting Services Instance and the 
Workstation components (if present). Click Next. 

10. Review the Confirmation dialog box and click Finish to uninstall the SQL 
Server components. 

11. When the uninstallation procedure completes, close the Programs and Features 
window. 

Uninstall SQL Server from Database Server (Side B) 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Before installing Microsoft SQL Server 2008 R2, Microsoft SQL Server 2005 must 
be removed. 

On the Side B Database Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click each of the SQL Server services in turn from the list of services and 
select Stop. 

4. When all the SQL Server services are in the Stopped state, close the Services 
window. 

5. Click Start > Control Panel > Uninstall A Program. The Programs and 
Features window displays. 

6. Select Microsoft SQL Server 2005. 

7. Click  Uninstall. The Microsoft SQL Server 2005 Setup dialog displays. 

8. Select the MSSQLSERVER: Database Engine and the Workstation Components 
(if present). Click Next. 

9. Review the Confirmation screen and click Finish to uninstall the SQL Server 
components. 

10. When the uninstallation procedure completes. Close the Programs and Features 
window. 
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Uninstall Existing Unified CCMP Software on Side B 

Uninstall the Data Import Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Data Import Server component: 

1. On the Side B database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Data Import Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Data Import Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Provisioning Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Provisioning Server component:  

1. On the Side B database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Provisioning Server. 

3. Click Uninstall. A window displays asking you if you are sure that you want to 
remove the Management Portal: Provisioning Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. Manually delete the folder: C:\Program Files\Management 
Portal\Provisioning Server\Config if it exists. 

Uninstall the Database Installer Component 
The Database Installer is the tool that maintains the database catalog. Uninstalling 
this does not remove the Unified CCMP Portal Database (which is upgraded later in 
the process). To remove the Database Installer component: 

1. On the Side B database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Database Install Tool. 
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3. Click the Uninstall option, and confirm. 

Uninstall the Application Server Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Application Server component:  

1. On the Side B database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Application Server. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Web Application Component 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

To uninstall the Web Application component:  

1. On the Side B database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Web Application. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Web Application. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Database Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Database components:  

1. On the Side B Database server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Database Components. 
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3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Database Components. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

Uninstall the Application Server Components 

 

This step is only required if you are upgrading from Unified CCMP 9.0. 

To uninstall the Application Server components:  

1. On the Side B App/Web server, click Start > Control Panel > Uninstall a 
program. The Programs and Features window displays. 

2. Select Management Portal: Application Server Components. 

3. Click the Uninstall option. A window displays asking you if you are sure that 
you want to remove the Management Portal: Application Server Components. 

4. Click Yes. The Setup Status window displays. The extent of the uninstallation 
progress displays on the progress bar. 

5. When the uninstall is complete, the App/Web server will reboot automatically. 

Install SQL Server and Restore the Portal Database (Side B) 

Install SQL Server  

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

On the Side B database server, install SQL Server 2008 R2 as described in section 
SQL Server on page 11, then follow the post installation configuration steps to 
configure DTC, SQL Server Network Protocols and any required Firewall rules as 
described in section Post-Installation Configuration on page 12. 

When the SQL Server 2008 R2 installation is complete, locate and install SQL Server 
2008 R2 Service Pack 1 before proceeding. 

Configure SQL Agent Service Account 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

After installing SQL Server 2008 R2 SP1, configure the SQL Server Agent account 
to run under the SQL Agent User account defined in the Required User Accounts 
section. 
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On the Side B Database Server: 

1. Click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right click the SQL Agent Service and select Properties. The Properties 
window displays. 

4. Select the Log On tab. 

5. Select the This account radio button. 

6. Enter the username and password of the SQL Server Agent user account. 

7. Click OK.  A notification message displays confirming that a service restart will 
be required for the change to take effect. 

8. Click OK. 

9. Right click the SQL Agent Service and select Restart. Check that the service 
returns to the Started state. 

Restore the Portal Database 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

After installing SQL Server 2008 R2, restore the Portal database backup. 

On the Side B database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Right click the Database folder and Click Restore Database. 

3. In the Restore Database window choose From Device and Add the location of 
the portal back up file from the same side database server. You may need to 
copy the backup file to a local file in order to access it. 

4. Select the backup file to restore the Portal database from and click OK.  

5. Select the check box next to the backup set you just added. 

6. Select the Portal database as the restore destination from the To Database drop-
down list.  

7. Select Options and choose Overwrite the existing database. This will restore 
the database to the same location as the previous database. If you would like to 
choose a different location, update the Restore As path for each file to your 
preferred data file location.  

8. Click OK to start the restore.  
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Add the SQL Agent User 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

On the Side B database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Expand the security folder; a list of subfolders is displayed. 

3. Right Click the Logins folder and select New Login 

4. Ensure the Windows authentication option is selected and enter the SQL Agent 
User domain and login name in the form <DOMAIN>\<LOGIN>. For example 
CISCO\sql_agent_user if your user is called sql_agent_user and belongs to the 
CISCO domain. 

5. Click User Mapping in the Select a page panel. 

6. Check the Portal database in the Users mapped to this login pane. The User 
column will auto-populate with the domain username for the SQL Agent User. 

7. Check the db_owner role in the Database Role Membership pane. 

8. Click OK to apply the changes. 

Add Network Service Accounts 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

You must also add the NETWORK SERVICE account for all web servers to the 
database logins with appropriate access permissions.  Before this can be done the 
existing accounts must be deleted from the Portal database logins. 

On the side B database server: 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Locate and expand the Portal database. A list of folders is displayed. 
3. Expand the Portal > Security > Users folder. A list of database logins is 

displayed. 
4. Right click and Delete any occurrences of the NETWORK SERVICE account 

for all remote web servers in the deployment. Do not delete the entry for the 
NETWORK SERVICE account for the local machine (NT AUTHORITY\ 
NETWORK SERVICE). For remote web server machines  in the deployment 
the NETWORK SERVICE logins will be of the form 
<DOMAIN>\<WEBSERVER MACHINE NAME>$. For example 
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CISCO\WEBSERVERA$ if your webserver is called WEBSERVERA and 
belongs to the CISCO domain. 

5. Expand the Security folder. A list of folders is displayed. 
6. Right Click the Logins folder and select New Login. 
7. Ensure the Windows authentication option is selected and enter the NT 

AUTHORITY\NETWORK SERVICE account for the Side A webserver  in the 
form <DOMAIN>\<WEBSERVER MACHINE NAME>$. 

8. Click User Mapping in the Select a page panel. 
9. Check the Portal database in the Users mapped to this login pane. Ensure that 

the User column correctly contains the Network Service account for the web 
server. 

10. Check the portalapp_ role, portalrs_role and portalreporting_role in the 
Database Role Membership pane. 

11. Click OK. 
12. Repeat steps 6 to 11  add the NT AUTHORITY\NETWORK SERVICE account 

for each web server in the deployment. 

Upgrade Portal Database and Install Unified CCMP Components 
Before upgrading the database the new Database Installer tool must be installed, this 
will then be used to perform the database upgrade.  

After you have installed the Database Installer, you need to decide whether to restore 
your database from the A side backup, or to upgrade the B side database directly. 
• Option 1 - If the system has been running in single-sided mode for less than 24 

hours, then we recommend that you upgrade the B side database as described in 
the section Upgrade Portal Database on Side B Database Server below.  

• Option 2 - If the system has been running in single-sided mode for more than 24 
hours, then we recommend that you restore the database on side B from the side 
A backup of the Portal database that you made when you started part 2 of the 
split side upgrade. This process is described in the section Restore the Side B 
Database from the Side A Database Backup below. 

Install the Database Installer on the Side B Database Server 
To install the Unified CCMP Database Installer on the Side B Database Server, refer 
to the steps in section Install the Unified CCMP Database Installer on page 121. 
 

 

This process does not upgrade the database directly. It just installs the Database 
Installer which is then used to upgrade the database. 
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To upgrade your database immediately after installing the Database Installer, select 
the Launch Database Management Utility check box at the end of the installation 
before clicking Finish. 

Upgrade Portal Database on Side B Database Server (Option 1) 
Choose the option if your system has been running in single-sided mode for less than 
24 hours. 

1. If you selected the Launch Database Management Utility check box when you 
installed the Database Installer, the Database Installer launches automatically 
after it has been installed. Otherwise, launch the Database Installer manually 
from Start > All Programs > Management Portal > Database > Database 
Installer. The Database Installer is a wizard which guides you through the steps 
to upgrade the database.  

2. Click Next to go through each window in turn.  

3. In Select an Action to Perform window select Upgrade an existing database 
and click Next. 

4. In the SQL Server Connection Details window, take the following actions: 
• Server Name - select the Microsoft SQL Server where the Unified CCMP 

database is located. In this case this is the machine running the application, 
and so it must be left as the default (local). 

• Database Name - enter or select the name of the database catalog that was 
originally used for Unified CCMP. 

• Connect Using - select the login credentials you want to use: 
• The Windows account information you use to log in to your 

computer. This is the recommended option. 
• The Microsoft SQL Server login information assigned by the system 

administrator. Only select this option if you are using a database 
catalog on a different domain. For this option you must enter your Login 
Name and Password in the fields provided. 

• Test Connection – click to make sure the connection to the Microsoft SQL 
Server is established. If you see the message ‘Connection succeeded but 
database does not exist’ then you must rectify this problem before 
continuing. Check that the database catalog name and security credentials are 
correct.  

• When the database connection details have been tested and the connection is 
successful, click OK to continue. 

5. Click Next to perform the upgrade. The upgrade may take several minutes. 

6. When the upgrade completes, click Close to close the Database Installer Wizard.  
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Restore the Side B Database from the Side A Database Backup (Option 2) 
Choose the option if your system has been running in single-sided mode for more 
than 24 hours. This will ensure that audit information is consistent across both sides. 

On the new Side B database server: 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2> Management 
Studio. 

2. Right Click the Portal database and Click Tasks > Restore. 

3. In the Restore Database window choose From Device and Add the location of 
the portal back up file from the A-Side database server.  You may need to copy 
the backup file to a local file in order to access it. 

4. Select the backup file to restore the Portal database from and click OK. 

5. Select the check box next to the backup set you just added. 

6. Select the Portal database as the restore destination from the To Database drop-
down list. 

7. Select Options and choose Overwrite the existing database. 

8. Click OK to start the restore. 

Remove 32-Bit Application Support 

 

This step is only required if you are upgrading from Unified CCMP 8.5(2) or Unified 
CCMP 8.5(3). 

Some components used by earlier versions of Unified CCMP ran as 32-bit 
applications on a 64-bit operating system. Prior to installing the App/Web Server, 
remove 32-bit application support on the Servers where App/Web Server component 
will be installed as follows: 

1. Click Start > All Programs > Accessories then right-click Command prompt 
and select Run as administrator. 

2. Copy the following script and paste into the command window: 
cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set 
w3svc/AppPools/Enable32bitAppOnWin64 0 

3. Press Enter to execute the script.  The script should return the following output: 
Enable32bitAppOnWin64           : (BOOLEAN) False 

The App/Web Server component can now be installed. 

Install the Unified CCMP App/Web Server 
Install the new App/Web Server components on the B Side App/Web Server.  
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1. To install the Unified CCMP App/Web component, in the Unified CCMP 
Installer, select App/Web Server, wait until the prerequisite checks have 
completed and click Install. The Management Portal: Application Server 
Component window displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. If the Management Portal: Application Server Components Dialog is displayed, 
click Install to install the additional required components. 

4. If the Microsoft .NET 4.5 Framework pre-requisite is missing, it will be installed 
at this point. Click Install to install the component and follow the on screen 
instructions. When the .NET 4.5 Framework is complete, restart the server to 
continue the installation of the App/Web Server. 

5. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting 

6. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 

7. In the Destination Folder window, you can click Change to change the location 
that the App/Web Server components are installed to. 

8. In the Configure Database window: 
• SQLServer Name Enter the name of the machine that is to be the Database 

Server. The default of localhost is valid only when installing on the Database 
Server. Enter the name of the side B database server. 

• Catalog Name Enter or select the name you selected while installing the 
Database Server component. By default this is Portal. 

• Connect Using Select the login credentials you want to use: 
• Windows authentication This is the recommended option. 
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• The SQL Server authentication This option should only be selected if 
you are using a database catalog on a different domain. For this option 
you must enter your SQL Server Login Name and Password in the fields 
provided. 

9. Click Install. 

10. When the installation has completed, click Finish. 
 

 

The machine will restart once the installation is complete.  

Finalize Configuration 

Stop Forcing Failover Connections to the Active Side 
Remove the entries you made to the hosts files on all servers to force failover 
connections to the active side. 

Restore Unified CCMP Database Replication 
Replication between the Portal databases is set up and monitored using the 
Replication Manager application which is available in the Unified CCMP Integrated 
Configuration Environment (ICE) tool. 
 

 

The user running the Unified CCMP Replication Manager must have administrator 
permissions in both Windows and SQL Server, for both the targeted publisher and 
subscriber servers. 

 

Always run Replication Manger on the Unified CCMP publisher database server. 

To start the Unified CCMP Integrated Configuration Environment, proceed as 
follows: 

1. Go to Start > All Programs > Management Portal > Configuration Tools > 
Integrated Configuration Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 

3. Click OK to open Unified CCMP Integrated Configuration Environment. 
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4. The Cluster Configuration tool is open by default. From the Tool drop-down 
list, select Replication Manager. 

5. Click the Setup tab to see the replication setup details and to configure or 
disable replication. Details of the displayed fields are contained in the 
Configuring Replication section of Chapter 5 of this document. 

6. The values used when replication was first set-up are displayed. Verify that the 
Distributor Properties Data Folder and Log Folder reflect the current data 
directory for SQL Server. 

 

 

In most cases the recommended defaults are valid and should be used. 

7. Click Configure to start the replication configuration process. Progress 
messages will be logged into the Replication Output window informing you of 
the steps being performed as the database is replicated. 

8. You may be prompted to save pending changes to the database before 
continuing. If so, click Yes to save pending changes and continue. 

 

After you click Configure, it may take several minutes to set up replication. Once 
replication has been set up, the Replication Manager will display the Monitor tab. 

Confirm Replication is Working 
The Monitor tab allows you to monitor the general health of SQL Server Replication 
between Unified CCMP databases. 

To confirm that replication is working: 

1. In the Replication Manager, click the Monitor tab. 

2. In the top left hand pane, select the [Portal]:BaseSubWin publication. 

3. In the bottom right hand pane (called Actions in selected session), look for a 
message that starts “Delivered snapshot from . . . )”. When you see this message, 
replication is working correctly. 

4. Close the ICE tool. 

Restart and Validate 

Restart the Unified CCMP Services 
Following an upgrade it is good practice to restart all Unified CCMP services. 

To restart a service: 

1. Click Start > Run 
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2. Enter Services.msc and then click OK. 

3. If the service is in the Started state, right click the service name and click 
Restart. If a service is not started, right-click the service name and click Start. 

All UCCMP services on all Database and App/Web Servers should be restarted. 
 

 

After starting the System Monitoring Service and Application Service on the web 
servers, you will need to wait a few minutes before logging in to allow the services to 
load completely. 

Validate the Upgrade 
Check that the system is functional following the upgrade using the validation tests in 
the section Validating an Upgrade on page 60. 
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11. Upgrade From Version 8.5(1) or Earlier 

Overview  
Versions of Unified CCMP prior to 8.5(2) ran on the 32-bit version of Windows 
Server 2003. Unified CCMP 8.5(2) and later runs on Windows Server 2008 R2 for 
which Microsoft do not support cross-architecture in-place upgrades. This means that 
you must upgrade your operating system before you can upgrade from Unified 
CCMP 8.5(1) or earlier. 

To upgrade Unified CCMP, a backup of the Unified CCMP databases must be taken 
before starting the upgrade. After the operating system, SQL Server prerequisites and 
the Unified CCMP 9.0(x) Database component are installed the database, backups 
can be restored and upgraded as part of the installation process.  
This checklist describes the steps that will be performed during the upgrade and can 
be used to track progress through the upgrade and ensure that no steps are missed. 
Depending on the version you are upgrading from, and the deployment model you 
have, some steps will not apply. The description assumes that you have a two tier 
deployment (separate database and app/web servers). 
 

 

Ensure that you have up-to-date backups of all Unified CCMP databases before you 
begin. 

 

Before you proceed with the upgrade please ensure you have the original 
cryptographic passphrase entered during the original Unified CCMP installation as 
you will need it at several points during the upgrade. 
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Checklist 
 

Step Complete 

Prepare to Upgrade 

Stop the Unified CCMP Services  

[Dual-sided Systems Only] Remove Reporting Services database 
replication. 

 

[Dual-sided Systems Only] Remove Portal database replication.  

Backup the Portal Databases  

Install and configure Windows 2008 Server R2 SP1  

Install SQL Server and Prerequisites 

Install SQL Server 2008 R2 and SQL Server 2008 R2 SP1  

Install the prerequisite software  

Add the SQL Agent User   

Add Network Service Accounts  

Install New Unified CCMP Components and Upgrade Database 

Install the Database Installer (side A)  

[Dual-sided Systems Only] Install the Database Installer (side B)  

Install the Unified CCMP database (side A)  

[Dual-sided Systems Only] Install the Unified CCMP database (side 
B) 

 

Restore the Portal database backup (Side A)  

[Dual-sided Systems Only] Restore the Portal database backup (Side 
B) 

 

Upgrade the Portal Database (Side A)  

[Dual-sided Systems Only] Upgrade the Portal database (side B)  

Install the Unified CCMP App/Web Server component (Side A)  
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Step Complete 

[Dual-sided Systems Only] Install the Unified CCMP App/Web 
component (Side B) 

 

Finalize Configuration  

[Dual-sided Systems Only] Restore Unified CCMP database 
replication 

 

[Dual-sided Systems Only] Confirm Replication is working  

Configure the Windows Firewall for UCCE Provisioning  

Ensure all Unified CCMP Windows Services have been started on all 
Database and App/Web Servers 

 

Restart and Validate  

Ensure all Unified CCMP Windows Services have been started on all 
Database and App/Web Servers.   

Test that the upgrade was successful.  

Prepare to Upgrade 
This section describes the procedure for upgrading Unified CCMP. 
 

 

Before you proceed with the upgrade please ensure you have the original 
cryptographic passphrase entered during the original Unified CCMP installation as 
you will need it at several points during the upgrade. 

This procedure covers both single-sided and dual-sided deployment models. The term 
‘Side A’ applies to both the A Side of a dual-sided installation and a single-sided 
installation. 

Unified CCMP 9.0(x) runs on the Windows Server 2008 R2 (64-Bit) operating 
system. Before the Unified CCMP 9.0(x) components can be installed, the Unified 
CCMP databases must be backed up and copied to a safe location so that the 
Windows operating system upgrade can be carried out.  Prior to backing up the 
databases, the Unified CCMP services must be stopped and if the system is dual-
sided, database replication must be disabled. 

Stop the Unified CCMP Services 
Before starting the upgrade the Unified CCMP services must be stopped on all 
servers. 
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To stop the Unified CCMP: Data Import Server service, proceed as follows: 

1. On the Side A database server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc. The Services window displays. 

3. Right-click the UCCMP: Data Import Server service from the list of services.  
Note:  In older versions of Unified CCMP this service appears as Management 
Portal: Data Import Server. 

4. Click Stop. 

5. Repeat this process for all running Unified CCMP services on the database 
server. 

6. Close the Services window. 

7. For dual-sided installations, repeat this process on the Side B database server. 

To stop the Unified CCMP:  Monitoring Service, the Unified CCMP: Application 
Search Server service, and the Unified CCMP: Reporting Services service, proceed 
as follows: 

1. On the Side A web server, click Start > Run. The Run window displays. 

2. In the Open field, enter services.msc.  The Services window displays. 

3. Right-click and click Stop on each of the Unified CCMP services from the list.  
Note:  In older versions of Unified CCMP these services appear as 
Management Portal: <SERVICE NAME> 

4. Close the Services window. 

5. For dual-sided installations, repeat this process on the Side B web server. 

Remove Reporting Services Replication 
 

 

If you have a dual-sided installation of Unified CCMP 8.0 or above Reporting 
Services replication must also be removed.  

Once replication has been successfully removed then you may close the 
Configuration Manager.  

Follow these steps to remove replication from the Reporting Services databases.  

1. Ensure you are logged in to the Side A database server as a domain level user 
with administrative rights over both database servers. 

2. In your Windows desktop, click Start > Programs > Management Portal > 
and click the Configuration Manager application. 

3. Click OK to login. 

4. Click UCCMP Servers. 
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5. Click the Report Server Databases tab. 

6. Click Replication. 

7. Click Unreplicate. 

8. Click Execute. 

9. Click Yes when prompted to remove replication. This step may take some time 
to complete. 

10. After replication has been successfully removed, click OK to close the 
Replication Removal dialog box. 

Remove Portal Database Replication 
 

 

If you have a dual-sided installation then you must follow these steps to remove 
replication.  

Follow these steps to remove replication from the Portal databases.  

1. Ensure you are logged in to the Side A database server as a domain level user 
with administrative rights over both database servers. 

2. In your Windows desktop, click Start > All Programs > Management Portal 
> Configuration Manager. Note: In some earlier versions of Unified CCMP 
this tool is called Cluster Configuration. 

3. Click UCCMP Servers.  Note: In some earlier versions of Unified CCMP this 
step is not required. 

4. Select the UCCMP Database tab.  Note: In some earlier versions of Unified 
CCMP this tab is labeled Portal Database. 

5. Click Replication. 

6. Click Unreplicate, then Execute. 

7. Click Yes when prompted to remove replication.  Note: Removing replication 
may take some time. 

8. Once complete, Click Close. 

9. After replication has been successfully removed, click OK to close the 
Replication Removal dialog box. 

Back up the Databases 
Back up the Portal and Report Server databases and copy the backups to a safe 
location where they can be accessed once the Windows 2008 R2 Server Operating 
System has been installed. 
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1. On the Side A database server click Start > All Programs > Microsoft SQL 
Server > Enterprise Manager (for installations using SQL Server 2005 then 
you must select Start > All Programs > Microsoft SQL Server 2005 > SQL 
Server Management Studio). 

2. Navigate to Portal database. 

3. Right-click Portal and select Tasks > Backup. Save the .bak file to a suitable 
location. 

For a dual-sided system repeat the backup process for the Side B database server. 

Windows Server 2008 R2 SP1 Installation 
After the database backups have been taken and stored in safe location, install 
Windows Server 2008 R2 SP1 on the Unified CCMP Servers. 
 

 

If your Unified CCMP servers are virtual machines then rebuild these before 
installing Windows Server 2008 R2 SP1, as the SCSI controller is not compatible 
with windows 2008 R2 

Apply the Windows post-installation configuration steps for Unified CCMP 
described in the Server Requirements section of Chapter 2. 

Install SQL Server and Prerequisites 

Install Microsoft SQL Server 2008 R2 SP1  
Install Microsoft SQL Server 2008 R2 and Microsoft SQL Server 2008 R2 SP1 as 
described in the SQL Server section of Chapter 3. 

Install the Prerequisite Software 
Review the list of prerequisite software described in Chapter 2 and install the 
remaining prerequisites on the Unified CCMP servers. 

Add the SQL Agent User  
For a dual-sided system, the SQL Agent User must be re-added. 

On the Side A database server:  

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Expand the security folder; a list of subfolders is displayed. 

3. Right Click the Logins folder and select New Login 

4. Ensure the Windows authentication option is selected and enter the SQL Agent 
User domain and login name in the form <DOMAIN>\<LOGIN>. For example 
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CISCO\sql_agent_user if your user is called sql_agent_user and belongs to the 
CISCO domain. 

5. Click User Mapping in the Select a page panel. 

6. Check the Portal database in the Users mapped to this login pane. The User 
column will auto-populate with the domain username for the SQL Agent User. 

7. Check the db_owner role in the Database Role Membership pane. 

8. Click OK to apply the changes. 

Repeat these steps on the Side B Database Server. 

Add Network Service Accounts 
You must also add the NETWORK SERVICE account for all web servers to the 
database logins with appropriate access permissions.  Before this can be done the 
existing accounts must be deleted from the Portal database logins. 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio.  

2. Locate and expand the Portal database. A list of folders is displayed. 

3. Expand the Portal > Security > Users folder. A list of database logins is 
displayed. 

4. Right click and Delete any occurrences of the NETWORK SERVICE account 
for all remote web servers in the deployment. Do not delete the entry for the 
NETWORK SERVICE account for the local machine (NT AUTHORITY\ 
NETWORK SERVICE). For remote web server machines  in the deployment 
the NETWORK SERVICE logins will be of the form 
<DOMAIN>\<WEBSERVER MACHINE NAME>$. For example 
CISCO\WEBSERVERA$ if your webserver is called WEBSERVERA and 
belongs to the CISCO domain. 

5. Expand the Security folder. A list of folders is displayed. 

6. Right Click the Logins folder and select New Login 

7. Ensure the Windows authentication option is selected and enter the NT 
AUTHORITY\NETWORK SERVICE account for the Side A webserver  in the 
form <DOMAIN>\<WEBSERVER MACHINE NAME>$. 

8. Click User Mapping in the Select a page panel. 

9. Check the Portal database in the Users mapped to this login pane. Ensure that 
the User column correctly contains the Network Service account for the web 
server. 

10. Check the portalapp_ role, portalrs_role and portalreporting_role in the 
Database Role Membership pane. 
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11. Click OK. 

12. Repeat steps6 to 11 to add the NT AUTHORITY\NETWORK SERVICE 
account for each web server in the deployment. 

Repeat these steps on the Side B database server to re-add the Web Server Network 
Service database logins there. 

Install New Unified CCMP Components and Upgrade Portal 
Database 

This section describes how to install the new Unified CCMP components and install 
the portal database for this release of Unified CCMP. 

Running the Unified CCMP Installer 
1. Insert the Unified CCMP DVD. If auto-run is enabled on the server, a window 

opens automatically showing a list of Unified CCMP components under the 
heading ‘Server Installation’ on the left hand side.  

 

 

If auto-run is disabled and you do not see the Installation Components screen, 
double-click the autorun.bat file located on the DVD to launch the Unified CCMP 
installer manually. 

  

If UAC has not been disabled, launch the installation manually by right-clicking on 
the autorun.bat file located on the DVD and selecting run as administrator option. 

 

Some anti-virus software may state that the autorun.hta script file is malicious. 
Please ignore and continue with the installation. 

2. Follow the steps in the sections below to install each component, but read the 
information about prerequisites in the rest of this section first.  

Before you can install a Unified CCMP component, the prerequisites for that 
component must be present. The Unified CCMP Installer checks the prerequisites for 
each component as follows:  
• When you click on a component to install it, the installer displays a list of 

prerequisites for that component and checks that each prerequisite is present. As 
each prerequisite check completes, you will see a green tick (check successful) or 
a red cross (check failed). The Install option for that component is only available 
when all prerequisite checks are successful. 

• Where possible, the Unified CCMP DVD includes redistributable packages for 
prerequisites, so if a prerequisite check fails, you can click on the link in the 
Unified CCMP installer to install the missing prerequisite. Once all the 
prerequisite software is installed, you can click on the component again, then 
click Rerun to rerun the tests. 
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• When all the prerequisites display a green tick, you will be able to click Install to 
install the chosen component. 

Install the Unified CCMP Database Installer 
This process does not upgrade the database directly. It just installs the Database 
Installer which is then used to upgrade the database. On the Side A Database Server: 

1. To install the Unified CCMP Database Installer, in the Unified CCMP Installer, 
select Database Server, and wait until the prerequisite checks have completed. 
If any checks fail, fix them as described above. When all checks have passed, 
click Install to begin the Database Server Installation. The Setup window 
displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting. 

4. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 

5. In the Configure Database window: 
• Database Name Enter the name of the database catalog for Unified CCMP. 

By default this is Portal. 
• Connect Using Select the login credentials you want to use: 

• Windows Authentication Credentials of Application This is the 
recommended option 

• SQL Server Authentication using the login and password below This 
option should only be selected if you are using a database catalog on a 
different domain. For this option you must enter your SQL Server Login 
Name and Password in the fields provided. 

• Click Next. 
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6. In the Destination Folder window, you can click Change to change the location 
that the Database Server component is installed to. It is not necessary to install 
all Unified CCMP components to the same location. 

7. Click Install to install the Database Installer.  
 

 

During the Database Install Tool Installation, the J2SE pre-requisite will be 
automatically installed if it is not already present.  A Security Alert dialog box stating 
that ‘Revocation Information for the security certificate for this site is not available’ 
may be displayed in some circumstances. If this dialog box appears click Yes to 
continue. 

8. When the installation has completed, to upgrade your database immediately after 
installing the Database Installer, select the Launch Database Management 
Utility check box at the end of the installation before clicking Finish  

9. Click Finish. 

Repeat the steps above to install the Database Installer process on the Side B 
Database Server. 

Install the Unified CCMP Portal Database 
Once the Database Installer is installed, it can be used to install the new Unified 
CCMP database. 

On the Side A Database Server: 

1. If you selected the Launch Database Management Utility check box when you 
installed the Database Installer, the Database Installer launches automatically 
after it has been installed. Otherwise, launch the Database Installer manually 
from Start > All Programs > Management Portal > Database > Database 
Installer. The Database Installer is a wizard which guides you through the steps 
to upgrade the database.  

2. Click Next to begin the install process.  

3. In the Database Setup Window choose Install a New Database. Click Next to 
continue. 

4. In the SQL Server Connection Details window, take the following actions: 
• Server Name - select the Microsoft SQL Server where the Unified CCMP 

database is located. In this case this is the machine running the application, 
and so it must be left as the default (local). 

• Database Name - enter or select the name of the database catalog that was 
originally used for Unified CCMP. 

• Connect Using - select the login credentials you want to use: 
• The Windows account information you use to log in to your 

computer. This is the recommended option. 
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• The Microsoft SQL Server login information assigned by the system 
administrator. Only select this option if you are using a database 
catalog on a different domain. For this option you must enter your Login 
Name and Password in the fields provided. 

• Test Connection – click to make sure the connection to the Microsoft SQL 
Server is established. If you see the message ‘Connection succeeded but 
database does not exist’ then you must rectify this problem before 
continuing. Check that the database catalog name and security credentials are 
correct.  

• When the database connection details have been tested and the connection is 
successful, click OK to continue. 

5. In Select an Action to Perform window select Install a new database.  

6. In the Setup Replication window for the Side A database server leave the 
Replicated Configuration checkbox unchecked and click Next. But when 
installing the database on the Side B database server, take the following actions: 
• Replicated Configuration Check this box when installing the database on 

the Side B database server.  The Share Name and Folder Path text boxes will 
become active. 

• Share Name Enter the name of the share for the ReplData folder. By default 
this is ReplData. 

• Folder Path Enter the path of the ReplData folder. This is configured in 
Microsoft SQL Server. 

7. The fields on the Configure the Location of Data Files window only need to be 
amended if you want to customize the size and location of the database files, 
otherwise click Next. 

8. The Configure SQL Server Agent Service Identity window sets up a user 
account that is used by Microsoft SQL Server for replication: 
• Account Type The type of user account that will be used. For a distributed 

installation, this must be Domain. 
• User Name The name of the user account. This defaults to sql_agent_user. 

If you used a different name when setting up the account, enter that name 
instead. For a domain user include the domain information so the name is of 
the form <DOMAIN>\sql_agent_user.  For example if the SQL agent user 
belongs to the UCCMPDOM domain then enter 
UCCMPDOM\sql_agent_user. 

• Automatically create the user account if missing For a single-sided 
system, it is possible to create the required user automatically. For all other 
systems, you must set up the required account manually. If you have not 
already created the user account, set it up now before continuing. 

• Password Enter the password of the sql_agent_user account. 
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• Confirm Password You are unable to continue until the contents of this 
field are identical to the passphrase entered above. 

9. In the Web Application Servers Network Service Configuration window, 
enter the details of each Web Server, from both sides, to be used in the 
installation: 
• Domain The network domain the web server resides; for example, 

UCCMPDOM. 
• Machine Name The name of the machine; for example, WEBSERVERA. 
• Note: The database installer will use this information to grant access for the 

Network Service accounts on these web servers to the Portal database.  If you 
need to add a new Web Server after the database has been installed you will 
need to grant permissions manually. For information on how to add these 
permissions manually, refer to Chapter 13 for details. 

10. Click Add to add each Web Server to the list. 

11. When all Web Servers have been added, click Next to begin installation. 
Installation will take several minutes. 

12. Click Close to close the installer. 

13. For dual-sided systems repeat the steps above on the Side B database server, 
noting the different options that need to be selected.  

Restore the Portal Database Backup 
Now that the Unified CCMP database is installed, the backup of the existing Portal 
database can be restored. 

The Portal databases must now be restored from the backups made earlier. 

On the new Side A database server: 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > Management 
Studio. 

2. Right Click the Portal database and Click Tasks > Restore > Database. 

3. In the Restore Database window choose From Device and Add the location of 
the portal back up file from the same side database server.  You may need to 
copy the backup file to a local file in order to access it. 

4. Select the backup file to restore the Portal database from and click OK. 

5. Select the check box next to the backup set you just added 

6. Select the Portal database as the restore destination from the To Database drop-
down list. 
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7. Select Options and choose Overwrite the existing database. The Restore 
Database dialog box is displayed, showing the database file names and the 
locations they will be restored to. 

8. The database file group names have changed, so you need to change the names 
in the Restore As column to use the new names. For each entry in the list of files 
that will be restored: 
• in the Restore Database dialog box, select the ellipsis at the end of the row 
• navigate to the folder where the portal database files were installed during the 

database installation (the default is <program_drive>\Program 
Files\Microsoft SQL 
Server\MSSQL10_50.MSSQLSERVER\MSSQL\Data) 

• refer to the table below and find the corresponding original file name and the 
revised file name to be used when the file is restored 

• locate the revised file in the folder tree and select it. 
 

Original File Name Restore As Change Required 

Portal Portal.mdf No Change 

SUMGROUP Portal_sum.ndf Change required 

SUMINDEXGROUP Portal_sum_idx.ndf Change required 

FCTGROUP Portal_fct.ndf Change required 

FCTINDEXGROUP Porgal_fct_idx.ndf Change required 

DIMGROUP Portal_dim.ndf Change required 

DIMINDEXGROUP Portal_dim_idx.ndf Change required 

SECGROUP Portal_sec.ndf Change required 

SECINDEXGROUP Portal_sec_idx.ndf Change Required 

STGGROUP Portal_stg.ndf Change Required 

STGINDEXGROUP Portal_stg.idx.ndf Change Required 

ADMGROUP Portal_adm.ndf Change Required 

ADMINDEXGROUP Portal_adm_idx.ndf Change Required 

PortalLog Portal.ldf No Change 

9. Click OK to start the restore. 
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10. For dual-sided systems repeat the process on Side B to restore the Side B portal 
database backup to the new Side B database server. 

Upgrade the Portal Database 
The Portal databases must be upgraded to bring them up to the required version to 
operate correctly with Unified CCMP 9.0(x). 

On the Side A Database Server: 

1. Click Start > All Programs > Management Portal > Database > Database 
Installer.  The Database Installer Wizard Displays. Click  Next to go through 
each window in turn  

2. In Select an Action to Perform window select Upgrade an existing database 
and click Next. 

3. In the SQL Server Connection Details window: 
• Server Name Select the Microsoft SQL Server where the Unified CCMP 

database is installed. In this case this is the machine running the application, 
and so it must be left as the default (local). 

• Database Name Enter or select the name of the database catalog that is used 
for Unified CCMP (Portal). 

• Connect Using Select the login credentials you want to use: 
• The Windows account information you use to logon to your computer. 

This is the recommended option. 
• The Microsoft SQL Server login information assigned by the system 

administrator. Only select this option if you are using a database catalog 
on a different domain. For this option you must enter your Login Name 
and Password in the fields provided. 

• Test Connection – click to make sure the connection to the Microsoft 
SQL Server is established. If you see the message ‘Connection succeeded 
but database does not exist’ then you must rectify this problem before 
continuing. Check that the database catalog name and security 
credentials are correct.  

• When the database connection details have been tested and the 
connection is successful, click OK to continue. 

4. Click Next to perform the upgrade. 

5. When the upgrade completes, click Close to close the Database Installer Wizard.  

6. For a dual-sided system repeat the process on the Side B database server to 
upgrade the Side B Portal database.  

Install the Unified CCMP App/Web Server 
Install the new App/Web Server components on the A Side App/Web Server.  



Chapter 11: Upgrade From Version 8.5(1) or Earlier  
Install New Unified CCMP Components and Upgrade Portal Database  

 

    

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal     
March 2013 (Updated 22 May 2013)  163   

 

1. To install the Unified CCMP App/Web component, in the Unified CCMP 
Installer, select App/Web Server, wait until the prerequisite checks have 
completed and click Install. The Management Portal: Application Server 
Component window displays. 

2. Click Next to go through each window in turn. You will need to enter the 
following details: 

3. If the Management Portal: Application Server Components Dialog is displayed, 
click Install to install the additional required components. 

4. If the Microsoft .NET 4.5 Framework pre-requisite is missing, it will be installed 
at this point. Click Install to install the component and follow the on screen 
instructions. When the .NET 4.5 Framework is complete, restart the server to 
continue the installation of the App/Web Server. 

5. In the License Agreement window: 
• I accept the terms in the license agreement You must select this option 

before you can continue. In doing so you agree to be bound by the terms in 
the license agreement, and so you should read it thoroughly before accepting 

6. In the Cryptography Configuration window: 
• Passphrase Enter the cryptographic passphrase you created during 

installation of the Database Server component when you first installed 
Unified CCMP. If you continue installation with a new passphrase, you will 
be unable to access your existing data. 

• Confirm Passphrase You will not be able to continue until the contents of 
this field are identical to the passphrase entered above. 

 

 

You must use the same cryptographic passphrase as was originally used when 
Unified CCMP was first installed. If you do not know the cryptographic passphrase, 
stop the installation immediately and contact your vendor. If you continue the 
installation with a new passphrase you will be unable to access your existing data. 

7. In the Destination Folder window, you can click Change to change the location 
that the App/Web Server components are installed to. 

8. In the Configure Database window: 
• SQLServer Name Enter the name of the machine that is to be the Database 

Server. The default of localhost is valid only when installing on the Database 
Server. Enter the name of the side A database server when installing the side 
A App/Web Server Components and enter the name of the side B database 
server when installing the side B App/Web Server Components. 

• Catalog Name Enter or select the name you selected while installing the 
Database Server component. By default this is Portal. 

• Connect Using Select the login credentials you want to use: 
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• Windows authentication This is the recommended option. 
• The SQL Server authentication This option should only be selected if 

you are using a database catalog on a different domain. For this option 
you must enter your SQL Server Login Name and Password in the fields 
provided. 

9. Click Install. 

10. When the installation has completed, click Finish. 
 

 

The machine will restart once the installation is complete.  

Repeat the steps above on the B side App/Web server. 

Unified CCMP Configuration 
After the database has been upgraded and the Unified CCMP 9.0(x) components have 
been installed, the following configuration updates must be made. 

Restore Unified CCMP Database Replication 
If you are upgrading a dual-sided environment you must reinstate replication between 
the Side A and Side B databases. Replication between the Portal databases is set up 
and monitored using the Replication Manager application which is available in the 
Unified CCMP Integrated Configuration Environment (ICE) tool. 
 

 

The user running the Unified CCMP Replication Manager must have administrator 
permissions in both Windows and SQL Server, for both the targeted publisher and 
subscriber servers. 

 

Always run Replication Manger on the Unified CCMP publisher database server. 

To restore replication: 

1. Go to Start > All Programs > Management Portal > Configuration Tools > 
Integrated Configuration Environment. 

2. The Database Connection window is displayed. In this window, set: 
• Server Name This option defaults to the current machine. 
• Database Name Select the Unified CCMP database that was installed when 

setting up the Database Component. If you accepted the default value, this 
will be Portal. 

• Authentication Select Windows Authentication. 
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3. Click OK to open Unified CCMP Integrated Configuration Environment. 

4. The Cluster Configuration tool is open by default. From the Tool drop-down 
list select Replication Manager. 

5. Click the Setup tab to see the replication setup details and to configure or 
disable replication. Details of the displayed fields are contained in the 
Configuring Replication section of Chapter 5 of this document. 

6. The values used when replication was first set-up are displayed. Verify that the 
Distributor Properties Data Folder and Log Folder reflect the current data 
directory for SQL Server. 

 

 

In most cases the recommended defaults are valid and should be used. 

7. Click Configure to start the replication configuration process. Progress 
messages will be logged into the Replication Output window informing you of 
the steps being performed as the database is replicated. 

8. You may be prompted to save pending changes to the database before 
continuing. If so, click Yes to save pending changes and continue. 

 

After you click Configure, it may take several minutes to set up replication. Once 
replication has been set up, the Replication Manager will display the Monitor tab. 

Confirm Replication is Working 
The Monitor tab allows you to monitor the general health of SQL Server Replication 
between Unified CCMP databases. 

To confirm that replication is working: 

1. In the Replication Manager, click the Monitor tab. 

2. In the top left hand pane, select the [Portal]:BaseSubWin publication. 

3. In the bottom right hand pane (called Actions in selected session), look for a 
message that starts “Delivered snapshot from . . . )”. When you see this message, 
replication is working correctly. 

4. Close the ICE tool. 

Configure the Windows Firewall for UCCE Provisioning 
 

 

By default the Windows Server 2008 R2 Firewall will not allow incoming traffic for 
Unified CCMP.  If the Windows firewall is on, create a rule to allow inbound TCP 
traffic for Unified CCMP to communicate with each configured UCCE. 
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This should be done for the Local Registry Port and Local Port stored for each 
Unified ICM server. 

Steps for adding a firewall rule are described in the Configure Windows Server 2008 
R2 Firewall for SQL Server section of Chapter 3. 

Restarting the Unified CCMP Services 
Following an upgrade it is good practice to restart all Unified CCMP services. 

To restart a service: 

1. Click Start > Run 

2. Enter Services.msc and then click OK. 

3. If the service is in the Started state, right click the service name and click 
Restart. If a service is not started, right-click the service name and click Start. 

All UCCMP services on all Database and App/Web Servers should be restarted. 
 

 

After starting the System Monitoring Service and Application Service on the web 
servers, you will need to wait a few minutes before logging in to allow the services 
to load completely. 

12. Uninstalling Unified CCMP 
This chapter describes how to remove the Unified CCMP components from the 
platform. The uninstallation procedure should be performed in the following order: 

Uninstalling Database Components 
This process will remove the database components. This removes the ability to 
import and provision data between remote data sources (such as Unified CCE or 
Unified CM) and the Unified CCMP Database. 

Removing Database Replication 
If you have a dual-sided installation then you must remove database replication 
before removing the database components. 
 

 

Removing database replication may take some time. 

Before removing database replication: 
• Ensure that you are logged in as a domain level user with administrative rights on 

both database servers. 
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• Ensure that the database is in a consistent state 
• Stop all Unified CCMP Services on all servers. 

To disable replication: 

1. Click Start > All Programs > Management Portal> Configuration Tools > 
Integrated Configuration Environment. 

2. In the Tools drop-down, select Replication Manager. The Replication Manager 
tool is displayed. 

3. Select the Setup tab. 

4. Click Disable. 

Once replication is disabled you can uninstall the database components as described 
in the next section. 

Uninstalling Database Components 
To uninstall the database components: 

1. Click Start > Control Panel > Uninstall a program. 

2. Select Management Portal: Database Components. 

3. Click Uninstall. 
 

 

Uninstalling the database components does not remove the Unified CCMP database 
catalog. 

Removing the Database Catalog 
 

 

Do not remove the database catalog from your system unless you intend to 
permanently remove Unified CCMP, or you have been instructed to do so by support 
personnel. 

To remove the Unified CCMP database catalog, you will need to use SQL Server 
Management Studio, as follows: 

1. Click Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server 
Management Studio 

2. Connect to the local database server. 

3. In the Object Explorer pane, expand the Databases node, navigate to the Unified 
CCMP database (the default name is Portal), right click it and select Delete. 

4. The Delete Database window displays. 

5. Select the Close existing connections check box. 
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6. Click OK. 

This permanently removes the database catalog.  

Uninstalling Other Components 
All the other Unified CCMP components may be uninstalled by clicking Remove 
from Add/Remove Programs.  
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13. Troubleshooting 

Installer Logs 
Unified CCMP installers are launched with logging enabled. Install logs may be 
located at C:\InstallLogs for both the Database and App/Web Server installers. 

Adding a New Web Server after the Database has been Installed 
If you need to recover or expand your system, you may need to install a new web 
server. Under normal installation conditions the details of the web server are known 
at install time and can be provided during the database installation so that suitable 
permissions for access to the database from the web server’s Network Service 
account can be applied by the installer. Adding a web server to the cluster at a later 
date requires permissions to be set up manually for the Web Server’s Network 
Service Account on the Portal database.  

To add permissions for the new Web Server’s Network Service Account on the Portal 
database: 

1. Using the SQL Server Management Studio connect to the Portal database, 
right-click on the Security folder beneath the server instance in the Object 
Explorer pane and select New > Login. 

2. Enter the name of the machine in the Login Name field in the 
<DOMAIN>\<MACHINENAME$> form. 

3. Click OK. 

4. Right-click on the Security folder beneath the Portal database and select New > 
User. 

5. Enter the name of the machine in the User Name field in the 
<DOMAIN>\<MACHINENAME$> form. 

6. Enter the name of the login created in Step 2 in the Login Name field or select it 
using the Explore dialog box. 

7. Select the following roles in the Database Role Membership list: 
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• db_datareader 
• db_datawriter 
• db_ddladmin 
• db_securityadmin 
• portalapp_role 
• portalreporting_role 
• portalrs_role  

8. Click OK. 

9.  
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