
 

MATE Design Tutorials
Release 6.1 
February 2015
Cisco Systems, Inc. 
www.cisco.com

Cisco has more than 200 offices worldwide.  
Addresses, phone numbers, and fax numbers  
are listed on the Cisco website at  
www.cisco.com/go/offices.

Text Part Number:   

http://www.cisco.com
http://www.cisco.com/go/offices


 

THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL 
STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT 
WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT 
SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE 
OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB’s public 
domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California. 

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED “AS IS” WITH 
ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT 
LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF 
DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, 
WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO 
OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this 
URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership 
relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display 
output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in 
illustrative content is unintentional and coincidental.

© 2015 Cisco Systems, Inc. All rights reserved.

http://www.cisco.com/go/trademarks


  

 

C O N T E N T S
Overview      1-1

Related Topics     1-1

Get Started with MATE Design     2-1

Launch MATE Design and a Open Plan File     2-1

View Network, Site, and Interface Plots     2-2

Work with Tables and Object Selections     2-4

Change Circuit Capacity Width     2-5

Determine Traffic Utilization     2-6

Most Highly Utilized Interface     2-9

Simulate Traffic Using Demands     2-10

Modify Demand Traffic     2-13

Edit Topology     2-15

Get Started with Simulation Analysis     3-1

Failures     3-1

SRLGs Failures     3-2

Simulation Analysis     3-3

Worst-Case Failure Analysis     3-5

Failure Impact Analysis     3-8
i
MATE Design Tutorials



 

Contents
ii
MATE Design Tutorials

  



C H A P T E R 1

Overview 

These tutorials take you through the MATE GUI in a structured way so that you quickly get an overview 
of the user interface, including the basics of failure simulations. 

Get Started with MATE Design—Introduces you to the basic elements of the GUI, such as how to 
manipulate plot views and display objects, and how to use the basic controls and menus. Additionally, 
this tutorial shows you the basics of how to modify simulated traffic (demands). 

Get Started with Simulation Analysis—Demonstrates how to generate failure scenarios and how to 
examine your network for component failure vulnerabilities. 

Related Topics
 • MATE Design User Guide 

 • MATE GUI Visualization Guide 

 • MATE Integration and Development Guide 

 • Sample plan files are in $CARIDEN_HOME/samples, where $CARIDEN_HOME is the directory containing 
the MATE software (on Linux, the default is /opt/cariden/software/mate/current)
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C H A P T E R 2

Get Started with MATE Design

This tutorial introduces you to the MATE GUI, which operates on plan files, or plans, that contain the 
components of information that display the network. In this tutorial, you use sample plan files that come 
with the MATE product. Topics include the following. 

 • MATE GUI display and behavior, including network plot, toolbars, tables, selection methods, and 
shortcuts.

 • Customizing displays for circuit capacities and traffic utilizations. 

 • Traffic demands, which are the foundation for network modeling and simulation in MATE Design.

Note MATE Design works on both measured and simulated traffic. Traffic is simulated through demands 
(which are explained in the Simulate Traffic Using Demands section). Unless otherwise noted, the 
instructions and diagrams are for simulated traffic. 

Launch MATE Design and a Open Plan File

Note Throughout this tutorial, $CARIDEN_HOME is the directory in which the MATE software is installed. The 
Linux default $CARIDEN_HOME is /opt/cariden/software/mate/current.

To view the network topology and perform MATE Design operations, you must open a plan file. To use 
MATE Design effectively, it is helpful to understand the main GUI components.

Task: Launch MATE Design, open a plan file, and develop a basic understanding of the GUI.

Step 1 Double-click the mate icon in the $CARIDEN_HOME directory, which is the directory in which MATE 
Design is installed. 

Step 2 If a license message is displayed, click OK to continue since you do not need a license to use the sample 
plans.

Step 3 Select the File->Open menu.

Step 4 Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt file, which is a sample 
European network. 

Step 5 Locate each of the following GUI components (Figure 2-1).

 • Menus—Menu selections for network modeling, simulation, and optimization.
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Chapter 2      Get Started with MATE Design 
View Network, Site, and Interface Plots
 • Visualization toolbar—Drop-down lists and icons that control how the network is displayed. 

 • Network plot—Displays a visual representation of the network topology.

 • Tables—Display network properties, including both measured and simulated information, for the 
network plan. 

 • Context menus—Enable you to right-click anywhere in the plots or tables to view a list of actions 
that you can take. 

Step 6 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Figure 2-1 Main Components of MATE GUI

View Network, Site, and Interface Plots
Upon opening the plan file used in this tutorial, the network plot shows sites (square icons) that appear 
to be connected by circuits, though they actually connect to nodes (routers) within each site. The nodes 
within the sites are connected with intrasite circuits. Each circuit consists of two interfaces that are 
delineated by the line in the middle of the circuit.

Note that sites can also contain other sites, and nodes do not have to be contained within sites.

Task: View network, site, and interface plots. 

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.
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Chapter 2      Get Started with MATE Design
View Network, Site, and Interface Plots
Step 2 In the network plot (Figure 2-2), notice the four sites. These are connected by 622 Mbps (OC12/STM4) 
circuits. LON and AMS are connected by two such circuits. This information is listed in the Capacity 
Sim column of the Interfaces table.

Figure 2-2 Network Plot of Sample European Plan File 

Step 3 Open a site plot. 

a. Double-click on the LON site to see its 
details. Notice that the LON site contains 
three nodes connected by intrasite 
circuits.

b. Click each of the outbound interfaces and 
notice the selection (blue highlight) of the 
same interface in the network plot.

c. Close the site plot by clicking on the top, 
right X.

Step 4 Open an interface plot.

a. Click the orange interface coming out of LON and going towards AMS. 

b. Press and hold the Ctrl key (Cmd on Mac) while selecting the green interfacing coming out of LON 
going towards PAR. Both interfaces are now selected.

c. Right-click on either of these interfaces and select Plot Interfaces from the context menu. An 
interface plot appears (Figure 2-3).

d. Click in an ow plot area to deselect them from both the interface and the network plots. 

Now click on each of the interfaces in the interface plot and notice that they are selected in the 
network plot.
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Chapter 2      Get Started with MATE Design 
View Network, Site, and Interface Plots
e. Close the interface plot by clicking on the top, right X.

Step 5 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Figure 2-3 Interface Plot

Work with Tables and Object Selections
This section familiarizes you with the basic dynamics between tables and objects, such as nodes, sites, 
circuits, interfaces, and ports. When you select an object in a table, it is automatically selected in the 
network plot. Conversely, whatever you select in the network plot is selected in the tables. 

Task: Show different tables and select objects. Each time you make a selection, observe what happens 
in the tables and in the network plot to see their relationships.

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 Notice that the Interfaces tab is selected. Click on the Sites tab to show the Sites table.

Step 3 In the network plot, click on various sites, and each time notice the blue highlight in the left column of 
the Sites table. Also notice that each time you select a new site, the other is no longer selected. This is 
because selecting an individual object deselects all others.

Step 4 Show the Circuits table, which is not in the default table tabs.

a. Right-click on any of the table tabs and select Show/Hide Tables from the context menu.

b. Click on the empty F (false) box on the Circuits row to turn this F to T (true).

c. Click OK. The Circuits table tab appears.

d. Click on the Circuits tab to show the Circuits table.

Step 5 In the Circuits table, select on the PAR-LON circuit. Press and hold Ctrl (Cmd on Mac) while clicking 
on the AMS-FRA circuit. Notice that both rows are highlighted as are the corresponding circuits in the 
network plot. 
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Chapter 2      Get Started with MATE Design
Change Circuit Capacity Width
This selects four interfaces, which is two interfaces per circuit. To verify these selections, in the Circuits 
table right-click on either of the two selected circuits, and select Filter to Interfaces from the context 
menu. The Interfaces table shows the four interfaces that are selected in the network plot.

Step 6 In the Interfaces table, click the Show All button.

Step 7 Click the top row of the Interfaces table. Press and hold Shift while clicking on the fourth row. All four 
interfaces are selected both in the table and in the plot. Two of these interfaces are intrasite as indicated 
by the small square appearing on top of the AMS site. 

a. Double-click on the AMS site to see the selected interface. 

b. Close the site plot by clicking on the top, right X. 

c. Click in an empty plot area to deselect the interfaces.

Step 8 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Change Circuit Capacity Width
Circuits are drawn to show the relationship of their capacity to their utilization. By default, the width of 
the circuit is proportional to the capacity, down to a predefined minimum width, and the interfaces 
appear without explanatory text. The Plot Options icon opens a dialog box where you can change the 
relationship between width and capacity, and control the minimum width and rate at which the width 
changes for different capacities.

Task: Change the relationship between circuits’ width and their capacity.

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 Click the Plot Options icon in the top, right of the visualization toolbar; a Plot Options dialog box 
appears.
2-5
MATE Design Tutorials

  



 

Chapter 2      Get Started with MATE Design 
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Step 3 In the Design Circuits tab, change the value in the “Circuits set to min width for capacity below” field 
from 580 to 50, and click OK.

Step 4 Notice that all circuits are wider than the minimum now because their capacities all exceed 50 Mbps. 
Notice how much wider the circuits are now.

Step 5 Double-click on the LON site to open its site plot. Notice that some circuits show at the minimum width 
with no fill color; this is because these circuits do not have a specified capacity.

Step 6 Re-open the Plot Options dialog box and change the setting back to the default of 580, and press OK.

Step 7 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Determine Traffic Utilization
MATE Design shows either measured network traffic or simulated traffic, depending on the view. The 
color fill of an interface shows the bandwidth utilization for traffic leaving that interface in proportion 
to the interface capacity. That is, it shows the traffic utilization.

The exact utilization of any circuit is listed in the tables where all the quantitative parameters of the 
network are available. The colors and thresholds are fully customizable from the Utilization Color menu.

Task: Determine the traffic utilization threshold using color fills, Util Sim column, and textual 
representations.

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 Select the green drop-down list in the Utilization Color menu. The range indicates that if an interface is 
green, its traffic utilization is between 30-50%.
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Determine Traffic Utilization
Step 3 In the network plot, select the green part of the circuit between LON and PAR. Right-click on this same 
interface and select Filter to Selection from the context menu. The Interfaces table opens and shows only 
this interface.

Step 4 Note that the Util Sim (simulated) column shows a utilization of 47.75% for this interface, which is 
between the 30-50% level denoted by green as shown in the Utilization Color drop-down menu 
(Figure 2-4). The interface is filled with green that extends to fill almost half of this interface. The other 
half of the circuit displays the traffic utilization for the reverse direction, which is 0% for this interface.

Step 5 In the Interfaces table, click the Show All button.

Step 6 Identify the percentages by displaying them on all interfaces.

a. Click on the Plot Options icon; the Plot Options dialog box appears.

b. In the Design Circuits tab, Interface Text list, select “Percentage of interface filled.”

c. Click OK. The interfaces now show the numeric utilization percentage (Figure 2-5).

Compare these numbers to those in the Util Sim column to see they are the same.

d. Re-open the Plot Options dialog box, change the Interface Text back to None, and click OK.

Step 7 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.
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Figure 2-4 Traffic Utilization on cr1.lon-cr1.par Interface

Figure 2-5 Traffic Utilization in Text Format
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Determine Traffic Utilization
Most Highly Utilized Interface
There are two ways to identify the most utilized interfaces, which is useful when analyzing large, 
complex networks.

Task: Determine the most highly utilized interfaces in the network using each of the following methods.

Method: Sort Util Sim Column

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 In the Interfaces table, click on the Util Sim column heading to sort the interfaces by descending order. 
Click it two more times to notice this is a toggle for sorting columns between ascending and descending 
order. 

Step 3 Notice that the most utilized interface is at 87.06% of capacity, which is the top row. Select this top row. 
The interface highlighted in the plot is the most highly utilized interface.

Step 4 Use the down arrow to move downward row to row, each time finding the next most highly utilized 
interface. Each selection is highlighted in the plot and its exact utilization value is visible in the Util Sim 
column of the selected row. 

Step 5 Click in an empty plot area to deselect the interfaces.

Method: Select Max Value in Utilization Color Menu

Step 1 Select the purple drop-down list in the Utilization Color menu to see that the maximum utilization value 
is 100%. Select Max. This resets the maximum threshold percentage to the most highly utilized interface, 
which color fills that interface, cr2.lon-cr1.ams, to purple. 

Step 2 Select the purple drop-down list again to see that maximum is now 87.06%. Verify this by reading its 
Util Sim value in the Interfaces table, which is also 87.06% (Figure 2-6). 

Step 3 In this same purple drop-down list, select <87.06%. This highlights the second most highly utilized 
interface, which is cr1.ams-cr2.fra. 
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Chapter 2      Get Started with MATE Design 
Simulate Traffic Using Demands
Step 4 Set the maximum utilization back to 100% by restoring the system default colors.

a. Select the Edit->Plot->Plot Options->Apply System Defaults menu.

b. Select the purple drop-down list again to see that maximum is now 100%.

Step 5 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Figure 2-6 Interface with Highest (Max) Utilization

Simulate Traffic Using Demands
Several MATE Design tables have columns that identify how much traffic is being carried or what 
percentage of the capacity is being utilized. For example, the Interfaces table has a Util Sim column that 
reflects simulated traffic utilization. The two basic inputs to the simulation are the network configuration 
itself and a set of traffic demands. A demand is a request for a specified amount of traffic to be sent from 
one node, the source, to another node, the destination. The routes taken are based on traffic, topology, 
network health, as well as the protocols used.

Task: Determine which service classes are associated with demands, read demand traffic and latency, 
and identify demands route in the network plot.
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Chapter 2      Get Started with MATE Design
Simulate Traffic Using Demands
Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt 
file.

Step 2 Click the Demands tab to show the Demands table. Notice that this network contains only six demands, 
all from the er1.lon edge node in the LON site to the edge notes in other sites.

Step 3 Show the Service Class column (Figure 2-7).

a. Right-click on any heading in the Demands table and select Show/Hide Columns.

b. In the top, right Search field, enter the word “service” and press Enter. The search feature locates 
all columns and column descriptions containing this word. 

c. Click the empty F (false) box on the Service Class row to turn this F to T (true).

d. Click OK. The Service Class column appears.

Figure 2-7 Search for and Show Column Names

Step 4 Click the Service Class column heading to sort demands by service class, noting that half the demands 
represent Internet traffic and half represent voice traffic.

Step 5 Read the Traffic column values to determine how much traffic each demand is attempting to route. 

Step 6 Determine the sum of the delays for all the interfaces on the longest path taken by each demand.

a. In the Demands table, right-click the Maximum Latency column heading to see that its sum value is 
zero.

b. Verify this value by reading the Delay Sim column in the Interfaces table. They, too, are zero. 

1. Select the Interfaces table tab, and then right-click on any of its headings and select Show/Hide Col-
umns.

2. Click the empty F (false) box on the Delay Sim row to turn this F to T (true).
3. Click OK. The Delay Sim column appears.
4. Right-click this Delay Sim column heading to see that its sum value is zero.

Step 7 In the Demands table, select the demand from er1.lon to er1.par. The network plot shows this demand 
from LON to PAR sites using a blue arrow to show the route, an A to show the source, and a Z to show 
the destination (Figure 2-8). 
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Chapter 2      Get Started with MATE Design 
Simulate Traffic Using Demands
Figure 2-8 Single-Path Demand Route

Step 8 Use the up and down arrow keys to move from row to row in the Demands table, highlighting each 
demand and showing its routing in the network. 

Notice the er1.lon to er1.ams demand takes two equal-cost multipath (ECMP) routes along two parallel 
circuits. Two blue lines show 50% of the traffic flowing through each of these circuits (Figure 2-9).

Step 9 Right-click the er1.lon to er1.ams demand, and select Plot Demand from the context menu. This view 
shows the details of the demand route (Figure 2-9).

Step 10 Close the demand plot. 

Step 11 Click in an empty plot area to deselect the demand.

If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.
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Simulate Traffic Using Demands
Figure 2-9 ECMP Demand Route and Associated Demand Plot

Modify Demand Traffic
You can modify demand traffic to determine the effects such changes in traffic have on the network. 
These modifications can be applied to regions or sites, or they can apply uniformly over the network, 
such as in the following task. 

For instance, you might increase demand traffic to plan for future traffic growth by simulating an overall 
traffic growth trend. Another example use might be to determine the network impact of an anticipated 
increase in sales of a particular service, such as video on demand. 

Task: Simulate an increase in voice traffic by 50%.

Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt 
file.

Step 2 Locate all voice demands by filtering to them. 

a. Click the Demands tab to show the Demands table. 

b. Click the Filter control menu; the Filter dialog box appears (Figure 2-10).

c. In the empty field on the Service Class Contains row, enter voice.

d. Click OK. The Demands table shows only three demands representing voice traffic.

e. Notice the values listed in the Traffic column are 63, 89, and 142 Mbps.
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Simulate Traffic Using Demands
Figure 2-10 Filter to Voice Demands

Step 3 Increase the demand traffic for all voice demands by 50% (Figure 2-11).

a. Select all rows that are currently showing in the Demands table by select one demand and then 
pressing Ctrl-A (Cmd-A on Mac).

b. Right-click on any row and select Modify Demand Traffic from the context menu.

c. Enter the value “50” in the “Change traffic by ___ %” field, and click OK.

Figure 2-11 Modify Voice Demand Traffic

Step 4 Click anywhere in the empty plot area to remove the demand selections.
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Step 5 Read the values in the Traffic column and note they have increased by 50% to 94.5, 133.5, and 213 Mbps. 
The plot shows that modifying this traffic created severe congestion between LON and AMS as noted 
by the purple color fill (Figure 2-12). Compare, for example, the color of interfaces between LON and 
AMS to those prior to the simulated traffic increase (Figure 2-8).

Step 6 Select the File->Close menu to close this file without saving it.

Figure 2-12 Voice Demand Traffic Increased by 50%

Edit Topology
MATE Design tools enable you to edit the network topology so that you can add, delete, and move 
objects. Some tools, such the duplication function, can greatly simplify the redesign of a complex 
network. 

Once topology changes are made, demands are rerouted, showing the resulting utilization changes in the 
new network.

Task: Create a new site by duplicating an existing one, place it in its geographically correct location, 
and observe how traffic is rerouted as a result of the topology change. 

Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt 
file.
2-15
MATE Design Tutorials

  



 

Chapter 2      Get Started with MATE Design 
Edit Topology
Step 2 Since you are determining the effect of adding a site, view the demand route before editing the topology. 

a. Click the Demands tab to show the Demands table. 

b. Select the er1.lon-er1.fra demand. Notice that the demand goes from LON (source) through AMS 
and to FRA (destination)

c. Click anywhere in the empty plot to deselect the demand.

Step 3 Create a BRU site by duplicating the AMS site. 

a. Right-click on the AMS site, and select Duplicate from the context menu. 

b. Enter BRU as the name of the new site, and click OK. The new site appears with the same intrasite 
and intersite circuit structure. 

c. Double-click on the new BRU site to see that the nodes have been duplicated from the old site, but 
renamed appropriately. Close this site plot.

d. Right-click on the newly created BRU site, and select Properties from the context menu. The 
Properties dialog box appears (Figure 2-13). The Location was copied as AMS, and the Longitude 
and Latitude fields give the airport location code for AMS.

1. Change the Location field to BRU and press Enter (do not press OK yet). The Location, Longitude, 
and Latitude fields update to show the airport location for Brussels.

2. Click OK. 

Figure 2-13 Duplicate AMS Site and Name it BRU

Step 4 Place the site on the plot using its newly updated geographic location (Figure 2-14). 

a. Click on the Sites table tab to show the Sites table.

b. Click the Show All button.

c. In the Sites table, select one site and then press Ctrl-A (Cmd-A on Mac) to select all the sites.

d. Right-click the plot background, and select Arrange from the context menu.

e. Click the Earth icon. The BRU moves to its proper geographic location. The 
$CARIDEN_HOME/samples/euro4_bru.txt file shows the same network with this change.
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Edit Topology
Figure 2-14 New BRU Site

Step 5 Observe the effect of adding this new site as it reroutes the er1.lon-er1.fra demand. 

a. Click on the Demands tab to show the Demands table. 

b. Select the er1.lon-er1.fra demand (Figure 2-15). Half the traffic now routes through AMS and half 
through BRU.

Step 6 Select the File->Close menu to close the file without saving it.
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Edit Topology
Figure 2-15 Rerouted Demand
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C H A P T E R 3

Get Started with Simulation Analysis

MATE Design Simulation enables you to perform several types of failure analysis, which can be useful 
in long-term planning and short-term maintenance preparation. For instance, MATE Design simulates 
reroutings and changes in traffic utilization under individual failure events, as well as across multiple 
failure scenarios causing worst-case utilizations. This tutorial guides you through a sample of these 
failure analysis tasks.

For more detailed information about simulating and analyzing failures, see the MATE Design User 
Guide.

Failures

Note Throughout this tutorial, $CARIDEN_HOME is the directory in which the MATE software is installed. The 
Linux default $CARIDEN_HOME is /opt/cariden/software/mate/current.

One of the most useful features of MATE Design is its ability to show network behavior when one or 
more objects fail. For example, your network might show utilizations are well under 100% under normal 
operation. But what happens under failure? 

Task: Determine the effects on the network if a single circuit were to fail.

Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the us_wan.txt 
file.

Step 2 Notice all traffic utilization is under 100%. You can tell this in two ways. None of the interfaces are 
purple, which by default means over 100% utilized. The Util Sim column in the Interfaces table shows 
no values over 100.

Step 3 Right-click on the wdc side of the wdc-nyc circuit (cr2.wdc-cr1.nyc interface), and select Filter to 
Demands Through Interfaces->All from the context menu.

Step 4 Select the er1.atl to er1.bos (first) demand to see its route. The solid blue arrow shows the demand path.

Step 5 Right-click on the wdc-nyc circuit and select Fail from the context menu. The red cross appearing on the 
circuit indicates a failure. Notice the difference in traffic utilization colors in the plot. For example, the 
kcy-wdc circuit is now congested. 

Step 6 Notice how the demand has been rerouted. The dashed line shows the current demand path under failure 
(Figure 3-1). Continue clicking on different demands to see how they are rerouted.

Step 7 To restore the failed circuit, right-click on it and select Recover. 
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Failures
Step 8 Click anywhere in an empty plot area to deselect the demand.

Step 9 If continuing with this tutorial, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Figure 3-1 Reroute of Demand Under Circuit Failure

SRLGs Failures
An SRLG (shared-risk link group) is a group of objects that would likely fail due to a common cause. In 
a live network, the most common type of SRLG is one that contains circuits that share a common fiber. 
If the fiber fails, all circuits will fail.

Several MATE Design tools enable you to simulate SRLG behavior, such as Simulation Analysis, which 
can provide a worst-case analysis of utilizations over SRLG failures. Metric Optimization can optimize 
routing over failure scenarios that can include SRLGs. 

Task: Create an SRLG and fail it to observe the consequences to network traffic.

Step 1 If us_wan.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the us_wan.txt file.

Step 2 Create an SRLG.

a. Select the Insert->SRLG menu to open a New SRLG dialog box.

b. Select Circuits from the Object Type list, and click the F on the rows for each of these circuits to set 
them to T (true).

 – cr1.sjc-cr1.kcy

 – cr2.chi-cr1.sjc
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 – cr1.chi-cr2.sea

c. Keep the name created by default (SRLG1), and click OK.

Step 3 Verify the SRLG1 is in the SRLG table. 

Step 4 Right-click on SRLG1 and select Fail from the context menu. Figure 3-2 shows the circuits that belong 
to this SRLG failed and the resulting severe congestion occurring as a result. The red crosses with white 
fill mean these circuits are still active, but are not operational because of other failures.

Step 5 To restore the SRLG, right-click in an empty plot area, and select Recover. 

Step 6 Keep this plan open and continue to the next task. If you are stopping here and plan to continue later, 
select File->Save As and save the plan file to a different location.

Figure 3-2 SRLG Failure

Simulation Analysis
The Simulation Analysis tool simulates network behavior across multiple failure scenarios, multiple 
traffic levels, and over multiple service classes.
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Task: Determine the network repercussions of failing single circuits and SRLGs to their worst-case 
utilizations.

Step 1 This task uses the us_wan.txt file containing the SRLG created and saved in the last section. If it is not 
open, select the File->Open menu, browse to its location to open it.

Step 2 Select the Tools->Simulation Analysis menu. A dialog box appears that allows you to select the set of 
failure scenarios over which the analysis will be run.

Step 3 Select both the Circuits and SRLGs options.

Step 4 Leave all defaults, and click OK. By default, the tool records up to 10 failure scenarios per interface that 
cause the worst-case utilization. 

MATE Design now performs a simulation for each possible circuit failure and each SRLG failure in the 
network, and calculates the utilization for these failure scenarios. The plot shows the resulting 
congestion in the Worst-Case Traffic view, which is located in the upper, left corner of the Visualization 
toolbar (Figure 3-3).

Step 5 Find the interface

Step 6 When all the simulations are complete, a report opens to display the results. 

a. Within this Report window, select the Simulations table from the left navigation pane. Each row in 
the table represents one of the simulations that was performed to construct the analysis. The first 
three columns describe the failure scenario, service class, and traffic level used in the simulation. 
The next two columns show that under none of these scenarios were there any break points in the 
network (there was always complete connectivity in the network), and that all demands were always 
able to be routed. 

b. Notice details are listed by failure. To find which failure scenario causing the highest utilization, 
click the MaxUtil column to sort from highest to lowest.

c. Close the Report window.

Step 7 Keep this plan open for the next task.
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Figure 3-3 Worst-Case Simulation

Worst-Case Failure Analysis
In the Worst-Case Traffic view the interfaces are colored based on their worst-case utilizations over all 
the scenarios specified for the simulation analysis (Figure 3-3). This view is very useful for seeing which 
circuits would become congested under different failure scenarios, and for discovering the cause of their 
worst-case loading on a circuit-by-circuit basis. 

To better understand the meaning of the plot, imagine that for each simulation case (here, each possible 
circuit or SRLG failure) a transparent plot was generated. After all scenarios are run, the plots are placed 
on top of one another and the worst-case utilization for all circuits is displayed in the plot. It is likely 
that different failure scenarios produce the worst-case utilization for different circuits. 

Task: Determine which interface had the worst-case traffic utilization under this failure scenario, and 
determine the failures causing it. 

Step 1 Continue using the us_wan.txt file on which you created an SRLG and ran a worst-case simulation 
analysis. If you are re-opening the file, it must contain the SRLG, and you must perform the previous 
task that runs a simulation analysis to fail circuits and SRLGs to their worst case. 

Step 2 To find the interface with the worst-case utilization over all failure scenarios calculated for this 
simulation analysis, click on the WC Util column heading in the Interfaces table to toggle it to the 
highest-to-lowest sort order. The cr1.lax to cr2.hst interface has the most with 134.34% (Figure 3-3).
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Step 3 Look at the WC Failures column to note which failures result in this worst-case utilization on this 
interface. Here, it is the failure of SRLG1 that is the culprit.

Step 4 Keep this plan open for the next task.

Task: View the failure scenarios that cause the worst-case utilization for the cr1.nyc to cr2.wdc interface 
and simulate one to determine how the network would react to this failure.

Step 1 Continue using the us_wan.txt file on which you ran a worst-case simulation analysis across circuits 
and SRLGs. 

Step 2 In the Interfaces table, right-click on the interface going from node cr1.nyc to cr2.wdc, and select Fail 
to WC from the context menu. The dialog box that appears lists two failures that would cause worst-case 
utilization on this interface. Select the first one, ct{cr1.kcy|{to_cr1.sjc}|cr1.sjc{to_cr1.kcy}}, and click 
OK. 

The plot now shows the effects of this failure scenario, and therefore changes to a Simulated Traffic view 
(Figure 3-4). 

Step 3 To restore the failed circuit, right-click in an empty plot area and select Recover.

Step 4 Keep this plan open for the next task.

Figure 3-4 Fail cr1.nyc-cr2.wdc to a Worst-Case Failure
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Task: View the worst-case information over a subset of the failure set without re-running the analysis.

Step 1 Continue using the us_wan.txt file on which you previously ran a worst-case simulation analysis across 
circuits and SRLGs.

Step 2 Select the Worst-Case Traffic view from the Network Plot View drop-down list (in the top left 
visualization toolbar). 

Step 3 Click the red cross in the top, right of the visualization toolbar. A dialog box appears, allowing you to 
select a subset of the simulated failure scenarios to view. 

Step 4 Deselect the SRLGs option, and click OK.

The network plot changes to reflect utilizations over circuit failures only (Figure 3-5). The WC Util 
column in the Interfaces table changes to show maximum utilizations over circuit failures only. The WC 
Failure column shows only circuit failures resulting in these utilizations. 

Step 5 Keep this plan open for the next task.
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Figure 3-5 Worst-Case Analysis for Circuit Failures Only

Failure Impact Analysis
The Failure Impact view colors each node and circuit to the maximum utilization level that would be 
caused elsewhere in the network if it were to fail. For example, by default red means a circuit is between 
90 to 100% utilized. Thus, a circuit that is red in the Failure Impact view means that if that circuit were 
to fail, it would cause other nodes or circuits to go to 90-100% utilization. This Failure Impact analysis 
is automatically calculated each time you run Simulation Analysis.

Task: View the Failure Impact to note the impact circuit failures would have on the network.

Step 1 Continue using the us_wan.txt file on which you ran a simulation analysis in the previous task on 
circuits only. If you are re-opening the file, you must run a worst-case simulation analysis that fails only 
circuits.

Step 2 Select Failure Impact from the Network Plot View drop-down list in the visualization toolbar.

Step 3 Show the Failure Impact row in the Interfaces table.

a. Right-click on any of the column heading and select Show/Hide Columns from the context menu.

b. Click on the empty F (false) box on the Failure Impact row to turn this F to T (true).

c. Click OK.
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Step 4 Study the plot to determine potential problems for the network should a circuit fail (Figure 3-6).

a. There are 10 interfaces (representing 5 circuits) showing purple in the network plot, but there are 12 
interfaces showing utilization over 100% in the Failure Impact column. (By default, purple indicates 
over 100% utilization.)

Double-click the chi site to see this sixth purple circuit.

 – If any one of these purple circuits were to fail, it would cause another circuit in the network to 
spike to over 100% utilization. 

 – The cr2.lax-cr2.sjc circuit shows red, indicating that if it were to fail, another circuit would 
increase its utilization to 90-100%.

b. Notice the various circuit colors and borders surrounding the sites. If you do not remember what 
each of these colors mean, use the drop-down color utilization lists to find their utilization range.

Step 5 Select the File->Close menu to close the file without saving it.

Figure 3-6 Failure Impact View
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